|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 1/13 Information Library|
- release devices from exclusive use
devfree key [device]...
devfree releases devices from exclusive use. Exclusive use is requested with the command devreserv.
When devfree is invoked with only the key argument, it releases all devices that have been reserved for that key. When called with key and device arguments, devfree releases the specified devices that have been reserved with that key.
The following operands are supported:
Defines device that this command will release from exclusive use. device can be the pathname of the device or the device alias.
Designates the unique key on which the device was reserved.
The following exit values are returned:
Command syntax was incorrect, an invalid option was used, or an internal error occurred.
Device table or device reservation table could not be opened for reading.
Reservation release could not be completely fulfilled because one or more of the devices was not reserved or was not reserved on the specified key.
See attributes(5) for descriptions of the following attributes:
The commands devreserv and devfree are used to manage the availability of devices on a system. These commands do not place any constraints on the access to the device. They serve only as a centralized bookkeeping point for those who wish to use them. Processes that do not use devreserv may concurrently use a device with a process that has reserved that device.