|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 1/13 Information Library|
- check the status of mediator hosts for a given diskset
/usr/sbin/medstat [-q] -s setname
If a specified diskset has been configured for mediators, medstat attempts to contact these hosts to see if they are accessible and returns the results of the communication.
This optional argument disables the printing of informative text. When used with -q, medstat still prints error messages and returns a result code.
Specifies the name of a diskset on which medstat will work.
Example 1 Checking diskset
This example checks the mediator hosts for the selected diskset.
# medstat -s relo-red
The name of the diskset is relo-red. The medstat command prints the status for each mediator host. Additionally, if the mediator quorum is met, either through a ``golden'' mediator host or because half+1 of the mediator hosts respond, the exit code is 0. If the quorum is not met, then the exit code is 1. If no mediator hosts have been configured for the named diskset, the exit code is 2. The status field will contain one of the following values: Unreachable, Bad, Fatal, or Ok, where Unreachable indicates an RPC/communication problem, Bad indicates an error in the mediator data, Fatal indicates any other error condition, and Ok indicates no error conditions.
Contains the mediator data for a host that has been selected as a mediator host.
The following exit values are returned:
An error occurred.
See attributes(5) for descriptions of the following attributes:
metaclear(1M), metadb(1M), metadetach(1M), metahs(1M), metainit(1M), metaoffline(1M), metaonline(1M), metaparam(1M), metareplace(1M), metaroot(1M), metaset(1M), metastat(1M), metasync(1M), metattach(1M), md.cf(4), md.tab(4), mddb.cf(4), meddb(4), mediator(7D)
Sun Cluster documentation, Solaris Volume Manager Administration Guide
This command is designed for use in the high availability product.