|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 1/13 Information Library|
- Solaris system registration utility
regadm auth [-u username] [-p password_file]
regadm register [-q] [-d]
regadm set [-n name] [-v value]
The regadm utility is used by a privileged system administrator to register products on a given Solaris system with My Oracle Support (MOS), and to manage the background auto-registration service that runs at system boot time. Registered products are extracted from the Service Tag Registry (see stclient(1M)) and uploaded to MOS by means of a secure HTTPS connection.
You can use regadm to explicitly register products. In addition, an smf(5) service runs at boot time that attempts to refresh the registration if the product installation base has changed. This service can be administratively enabled or disabled by means of subcommands of regadm. By default, the service is enabled.
The following options are supported:
Dry-run mode. Show the registration information that will be transmitted to MOS but do not perform the actual registration. Output is displayed in XML format.
Used with the authentication subcommand, the -p option specifies a file name containing the password associated with the MOS username (the -u option). This should be a single-line file and it can be immediately removed after running this command.
Quiet mode. Do not show any output during a registration.
Used with the authentication subcommand, the -u option specifies the MOS user name to be associated with registrations of products on a given system.
The subcommands for regadm are as follows:
Each system must be authenticated with valid MOS credentials before its products can be registered. A successful authentication is made persistent and thus only needs to be done once.
Remove all configured authentication and HTTPS connectivity information. This effectively configures an anonymous registration with no HTTP proxy information.
Disable the auto-registration service at system boot time.
Enable the auto-registration service at system boot time.
Displays the current authenticated MOS user name and the network connectivity information needed for HTTPS communication with MOS. If no authentication has yet been done (by means of the auth command), the anonymous account will be displayed.
Registers each product from the Solaris Service Tag registry (see stclient(1M)) with MOS, using the current authentication credentials. If no credentials have been supplied, the registration is performed using an anonymous MOS account.
Configure HTTP proxy information, to be used for HTTPS communication with the MOS backend.
Report the status (enabled/disabled) of the Solaris auto-registration smf(5) service. See the disable and enable subcommands.
Example 1 Authenticating with MOS Interactively
The following command is used to interactively authenticate this system with MOS. You will be prompted for your support username and password.
# regadm auth
Example 2 Authenticating Non-Interactively
This is similar to the interactive example, but specifies the MOS username and password on the command line.
# regadm auth -u "firstname.lastname@example.org" -p mypassword
The file mypassword must contain the MOS password.
Example 3 Setting HTTP Proxy Information
The following command sequence configures an HTTP proxy and port, used for HTTPS communication with the MOS.
# regadm set -n http_proxy -v webcache.example.com # regadm set -n http_proxy_port -v 8080
Example 4 Setting HTTP Proxy Authentication Information
Some HTTP proxies require authentication. This example shows the configuring of a username/password for basic RFC 2617 HTTP authentication. Note that a filename containing the password (mypassword) is specified, not the actual password itself.
# regadm set -n http_proxy_user -v webuser # regadm set -n http_proxy_user_pw -v mypassword
See attributes(5) for descriptions of the following attributes: