|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 1/13 Information Library|
- monitor deltas of integer valued SNMP variables
/usr/sfw/bin/snmpdelta [common options] [-Cf] [-Ct] [-Cs] [-CS] [-Cm] [-CF configfile] [-Cl] [-Cp period] [-CP peaks] [-Ck] [-CT] [-Cv vars/pkt] agent OID [OID]...
The snmpdelta command monitors the specified integer-valued OIDs and reports changes over time.
The operand agent identifies a target SNMP agent, which is instrumented to monitor a given set of objects. At its simplest, the agent specification will consist of a hostname or an IPv4 address. With such an operand, the command attempts communication with the agent, using UDP/IPv4 to port 161 of the given target host. See snmpcmd(1M) for a full list of the possible formats for agent.
The operand OID is an object identifier that uniquely identifies the object type within a MIB. Multiple OIDs can be specified in a single snmpdelta command.
See snmpcmd(1M) for a list of common options. In addition to the common options, snmpdelta supports the options described below.
Do not fix errors and then retry the request. Without this option, if multiple OIDs have been specified for a single request and if the request for one or more of the OIDs fails, snmpdelta will retry the request so that data for OIDs apart from the ones that failed will still be returned. Specifying -Cf tells snmpdelta not to retry a request, even if there are multiple OIDs specified.
Determines time interval from the monitored entity.
Displays a timestamp.
Generates a "sum count" in addition to the individual instance counts. The "sum count" is the total of all the individual deltas for each time period.
Displays the maximum value ever attained.
Tells snmpdelta to read its configuration from the specified file. This option allows the input to be set up in advance rather than having to be specified on the command line.
Tells snmpdelta to write its configuration to files whose names correspond to the MIB instances monitored. For example:
% snmpdelta -c public -v 1 -Cl localhost ifInOctets.1
...will create a file localhost-ifInOctets.1.
Specifies the number of seconds between polling periods. Polling involves sending a request to the agent. The default polling period is one second.
Specifies the reporting period in number of polling periods. If this option is specified, snmpdelta polls the agent peaks number of times before reporting the results. The result reported includes the average value over the reporting period. In addition, the highest polled value within the reporting period is shown.
When the polling period (-Cp) is an increment of 60 seconds and the timestamp is displayed in the output (-Cs), then the default display shows the timestamp in the format hh:mm mm/dd. This option causes the timestamp format to be hh:mm:ss mm/dd (adding seconds).
Display output in tabular form.
Specifies the maximum number of OIDs allowed to be packaged in a single PDU. Multiple PDUs can be created in a single request. The default value of variables per packet is 60. This option is useful if a request response results in an error because the request packet is too big.
Example 1 Obtaining Timestamped Output
The following command uses the -Cs option to timestamp output. This example assumes that there are at least three entries in your ifTable.
% snmpdelta -c public -v 1 -Cs localhost \ IF-MIB::ifInUcastPkts.3 IF-MIB::ifOutUcastPkts.3 [20:15:43 6/14] ifInUcastPkts.3 /1 sec: 158 [20:15:43 6/14] ifOutUcastPkts.3 /1 sec: 158 [20:15:44 6/14] ifInUcastPkts.3 /1 sec: 184 [20:15:44 6/14] ifOutUcastPkts.3 /1 sec: 184 [20:15:45 6/14] ifInUcastPkts.3 /1 sec: 184 [20:15:45 6/14] ifOutUcastPkts.3 /1 sec: 184 [20:15:46 6/14] ifInUcastPkts.3 /1 sec: 158 [20:15:46 6/14] ifOutUcastPkts.3 /1 sec: 158 [20:15:47 6/14] ifInUcastPkts.3 /1 sec: 184 [20:15:47 6/14] ifOutUcastPkts.3 /1 sec: 184 [20:15:48 6/14] ifInUcastPkts.3 /1 sec: 184 [20:15:48 6/14] ifOutUcastPkts.3 /1 sec: 184 [20:15:49 6/14] ifInUcastPkts.3 /1 sec: 158 [20:15:49 6/14] ifOutUcastPkts.3 /1 sec: 158 ^C
Example 2 Displaying Output in Tabular Form
The following command uses the -CT option to format output as a table. This example assumes that there are at least three entries in your ifTable.
% snmpdelta -c public -v 1 -Cs -CT localhost \ IF-MIB:ifInUcastPkts.3 IF-MIB:ifOutcastPkts.3 \ localhost ifInUcastPkts.3 ifOutUcastPkts.3 [20:15:59 6/14] 184.00 184.00 [20:16:00 6/14] 158.00 158.00 [20:16:01 6/14] 184.00 184.00 [20:16:02 6/14] 184.00 184.00 [20:16:03 6/14] 158.00 158.00 [20:16:04 6/14] 184.00 184.00 [20:16:05 6/14] 184.00 184.00 [20:16:06 6/14] 158.00 158.00 ^C
Example 3 Sending Output to a File
The following example uses a number of options. This example assumes that there are at least four entries in your ifTable. Because the -Cl option is specified, the output is sent to a file and not to the screen.
% snmpdelta -c public -v 1 -Ct -Cs -CS -Cm -Cl -Cp 60 -CP 60 \ interlink.sw.net.cmu.edu .18.104.22.168.22.214.171.124.1.16.3 \ .126.96.36.199.188.8.131.52.1.16.4
A usage syntax error. A usage message is displayed. Also used for timeout errors and for cases where an SNMP client session could not be opened.
See attributes(5) for descriptions of the following attributes: