|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 1/13 Information Library|
- obtain and display an SNMP table
/usr/sfw/bin/snmptable [common options] [-Cb] [-CB] [-Cb] [-Ch] [-CH] [-Ci] [-Cf string] [-Cw width] [agent] [table-oid]
The snmptable command is an SNMP application that repeatedly uses the SNMP GETNEXT or GETBULK requests to query for information on a network entity. The operand table-oid must specify an SNMP table. Both numeric and symbolic (string) OIDs are supported.
The operand agent identifies a target SNMP agent that is instrumented to monitor manageable objects. At its simplest, the agent specification consists of a hostname or an IPv4 address. With such an address, the command attempts communication with the agent, using UDP/IPv4 to port 161 of the given target host. See snmpcmd(1M) for a full list of the possible formats for agent.
See snmpcmd(1M) for a list of common options. In addition to the common options, snmptable supports the options described below.
Display only a brief heading. Any common prefix of the table field names is not displayed.
Use only GETNEXT, not GETBULK, requests to retrieve data.
The string string is used to separate table columns. With this option, each table entry is printed in compact form, using only the specified string to separate the columns. This option can be useful if you intend to import the table into a database. Without this option, the table is displayed in vertically aligned columns.
Display only the column headings.
Do not display the column headings or the table name. Only raw data is displayed.
Prepends the index of the entry to all printed lines.
Specifies the width of the lines when the table is printed. If a line is longer than width, lines are truncated to fit within width.
Example 1 Retrieving an SNMP Table
The following commands retrieve two-column SNMP tables.
% snmptable -v 2c -c public localhost at.atTable SNMP table: at.atTable RFC1213-MIB::atTable atIfIndex atPhysAddress atNetAddress 1 8:0:20:20:0:ab 220.127.116.11 % snmptable -v 2c -c public -Cf + localhost at.atTable SNMP table: at.atTable atIfIndex+atPhysAddress+atNetAddress 1+8:0:20:20:0:ab+18.104.22.168
A usage syntax error. A usage message is displayed. Also used for timeout errors.
An error occurred while executing the command. An error message is displayed.
See attributes(5) for descriptions of the following attributes:
The test for table-oid actually specifying a table is not perfect. Note also that the test requires the defining MIB file to be loaded.