|Skip Navigation Links|
|Exit Print View|
|man pages section 4: File Formats Oracle Solaris 10 1/13 Information Library|
- configuration file for LDAP display template routines
The ldaptemplates.conf file contains information used by the LDAP display routines.
Blank lines and lines that start with a hash character ('#') are treated as comments and ignored. Non-comment lines contain one or more tokens. Tokens are separated by white space, and double quotes can be used to include white space inside a token.
The first non-commment line specifies the version of the template information and must contain the token Version followed by an integer version number. For example,
The current version is 1, so the above example is always the correct first line.
The remainder of the file consists of one or more display templates. The first two lines of the display template each contain a single token that specifies singular and plural names for the template in a user-friendly format. For example,
specifies appropriate names for a template designed to display person information.
The next line specifies the name of the icon or similar element that is associated with this template. For example,
The next line is a blank-separated list of template options. "" can be used if no options are desired. Available options are: addable (it is appropriate to allow entries of this type to be added), modrdn (it is appropriate to offer the modify rdn operation), altview (this template is an alternate view of another template). For example,
The next portion of the template is a list of X.500 object classes that is used to determine whether the template should be used to display a given entry. The object class information consists of one or more lines, followed by a terminating line that contains the single token END. Each line contains one or more object class names, all of which must be present in a directory entry. Multiple lines can be used to associate more than one set of object classes with a given template. For example,
emailPerson orgPerson END
means that the template is appropriate for display of emailPerson entries or orgPerson entries.
The next line after the object class list is the name of the attribute to authenticate as to make changes (use "" if it is appropriate to authenticate as the entry itself). For example,
The next line is the default attribute to use when naming a new entry, for example,
The next line is the distinguished name of the default location under which new entries are created. For example,
The next section is a list of rules used to assign default values to new entries. The list should be terminated with a line that contains the single token END. Each line in this section should either begin with the token constant and be followed by the name of the attribute and a constant value to assign, or the line should begin with addersdn followed by the name of an attribute whose value will be the DN of the person who has authenticated to add the entry. For example,
constant associatedDomain XYZ.us addersdn seeAlso END
The last portion of the template is a list of items to display. It consists of one or more lines, followed by a terminating line that contains the single token END. Each line is must begin with the token samerow or the token item
It is assumed that each item appears on a row by itself unless it was preceded by a samerow line (in which case it should be displayed on the same line as the previous item, if possible). Lines that begin with samerow should not have any other tokens on them.
Lines that begin with item must have at least three more tokens on them: an item type, a label, and an attribute name. Any extra tokens are taken as extra arguments.
The item type token must be one of the following strings:
case-ignore string attributes
multiline string attributes
RFC-822 conformant mail address attributes
distinguished name pointer attributes
JPEG photo attributes
a button that will retrieve and show a JPEG photo attribute
FAX T.4 format image attributes
a button that will retrieve and show a FAX photo attribute
UTC time attributes
UTC time attributes where only the date portion should be shown
labeled Uniform Resource Locator attributes
define an action that will do a directory search for other entries
define an action which is a link to another display template
for an encrypted attribute, with values displayed as asterisks
An example of an item line for the drink attribute (displayed with label "Work Phone"):
item cis "Work Phone" telephoneNumber
Example 1 A Sample Configuration File Containing a Template that Displays People Entries
The following template configuration file contains a templates for display of people entries.
# # LDAP display templates # # Version must be 1 for now # Version 1 # # Person template "Person" "People" # name of the icon that is associated with this template "person icon" # blank-separated list of template options ("" for none) "addable" # # objectclass list person END # # name of attribute to authenticate as ("" means auth as this entry) "" # # default attribute name to use when forming RDN of a new entry # "cn" # # default location when adding new entries (DN; "" means no default) "o=XYZ, c=US" # # rules used to define default values for new entries END # # list of items for display item jpegbtn "View Photo" jpegPhoto "Next Photo" item audiobtn "Play Sound" audio item cis "Also Known As" cn item cis "Title" title item mls "Work Address" postalAddress item cis "Work Phone" telephoneNumber item cis "Fax Number" facsimileTelephoneNumber item mls "Home Address" homePostalAddress item cis "Home Phone" homePhone item cis "User ID" uid item mail "E-Mail Address" mail item cis "Description" description item dn "See Also" seeAlso END
See attributes(5) for a description of the following attributes: