|Skip Navigation Links|
|Exit Print View|
|man pages section 4: File Formats Oracle Solaris 10 1/13 Information Library|
- user-preference variables files for AT&T FACE
The .environ, .pref, and .variables files contain variables that indicate user preferences for a variety of operations. The .environ and .variables files are located under the user's $HOME/pref directory. The .pref files are found under $HOME/FILECABINET, $HOME/WASTEBASKET, and any directory where preferences were set via the organize command. Names and descriptions for each variable are presented below. Variables are listed one per line and are of the form variable=value.
Variables found in .environ include:
Windows that are opened when FACE is initialized.
Sort mode for file folder listings. Values include the following hexadecimal digits:
Sorted alphabetically by name.
Files most recently modified first.
Sorted alphabetically by object type.
The values above may be listed in reverse order by ORing the following value:
List objects in reverse order. For example, a value of 1002 will produce a folder listing with files LEAST recently modified displayed first. A value of 1001 would produce a "reverse" alphabetical by name listing of the folder.
Display mode for file folders. Values include the following hexadecimal digits:
File names only.
File names and brief description.
File names, description, plus additional information.
Prompt before emptying wastebasket (yes/no?).
Number of days before emptying wastebasket.
Print command defined to print files.
Holds default permissions with which files will be created.
Variables found in .pref are the following:
Contains the same values as the SORTMODE variable described in .environ above.
Contains the same values as the DISPLAYMODE variable described in .environ above.
Variables found in .variables include:
See attributes(5) for descriptions of the following attributes:
The Framed Access Command Environment Interface (FACE) is obsolete and might be removed in a future release.