|Skip Navigation Links|
|Exit Print View|
|man pages section 4: File Formats Oracle Solaris 10 1/13 Information Library|
- configuration file for Trusted Extensions X Server Extension
TrustedExtensionsPolicy is the configuration file for Trusted Extensions X Server Extension (SUN_TSOL). SUN_TSOL provides security policy enforcement. This enforcement is based on Mandatory Access Control (MAC) and Discretionary Access Control (DAC).
Blank lines and comments in the TrustedExtensionsPolicy file are ignored. Comments start with a pound sign (#). The format of the file is as follows:
where keyword can be one of the following:
Label this atom ADMIN_LOW, so that XGetAtomName(3X11) succeeds.
Instantiate this property once. The default is to polyinstantiate a property.
Polyinstantiate this selection. The default is to instantiate the selection once.
Disable this extension.
Implicitly allow this window privilege on all clients.
For possible keyword values, see the /usr/X11/lib/X11/xserver/TrustedExtensionsPolicy file for the Xorg X server. For Xsun, see the /usr/openwin/server/etc/TrustedExtensionsPolicy file.
The following entry in the TrustedExtensionsPolicy file polyinstantiates the Dtpad program:
If the entry is missing, or commented out, the Dtpad program is instantiated once.
Similarly, the following entry instantiates the WM_ICON_SIZE property once:
If the entry is missing, or commented out, the WM_ICON_SIZE property is polyinstantiated.
Configuration file for Trusted Extensions X Server Extension
See attributes(5) for descriptions of the following attributes:
The functionality described on this manual page is available only if the system is configured with Trusted Extensions.