|Skip Navigation Links|
|Exit Print View|
|man pages section 4: File Formats Oracle Solaris 10 1/13 Information Library|
- FTP Server transfer log file
By default, each server entry is composed of a single line of the following form. All fields are separated by spaces.
current-time transfer-time remote-host bytes-transferred \ filename transfer-type special-action-flag direction access-mode username service-name authentication-method authenticated-user-id \ completion-status
The xferlog format capability can be used to customize the transfer log file format used. In addition to those in the default format, it also supports chroot-filename, file-size, and restart-offset fields. See ftpaccess(4).
The fields are defined as follows:
The current local time in the form DDD MMM dd hh:mm:ss YYYY, where:
Is the day of the week
Is the month
Is the day of the month
Is the hour
Is the minutes
Is the seconds
Is the year
The total time in seconds for the transfer
The remote host name
The number of bytes transferred
The absolute pathname of the transferred file
A single character indicating the type of transfer:
Indicates an ascii transfer
Indicates a binary transfer
One or more single character flags that indicate any special action taken. The special-action-flag can have one of more of the following values:
File was compressed
File was uncompressed
File was archived, for example, by using tar(1)
No action was taken.
The direction of the transfer. direction can have one of the following values:
The method by which the user is logged in. access-mode can have one of the following values:
For an anonymous user.
For a passworded guest user. See the description of the guestgroup capability in ftpaccess(4).
For a real, locally authenticated user
The local username, or if anonymous, the ID string given
The name of the service invoked, usually ftp
The method of authentication used. authentication-method can have one of the following values:
RFC 931 authentication
The user ID returned by the authentication method. A * is used if an authenticated user ID is not available.
A single character indicating the status of the transfer. completion-status can have one of the following values:
Indicates complete transfer
Indicates incomplete transfer
The pathname of the transferred file relative to the chroot point. This will differ from the filename field for anonymous and guest users.
The size, in bytes, of the file on the server.
The offset, in bytes, at which the file transfer was restarted (0 when no restart offset was specified).
See attributes(5) for descriptions of the following attributes:
StJohns, Mike. RFC 931, Authentication Server. Network Working Group. January 1985.