|Skip Navigation Links|
|Exit Print View|
|man pages section 7: Device and Network Interfaces Oracle Solaris 10 1/13 Information Library|
- ATI IXP400 south bridge audio digital controller interface
The audioixp device uses the IXP400 south bridge audio digital controller and a AC–97 Codec to implement the audio device interface.
Applications that open /dev/audio may use the AUDIO_GETDEV ioctl(2) to determine which audio device is being used. The audioixp driver returns the string SUNW,audioixp in the name field of the audio_device structure. The version field contains the letter "a" and the config field contains the string onboard1.
Key to the above table: Ver. = Version. Out = Line Out. H. Phone = Head Phone. Spkr = Internal Speaker. In = Line In. Mic. = Microphone. CD = CD=ROM
The audioixp device provides support for the internal speaker, headphone, line out, line in, and microphone. The play.mod_ports and record.mod_ports fields of the audio_info structure (see audio(7I)) indicate which ports may be manipulated.
You use the /kernel/drv/audioixp.conf file to configure the audioixp driver and enable or disable the audio mixer. See the mixer(7I) manual page for details. You can change the audio mixer mode at any time using the sdtaudiocontrol(1) or mixerctl(1) commands. Note that some systems support 48K sample rates only. On these systems, the compatible mode may not work and the mixer mode should be used.
The audioixp device supports 8-bit and 16-bit linear encoding in mono and stereo. With the mixer enabled, a continuous range of sample rates from 5510 to 48000 Hz is supported. With the mixer disabled, the following sample rates may be supported, depending on Codec capability: 5510, 6620, 8000, 9600, 11025, 16000, 18900, 22050, 27420, 32000, 33075, 37800, 4410, and 48000 Hz. Whether the mixer is enabled or not, the device can be opened for simultaneous playing and recording.
Because the audioixp device manipulates buffers of audio data, the reported input and output sample counts will vary at any given time from the actual sample count by no more than the size of the buffers the audioixp driver is transferring. In general, programs should not rely on the absolute accuracy of the play.samples and record.samples fields of the audio_info structure.
The driver determines how often play and record interrupts should take place. For playing audio, this determines how often and how much audio is requested from the audio mixer. The impact of interrupts on recording is minimal. However, if a very small read buffer size is set, the record interrupt rate should be increased to prevent the buffer from overflowing. The play and record interrupt rates are tunable in the /kernel/drv/audioixp.conf file.
See the audio(7I) manpage for audioixp errors.
Symbolic link to the system's primary audio device. (Not necessarily an audioixp audio device).
Control device for the primary audio device.
Represents the first audio device on the system. (Not necessarily an audioixp audio device).
Audio control for /dev/sound/0.
Audio sample files.
Driver configuration file.
See attributes(5) for a descriptions of the following attributes:
ATI IXP400 South Bridge Data Sheet
In addition to being logged, the following messages may appear on the system console:
The play interrupt rate in audioixp.conf is set too low. It has been reset to the rate specified in the message. Update audioixp.conf to a higher play interrupt rate.
The play interrupt rate set in audioixp.conf is set too high. It has been reset to the rate specified in the message. Update audioixp.conf to a lower play interrupt rate.
The record interrupt rate in audioixp.conf is set too low. It has been reset to the rate specified in the message. Update audioixp.conf to a higher record interrupt rate.
The record interrupt rate in audioixp.conf is set too high. It has been reset to the rate specified in the message. Update audioixp.conf to a lower record interrupt rate.