|Skip Navigation Links|
|Exit Print View|
|man pages section 7: Device and Network Interfaces Oracle Solaris 10 1/13 Information Library|
- Sun Blade 40/10Gigabit Ethernet network driver
The sxge 40/10Gb Ethernet driver is a multi-threaded, loadable, clonable, GLD-based STREAMS driver supporting the Data Link Provider Interface, dlpi(7P), on the Sun Blade Shared 40/10Gb Ethernet Interface.
The Shared PCI-Express Gen-2 40/10Gb networking interface provides network I/O consolidation for up to ten Constellation blades, with each blade seeing its own portion of the network interface.
The sxge driver functions include chip initialization, frame transmit and receive, flow classification, multicast and promiscuous support and error recovery and reporting in the blade domain.
The cloning character-special device, /dev/sxge, is used to access Sun Blade Shared 40/10Gb Ethernet Interface devices installed within the system.
You must send an explicit DL_ATTACH_REQ message to associate the opened stream with a particular device (PPA). The PPA ID is interpreted as an unsigned integer data type and indicates the corresponding device instance (unit) number. The driver returns an error (DL_ERROR_ACK) if the PPA field value does not correspond to a valid device instance number for the system. The device is initialized on first attach and de-initialized (stopped) at last detach.
The values returned by the driver in the DL_INFO_ACK primitive in response to a DL_INFO_REQ are:
Maximum SDU is 1500 (ETHERMTU, defined in <sys/ethernet.h>).
Minimum SDU is 0.
DLSAP address length is 8.
MAC type is DL_ETHER.
SAP length value is -2, meaning the physical address component is followed immediately by a 2-byte SAP component within the DLSAP address.
Broadcast address value is the Ethernet/IEEE broadcast address (FF:FF:FF:FF:FF:FF).
In the transmit case for streams that have been put in raw mode using the DLIOCRAW ioctl, the dlpi application must prepend the 20 byte IPoIB destination address to the data it wants to transmit over-the-wire. In the receive case, applications receive the IP/ARP datagram along with the IETF defined 4 byte header.
Once in the DL_ATTACHED state, you must send a DL_BIND_REQ to associate a particular Service Access Point (SAP) with the stream.
By default, the link speed is 10 Gbps. It can be configured from Network Express Module. The link mode is fixed to full-duplex only.
The default MTU is 1500. To enable jumbo frame support, you configure the sxge driver by defining the accept-jumbo property to 1 in the sxge.conf file. The largest jumbo size is 9194 bytes.
The sxge driver supports the self-healing functionality of the Oracle Solaris OS. It is configured to DDI_FM_EREPORT_CAPABLE | DDI_FM_ERRCB_CAPABLE by default. You configure the sxge driver by defining the fm-capable property in sxge.conf to other capabilities or to 0x0 to disable it entirely.
The sxge driver can be configured using the standard ifconfig(1M) command.
The sxge driver also reports various hardware and software statistics data. You can view these statistics using the kstat(1M) command.
In SR-IOV mode, the following device-specific parameters are exported by the sxge driver to support SR-IOV feature.
This is a read-only parameter describing the maximum number of VFs that can be configured.
This is a read-only parameter describing the maximum MTU allowed for a VF.
Special character device
64-bit device driver (SPARC)
64-bit device driver (x86)
See attributes(5) for a description of the following attributes: