JavaScript is required to for searching.
Ignorar Links de Navegao
Sair do Modo de Exibio de Impresso
Notas de versão do Oracle Solaris 11     Oracle Solaris 11 Information Library (Portugu√™s (Brasil))
search filter icon
search icon

Informação sobre o documento

Prefácio

1.  Antes de começar

2.  Problemas de instalação

3.  Problemas de tempo de execução

4.  Problemas de atualização

Erros de atualização

Não é possível atualizar do Oracle Solaris 11 Express para o Oracle Solaris 11 usando o Gerenciador de pacotes (19022)

Diretório não vazio ou mensagens inesperadas durante a atualização (7019792)

Produtos que têm dependências em pacotes obsoletos (7106586)

O CUPS substitui o serviço de impressão LP como serviço de impressão padrão no Oracle Solaris 11

syslog relata que o banco de dados de aliases /etc/mail/aliases.db está desatualizado após uma atualização (7096745)

Problemas de idioma padrão para facetas de localidade não configuradas (7073516)

Erros de atualização

Os erros a seguir podem ocorrer durante a atualização para o Oracle Solaris 11.

Não é possível atualizar do Oracle Solaris 11 Express para o Oracle Solaris 11 usando o Gerenciador de pacotes (19022)

Você não pode atualizar do Oracle Solaris 11 Express (compilação 151a) para o Oracle Solaris 11 usando o Gerenciador de pacotes.

Solução alternativa: use o utilitário de linha de comandopkg(1) para fazer a atualização. Consulte Como atualizar do Oracle Solaris 11 Express para o Oracle Solaris 11.

Diretório não vazio ou mensagens inesperadas durante a atualização (7019792)

Durante a atualização do Oracle Solaris 11 Express para o Oracle Solaris 11, a seguinte mensagem poderá aparecer:

The following unexpected or editable files and directories were
salvaged while executing the requested package operation; they
have been moved to the displayed location in the image:
followed by one or more directories named as such: 

dir -> /tmp/tmpdir/var/pkg/lost+found/dir-timestamp

Solução: ignore a mensagem. Os diretórios exibidos não estão mais no pacote do sistema atualizado. Entretanto, o conteúdo do diretório pode ser encontrado no diretório /var/pkg/lost+found no ambiente de inicialização atualizado.

Produtos que têm dependências em pacotes obsoletos (7106586)

Se determinados pacotes de pkg://opensolaris.org/ estiverem instalados, a atualização do sistema para Oracle Solaris 11 talvez não seja possível. A tabela a seguir lista esses pacotes.

Nome do pacote
Descrição
amp-dev
Cluster de desenvolvimento AMP
eclipse
IDE Eclipse
java-dev
Cluster de desenvolvimento Java
libnb-apisupport
Suporte à API do cluster NetBeans
libnb-enterprise
Suporte a NetBeans Java EE
libnb-groovy
Suporte a NetBeans Groovy
libnb-identity
Identidade de cluster NetBeans
libnb-java
Suporte a NetBeans Java
libnb-profiler
NetBeans Profiler
mq41
Message Queue 4.1
netbeans
IDE do NetBeans
netbeans-java
NetBeans Web e Java Enterprise Edition (EE)
netbeans-javase
Distribuição NetBeans Java Standard Edition (SE)
openoffice
OpenOffice.org versão 3.1.0
openoffice-sdk
SDK para OpenOffice.org versão 3.1.0
service/network/message-queue-41
Message Queue 4.1
web/glassfish-2
GlassFish Java EE 5 Server

Solução alternativa: desinstale os pacotes antes de atualizar para Oracle Solaris 11. Consulte os seguintes sites para verificar as versões mais recentes:

O CUPS substitui o serviço de impressão LP como serviço de impressão padrão no Oracle Solaris 11

O padrão e único serviço de impressão no Oracle Solaris 11 é o CUPS (Common UNIX Printing System). No Oracle Solaris 10 e em versões anteriores, o serviço de impressão LP é o serviço de impressão padrão. O serviço de impressão LP foi removido do Oracle Solaris 11.

Caso você esteja instalando o Oracle Solaris 11 ou atualizando para essa versão, as impressões que estiverem configuradas com o serviço de impressão LP deverão ser reconfiguradas para funcionar com o CUPS, já que essas impressoras não funcionarão mais. As impressoras podem ser reconfiguradas de uma das seguintes maneiras:


Observação - Se você estiver executando o Oracle Solaris 11 Express não modificado, o CUPS já será o servidor de impressão padrão. Se você atualizar para o Oracle Solaris 11, não precisará reconfigurar nenhuma fila de impressão existente usando o CUPS. Entretanto, se tiver trocado para o serviço de impressão LP e configurado impressoras usando os comandos de impressão LP, deverá reconfigurar essas impressoras existentes usando o CUPS após a atualização.


Para obter instruções sobre a configuração do seu ambiente de impressão para trabalhar com o CUPS, consulte Capítulo 15, Setting Up and Administering Printers by Using CUPS (Tasks), no Oracle Solaris Administration: Common Tasks.

syslog relata que o banco de dados de aliases /etc/mail/aliases.db está desatualizado após uma atualização (7096745)

Em um sistema em que não foi adicionado nenhum alias local (/etc/mail/aliases), após uma atualização para o Oracle Solaris 11 a partir de versões anteriores do Oracle Solaris, você poderá ver a seguinte mensagem de log:

hostname sendmail[<pid>]: 
[ID 702911 mail.info] alias database /etc/mail/aliases.db out of date

Essa mensagem não é prejudicial e não afeta o seu sistema.

Solução alternativa: execute /usr/sbin/newaliases com privilégios root.

Problemas de idioma padrão para facetas de localidade não configuradas (7073516)

No Oracle Solaris 11, a instalação de localização é controlada por um mecanismo chamadofaceta, um componente opcional no IPS (Image Packaging System). Durante a instalação inicial do Oracle Solaris 11, as facetas são inicialmente configuradas para selecionar os idiomas (localidades) listados na tabela a seguir.

Idioma
Localidade
Chinês (simplificado)
zh_CN.UTF-8
Chinês (tradicional)
zh_TW.UTF-8
Inglês
en_US.UTF-8
Francês
fr_FR.UTF-8
Alemão
de_DE.UTF-8
Italiano
it_IT.UTF-8
Japonês
ja_JP.UTF-8
Coreano
ko_KR.UTF-8
Português (Brasil)
pt_BR.UTF-8
Espanhol
es_ES.UTF-8

Quando você atualiza do Oracle Solaris 11 Express para o Oracle Solaris 11, as facetas não são configuradas por padrão. Neste caso, todos os idiomas são implicitamente selecionados e instalados por padrão.

Solução alternativa: se você desejar configurar seu sistema com os idiomas selecionados, escolha uma das seguintes soluções após a atualização:

Para obter informações sobre o uso da opção -change-facet, consulte a página man pkg(1).