- check group database entries
The grpck utility checks that a file in group(4) does not contain any errors; it checks the /etc/group file by default.
See attributes(5) for descriptions of the following attributes:
An entry in the group file does not have the proper number of fields.
The group name field of an entry is empty.
The group name in an entry contains characters other than lower-case letters and digits.
The group ID field in an entry is not numeric or is greater than 65535.
A login name in the list of login names in an entry is null.
A login name in the list of login names in an entry is not in the password file.
A line (including the NEWLINE character) in the group file exceeds the maximum length of 512 characters.
A login name appears more than once in the list of login names for a group file entry.
The program cannot allocate memory in order to continue.
A login name's group membership exceeds the maximum, NGROUPS_MAX.