- provide truth values
The true utility does nothing, successfully. The false utility does nothing, unsuccessfully. They are typically used in a shell script sh as:
while true do command done
which executes command forever.
true has exit status 0.
false always will exit with a non-zero value.
See attributes(5) for descriptions of the following attributes: