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PREFACE 

About This Guide

This guide provides technical staff with detailed information on installing and configuring Oracle Knowledge 
Analytics to report on configured Oracle Knowledge Intelligent Search and Oracle Knowledge Information 
Manager applications.

In This Guide
The Oracle Knowledge Analytics Installation Guide is divided into the following sections:

Screen and Text Representations
The product screens, screen text, and file contents depicted in the documentation are examples. We attempt 
to convey the product's appearance and functionality as accurately as possible; however, the actual product 
contents and displays may differ from the published examples.

References to External Web Content
For your convenience, we refer to Uniform Resource Locators (URLs) for resources published on the World 
Wide Web when appropriate. We attempt to provide accurate information; however, these resources are 
controlled by their respective owners and are therefore subject to change at any time.

Chapter 1, Oracle 
Knowledge Analytics 
Overview 

This chapter describes Analytics, including its 
architecture and components.

Chapter 2, Oracle 
Knowledge Analytics 
Requirements and 
Dependencies

This chapter describes the requirements and 
dependencies that you must satisfy before 
installing Analytics.

Chapter 3, Installing 
Oracle Knowledge 
Analytics

This chapter describes how to install and configure 
Analytics using the automated installation 
program.

Chapter 4, 
Configuring and 
Deploying Analytics

This chapter describes how to configure and 
deploy Analytics.
ORACLE KNOWLEDGE ANALYTICS INSTALLATION GUIDE
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The Analytics Application 
CHAPTER 1

Oracle Knowledge Analytics 
Overview

Oracle Knowledge Analytics is an enterprise-grade business intelligence application designed 
specifically to provide insight into the effectiveness and performance of Oracle Knowledge 
applications. The Oracle Knowledge Analytics solution features extensive dashboards, intuitive 
reporting, and ad hoc investigation tools that enable you to:

• assess answer quality, and whether users are finding the information they seek

• guard against escalations by identifying and filling knowledge gaps and determine whether 
important information is missing from your content

• understand user behavior, monitor customer satisfaction, and continually improve user 
experience

• keep pace with new product releases and evolving audience needs

The Analytics Application
An Oracle Knowledge Analytics application consists of multiple components configured to extract, 
store, and present data collected from one or more configured Intelligent Search and/or 
Information Manager instances. Analytics components include:

• the ETL server, which uses a configured Oracle Knowledge instance to execute the data 
extraction, transform, and load (ETL) processes

• the data warehouse, which stores the extracted Intelligent Search and Information Manager 
log data, repository data and additional metadata used to create the report

• a configured Oracle Business Intelligence Enterprise Edition (OBIEE) instance, which 
provides the user interface for generating, viewing, and working with reports

OBIEE and Oracle Knowledge Analytics
Oracle Knowledge Analytics uses a configured instance of OBIEE installed on the Reports server. 
OBIEE is available separately, and is not included in the Oracle Knowledge product distribution. This 
document describes how to configure an installed instance of OBIEE to use the RPD (repository) and 
Catalog components that are provided with the product. See http://www.oracle.com/technetwork/
middleware/bi-enterprise-edition/overview/index.html for more information on OBIEE.
Oracle Knowledge Analytics Installation Guide 3



Analytics Reporting Process
Analytics Reporting Process
The Analytics application reports on Oracle Knowledge applications using a configured Oracle 
Knowledge instance to run a scheduled ETL process. The ETL process extracts log data from the 
configured instances and stores the formatted data in a data warehouse. You can then use the 
configured OBIEE application to access the data warehouse to generate the standard reports. 
4 Oracle Knowledge Analytics Installation Guide



 

CHAPTER 2

Oracle Knowledge Analytics 
Requirements and Dependencies

This chapter describes the prerequisites and dependencies for installing, configuring, and operating 
Analytics.

Recommended Server and Processor Deployment
For high-volume applications, we recommend separating the Reports server from the server that 
hosts the database and ETL processes. If your Analytics application processes fewer than 3,000 
questions per day, you can deploy all of the application components on a single processor. If your 
application processes more than 30,000 questions per day, we recommend that you deploy the data 
warehouse, ETL, and Reports server on separate networked processors.

Server and Database Requirements
The Oracle Knowledge Platforms and Languages Support Guide included with the Oracle Knowledge 
product documentation describes the hardware, software, and database requirements for Oracle 
Knowledge applications, including Oracle Knowledge Analytics.

Report Server (OBIEE) Requirements
Please refer to the Oracle Fusion Middleware Quick Installation Guide for Oracle Business 
Intelligence for OBIEE hardware and software requirements, installation pre-requisites, and 
instructions for installing, configuring, and uninstalling Oracle Business Intelligence products. You can 
access the Oracle Business Intelligence Documentation Library at: http://www.oracle.com/
technetwork/middleware/bi-enterprise-edition/documentation/index.html. We strongly recommend 
that you familiarize yourself with the contents of the Oracle Business Intelligence Documentation 
Library.

The initial Analytics configuration process depends on the OBIEE Administration Tool, which runs 
only in Windows environments. Consult the OBIEE documentation for specific Administration Tool 
requirements and dependencies. 

IMPORTANT:  If you are using an SQL Server database, you need to install Microsoft Data 
Access Components (MDAC), also known as Windows DAC, on the Report server 
in order to connect OBIEE to the SQL Server database. You can locate Microsoft 
Oracle Knowledge Analytics Installation Guide 5



Report Server (OBIEE) Requirements
Data Access Components (MDAC) 2.8 SP1 at http://www.microsoft.com/
download/en/default.aspx
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Report Server (OBIEE) Requirements
8 Oracle Knowledge Analytics Installation Guide



CHAPTER 3

Installing Oracle Knowledge 
Analytics

You install the Analytics software on the processor that you have designated as the ETL server within 
your Analytics application architecture. The ETL server must have an installed and configured 
Intelligent Search scheduler instance, including the Advanced Configuration Facility.

The Analytics installation process uses an automated installation program that copies the product 
files from the product distribution and installs Analytics into the existing Oracle Knowledge directory 
structure. The installation program will install and configure either or both Intelligent Search Analytics 
and Information Manager Analytics.

You install and configure Analytics, using the following process:

• install the Analytics software

• install Oracle Business Intelligence, Enterprise Edition (OBIEE)

• configure the database connection

• configure and deploy the Repository (RPD) and the Catalog

The Analytics installer contains:

• Analytics 8.4.2.2 installer executable 

• RPD (Repository)

• Business Intelligence Catalog 

IMPORTANT:  Before installing Oracle Knowledge Analytics, make sure the requirements and 
prerequisites are satisfied, and that appropriate personnel with access to the 
specified environments are available to perform the installation.

For instructions on starting the installation program, see “Starting the Installation Program”.
Oracle Knowledge Analytics Installation Guide 9



Starting the Installation Program
Starting the Installation Program

IMPORTANT:  We strongly recommend that you log out of all programs before proceeding 
with the installation.

1 Start the installation program by locating and executing the appropriate installation program for 
your environment.

To start the installation program in Microsoft Windows environments, run:

install_analytics.exe

To start the installation program in Linux environments, run: 

install_analytics.bin

The Analytics installation program starts and Introduction screen displays.

2 At the Introduction screen, click Next.
10 Oracle Knowledge Analytics Installation Guide



Starting the Installation Program
3 At the Choose Install Folder, select or enter the directory where Analytics will be installed. 

The installation program selects a default location:

- C:\Inquira_x.x in Windows environments or <user_home>/InQuira_x.x in Linux 
environments

You can click Choose to open a file explorer and select an alternate location. Click Restore 
Default Folder to reset the default installation directory, if necessary.

IMPORTANT:  The installation program checks to see that an Oracle Knowledge instance has 
been properly installed. If it does not find the folders and files it is expecting, an 
error message displays.
Oracle Knowledge Analytics Installation Guide 11



Starting the Installation Program
4 At the Choose InQuira Instance Folder screen, select the location of the Oracle Knowledge 
instance folder to be used for Analytics. The location needs to be one of the subfolders in the 
instances folder. 

Note:   Ensure that the selected instance is a configured Intelligent Search scheduler instance.

- The installation program selects a default location:

- C:\Inquira_x.x \instances\ in Windows environments or <user_home>/
InQuira_x.x\instances in Linux environments.

You can click Choose to open a file explorer and select an alternate location. 

Click Restore Default Folder to reset the default installation directory, if necessary.
12 Oracle Knowledge Analytics Installation Guide



Starting the Installation Program
5 At the Install Information Manager Support screen, select Yes or No. 

If you select Yes, Information Manager Analytics will be installed. You must have InQuira 
Information Manager already installed before selecting Yes. Click Next.
Oracle Knowledge Analytics Installation Guide 13



Starting the Installation Program
6 At the Install Analytics Archiver Support screen, select Yes or No and click Next.

Selecting Yes will install an Analytics Archive.
14 Oracle Knowledge Analytics Installation Guide



Starting the Installation Program
7 At the Set Database Type screen, select an Oracle database or an SQL database and click 
Next.
Oracle Knowledge Analytics Installation Guide 15



Starting the Installation Program
8 If you selected No at the Install Information Manager Support screen, skip to step 10.

If you selected Yes to install Information Install Information Manager Support screen, the Set 
IM Database Parameters screen displays. 

Set the database parameters for the Information Manager Analytics Database.
16 Oracle Knowledge Analytics Installation Guide



Starting the Installation Program
9 If you selected No at the Install Analytics Archive Support screen, skip to step 10.

If you selected Yes at the Install Analytics Archive Support screen, the Set Analytics Archive 
Database Parameters displays.

Set the database parameters for the Analytics Archive Databases.
Oracle Knowledge Analytics Installation Guide 17



Starting the Installation Program
10 At the Set Analytics Database Parameters screen, enter the Database JDBC URL (database 
location), Database User, and Data Password, and click Next.

IMPORTANT:  The database for Analytics and the database for the Analytics Archive must be 
separate.
18 Oracle Knowledge Analytics Installation Guide



Starting the Installation Program
11 At the Create Analytics Database screen, select Yes or No and click Next.

IMPORTANT:  If you select Yes and the schema already exists, it will be deleted and 
recreated. 
Oracle Knowledge Analytics Installation Guide 19



Starting the Installation Program
12 At the Pre-installation Summary screen, check your selections; to modify, click Previous until 
you get back to the screen on which you need to make a change. Click Install to start the 
installation process.
20 Oracle Knowledge Analytics Installation Guide



Starting the Installation Program
13 The Installing Analytics 8.4.2.2 screen displays the progress of the installation.

14 The completion screen summarizes the installation process.The InQuira Analytics component 
directories and files are now installed in the specified location. 
Oracle Knowledge Analytics Installation Guide 21
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Installing OBIEE
CHAPTER 4

Configuring and Deploying 
Analytics

Installing OBIEE
You install OBIEE on the designated Reports server using the process described in the OBIEE 
installation documentation. You must also install the OBI Administration tool.

When you have completed the OBIEE installation, you can configure OBIEE by creating the Analytics 
project. 

Installing the OBI Administration Tool
You can install the OBI Administration tool:

• on the Reports server, which also hosts OBIEE and the data warehouse

• on a separate server

IMPORTANT:  The OBI Administration Tool operates only in Windows environments.

Creating the Analytics Project in OBIEE
The Oracle Knowledge Analytics installation process creates an RPD (repository) file and a catalog 
that defines the Oracle Knowledge project, including the various dashboards and reports that make 
up the application. You create the Oracle Knowledge Analytics project by:

• connecting OBIEE to the data warehouse

• deploying the RPD and Catalog

You can then validate the application.

Connecting OBIEE to the Data Warehouse
You connect the OBIEE instance to the data warehouse by editing the database connection 
parameters in the RPD file that was installed as part of the Analytics installation process. You edit the 
RPD file using the OBIEE Administration Tool. 

IMPORTANT:  If you are using an SQL Server database, you must use MDAC, (or Windows 
Oracle Knowledge Analytics Installation Guide 23



Installing OBIEE
DAC, to define the ODBC data source and add and configure the appropriate 
driver. See http://msdn.microsoft.com/en-us/library/windows/
desktop/ms692872%28v=vs.85%29.aspx for MDAC / Windows DAC 
documentation resources. 

The Analytics installation process creates the catalog and RPD files on the file system in 
SEARCH_INSTALL_DIR\analytics\reporting.

• Copy the catalog file (analyticsReports.zip) and the RPD (analyticsReports.rpd) file to a 
temporary directory on the OBIEE server. 

• Extract the contents of the analyticsReports.zip file in the temporary directory. 

This creates the IM_Analytics directory.

Changing the RPD Password
The RPD file is shipped with a default password. We strongly recommend that you change the 
RPD password prior to deploying the RPD and Catalog. The repository password must be at 
least eight characters, with at least one numeric character. The Repository Password field 
cannot be empty.

Change the RPD password using the Business Intelligence (BI) Administration Tool. 

To change the RPD password:

1 Open the repository in the BI Administration Tool and select File> Open > Offline.

2 Select File> Change Password.

3 Enter the current (default) password: inquira1.

4 Enter the new password and confirm it. 

5 Select File>Save.

Configuring Connections to the Data Warehouse
You configure the connection between OBIEE and the data warehouse using the Oracle Business 
Intelligence (BI) Administration tool and the tnsnames.ora mapping file.

Defining the Database Connections
You define the connection to the Analytics database using tnsnames.ora files. A tnsnames.ora file is a 
configuration file that defines database addresses for connection. When you install and configure 
OBIEE, you must configure the tnsnames.ora file and place copies: 

• in the network/admin directory within the OBIEE installed directory structure

• in the network/admin directory in the BI Administration tool installed directory structure
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Installing OBIEE
Connecting to the Analytics Schema (Oracle)
1 Open the BI Administration Tool and select File> Open > Offline.

2 Navigate to the directory where you put the RPD file, and open it.

3 At the Repository login, enter your repository password.

4 Select Manage>Variables.

5 At the Variable Manager, double click on Inquira_IM_DSN.

Enter the Default Initializer, which is the database server name, as it is defined in the ODBC 
connection. The database server name is surrounded by single quotes (‘DBServerName‘).

6 At the Variable Manager, double click on Inquira_IM_USER.

Enter the Default Initializer, which is the database schema name, The database schema name 
is surrounded by single quotes (‘DBSchema‘).

7 At the BI window, expand and then double click on DW_IM_Search in the Physical panel.

8 Enter the Analytics schema password, and enter again to confirm it.

9 To check the connection:

a Expand the INQ_ANALYTICS node in the Physical panel 

b Right-click on Repository Dim>View Data to ensure the RPD is connected and repository 
table data is displayed.

10 Click File>Save.

Connecting to the Analytics Database (MS SQL Server)
1 Open the BI Administration Tool and select File> Open > Offline.

2 Navigate to the directory where you put the RPD file, and open it.

3 At the Repository login, enter your repository password.

4 Select Manage>Variables.

5 At the Variable Manager, click on inquira_IM_USER.

Enter the Default Initializer, which is the database user name, The database user name is 
surrounded by single quotes (‘DBUser‘).

6 At the BI window, double click on DW_IM_SEARCH_Inq in the Physical panel. Under the 
Database source definition, select SQL Server database.

7 At the BI window, double click on DW_IM_Search in the Physical panel.

8 Select ODBC in the Call Interface field.

9 Select SQL Server (defined in the ODBC connection) as the data source name.

10 Enter the user password, and enter again to confirm it.

11 To check the connection:
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Installing OBIEE
a Expand the INQ_ANALYTICS node in the Physical panel 

b Right-click on Repository Dim>View Data to ensure the RPD is connected and repository 
table data is displayed.

12 Click File>Save.
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Deploying the RPD and Catalog
Deploying the RPD and Catalog 
The RPD and catalog define the Oracle Knowledge project, including the dashboards and reports, 
that you access using the OBIEE user interface. 

To deploy the RPD and catalog: 

1 Copy the edited RPD file from the temporary directory to the Repository directory at: 
OBIEE_INSTALL_DIR\instances\instance1\bifoundation\OracleBIServerComp
onent\coreapplication_obis1\repository.

1. Copy the IM_ANALYTICS folder to the catalog directory at: 
OBIEE_INSTALL_DIR\instances\instance1\bifoundation\OracleBIPresentati
onServicesComponent\coreapplication_obips1\catalog

2 Navigate to OBIEE Enterprise Manager at http://_hostname_:7001/em 

where hostname is the name of the server where OBIEE is installed.

a Log in with the username and password you used to install OBIEE.

3 On the left pane, click Business Intelligence/coreapplication.

4 On the right pane, click Overview and then press Stop on Manage System to stop the BI 
Server.

5 On the right pane, click Lock and Edit Configuration. 

This prevents anyone else from making configuration changes at the same time. Wait for 
confirmation popup.

6 On the right pane, click Deployment/Repository.

7 Enter the Repository password and click Apply.

8 At BI Presentation Catalog, change the catalog location to: 

$ORACLE_INSTANCE/bifoundation/OracleBIPresentationServicesComponent/
$COMPONENT_NAME/catalog/IM_Analytics

9 Click Activate Changes.

10 On the left pane, go to Overview and press Start.

The RPD is deployed and the catalog that defines the Oracle Knowledge Analytics project within 
OBIEE is added. 
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Validating the Analytics Installation
Purging the Caches
Frequently, the caches require a purge after configuration and deployment.

1 Enter the Repository password: inquira1, and enter the user and password you established 
when you installed OBIEE.

2 Navigate to Manage>Cache to open the caches.

3 Select Edit>Select all, and then select Edit>Purge.

The caches are now empty.

Validating the Analytics Installation
You can log onto the OBIEE reporting user interface to validate the installation and configuration 
process.You can validate the installation process by logging onto the application at:

http://_hostname_:7001/analytics

using the credentials you specified during installation.

The Oracle Knowledge Analytics Home Page displays the preconfigured dashboards. You can now 
define additional users, configure the extraction, transformation, and load (ETL) process to populate 
the reports, and perform other administrative tasks as described in the Oracle Knowledge Analytics 
Administration Guide. 
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