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1. About this Manual 

This manual provides the required information that Balance Sheet Planning 

Application administrator needs to setup the application. The document 

contains steps to create Hyperion Planning Application with BSP specific 

parameters, Creating Essbase Database, steps for creating Balance Sheet 

Planning relational data model and other required configurations. 

2. Audience 

This Manual is meant for use by the Oracle Financial Services Analytical 

Applications Infrastructure System Administrator or Hyperion System 

Administrator. It provides step-by-step instructions necessary for configuring 

the Oracle Financial Services Balance Sheet Planning v6.0 Product.  

3. Environmental variables configuration 

Set the following environmental variables in the profile for the UNIX user 

where Hyperion Planning has been installed, if not already set: 

 

 EPM_ORACLE_HOME 

 MIDDLEWARE_HOME 

 HYPERION_HOME – Same as EPM_ORACLE_HOME 

 ORACLE_HOME - Oracle Client Home 

 JAVA_HOME 

 ARBORPATH=$EPM_ORACLE_HOME/products/Essbase/EssbaseServer 

 ESSBASEPATH=$EPM_ORACLE_HOME/products/Essbase/EssbaseServer 

 NLSPATH=$EPM_ORACLE_HOME/products/Planning/bin/nls/msg/en_US/ofs

msg.cat:$EPM_ORACLE_HOME/products/Planning/bin/nls/msg/C/ofsmsg.ca

t 

 INIPATH=$EPM_ORACLE_HOME/products/Planning/config 

 FIC_HOME=$EPM_ORACLE_HOME 

 FIC_DB_HOME=$EPM_ORACLE_HOME/logs/bsplog 

 PATH=$JAVA_HOME/bin:$ARBORPATH/bin:$EPM_ORACLE_HOME/products/P

lanning/bin:$EPM_ORACLE_HOME/products/Planning/config:$EPM_ORACLE_

HOME/products/Planning/lib:$ORACLE_HOME/bin:$PATH:$HOME/bin 

 LD_LIBRARY_PATH=$ORACLE_HOME/lib:$ORACLE_HOME/rdbms/public:$EPM_ORA

CLE_HOME/common/ODBC-

64/Merant/6.1/lib:$EPM_ORACLE_HOME/products/Planning/lib:$ARBORPATH/bin 

 LD_LIBRARY_PATH_64=$LD_LIBRARY_PATH:$LD_LIBRARY_PATH_64 

 ODBCINI=$EPM_ORACLE_HOME/common/ODBC-64/Merant/6.1/odbc.ini 

 ODBCINST=$EPM_ORACLE_HOME/common/ODBC-

64/Merant/6.1/odbcinst.ini 

Note: You need to make the changes into the .profile file of the UNIX account 

where Planning and ESSBASE are installed. Oracle client is required on the 

servers where Hyperion ESSBASE and Planning are installed. BSP uses the 

Oracle drivers. 
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4. Installation of BSP 6.0 on Hyperion Planning PS2  

If CAPEX and/or WORKFORCE applications are required, initialize CAPEX and/or 

WORKFORCE after BSP initialization is complete. Furthermore, after initializing 

the WORKFORCE and/or CAPEX modules you need to perform the following 

activities. 

o Go to Manage->Dimension->Account and Entity Dimensions 

o Edit “No Entity” and “No Account” members and select the option 

“BSP”, “Rates” and “Core” Plan types. Perform a database refresh. 

If you are upgrading from BSP 5.6, perform the below steps and directly 

proceed to section “5. Initializing Balance Sheet Planning” 

o Upgrade Hyperion Planning PS1 to PS2 

o Rename the Dimension member “Assets” to “Asset” under the 

dimension Chart of Account. 

o Delete “LedgerDataLoad” Menu. 

4.1 Hyperion Planning Application Creation 

Note: Setup Classic Planning Application for Balance Sheet Planning as 

described in Oracle Hyperion Planning, Fusion Edition Administrator’s 

Guide. 

 

Select the value of following options in Create Application Wizard as 

specified below: 

 

Application Type: Generic 

First Fiscal Year -> Start Year: Set the value as per below illustration  

If start year falls in a century between: 

1900-2000 – Then start year will be 1980 

2000-2100 – Then start year will be 2000  

2100-2200 – Then start year will be 2100 and so on. 

Note: Here, Start year should be any centennial year such as, 2000, 

2100, and so on. BSP recommends to use 2000 as the Start year. 

Create 3 Plan Types as given below: 

Plan Type 1: BSP 

Plan Type 2: Rates 

Plan Type 3: Core 

In addition to the above, select the below mentioned Plan types: 

Plan Type 4: WORKFORCE [WRKFORCE] 

Plan Type 5: CAPEX 

 

Change the Date format in File -> PreferencesDisplay Options to MM-DD-YYYY  
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Note: While creating the Hyperion Planning Application, you can use any 

Application Name. BSP does not place any restriction on the Application 

naming conversion. It is recommended to not use any special characters, 
like &, *, ‘’, ””, %, and so on. 

4.2 Create Essbase Database 

 Log in to Balance Sheet Planning Application using the administrator 

username and password  

 Go to Administration->Application->Create Database screen and 

selection options specified in the screen and create database. 
 

4.3 Create Balance Sheet Planning Relational Data Model 

 Create a tablespace with the user define name. The same table space 

name should be used in user “Configuration” UI for the variable 

TABLESPACE.  

Note: Here, this tablespace refers to Oracle TABLESPACE and all the 
output tables of Cash Flow Engine will be created in this TABLESPACE. 

 Create Oracle database user for Balance Sheet Planning Relational 

Data Model in the tablespace as created in previous step. This 

database user should have ‘create’ privileges on tablespace it belongs 

to 

o This database user is different than Hyperion configuration 

database users and application data source. 

Note: BSP requires a distinct schema that is different from the schema 

created for creation of an application in Hyperion Planning (which is 

created in section 4.1 Hyperion Planning Application Creation). 

o Assign the following specific privileges to the user created for 

Balance Sheet Planning. These privileges are 
 

GRANT MGMT_USER TO <DBUSERNAME>;  

GRANT SELECT_CATALOG_ROLE TO <DBUSERNAME>;  

GRANT CREATE PROCEDURE TO <DBUSERNAME>;  

GRANT CREATE SEQUENCE TO <DBUSERNAME>;  

GRANT CREATE SESSION TO <DBUSERNAME>;  

GRANT CREATE SYNONYM TO <DBUSERNAME>;  

GRANT CREATE TABLE TO <DBUSERNAME>;  

GRANT CREATE TRIGGER TO <DBUSERNAME>;  

GRANT CREATE TYPE TO <DBUSERNAME>;  

GRANT CREATE VIEW TO <DBUSERNAME>; 

4.4 Create Data Source DSN to Database 

Note: BSP requires only one Data Source, this data-source will point to 

the Oracle schema where the BSP application will be initialized.  

 Open $HYPERION_HOME/common/ODBC-64/Merant/6.1/odbc.ini.  

 Add a new ODBC Data Source entry pointing to the Oracle-schema into 

which BSP was initialized, in section 4.3 Create Balance Sheet Planning 

Relational Model. This name should later be specified in the BSP’s 

configuration UI (available in Planning under Administrator Activities -
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> Master Maintenance -> Assumption Forms -> Configuration), as 

mentioned in Section 5 below. 

 The entry should contain information required to connect to the 

schema created for BSP objects.  

 Verify Host Name, Logon ID, Password, Port Number, and SID contain 

the information required to connect to the schema. 

5. Initializing Balance Sheet Planning  

 Login into Hyperion Planning 

 Go to AdministrationApplication-->Properties 

 In the Properties window Add new row  

o Properly Name = APPTYPE Property Value = BSP 

o Restart the Planning Sever 

 Go to AdministrationInitialization->Balance Sheet Planning. 

 Specify the below parameters: 

 Server: Database Server Name/IP Address  

 Port: Database port 

 Database: Database SID 

 User: Username 

 Password: Password for Database schema 

 APS Server: <IPAdress> 

Below is a sample screenshot: 

 

The Model option (in above sample screenshot) allows you to choose the 

number of custom dimensions that you need for initialization of BSP. This 

drop-down list has following options:  

 Standard – No additional custom dimensions 

 Custom 1 - One additional custom dimension 

 Custom 2 - Two additional custom dimensions 

Note: In case you are planning for an integrated installation of BSP with 

OFSAA applications, you should first initialize BSP as a standalone 

installation and then point BSP to the OFSAA instance. 

 Select “Finish” 

 After successful initialization, click the “Configure” button to launch the 

“Configuration UI”.  



 
 

5 
 

Note: You should pass the valid BSP application name to the config.xml file. 

xmlparserv2.jar needs to be copied in the post.sh script. The DSN name 

entry should not be missing in the odbc.ini file as configured through 

configuration UI that is, BSP application name (as per provided in config.xml). 

The mapped DB user details should be correct for the mapped DSN name (against 

BSP application name) in odbc.ini file. There should be an entry in .profile file 

for the mapped user of environment variable called ODBCINI and ODBCINST with 

proper path for odbc.ini and odbcinst.ini respectively. 

 

 Specify values for the parameters as mentioned under “annexure” section 

and click “save”. 

 Edit the file 

$EPM_ORACLE_HOME/products/Planning/bin/bsp_user_profile.sh file to 

specify the path for ORACLE_HOME variable. 

5.1 Set Evaluation Order  

Go to Administration->Dimensions->Evaluation Order tab. 

o For BSP Plan type: 

 Set Chart of Account, Attribute Value and then Account 

Dimension. 

2 For Rates Plan type:      

 Set Rate Element then Mix Breakout Dimension 

5.2 Steps to Enable Validation Rules 

Follow the below steps to enable the validation rules: 

1) Go to Manage data form open the Loan Fees form and click on column 

A the Loan_Fees_VR Validation rule is enable open this rule and select 

the Chart of Account dimension against attribute of source type in last 

condition. Then click ok and save the form. 

2) Go to Manage data form open the Loan Fees Annual form and click on 

Grid the Loan_Fees_VR, Loan_Fees_VR1, Validation rules are enable 

open these rules and select the Chart of Account dimension against 

attribute of source type in last condition. Then click ok and save the 

form. 

3) Go to Manage data form open the Deposit Service Charge form and 

click on Grid the Dep_Svc_Chg_VR, Validation rules are enable open 

this rule and select the Chart of Account dimension against attribute of 

source type in last condition. Then click ok and save the form. 

4) Go to Manage data form open the Deposit Service Charge Annual form 

and click on Grid the Dpst_Svc_Chg_Annl_VR, Loan_Fees_VR1, 

Validation rules are enable open these rules and select the Chart of 

Account dimension against attribute of source type in last condition. 

Then click ok and save the form. 



 
 

6 
 

5) Go to Manage data form open the Synchronization for Balance 

Accounts form and click on Row1 the Syn_Assets_VR, Syn_Liabty_VR, 

Validation rules are enable open these rules and select the Chart of 

Account dimension against attribute of source type in last condition. 

Then click ok and save the form 

    

5.3 LCM export and Preparation for Metadata Synchronization 

1) Post the Loading of Metadata in to BSP Planning Application, the 

administrator should export the Application Metadata to File System in 

Shared Services. 

2) Administrator has to login into Shared Services and Select the BSP 

Planning Application. 

3) In the Artifact Summary Page at the right Bottom Submit Select All 

and then Click Export. 

4) Here the Administrator defines a LCM Directory Name which has to be 

provided in Configuration Custom UI in the BSP Application 

5) Once the LCM export is completed, a folder will be created with the 

given name in shared services. 

6) This folder will be located in the import_export path of the Hyperion 

Instance chosen during Installation. 

5.4 Metadata Synchronization 

1) After completing the Preparation for Metadata Sync, Login to the BSP 

application, Select Administrator Activities folder in the left pane. 

2) Select Master Maintenance form and then Right Click on the menu 

appeared as large square box. 

3) From the right click menu Select Metadata Synchronization and choose 

the type needed by the Administrator Purpose. 
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5.5 Running the post.sh 

After installing Balance Sheet Planning (BSP) 6.0, run the post.sh in the 

directory $EPM_ORACLE_HOME/OPatch/14036211/custom/scripts to 

change the file permissions.  
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6. Annexure 

 

List of Parameters 

Sl. No. Parameter Name Description 

1 PASSWORD   Database Password  

2 USERNAME  Database User 

3 DSNNAME   DSN Name  

4 SERVERNAME   Essbase Server Name  

5 ESSUSER   Essbase User Name  

6 ESSPWD   Essbase Password  

7 LCMDIRPATH   LCM Directory path 

8 LCMDirName   LCM Directory Name  

9 FirstYr   First Year 

10 EndYr  End Year 

11 CurrMonth   Current Month  

12 StartPeriod  Start Period (By Default set to Jan) 

13 EndPeriod   End Period (By Default set to Dec) 

14 TABLESPACE  DB Table Space  
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Setting of Substitution Variable 

Note: If you are attempting to open a Form in BSP and following error 

appears: "A substitution variable required for this calculation is undefined. 

Variable: SecondYr", then set the SecondYr variable in Essbase 

Administration Services. 

SecondYr is a substitution variable. Any other variable can also be appeared in 

the above error message. Follow the below steps to configure the variable: 

1. Log in to EAS Console: http://<hostname>:19000/easconsole 

2. Click on "Launch" 

3. The Essbase Administration Services console will open. 

4. Expand Enterprise View -> Essbase Servers. 

5. Right-click on your server -> Edit -> Variables. 
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6. The Substitution Variables window will open. Go to the variable you are 

looking for and double-click on the value 

7. Enter the value and click on Set. 

 

8. Go back to BSP, and reload the Form.  

Note: Logout and Login are not required. 

 

Deploying Hyperion Planning in BSP 

1. Stop the Planning service (if already running): 

i. In the UNIX command prompt, check if the Planning service is running 

using command “ps –aef | grep Planning”. 

ii. Go to Planning bin path ( like  

$MIDDLEWARE_HOME/user_projects/epmsystem1/bin). 

iii. Run the command ./stopPlanning.sh. 

iv. Login to WebLogic Administration Console: 

http://<<ServerIP>>:7001/console/login/LoginForm.jsp. 
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2. Click Deployments:   

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

In the WebLogic Server: Click the Lock & Edit button to edit the console. 
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Take a backup of the ear file:  

$EPM_ORACLE_HOME/products/Planning/AppServer/InstallableApps/Common/ 

HyperionPlanning.ear. 

3. Delete the existing Planning deployment in the Weblogic Console. 

 

 
 

4. Activate the changes by clicking the Activate Changes button. 

 
 

5. Again click the Lock & Edit button to create the new Planning deployment. 
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6. Install the Planning Application. 

i. Click Install to install the Planning Application. 

 

 
 

ii. Select the check Box “HyperionPlanning.ear” (Path: Location of  

HyperionPlanning.ear). 

 

 

iii. Select the check Box Install this deployment as an Application and 

click Next. 

 

 

 

 

 

 

 

 

 

 

 

iv. For Instance Mapping, select Planning0 as the target to deploy the 

new JDBC Data Source and then click Next. 
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v. Give the Name of the Deployment (example PLANNING ) and leave 

all the rest of the options with the default values. Click Finish. 

 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

vi. Activate the changes by again clicking the Activate Changes button. 
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7. Start Planning Services: Check the Service PLANNING and press Start-> 

Servicing all requests. 
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8. Check Planning Services Up and Running. 

 

 

 

List of Log files 

 bsplog.log: This is being written BSP initialization and all Assumption 

Forms UI related log statements. 

 BSPCalculation_UnpricedAcc_udf.log: This is being written with while user 

is executing new Business and Current Business. 

 Config_FileCall.log: This is being written with statements related to 

Database access and import rule data load activities during various BSP 

business rule executions. 

 Data_Export.log: This is being written with statements related to exported 

 data during various BSP business rule executions. 

 DBProcsFuncs_PAttrs_Call.log: This is being written with statements for 

executed database procedures and functions during BSP business rule 

executions. 

 Metadata_Sync.log: This is being written with statements for Metadata 

Synchronization activities invoked through BSP business rules. 

In Single tier setup 

 BSP generates all log files under path 

$EPM_ORACLE_HOME/logs/bsplog   

 BSP generates all Cash flow engine related log files as part of Cash Flow 

Edit run , New business and Current business execution under path 

$EPM_ORACLE_HOME/logs/bsplog/log/FusionApps 
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In Distributed setup  

On Planning Server: 

 BSP generates BSP Initialization process  and all Assumption Forms UI 

related log statements in 

$EPM_ORACLE_HOME/logs/bsplog/bsplog.log 

 BSP generates all Cash Flow Edit runs log statements under path 

$EPM_ORACLE_HOME/logs/bsplog/log/FusionApps 

On Essbase Server:    

 BSP generates all Business Rule execution related log files under path 

$EPM_ORACLE_HOME/logs/bsplog 

 BSP generates all Cash flow engine related log files as part of New 

business and Current business execution under path 

$EPM_ORACLE_HOME/logs/bsplog/log/FusionApps 

 

Following tables capture the intermediate stages on database side: 

 fsi_bsp_process_log: This is a BSP specific table to capture intermediate 

state, success and failure message of individual procedure / function 

executions through BSP business rules. 

 fsi_process_errors: This is a OFSAAI table which maintains the various 

information related to Cash flow engine invocations through New business, 

Current Business, Cash flow edit process runs. 

 fsi_message_log: This is a OFSAAI table which maintains the various 

information related to hierarchy members’ registration process. 
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