Skip Headers
Oracle® Fusion Middleware Oracle Reports User's Guide to Building Reports
11g Release 1 (11.1.1)

Part Number B32122-03
Go to Documentation Home
Home
Go to Book List
Book List
Go to Table of Contents
Contents
Go to Index
Index
Go to Master Index
Master Index
Go to Feedback page
Contact Us

Go to previous page
Previous
Go to next page
Next
PDF · Mobi · ePub

1.6 The Report Editor

The topics in this section discuss the Report Editor and its different views of a report.

1.6.1 About the Report Editor

The Report Editor is a work area in which you can manipulate the objects in your report directly or by changing properties in the Property Inspector. In the Report Editor window, you can navigate between different views of your report: the Data Model view, Paper Layout view, Paper Design view, Paper Parameter Form view, and Web Source view.

Note:

By default the File > Administration option is always disabled.

1.6.2 About the Data Model view

The Report Editor's Data Model view is a work area in which you create, define, and modify data model objects (queries, groups, queries, groups, formula columns, summary columns, placeholder columns, system and user parameters, and data links) to be used in your report. In this view, objects and their property settings are represented symbolically to highlight their types and relationships. To create the query objects for your data model, you can use the Report Wizard, Data Wizard, or the Query tools in the tool palette.

Oracle Reports Builder uses the data model to determine what data to retrieve for the report. The data retrieved from the database may or may not appear in the report output.

Access

To display the Data Model view:

  • In any of the Report Editor views, choose View > Change View> Data Model.

  • Click the Data Model view button in the toolbar.

  • In the Object Navigator, double-click the Data Model view icon next to the Data Model node.

1.6.3 About the Paper Layout view

The Report Editor's Paper Layout view is a work area in which you can modify the format of your paper report. The default format for your report is defined by the information you specify in the Report Wizard. You can modify the format by working with layout objects (boilerplate text and graphic objects, frames, repeating frames, graphs, fields, anchors, file links, and report blocks). In this view, objects and their property settings are represented symbolically to highlight their types and relationships.

The Paper Layout view is similar to the Paper Design view, in that it is a work area in which you modify the format of your report. However, the Paper Design view displays only when you run your report, allowing you to preview your report and manipulate the actual, or live, data at the same time. In the Paper Design view, you can customize reports interactively, meaning that you can see the results immediately as you make each change.

Access

To display the Paper Layout view:

  • In any of the Report Editor views, choose View > Change View > Paper Layout.

  • Click the Paper Layout view button in the toolbar.

  • In the Object Navigator, double-click the Paper Layout view icon next to the Paper Layout node.

1.6.4 About the Paper Design view

The Report Editor's Paper Design view is a work area in which you can preview your paper report and manipulate the actual, or live, data at the same time. In the Paper Design view, you can customize reports interactively, meaning that you can see the results immediately as you make each change.

To edit your report, such as changing column size, the Paper Design view must be in Flex mode.

Access

The Paper Design view is displayed whenever you run a report. To run a report from the Object Navigator or any editor, click the Run Paper Layout button in the toolbar or choose Program > Run Paper Layout. To run a report from the Report Wizard, click Finish.

You can also display the Paper Design view in these ways:

  • In any of the Report Editor views, choose View > Change View > Paper Design.

    Note:

    In the Object Navigator, there is no Paper Design node; this view is displayed only after running a report.

  • Click the Paper Design view button in the toolbar.

Usage notes

To speed the execution of your report, avoid "fetching ahead" when sending report output to the Paper Design view. The following items can result in fetching ahead when referenced before the data on which they rely:

  • total number of pages/panels

  • grand totals

  • break columns that are formulas

  • break columns that have Value if Null specified

Matrix (cross-product) groups also cause fetching ahead. In order to cross-tabulate the data, Oracle Reports Builder must first fetch all of the data.

It should be noted that while these items slow down the Paper Design view, they do not affect performance when writing to a file or some other destination.

Note:

A column can cause fetching ahead even if it is not displayed. For example, a grand total may not appear in the report output, but since it is in the report, fetching ahead may still occur when Oracle Reports Builder calculates it.

1.6.5 About the Paper Parameter Form view

The Report Editor's Paper Parameter Form view is a work area in which you define the format of the report's Runtime Parameter Form. To do this, you define and modify parameter form objects (fields and boilerplate). You can select pre-defined system parameters for your report using the Parameter Form Builder, or you can create your own.

When you run a report, Oracle Reports Builder uses the Paper Parameter Form view as a template for the Runtime Parameter Form. Fields and boilerplate appear in the Runtime Parameter Form exactly as they appear in the Paper Parameter Form view. If you do not define a Runtime Parameter Form in the Paper Parameter Form view, Oracle Reports Builder displays a default Runtime Parameter Form for you at runtime.

Note:

At runtime, the Runtime Parameter Form displays only when running the paper report layout. For JSP-based Web reports, the Runtime Parameter Form displays when you run your report within Oracle Reports Builder for debugging purposes, but will not display at runtime. For more information, see Section 1.9.4, "About Parameter Forms for Web reports".

Access

To display the Paper Parameter Form view:

  • In any of the Report Editor views, choose View > Change View > Paper Parameter Form.

  • Click the Paper Parameter Form view button in the toolbar.

  • In the Object Navigator, double-click the Paper Parameter Form view icon next to the Paper Parameter Form node.

1.6.6 About the Web Source view

The Report Editor's Web Source view displays the source code for your JSP-based Web report, including HTML, JSP, and XML tags. It is a Web page where you can view and add dynamic report blocks using the Report Block Wizard, and graphs using the Graph Wizard. Experienced Web developers can edit the Web source directly in this view using JSP tags, HTML, Java, and XML.

Access

To display the Web Source view, do any of the following:

  • In any of the Report Editor views, choose View > Change View > Web Source.

  • Click the Web Source button in the toolbar.

  • In the Object Navigator, double-click the Web Source view icon next to the Web Source node.

Usage notes

  • In the Web Source view, the following languages may appear garbled: Arabic, Central European languages, Cyrillic, Greek, Hebrew, Japanese, Thai, and Turkish. To work around this issue, you can set the font names for Oracle Reports Builder in uifont.ali (in ORACLE_INSTANCE\config\FRCommonComponent\
    frcommon\guicommon\tk\admin
    ) as follows:

    [rwbuilder]
    .....AR8MSWIN1256="Courier New"
    .....CL8MSWIN1251="Courier New"
    .....EE8MSWIN1250="Courier New"
    .....EL8MSWIN1253="Courier New"
    .....IW8MSWIN1255="Courier New"
    .....JA16SJIS="MS Gothic"
    .....TH8TISASCII="Andale Duospace WT"
    .....TR8MSWIN1254="Courier New"

    You can download a copy of the Andale Duospace WT (fixed-width) font from Metalink (http://metalink.oracle.com). The ARU number is 2638552.

  • When performing a Find/Replace operation in the Web Source view and running in an Asian language (for example, Japanese) on Windows, Oracle Reports Builder fails. This problem does not occur on UNIX.

See also

Section 1.2.2, "About Web Reports"

Section 2.2.1, "About JavaServer Pages (JSPs) and servlets"

Section 4.6.3, "Adding report data to an existing Web page (HTML file)"

Section 4.6.4, "Adding a report block to a Web page"

Section 4.9.8.2.2, "Adding a graph to a JSP-based Web report"

"Oracle Reports JSP tags" in the Reference section of the Oracle Reports online Help

1.6.7 About the tool palette and toolbar

The tool palette and toolbar contain tools used to manually create or manipulate objects in the Report Editor views (excluding the Web Source view). Each tool appears as an icon. Some tools, such as the Select tool, are common to tool palettes in all Report Editor views. Other tools are specific to the views in which they appear. In Oracle Reports Builder, run your cursor over a tool to display the hint text that identifies the tool.

Tool palette

The tool palette is positioned along the left side of the Report Editor views. Click a tool to activate it for a single operation, or double-click a tool to "lock" it for multiple operations. You can hide the tool palette by choosing View > Tool Palette to deselect it.

Toolbar

The toolbar is positioned along the top of the Report Editor views. To use the tools in the toolbar, click the desired tool to perform the action. All toolbar tools also have menu equivalents. If the tool is designed to perform an action on a group of objects, it appears grayed out until one or more objects are selected. Then clicking the tool performs the action on the selected object(s).

See also

Appendix A, "Tool Palette and Toolbar Reference"