Skip Headers
Oracle® Fusion Middleware Oracle Reports User's Guide to Building Reports
11g Release 1 (11.1.1)

Part Number B32122-03
Go to Documentation Home
Home
Go to Book List
Book List
Go to Table of Contents
Contents
Go to Index
Index
Go to Master Index
Master Index
Go to Feedback page
Contact Us

Go to previous page
Previous
Go to next page
Next
PDF · Mobi · ePub

4.4 Work with the Object Navigator

This section provides procedures for the following tasks that you may perform as you work with the Object Navigator:

See also

Section 1.5.1, "About the Object Navigator"

4.4.1 Displaying a Report Editor view from the Object Navigator

To display a Report Editor view from the Object Navigator, do any of the following:

  • Double-click the icon next to the node of the view you want to display. For example, to display the Paper Layout view, double-click the view icon next to the Paper Layout node.

  • Click the node, then click the right mouse button and choose Report Editor.

  • Click the node, then choose Tools > Report Editor.

    Note:

    In the Object Navigator, there is no Paper Design node; the Paper Design view is displayed only after running a report.

See also

Section 1.6.2, "About the Data Model view"

Section 1.6.3, "About the Paper Layout view"

Section 1.6.5, "About the Paper Parameter Form view"

Section 1.6.6, "About the Web Source view"

4.4.2 Expanding and collapsing nodes

To expand or collapse a node one level, do either of the following:

  • In the Object Navigator, click the plus or minus sign next to the node.

  • Click the node, then click the Expand or Collapse tool in the tool palette.

To fully expand or collapse a node, do either of the following:

  • In the Object Navigator, click the plus or minus sign next to the node repeatedly until fully expanded.

  • Click the node, then click the Expand All or Collapse All tool in the tool palette.

  • Click the node, then choose View > Expand All or View > Collapse All.

4.4.3 Searching for nodes

To search for a specific node in the Object Navigator:

  1. Type the full of partial name of the node in the Find field.

  2. To search for the next match, click the Find Next button in the toolbar.

  3. To search for the previous match, click the Find Previous button in the toolbar.

4.4.4 Changing Object Navigator views

To view objects in the Object Navigator by object hierarchy to see the parent-child relationships:

  • Choose View > Change View > Ownership View.

To view objects in the Object Navigator by their type such as all queries under a single heading:

  • Choose View > Change View > Object Type View.

See also

Section 1.5.2, "About Object Navigator views"

4.4.5 Setting preferences for the Object Navigator

See Section 4.2.4, "Setting preferences for the Object Navigator".