Skip Headers
Oracle® Fusion Middleware Oracle Reports User's Guide to Building Reports
11g Release 1 (11.1.1)

Part Number B32122-03
Go to Documentation Home
Home
Go to Book List
Book List
Go to Table of Contents
Contents
Go to Index
Index
Go to Master Index
Master Index
Go to Feedback page
Contact Us

Go to previous page
Previous
Go to next page
Next
PDF · Mobi · ePub

25.6 Add Zeroes in Place of Blanks

A matrix report displays a juxtaposition of data – in other words, the values held in common by two different categories of data. These categories are indicated by the row and column labels.

The matrix displays this juxtaposition of values using a grid-like format. If the two categories have nothing in common, the grid at that point is empty. The matrix appears to be full of "holes". You can fill the holes using boilerplate text.

Note:

Do not confuse empty spaces in the grid with null values. A null value is an actual value fetched from the database. The spaces in a matrix report are empty because nothing has been fetched to fill them.

To replace blanks with zeroes:

  1. Open the matrix report to which you previously added the summaries.

  2. In the Object Navigator, double-click the view icon next to the Paper Layout node to display the Paper Layout view.

    Tip:

    The steps that follow require some precision in the placement of objects. Hence, you may want to magnify the view to make the process easier. Click the Magnify tool and then click somewhere in the Paper Layout view. Repeat as many times as necessary.

  3. In the Paper Layout view, click the Confine On and Flex On buttons in the toolbar to turn both modes on.

  4. From the font lists in the toolbar, choose Arial (Western), point size 10.

  5. Click the Align Right button in the toolbar.

  6. Click the Text tool in the tool palette.

  7. Click the top of the F_SUM_SAL field about 0.75 inches (2 centimeters) from its right edge. Your objective is to create an object right on top of F_SUM_SAL.

  8. Type the following:

    $0.00
    
    
  9. Click in an open area of the layout to deselect all objects.

  10. In the Object Navigator, type B_1 in the Find field. You will be taken to the object you just created. If you are viewing the Object Navigator in Ownership View (View > Change View > Ownership View), you should see B_1 underneath R_G_SUM_SAL and on the same level as F_SUM_SAL.

    Tip:

    If B_1 does not appear underneath R_G_SUM_SAL, return to the Paper Layout view, delete B_1 and try again.

    Figure 25-10 Object Navigator with new object selected

    Description of Figure 25-10 follows
    Description of "Figure 25-10 Object Navigator with new object selected"

  11. Click R_G_SUM_SAL and then ctrl-click F_SUM_SAL so that they are both selected and B_1 is deselected.

    Figure 25-11 Object Navigator with repeating frame and field selected

    Description of Figure 25-11 follows
    Description of "Figure 25-11 Object Navigator with repeating frame and field selected"

  12. Click the title bar of the Report Editor to make it the active window.

  13. Click the Confine Off button in the toolbar to turn Confine mode off.

  14. Choose Layout > Move Forward.

    Tip:

    After this operation, B_1 should appear just above R_G_SUM_SAL, as a peer rather than a child of R_G_SUM_SAL. If B_1 is still appearing as a child under R_G_SUM_SAL, repeat steps 11 through 14 until it is no longer appearing as a child of R_G_SUM_SAL.

  15. In the Paper Layout view, click the Confine On button in the toolbar to turn Confine mode back on again.

  16. Click the Paper Design button in the toolbar to display the Paper Design view.

    Tip:

    If the $0.00 is not quite aligning with the other monetary values around it, select it and use the arrow keys to move it to the desired location.

    Figure 25-12 Matrix report output with zeroes replacing blanks

    Description of Figure 25-12 follows
    Description of "Figure 25-12 Matrix report output with zeroes replacing blanks"