Skip Headers
Oracle® Fusion Middleware User's Guide for Oracle Business Intelligence Publisher
11g Release 1 (11.1.1)

Part Number E22257-03
Go to Documentation Home
Home
Go to Book List
Book List
Go to Table of Contents
Contents
Go to Index
Index
Go to Master Index
Master Index
Go to Feedback page
Contact Us

Go to previous page
Previous
Go to next page
Next
PDF · Mobi · ePub

3 Viewing a Report

This chapter describes viewing reports in BI Publisher, including interacting with report components, viewing alternative layouts, changing output options, and creating interactive pivot tables.

This chapter includes the following sections:

3.1 About Viewing Reports in BI Publisher

View a report in your Web browser using the report viewer. Depending on the report properties and your user permissions, you can select and view different layouts, interact directly with displayed data, change the output type, or send the report to someone else.

3.2 Viewing a Report

All reports reside in the catalog. The Home page displays recently viewed and your favorite reports for quick access.

To view a report:

  1. Navigate to the report.

    The Catalog displays two main reports folders.

    • Shared Folders contains the reports and folders you have been granted access to based on your role.

    • My Folders contains the reports and folders you have created.

  2. Open the appropriate folder and then click the report name or the Open link for the report. This action runs the report using the options set in the report definition.

    Note:

    Some reports are not configured for online viewing. For these reports, the Open link does not display. Select Schedule to schedule a report job. For more information, see Section 4.1, "Navigating to the Schedule Report Job Page."

    Some reports require you to select parameter values before running the report. If the report does not immediately display data, then select values for the displayed parameters and click Apply.

3.3 Using the Report Viewer Options

Figure 3-1 shows the report viewer:

Figure 3-1 Report Viewer

Report viewer

The following are options available in the report viewer. Not all options are available for all reports. See each section for more details:

3.3.1 Parameters

Reports that enable parameter value input present the parameter selection prompts in the report viewer. The presentation of the prompts varies according to the report configuration. Parameters can be presented on the top of the report viewing area, to the left side of the report viewing area, as a pop-up dialog, or as prompts on the page before the report is displayed.

The parameter prompts can be hidden or displayed by clicking the Parameters action button in the upper right area of the report viewer.

Some reports include an Apply button that you must click to redisplay the report after making parameter selections. If there is no Apply button, the report is regenerated automatically after you make a new value selection. The display of the Apply button is a parameter property setting. For information about setting this property, see "Configuring Parameter Settings for the Report" in Oracle Fusion Middleware Report Designer's Guide for Oracle Business Intelligence Publisher.

Parameter prompts may be one of the following types:

  • A list from which you can make a selection.

    A list may be displayed as a menu or all values of the list may be displayed in a series. Some lists support multiple selections. A multi-select list displays a check box next to each item. Click the box to select the item. Click the box again to deselect the item, as shown in Figure 3-2.

    Figure 3-2 Multi-Select List Displayed as a Menu

    Multi-select list displayed as menu

    Lists with many values support search. Click Search at the bottom of the scroll list to open the Search dialog. For more information, see Section 3.3.1.1, "The Parameter Search Dialog."

  • A text box into which you can type a value, as shown in Figure 3-3.

    Figure 3-3 Text Box

    Text box parameter
  • A date editor that launches a calendar from which to select the date, as shown in Figure 3-4.

    Figure 3-4 Date Editor

    Date editor

3.3.1.1 The Parameter Search Dialog

To search for a parameter value in a list, click Search at the bottom of the parameter scroll list to launch the Search dialog. Enter a search string and then choose whether the value you are looking for starts with, ends with, or contains the entered string. You can also use the "%" character as a wild card in your search string.

Figure 3-5 Parameter Search Dialog

Parameter search dialog

For parameters that support multiple value selections, the search dialog includes a shuttle interface to select multiple returned values.

3.3.1.2 Flexfield Parameter Dialog

This type of parameter applies to Oracle E-Business Suite only. Flexfield parameters display the identifier shown in Figure 3-6.

Figure 3-6 Flexfield Parameter Identifier

Flexfield parameter indicator in report viewer

Click the flexfield parameter identifier to open the parameter entry dialog. Enter values for the flexfield segments in the dialog, as shown in Figure 3-7.

Figure 3-7 Flexfield Parameter Dialog

Flexfield parameter dialog

3.3.2 Layouts

When multiple layouts are available, they are displayed as separate tabs in the report viewer page, as shown in Figure 3-8. To view the report displayed in a different layout, click its tab. Note that different layouts may have different output types enabled.

Figure 3-8 Multiple Layout Tabs

Multiple layout tabs

3.3.3 View Report and Choose Other Output Types

The View Report list contains other output types that are available for this report. When you select an option from the menu, the output automatically renders either in the browser or in a spawned application.

Figure 3-9 View Report List

View Report list

Possible output options are:

  • Interactive - this output is only available for layouts designed using BI Publisher's Layout Editor. Interactive output enables pop-up chart value displays, scrollable and filterable tables, and other interactive features for a report.

  • HTML - (Hypertext Markup Language) formats the report for browser viewing.

  • PDF - (Portable Document Format) formats the report as PDF and opens the report in Adobe Acrobat reader. This output type is optimized for printing.

  • RTF - (Rich Text Format) is a format used by word processing applications. If you have a word processing application installed, such as Microsoft Word or OpenOffice.org, then you are prompted to open the application for viewing.

  • Excel (mhtml) - select this output type to view the report in Excel if you have Microsoft Excel 2003. This option generates an MHTML format file that can be opened in Excel 2003 or later. This option supports embedded images, such as charts and logos.

  • Excel (html) - select this output type only if you are running the earlier versions of Microsoft Excel 2000 or 2002. This option generates HTML that can be opened in Excel. It does not support embedded images.

  • Excel (*.xlsx) - select this option to generate the report in Excel.xlsx (Excel XML format). If you have Excel 2007 or later installed, this option provides the best preservation of layout and formatting.

    Note:

    For output format Excel 2007 (file extension xlsx), BI Publisher does not apply any formatting for number and date. BI Publisher saves the formatting mask and the actual value (date or number) into the XLSX output file. The formatting is handled by Microsoft Excel. For example:

    • If the Microsoft Windows Region and Language of the client computer is set to English (United States), then the numbers and dates are formatted in en-US locale in the Excel 2007 output file.

    • If the Microsoft Windows Region and Language of the client computer is set to French (France), then the numbers and dates in the same Excel 2007 output file are formatted in fr-FR locale.

  • PowerPoint (mhtml) - select this output type to generate a PowerPoint file compatible with Microsoft PowerPoint 2003. Note that Microsoft PowerPoint 2010 does not support this output type. Choose PowerPoint (*.pptx) instead.

  • PowerPoint (*.pptx) - select this output type to generate a PowerPoint file in Microsoft Office Open XML format. This output type is supported for versions of Microsoft PowerPoint 2007 and later.

  • MHTML - (Mime HyperText Markup Language) format enables you to save a Web page and its resources as a single MHTML file (.mht), in which all images and linked files are saved as a single entity. Use this option to send or save HTML output and retain the embedded images and stylesheet formatting.

  • PDF/A - is an archiving standard to support reports that require long-term preservation. PDF/A is a specialized subset of the PDF standard that prohibits elements that may interfere with the preservation of the file as a self-contained document.

  • PDF/X - is for reports that require formatting for prepress graphics exchange. PDF/X is a specialized subset of the PDF standard that streamlines documents for high-quality print production output and restricts content that does not serve the print production, such as signatures, comments, and embedded multimedia.

  • Zipped PDFs - this option is only available for reports that have been designed to enable zipped PDF output. BI Publisher generates a zip file containing the report PDF output and index files.For more information on designing a report to generate a zipped PDF, see "Generating Zipped PDF Output" in Oracle Fusion Middleware Report Designer's Guide for Oracle Business Intelligence Publisher.

  • FO Formatted XML - generates an XML file with the XSL-FO information.

  • Data (XML) - displays the report XML data.

    Important:

    For Safari browser users: The Safari browser renders XML as text. To view the XML generated by the data engine as XML, right-click inside the frame displaying the data and then click View Frame Source. This is a display issue only. The data is saved properly if you choose to export the data.

  • Data (CSV) - displays the data in comma separated value format. The data must be in a simple <rowset>/<row> structure.

  • Flash - displays output for templates designed using Adobe Flash. You must have the Adobe Flash Player Plug-in installed for your Web browser.

3.3.4 Actions

The Actions menu provides more actions that you can take on the report. The complete list of possible options follows. The options that are available to you depend on your user privileges and properties set for the report. The full list of options is shown in Figure 3-10.

Figure 3-10 Action Menu Options

Action menu options
  • Add to My Favorite adds this report to your My Favorites list on your home page.

  • Edit Report enables you to update the report definition. For example, you can add or create new layouts, update the report properties, or change the default parameter values. For more information on using the report editor, see "Editing Reports" in Oracle Fusion Middleware Report Designer's Guide for Oracle Business Intelligence Publisher.

  • Edit Layout enables you to update the layout you are viewing. If the layout was created using BI Publisher's Layout Editor, then the Layout Editor launches in the browser. For more information, see "Creating BI Publisher Layout Templates" in Oracle Fusion Middleware Report Designer's Guide for Oracle Business Intelligence Publisher. If the layout is based on another supported template type (such as RTF, PDF, or Excel) then you are prompted to save the template file. You can then open it in the appropriate application.

  • Export exports the report to the default application for the output type you select (for example: Adobe Acrobat for PDF output or Microsoft Excel for Excel output).

  • Send enables you to schedule the report for immediate delivery to an e-mail address, printer, or other destination.

    The Send action launches the Schedule Report Job page where you can select the output, destination, and notification options.

    Note that you cannot send a report in Interactive mode. First, select a different output type (such as PDF or HTML) from the View Report list and then click Send.

  • Schedule creates a job to run and distribute the report. For more information, see Section 4.1, "Navigating to the Schedule Report Job Page."

  • Jobs enables you to view and manage currently scheduled jobs for this report. For more information, see Section 5.1, "About the Manage Report Jobs Page."

  • Job History enables you to view completed and running report jobs. For more information, see Section 6.1, "Viewing Report Job History and Saved Output."

  • Republish from History enables you to select a previously scheduled, completed job and specific output for viewing in the report viewer.

  • Analyzer enables you to create ad hoc pivot views of the data using the Online Analyzer. For more information, see Section 3.4, "Creating an Ad Hoc Pivot Table with the Analyzer."

  • Analyzer for Excel exports the report data to Microsoft Excel and enables you to manipulate the report using BI Publisher's plug-in for Excel. For more information, see Section 3.7, "Using the Analyzer for Excel."

  • Share Report Link enables you to generate a link that you can copy and reuse, based on the report that you are currently viewing. When you select an option, a dialog displays the URL to the report. You can control what the URL displays as follows:

    • Current Page displays the current page as shown.

    • No Header displays the current report without the BI Publisher logo, tabs, or navigation path.

    • No Parameters displays the current report without the header or any parameter selections. The Actions menu, Export, and View Report menus are still available.

    • Document Only displays the URL to the current report document only. No other page information or options are displayed.

    Note:

    Share Report Link is a report property that can be disabled. For more information on setting this and other report properties, see "Configuring Report Properties" in Oracle Fusion Middleware Report Designer's Guide for Oracle Business Intelligence Publisher.

3.4 Creating an Ad Hoc Pivot Table with the Analyzer

Note:

Your administrator must assign you the appropriate permissions to use this feature.

The online Analyzer enables you to create ad hoc analyses of your data by quickly dragging and dropping your report data elements into a pivot table structure. You can then save the pivot table as a layout for the report. The interface enables you to easily rearrange and pivot the data by dragging items to different row, column or summary positions.

You can limit the data displayed in the pivot table by defining page-level filters. The page-level filter is an element from the data set by which to specify the results displayed in the table. Drag and drop the desired element from the data pane to the Page item area to automatically create a menu of the values for that element. You can then select a value from the list to filter the results in the table to display only the data that corresponds to your selection.

After selecting all the data elements for the table, choose whether to view the Sum, Average, or Count of the data.

This topic contains two procedures:

3.4.1 Limitations of the Online Analyzer

Because the data presented in the Online Analyzer is from the source XML file, no data type information is available; therefore, number formats cannot be localized according to Report Locale preferences.

3.4.2 Accessing the Online Analyzer

To access the Online Analyzer:

  • From the Report Viewer, click Actions, then click Analyzer.

3.4.3 About the Online Analyzer Toolbar

The Analyzer toolbar enables you to perform the following functions:

  • New - creates a new empty pivot table structure. If you have already created an analysis that you want to save, you must click Save before you click New.

  • Export - enables you to export and save your pivot table as a BI Publisher layout.

  • Move decimal left - click once to display an additional decimal position. You can continue clicking to move the decimal multiple times.

  • Move decimal right - click once to remove the display of a decimal position. You can continue clicking to move the decimal multiple times.

3.5 Creating an Interactive Pivot Table

This procedure describes how to create an interactive pivot table using the Online Analyzer.

The following example displays the usage of the Analyzer with a simple Sales Analysis report:

  1. From the report viewer, click Actions and then click Analyzer.

    The Analyzer interface displays the list of data fields on a pane and an empty pivot table structure on the adjacent pane, as shown in Figure 3-11.

    Figure 3-11 Analyzer Interface

    Analyzer interface
  2. To filter by CATEGORY_NAME, drag the item to the Page Items region, as shown in Figure 3-12.

    Figure 3-12 Dragging Item to the Page Items region

    Page items region

    Now you can choose a value from the CATEGORY_NAME list to filter the page data as shown in Figure 3-13.

    Figure 3-13 Filtering the Page Data

    Filter page data
  3. To view product sales by year, drag PRODUCT_NAME into the Row Field area, and drop ORDER_YEAR into the Column Field area. Drop the SALES data into the table body area, as shown in Figure 3-14.

    Figure 3-14 Viewing Product Sales by Year

    Viewing Product Sales by Year

    You can now see the calculated sales totals as a sum of the data items.

  4. Add the dimension of ORDER_PERIOD to the table by dragging the data item over the ORDER_YEAR as shown in Figure 3-15.

    Figure 3-15 Adding the ORDER_PERIOD

    Adding the ORDER_PERIOD
  5. Now you can click the ORDER_YEAR to open it up to display each ORDER_PERIOD total. Click again to close the item and view only the ORDER_YEAR total, as shown in Figure 3-16.

    Figure 3-16 Viewing Totals

    Viewing totals

3.6 Saving the Interactive Pivot Table as a Layout

You can save the pivot table as a layout for your report by exporting it and saving it as a BI Publisher layout. The export command saves the pivot table as the BI Publisher layout type (.xpt). It then has all the features and properties of a BI Publisher layout.

To save the pivot table as a layout:

  1. Click Export.

  2. In the dialog, enter a name. The analyzer layout is saved as a layout selection for this report.

  3. Close the Online Analyzer.

  4. On the Actions menu, click Edit Report.

  5. From the Report Editor, click View a List to display the layouts in the list view.

  6. Locate your new layout in the layout table and select a locale for it.

  7. Click Save.

3.7 Using the Analyzer for Excel

Note:

Your administrator must assign you the appropriate permissions to use this feature.

You can use the Analyzer for Excel if you meet the following prerequisites:

Important:

If you have previously installed the Analyzer for Excel, and you are installing a later version, perform the following:

  1. Uninstall the current version of Analyzer for Excel from the Control panel, using the Add or Remove Programs function.

  2. Remove Xmlpreportaddin.xla from the add-ins list.

    To remove it from Word 2003: On the Tools menu, click Add-ins, then click Xmlpreportaddin.xla to remove it.

    To remove it from Word 2007 or 2010: Click the Office button, then click Excel Options, then click Add-Ins. Next to Manage: Excel Add-ins, click Go. Select the box next to Xmlpreportaddin. When prompted, delete it from the list.

3.7.1 Features

The Analyzer for Excel offers two modes: online mode and offline mode. The report designer sets the mode as a property of the report. The online mode is the default mode and is described in this section. For information on the offline mode, see "Excel Analyzer Options" in Oracle Fusion Middleware Report Designer's Guide for Oracle Business Intelligence Publisher.

The Analyzer for Excel enables you to do the following:

  • Export the results of the report query to an Excel spreadsheet

  • Log in to BI Publisher Enterprise from Excel to refresh your data, apply new parameter values, and apply layouts+ to the report data

  • Create Excel Analyzer layouts and upload them to the BI Publisher server

  • Access and run your reports from an Excel session

3.7.2 Launching the Analyzer for Excel

To launch the Analyzer for Excel:

  1. From the report viewer, click the Actions toolbar button, then select Analyzer for Excel from the list. You are prompted to save or open the report file.

  2. When you open the file in Excel, select Enable Macros from the Excel dialog.

    Note:

    You must enable macros to use the Analyzer for Excel in online mode.

    The report data displays in an Excel worksheet and the Oracle BI Publisher menu is displayed on your Excel menu bar. Note that the data are the results of the report query with no layout or filtering applied.

    You can now manipulate the report data in Excel.

    If the report has parameters, the parameter fields are displayed at the top of the worksheet, but you must log in to apply new parameter values. For more information, see the Analyzer for Excel help, or Section 3.8, "Using the BI Publisher Menu."

3.8 Using the BI Publisher Menu

You must log in to enable all the menu commands.

Login - enables you to log in to BI Publisher. For more information, see Section 3.10, "Logging in Through Excel."

Show Report Parameters - displays the updatable parameters and available layouts for the report in the Analyzer for Excel Toolbar, as shown in Figure 3-17.

Figure 3-17 Analyzer for Excel Toolbar

Analyzer for Excel Toolbar

To update the data, select a new parameter value then click Refresh Data to refresh the data in the current sheet.

To apply a layout, select the layout, then click Refresh Formatted Data. This action downloads the report as HTML into a new worksheet. Select the new worksheet to see the data with the new layout applied.

Note:

The layout that you select must have HTML as an available output.

To change the parameter values from this worksheet, select the new values, then click Refresh Data, then click Refresh Formatted Data.

Update Excel Template - If you have edited the layout and want to save the changes, then use this option to upload the updated layout to the report definition in the BI Publisher catalog.

Note that to include charts in your saved layout, you must create them on the same worksheet that is downloaded by the Excel Analyzer.

Add as New Excel Template - Use this option to upload your layout and save it to the report definition.

View Report Online - Launches the report viewer page.

Browse for Reports Online - This feature enables you to select reports from the BI Publisher catalog and open them directly in Excel. You can either download the report data to Excel, or download an existing layout to update it or to use as a starting point for a new layout. For more information, see Section 3.9, "About the Open Template Dialog."

Preferences - Select the locale and proxy settings if required.

3.9 About the Open Template Dialog

When you use the Open Template dialog to initiate the layout building process, you can then use the Update Excel Template options from the Oracle BI Publisher Menu to upload the layout directly to the appropriate report in the BI Publisher catalog.

Workspace

Select Oracle BI Publisher to browse the catalog.

Reports Pane

The Reports pane lists the reports in the selected folder. Select a report to display the available layouts in the Layout Templates pane.

Open Layout Template Downloads and opens the selected template in the Analyzer for Excel.

To start a new template, select <New> from the list of templates then select Open Layout Template; or double-click <New>.

Use the Report Browser's Up icon to move up the directory structure.

Use the View As menu to view the folder contents as Large Icons, Small Icons, List or Details.

3.10 Logging in Through Excel

When you have installed the Analyzer for Excel, you can log in to the BI Publisher from Excel, you do not have to log in to BI Publisher first.

When you have Excel open, select Log in from the Oracle BI Publisher menu. The BI Publisher login screen prompts you to enter your credentials and to select (or enter) the Report Server URL. For example: http://example.com:7001/xmlpserver.

Important:

For Oracle BI Enterprise Edition installations, the URL must point to the /xmlpserver as shown above.