11 Oracle HTTP Server

This chapter describes issues and release-specific user information associated with Oracle HTTP Server. It includes the following notes:

11.1 mod_security Reintroduced

The mod_security plug-in was removed from earlier versions of Oracle HTTP Server but is reintroduced in version This version follows the recommendations and practices prescribed for open source mod_security 2.6.2. Only documentation applicable to open source Apache mod_security 2.6.2 is applicable to the Oracle HTTP Server implementation of the module.

11.2 Installing OHS with WLS 12g

You can install Oracle HTTP Server 11.1.17 with the Oracle WebLogic Server 12c JRF/ADF combination if you do the following:

  • Install the two components separately, from scratch, and choose the correct versions (Oracle HTTP Server 11.1.17 with Oracle WebLogic Server 12c JRF/ADF)

  • During the OHS 11g installation, deselect the components associated with a WebLogic Domain.