Skip Headers
Oracle® Fusion Middleware Integration Guide for Oracle Enterprise Repository
11g Release 1 (11.1.1.7)

Part Number E15754-15
Go to Documentation Home
Home
Go to Book List
Book List
Go to Table of Contents
Contents
Go to Index
Index
Go to Master Index
Master Index
Go to Feedback page
Contact Us

Go to previous page
Previous
Go to next page
Next
PDF · Mobi · ePub

10 Configuring Your IDE to Support Integration with Oracle Enterprise Repository

This chapter describes how to configure Oracle JDeveloper, Eclipse, and Visual Studio .NET (VS .NET) to integrate with Oracle Enterprise Repository.

This chapter includes the following sections:

10.1 Configuring Oracle JDeveloper

This section contains the following topics:

10.1.1 Integrating with Oracle JDeveloper 11g R1 Patchset Releases

To create a connection between the Oracle Enterprise Repository and Oracle JDeveloper 11g Release 1 PatchSets:

  1. Install Oracle JDeveloper on your local computer.

  2. Open Oracle JDeveloper and click Help, Check for Updates. The Check for Updates dialog is displayed.

  3. Click Next. The Source page is displayed, as shown in Figure 10-1.

    Figure 10-1 Check for Updates - Source Page

    This image is described in surrounding text
    Description of "Figure 10-1 Check for Updates - Source Page"

  4. Click Next. The Updates page is displayed.

  5. Enter soa in the Available Updates box, and search for Oracle SOA Composite Editor 11.1.1.x.x.

  6. Select the SOA JDeveloper Extension update and click Next. The Download page is displayed.

    Note:

    The version of Composite editor may change based on the JDeveloper version you are using.

  7. Click Next. The Summary page is displayed.

  8. Click Finish.

  9. Restart Oracle JDeveloper. The Oracle JDeveloper window is displayed.

  10. Repeat Steps 2 to 4. The Updates page is displayed.

  11. Enter repository in the Available Updates box, and search for available updates.

  12. Select both the extensions: Oracle Enterprise Repository Adapter 111.1.1.x.x and Oracle Enterprise Repository Harvester 111.1.1.x.x and click Next. The Download page is displayed.

    Note:

    The versions of Oracle Enterprise Repository Adapter and Oracle Enterprise Repository Harvester Extensions may vary based on the JDeveloper version you are using.

  13. Click Next. The Summary page is displayed. Confirm that you have selected extensions for both Oracle Enterprise Repository and Oracle Enterprise Repository Harvester.

  14. Click Finish.

  15. Restart Oracle JDeveloper. The Oracle JDeveloper window is displayed.

  16. Click File, New. The New Gallery dialog is displayed.

  17. Select General, Connections, and then select Oracle Enterprise Repository Connection, as shown in Figure 10-2.

    Figure 10-2 New Gallery Dialog

    This image is described in surrounding text
    Description of "Figure 10-2 New Gallery Dialog"

  18. Click OK. The Create Oracle Enterprise Repository Connection dialog is displayed, as shown in Figure 10-3.

    Figure 10-3 Create Oracle Enterprise Repository Connection Dialog

    This image is described in surrounding text
    Description of "Figure 10-3 Create Oracle Enterprise Repository Connection Dialog"

  19. Enter the following information:

    • Repository URL: The URL from where a running instance of Oracle Enterprise Repository can be accessed.

    • User Name: The user name for the Oracle Enterprise Repository.

    • Password: The password for the Oracle Enterprise Repository.

  20. Click Test Connection. A success message is displayed in the Status pane.

  21. Click OK.

  22. In the Resource Palette, under IDE Connections, expand Oracle Enterprise Repository to see the application server connection that you created, as shown in Figure 10-4.

    Figure 10-4 Resource Palette

    This image is described in surrounding text
    Description of "Figure 10-4 Resource Palette"

  23. Enter a search criteria to search for assets in the Search field. A list of all the assets is displayed, as shown in Figure 10-5.

    Figure 10-5 Search Results

    This image is described in surrounding text
    Description of "Figure 10-5 Search Results"

Note:

  • You have to install SOA Harvester Solution Pack into Oracle Enterprise Repository to enable harvesting from JDeveloper. This is applicable for both JDeveloper 10g and 11g.

  • Steps 16 - 23 that describe the procedure for creating and testing the Oracle Enterprise Repository connection is same for all the patchset releases (11.1.1.x.x).

10.1.2 Integrating with Oracle JDeveloper 11g R1

To install the harvester Ant tasks in JDeveloper 11g or in SOA Suite 11g, perform the following steps:

  1. Double-click jdeveloper.exe in the jdev installation directory to open Oracle JDeveloper.

    Note:

    You should start and close the JDeveloper application at least once during this step.

  2. Unzip the harvester zip file into your JDeveloper installation. The contents of the zip file are extracted to the <jdeveloper_home>/harvester directory.

  3. Edit the tools11g.xml file to match your JDeveloper installation.

  4. Merge the contents of tools11g.xml into your JDeveloper's product preferences XML file located in the <jdeveloper_home>\system11.1.1.x.xx.xx.xx\o.jdeveloper\product-preferences.xml directory.

    If there is an existing entry "<hash n = "oracle.ideimpl.externaltools.ExternalToolList">, then replace with the contents in the tools11g.xml file. If not, add it right after the initial <ide:preferences> element.

10.1.3 Integrating with Oracle JDeveloper 10g

To configure Oracle JDeveloper to support the integration with Oracle Enterprise Repository, perform the following steps:

  1. Navigate to the Oracle_HOME\repositoryXXX\core\tools\solutions directory and unzip the 11.1.1.x.x-OER-Harvester.zip file to the Oracle JDeveloper directory. For example, if the jdeveloper.exe file is located in C:\oracle\soa, ensure that the introspector directory is unzipped into that directory.

  2. Navigate to the <jdeveloper_home>\harvester directory and right-click the tools.xml file to open in a text editor.

  3. Copy all the elements between the <tools> and </tools> elements and paste the copied elements into the tools.xml file in the <jdeveloper_home>\jdev\system\oracle.jdeveloper.10.1.xxxxx directory.

  4. Save the tools.xml file in the <jdeveloper_home>\jdev\system\oracle.jdeveloper.10.1.xxxxx directory.

  5. Start Oracle JDeveloper. In JDeveloper window, select Tools, External Tools. The following two options are displayed:

    • Submit this File into OER

    • Submit this Project into OER

  6. Select Submit this File into OER and click Edit. The Edit External Tool dialog is displayed.

  7. Click the Properties tab, and configure the missing properties to point to your Oracle Enterprise Repository server.

  8. To point to an external HarvesterSettings.xml file, add a property called settings.file, and set the value to the URL of the settings file, for example, c:\temp\MyHarvesterSettings.xml.

  9. Repeat Steps 6 to 8 for the Submit this Project into OER option.

  10. In the Applications Navigator, select a file, and right-click and then select Submit this File into OER or Submit this Project into OER.

    Note:

    Oracle JDeveloper 10g does not support multi-select correctly for external tools. Even if you multi-select, only one file is harvested.

  11. In the Edit External Tool dialog, click the Process tab.

  12. Click Change to change the JDK version to 1.6, and then click OK.

Note:

Oracle Enterprise Repository browsing is not supported from Oracle JDeveloper 10g. To make 10g assets as consumable:

  • Harvest assets from JDeveloper 10g.

  • Reharvest from SOA runtime for just WSDLs.

Also, the assets that are harvested from JDeveloper 10g or 11g cannot be used for consumption.

10.2 Configuring Eclipse

The Harvester integrates the Oracle SOA Suite artifacts to Oracle Enterprise Repository to support the visibility, impact analysis, and reusability use cases. This section describes the various steps involved in configuring Eclipse to support integration with Oracle Enterprise Repository:

10.2.1 Enable Harvesting in Eclipse using ANT

This section describes how to harvest sample artifacts into Oracle Enterprise Repository using Eclipse.

10.2.1.1 Setting up Eclipse Environment to use Harvester Using ANT

  1. In the Eclipse Workspace, select Run, External Tools, External Tools Configurations.

  2. Create a new ANT build.

  3. In the Main tab, enter the following:

    • Buildfile: <Harvester_Home>\harvester-ant.xml

    • Base Directory: <Harvester_Home>

  4. In the Targets tab, check the introspect-project option.

  5. In the Classpath tab, add the following external jars:

    • <Harvester_Home>\lib\mail-1.4.jar

    • <Harvester_Home>\lib\activation-1.0.2.jar

  6. In the Properties tab, add the following properties/values

    • project.dir/${project_loc}

    • registration.status/<"Unsubmitted", "Submitted - Pending Review", "Submitted - Under Review", or "Registered">

    • repository.url/http://localhost:7101/oer/

    • repository.username/admin

    • repository.password/<encrypted password>

  7. In the Common tab, enable the External Tools option.

  8. Click Apply, and then click Close.

After the configuration of the Properties tab, the External Tools dialog is displayed, as shown in Figure 10-6.

Figure 10-6 External Tools Dialog - Properties Tab

This image is described in surrounding text
Description of "Figure 10-6 External Tools Dialog - Properties Tab "

10.2.1.2 Harvesting in Eclipse Environment using ANT

  1. In Eclipse, click New, Project, General, Project to create a new eclipse project.

  2. Browse for any WSDL file in the file system, copy and paste it into the project that you just created.

  3. Select the project and then click Submit this file to Oracle Enterprise Repository using ANT. This invokes Harvester and submits all the artifacts in the project, as shown in Figure 10-7.

    Figure 10-7 The Console Window

    This image is described in surrounding text
    Description of "Figure 10-7 The Console Window"

10.2.2 Configure the Oracle Enterprise Repository Plug-ins

This section describes the steps to configure the Oracle Enterprise Repository Plug-ins for repository access and the prerequisites to enable this configuration. This section contains the following topics:

10.2.2.1 Configuring the Oracle Enterprise Repository Plug-ins for Repository Access

For instructions on installing the Oracle Enterprise Repository plug-ins for repository access within the Eclipse-based Enterprise Repository Plug-in for Eclipse, see Oracle Fusion Middleware Installation Guide for Oracle Enterprise Repository.

Prerequisites for Using the Oracle Enterprise Repository Plug-in for Eclipse

Perform the following steps to install the Oracle Enterprise Repository plug-in for repository access:

  1. Open Eclipse. The Eclipse window is displayed.

  2. Click Help, Install New Software. The Install dialog is displayed.

  3. Click the Add button that is found at the end of the Work With field. The Add Site dialog is displayed.

  4. Enter Oracle Enterprise Repository in the Name field and http(s)://<hostname>:<port>/<context>-web/eclipse in the Location field.

  5. Click OK.

  6. Select Oracle Enterprise Repository and Click Next.

  7. Review the items that must be installed.

  8. Click Next and accept the agreement.

  9. Click Finish.

  10. In the Confirmation dialog, click Yes to restart Eclipse.

    Click Windows, Preferences to verify if the Oracle Enterprise Repository plug-in was installed.

Uninstalling the Oracle Enterprise Repository Plug-ins

The Oracle Enterprise Repository plug-in for Eclipse can be uninstalled the same as any other Eclipse plug-in through the Eclipse software update menu.

Installing Products After Installing Oracle Enterprise Repository

If Oracle Service Bus applications are installed after the Oracle Enterprise Repository plug-in is installed, then Eclipse must be launched using the -clean flag.

10.2.2.2 Prerequisites for Using the Oracle Enterprise Repository Plug-ins for Eclipse

You should complete the prerequisites described in this section before using the Oracle Enterprise Repository plug-ins for Eclipse:

10.2.2.2.1 Assign Users to an Oracle Enterprise Repository Project

To download assets from the repository, users must be assigned to at least one Oracle Enterprise Repository project. An Oracle Enterprise Repository project administrator can assign users to projects using the Oracle Enterprise Repository Projects page.

Obtain the Eclipse integration path from the Oracle Enterprise Repository administrator. (For example, http://appserver.example.com/oer-web/eclipse).

10.2.2.2.2 Enabling the Assets-in-Progress Properties

Two system settings must be enabled to activate Assets-in-Progress when using the Oracle Enterprise Repository Plug-in for Eclipse.

This procedure is performed on the Oracle Enterprise Repository Admin screen.

  1. Click System Settings.

  2. Click General Settings in the System Settings section.

  3. Enter the cmee.asset.in-progress property in the Enable New System Setting box and click Enable to reveal this hidden property.

  4. Ensure the Asset in Progress property is set to True.

  5. Click Save.

  6. Enter the cmee.asset.in-progress.visible property in the Enable New System Setting box and click Enable to reveal this hidden property.

  7. Ensure the Asset in Progress property is set to True.

  8. Click Save.

The Registration Status list now appears in the Search section on the Oracle Enterprise Repository Assets screen. For more information about Assets-in-Progress, see Oracle Fusion Middleware Configuration Guide for Oracle Enterprise Repository.

10.2.2.2.3 SiteMinder

If Oracle Enterprise Repository is or will be configured to be secured by Siteminder, the policy server must be configured to ignore (or unprotect) the following URL:

http://appserver.example.com:8080/oer-web/eclipse/
10.2.2.2.4 Java JDK

The Java Cryptography Extension (JCE) is required. It is provided in JDK v1.4, and is available as an optional package in JDK 1.2.x through 1.5.x. Note that Oracle Enterprise Repository plug-ins for use with Eclipse 3.x require JDK v 1.5.x or later.

10.2.2.2.5 XML Parsing

Since Editor and Viewer metadata is represented as CDATA-escaped XML, some XML parsers may exceed their entity expansion limit when communicating with Oracle Enterprise Repository. For example, if you have defined a large number of Asset Types in Oracle Enterprise Repository, then you may must increase the Entity Expansion Limit of your XML parser.

On some popular parsers, the default entity expansion limit is set to 64,000. This limit can be increased on JAXP-compliant processors by passing a command-line parameter called entityExpansionLimit. The entityExpansionLimit can be increased by passing a VM argument on the Eclipse command-line (modify the Eclipse desktop shortcut). For example, set the target of the shortcut to the following:

c:\eclipse\eclipse.exe -debug -consolelog -vmargs -DentityExpansionLimit=1048576

10.2.3 Configure the Oracle Enterprise Repository Preferences

This section describes the steps to configure the Oracle Enterprise Repository connection.

When you invoke an action on a repository, such as querying or publishing assets, before repository connectivity has been established, then the Connect to Enterprise Repository wizard is either automatically displayed (in the case of querying the repository), or is launched by an explicit user gesture.

Note:

If credential information had been specified in a previous session, the wizard is displays this persisted information when it is launched.

  1. In the Credentials area, as shown in Figure 10-8, enter the server location and login credentials, as follows:

    • Repository URL: the URL of the repository server. The URL must include the host, port, and Oracle Enterprise Repository server name, for example, http://localhost:7001/oer.

    • User Name: user name to gain access to the repository.

    • Password: password to gain access to the repository.

    Figure 10-8 Establish Enterprise Repository Connection

    This image is described in surrounding text
    Description of "Figure 10-8 Establish Enterprise Repository Connection"

  2. Click the Establish Connection button to ensure enterprise repository connectivity.

    If a connection cannot be established, then an appropriate error message is displayed.

  3. In Figure 10-9, after connectivity is established, you can either:

    • Click Finish to exit.

    • Click Next to select your workspace preferences (skip to Step 4).

    Figure 10-9 Specify Workspace Preferences

    This image is described in surrounding text
    Description of "Figure 10-9 Specify Workspace Preferences "

  4. After connectivity is established, you can specify your workspace preferences:

    • Select a Repository project in Oracle Enterprise Repository that the submitted model is associated with. Asset usage is tracked in the repository and attributed to repository projects, which typically represent software development programs, business initiatives, and so on.

    • Enable usage detection: If you selected an Oracle Enterprise Repository project as the workspace default, usage detection is enabled for the default Oracle Enterprise Repository project. For more information about workspace preferences, see Oracle Fusion Middleware Configuration Guide for Oracle Enterprise Repository.

  5. Click Finish to exit.

10.2.4 Enable Automatic Usage Detection

Oracle Enterprise Repository can automatically detect asset reuse within the development environment. This enables development teams to ensure that they get asset reuse credit, regardless of whether the assets have been downloaded through Oracle Enterprise Repository or pulled from another source, such as the developer's desktop. Automated Usage Detection relies on a fingerprinting process, called Software File Identification (SFID), which tags selected files within an asset with a unique ID. This SFID is then used to detect when and where an asset is used, even if the asset was acquired through means other than the Oracle Enterprise Repository Use - Download process. An instance of usage is recorded by Oracle Enterprise Repository when tagged files within the asset are brought into the developer's IDE, and a new build or build clean occurs.

For more information, see Oracle Fusion Middleware Configuration Guide for Oracle Enterprise Repository.

Note:

Automated Usage Detection requires the installation of the Oracle Enterprise Repository Plug-in for Eclipse, and is currently compatible only with Eclipse and Eclipse-based IDEs.

  1. On the Window menu, click Preferences.

  2. Select Oracle Enterprise Repository.

  3. Select Workspace Automatic Usage Detection. The Workspace Automatic Usage Detection screen is displayed, as shown in Figure 10-10.

    Figure 10-10 Preferences - Workspace Automatic Usage Detection

    This image is described in surrounding text
    Description of "Figure 10-10 Preferences - Workspace Automatic Usage Detection "

  4. Click the Detect usage in workspace projects option, and then activate the desired usage detection features, as appropriate:

    • Enable usage detection in new workspace projects by default - monitors new projects

    • Detect usage of files on classpath - monitors files on classpath.

    • Detect usage of Java Run-time JARs - monitors Java run-time JARs

    • Cache calculated SFIDs (recommended) - caches calculated SFIDs (enhances performance)

    • Detect usage of files matching pattern - monitors files matching specified patterns

  5. Enter the appropriate information in the File Pattern text boxes:

    • Include File Pattern - Includes indicated file pattern

    • Exclude File Pattern - Excludes the indicated file pattern

  6. Specify which project directories are targets for automatic usage detection by using the individual check boxes or by using the Select All and/or Unselect All buttons.

  7. Click OK when finished.

10.3 Configuring VS .NET

Oracle Enterprise Repository integration with Visual Studio .NET provides users with the ability to easily search for and use assets from the repository without leaving the VS .NET IDE environment. Assets and any associated artifacts are downloaded directly to your VS .NET solution. Repository Access within the VS .NET solution also provides a view into Oracle Enterprise Repository that enables you to download artifacts and assets from the repository, query the repository, and view the contents of the repository.

This section contains the following topics:

10.3.1 Enable Harvesting in VS .NET

  1. In Microsoft Visual Studio, click Tools, External Tools. The External Tools dialog is displayed.

  2. Click Add. A entry is added to the Menu Contents pane.

  3. Enter the following details in the External Tools dialog, as shown in Figure 10-11:

    • In the Title field, type OER - Harvest.

    • In the Command field, click the Browse button at the end of the field and select the harvest.bat file in the harvester directory.

    • In the Arguments field, type the -dir parameter. Click the right-arrow at the end of this field and select ItemPath from the menu.

    • In the Initial Directory field, type the location of the harvester directory.

    • Select the Use Output Window option. This option enables you to monitor progress.

      Figure 10-11 External Tools Dialog

      This image is described in surrounding text
      Description of "Figure 10-11 External Tools Dialog"

  4. Click OK.

  5. Select the WSDL file in the Microsoft Visual Studio and click Tools, OER - Harvest. The Output window is displayed with the Shutdown and Clean up messages indicating that the introspection is complete.

  6. Open the Oracle Enterprise Repository home page with your username/password credentials.

  7. In Assets pane, enter the name of the WSDL as the search criteria in the Enter Search String field, and then click Search. The search results are displayed in the right pane.

  8. Select the service in the search results section, the details of the service are displayed in the bottom pane.

  9. Click the Navigator button to view the relationships.

  10. In the Oracle Enterprise Repository main page, click Admin, and then System Settings. The System Settings page is displayed.

  11. Enter Show in the Search field, and set the Show System-Supplied Relationships option to True.

  12. Click Save at the bottom of the page.

  13. In the Oracle Enterprise Repository main page, click Assets and repeat the same search that you performed in step 7. The automatic relationships that were not imported earlier are now imported.

10.3.2 Configure the Oracle Enterprise Repository Plug-ins

Oracle Enterprise Repository can automatically detect asset reuse within the development environment. This enables development teams to ensure that they get asset reuse credit, regardless of whether the assets have been downloaded through Oracle Enterprise Repository. For more information, see Section 10.3.5, "Enable Automatic Usage Detection".

10.3.2.1 Prerequisites

To configure the Oracle Enterprise Repository plug-ins, you need the following prerequisites:

  • Microsoft Visual Studio 2008.

  • Microsoft Visual J# 2005 runtime. (If J# is not installed on your computer, the installer prompts you to download the correct version from Microsoft.)

  • The VS .NET Always show solution option should be selected (Tools -> Options -> Projects and Solutions -> General).

  • Users must be assigned to at least one Oracle Enterprise Repository project. A Project Administrator can assign users to projects using the Oracle Enterprise Repository Projects page.

  • If your Oracle Enterprise Repository is or will be secured by Siteminder, then you must configure the policy server to ignore (or unprotect) the following URL to allow the OpenAPI integration to function properly:

    • http://appserver.example.com:8080/OER/services/

10.3.2.2 Installation

To install VS .NET plug-in, perform the following steps:

  1. Download the VS .NET plug-in Zip file from your Oracle Enterprise Repository instance at the following URL:

    http://appserver.example.com/oer-web/integration/dotnet/OER103-VisualStudioAddin.zip

  2. Unzip the OER103-VisualStudioAddin.zip file.

  3. Locate and run the setup.exe program.

  4. Follow the prompts, as shown in Figure 10-12, to select installation parameters.

    Figure 10-12 Oracle Enterprise Repository Adapter Add-in for Visual Studio

    This image is described in surrounding text
    Description of "Figure 10-12 Oracle Enterprise Repository Adapter Add-in for Visual Studio"

  5. Click Finish to complete the installation.

  6. Follow the instructions in Section 10.3.3, "Configure the Connection to Oracle Enterprise Repository" to configure and establish a connection to an Oracle Enterprise Repository instance from VS. NET.

10.3.3 Configure the Connection to Oracle Enterprise Repository

Follow these steps to configure and establish a connection to an Oracle Enterprise Repository instance from VS. NET.

  1. Launch Visual Studio .NET.

  2. Open the Tools menu and click Options.

  3. On the list of options, click the OER Add-in for Visual Studio .NET option, as shown in Figure 10-13, and provide the required login information.

    Figure 10-13 The Options Dialog

    This image is described in surrounding text
    Description of "Figure 10-13 The Options Dialog"

    • OER URL: The URL of the Oracle Enterprise Repository instance, for example, http://appserver.example.com/OER.

    • Note:

      Do not include index.jsp used in the default home page as part of the URL.

    • User Name: The user name to connect as.

    • User Password: The password to connect with. Passwords are case-sensitive.

    • Establish Connection: Click to verify a valid connection.

    • Automatically register downloaded Asset files: If selected, downloaded asset files are registered with the Windows Registry, as appropriate. This may be overridden on an case-by-case basis for each asset download.

  4. Click the Establish Connection button to connect to the Oracle Enterprise Repository instance you specified.

  5. Optionally, click the Advanced button to enable additional Oracle Enterprise Repository options:

    • Usage detection for VS .NET Solution Projects

    • Automated usage detection of referenced DLLs, WSDLs, and allow local caching of SFIDs (if SFID is enabled at your installation)

    • File name patterns to include and exclude

  6. Click OK when finished.

10.3.4 Assign an Oracle Enterprise Repository Project to a .NET Solution

To track the usage of downloaded assets, an Oracle Enterprise Repository project must be assigned to a .NET solution.

Note:

Before using this feature, you must be assigned to at least one Oracle Enterprise Repository Project by a Project Administrator.

  1. Open the .NET Solution Explorer.

  2. Right-click a solution in the file tree and select the Oracle Enterprise Repository Add-in for Visual Studio .NET option from the context menu.

  3. Click Assign OER Project from the submenu, as shown in Figure 10-14.

    Figure 10-14 The Solution Explorer Window

    This image is described in surrounding text
    Description of "Figure 10-14 The Solution Explorer Window"

  4. In the Project Selection window, use the Select the Oracle Enterprise Repository Project list to view the Oracle Enterprise Repository projects that you are assigned to, as shown in Figure 10-15.

    Figure 10-15 Oracle Enterprise Repository Project Selection Dialog

    This image is described in surrounding text
    Description of "Figure 10-15 Oracle Enterprise Repository Project Selection Dialog"

    Note:

    If the list is empty, you have not been assigned to any projects and the procedure must be canceled.

  5. Select an Oracle Enterprise Repository project from the list.

  6. Click Finish to save your changes.

10.3.5 Enable Automatic Usage Detection

Follow these steps to enable advanced configuration options, such as enabling automatic usage detection of DLLs, WSDLs, local caching of SFIDs, and file pattern detection.

10.3.5.1 Overview of SFID

If SFID is enabled at your installation, Oracle Enterprise Repository can automatically detect asset reuse within the development environment. This enables development teams to ensure that they get asset reuse credit, regardless of whether the assets have been downloaded through Oracle Enterprise Repository. Automated Usage Detection relies on a fingerprinting process, called Software File Identification (SFID), which tags selected files within an asset with a unique ID. This SFID is then used to detect when and where an asset is used, even if the asset was acquired through means other than the Oracle Enterprise Repository Use - Download process. An instance of usage is recorded by Oracle Enterprise Repository when tagged files within the asset are brought into the developer's IDE, and a new build or build clean occurs.

10.3.5.2 Configuring Automatic Usage Detection

  1. Launch Visual Studio .NET.

  2. Open the Tools menu and click Options.

  3. In the list of options, click Oracle Enterprise Repository Add-in for Visual Studio .NET to reopen the Login window.

  4. Click the Advanced Options button to open the Advanced Settings window. Use the Detect Usage tab to enable usage detection for VS .NET Solution Projects, as shown in Figure 10-16.

    Figure 10-16 The Advanced Settings Dialog - Detect Usage Tab

    This image is described in surrounding text
    Description of "Figure 10-16 The Advanced Settings Dialog - Detect Usage Tab"

  5. Click the Automated Usage Detection tab to enable usage detection of referenced DLLs, WSDLs, and allow local caching of SFIDs, as shown in Figure 10-17.

    Figure 10-17 The Advanced Settings Dialog - Automated Usage Detection Tab

    This image is described in surrounding text
    Description of "Figure 10-17 The Advanced Settings Dialog - Automated Usage Detection Tab"

  6. Click the File Pattern Detection tab to specify include and exclude file name patterns, as shown in Figure 10-18.

    Figure 10-18 The Advanced Settings Dialog - File Pattern Detection Tab

    This image is described in surrounding text
    Description of "Figure 10-18 The Advanced Settings Dialog - File Pattern Detection Tab"

  7. Click Done to save your settings.