Skip Headers
Oracle® Fusion Middleware User's Guide for Oracle WebCenter Portal: Spaces
11g Release 1 (11.1.1.7.0)

Part Number E10149-12
Go to Documentation Home
Home
Go to Book List
Book List
Go to Table of Contents
Contents
Go to Index
Index
Go to Master Index
Master Index
Go to Feedback page
Contact Us

Go to previous page
Previous
Go to next page
Next
PDF · Mobi · ePub

48 Working with Microsoft Office and Explorer Integration

WebCenter Portal: Spaces integrates with Microsoft Office and Windows Explorer to provide you with flexibility in managing files in a space when the content repository is Content Server. Microsoft Office shared document management functionality offers alternate ways to perform tasks that can also be performed within Spaces.

Note:

The Documents service is exposed on the Documents page and administration settings in a space only with Content Server 11g. If the connected content repository is Content Server 10g, the Documents page is not shown in a space, and the Documents service is not available in the space administration settings (Services and Roles). To use the Documents service functionality in 10g, you can create a page in a space and add Documents service task flows to the page.

The differences in Microsoft Office 2003, 2007, and 2010 mean that each version may support a particular feature in a different way, and one or more versions may not support some of the tasks described in this chapter. Each section in this chapter provides information about which Microsoft Office version supports the task described, and how that support is implemented, where there are differences. Additionally, Table 48-1 provides a quick reference summary of the Microsoft Office functionality supported by WebCenter Portal: Spaces in the different versions of Microsoft Office.

This chapter includes the following sections:

Audience

This chapter is intended for Spaces users interested in using Microsoft Office applications and Windows Explorer to manage information in a space.

48.1 What You Should Know About Microsoft Office and Explorer Integration

The following sections provide an overview of the functionality provided by integration with Microsoft Office and Windows Explorer:

48.1.1 Understanding Microsoft Office Word, PowerPoint, and Excel Integration

Using the Microsoft Office shared document management functionality, you can work with Word, PowerPoint, or Excel files in any space, including the Home space. This functionality is available in Microsoft Office 2003 and later, when the backend content repository is Content Server.

Note:

The differences in Microsoft Office 2003, 2007, and 2010 mean that each version may support a particular feature in a different way, and one or more versions may not support some of the tasks described in this chapter. Each section provides information about which version supports the task described, and how that support is implemented, where there are differences.

Table 48-1 provides a quick reference summary of the Microsoft Office functionality supported by WebCenter Portal: Spaces in the different versions of Microsoft Office.

Note:

The following browsers are supported for all versions of Microsoft Office:

  • Internet Explorer 7+

  • Firefox 3.6+

  • Safari 4+

  • Google Chrome 12+

Table 48-1 Microsoft Office Version Support Summary

Task 2003 2007 2010

Creating a Space from a Microsoft Office Document

Not supported

Supported

Not supported

Opening a Microsoft Word, Excel, or PowerPoint file from Spaces:

Supported

Supported

Supported

Closing a File

Supported

Supported

Supported

Working with the Microsoft Office Task Pane (2003 and 2007 only)

Supported

Supported

Not supported

Displaying and Hiding the Microsoft Office Task Pane:

Supported

Supported

N/A

Microsoft Office Task Pane: Top section

Task pane top section dropdown menu

Supported

Supported

N/A

User or space name. See Table 48-2.

Supported

Supported

N/A

Open Site in Browser. See Table 48-2.

Supported

Supported

N/A

Change Site Title

Not supported

Not supported

N/A

Change Site Settings. See Table 48-2.

Supported

Supported

N/A

Disconnect from Workspace

Not supported

Not supported

N/A

Delete Workspace

Not supported

Not supported

N/A

Microsoft Office Task Pane: Status section

Task pane Status section 2003 Task pane Status section menu

Supported

Supported

N/A

User who checked out the file

Supported

Supported

N/A

Check in

Supported

Supported

N/A

Schedule a Meeting. See Table 48-2.

Supported

Supported

N/A

Call

Not supported

Not supported

N/A

Send Mail

Supported

Supported

N/A

Additional Actions

Not supported

Not supported

N/A

Add to Outlook Contacts. See Table 48-2.

Supported

Supported

N/A

Outlook Properties. See Table 48-2.

Supported

Supported

N/A

Microsoft Office Task Pane: Members section

Task Pane Members section Task pane Members section menu

Supported

Supported

N/A

User who checked out the file

Supported

Supported

N/A

Listing of current people connections

Supported

Supported

N/A

Add new members (not supported for Home space)

Supported

Supported

N/A

Send e-mail to all members

Supported

Supported

N/A

Schedule a Meeting

Not supported

Not supported

N/A

Additional Actions

Not supported

Not supported

N/A

Edit Site Group Membership

Not supported

Not supported

N/A

Edit User Information

Not supported

Not supported

N/A

Add to Outlook Contacts

Not supported

Not supported

N/A

Outlook Properties

Not supported

Not supported

N/A

Microsoft Office Task Pane: Tasks section

Task pane Tasks section

Not supported

Not supported

N/A

Microsoft Office Task Pane: Documents section

Task pane Documents section

Supported

Supported

N/A

Managing the Currently Open File

Task Pane Documents Section: Current File Menu
     

Open in Microsoft Office Xxxxx

Not supported

Not supported

N/A

Delete

Not supported

Not supported

N/A

Alert Me About This Document

Not supported

Not supported

N/A

Check Status. See Table 48-2.

Supported

Supported

N/A

Document Updates

Not supported

Not supported

N/A

Save Updatable Copy

Not supported

Not supported

N/A

Create Document Workspace

Not supported

Not supported

N/A

Publish Back to Source Location

Not supported

Not supported

N/A

Managing Other Files in the Current Space

Task Pane Documents Section: Other Fles Menu
     

Open in Microsoft Office Xxxxx

Supported

Supported

N/A

Delete

Not supported

Not supported

N/A

Alert Me About This Document

Not supported

Not supported

N/A

Managing Folders:

Task Pane Documents Section: Folder Menu
     

View Contents.

Supported

Supported

N/A

Delete

Not supported

Not supported

N/A

Other action in the Documents section:

     

Add new document

Supported

Supported

N/A

Add new folder

Supported

Supported

N/A

Alert me about documents

Not supported

Not supported

N/A

Microsoft Office Task Pane: Links section

Task pane Links section

Supported

Supported

N/A

Documents and URL links defined in Spaces to the current file

Supported

Supported

N/A

Add new link

Not supported

Not supported

N/A

Alert me about links

Not supported

Not supported

N/A

Microsoft Office Task Pane: Document Information section

Task pane Document Info section

Supported

Not supported

N/A

Document Information

Supported

Not supported

N/A

Restrict permission

Not supported

Not supported

N/A

Alert me about this document

Not supported

Not supported

N/A

Check out or Check in

Supported

Not supported

N/A

Version history

Supported

Not supported

N/A

Microsoft Office Task Pane: Bottom section

Task pane bottom section

Supported

Supported

N/A

Get Updates. See Table 48-2.

Supported

Supported

N/A

Options. See Table 48-2.

Supported

Supported

N/A

Date and time that the file was last modified.

Supported

Supported

N/A


48.1.2 Understanding Microsoft Windows Explorer Integration

In Windows Explorer, you can manage the folders and files in a space when the backend content repository is Content Server. To use this functionality, you create a network place in Windows Explorer for the space documents. See Section 48.4, "Working with Microsoft Windows Explorer Integration."

48.2 Configuring Microsoft Office Integration with Spaces

To allow for full integration of Microsoft Office with Spaces, your system administrator must complete the steps detailed in "Managing Microsoft Office Integration" in Oracle Fusion Middleware Administrator's Guide for Oracle WebCenter Portal.

48.3 Working with Microsoft Word, PowerPoint, and Excel Integration

Spaces integrates with the Microsoft Office shared document management functionality for working with Microsoft Word, Excel, or PowerPoint files. This functionality is available in Microsoft Office 2003 and later, when the backend content repository is Content Server. For more information, see Section 48.1.1, "Understanding Microsoft Office Word, PowerPoint, and Excel Integration."

Many of the tasks you can perform using the Microsoft Office shared document management functionality can also be performed in Spaces, and described in Chapter 43, "Working with the Documents Service Task Flows and Document Components."

This section provides steps to perform the following tasks using Microsoft Office shared document management:

Note:

Spaces does not implement administrative features of the Microsoft Office shared document management functionality, such as creating a workspace using the task pane, deleting a workspace, or changing a workspace title.

48.3.1 Creating a Space from a Microsoft Office Document

Note:

This feature is available only in Microsoft Office 2007. It is not available in Microsoft Office 2003 or 2010.

With Microsoft Office 2007, you can create a space from a Microsoft Office document, as long as your permissions on the document are the same as your permissions in Spaces.

To create a space from a Microsoft Office document:

  1. If you are using Internet Explorer as a browser, add Spaces to your list of trusted sites in the browser settings.

  2. In the Microsoft Office document, click the Office Button (Figure 48-1) in the top left corner of the Microsoft Office application.

    Figure 48-1 Office Button in Microsoft Office

    Office Button in Microsoft Office
  3. From the Publish menu, select Create Document Workspace (Figure 48-2).

    Figure 48-2 Creating a Space from an Office Document

    Creating a Space from an Office Document
  4. The Microsoft Office application displays the Document Management task pane, displaying the file name as the default workspace name.

    Figure 48-3 Document Management Task Pane: Document Workspace

    Document Management Task Pane: Document Workspace
  5. In the Document Workspace name field, type a name for the space if you want to change the default name.

  6. In the Location for new workspace field, type the Explorer URL for the Spaces instance. For example:

    http://myserver.example.com:8888/wcsdocs/conn/myserver-ucm11g/spaces
    /WebCenter/
    

    You can find this URL in the About Space dialog for an existing space, as described in Section 51.6, "Viewing Information About a Space."

  7. Click Create.

  8. At the prompt, enter your Spaces login credentials.

Spaces creates the new space.

In Microsoft Office, the Status section of the Microsoft Office task pane (see Table 48-2) displays one of the following status messages:

This document is up to date.  If you have unsaved changes, you must save the document before you can update the workspace copy.

A copy of this document is stored in a Document Workspace.  Changes made to your document have not been udpated in the workspace copy.

If you update the document in Microsoft Office, you can simply click the Update Workspace Copy link to synchronize the document with the version in the space (on the server).

48.3.2 Opening and Editing a File

When you open a Microsoft Office file from Spaces (using any browser), the file is automatically checked out of the Content Server repository. When you refresh the page in Spaces, the Status column for the file shows a Checked Out icon.

To make your changes available to other users, you can save and close it in Microsoft Office, or explicitly check the file in using Microsoft Office.

Note:

(For all browsers, with the exception of Internet Explorer: If you are using Windows 7 or a 64-bit machine, you must install the Java plugin available at http://support.mozilla.com to edit a Microsoft Office file. This plugin is included in Java 6 Update 15 and above.

To open a Microsoft Word, Excel, or PowerPoint file from Spaces in-place in its Microsoft Office application:

  1. On the Documents page, or in a Documents service task flow on a page, click in the row of the file you want to edit, but not on the file name.

    Alternatively, you can edit an open file in the Document Viewer preview pane.

  2. Depending on your view and the file type, perform one of the following actions:

    • On the Documents page or in a Documents service task flow, from the File menu or the context (right-click) menu, select the Edit action that opens the file in-place in its Microsoft Office application. For example, for Microsoft Word files, select Edit with Word (Figure 48-4)

      Figure 48-4 Open a File in Microsoft Word

      Open a Document in Microsoft Word
    • In the Document Viewer preview pane, click the Edit action.

    Note:

    If the file is already checked out by another user, the File in Use dialog opens. See Section 48.3.2.1, "Opening a File Already Checked Out By Another User."

  3. If prompted, enter the same credentials used to log in to Spaces to open the file in-place in its corresponding application.

    Note:

    The user name and password must contain only ASCII characters. A user name or password containing multi-byte characters cannot be successfully authenticated.

    Figure 48-5 Microsoft Office 2003 Shared Workspace Task Pane

    Microsoft Office 2003 Shared Workspace Task Pane
  4. When the file opens, it is automatically checked out of the Content Server repository, indicated by the Checked Out icon (Figure 48-6).

    Figure 48-6 Checked Out Icon in Spaces

    Checked Out Icon in WebCenter Spaces
  5. Make required updates, then save and close the file.

    The modified file is automatically checked back in.

You can use the Microsoft Office task pane to open other files in the space directly from Microsoft Office, instead of from Spaces. See Section 48.3.3.7, "Managing Other Files in the Current Space."

48.3.2.1 Opening a File Already Checked Out By Another User

If the file that you attempt to open is already checked out by another user, the File In Use dialog opens (Figure 48-7).

Figure 48-7 File in Use Dialog

File in Use Dialog

In the File In Use dialog, select the desired option:

  • Open a Read Only copy to open the file in its default application to view it.

  • Create a local copy and merge your changes later is not supported.

  • Receive notification when the original copy is available to open a read-only copy of the file until it is available for editing. When the file is available, the File Now Available dialog (Figure 48-8) notifies you; in the dialog, click Read-Write to change the read-only state to editable.

    Figure 48-8 File Now Available Dialog

    File Now Available Dialog

48.3.3 Working with the Microsoft Office Task Pane

Note:

The Microsoft Office task pane is available only in Microsoft Office 2003 and 2007. Microsoft Office 2010 does not include a task pane.

The Microsoft Office task pane provides information pertaining to the currently open file and access to tasks for all folders and files in the current space, as described in Table 48-2.

Table 48-2 Microsoft Office Task Pane for Files in a Space

Task Pane Area Description

Top section in Microsoft Office 2003:

Task pane top section 2003

Top section in Microsoft Office 2007:

Task pane top section 2007

Dropdown menu:

Task pane top section dropdown menu

For a file in the Home space:

  • Shows the user name.

  • Open site in browser. Click to display the Spaces Home page.

For a file in a space:

  • Shows the space name.

  • Open site in browser. Click to display the space Home page.

Additionally, the top section provides a dropdown menu of actions available for the user or space:

  • Open Site in Browser. See above.

  • Change Site Title. Not supported.

  • Change Site Settings. For the Home space, displays the Spaces Home page; for a space, displays the Settings tab of the space.

  • Disconnect from Workspace. Not supported.

  • Delete Workspace. Not supported.

Status section in Microsoft Office 2003:

Task pane Status section 2003

Status section in Microsoft Office 2007:

Task pane Status section 2007

Dropdown menu:

Task pane Status section menu

Displays information only if the file is checked out.

Shows the following information:

Additionally, the Status section provides a dropdown menu of actions available for the user:

  • Schedule a Meeting. Opens the Microsoft Outlook calendar scheduler.

  • Call. Not supported.

  • Send Mail. Opens a Microsoft Outlook message with the To field populated with the mail address that is specified for the user in Spaces. See Section 48.3.3.13, "Sending a Message." This selection has the same effect as clicking the user name in the Members section.

  • Additional Actions. Not supported.

  • Add to Outlook Contacts. Opens the Microsoft Outlook Contacts page populated with contact information for the user.

  • Outlook Properties. Opens the Microsoft Outlook E-mail Properties dialog.

Members section:

Task Pane Members section

Dropdown menu:

Task pane Members section menu

For a file in the Home space:

For a file in a space:

Additionally, the Members section provides a dropdown menu of actions available for the listed member(s). The actions in this menu are not supported.

To send a message to any member, simply click the member's user name to open a Microsoft Outlook window with the To field populated with the mail address that is specified for the member in Spaces.

Tasks section:

Task pane Tasks section

Not supported.

Documents section:

Task pane Documents section

Provides access to other files in the current space directly from Microsoft Office.

Links section:

Task pane Links section

Shows all document and URL links defined in Spaces to the currently open file.

  • Sort by. Select from the menu to sort the list of links by Creation Date, Modified Date, URL, Ascending, or Descending.

  • Lists all links for the currently open file. See Section 48.3.3.9, "Viewing Link Targets." Click a link to navigate to the linked object.

  • Add new link. Not supported

  • Alert me about links. Not supported

Document Information section (Microsoft Office 2003 only):

Task pane Document Info section

Provides information about the currently open document:

Bottom section:

Task pane bottom section

Includes:

  • Get Updates. Refreshes the files and associated information from the Spaces server.

  • Options. Opens the Service Options dialog. Refer to the Microsoft Office online help for more information.

  • Shows the date and time that the file was last modified.


The following sections describe the tasks you can perform using the Microsoft Office task pane:

48.3.3.1 Displaying and Hiding the Microsoft Office Task Pane

Note:

The Microsoft Office task pane is available only in Microsoft Office 2003 and 2007. Microsoft Office 2010 does not include a task pane.

In Microsoft Office 2003, the task pane displays by default when you open a file, whereas in Microsoft Office 2007, the task pane does not display by default.

You can manage the display of the Microsoft Office task pane as described in the following sections:

48.3.3.1.1 Displaying or Hiding the Task Pane Manually

To display or hide the Microsoft Office task pane manually:

In Microsoft Office 2003:

  • From the Tools menu, select Shared Workspace to toggle between displaying and hiding the task pane.

In Microsoft Office 2007:

  1. Click the Office Button (Figure 48-9) in the top left corner of the Microsoft Office application.

    Figure 48-9 Office Button in Microsoft Office

    Office Button in Microsoft Office
  2. From the Server menu, select Document Management Information to toggle between displaying and hiding the Document Management task pane (Figure 48-10).

    Figure 48-10 Microsoft Office 2007 Document Management Task Pane

    MS Office 2007 Document Management Task Pane
48.3.3.1.2 Displaying or Hiding the Task Pane By Default

To display or hide the Microsoft Office task pane automatically by default every time you open a Microsoft Word, Excel, or PowerPoint file:

In Microsoft Office 2003:

  1. From the Tools menu, select Options.

  2. In the Options dialog, on the General tab, click Service Options.

  3. In the Shared Workspace category, select or deselect the check box The document is part of a workspace or SharePoint site to respectively display or hide the task pane by default.

In Microsoft Office 2007:

  1. At the bottom of the Microsoft Office task pane, click Options (Figure 48-11).

    Figure 48-11 Options Link in Task Pane (Microsoft Office 2007)

    Options Link in Task Pane
  2. In the Service Options dialog, select or deselect the check box The document is part of a workspace or SharePoint site to respectively display or hide the task pane by default.

48.3.3.2 Adding a File

Using the Microsoft Office shared document management functionality, you can add a new file to the Content Server repository, exposing the file in a space, as described in the following sections:

Note:

Other methods to add a file to the connected content repository are:

48.3.3.2.1 Saving a File As a New File in a Space

To save a local Microsoft Word, Excel, or PowerPoint file to a space:

Note:

This feature is supported in Microsoft Office 2003 and 2007 only.

  1. Add the space as a new network place in Windows Explorer, as described in Section 48.4, "Working with Microsoft Windows Explorer Integration."

  2. Open the file in its Microsoft Office application.

  3. (In Microsoft Office 2007 only) Set save options for shared documents:

    1. Click the Office Button in the top left corner of the Microsoft Office application, then click Word Options (Figure 48-12) at the bottom of the menu.

      Figure 48-12 Office Button Menu: Word Options

      Office Button Menu: Word Options
    2. In the Word Options dialog, select Save in the left pane (Figure 48-13).

    3. Under Offline editing options for document management server files, select The web server (Figure 48-13).

      Figure 48-13 Word Options Dialog

      Word Options Dialog
  4. Publish the file to the space:

    In Microsoft Office 2003. From the File menu, select Save As.

    In Microsoft Office 2007. Click the Office Button, then select either:

    • Publish, then Document Management Server.

    • Or, Save As, then Application Document.

  5. In the Save As dialog, select the space network place, then click Save. For more information about space network place URLs, see Section 48.4.1, "Adding a Space as a Network Place."

  6. Enter login credentials for Spaces, then click OK.

  7. In Spaces, on the Documents page of the space, click the Refresh icon to confirm that the file was added.

    Note:

    To make the file visible to others, you must check the file in. See Section 48.3.3.5, "Checking a File In."

  8. To display the Microsoft Office task pane in the open file, see Section 48.3.3.1, "Displaying and Hiding the Microsoft Office Task Pane."

48.3.3.2.2 Adding a New File Using the Task Pane

To add a new file to a space using the Microsoft Office task pane:

Note:

This feature is available with Microsoft Office 2003 and 2007. Microsoft Office 2010 does not include a task pane.

  1. Open a Microsoft Word, Excel, or PowerPoint file to use the Microsoft Office shared document management functionality (see Section 48.3.2, "Opening and Editing a File").

  2. At the bottom of the Documents section of the task pane, click Add new document (Figure 48-14).

    Figure 48-14 Task Pane Documents Section: Adding a New File

    Task Pane Documents Section: Bottom Area

    The Add New Document dialog opens (Figure 48-15).

    Figure 48-15 Add New Document Dialog

    Add New Document dialog
  3. Browse to the file that you want to add to the current space.

    Note:

    Spaces supports files up to 2GB in size.

    The check box Make workspace updates available when I open my copy is not supported.

  4. Click OK.

    The new file displays at the top of the document list in the Documents section of the Microsoft Office task pane. When you refresh the Documents page of the space in Spaces, the file appears in the document list in alphabetical order.

48.3.3.3 Adding a New Folder

Using the Microsoft Office shared document management functionality, you can add a new folder to the Content Server repository, exposing the folder in a space.

Note:

Other methods to add a new folder to a space are:

To add a new folder to a space using the Microsoft Office task pane:

  1. Open a Microsoft Word, Excel, or PowerPoint file in the space to use the Microsoft Office shared document management functionality (see Section 48.3.2, "Opening and Editing a File").

  2. At the bottom of the Documents section of the task pane, click Add new folder (Figure 48-16).

    Figure 48-16 Task Pane Documents Section: Adding a New Folder

    Task Pane Documents Section: Adding a New Folder

    The Add New Folder dialog opens (Figure 48-17).

    Figure 48-17 Add New Folder Dialog

    Add New Document Dialog
  3. Enter a name for the new folder, then click OK.

    Note:

    The rules for folder names follow the Windows Explorer standards.

    The new folder displays at the top of the document list in the Documents section of the Microsoft Office task pane. When you refresh the Documents page of the space in Spaces, the folder appears in the folder list in alphabetical order.

48.3.3.4 Checking a File Out

Note:

To check any file out using the Spaces application, see Section 43.12.1, "Checking a File Out."

When you open a Microsoft Office file in a space using the Microsoft Office shared document management functionality, the file is automatically checked out from the Content Server repository. If you have been granted the appropriate permissions, you can open and check a file out in two environments:

  • From Spaces. Open a file in-place (see Section 48.3.2, "Opening and Editing a File") to automatically check out the file.

  • (Microsoft Office 2003 and 2007) From the Microsoft Office task pane. In the Documents section of the task pane, click a file name to automatically check out the file and open it in its default Microsoft Office application.

48.3.3.4.1 Checking the Currently Open File Out Again After Checking It In

After you check a file in (see Section 48.3.3.5, "Checking a File In"), the file remains displayed in Microsoft Office until you close it (see Section 48.3.4, "Closing a File"). If you want to check in further changes to the file, it must be checked out again:

  • In Microsoft Office 2003. In the Document Information section of the Microsoft Office task pane, you can optionally click Check out to check the file out again (Figure 48-18). However, even if you do not explicitly check out the file, you can continue to edit the file, then save it, and the Status and Document Information sections of the task pane automatically provide a Check in link to check the changed file back in to the repository.

    Figure 48-18 Checking Out a Checked In File

    Checking Out a Checked In File
  • In Microsoft Office 2007 and 2010. When you check a file in, the Check In dialog (Figure 48-22) provides a check box labeled Keep the document checked out after checking in this version:

    • Select the check box to keep the file checked out after checking in the current version. This allows you to refresh the version of the file available to other users, yet still retain the checked out status to make further changes.

    • Deselect the check box to check the file in and cancel the checked out status.

    If you deselect the check box, you can optionally check the file out again:

    • Click Edit Document in the area below the toolbar (Figure 48-19).

      After you check a file in, Microsoft Office 2007 locks editing that file until you click Edit Document.

      Figure 48-19 Checking Out and Editing the Current Document

      Checking Out and Editing the Current Doc

48.3.3.5 Checking a File In

When you open a file using the Microsoft Office shared document management functionality, you can check it back in to the repository, whether or not you have made changes to it.

Note:

This feature is available with Microsoft Office 2003 and 2007. Microsoft Office 2010 does not include a task pane.

In Microsoft Office 2010, you can find file checkin and checkout information on the Info tab (from the File menu, select Info). When you open a Microsoft Office 2010 file from Spaces (using any browser), the file is automatically checked out of the Content Server repository, changes are (temporarily) applied when saved, and the file is automatically checked in when the file is closed, with a default checkin comment.

Note:

Intermittently saving the file saves it on the server, but changes are not visible to others until you check the file in. To update the file stored in the Content Server repository, you must explicitly check it in as described in this section. If you close the Microsoft Office application and do not check the file in when prompted, your changes are lost.

To check a file in:

  1. In the Status section of the Microsoft Office task pane, click Check in (Figure 48-20).

    Figure 48-20 Status Section in MS Office 7: Checking In a File

    Status Section in MS Office 7: Checking In a File

    Notes:

    • If the Check in link does not display, click the icon for any other section, then return to the Status section to refresh the pane.

    • In Microsoft Office 2003, you can also find Check in in the Document Information section of the task pane.

  2. In Microsoft Office 2003. In the Check In Comments dialog (Figure 48-21), optionally enter comments about the changes made to the file since it was last checked out.

    Figure 48-21 Check In Comments Dialog (Microsoft Office 2003)

    Check In Comments Dialog (Office 2003)

    In Microsoft Office 2007. In the Check In dialog (Figure 48-22), optionally enter comments about the changes made to the file since it was last checked out, and select the state in which to leave the file:

    Figure 48-22 Check In Dialog (Microsoft Office 2007)

    Check In Comments Dialog (Office 2007)
    • Select the check box to keep the file checked out after checking in the current version. This allows you to refresh the version of the file available to other users, yet still retain the checked out status to make further changes.

    • Deselect the check box to check the file in and cancel the checked out status. To check the file out again, see Section 48.3.3.4.1, "Checking the Currently Open File Out Again After Checking It In."

  3. Click OK.

    If the file was modified since its prior version, it is automatically saved and checked in to Spaces as a new version. If check in comments were entered in the Check In dialog, a new file revision is created with the new comments, which display as the file description in Spaces (Figure 48-23).

    Figure 48-23 Documents Listing in Spaces after Check In

    Documents Listing in WebCenter Spaces after Check In
  4. After checking a file in, the file remains displayed in Microsoft Office until you close it (see Section 48.3.4, "Closing a File"). If you wish to make further changes to the file, see Section 48.3.3.4.1, "Checking the Currently Open File Out Again After Checking It In."

  5. When you have finished making changes and checking in the file, close the Microsoft Office application (see Section 48.3.4, "Closing a File").

48.3.3.6 Managing the Currently Open File

Note:

This feature is available with Microsoft Office 2003 and 2007. Microsoft Office 2010 does not include a task pane.

To manage the currently open file using the Microsoft Office task pane:

  1. In the Documents section of the task pane, click the dropdown menu icon to the right of the file name (Figure 48-24).

    Figure 48-24 Task Pane Documents Section: Current File Menu

    Task Pane Documents Section: Current File Menu
  2. Select an available action, as described in Table 48-3:

    Table 48-3 Dropdown Menu Actions for Currently Open File

    Menu Action Description

    Open in Microsoft Office Application

    Not applicable.

    Delete

    Not supported. To delete a file in a space, you must use the Spaces application (see Section 43.16, "Deleting Folders and Files") or Windows Explorer (see Section 48.4, "Working with Microsoft Windows Explorer Integration").

    Alert Me About This Document

    Not supported. Opens the home page of the space in Spaces.

    Check Status

    Displays the Status section of the task pane.

    Document Updates

    Not supported.

    Save Updatable Copy

    Not supported.

    Create Document Workspace

    Not supported.

    Publish Back to Source Location

    Not supported.


48.3.3.7 Managing Other Files in the Current Space

Note:

This feature is available with Microsoft Office 2003 and 2007. Microsoft Office 2010 does not include a task pane.

To manage a file other than the currently open file in the current space using the Microsoft Office task pane:

  1. In the Documents section of the task pane, navigate to the file.

    Note:

    Navigating upward in the folder hierarchy from the current document is not supported; you can drill down and then back up to the current level.

  2. To open the file, click its name.

    Depending on the file type, the file opens as described in Section 48.3.2, "Opening and Editing a File" for Microsoft Word, Excel, and PowerPoint files, or Section 43.10, "Opening a File" for other file types (such as HTML files or images).

    Note:

    If you have OpenOffice installed, an error may occur when attempting to open a file from the task pane. To resolve the error, uninstall OpenOffice.

  3. To perform other actions, click the dropdown menu icon to the right of a file name (Figure 48-25):

    Figure 48-25 Task Pane Documents Section: Other Files Menu

    Task Pane Documents Section: Other Fles Menu
  4. Select an available action, as described in Table 48-4:

    Table 48-4 Dropdown Menu Actions for Other Files

    Menu Action Description

    Open in Microsoft Office Application

    Attempts to check out the file: if checked out by another user, it opens read-only; if not checked out, the file opens in its Microsoft Office application for editing. For more information, see Section 48.3.2, "Opening and Editing a File."

    Delete

    Not supported. To delete a file in a space, you must use the Spaces application (see Section 43.16, "Deleting Folders and Files") or Windows Explorer (see Section 48.4, "Working with Microsoft Windows Explorer Integration").

    Alert Me About This Document

    Not supported. Opens the home page of the space in Spaces.


48.3.3.8 Managing Folders

Note:

This feature is available with Microsoft Office 2003 and 2007. Microsoft Office 2010 does not include a task pane.

To manage a folder under the current folder using the Microsoft Office task pane:

  1. In the Documents section of the task pane, navigate to the folder.

    Note:

    Navigating upward in the folder hierarchy from the current document is not supported; you can drill down and then back up to the current level.

  2. To open the folder, click its name.

  3. To perform other actions, click the dropdown menu icon to the right of the folder name (Figure 48-26):

    Figure 48-26 Task Pane Documents Section: Folder Menu

    Task Pane Documents Section: Folder Menu
  4. Select an available action, as described in Table 48-5:

    Table 48-5 Dropdown Menu Actions for a Folder

    Menu Action Description

    View Contents

    Refreshes the list of files with the contents of the folder only (same effect as clicking the folder name). Click the folder name to refresh to the original list.

    Delete

    Not supported. To delete a folder in a space, you must use the Spaces application (see Section 43.16, "Deleting Folders and Files") or Windows Explorer (see Section 48.4, "Working with Microsoft Windows Explorer Integration").


48.3.3.9 Viewing Link Targets

Note:

This feature is available with Microsoft Office 2003 and 2007. Microsoft Office 2010 does not include a task pane.

The Links section of the Microsoft Office task pane lists the links defined in Spaces that are associated with the currently open file (Figure 48-27). Files can have links to related documents, discussions, announcements, events, and notes; the Links section in the task pane shows the links to associated documents and notes.

Links are prefixed with the name of the service with which they are associated. For example, a link to another document is prefixed Document, a link to a note is prefixed URL.

Figure 48-27 Task Pane Links Section

Task Pane Links Section

To display the target of a link, simply click the link:

  • Document links open in the same way as files in the Document section, namely Microsoft Word, Excel, and PowerPoint files open in Microsoft Office with a task pane, and other file types open in their default viewer or a browser.

  • URL links open a browser window displaying the link target.

48.3.3.10 Viewing Document Information

Note:

This feature is available with Microsoft Office 2003 and 2007. Microsoft Office 2010 does not include a task pane.

In Microsoft Office 2003: The Document Information section of the Microsoft Office task pane shows the user who last modified the file and the modified date (Figure 48-28).

Figure 48-28 Task Pane Document Information Section (Microsoft Office 2003 Only)

Task Pane Document Information Section

In Microsoft Office 2007. Information about the user who last modified the file and the modified date is shown in the Version History. See Section 48.3.3.11, "Working with File Version History."

48.3.3.11 Working with File Version History

Whenever you check in a file or upload a file into a folder that already contains a file of the same name, Spaces creates a new version of the file. When a file has multiple versions, it has a version history.

Note:

To use the Spaces application to work with the version history of a file in any connected content repository, see Section 43.21, "Viewing and Deleting File Version History."

In Microsoft Office 2003: To view the version history of the currently open file using the Microsoft Office task pane:

  1. In the Document Information section of the task pane, click Version history (Figure 48-29).

    Figure 48-29 Task Pane Document Information Section: Version History

    Task Pane Document Information Section: Version History

    The version history dialog for the file opens (Figure 48-30):

    Figure 48-30 Version History for Currently Open File in Microsoft Office 2003

    Version History for Currently Open File

    In the version history dialog, select a file version, then select the desired action:

    • Open to open the selected file version read-only.

    • Restore is not supported.

    • Delete to delete the selected file version (inactive for the most recent version).

    • View Comments to display the comments entered for the selected file version (most useful when the comments are especially long).

  2. To open the Documents page in the current space, click Modify settings for document versions.

In Microsoft Office 2007: To view the version history of the currently open file:

  1. Click the Office Button (Figure 48-31) in the top left corner of the Microsoft Office application.

    Figure 48-31 Office Button in Microsoft Office

    Office Button in Microsoft Office
  2. From the Server menu, select View Version History.

    The version history dialog for the file opens (Figure 48-32):

    Figure 48-32 Version History for Currently Open File in Microsoft Office 2007

    Version History for Current File in Office 2007
  3. In the version history dialog, select a file version, then select the desired action:

    • Open to open the selected file version read-only.

    • Compare to compare the selected file version with the currently open file.

    • Restore is not supported.

    • Delete to delete the selected file version (inactive for the most recent version).

  4. To view the check in comments for a file version, click the link under Comments.

  5. To open the Documents page in the space, click the link next to Versions saved to.

In Microsoft Office 2010: To view the version history of the currently open file:

  • From the File menu, select Info.

    The Info tab shows version history information on the Info tab in the Versions section. Refer to the Microsoft Office online help for more information.

48.3.3.12 Adding Members to a Space

Note:

To add members to a space using the Spaces application, see Section 54.3, "Managing Members and Assigning Roles."

If you are granted the Moderator role or Manage All permissions in a space, you can add new members to a space using the Microsoft Office task pane. The currently open file must be a space document.

Note:

This feature is available with Microsoft Office 2003 and 2007. Microsoft Office 2010 does not include a task pane.

To add members to a space when the currently open file is a space document:

  1. In the Members section of the task pane, click Add new members.

    The Add New Members dialog opens (Figure 48-33).

    Figure 48-33 Add New Members Dialog

    Add New Members dialog
  2. Enter the login names or mail addresses of the users you want to add to the space, separated by semicolons.

    Note:

    Users who are already members of the space cannot be added again. The user names that you enter must have an associated mail address defined in Spaces.

  3. From the site group dropdown list, select the role to be given to the listed users. The listed roles are those defined for the current space. The permissions granted to each role are defined by the Spaces administrator or space moderator. For more information about space roles, see Section 54.2, "Managing Roles and Permissions for a Space."

    Note:

    To define different roles to different users, limit the list of users to those who should be assigned the same role, finish this assignment, then click Add new members again to assign a different role to one or more different users.

  4. Click Next.

  5. Confirm or modify the member information, then click Finish.

  6. In the Add New Members dialog (Figure 48-34), select or deselect the check box to send an invitation to the new members to join the space, then click OK.

    Figure 48-34 Add New Members Dialog

    Add New Members Dialog

48.3.3.13 Sending a Message

From the Microsoft Office task pane, you can send a message to any user who has a mail address defined in Spaces:

Note:

This feature is available with Microsoft Office 2003 and 2007. Microsoft Office 2010 does not include a task pane.

48.3.3.13.1 Sending a Message to the Current User

To send a message to the user who has the currently open document checked out:

  • In the Status section of the Microsoft Office task pane, click the dropdown menu icon next to the user name, and select Send Mail (Figure 48-35).

    Figure 48-35 Send a Message to the Current Document User

    Send a Message to the Current User

    A Microsoft Outlook message composition window opens with the To field populated with the mail address that is specified for the user in Spaces.

48.3.3.13.2 Sending a Message to Your Connections

To send a message to your connections when you are working with a document in the Home space:

  1. In the Members section of the Microsoft Office task pane:

    • To send a message to an individual who is one of your connections, click the user name in the Members list (Figure 48-36):

      Figure 48-36 Send a Message to a Connection

      Send Mail to Individual Connection
    • To send a message to all of your connections, click Send e-mail to all members (Figure 48-37).

      Figure 48-37 Send a Message to All Connections

      Send a Message to All Connections

    A Microsoft Outlook message composition window opens, where the Home space name is the subject, and the To field is populated with the mail address(es) specified for the people connection(s) in Spaces.

  2. Modify the addresses and content of the message as desired, then click Send.

48.3.3.13.3 Sending a Message to Members of a Space

To send a message to the members of a space when you are working with a document in a space:

  1. In the Members section of the Microsoft Office task pane:

    • To send a message to an individual who is a member of the space, click the user name in the Members list (Figure 48-38):

      Figure 48-38 Send a Message to an Individual Space Member

      Send Mail to Individual in People Connections
    • To send a message to all members of the space, click Send e-mail to all members.

      Figure 48-39 Send a Message to All Space Members

      Send a Message to All Group Space Members

    A Microsoft Outlook message composition window opens, where the space name is the subject, and To field is populated with the mail address(es) specified for the space member(s) in Spaces

  2. Modify the addresses and content of the message as desired, then click Send.

48.3.4 Closing a File

You can close a file opened in a Microsoft Office application with or without checking it in, as described in the following sections:

48.3.4.1 Closing a File After Checking It In

After checking a file in, the file remains open in the Microsoft Office application until you close it.

To close a file after you have checked it in (see Section 48.3.3.5, "Checking a File In"):

  • From the File menu, select Close.

48.3.4.2 Closing a File Before Checking It In

If you attempt to close a file or the Microsoft Office application before you have checked the file in, the Check In dialog provides the opportunity to check it in or cancel the check out and discard changes to the file. The selections in the Check In dialog are dependent on whether or not the file has been modified since the last time it was checked in.

48.3.4.2.1 Closing an Unchanged File

In Microsoft Office 2003: To close a file that has not been modified since the last time it was checked in:

  1. From the File menu, select Close.

  2. In the Check In dialog (Figure 48-40), select one of the following actions:

    Figure 48-40 Check In Dialog for File with No Changes (Microsoft Office 2003)

    Check In Dialog for File with No Changes
    • Check in file to check the file in with no changes. In the Check In Comments dialog (Figure 48-21), optionally enter new comments, then click OK.

    • Keep checked out to close the file, but keep it in a checked out and locked to changes by other users. To later cancel the checked out status, see Section 43.12.1, "Checking a File Out."

    • Discard changes and undo check out to cancel the checked out status.

  3. Click OK.

In Microsoft Office 2007: To close a file that has not been modified since the last time it was checked in:

  • Click the Office Button (Figure 48-41) in the top left corner of the Microsoft Office application, then select Close.

    Figure 48-41 Office Button in Microsoft Office

    Office Button in Microsoft Office

If a file is unchanged, Microsoft Office 2007 does not prompt you to first check the file back in again. If saving to a local draft folder instead of the Content Server repository, the file remains in a checked out status and locked to changes by other users, and you will need to explicitly cancel the checked out status (see Section 43.12.2, "Cancelling a Checked Out Status"). If saving to the Content Server repository, the checked out status is canceled upon closing the file.

48.3.4.2.2 Closing an Updated File

In Microsoft Office 2003: To close a file that has been modified since the last time it was checked in:

  1. From the File menu, select Close.

  2. In the Check In dialog (Figure 48-42), select one of the following actions:

    Figure 48-42 Check In Dialog for File with Changes (Microsoft Office 003)

    Check In Dialog for File with Changes
    • Save changes and check in to save the changes since the last check in and check the file in.

    • Save changes only to save changes since the last check in, but keep the file checked out and locked to changes by other users. To later cancel the checked out status, see Section 43.12.1, "Checking a File Out."

    • Discard changes and undo check out to retain the prior saved version of the file and cancel the checked out status.

    • Discard changes only to retain the prior saved version of the file and keep the file checked out.

  3. Click OK.

In Microsoft Office 2007: To close a file that has been modified since the last time it was checked in:

  1. Click the Office Button (Figure 48-43) in the top left corner of the Microsoft Office application, then select Close.

    Figure 48-43 Office Button in Microsoft Office

    Office Button in Microsoft Office
  2. If you have not already saved the changes, respond to the confirmation prompt to save or discard your changes.

  3. In the confirmation dialog (Figure 48-44), respond to the prompt:

    Figure 48-44 Close File Confirmation Prompt (Microsoft Office 2007)

    Close File Confirmation in Office 2007
    • Yes to display the Check In dialog where you can enter version comments and select whether or not you want the file to remain checkout out (see Section 48.3.3.5, "Checking a File In"). If you choose to keep the file checked out and locked to changes by other users, see Section 43.12.1, "Checking a File Out" to later cancel the checked out status.

    • No to skip the checkin, with one of the following results:

      • If saving to a local draft folder, keep the file checked out and locked to changes by other users. To later cancel the checked out status, see Section 43.12.2, "Cancelling a Checked Out Status."

      • If saving to the Content Server repository, cancel the checked out status of the file.

48.4 Working with Microsoft Windows Explorer Integration

Spaces integrates with Microsoft Windows Explorer to manage the folders and files in the Home space or a group space when the backend content repository is Content Server.

In Spaces, the most useful feature of Windows Explorer integration is the ability to add multiple files at once to a space, rather than uploading up to 10 files at a time (see Section 43.8.1, "Uploading Files"). It is important to be aware that Windows Explorer is not designed as a content repository, so if you try to open, delete, or rename a file that is checked out by another user, an error message displays to notify you that the operation failed, but the error message will not be specific as to the cause of the failure.

To expose the folders and files in a space in Windows Explorer, you create a new Windows network place to work with the files, as described in the following sections:

48.4.1 Adding a Space as a Network Place

To expose the folders and files in a space using Windows Explorer, you can add the space as a Windows network place.

To add a space as a Windows network place:

  1. Open the Add Network Place/Location wizard:

    • In Microsoft Windows XP, open My Network Places and click Add Network Place.

    • In Microsoft Windows 7, right-click My Computer, and select Add a Network Location.

    Refer to the Microsoft Windows online help for more information

  2. In the Add Network Place/Location wizard, enter the network address using the following format:

    • (In Windows XP only) To access all spaces in your Spaces application through Windows Explorer:

      http://hostname:port/wcsdocs/conn/repository_server/spaces/

      For example:

      http://myserver:8888/wcsdocs/conn/myserver-ucm/spaces/

    • To access the Home space through Windows Explorer:

      http://hostname:port/wcsdocs/conn/repository_server/spaces/PersonalSpaces/username

      For example:

      http://myserver:8888/wcsdocs/conn/myserver-ucm/spaces/PersonalSpaces/wcsadmin

    • To access a specific space through Windows Explorer, open the About Space dialog, and copy the Explorer URL. See Section 51.6, "Viewing Information About a Space."

      http://hostname:port/wcsdocs/conn/repository_server/spaces/instance/spacename

      For example:

      http://myserver:8888/wcsdocs/conn/myserver-ucm/spaces/WebCenter/philatelists

    Tip:

    The host name and port is shown in the browser URL for your Spaces application.

    To find the name of the repository server, view the information for any space in the Spaces application, and note the name of the content repository specified by the Explorer URL. See Section 51.6, "Viewing Information About a Space."

  3. At the prompt, enter your Spaces login credentials.

  4. Optionally enter a name for the space network place, then click Finish.

    Windows Explorer displays a drive for all spaces or the folders and files of a space, depending on the URL you entered.

48.4.2 Working with Files Using Windows Explorer

Once you have created a Windows network place to a space (see Section 48.4.1, "Adding a Space as a Network Place"), you can manage the folders and files using Windows Explorer.

Note:

If you change the internal name of a space (see Section 53.14.2, "Changing a Space URL"), the original network place to that individual space is no longer accessible. You will need to add the space as a Windows network place again using the new space internal name. Changing the internal name of a space has no effect if you create a network place to the parent URL for all spaces (http://hostname:port/wcsdocs/conn/repository_server/spaces/).

In Windows Explorer, navigate to the network place for the space to perform any of the following actions:

When you open a file, an attempt is made to check the file out. If it is checked out by another user, or you do not have permissions to update the file, it will open read-only. A file remains checked out until you check it back in (see Section 48.3.3.5, "Checking a File In").

The changes you make in Windows Explorer are reflected in Spaces, and vice versa.

Note:

To use the Spaces application to manage folders and files in a space in any connected content repository, see Chapter 43, "Working with the Documents Service Task Flows and Document Components."