Skip Headers
Oracle® Fusion Middleware Using Oracle WebCenter Portal
11g Release 1 (11.1.1.8.0)

Part Number E27785-02
Go to Documentation Home
Home
Go to Book List
Book List
Go to Table of Contents
Contents
Go to Master Index
Master Index
Go to Feedback page
Contact Us

Go to previous page
Previous
Go to next page
Next
PDF · Mobi · ePub

19 Working with Microsoft Office and Explorer Integration

This chapter describes how to use Microsoft Office applications and Windows Explorer to manage documents in a portal.

This chapter includes the following topics:

Permissions:

To perform the tasks in this chapter, you need the portal-level permission Create and Edit Documents (which includes delete permissions on documents that you create). To delete documents that are not your own, you must have Delete Documents permission. These permissions are granted by default to the portal Participant role.

19.1 About Microsoft Office and Explorer Integration

WebCenter Portal integrates with Microsoft Office and Windows Explorer to provide you with flexibility in managing files in a portal when the content repository is Content Server.

The differences in Microsoft Office 2003, 2007, and 2010 mean that each version may support a particular feature in a different way, and one or more versions may not support some of the tasks described in this chapter. Each section in this chapter provides information about which Microsoft Office version supports the task described, and how that support is implemented, where there are differences. Additionally, Table 19-1 provides a quick reference summary of the Microsoft Office functionality supported by WebCenter Portal in the different versions of Microsoft Office

This following sections provide an overview of the added functionality provided by integration with Microsoft Office and Windows Explorer:

19.1.1 Understanding Microsoft Office Word, PowerPoint, and Excel Integration

Using the Microsoft Office shared document management functionality, you can work with Word, PowerPoint, or Excel files in any portal, including the Home portal, from the task pane in the Office application.

Note:

The differences in Microsoft Office 2003, 2007, and 2010 mean that each version may support a particular feature in a different way, and one or more versions may not support some of the tasks described in this chapter. Each section provides information about which version supports the task described, and how that support is implemented, where there are differences.

Table 19-1 provides a quick reference summary of the Microsoft Office functionality supported by WebCenter Portal in the different versions of Microsoft Office.

Note:

The following browsers are supported for all versions of Microsoft Office:

  • Internet Explorer 7+

  • Firefox 3.6+

  • Safari 4+

  • Google Chrome 12+

Table 19-1 Microsoft Office Version Support Summary

Task 2003 2007 2010

Creating a Portal from a Microsoft Office Document

Not supported

Supported

Not supported

Opening a Microsoft Word, Excel, or PowerPoint file from WebCenter Portal:

Supported

Supported

Supported

Closing a File

Supported

Supported

Supported

Working with the Microsoft Office Task Pane (2003 and 2007 only)

Supported

Supported

Not supported

Displaying and Hiding the Microsoft Office Task Pane:

Supported

Supported

N/A

Microsoft Office Task Pane: Top section

Task pane top section menu actions described below

Supported

Supported

N/A

User or portal name (see Table 19-3)

Supported

Supported

N/A

Supported

Supported

N/A

  • Change Site Title

Not supported

Not supported

N/A

Supported

Supported

N/A

  • Disconnect from Workspace

Not supported

Not supported

N/A

  • Delete Workspace

Not supported

Not supported

N/A

Microsoft Office Task Pane: Status section

Task pane Status section described below

Supported

Supported

N/A

Document checked out to: user name

Status section username menu actions described below

Supported

Supported

N/A

Supported

Supported

N/A

  • Call

Not supported

Not supported

N/A

Supported

Supported

N/A

  • Additional Actions

Not supported

Not supported

N/A

Supported

Supported

N/A

Supported

Supported

N/A

Check in

Supported

Supported

N/A

Microsoft Office Task Pane: Members section

Task Pane Members section described below

Supported

Supported

N/A

User who checked out the file

Members section username menu actions described below

Supported

Supported

N/A

  • Schedule a Meeting

Not supported

Not supported

N/A

  • Additional Actions

Not supported

Not supported

N/A

  • Edit Site Group Membership

Not supported

Not supported

N/A

  • Edit User Information

Not supported

Not supported

N/A

  • Add to Outlook Contacts

Not supported

Not supported

N/A

  • Outlook Properties

Not supported

Not supported

N/A

Listing of current people connections

Supported

Supported

N/A

Add new members (not supported for Home portal)

Supported

Supported

N/A

Send e-mail to all members

Supported

Supported

N/A

Microsoft Office Task Pane: Tasks section

Task pane Tasks section

Not supported

Not supported

N/A

Microsoft Office Task Pane: Documents section

Task pane Documents section described below

Supported

Supported

N/A

Managing the Currently Open File

Documents Section current file menu actions described below
     
  • Open in Microsoft Office Xxxxx

Not supported

Not supported

N/A

  • Delete

Not supported

Not supported

N/A

  • Alert Me About This Document

Not supported

Not supported

N/A

Supported

Supported

N/A

  • Document Updates

Not supported

Not supported

N/A

  • Save Updatable Copy

Not supported

Not supported

N/A

  • Create Document Workspace

Not supported

Not supported

N/A

  • Publish Back to Source Location

Not supported

Not supported

N/A

Managing Other Files in the Current Portal

Documents Section other files menu actions described below
     
  • Open in Microsoft Office

Supported

Supported

N/A

  • Delete

Not supported

Not supported

N/A

  • Alert Me About This Document

Not supported

Not supported

N/A

Managing Folders:

Documents Section folder menu actions described below
     
  • View Contents.

Supported

Supported

N/A

  • Delete

Not supported

Not supported

N/A

Add new document

Supported

Supported

N/A

Add new folder

Supported

Supported

N/A

Alert me about documents

Not supported

Not supported

N/A

Microsoft Office Task Pane: Links section

Task Pane Links Section actions described below

Supported

Supported

N/A

Documents and URL links defined in WebCenter Portal to the current file

Supported

Supported

N/A

Add new link

Not supported

Not supported

N/A

Alert me about links

Not supported

Not supported

N/A

Microsoft Office Task Pane: Document Information section

Task pane Document Info section described below

Supported

Not supported

N/A

Document Information

Supported

Not supported

N/A

Restrict permission

Not supported

Not supported

N/A

Alert me about this document

Not supported

Not supported

N/A

Check out or Check in

Supported

Not supported

N/A

Version history

Supported

Not supported

N/A

Microsoft Office Task Pane: Bottom section

Task pane bottom section described below

Supported

Supported

N/A

Get Updates (see Table 19-3)

Supported

Supported

N/A

Options (see Table 19-3)

Supported

Supported

N/A

Date and time that the file was last modified.

Supported

Supported

N/A


19.1.2 Understanding Microsoft Windows Explorer Integration

In Windows Explorer, you can manage the folders and files in a portal when the back-end content repository is Content Server. To use this functionality, you create a network place in Windows Explorer for the portal documents. See Section 19.4, "Working with Microsoft Windows Explorer Integration."

19.2 Configuring Microsoft Office Integration with WebCenter Portal

To allow for full integration of Microsoft Office with WebCenter Portal, your system administrator must complete the steps detailed in the "Managing Microsoft Office Integration" chapter in Oracle Fusion Middleware Administering Oracle WebCenter Portal.

Additionally, it is recommended that you set your Microsoft Office application options to use a web server (Content Server) for managing checked out files rather than a local draft folder. Table 19-2 describes the behavior of save and close actions when using a local draft folder and a web server:

Table 19-2 Microsoft Office Save Options Settings

MS Office Action Save to Local Draft Folder Save to Web Server

Save a file

The file is saved to the client local drive. This is useful when the client does not maintain a connection to a server. The file is not automatically checked-in when the connection to the server is established. You will need to check in the file as a separate operation (see Section 19.3.4.4, "Checking a File In").

The file is sent to the server and saved to a temporary file. The temporary file is used to check in of the new updated version of the file.

Close a file or exit application (see Section 19.3.5.2.2, "Closing an Updated File").

If the file is checked out, MS Office prompts for check-in. If you select No to the check-in prompt, MS Office exits and the file remains checked out and locked to changes by other users. Any changes made to the file are not saved. To later cancel the checked out status, see Section 17.8.2, "Cancelling a Checked Out Status."

If the file is checked out, MS Office prompts for checkin. If you select No to the checkin prompt, MS Office exits and cancels the checked out status of the file. Any changes made to the file are not saved.


To configure your Microsoft Office application options to follow the recommendation to use a web server (Content Server) for managing checked out files:

  1. In the Microsoft Office document, click the Office Button (Figure 19-4) in the top left corner of the Microsoft Office application.

    Figure 19-1 Office Button in Microsoft Office

    Office Button in Microsoft Office
  2. Click Application Options (for example, Word Options, as shown inFigure 19-2) at the bottom of the menu.

    Figure 19-2 Office Button Menu: Word Options

    Office Button Menu: Word Options
  3. In the Options dialog, select Save in the left pane (Figure 19-3).

  4. Under Offline editing options for document management server files, select The web server (Figure 19-3).

    Figure 19-3 Word Options Dialog

    Description of Figure 19-3 follows
    Description of "Figure 19-3 Word Options Dialog"

19.3 Working with Microsoft Word, PowerPoint, and Excel Integration

WebCenter Portal integrates with the Microsoft Office shared document management functionality for working with Microsoft Word, Excel, or PowerPoint files. For more information, see Section 19.1.1, "Understanding Microsoft Office Word, PowerPoint, and Excel Integration."

Many of the tasks you can perform using the Microsoft Office shared document management functionality can also be performed in WebCenter Portal, as described in Chapter 17, "Creating and Managing Documents."

This section provides steps to perform the following tasks using Microsoft Office shared document management:

Note:

WebCenter Portal does not implement administrative features of the Microsoft Office shared document management functionality, such as creating a workspace using the task pane, deleting a workspace, or changing a workspace title.

19.3.1 Creating a Portal from a Microsoft Office Document

Note:

This feature is available only in Microsoft Office 2007. It is not available in Microsoft Office 2003 or 2010.

With Microsoft Office 2007, you can create a portal from a Microsoft Office document, as long as your permissions on the document are the same as your permissions in WebCenter Portal.

To create a portal from a Microsoft Office document:

  1. In the Microsoft Office document, click the Office Button (Figure 19-4) in the top left corner of the Microsoft Office application.

    Figure 19-4 Office Button in Microsoft Office

    Office Button in Microsoft Office
  2. From the Publish menu, select Create Document Workspace (Figure 19-5).

    Figure 19-5 Creating a Portal from an Office Document

    Description of Figure 19-5 follows
    Description of "Figure 19-5 Creating a Portal from an Office Document"

  3. The Microsoft Office application displays the Document Management task pane, displaying the file name as the default workspace name.

    Figure 19-6 Document Management Task Pane: Document Workspace

    Description of Figure 19-6 follows
    Description of "Figure 19-6 Document Management Task Pane: Document Workspace"

  4. In the Document Workspace name field, type a name for the portal if you want to change the default name.

  5. In the Location for new workspace field, type the Explorer URL for the WebCenter Portal instance.

    http://hostname:port/wcsdocs/conn/repository_server/spaces/

    For example:

    http://myserver:8888/wcsdocs/conn/myserver-ucm/spaces/

    Tip:

    The host name and port is shown in the browser URL for your WebCenter Portal application.

    To find the name of the repository server:

    • On the Documents page of the portal you want to connect to, or the Home portal, from the View menu, select Containing Folder Info.

    • Use the portion of the Identifier value that precedes the pound (#) sign as the repository server value. For example, if the Identifier value is myserver-ucm#dCollectionID:549132825864000605, then the repository server value is myserver-ucm.

  6. Click Create.

  7. At the prompt, enter your WebCenter Portal login credentials.

WebCenter Portal creates the new portal in WebCenter Portal.

In Microsoft Office, the Status section of the Microsoft Office task pane (see Table 19-3) displays one of the following status messages:

This document is up to date.  If you have unsaved changes, you must save the document before you can update the workspace copy.

A copy of this document is stored in a Document Workspace.  Changes made to your document have not been udpated in the workspace copy.

If you update the document in Microsoft Office, you can simply click the Update Workspace Copy link to synchronize the document with the version in the portal (on the server).

19.3.2 Opening and Editing a File

When you open a Microsoft Office file from WebCenter Portal (using any browser), the file is automatically checked out of the Content Server repository. When you refresh the page in WebCenter Portal, the Status column for the file shows a Checked Out icon.

To make your changes available to other users, you can save and close it in Microsoft Office, or explicitly check the file in using Microsoft Office.

Note:

For all browsers except Internet Explorer, you will need to install the Java plugin available at http://support.mozilla.com to edit a Microsoft Office file. This plugin is included in Java 6 Update 15 and above.

To open a Microsoft Word, Excel, or PowerPoint file from WebCenter Portal in-place in its Microsoft Office application:

  1. On the Documents page, or in the Document Explorer, Document Manager, or Folder Viewer on a page, click in the row of the file you want to edit, but not on the file name. (Clicking on the file name opens the document in the Document Viewer).

    Alternatively, you can edit an open file in the Document Viewer preview pane.

  2. Depending on your view and the file type, perform one of the following actions:

    • On the Documents page, or in the Document Explorer, Document Manager, or Folder Viewer on a page, from the File menu or the context (right-click) menu, select the Edit action that opens the file in-place in its Microsoft Office application. For example, for Microsoft Word files, choose Edit with Word.

    • In the Document Viewer preview pane, click the Edit action.

    Note:

    If the file is already checked out by another user, the File in Use dialog opens. See Section 17.8.4.1, "Opening a File Already Checked Out By Another User."

  3. If prompted, enter the same credentials used to log in to WebCenter Portal to open the file in-place in its corresponding application.

    Note:

    The user name and password must contain only ASCII characters. A user name or password containing multi-byte characters cannot be successfully authenticated.

    Figure 19-7 Microsoft Office 2003 Shared Workspace Task Pane

    Description of Figure 19-7 follows
    Description of "Figure 19-7 Microsoft Office 2003 Shared Workspace Task Pane"

  4. When the file opens, it is automatically checked out of the Content Server repository, indicated by the Checked Out icon next to the file name.

    Figure 19-8 Checked Out Icon

    Description of Figure 19-8 follows
    Description of "Figure 19-8 Checked Out Icon"

  5. Make required updates, then save and close the file.

    The modified file is automatically checked back in.

19.3.3 Displaying and Hiding the Microsoft Office Task Pane

Note:

The Microsoft Office task pane is available only in Microsoft Office 2003 and 2007. Microsoft Office 2010 does not include a task pane.

In Microsoft Office 2003, the task pane displays by default when you open a file, whereas in Microsoft Office 2007, the task pane does not display by default.

You can manage the display of the Microsoft Office task pane as described in the following sections:

19.3.3.1 Displaying or Hiding the Task Pane Manually

To display or hide the Microsoft Office task pane manually:

In Microsoft Office 2003:

  • From the Tools menu, select Shared Workspace to toggle between displaying and hiding the task pane.

In Microsoft Office 2007:

  1. Click the Office Button (Figure 19-9) in the top left corner of the Microsoft Office application.

    Figure 19-9 Office Button in Microsoft Office

    Office Button in Microsoft Office
  2. From the Server menu, select Document Management Information to toggle between displaying and hiding the Document Management task pane (Figure 19-10).

    Figure 19-10 Microsoft Office 2007 Document Management Task Pane

    Description of Figure 19-10 follows
    Description of "Figure 19-10 Microsoft Office 2007 Document Management Task Pane"

19.3.3.2 Displaying or Hiding the Task Pane By Default

To display or hide the Microsoft Office task pane automatically by default every time you open a Microsoft Word, Excel, or PowerPoint file:

In Microsoft Office 2003:

  1. From the Tools menu, select Options.

  2. In the Options dialog, on the General tab, click Service Options.

  3. In the Shared Workspace category, select or deselect the check box The document is part of a workspace or SharePoint site to respectively display or hide the task pane by default.

In Microsoft Office 2007:

  1. At the bottom of the Microsoft Office task pane, click Options (Figure 19-11).

    Figure 19-11 Options Link in Task Pane (Microsoft Office 2007)

    Options Link in Task Pane
  2. In the Service Options dialog, select or deselect the check box The document is part of a workspace or SharePoint site to respectively display or hide the task pane by default.

19.3.4 Working with the Microsoft Office Task Pane

Note:

The Microsoft Office task pane is available only in Microsoft Office 2003 and 2007. Microsoft Office 2010 does not include a task pane.

The Microsoft Office task pane provides information pertaining to the currently open file and access to tasks for all folders and files in the current portal, as described in Table 19-3.

Table 19-3 Microsoft Office Task Pane for Files in a Portal

Task Pane Area Description

Top section in Microsoft Office 2003:

Task pane top section 2003 actions described on right

Top section in Microsoft Office 2007:

Task pane top section 2007 actions described on right

Dropdown menu:

Task pane top section menu actions described on right

For a file in the Home portal:

  • Shows the user name.

  • Open site in browser. Click to display the WebCenter Portal Home page.

For a file in a portal:

  • Shows the portal name.

  • Open site in browser. Click to display the portal Home page.

Additionally, the top section provides a drop-down menu of actions available for the user or portal:

  • Open Site in Browser. See above.

  • Change Site Title. Not supported.

  • Change Site Settings. For the Home portal, displays the WebCenter Portal Home page; for a portal, displays the Settings tab of the portal.

  • Disconnect from Workspace. Not supported.

  • Delete Workspace. Not supported.

Status section in Microsoft Office 2003:

Task pane Status section 2003 actions described on right

Status section in Microsoft Office 2007:

Task pane Status section 2007 actions described on right

Dropdown menu:

Task pane Status section menu actions described on right

Displays information only if the file is checked out.

Shows the following information:

Additionally, the Status section provides a dropdown menu of actions available for the user:

  • Schedule a Meeting. Opens the Microsoft Outlook calendar scheduler.

  • Call. Not supported.

  • Send Mail. Opens a Microsoft Outlook message with the To field populated with the mail address that is specified for the user in WebCenter Portal. See Section 19.3.4.12, "Sending a Message." This selection has the same effect as clicking the user name in the Members section.

  • Additional Actions. Not supported.

  • Add to Outlook Contacts. Opens the Microsoft Outlook Contacts page populated with contact information for the user.

  • Outlook Properties. Opens the Microsoft Outlook E-mail Properties dialog.

Members section:

Task Pane Members section actions described on right

Dropdown menu:

Task pane Members section menu actions described on right

For a file in the Home portal:

For a file in a portal:

Additionally, the Members section provides a dropdown menu of actions available for the listed member(s). The actions in this menu are not supported.

To send a message to any member, simply click the member's user name to open a Microsoft Outlook window with the To field populated with the mail address that is specified for the member in WebCenter Portal.

Tasks section:

Task pane Tasks section actions described on right

Not supported.

Documents section:

Task pane Documents section actions described on right

Provides access to other files in the current portal directly from Microsoft Office.

Sort by. Choose from the menu to sort the list of documents by Creation Date, Modified Date, File Name, File Type, Ascending, or Descending.

Links section:

Task pane Links section actions described on right

The Links section shows all document and URL links defined in WebCenter Portal to the currently open file.

Sort by. Choose from the menu to sort the list of links by Creation Date, Modified Date, URL, Ascending, or Descending.

Document Information section (Microsoft Office 2003 only):

Task pane Document Info section actions described on right

Provides information about the currently open document:

Bottom section:

Task pane bottom section actions described on right

Includes:

  • Get Updates. Refreshes the files and associated information from the WebCenter Portal server.

  • Options. Opens the Service Options dialog. Refer to the Microsoft Office online help for more information.

  • Shows the date and time that the file was last modified.


The following sections describe the tasks you can perform using the Microsoft Office task pane:

19.3.4.1 Adding a File

Using the Microsoft Office shared document management functionality, you can add a new file to the Content Server repository, exposing the file in a portal, as described in the following sections:

Note:

Other methods to add a file to the connected content repository are:

19.3.4.1.1 Saving a File As a New File in a Portal

To save a local Microsoft Word, Excel, or PowerPoint file to a portal:

Note:

This feature is supported in Microsoft Office 2003 and 2007 only.

  1. Add the portal as a new network place in Windows Explorer, as described in Section 19.4, "Working with Microsoft Windows Explorer Integration."

  2. Open the file in its Microsoft Office application.

  3. (In Microsoft Office 2007 only) Set save options for shared documents:

    1. Click the Office Button in the top left corner of the Microsoft Office application, then click Word Options (Figure 19-12) at the bottom of the menu.

      Figure 19-12 Office Button Menu: Word Options

      Office Button Menu: Word Options
    2. In the Word Options dialog, select Save in the left pane (Figure 19-13).

    3. Under Offline editing options for document management server files, select The web server (Figure 19-13).

      Figure 19-13 Word Options Dialog

      Description of Figure 19-13 follows
      Description of "Figure 19-13 Word Options Dialog"

  4. Publish the file to the portal:

    In Microsoft Office 2003. From the File menu, select Save As.

    In Microsoft Office 2007. Click the Office Button, then choose either:

    • Publish, then Document Management Server.

    • Or, Save As, then Application Document.

  5. In the Save As dialog, select the portal network place, then click Save. For more information about portal network place URLs, see Section 19.4.1, "Adding a Portal as a Network Place."

  6. Enter login credentials for WebCenter Portal, then click OK.

  7. In WebCenter Portal, on the Documents page of the portal, click the Refresh icon to confirm that the file was added.

    Note:

    To make the file visible to others, you must check the file in. See Section 19.3.4.4, "Checking a File In."

  8. To display the Microsoft Office task pane in the open file, see Section 19.3.3, "Displaying and Hiding the Microsoft Office Task Pane."

19.3.4.1.2 Adding a New File Using the Task Pane

To add a new file to a portal using the Microsoft Office task pane:

Note:

This feature is available with Microsoft Office 2003 and 2007. Microsoft Office 2010 does not include a task pane.

  1. Open a Microsoft Word, Excel, or PowerPoint file to use the Microsoft Office shared document management functionality (see Section 19.3.2, "Opening and Editing a File").

  2. At the bottom of the Documents section of the task pane, click Add new document (Figure 19-14).

    Figure 19-14 Task Pane Documents Section: Adding a New File

    Task Pane Documents Section: Bottom Area

    The Add New Document dialog opens (Figure 19-15).

    Figure 19-15 Add New Document Dialog

    Description of Figure 19-15 follows
    Description of "Figure 19-15 Add New Document Dialog"

  3. Browse to the file that you want to add to the current portal.

    Note:

    WebCenter Portal supports files up to 2GB in size.

    The check box Make workspace updates available when I open my copy is not supported.

  4. Click OK.

    The new file displays at the top of the document list in the Documents section of the Microsoft Office task pane. When you refresh the Documents page of the portal in WebCenter Portal, the file appears in the document list in alphabetical order.

19.3.4.2 Adding a New Folder

Using the Microsoft Office shared document management functionality, you can add a new folder to the Content Server repository, exposing the folder in a portal.

Note:

Other methods to add a new folder to a portal are:

To add a new folder to a portal using the Microsoft Office task pane:

  1. Open a Microsoft Word, Excel, or PowerPoint file in the portal to use the Microsoft Office shared document management functionality (see Section 19.3.2, "Opening and Editing a File").

  2. At the bottom of the Documents section of the task pane, click Add new folder (Figure 19-16).

    Figure 19-16 Task Pane Documents Section: Adding a New Folder

    Task Pane Documents Section: Adding a New Folder

    The Add New Folder dialog opens (Figure 19-17).

    Figure 19-17 Add New Folder Dialog

    Description of Figure 19-17 follows
    Description of "Figure 19-17 Add New Folder Dialog"

  3. Enter a name for the new folder, then click OK.

    Note:

    The rules for folder names follow the Windows Explorer standards.

    The new folder displays at the top of the document list in the Documents section of the Microsoft Office task pane. When you refresh the Documents page of the portal in WebCenter Portal, the folder appears in the folder list in alphabetical order.

19.3.4.3 Checking a File Out

Note:

To check any file out using the WebCenter Portal application, see Section 19.3.4.3, "Checking a File Out."

When you open a Microsoft Office file in a portal using the Microsoft Office shared document management functionality, the file is automatically checked out from the Content Server repository. If you have been granted the appropriate permissions, you can open and check a file out in two environments:

  • From WebCenter Portal. Open a file in-place (see Section 19.3.2, "Opening and Editing a File") to automatically check out the file.

  • (Microsoft Office 2003 and 2007) From the Microsoft Office task pane. In the Documents section of the task pane, click a file name to automatically check out the file and open it in its default Microsoft Office application.

19.3.4.3.1 Checking the Currently Open File Out Again After Checking It In

After you check a file in (see Section 19.3.4.4, "Checking a File In"), the file remains displayed in Microsoft Office until you close it (see Section 19.3.5, "Closing a File"). If you want to check in further changes to the file, it must be checked out again:

  • In Microsoft Office 2003. In the Document Information section of the Microsoft Office task pane, you can optionally click Check out to check the file out again (Figure 19-18). However, even if you do not explicitly check out the file, you can continue to edit the file, then save it, and the Status and Document Information sections of the task pane automatically provide a Check in link to check the changed file back in to the repository.

    Figure 19-18 Checking Out a Checked In File

    Description of Figure 19-18 follows
    Description of "Figure 19-18 Checking Out a Checked In File"

  • In Microsoft Office 2007 and 2010. When you check a file in, the Check In dialog (Figure 19-22) provides a check box labeled Keep the document checked out after checking in this version:

    • Select the check box to keep the file checked out after checking in the current version. This allows you to refresh the version of the file available to other users, yet still retain the checked out status to make further changes.

    • Deselect the check box to check the file in and cancel the checked out status.

    If you deselect the check box, you can optionally check the file out again:

19.3.4.4 Checking a File In

When you open a file using the Microsoft Office shared document management functionality, you can check it back in to the repository, whether or not you have made changes to it.

Note:

This feature is available with Microsoft Office 2003 and 2007. Microsoft Office 2010 does not include a task pane.

In Microsoft Office 2010, you can find file check-in and checkout information on the Info tab (from the File menu, select Info). When you open a Microsoft Office 2010 file from WebCenter Portal (using any browser), the file is automatically checked out of the Content Server repository, changes are (temporarily) applied when saved, and the file is automatically checked in when the file is closed, with a default check-in comment.

Note:

Saving the file without checking it in or closing the application saves it on the server, but changes are not visible to others until you check the file in. To update the file stored in the Content Server repository, you must explicitly check it in as described in this section. If you close the Microsoft Office application and do not check the file in when prompted, your changes are lost.

To check a file in:

  1. In the Status section of the Microsoft Office task pane, click Check in (Figure 19-20).

    Figure 19-20 Status Section in MS Office 7: Checking In a File

    Description of Figure 19-20 follows
    Description of "Figure 19-20 Status Section in MS Office 7: Checking In a File"

    Notes:

    • If the Check in link does not display, click the icon for any other section, then return to the Status section to refresh the pane.

    • In Microsoft Office 2003, you can also find Check in in the Document Information section of the task pane.

  2. In Microsoft Office 2003. In the Check In Comments dialog (Figure 19-21), optionally enter comments about the changes made to the file since it was last checked out.

    Figure 19-21 Check In Comments Dialog (Microsoft Office 2003)

    Description of Figure 19-21 follows
    Description of "Figure 19-21 Check In Comments Dialog (Microsoft Office 2003)"

    In Microsoft Office 2007. In the Check In dialog (Figure 19-22), optionally enter comments about the changes made to the file since it was last checked out, and select the state in which to leave the file:

    Figure 19-22 Check In Dialog (Microsoft Office 2007 and 2010)

    Description of Figure 19-22 follows
    Description of "Figure 19-22 Check In Dialog (Microsoft Office 2007 and 2010)"

    • Select the check box to keep the file checked out after checking in the current version. This allows you to refresh the version of the file available to other users, yet still retain the checked out status to make further changes.

    • Deselect the check box to check the file in and cancel the checked out status. To check the file out again, see Section 19.3.4.3.1, "Checking the Currently Open File Out Again After Checking It In."

  3. Click OK.

    If the file was modified since its prior version, it is automatically saved and checked in to WebCenter Portal as a new version. If check in comments were entered in the Check In dialog, a new file revision is created with the new comments, which display as the file description in WebCenter Portal.

  4. After checking a file in, the file remains displayed in Microsoft Office until you close it (see Section 19.3.5, "Closing a File"). If you wish to make further changes to the file, see Section 19.3.4.3.1, "Checking the Currently Open File Out Again After Checking It In."

  5. When you have finished making changes and checking in the file, close the Microsoft Office application (see Section 19.3.5, "Closing a File").

19.3.4.5 Managing the Currently Open File

Note:

This feature is available with Microsoft Office 2003 and 2007. Microsoft Office 2010 does not include a task pane.

To manage the currently open file using the Microsoft Office task pane:

  1. In the Documents section of the task pane, click the drop-down menu icon to the right of the file name (Figure 19-23).

    Figure 19-23 Task Pane Documents Section: Current File Menu

    Description of Figure 19-23 follows
    Description of "Figure 19-23 Task Pane Documents Section: Current File Menu"

  2. Select an available action, as described in Table 19-4:

    Table 19-4 Drop-Down Menu Actions for Currently Open File

    Menu Action Description

    Open in Microsoft Office Application

    Not applicable.

    Delete

    Not supported. To delete a file in a portal, you must use the WebCenter Portal application (see Section 17.12, "Deleting Folders and Files") or Windows Explorer (see Section 19.4, "Working with Microsoft Windows Explorer Integration").

    Alert Me About This Document

    Not supported.

    Check Status

    Displays the Status section of the task pane.

    Document Updates

    Not supported.

    Save Updatable Copy

    Not supported.

    Create Document Workspace

    Not supported.

    Publish Back to Source Location

    Not supported.


19.3.4.6 Managing Other Files in the Current Portal

Note:

This feature is available with Microsoft Office 2003 and 2007. Microsoft Office 2010 does not include a task pane.

To manage a file other than the currently open file in the current portal using the Microsoft Office task pane:

  1. In the Documents section of the task pane, navigate to the file.

    Note:

    Navigating upward in the folder hierarchy from the current document is not supported; you can drill down and then back up to the current level.

  2. To open the file, click its name.

    Depending on the file type, the file opens as described in Section 19.3.2, "Opening and Editing a File" for Microsoft Word, Excel, and PowerPoint files, or Section 17.6.2, "Opening a File" for other file types (such as HTML files or images).

    Note:

    If you have OpenOffice installed, an error may occur when attempting to open a file from the task pane. To resolve the error, uninstall OpenOffice.

  3. To perform other actions, click the drop-down menu icon to the right of a file name (Figure 19-24):

    Figure 19-24 Task Pane Documents Section: Other Files Menu

    Description of Figure 19-24 follows
    Description of "Figure 19-24 Task Pane Documents Section: Other Files Menu"

  4. Select an available action, as described in Table 19-5:

    Table 19-5 Drop-Down Menu Actions for Other Files

    Menu Action Description

    Open in Microsoft Office Application

    Attempts to check out the file: if checked out by another user, it opens read-only; if not checked out, the file opens in its Microsoft Office application for editing. For more information, see Section 19.3.2, "Opening and Editing a File."

    Delete

    Not supported. To delete a file in a portal, you must use the WebCenter Portal application (see Section 17.12, "Deleting Folders and Files") or Windows Explorer (see Section 19.4, "Working with Microsoft Windows Explorer Integration").

    Alert Me About This Document

    Not supported.


19.3.4.7 Managing Folders

Note:

This feature is available with Microsoft Office 2003 and 2007. Microsoft Office 2010 does not include a task pane.

To manage a folder under the current folder using the Microsoft Office task pane:

  1. In the Documents section of the task pane, navigate to the folder.

    Note:

    Navigating upward in the folder hierarchy from the current document is not supported; you can drill down and then back up to the current level.

  2. To open the folder, click its name.

  3. To perform other actions, click the drop-down menu icon to the right of the folder name (Figure 19-25):

    Figure 19-25 Task Pane Documents Section: Folder Menu

    Description of Figure 19-25 follows
    Description of "Figure 19-25 Task Pane Documents Section: Folder Menu"

  4. Select an available action, as described in Table 19-6:

    Table 19-6 Drop-Down Menu Actions for a Folder

    Menu Action Description

    View Contents

    Refreshes the list of files with the contents of the folder only (same effect as clicking the folder name). Click the folder name to refresh to the original list.

    Delete

    Not supported. To delete a folder in a portal, you must use the WebCenter Portal application (see Section 17.12, "Deleting Folders and Files") or Windows Explorer (see Section 19.4, "Working with Microsoft Windows Explorer Integration").


19.3.4.8 Viewing Link Targets

Note:

This feature is available with Microsoft Office 2003 and 2007. Microsoft Office 2010 does not include a task pane.

The Links section of the Microsoft Office task pane lists the links defined in WebCenter Portal that are associated with the currently open file (Figure 19-26). Files can have links to related documents, discussions, announcements, events, and notes; the Links section in the task pane shows the links to associated documents and notes.

Links are prefixed with the name of the service with which they are associated. For example, a link to another document is prefixed Document, a link to a note is prefixed URL.

Figure 19-26 Task Pane Links Section

Description of Figure 19-26 follows
Description of "Figure 19-26 Task Pane Links Section"

To display the target of a link, simply click the link:

  • Document links open in the same way as files in the Document section, namely Microsoft Word, Excel, and PowerPoint files open in Microsoft Office with a task pane, and other file types open in their default viewer or a browser.

  • URL links open a browser window displaying the link target.

19.3.4.9 Viewing Document Information

Note:

This feature is available with Microsoft Office 2003 and 2007. Microsoft Office 2010 does not include a task pane.

In Microsoft Office 2003: The Document Information section of the Microsoft Office task pane shows the user who last modified the file and the modified date (Figure 19-27).

Figure 19-27 Task Pane Document Information Section (Microsoft Office 2003 Only)

Description of Figure 19-27 follows
Description of "Figure 19-27 Task Pane Document Information Section (Microsoft Office 2003 Only)"

In Microsoft Office 2007. Information about the user who last modified the file and the modified date is shown in the Version History. See Section 19.3.4.10, "Working with File Version History."

19.3.4.10 Working with File Version History

Whenever you check in a file or upload a file into a folder that already contains a file of the same name, WebCenter Portal creates a new version of the file. When a file has multiple versions, it has a version history.

Note:

To use the WebCenter Portal application to work with the version history of a file in any connected content repository, see Section 17.16, "Viewing and Deleting File Version History."

In Microsoft Office 2003: To view the version history of the currently open file using the Microsoft Office task pane:

  1. In the Document Information section of the task pane, click Version history (Figure 19-28).

    Figure 19-28 Task Pane Document Information Section: Version History

    Description of Figure 19-28 follows
    Description of "Figure 19-28 Task Pane Document Information Section: Version History"

    The version history dialog for the file opens (Figure 19-29):

    Figure 19-29 Version History for Currently Open File in Microsoft Office 2003

    Description of Figure 19-29 follows
    Description of "Figure 19-29 Version History for Currently Open File in Microsoft Office 2003"

    In the version history dialog, select a file version, then select the desired action:

    • Open to open the selected file version read-only.

    • Restore is not supported.

    • Delete to delete the selected file version (inactive for the most recent version).

    • View Comments to display the comments entered for the selected file version (most useful when the comments are especially long).

  2. To open the Documents page in the current portal, click Modify settings for document versions.

In Microsoft Office 2007: To view the version history of the currently open file:

  1. Click the Office Button (Figure 19-30) in the top left corner of the Microsoft Office application.

    Figure 19-30 Office Button in Microsoft Office

    Office Button in Microsoft Office
  2. From the Server menu, select View Version History.

    The version history dialog for the file opens (Figure 19-31):

    Figure 19-31 Version History for Currently Open File in Microsoft Office 2007

    Description of Figure 19-31 follows
    Description of "Figure 19-31 Version History for Currently Open File in Microsoft Office 2007"

  3. In the version history dialog, select a file version, then select the desired action:

    • Open to open the selected file version read-only.

    • Compare to compare the selected file version with the currently open file.

    • Restore is not supported.

    • Delete to delete the selected file version (inactive for the most recent version).

  4. To view the check in comments for a file version, click the link under Comments.

  5. To open the Documents page in the portal, click the link next to Versions saved to.

In Microsoft Office 2010: To view the version history of the currently open file:

  • From the File menu, select Info.

    The Info tab shows version history information on the Info tab in the Versions section. Refer to the Microsoft Office online help for more information.

19.3.4.11 Adding Members to a Portal

Note:

Adding members to a portal using the WebCenter Portal application is described in the "Managing Members and Assigning Roles in a Portal" chapter in Oracle Fusion Middleware Building Portals with Oracle WebCenter Portal.

If you are granted the Moderator role or Manage All permissions in a portal, you can add new members to a portal using the Microsoft Office task pane. The currently open file must be a portal document.

Note:

This feature is available with Microsoft Office 2003 and 2007. Microsoft Office 2010 does not include a task pane.

To add members to a portal when the currently open file is a portal document:

  1. In the Members section of the task pane, click Add new members.

    The Add New Members dialog opens (Figure 19-32).

    Figure 19-32 Add New Members Dialog

    Description of Figure 19-32 follows
    Description of "Figure 19-32 Add New Members Dialog"

  2. Enter the login names or mail addresses of the users you want to add to the portal, separated by semicolons.

    Note:

    Users who are already members of the portal cannot be added again. The user names that you enter must have an associated mail address defined in WebCenter Portal.

  3. From the site group drop-down list, select the role to be given to the listed users. The listed roles are those defined for the current portal. The permissions granted to each role are defined by the application specialist or portal moderator.

    Note:

    To define different roles to different users, limit the list of users to those who should be assigned the same role, finish this assignment, then click Add new members again to assign a different role to one or more different users.

  4. Click Next.

  5. Confirm or modify the member information, then click Finish.

  6. In the Add New Members dialog (Figure 19-33), select or deselect the check box to send an invitation to the new members to join the portal, then click OK.

    Figure 19-33 Add New Members Dialog

    Description of Figure 19-33 follows
    Description of "Figure 19-33 Add New Members Dialog"

19.3.4.12 Sending a Message

From the Microsoft Office task pane, you can send a message to any user who has a mail address defined in WebCenter Portal:

Note:

This feature is available with Microsoft Office 2003 and 2007. Microsoft Office 2010 does not include a task pane.

19.3.4.12.1 Sending a Message to the Current User

To send a message to the user who has the currently open document checked out:

  • In the Status section of the Microsoft Office task pane, click the drop-down menu icon next to the user name, and choose Send Mail (Figure 19-34).

    Figure 19-34 Send a Message to the Current Document User

    Description of Figure 19-34 follows
    Description of "Figure 19-34 Send a Message to the Current Document User"

    A Microsoft Outlook message composition window opens with the To field populated with the mail address that is specified for the user in WebCenter Portal.

19.3.4.12.2 Sending a Message to Your Connections

To send a message to your connections when you are working with a document in the Home portal:

  1. In the Members section of the Microsoft Office task pane:

    A Microsoft Outlook message composition window opens, where the Home portal name is the subject, and the To field is populated with the mail address(es) specified for the people connection(s) in WebCenter Portal.

  2. Modify the addresses and content of the message as desired, then click Send.

19.3.4.12.3 Sending a Message to Members of a Portal

To send a message to the members of a portal when you are working with a document in a portal:

  1. In the Members section of the Microsoft Office task pane:

    A Microsoft Outlook message composition window opens, where the portal name is the subject, and To field is populated with the mail address(es) specified for the portal member(s) in WebCenter Portal

  2. Modify the addresses and content of the message as desired, then click Send.

19.3.5 Closing a File

You can close a file opened in a Microsoft Office application with or without checking it in, as described in the following sections:

19.3.5.1 Closing a File After Checking It In

After checking a file in, the file remains open in the Microsoft Office application until you close it.

To close a file after you have checked it in (see Section 19.3.4.4, "Checking a File In"):

  • From the File menu, select Close.

19.3.5.2 Closing a File Before Checking It In

If you attempt to close a file or the Microsoft Office application before you have checked the file in, the Check In dialog provides the opportunity to check it in or cancel the check out and discard changes to the file. The selections in the Check In dialog are dependent on whether or not the file has been modified since the last time it was checked in:

19.3.5.2.1 Closing an Unchanged File

In Microsoft Office 2003: To close a file that has not been modified since the last time it was checked in:

  1. From the File menu, select Close.

  2. In the Check In dialog (Figure 19-39), select one of the following actions:

    Figure 19-39 Check In Dialog for File with No Changes (Microsoft Office 2003)

    Description of Figure 19-39 follows
    Description of "Figure 19-39 Check In Dialog for File with No Changes (Microsoft Office 2003)"

    • Check in file to check the file in with no changes. In the Check In Comments dialog (Figure 19-21), optionally enter new comments, then click OK.

    • Keep checked out to close the file, but keep it in a checked out and locked to changes by other users. To later cancel the checked out status, see Section 19.3.4.3, "Checking a File Out."

    • Discard changes and undo check out to cancel the checked out status.

  3. Click OK.

In Microsoft Office 2007: To close a file that has not been modified since the last time it was checked in:

  • Click the Office Button (Figure 19-40) in the top left corner of the Microsoft Office application, then choose Close.

    Figure 19-40 Office Button in Microsoft Office

    Office Button in Microsoft Office

If a file is unchanged, Microsoft Office 2007 does not prompt you to first check the file back in again. If saving to a local draft folder instead of the Content Server repository (see Section 19.2, "Configuring Microsoft Office Integration with WebCenter Portal"), the file remains in a checked out status and locked to changes by other users, and you will need to explicitly cancel the checked out status (see Section 17.8.1, "Checking a File Out"). If saving to the Content Server repository, the checked out status is canceled upon closing the file.

19.3.5.2.2 Closing an Updated File

In Microsoft Office 2003: To close a file that has been modified since the last time it was checked in:

  1. From the File menu, select Close.

  2. In the Check In dialog (Figure 19-41), select one of the following actions:

    Figure 19-41 Check In Dialog for File with Changes (Microsoft Office 003)

    Description of Figure 19-41 follows
    Description of "Figure 19-41 Check In Dialog for File with Changes (Microsoft Office 003)"

    • Save changes and check in to save the changes since the last check in and check the file in.

    • Save changes only to save changes since the last check in, but keep the file checked out and locked to changes by other users. To later cancel the checked out status, see Section 19.3.4.3, "Checking a File Out."

    • Discard changes and undo check out to retain the prior saved version of the file and cancel the checked out status.

    • Discard changes only to retain the prior saved version of the file and keep the file checked out.

  3. Click OK.

In Microsoft Office 2007: To close a file that has been modified since the last time it was checked in:

  1. Click the Office Button (Figure 19-42) in the top left corner of the Microsoft Office application, then choose Close.

    Figure 19-42 Office Button in Microsoft Office

    Office Button in Microsoft Office
  2. If you have not already saved the changes, respond to the confirmation prompt to save or discard your changes.

  3. In the confirmation dialog (Figure 19-43), respond to the prompt:

    Figure 19-43 Close File Confirmation Prompt (Microsoft Office 2007)

    Description of Figure 19-43 follows
    Description of "Figure 19-43 Close File Confirmation Prompt (Microsoft Office 2007)"

19.4 Working with Microsoft Windows Explorer Integration

WebCenter Portal integrates with Microsoft Windows Explorer to manage the folders and files in the Home portal or a group portal when the back-end content repository is Content Server.

In WebCenter Portal, the most useful feature of Windows Explorer integration is the ability to add multiple files at once to a portal, rather than uploading up to 10 files at a time (see Section 17.5.1, "Uploading Files"). It is important to be aware that Windows Explorer is not designed as a content repository, so if you try to open, delete, or rename a file that is checked out by another user, an error message displays to notify you that the operation failed, but the error message will not be specific as to the cause of the failure.

To expose the folders and files in a portal in Windows Explorer, you create a new Windows network place to work with the files, as described in the following sections:

19.4.1 Adding a Portal as a Network Place

To expose the folders and files in a portal using Windows Explorer, you can add the portal as a Windows network place.

To add a portal as a Windows network place:

  1. Open the Add Network Place/Location wizard:

    • In Microsoft Windows XP, open My Network Places and click Add Network Place.

    • In Microsoft Windows 7, right-click My Computer, and choose Add a Network Location.

    Refer to the Microsoft Windows online help for more information

  2. In the Add Network Place/Location wizard, enter the network address using the following format:

    Tip:

    The host name and port is shown in the browser URL for your WebCenter Portal application.

    To find the name of the repository server:

    • On the Documents page of the portal you want to connect to, or the Home portal, from the View menu, select Containing Folder Info.

    • Use the portion of the Identifier value that precedes the pound (#) sign as the repository server value. For example, if the Identifier value is myserver-ucm#dCollectionID:549132825864000605, then the repository server value is myserver-ucm.

    • To access all portals in your WebCenter Portal application through Windows Explorer:

      http://hostname:port/wcsdocs/conn/repository_server/spaces/

      For example:

      http://myserver:8888/wcsdocs/conn/myserver-ucm/spaces/

    • To access the Home portal through Windows Explorer:

      http://hostname:port/wcsdocs/conn/repository_server/spaces/PersonalSpaces/username

      For example:

      http://myserver:8888/wcsdocs/conn/myserver-ucm/spaces/PersonalSpaces/wcsadmin

    • To access a specific portal through Windows Explorer:

      http://hostname:port/wcsdocs/conn/repository_server/spaces/instance/spacename

      For example:

      http://myserver:8888/wcsdocs/conn/myserver-ucm/spaces/WebCenter/philatelists

  3. At the prompt, enter your WebCenter Portal login credentials.

  4. Optionally enter a name for the portal network place, then click Finish.

    Windows Explorer displays a drive for all portals or the folders and files of a portal, depending on the URL you entered.

19.4.2 Working with Files Using Windows Explorer

Once you have created a Windows network place to a portal (see Section 19.4.1, "Adding a Portal as a Network Place"), you can manage the folders and files using Windows Explorer.

Note:

If a portal moderator changes the internal name of a portal, the original network place to that individual portal is no longer accessible. You will need to add the portal as a Windows network place again using the new portal internal name. Changing the internal name of a portal has no effect if you create a network place to the parent URL for all portals (http://hostname:port/wcsdocs/conn/repository_server/spaces/).

In Windows Explorer, navigate to the network place for the portal to perform any of the following actions:

When you open a file, an attempt is made to check the file out. If it is checked out by another user, or you do not have permissions to update the file, it will open read-only. A file remains checked out until you check it back in (see Section 19.3.4.4, "Checking a File In").

The changes you make in Windows Explorer are reflected in WebCenter Portal, and vice versa.

Note:

To use the WebCenter Portal application to manage folders and files in a portal in any connected content repository, see Chapter 17, "Creating and Managing Documents."