Oracle Tuxedo Plug-in for Oracle Solaris Studio User’s Guide

     Previous  Next    Open TOC in new window    View as PDF - New Window  Get Adobe Reader - New Window
Content starts here

Developing an Oracle Tuxedo ATMI Application Project

The following sections briefly describe the steps for developing an Oracle Tuxedo ATMI application project in the IDE. Details on all of the steps are contained in the Developing Oracle Tuxedo Applications section of the online help in the IDE. To open the online help in the IDE, choose Help > Help Contents.

 


Using the Project Templates

A Tuxdo ATMI application consists of a set of servers and clients, and the ubbconfig.ubb configuration file, VIEW files, and FML tables that describe them

With the plug-in installed, the Oracle Solaris Studio IDE includes three project templates for creating the elements of an Oracle Tuxedo ATMI application:

To use these templates, choose File > New Project and select the Tuxedo category in the New Project Wizard.

 


Creating an ATMI Application Project

The steps for creating an ATMI application are:

  1. Create an ATMI Application project by choosing File > New Project, and selecting the Tuxedo category and the Tuxedo ATMI Application project type. The New Project Wizard guides you through creating the project.
  2. Add ATMI servers by creating Tuxedo ATMI Server projects.
  3. Add ATMI clients by creating Tuxedo ATMI Client projects
  4. Add services to the servers and clients by adding a service metadata input (MIF) file to your project, and then generating services in your server and client projects.
  5. Edit VIEW/VIEW32 or FML/FML32 files in the Editor window, using the Text tab to edit the file directly or the Visual tab to edit the table view of the file.
Note: You can open and edit all of the source code files created in the application, server, and client projects by clicking the Files tab in the IDE and opening the files in the Editor window.

 


Building an ATMI Application Project

Build an application, server, or component project by right-clicking the project node and choosing Build.

 


Running an SCA Application Project

To run your ATMI application project, right-click the project node and choose Start.

To stop a running ATMI application project, right-click the project node and choose Stop

 


Debugging an ATMI Application Project

Debug the server part of the ATMI application by setting breakpoints in the source code files, and right-clicking the server node and choosing Debug.

Debug the client part of the application by setting breakpoints in the source code files, and right-clicking the client node and choosing debug.

You can use the features of the debugger in the IDE to step through your code, display the call stack, and view the values of variables.

For detailed information on debugging the project, see the Debugging a Project with dbx section of the online help in the IDE.


  Back to Top       Previous  Next