man pages section 1M: System Administration Commands

Exit Print View

Updated: July 2014
 
 

poweradm(1M)

Name

poweradm - manage power management properties

Synopsis

poweradm [-v] get [-a all|smf|platform|current] property ...
poweradm [-v] set property=value ...
poweradm [-v] list
poweradm show
poweradm -?

Description

The poweradm program is used to display and manage the Power Management settings within a Solaris instance.

The Power Management properties and their values are stored in the service management facility (see smf(5)).

All users can run the list, get, and show forms given in the SYNOPSIS. These commands allow all users to view the current Power Management settings within a Solaris instance.

Only users and roles that belong to the Maintenance and Repair RBAC profile can execute the set form of poweradm given in the SYNOPSIS. See also the NOTES section below.

poweradm supports the following service property:

administrative-authority

The value for this property is specified as a string and can have the values:

  • smf

  • platform

  • none

...with platform as the default value. The significance of this property is the source of administrative control for power management within the Solaris kernel. That is, this property indicates the origin of time-to-full-capacity and time-to-minimum-responsiveness settings within the Solaris kernel. Only a Solaris user with appropriate privileges can set this property.

When the administrative-authority is set to platform the values of time-to-full-capacity and time-to-minimum-responsiveness will be taken from the platform code. Setting these values in SMF, using the poweradm command will have no effect upon the values in the kernel. The poweradm list command will indicate that the kernel is currently using the platform values. As these values are changed by the platform administrator, so they will be modified in the kernel. Also, commands to enable or disable the power management within the Solaris kernel will come from the platform code. On systems that run virtual machines, the hypervisor or virtual machine manager can be the source of this property.

When the administrative-authority is set to smf, the values of time-to-full-capacity and time-to-minimum-responsiveness will be taken from SMF. As these values in SMF are changed by the Solaris administrator, so they will be applied to the kernel. Setting these values in the platform will have no effect upon the values in the kernel while administrative-authority is set to smf. Under this condition, the poweradm command will indicate that the kernel is currently using the values from SMF. As these values are changed by the Solaris administrator, so they will be modified in kernel.

When the administrative-authority is set to none, power management within the Solaris kernel will be turned off, although the power service will continue to run. Any power management instructions from the platform will be ignored, as will the settings in SMF. Only when administrative-authority is set to one of the other values will power management within the Solaris kernel restart, using the settings from the specified source.

time-to-full-capacity

Specified in microseconds.

This parameter constrains the dynamic capacity adjustment allowed while the system is in an active state.

This parameter defines the maximum time the system is allowed to reach (re-provision and make available) its full capacity, returning from any lower-capacity/less-responsive state, while it has been using any or all of the PM features falling within this bound.

By default, this value is taken from the platform (for example, i86pc), because the default setting for administrative-authority is set to platform.

Alternatively, if administrative-authority is set to smf, this value is taken from the definition provided by the power service (that is, SMF). At install time this value is set to be undefined. If the Solaris administrator chooses to modify this property, a value appropriate to the needs of the workload or applications must be picked.

time-to-minimum-responsiveness

Specified in milliseconds.

This parameter constrains the dynamic capacity adjustment allowed while the system is in an inactive state.

This parameter defines how long the system is allowed to return to its active state—that is, to provide the minimum capacity required to meet the above time-to-full-capacity constraint.

Moderate values (seconds) allow hardware components or subsystems on the platform to be placed in slower-response inactive states; larger values still (for example, 30 seconds to minutes) allow for such as whole system suspension, using techniques such as suspend-to-RAM.

By default, this value is taken from the platform (for example, i86pc), because the default setting for administrative-authority is set to platform.

Alternatively, if administrative-authority is set to smf, this value is taken from the definition provided by the power service (that is, SMF). At install time this value is set to be undefined. If the Solaris administrator chooses to modify this property, a value appropriate to the needs of the workload or applications must be picked.

suspend-enable

By default no machine running Solaris is permitted to attempt a suspend operation. Setting this property to true will permit a suspend operation to be attempted. The value of administrative-authority has no effect upon this property.

platform-disabled

This property cannot be changed by the poweradm command. The value of platform-disabled can be viewed by running the list subcommand. If set to true and administrative-authority is set to platform, power management has been disabled by the platform. If set to false, control of power management will be through the values of the other properties, described above. The output of the show subcommand will display the values of these properties. On systems that run virtual machines, the hypervisor or virtual machine manager can be the source of platform-disabled. The default value for platform-disabled is false.

Options

The following options are supported.

–?

Display a synopsis of available subcommands and options.

–v

Provide verbose output. Can be used with any of the subcommands listed below.

Sub Commands

The following subcommands are supported:

get [–a all|smf|platform|current]

Retrieves the current value of the named property. The –a option can be used to indicate the origin of the value either: SMF (smf), the platform (platform), the current value used by the kernel (current) or all of the preceeding (all). By default, if no origin is specified then current is assumed.

The administrative-authority and suspend-enable properties do not have a platform value

set property=value...

Changes the named property to the given value. The properties administrative-authority and suspend-enable are automatically synchronized to the new value in the kernel. The properties time-to-full-capacity and time-to-minimum-responsiveness are synchronized to the kernel if and only if administrative-authority is set to smf. If the –v option is used and the kernel cannot be updated immediately because administrative-authority is not set to smf, a warning message will be issued.

Only users and roles that belong to the Maintenance and Repair RBAC profile can execute the set subcommand.

list

Lists all the available Power Management properties values and indicate whether power management is active.

show

Output human readable text that indicates whether the platform or the Solaris instance is controlling power management, whether power management is enabled, and, if it is enabled, the values of time-to-full-capacity and time-to-minimum-responsiveness.

Examples

Example 1 Setting Platform to Control Power Management

The following command sets the platform to control power management.

# poweradm set administrative-authority=platform
Example 2 Disabling Power Management

The following command disables power management.

# poweradm set administrative-authority=none
Example 3 Setting Useful Parameters

The following sequence of commands sets time-to-full-capacity to 300 microseconds, setstime-to-minimum-responsiveness to 500 milliseconds, and informs the Solaris instance of the new values.

# poweradm set time-to-full-capacity=300
# poweradm set time-to-minimum-responsiveness=500
# poweradm set administrative-authority=smf
Example 4 Disabling Suspend and Resume

The following command disables suspend and resume.

# poweradm set suspend-enable=false
Example 5 Listing Power Management Properties

The following command lists all available power management properties.

# poweradm list
Example 6 Obtaining Value of a Property

The following command shows the current value of time-to-full-capacity.

# poweradm get time-to-full-capacity
Example 7 Showing Value of a Property as Set by Platform

The following command retrieves the value of time-to-full-capacity set by the platform.

# poweradm get -a platform time-to-full-capacity

Note that this will only be the same as current value if administrative-authority has been set to platform. See the explanation of the administrative-authority property, above.

Example 8 Showing Value of a Property as Set by Solaris Instance

The following command retrieves the value of time-to-full-capacity set by the Solaris instance.

# poweradm get -a smf time-to-full-capacity

Note that this will only be the same as current value if administrative-authority has been set to smf. See the explanation of the administrative-authority property, above.

Example 9 Invoking show Subcommand

The following example commands illustrate the four possible contexts in which poweradm show can be invoked.

The following command is invoked when power management has been disabled by the platform.

# poweradm show
Power management is disabled with the hardware platform as the authority

The following command is invoked when power management has been disabled by the Solaris administrator.

# poweradm show
Power management is disabled with the Solaris instance as the authority

The following command is invoked when power management has been enabled by the platform.

# poweradm show
Power management is enabled with the hardware platform as the authority
time-to-full-capacity 300 microseconds
time-to-minimum-responsiveness 500 milliseconds

The following command is invoked when power management has been enabled by the Solaris instance.

# poweradm show
Power management is enabled with the Solaris instance as the authority
time-to-full-capacity 300 microseconds
time-to-minimum-responsiveness 500 milliseconds

Exit Status

0

Successful completion.

1

An error occurred.

2

Invalid command line options were specified.

Attributes

See attributes(5) for descriptions of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Availability
system/kernel/power
Interface Stability
Committed

See also

attributes(5), smf(5), smf_security(5)

Notes

The power service is managed by the service management facility, smf(5), under the service identifier:

svc:/system/power:default

The properties that can be set by poweradm are defined in that service as:

  • active_control/administrative-authority, which is described under administrative-authority above

  • active_config/time-to-full-capacity, which is described under time-to-full-capacity above

  • active_config/time-to-minimum-responsiveness, which is described under time-to-minimum-responsiveness above

  • suspend/suspend-enable, which is described under suspend-enable above

If the service is disabled, no power management settings will be uploaded to the kernel in the future. Existing settings will not be undone until the next reboot. Disabling all power management is best accomplished by setting administrative-authority to none.

If administrative-authority is set to the value smf before both time-to-full-capacity and time-to-minimum-responsiveness have been set, the service will go into maintenance mode. In such a situation, set administrative-authority to the value none then set both time-to-full-capacity and time-to-minimum-responsiveness to the values you want, clear the service and then set administrative-authority to smf.

To set properties in the active_config and suspend property groups, the solaris.smf.value.power_config authorization is required. To set properties in the active_control property group requires the solaris.smf.value.power_control authorization is required. Both of these authorizations are part of the Maintenance and Repair profile.