man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: July 2014
 
 

net_getnetid(9F)

Name

net_getnetid - returns the instance identifier

Synopsis

#include <sys/neti.h>

netid_t net_getnetid(const net_data_t net);

Interface Level

Solaris DDI specific (Solaris DDI).

Parameters

net

value returned from a successful call to net_protocol_lookup(9F).

Description

The net_getnetid() function returns the instance identifier for the protocol instance returned via a call to net_protocol_lookup(9F).

Return Values

The net_getnetid() function returns the value of the instance identifier.

Context

The net_getnetid() function may be called from user, kernel, or interrupt context.

Attributes

See attributes(5) for descriptions of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Availability
system/core-os
Interface Stability
Committed

See also

net_protocol_lookup(9F)