man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: July 2014
 
 

nvlist_exists(9F)

Name

nvlist_lookup_nvpair, nvlist_exists - lookup named pairs

Synopsis

#include <libnvpair.h>

int nvlist_lookup_nvpair(nvlist_t *nvl, const char *name,
     nvpair_t **nvp);
boolean_t nvlist_exists(nvlist_t *nvl, const char *name);

Description

The nvlist_lookup_nvpair() function returns the nvpair with the matching name, regardless of type. It is valid only for lists allocated with NV_UNIQUE_NAME. See nvlist_alloc(9F).

The nvlist_exists() function returns success if any nvpair exists with the given name. It is valid for all types of lists.

Return Values

The nvlist_lookup_nvpair() function returns 0 on success and an error value on failure.

The nvlist_exists() function returns B_TRUE if an nvpair with the given name exists and B_FALSE otherwise.

Errors

The nvlist_lookup_nvpair() function will fail if:

EINVAL

There is an invalid argument.

ENOENT

No matching name-value pair is found.

ENOTSUP

The list was not allocated with NV_UNIQUE_NAME.

Attributes

See attributes(5) for descriptions of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Interface Stability
Committed

See also

nvlist_lookup_nvpair(3NVPAIR), nvlist_alloc(9F), attributes(5)