man pages section 9: DDI and DKI Properties and Data Structures

Exit Print View

Updated: July 2014
 
 

free_rtn(9S)

Name

free_rtn - structure that specifies a driver's message-freeing routine

Synopsis

#include <sys/stream.h> 

Interface Level

Architecture independent level 1 (DDI/DKI).

Description

The free_rtn structure is referenced by the datab structure. When freeb(9F) is called to free the message, the driver's message-freeing routine (referenced through the free_rtn structure) is called, with arguments, to free the data buffer.

Structure Members


void     (*free_func)()      /* user's freeing routine */
char     *free_arg           /* arguments to free_func() */

The free_rtn structure is defined as type frtn_t.

See also

esballoc(9F), freeb(9F), datab(9S)

STREAMS Programming Guide