Skip Headers
Oracle® Application Express Installation Guide
Release 4.2

E35123-05
Go to Documentation Home
Home
Go to Book List
Book List
Go to Table of Contents
Contents
Go to Index
Index
Go to Master Index
Master Index
Go to Feedback page
Contact Us

Go to previous page
Previous
Go to current chapter
Up
Go to next page
Next
PDF · Mobi · ePub

2 Oracle Application Express Installation Requirements

This chapter describes the requirements for installing Oracle Application Express.

Topics:

2.1 Oracle Database Requirement

Oracle Application Express release 4.2 requires an Oracle database (Enterprise Edition, Standard Edition or Standard Edition One) that is Release 10.2.0.4 or higher. Oracle Application Express 4.2 can also be used with Oracle Database Express Edition 10g Release 2 and later. The Oracle HTTP Server is not included with the distribution of Oracle Database Express Edition.

Note:

You can upgrade the version of Oracle Application Express in Oracle Database Express Edition 10g Release 2 (10.2) and later, by installing Oracle Application Express release 4.2. For more information, see the Oracle Application Express Learn More page on the Oracle Technology Network (OTN).

2.1.1 Checking the shared_pool_size of the Target Database

Note:

Ignore this requirement if your configuration defines specific memory target values for the database initialization parameters SGA_TARGET (in Oracle Database 10g and 11g) or MEMORY_TARGET (in Oracle Database 11g).

Oracle Application Express requires the shared_pool_size of the target database to be at least 100 MB.

To check the shared_pool_size of the target database:

  1. Start the database:

    SQL> STARTUP
    
  2. If necessary, enter the following command to determine whether the system uses an initialization parameter file (initsid.ora) or a server parameter file (spfiledbname.ora):

    SQL> SHOW PARAMETER PFILE;
    

    This command displays the name and location of the server parameter file or the initialization parameter file.

  3. Determine the current values of the shared_pool_size parameter:

    SQL> SHOW PARAMETER SHARED_POOL_SIZE
    
  4. If the system is using a server parameter file, set the value of the SHARED_POOL_SIZE initialization parameter to at least 100 MB:

    SQL> ALTER SYSTEM SET SHARED_POOL_SIZE='100M' SCOPE=spfile;
    
  5. If the system uses an initialization parameter file, change the value of the SHARED_POOL_SIZE parameter to at least 100 MB in the initialization parameter file (initsid.ora).

  6. Shut down the database:

    SQL> SHUTDOWN
    
  7. Restart the database:

    SQL> STARTUP
    

2.2 Browser Requirements

To run or develop Oracle Application Express applications, Web browsers must have JavaScript enabled. The following browsers are required to develop applications in Oracle Application Express:

Oracle Application Express applications can be developed that support earlier Web browser releases, including Microsoft Explorer 6.0. Application Express has a number of advanced widgets, such as date pickers, which may not work correctly on earlier browsers.

2.3 Web Listener Requirements

In order to run Oracle Application Express you must have access to one of the following:

The following products include appropriate versions of HTTP Server and mod_plsql:

2.4 Disk Space Requirement

Oracle Application Express disk space requirements are as follows:

2.5 Oracle XML DB Requirement

Oracle XML DB must be installed in the Oracle database that you want to use. If you are using a preconfigured database created either during an installation or by Database Configuration Assistant (DBCA), Oracle XML DB is already installed and configured.

See Also:

Oracle XML DB Developer's Guide for more information about manually adding Oracle XML DB to an existing database

Tip:

The installer does a prerequisite check for Oracle XML DB and will exit if it is not installed.

Tip:

The installation of Oracle XML DB creates the user ANONYMOUS. In order for Oracle Application Express workspace provisioning to work properly, the ANONYMOUS user must not be dropped from the database.

2.6 PL/SQL Web Toolkit

Oracle Application Express requires the PL/SQL Web Toolkit release 10.1.2.0.6 or later. For instructions on determining the current release of the PL/SQL Web Toolkit, and for instructions on installing release 10.1.2.0.6, please review the README.txt file contained in the directory apex/owa.