3.4 Upgrading OFED Packages

If you have enabled the ol6_ofed_UEK channel, you must remove any existing OFED packages for the 32-bit x86 architecture before you can upgrade the remaining OFED packages on your system. You must also completely remove and reinstall the ibutils packages. The latest version of the ibutils package no longer depends on an ibutils-libs package as the libraries are now included in ibutils itself.

  1. Use the following command to remove any non-upgradable packages for the x86 architecture:

    # rpm -e infiniband-diags-1.5.12-5.el6.i686 \
    libibcm-1.0.5-3.el6.i686 \
    libibcm-devel-1.0.5-3.el6.i686 \
    libibmad-1.3.9-1.el6.i686 \
    libibmad-devel-1.3.9-1.el6.i686 \
    libibumad-1.3.8-1.el6.i686 \
    libibumad-devel-1.3.8-1.el6.i686 \
    libibverbs-1.1.6-5.el6.i686 \
    libibverbs-devel-1.1.6-5.el6.i686 \
    libmlx4-1.0.4-1.el6.i686 \
    librdmacm-1.0.17-0.git4b5c1aa.el6.i686 \
    librdmacm-devel-1.0.17-0.git4b5c1aa.el6.i686 \
    opensm-devel-3.3.15-1.el6.i686 \
    opensm-libs-3.3.15-1.el6.i686 \
    ibacm-devel-1.0.8-0.git7a3adb7.el6.i686
  2. Enter the following commands to remove the existing ibutils and ibutils-libs packages and install the new ibutils package:

    # rpm -e ibutils-1.5.7-7.el6.x86_64 \
    ibutils-libs-1.5.7-7.el6.x86_64
    # yum install ibutils