JavaScript is required to for searching.
탐색 링크 건너뛰기
인쇄 보기 종료
Oracle Solaris 11.1 시스템     Oracle Solaris 11.1 Information Library (한국어)
search filter icon
search icon

문서 정보

머리말

제1부Oracle Solaris 11.1 설치 옵션

1.  설치 옵션 개요

제2부설치 매체를 사용하여 설치

2.  설치 준비

3.  라이브 매체 사용

4.  텍스트 설치 프로그램 사용

5.  매체에서 부트하는 자동 설치

6.  Oracle Solaris 인스턴스 구성 해제 또는 재구성

제3부설치 서버를 사용하여 설치

7.  다중 클라이언트의 자동 설치

8.  설치 서버 설정

9.  설치 사용자 정의

10.  클라이언트 시스템 프로비전

11.  클라이언트 시스템 구성

12.  영역 설치 및 구성

13.  처음 부트 중 사용자 정의 스크립트 실행

처음 부트 시 한번 실행 컨트롤 구현

처음 부트 시 한번 실행을 보증하는 방법

처음 부트 시 실행할 스크립트 만들기

SMF 매니페스트 파일 만들기

매니페스트 만들기 도구 사용

생성된 매니페스트 사용자 정의

스크립트 및 서비스에 대한 IPS 패키지 만들기

IPS 패키지를 만들어 게시하는 방법

AI 클라이언트에 처음 부트 패키지 설치

IPS 패키지를 설치하는 방법

처음 부트 서비스 테스트

스크립트 또는 서비스를 업데이트하는 방법

14.  클라이언트 시스템 설치

15.  자동 설치 문제 해결

제4부관련 작업 수행

A.  Oracle Configuration Manager 작업

B.  Device Driver Utility 사용

색인

처음 부트 시 실행할 스크립트 만들기

스크립트에 사용할 수 있는 소스를 알려면 처음 부트 시 클라이언트 시스템에 설치된 도구를 알아야 합니다. solaris-large-server 패키지가 기본적으로 설치됩니다. 해당 그룹 패키지를 설치한 경우 Python, bash, ksh 및 기타 처음 부트 시 사용 가능한 도구가 제공됩니다. solaris-large-server 그룹 패키지에 포함될 전체 패키지 목록은 Oracle Solaris 11.1 소프트웨어 패키지 추가 및 업데이트의 그룹 패키지의 설치 가능한 모든 패키지 나열에 설명된 대로 pkg contents 명령을 사용하십시오. solaris-large-server 패키지에 제공되지 않은 스크립트의 소스를 사용하려면 필요한 패키지를 식별하고 AI 매니페스트에 지정하십시오. 설치할 다른 패키지의 이름을 찾는 방법은 Oracle Solaris 11.1 소프트웨어 패키지 추가 및 업데이트를 참조하십시오.


참고 -


예 13-1 템플리트 처음 부트 스크립트

이 예는 처음 부트 스크립트에서 수행할 작업을 보여줍니다.

기본적으로 shksh93임을 잊지 마십시오.

#!/bin/sh

# Load SMF shell support definitions
. /lib/svc/share/smf_include.sh

# If nothing to do, exit with temporary disable
completed=`svcprop -p config/completed site/first-boot-script-svc:default`
[ "${completed}" = "true" ] && \
    smf_method_exit $SMF_EXIT_TEMP_DISABLE completed "Configuration completed"

# Obtain the active BE name from beadm: The active BE on reboot has an R in
# the third column of 'beadm list' output. Its name is in column one.
bename=`beadm list -Hd|nawk -F ';' '$3 ~ /R/ {print $1}'`
beadm create ${bename}.orig
echo "Original boot environment saved as ${bename}.orig"

# Place your one-time configuration tasks here

# Record that this script's work is done
svccfg -s site/first-boot-script-svc:default setprop config/completed = true
svcadm refresh site/first-boot-script-svc:default

smf_method_exit $SMF_EXIT_TEMP_DISABLE method_completed "Configuration completed"

예 13-2 다중 IP 인터페이스를 구성하는 처음 부트 스크립트

이 예는 두 IP 인터페이스에 주소를 구성하고 기본 경로를 추가하는 first-boot-script.sh라는 처음 부트 스크립트를 보여줍니다.

#!/bin/sh

# Load SMF shell support definitions
. /lib/svc/share/smf_include.sh

# If nothing to do, exit with temporary disable
completed=`svcprop -p config/completed site/first-boot-script-svc:default`
[ "${completed}" = "true" ] && \
    smf_method_exit $SMF_EXIT_TEMP_DISABLE completed "Configuration completed"

# Obtain the active BE name from beadm: The active BE on reboot has an R in
# the third column of 'beadm list' output. Its name is in column one.
bename=`beadm list -Hd|nawk -F ';' '$3 ~ /R/ {print $1}'`
beadm create ${bename}.orig
echo "Original boot environment saved as ${bename}.orig"

# Create and configure addresses on two IP interfaces
/usr/sbin/ipadm create-ip net0
/usr/sbin/ipadm create-ip net1
/usr/sbin/ipadm create-addr -a 10.153.125.222/24 net0
/usr/sbin/ipadm create-addr -a 169.254.182.77/24 net1

# Add a default route with net0 as the gateway
/usr/sbin/route add default 10.153.125.1 -ifp net0

# Record that this script's work is done
svccfg -s site/first-boot-script-svc:default setprop config/completed = true
svcadm refresh site/first-boot-script-svc:default

smf_method_exit $SMF_EXIT_TEMP_DISABLE method_completed "Configuration completed"