Skip to Main Content
Return to Navigation

Using PTF Explorer

PTF Explorer gives you access to the PTF test assets (tests, test cases, libraries, and logs) stored within an application database. Assets appear in a tree structure with collapsible folders for organizing test assets. PTF Explorer is the first pane visible to the user after startup. It is labeled with the name of the PTF environment:

Image: Example of the PTF Explorer User interface for the PB_Demo Environment

This example illustrates the PTF Explorer user interface for the PB_Demo environment.

Example of the PTF Explorer user interface for the PB_Demo environment

You use PTF Explorer to:

Using myFolder

The PTF Explorer tree contains a folder called myFolder. You can use myFolder to store tests that you do not want to share with other users. Users with the PTF User role can create, edit, and delete tests only in myFolder.

PTF Explorer Menus

The following menus appear when PTF Explorer has focus. Note that many menu commands are specific to a currently selected item. The PTF Explorer menu name corresponds to the name of the current PTF environment. In the previous example, the PTF Explorer menu name is PBDEMO.

This table describes the PTF Explorer PTF menu commands:

PTF Menu Command

Usage

Refresh

Refreshes the current view.

Local Options

Opens the Local Options dialog box.

Execution Options

Opens the Execution Options dialog box.

This table describes the PTF Explorer Test menu commands:

Test Menu Command

Usage

Open

Opens the selected test or test case.

Delete

Deletes the selected test.

Rename

Select to rename the selected test or test case.

Refresh Selection

Refreshes the view for the selected test.

Expand Selection

Expands all the branches in the selected node.

Collapse Selection

Collapses all the branches in the selected node.

The PTF Explorer Edit menu contains standard Microsoft edit commands, such as Cut, Copy, and Paste, and the following PTF Explorer Edit menu command in the table.

This table lists the additional PTF Explorer Edit menu command:

Edit Menu Command

Usage

Copy Link to Clipboard

Copies the link to the selected test to the clipboard. You can use this information in conjunction with the Quick Open command.

Use the PTF Explorer Create menu to create folders and tests.

This table describes the Create menu commands:

Create Menu Command

Usage

Folder

Creates a new folder within the selected folder.

Test

Creates a new test in the selected folder.

Shell Test

Creates a shell test in the selected folder.

This table describes the PTF Explorer Tools menu commands:

Tools Menu Command

Usage

Message

Opens the Message tool, which enables you to monitor test execution. The Message tool displays details about the current step, including name, object type, and value.

Log Manager

Opens the Log Manager tool, which enables you to delete logs from tests.

This table describes the PTF Explorer Window menu command:

Window Menu Command

Usage

Quick Open

Opens a test, test case or a text execution log with data that was copied to the clipboard using the Copy Link to Clipboard command.

Using the Copy Link to Clipboard command and the Quick Open command together enables users to easily share tests without having to navigate to the test in PTF Explorer. You can select a test and select Edit, Copy Link to Clipboard. Then, you paste that data into a text message and send it to another user, who can then copy and paste the data into the Quick Open dialog box and open the test.

PTF Explorer Tree Functionality

Based on the item or items selected in the tree view, when you right-click a list of valid actions is displayed. The tree view supports multiple selections. The following actions are supported with multi-select:

  • Cut and paste folders and tests.

  • Delete tests and folders.

  • Expand and collapse tests and folders.

The valid actions are based on the PTF role associated with the logged on user.