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C H A P T E R 1

Introduction

The Oracle Tuxedo Plug-in for Oracle Solaris Studio 12.3 adds Oracle Tuxedo development 
support to the Oracle Solaris Studio IDE. This support lets you use the features of the IDE to 
quickly and easily develop Oracle Tuxedo SCA and ATMI applications.

The IDE works with your separately installed Oracle Tuxedo so that you can create, build, run, 
and debug application, server, component, and client projects.

The following sections introduce you to the basics of a project in the IDE, and describe how to 
install the plug-in and its prerequisite software.

Oracle Solaris Studio and the IDE

Using Tuxedo Projects in the IDE

Installing and Setting Up the Plug-in and Its Prerequisites

Starting the IDE

Uninstalling the Oracle Tuxedo Plug-in

Oracle Solaris Studio and the IDE
Oracle Solaris Studio comprises a suite of tools for application development on Oracle Solaris 
and Linux operating environments, including C, C++, and Fortran compilers, the dbx debugger, 
and performance and code analysis tools.
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The Oracle Solaris Studio 12.3 IDE (Integrated Development Environment) provides modules 
for creating, editing, building, and debugging C, C++, and Fortran applications using a graphical 
user interface and the Oracle Solaris Studio compilers and tools.

Using Tuxedo Projects in the IDE
In the Oracle Solaris Studio IDE, all development has to take place within a project. A project is 
a group of C, C++, or Fortran files, and the settings with which you build, run, and debug those 
source files.

The IDE stores all of the information about your project in makefiles, a properties file, and a few 
XML configuration files. You can build and run your projects outside the IDE exactly the same 
as inside the IDE.

The Oracle Studio IDE includes several project templates that are used when creating new 
projects. The Oracle Solaris Studio Tuxedo plug-in for the IDE adds templates and support for 
Oracle Tuxedo projects for SCA and ATMI applications.

Installing and Setting Up the Plug-in and Its 
Prerequisites

The Oracle Solaris Studio Oracle Tuxedo plug-in requires that you have Oracle Solaris Studio 
and Oracle Tuxedo installed on an Oracle Solaris 10, Linux, or Oracle Solaris 11 platform. It also 
requires an IDE patch, which is provided with the plug-in.

Installing Oracle Solaris Studio and Oracle Tuxedo
Before installing the plug-in, you must install Oracle Solaris Studio 12.3.

Installing on an Oracle Solaris 10 or Linux Platform
To install Oracle Solaris Studio 12.3 on an Oracle Solaris 10 or Linux platform:

1. Download Oracle Solaris Studio 12.3 from the download page at 
http://www.oracle.com/technetwork/server-storage/solarisstudio/downloads/index-jsp-1411
49.html.

2. Accept the license agreement, and download either the package installer or the tarfile for your 
platform.
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3. If you downloaded the package installer, unpack it with the following command and then 
follow the instructions in the Oracle Solaris Studio 12.3 Installation Guide to install Oracle 
Solaris Studio in the default installation directory /opt. If you downloaded the tarfile, which 
extracts the installed version of Oracle Solaris Studio software (no packages), unpack it in the 
directory of your choice with the following command:

bzcat download_directory/SolarisStudio12.3-OS-PLATFORM-FORMAT.tar.bz2 | 
/bin/tar -xf -

Installing on an Oracle Solaris 11 Platform
To install Oracle Solaris Studio 12.3 on an Oracle Solaris 11 platform:

1. On the Oracle Certificate Requests page (https://pkg-register.oracle.com/register/status), 
request an Oracle Solaris Studio certificate.

2. Accept the Software License Agreement.

3. Follow the instructions on the Certificate Information page to download the key and 
certificate and install them, install the Oracle Solaris Studio publisher, and then install the 
Oracle Solaris Studio packages.

Setting the Path to Your Installed Oracle Solaris Studio
To set the path to your installed Oracle Solaris Studio:

On Solaris platforms, add the path 
/installation_directory/solarisstudio12.3/bin to your PATH.

On Linux platforms, add the path 
/installation_directory/oracle/solarisstudio12.3/bin to your PATH.

The default installation directory is /opt.

Installing Oracle Tuxedo
To use the features of the plug-in in the IDE, you must have Oracle Tuxedo and Oracle Service 
Architecture Leveraging Tuxedo (SALT) installed. You can download this software from the 
download page at 
http://www.oracle.com/technetwork/middleware/tuxedo/downloads/index.html.

http://docs.oracle.com/cd/E24457_01/html/E21988/index.html
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Setting the Path to Your Installed Oracle Tuxedo
If you add the path to your installed Oracle Tuxedo to your PATH, the IDE will find it. Otherwise 
you will need to set the path using the Options window after you start the IDE.

Installing the Oracle Tuxedo Plug-in and IDE Patch
You can download the Oracle Tuxedo plug-in and the required IDE patch for Oracle Solaris 10 
and Linux platforms from the download page at 
http://www.oracle.com/technetwork/server-storage/solarisstudio/downloads/solaris-studio-tuxe
do-plugin-1669907.htm. The download page also includes instructions for installing the plug-in 
and patch on Oracle Solaris 11 platforms.

Installing on an Oracle Solaris 10 or Linux Platform
If you installed Oracle Solaris Studio 12.3 using its package installer, then download the package 
for the plug-in and IDE patch and install them by doing the following:

1. Unpack the download tarfile by typing:

bzcat 
download_directory/solarisstudio12.3-tuxedoplugin12.3-PLATFORM-FORMAT.t
ar.bz2 | /bin/tar -xf -

2. Become superuser (root) by typing:

su
Password: root-password

3. Install the IDE patch, located in the patch directory, by following the instructions in its 
README file.

4. Install the plug-in, located in the package directory, by doing one of the following:

– On Solaris platforms, type:

pkgadd -d SPRO-12-3-tuxedo-plugin

– On Linux platforms, type:

rpm -i solarisstudio12.3-tuxedo-plugin-12.3-1.x86_64.rpm 

If you installed Oracle Solaris Studio12.3 by extracting it from the download tarfile, then do the 
following:

1. Download the tarfile for the plug-in and IDE patch and unpack it by typing:
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bzcat solarisstudio12.3-tuxedoplugin12.3-PLATFORM-bin.tar.bz2

2. Go to the directory where Oracle Solaris Studio 12.3 is installed (for example, /opt) and 
unpack the tarfile: 

/bin/tar -xf download_directory/tuxedo-plugin.tar

Starting the IDE
To start the Oracle Solaris Studio IDE, type:

solstudio &

Uninstalling the Oracle Tuxedo Plug-in
If you installed the plug-in using the download package, uninstall it by doign one of the 
following:

On Solaris platforms, type:

pkgrm SPRO-12-3-tuxedo-plugin

On Linux platforms, type:

rpm -e solarisstudio12.3-tuxedo-plugin-12.3-1

The Oracle Solaris Studio uninstaller does not remove the plug-in. You can run the Oracle Solaris 
Studio uninstaller after you have removed the plug-in.



In t roduct ion

1-6 Oracle Tuxedo Plug-in for Oracle Solaris Studio User’s Guide



Oracle Tuxedo Plug-in for Oracle Solaris Studio User’s Guide 2-1

C H A P T E R 2

Developing an Oracle Tuxedo SCA 
Application Project

The following sections briefly describe the steps for developing an Oracle Tuxedo SCA 
application project in the IDE. Details on all of the steps are contained in the Developing Oracle 
Tuxedo Applications section of the online help in the IDE. To open the online help in the IDE, 
choose Help > Help Contents.

Using the Project Templates

Creating an SCA Application Project

Building an SCA Application Project

Running an SCA Application Project

Debugging an SCA Application Project

Using the Project Templates
A Tuxedo SCA application consists of a set of servers and the ubbconfig.ubb and 
root.composite configuration files that describe them. A server consists of a set of 
components in which services are defined.

With the plug-in installed, the Oracle Solaris Studio IDE includes three project templates for 
creating the elements of an Oracle Tuxedo SCA application:

Tuxedo SCA Application

Tuxedo SCA Server
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Tuxedo SCA Component

To use these templates, choose File > New Project and select the Tuxedo category in the New 
Project Wizard.

Creating an SCA Application Project
The steps for creating an SCA application are:

1. Create an SCA Application project by choosing File > New Project, and selecting the Tuxedo 
category and the Tuxedo SCA Application project type. The New Project Wizard guides you 
through creating the project. 

2. Add SCA servers by creating Tuxedo SCA Server projects.

3. Add SCA components by creating SCA Component projects.

4. Add services to the SCA components by doing one of the following:

– Right-clicking the Service node of the component porject and choosing Add Service

– Adding a service metadata input (MIF) file to your project.and then generating a new 
service from the file

– Adding a web service definition (WSDL) file and then generating a new sercvice from 
the file

5. If you want to use a service in other servers in the SCA application than the one in which you 
created it, promote the service to make it accessible to these servers. 

You can also promote an SCA service to use as a web service.

6. If you want to use an SCA service declared in another server or component, add a reference 
in the server or component project.

7. To use your libraries in an SCA component, add the library directories to the linker properties 
of the project.

8. Add the client part of the SCA application by adding tests in the Test folders of the server 
projects.

Note: You can open and edit all of the source code files created in the application, server, and 
component projects by clicking the Files tab in the IDE and opening the files in the Editor 
window.
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Building an SCA Application Project
Build an application, server, or component project by right-clicking the project node and 
choosing Build.

Running an SCA Application Project
To run your SCA application project, right-click the project node and choose Start.

To stop a running SCA application project, right-click the project node and choose Stop.

Debugging an SCA Application Project
Debug the server part of the SCA application by setting breakpoints in the source code file of a 
server project, and right-clicking the server node and choosing Debug.

Debug the client part of the application by debugging the client executable files in the tests in the 
Test folders of the server projects.

You can use the features of the debugger in the IDE to step through your code, display the call 
stack, and view the values of variables.

For detailed information on debugging the project, see the Debugging a Project with dbx section 
of the online help in the IDE.
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C H A P T E R 3

Developing an Oracle Tuxedo ATMI 
Application Project

The following sections briefly describe the steps for developing an Oracle Tuxedo ATMI 
application project in the IDE. Details on all of the steps are contained in the Developing Oracle 
Tuxedo Applications section of the online help in the IDE. To open the online help in the IDE, 
choose Help > Help Contents.

Using the Project Templates

Creating an ATMI Application Project

Building an ATMI Application Project

Running an SCA Application Project

Debugging an ATMI Application Project

Using the Project Templates
A Tuxdo ATMI application consists of a set of servers and clients, and the ubbconfig.ubb 
configuration file, VIEW files, and FML tables that describe them

With the plug-in installed, the Oracle Solaris Studio IDE includes three project templates for 
creating the elements of an Oracle Tuxedo ATMI application:

Tuxedo ATMI Application

Tuxedo ATMI Server

Tuxedo ATMI Client
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To use these templates, choose File > New Project and select the Tuxedo category in the New 
Project Wizard.

Creating an ATMI Application Project
The steps for creating an ATMI application are:

1. Create an ATMI Application project by choosing File > New Project, and selecting the 
Tuxedo category and the Tuxedo ATMI Application project type. The New Project Wizard 
guides you through creating the project.

2. Add ATMI servers by creating Tuxedo ATMI Server projects.

3. Add ATMI clients by creating Tuxedo ATMI Client projects

4. Add services to the servers and clients by adding a service metadata input (MIF) file to your 
project, and then generating services in your server and client projects.

5. Edit VIEW/VIEW32 or FML/FML32 files in the Editor window, using the Text tab to edit the 
file directly or the Visual tab to edit the table view of the file.

Note: You can open and edit all of the source code files created in the application, server, and 
client projects by clicking the Files tab in the IDE and opening the files in the Editor 
window.

Building an ATMI Application Project
Build an application, server, or component project by right-clicking the project node and 
choosing Build.

Running an SCA Application Project
To run your ATMI application project, right-click the project node and choose Start.

To stop a running ATMI application project, right-click the project node and choose Stop

Debugging an ATMI Application Project
Debug the server part of the ATMI application by setting breakpoints in the source code files, and 
right-clicking the server node and choosing Debug.

Debug the client part of the application by setting breakpoints in the source code files, and 
right-clicking the client node and choosing debug.
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You can use the features of the debugger in the IDE to step through your code, display the call 
stack, and view the values of variables.

For detailed information on debugging the project, see the Debugging a Project with dbx section 
of the online help in the IDE.
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