JavaScript is required to for searching.
Skip Navigation Links
Exit Print View
Sun Ethernet Fabric Operating System

IGMP Administration Guide

search filter icon
search icon

Document Information

Using This Documentation

Product Notes

Related Documentation

Acronyms and Abbreviations

CLI Command Modes

Feedback

Support and Accessibility

Protocol Description

IGMP Protocol

IGMP Topology

Configuring IGMP

Example Topology

Configuration Guidelines

Default Settings

Enable IGMP Globally

Enable IGMP on an Individual Interface

Enable Fast Leave

Configure the IGMP Version

Configure the IGMP Query Interval

Configure the IGMP Query Maximum Response Time

Configure the IGMP Robustness Value

Configure the IGMP Last Member Query Interval

Configure a Static-Multicast Group Membership

Enable the IGMP Proxy Service

Configure an Interface as an Upstream Interface

Configure the Purge Interval for an Upstream Interface

Configure the IGMP Version on an Upstream Interface

Configure the IGMP Proxy

Configure the IGMP Proxy

This section shows how to set up an IGMP topology.

  1. On the router, create VLAN 2 and VLAN 3, and associate the ports to the corresponding VLAN.
    SEFOS# configure terminal
    SEFOS(config)# vlan 2
    SEFOS(config-vlan)# ports extreme-ethernet 0/1 untagged extreme-ethernet 0/1
    SEFOS(config-vlan)# exit
    SEFOS(config)# interface extreme-ethernet 0/1
    SEFOS(config-if)# switchport access vlan 2
    SEFOS(config-if)# exit
    SEFOS(config)# interface vlan 2
    SEFOS(config-if)# shutdown
    SEFOS(config-if)# ip address 12.0.0.1 255.0.0.0
    SEFOS(config-if)# no shutdown
    SEFOS(config-if)# exit
    SEFOS(config)# vlan 3
    SEFOS(config-vlan)# ports extreme-ethernet 0/2 untagged extreme-ethernet 0/2
    SEFOS(config-vlan)# exit
    SEFOS(config)# interface extreme-ethernet 0/2
    SEFOS(config-if)# switchport access vlan 3
    SEFOS(config-if)# no shutdown
    SEFOS(config-if)# exit
    SEFOS(config)# interface vlan 3
    SEFOS(config-if)# shutdown
    SEFOS(config-if)# ip address 20.0.0.1 255.0.0.0
    SEFOS(config-if)# no shutdown
    SEFOS(config-if)# end
  2. Verify the changes to the VLAN configuration.
    SEFOS# show ip interface
     
    vlan1 is up, line protocol is down
    Internet Address is 10.0.0.1/8
    Broadcast Address  10.255.255.255
     
    vlan2 is up, line protocol is up
    Internet Address is 12.0.0.1/8
    Broadcast Address  12.255.255.255
     
    vlan3 is up, line protocol is up
    Internet Address is 20.0.0.1/8
    Broadcast Address  20.255.255.255
  3. Review the VLAN database information.
    SEFOS# show vlan brief
     
    Vlan database
    -------------
    Vlan ID             : 2
    Member Ports        : Ex0/1
    Untagged Ports      : Ex0/1
    Forbidden Ports     : None
    Name                :
    Status              : Permanent
    ----------------------------------------------------
    Vlan ID             : 3
    Member Ports        : Ex0/2
    Untagged Ports      : Ex0/2
    Forbidden Ports     : None
    Name                :
    Status              : Permanent
    ----------------------------------------------------
    Vlan ID             : 1
    Member Ports        : Ex0/3, Ex0/4, Ex0/5, Ex0/6, Ex0/7, Ex0/8
                          Ex0/9, Ex0/10, Ex0/11, Ex0/12, Ex0/13, Ex0/14
                          Ex0/15, Ex0/16, Ex0/17, Ex0/18, Ex0/19, Ex0/20
                          Ex0/21, Ex0/22, Ex0/23, Ex0/24
    Untagged Ports      : Ex0/3, Ex0/4, Ex0/5, Ex0/6, Ex0/7, Ex0/8
                          Ex0/9, Ex0/10, Ex0/11, Ex0/12, Ex0/13, Ex0/14
                          Ex0/15, Ex0/16, Ex0/17, Ex0/18, Ex0/19, Ex0/20
                          Ex0/21, Ex0/22, Ex0/23, Ex0/24
    Forbidden Ports     : None
    Name                :
    Status              : Permanent
    ----------------------------------------------------
  4. Enable IGMP and the IGMP proxy service globally on the VLANs.
    SEFOS# configure terminal
    SEFOS(config)# set ip igmp enable
    SEFOS(config)# ip igmp proxy-service
    SEFOS(config)# interface vlan 2
    SEFOS(config-if)# set ip igmp enable
    SEFOS(config-if)# exit
    SEFOS(config)# interface vlan 3
    SEFOS(config-if)# set ip igmp enable
    SEFOS(config-if)# end
  5. Configure VLAN 2 as an upstream interface to receive the incoming data packets.
    SEFOS# configure terminal
    SEFOS(config)# interface vlan 2
    SEFOS(config-if)# ip igmp-proxy mrouter
    SEFOS(config-if)# end
  6. For VLAN 3 (224.1.1.1), add a static-multicast group membership.
    SEFOS# configure terminal
    SEFOS(config)# interface vlan 3
    SEFOS(config-if)# ip igmp static-group 224.1.1.1
    SEFOS(config-if)# end

    Note - Adding a static group membership is not required if the device connected to the VLAN 3 interface is capable of sending an IGMP membership report to the switch.


  7. Verify the changes to the IGMP configuration.
    SEFOS# show ip igmp global-config
     
     IGMP is globally enabled
     IGMP Proxy is globally enabled in the system
  8. Review the configuration information.
    SEFOS# show ip igmp interface
     
     vlan2, line protocol is up
     Internet Address is 12.0.0.1/8
     IGMP is enabled on interface
     Interface is configured as Upstream interface
     
    vlan3, line protocol is up
     Internet Address is 20.0.0.1/8
     IGMP is enabled on interface
     Current IGMP router version is 2
     IGMP query interval is 125 seconds
     Last member query response interval is 10 seconds
    IGMP max query response time is 100 seconds
    Robustness value is 2
     IGMP querying router is 20.0.0.1 (this system)
     Fast leave is disabled on this interface
     Number of multicast groups joined 1
  9. Review the IGMP group information.
    SEFOS# show ip igmp groups
     
    I - Include Mode,  E - Exclude Mode
    S - Static Mbr,    D - Dynamic Mbr
     
    GroupAddress  Flg  Iface  UpTime        ExpiryTime    LastReporter
    -----------  ----  ---   -------        ----------     -----------
    224.1.1.1     S   vlan3 [0d 00:03:02.86] [0d 00:00:00.00]  0.0.0.0
  10. Verify that the multicast data from VLAN 2 is forwarded to VLAN 3.

    At the packet generator, create and transmit a valid multicast data packet with destination IP address 224.1.1.1 and source IP address 12.0.0.x. Ensure that the packet is received by the packet capturing device.