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Preface

This guide includes some information on third-party software products used by Oracle Communications MetaSolv Solution. However, this information is limited to information needed to install and perform initial configuration tasks. If you need additional information on a third-party software application, consult the documentation provided by the product's manufacturer.


Audience

This guide is for individuals responsible for installing or maintaining MetaSolv Solution and ensuring the software is operating as required. This guide assumes the installer has an Oracle DBA and WebLogic administrator background, with a working knowledge of Windows 2000 or higher and JEE.

	
Programmers, program analysts, and system analysts who are familiar with SQL and gather requirements for reports.


	
Database administrators and system analysts who design, build, and customize reports.


	
Management or administrative personnel responsible for generating reports.








Related Documents

For more information, see the following documents in Oracle Communications MetaSolv Solution 6.2.1 documentation set:

	
MSS Planning Guide: Describes information you need to consider in planning your MetaSolv Solution environment prior to installation.


	
MSS Installation Guide: Describes system requirements and installation procedures for installing MetaSolv Solution.


	
MSS System Administrator's Guide: Describes post-installation tasks and administrative tasks such as maintaining user security.


	
MSS Database Change Reference: Provides information on the database changes for the MetaSolv Solution 6.2.1 release. Database changes for subsequent maintenance releases will be added to this guide as they are released.


	
MSS Network Grooming User's Guide: Provides information about the MSS Network Grooming tool.


	
MSS Technology Module Guide: Describes each of the MetaSolv Solution technology modules.


	
MSS Data Selection Tool How-to Guide: Provides an overview of the Data Selection Tool, and procedures on how it used to migrate the product catalog, equipment specifications, and provisioning plans from one release of your environment to another.


	
MSS CORBA API Developer's Reference: Describes how MetaSolv Solution APIs work, high-level information about each API, and instructions for using the APIs to perform specific tasks.


	
MSS Custom Extensions Developer's Reference: Describes how to extend the MetaSolv Solution business logic with custom business logic through the use of custom extensions.


	
MSS XML API Developer's Reference: Describes how to integrate MetaSolv Solution with other Oracle products, or with external applications, through the use of APIs.


	
MSS Flow-through Packages Guide: Describes information and procedures you need to install and work with the flow-through packages provided by Oracle as an example of how to integrate MetaSolv Solution with ASAP for flow-through activation.




For step-by-step instructions for tasks you perform in MetaSolv Solution, log into the application to see the online Help.





Documentation Accessibility

For information about Oracle's commitment to accessibility, visit the Oracle Accessibility Program website at http://www.oracle.com/pls/topic/lookup?ctx=acc&id=docacc.


Access to Oracle Support

Oracle customers have access to electronic support through My Oracle Support. For information, visit http://www.oracle.com/pls/topic/lookup?ctx=acc&id=info or visit http://www.oracle.com/pls/topic/lookup?ctx=acc&id=trs if you are hearing impaired.








1 About MSS Operational Reports

Oracle Communications MetaSolv Solution (MSS) Operational Reports provides the vital business intelligence you need by giving you immediate access to critical information maintained within MetaSolv Solution through reports.

MSS Operational Reports offers three separate universes and each universe represents a key functional area in MetaSolv Solution, such as customer, ordering, and engineering. Each universe is supported by individual reporting kits. Each kit contains a set of reports for a specific area.

MSS Operational Reports gives you the ability to customize the universes and reports. You can add new reports quickly using the supplied objects and filters. A simple drag-and-drop interface makes it easy to create, modify, and filter reports. In addition, you can add calculations and queries to customize the data.

MSS Operational Reports is built using SAP Business Objects 4.0 technology. The MSS Operational Reports solution requires separate licensing of Business Objects 4.0 Universe Design Tool, Central Management Console, and Web Intelligence. The Web Intelligence Client enables you to use reporting universes to create and maintain reports on the Internet.


About Business Objects 4.0

Business Objects 4.0 is an integrated query, reporting and analysis tool. It allows you to access data stored in the MetaSolv Solution databases directly from your desktop and analyze this information in a Business Objects 4.0 report. Business Objects 4.0 does not require you to have any knowledge of the database structure or technology. You can present the information that you retrieve in reports in the form of tables or as dynamic documents with drillable charts. You can save these documents for your own personal use, send them to others, or publish them to the corporate repository for broader circulation.


Business Object 4.0 Components

Figure 1-1 summarizes the Business Objects 4.0 components and security for everything in the Central Management Console.


Figure 1-1 Business Objects 4.0 Components

[image: Description of Figure 1-1 follows]






Business Objects 4.0 consists of the following components:

	
Repository: Storehouse for all of the Business Objects 4.0 reporting.


	
Central Management Console: Maintains the repository, the repository information, and security for everything in the repository.


	
Universe Design Tool: Enables you to design universes, objects, and filters for the reports.


	
Web Intelligence: Enables you to design and generate the reports.








Solution Structure

MSS Operational Reports consists of the following components:

	
Business Object 4.0 Tools

	
Web Intelligence is used to build and customize reports. You are required to have a Web Intelligence license to create reports.


	
Universe Design Tool is used to maintain the universe. It is a development tool used only by the universe administrator and developers.


	
Central Management Console provides security. It allows you to maintain strict control over the data down to the object level. It also enables you to build a repository that contains universes and reports, which you can distribute through the client/server platform.





	
Universes

The universe contains a metadata subset of the MetaSolv Solution database structure and the relationships between those tables. The metadata is contained in the objects and the filters that are used to create reports. It is the container that holds the key pieces required to build a report. With Web Intelligence, you can use the universes and its components to construct new reports and customize MetaSolv Solution's standard reporting set.

	
Customer Universe: Contains customer information, such as address, service items, and deposit information, along with customer service sales information. It enables you to keep track of sales performance of an individual or a product type. Security features also allow you to keep track of user names and privileges.


	
Ordering Universe: Centered on service requests. It contains the objects necessary to generate information on all types of service requests (ASR, ISR, PSR, and LSR). It also contains work management and provisioning objects that let you uncover problems in your order fulfillment and activation cycle.


	
Engineering Universe: Contains the objects necessary to report on circuits, equipment, infrastructure, threshold management, and capacity management. An equipment kit contains reports that you can use to monitor equipment usage and audit equipment implementation.





	
Reports

MSS Operational Reports gives you the ability to customize the universes and reports. You can add new reports quickly using the supplied objects and filters. A simple drag-and-drop interface makes it easy to create, modify, and filter reports.

You can use data from multiple sources to create reports. Using Web Intelligence, you can merge data from two separate data sources. For example, the MetaSolv Solution database could be queried for a list of customers, and then a billing database could be queried for additional billing information. You can show these two reports together as one report. Business Objects 4.0 supports data retrieval from spreadsheets and other flat files that you can use in combination with the data retrieved from MSS Operational Reports universes.

Business Objects 4.0 uses a document repository for distributing reports and universes to multiple users. You can log in to the repository and retrieve documents, or create and send reports to other users.








Installation

Install and configure the following software:

	
SAP BusinessObjects BI platform 4.0 SP4:

	
SAP BusinessObjects Enterprise Server 4.0 SP4 (64-bit)—Includes the Central Management Console.


	
SAP BusinessObjects BI platform 4.0 Client Tools SP4 (32-bit or 64-bit)—Includes the Universe Design Tool and the Web Intelligence Client.







Ensure that the service pack versions of both the server and client software are the same.


Software and Licensing Requirements

Contact SAP for your software and licensing requirements.









Upgrading Business Objects XI R2 to 4.0

See the following Web page for information about upgrading from Business Objects XI R2 to Business Objects 4.0:

http://wiki.sdn.sap.com/wiki/display/BOBJ/How+to+Upgrade+to+BI4.0





Support and Maintenance

MSS Operational Reports may be enhanced when new versions of the MetaSolv Solution data model are released. These enhancements are available to MetaSolv Solution users who have signed maintenance agreements. The enhancements include any additional objects, filters, and reports for new data structures and new requirements.

The customer's maintenance contract covers support for MSS Operational Reports; however, Oracle does not support any issues with Business Objects 4.0.

Table 1-1 provides information about the error messages and whom you should contact if you encounter them.


Table 1-1 Error Message Contact Information

	Error Message	Contact
	
ADM, DMA, UNV, or USR prefixes are the most common.

	
SAP


	
ORA prefix.

	
Oracle


	
Data in report does not match data in MetaSolv Solution.

	
Oracle














2 Using MSS Operational Reports

Before using Oracle Communications MetaSolv Solution (MSS) Operational Reports, you are required to complete training on SAP Business Objects 4.0 Central Management Console, Universe Design Tool, and Web Intelligence.

This chapter outlines the common procedures used in MSS Operational Reports. This chapter does not replace Business Objects 4.0 training and should be used as a supplement to additional information specific to MSS Operational Reports.



Database Connections

Ensure that you are using the correct database connection when generating reports. This connection directs the universe to the database from which to retrieve information.


Connecting to the Database

To connect to a database:

	
Open the Universe Design Tool.


	
From the Tools menu, select Connections.

The Connection Panel is displayed.


	
Select a connection and click Close.









Adding a Connection

To add a connection:

	
Open the Universe Design Tool.


	
From the Tools menu, select Connections.

The Connection Panel is displayed.

[image: This image is described in the surrounding text.]

	
Click the Add icon.

The Define a new connection - Welcome to the New Connection Wizard [1/2] window is displayed.

[image: This image is described in the surrounding text.]

	
From the Connection Type list, select one of the following:

	
Personal: A personal connection is only available on the machine that you are working on.


	
Secured: A secured connection is necessary to import and export from the repository. This is the default connection type.


	
Shared: A shared connection is necessary to transfer a universe to another repository.





	
In the Connection Name field, specify a name for your connection.


	
In the Connection Folder field, browse and choose your connection folder.


	
(Optional) In the Connection Description area, provide a description for your connection.


	
Click Next.

The Define a new connection - Database Middleware Selection [2/2] window is displayed.

[image: This image is described in the surrounding text.]

	
Expand the Oracle node, then expand the Oracle 11 node, and then select JDBC Drivers or Oracle Client.


	
Click Next.

The Define a new connection - Login parameters [3/5] window is displayed.

[image: This image is described in the surrounding text.]

	
From the Authentication Mode list, select Use specified username and password.


	
In the User Name field, enter ASAP or an Oracle user name that has access to all the ASAP tables.


	
In the Password field, enter your password.


	
In the Server(s) (host:port{,host:port}) field, enter the server name and port. This connection should point to where the data for the reports is stored. For example, the MetaSolv Solution database.


	
In the Net Service field, enter the SID.


	
Click Test Connection.

The Test the connection window is displayed and informs you that the server is responding.

[image: This image is described in the surrounding text.]

	
Click OK.


	
Click Next.

The Define a new connection - Configuration Parameters [4/5] window is displayed.

[image: This image is described in the surrounding text.]

	
From the Connection Pool Mode list, select Keep the connection active for.


	
In the Pool Timeout field, enter 10.


	
In the Array Fetch Size field, retain the default value of 250.


	
In the Array Bind Size field, enter a value.


	
In the Login Timeout field, enter a value. This field considers the unit of time in seconds.


	
(Optional) In the JDBC Driver Properties (key=value,key=value) field, enter a value.


	
Click Next.

The Define a new connection - Custom Parameters [5/5] window is displayed.

[image: This image is described in the surrounding text.]

	
Click Finish.









Editing a Connection

To edit a connection:

	
Open the Universe Design Tool.


	
From the Tools menu, select Connections.

The Connection Panel is displayed.


	
Select the connection you want to edit.


	
Click the Edit icon.


	
Make your changes and click Next to navigate through the Edit connection - Login parameters, Configuration Parameters, and Custom Parameters windows.


	
Click Finish.


	
Click Close.









Removing a Connection

To remove a connection:

	
Open the Universe Design Tool.


	
From the Tools menu, select Connections.

The Connection Panel is displayed.


	
Select the connection you want to remove.


	
Click the Remove icon.

A confirmation message is displayed.


	
Click Yes.


	
Click Close.









Installing a New MetaSolv Solution Universe

When installing a new MetaSolv Solution universe, do the following:

	
Download the new MetaSolv Solution universe


	
Export the universe to a repository


	
Create a sandbox




The repository should already be created.

To download a new MetaSolv Solution universe:

	
Download the newest versions of the MetaSolv Solution universes from the Oracle software delivery Web site:

https://edelivery.oracle.com




To export a universe to a repository:

	
Open the Universe Design Tool.


	
From the File menu, select Open.

The Open window is displayed.


	
Open the universe file.


	
From the File menu, select Parameters.

The Universe Parameters window is displayed.


	
From the Connection list, select a secure connection.


	
Click OK.


	
From the File menu, click Save.


	
Repeat steps 2 through 7 for each new universe.


	
From the File menu, select Export.

The Export Universe window is displayed. Verify that all the universes are displayed in the Export Universe window.


	
Do one of the following:

	
If all the universes appear in the Export Universe window, click OK.


	
If a universe is missing, click the Add button, and navigate to the location where you saved the universes. Select the missing universe and click OK.





	
Close the universes.




You can now associate a connection to the universe. See "Associating a Connection to the Universe" for more information.






Associating a Connection to the Universe

To associate the connection to the universe:

	
Open the Universe Design Tool.


	
From the File menu, select Open.

The Open window is displayed.


	
Open the universe file.


	
From the File menu, select Parameters.

The Universe Parameters window is displayed.


	
From the Connection list, select a secure connection.


	
Click OK.


	
From the File menu, click Save.


	
Repeat steps 2 through 7 for each new universe.


	
From the File menu, select Export to make it available to all users of the repository.

The Export Universe window is displayed. Verify that all the universes are displayed in the Export Universe window.


	
Do one of the following:

	
If all the universes appear in the Export Universe window, click OK.


	
If a universe is missing, click the Add button, and navigate to the location where you saved the universes. Select the missing universe and click OK.












Connections

Connections in Business Objects 4.0 refer to creating a connection to the database that contains the data used to generate reports. In a single repository, you can create numerous connections to many databases.

You can create new connections using the Universe Design Tool. The security information is stored in the Central Management Console.

The types of information are as follows:

	
Security


	
Document


	
Universe




Table 2-1 describes the repository connections.


Table 2-1 Definition of Repository Connections

	Repository Connections (Domain)	Description
	
Security

	
Defined when setting up access to the repository through Central Management Console. This cannot be modified.


	
Document

	
Defines the location of documents within the repository. Multiple document domains can be used.


	
Universe

	
Defines the location of universes within the repository. Multiple universes can be used.








The connections are defined by the universes. Therefore, while developing a document, it is created from the custom universe. The universe controls the connection to the database. See the scenario in Figure 2-1 for an overview of the connection relationships.


Figure 2-1 Overview of Connection Relationships

[image: Description of Figure 2-1 follows]






The SQL behind an object/filter can change in the universe without the report needing to be updated, because Web Intelligence refers to the universe before dynamically creating the SQL to run the report.






Creating a Sandbox

You must create and customize sandbox universes. When you upgrade MetaSolv Solution, you can download the universes that pertain to the upgraded version from the Oracle software delivery Web site:

Any new universes that are downloaded overwrite the existing MetaSolv Solution universes.

To create a sandbox:

	
Open the Universe Design Tool.


	
From the File menu, select New.

The Universe Parameters window is displayed.


	
On the Definition tab, do the following:

	
In the Name field, enter a name for the universe.


	
From the Connection list, select a secure connection.





	
On the Links tab, click Add Link.


	
Navigate to the folder named after the repository, select the appropriate universe.


	
Click OK.


	
From the File menu, click Save.


	
Repeat steps 2 through 7 for each new universe.


	
From the File menu, select Export.

The Export Universe window is displayed. Verify that all the universes are displayed in the Export Universe window.


	
Do one of the following:

	
If all the universes appear in the Export Universe window, click OK.


	
If a universe is missing, click the Add button, and navigate to the location where you saved the universes. Select the missing universe and click OK.












Creating, Modifying, and Deleting Categories for Report Kits

Creating categories allows you to organize reports into specific into smaller or functional groups. Security can be applied to categories to give access to specified users. Oracle recommends creating your categories before installing the report kits.

To create a category:

	
Open the Central Management Console by entering the following in a Web browser:

http://localhost:port/BOE/CMC

where:

localhost is the server on which the Business Objects 4.0 is installed.

port is the server's HTTP port number.


	
Click Categories.


	
Right-click the Categories folder and select New.

The Create Category window is displayed.


	
In the Enter a new category name field, enter a name for the category.


	
Click OK.




To modify a category:

	
Open the Central Management Console.


	
Click Categories.


	
Right-click the category you want to modify and select Properties.

[image: This image is described in the surrounding text.]

The Properties window is displayed.

[image: This image is described in the surrounding text.]

	
In the Category Name field, modify the category name.


	
Click Save & Close.




To delete a category:

	
Open the Central Management Console.


	
Click Categories.


	
Right-click the category you want to delete and select Delete.

A confirmation message is displayed.


	
Click OK.









Installing a Reporting Kit

To install a reporting kit:

	
Download the reporting zip file from the Oracle software delivery Web site.


	
Extract the zip files to any folder.


	
Open the Web Intelligence Client.

[image: Surrounding text describes opr_using_webi_doc_browse.gif.]

	
Under the Open Document section, click browse.


	
Open all the reports in a reporting kit.


	
From the File menu, select Save to Enterprise.

[image: This image is described in the surrounding text.]

The Save Document window is displayed.

[image: This image is described in the surrounding text.]

	
On the Folders tab or Categories tab, select a folder or a category in which you want to save the report.


	
Click Save.


	
Repeat this procedure for each report in the kit.









Customizations

This section provides an overview of guidelines for customization, report customization, using sandbox universes for customization, and linking universes best practices.


Guidelines for Customization

All of the universe customizations occur originally in sandbox universes. You must follow the procedures to create sandbox universes and customize those universes so that you do not lose your customizations. When you upgrade MetaSolv Solution, you can download the universes that pertain to that upgraded version from the Oracle software delivery Web site. Any new universes that you download will overwrite the existing MetaSolv Solution universes.

The following general rules enable you to receive requirements from a user:

	
Determine if an existing report can meet at least some of the needs.


	
Determine how many of the requirements exist among the list of current objects, measures, and filters.


	
Determine which universe is the closest to meeting your needs.


	
Determine what you have to map into a Sandbox universe linked to the universe you have chosen.


	
Determine if the tables that you need exist in the universe.


	
Determine if you need to create an alias in order for the report to run correctly.


	
Determine if you can reuse an existing object as a base to what you need to create.




The changes that you make in the sandbox are available for reporting but are not affected by universe updates.





Report Customization

You can customize your reports in two ways. You may need to create a new report or alter an existing report, but do not require any new or modified objects in the reporting universe. These customizations can be made in the Web Intelligence Query Panel. Figure 2-2 displays the Web Intelligence Query Panel.


Figure 2-2 Web Intelligence Query Panel

[image: Description of Figure 2-2 follows]






When creating custom reports from MetaSolv Solution reports, name the customized report differently from the MetaSolv Solution report. This allows the original MetaSolv Solution reports to be used multiple times in custom report creation.

When forwarding this report to others or if other Business Objects 4.0 users want to access this report without first exporting the report to the repository, select the Save for all users check box in the Save Document window before saving the report.

When importing the report into another repository, select the Remove document security check box in the Save Document window before saving the report.

Figure 2-3 shows the Save Document window.


Figure 2-3 Save Document Window

[image: This image is described in the surrounding text.]



You may need reporting requirements that are not presently satisfied by existing reporting objects in the reporting universe. This type of customization is more complex, because it requires making modifications to the reporting universes and is done by the universe designer.





Sandbox Universes for Customization

When MSS Operational Reports is installed at a customer site, each reporting universe is locked and then linked to a Sandbox universe which contains each universe. This sandbox environment allows for the augmentation of a baseline reporting universe without requiring the baseline itself to be modified. This design approach allows for upgrades of the MSS Operational Reports product, and the baseline universes without affecting any customizations made by the customer. When the baseline universes are updated, the sandbox universe merely needs to be re-linked to the baseline which preserves any prior customizations.

Figure 2-4 illustrates where the updates occur.


Figure 2-4 Overview of Customer Data Security During Updates

[image: Description of Figure 2-4 follows]






When you need to report on data that is not defined as objects in the baseline reporting universes, you must create those objects in the sandbox environment associated with the respective universe and not in the baseline universe itself. Reports can be created or modified with the newly defined objects once the objects have been created and defined in the sandbox universe, and the sandbox universe has been saved and exported.





Linking Universes Best Practices

Do not use the Include option when linking the baseline and sandbox universe to remain compliant with MetaSolv Solution's maintenance protocol. This option merges the two universes, thereby making them appear as one. This complicates further updates to the product. Linking the universes allows you to see everything, use everything, and add customizations without losing any customizations when you must update the baseline universes.

You must avoid creating links between the universes that MetaSolv Solution provides, or between custom universes and the MetaSolv Solution universes. This can create additional or redundant relationships or joins between the tables in the database, thus confusing the Business Objects 4.0 SQL generator. You cannot use the resulting universe until you resolve the redundant relationships or loops.








Transferring Customized Universes and Reports

If you are maintaining multiple repositories, such as a development, testing, and production repositories, a different set of procedures is used to determine what items need to be transferred when moving universes or reports between repositories.

When transferring customized universes and reports, you need to complete the following:

	
Determine what to transfer


	
Prepare the universe for transfer between repositories


	
Transfer the document between repositories


	
Prepare the production repository for the transfer of the universe


	
Prepare the production repository for the transfer of the documents


	
Move the universe from one repository to another


	
Move documents from one repository to another





Transferring Universes and Documents Between Repositories

Customized documents are created in the sandbox universe. The universe controls the connection to the database. Figure 2-5 shows the overall hierarchy.


Figure 2-5 Overview of Connection Relationships

[image: Description of Figure 2-5 follows]






The SQL behind an object/filter can change in the universe without the report needing to be updated, because Web Intelligence refers to the universe before dynamically creating the SQL to run the report. Therefore, if the changes have been made only in the custom universe, you must transfer only the universe.

If the only changes that have occurred are in a document, whether it is a new or modified report, then only the report needs to be transferred. This assumes that the report is not using any new objects created in the custom universe to support this report.

If the custom universe has changed and the document is new or modified, then you must transfer both the universe and the document.

To prepare a universe for transfer between repositories:

	
Open the Universe Design Tool in the repository you want to move the universe from.


	
From the File menu, select Import.

The Import Universe window is displayed.


	
Select the universe that you want to transfer and click OK.

The universe is imported.


	
From the File menu, select Parameters.

The Universe Parameters window is displayed.

[image: This image is described in the surrounding text.]

	
On the Definition tab, from the Connection list, select a shared connection.


	
To add a new connection, click New. When creating a connection ensure that you select Shared from the Connection Type list. See "Adding a Connection" for more information.


	
From the File menu, select Save As.

The Save As window is displayed.

[image: This image is described in the surrounding text.]

	
Select the Save for all users check box.

You can change the name of the universe if you want. The name of the file should not be more than eight characters. For example, create a folder named Shared.


	
Navigate to the new folder.


	
Click Save.

This universe is ready to be transferred.


	
Repeat steps 2 through 10 for all the universes that you want to transfer.




To transfer a document between repositories:

	
Open the Web Intelligence Client.

[image: Surrounding text describes opr_using_webi_doc_browse.gif.]

	
Under the Open Document section, click browse.

The Open a document from server window is displayed.

[image: This image is described in the surrounding text.]

	
Click My Enterprise, log on to the server and select your category, and then select the report and click Open. To search for reports, enter the report name in the Search title field and click the Search icon.


	
Click Title to sort by the name of the report.


	
Select the report you want to move and click Open.


	
From the File menu, select Save As.

The Save Document window is displayed.

[image: This image is described in the surrounding text.]

	
Select the Save for all users and Remove document security check boxes and change the name of the report, if required.


	
Click Save.




To prepare the production repository for the transfer of universes:

	
Open the Central Management Console by entering the following in a Web browser:

http://localhost:port/BOE/CMC

where:

localhost is the server on which the Business Objects 4.0 is installed.

port is the server's HTTP port number.


	
Click Universes.

The list of universes is displayed.

[image: This image is described in the surrounding text.]

	
From the list of universes, right click the universe and select Delete.

You do not have to delete the universe, you can overwrite it.


	
Repeat this procedure for each universe you want to delete.




To move a universe from one repository to another:

	
Open the Universe Design Tool and ensure that it is connected to the destination repository.


	
From the File menu, select Open.


	
Navigate to the folder where the shared universes are saved, select the file, and then click Open.

The universe opens.


	
From the File menu, select Parameters.

The Universe Parameters window is displayed.


	
From the Connection list, select a secured connection.


	
Click OK.


	
From the File menu, click Save.


	
From the File menu, select Export.

The Export Universe window is displayed.


	
Click OK.

You receive a message that informs you that the universe was successfully exported when you transfer your universe from one repository to another.


	
Repeat steps 2 through 9 for all the universes that you want to move.




To move documents from one repository to another:

	
Open the Web Intelligence Client and ensure that it is connected to the destination repository.


	
Under the Open Document section, click browse.


	
Navigate to the document/report you want to move and click Open.


	
Click the Data button on the top right corner.


	
Under Data, right-click the universe and select Change Source.

[image: Surrounding text describes opr_using_webi_chng_src.gif.]

The Change Source Wizard is displayed.

[image: This image is described in the surrounding text.]

	
To change the universe that the report is associated to, select the Specify a new data source option.


	
From the Select a data source list, select Universe.

The Universe window is displayed.

[image: This image is described in the surrounding text.]

	
Select a universe to which you want to associate the report and click Select.

The selected universe is displayed under the Specify a new data source option.

[image: The image is described in the surrounding text.]

	
Click Next.

The Change Source Wizard - Object Mapping window is displayed.

[image: This image is described in the surrounding text.]

	
Click Finish.


	
From the File menu, click Save to Enterprise.

[image: This image is described in the surrounding text.]

The Save Document window is displayed.


	
On the Folders tab or Categories tab, select a folder or a category in which you want to save the report.

[image: This image is described in the surrounding text.]

	
Click Save.


	
Repeat this procedure for all the reports that you want to put into this repository.











Moving Repositories

You can move repositories using the Promotion Management feature in the Central Management Console.

See the SAP Web site for more information about moving repositories.


Figure 2-6 Promotion Management in Central Management Console

[image: Description of Figure 2-6 follows]










Upgrading Universes

Universe upgrades are required if you:

	
Upgrade to a newer version of MSS Operational Reports.


	
Want the latest universe or reporting enhancements.




Upgrading a MetaSolv Solution universe involves the following tasks:

	
Delete existing copies of MetaSolv Solution universes.


	
Download and export the new MetaSolv Solution universes.


	
Import the sandbox and associate the new universe.




To delete a universe:

	
Open the Central Management Console by entering the following in a Web browser:

http://localhost:port/BOE/CMC

where:

localhost is the server on which the Business Objects 4.0 is installed.

port is the server's HTTP port number.


	
Click Universes.

The list of universes is displayed.


	
From the list of universes, right click the universe and select Delete.

You do not have to delete the universe, you can overwrite it.


	
Repeat this procedure for each universe you want to delete.




To download and export a new MetaSolv Solution universe:

	
Download the latest versions of the MetaSolv Solution universes from the Oracle software delivery Web site.


	
Open the Universe Design Tool.


	
From the File menu, select Open.


	
Open the universe files that you downloaded.


	
From the File menu, select Parameters.

The Universe Parameters window is displayed.


	
On the Definition tab, from the Connection list, select a secure connection.


	
Click OK.


	
From the File menu, select Save.


	
Repeat steps 3 through 8 for each universe.


	
From the File menu, select Export.

The Export Universe window is displayed. Verify that all the universes are displayed in the Export Universe window.


	
Do one of the following:

	
If all the universes appear in the Export Universe window, click OK.


	
If a universe is missing, click the Add button, and navigate to the location where you saved the universes. Select the missing universe and click OK.





	
Close the universes.




To update a sandbox:

	
Open the Universe Design Tool.


	
From the File menu, select Import.

The Import Universe window is displayed.


	
Select the universe.


	
Click OK.


	
From the File menu, select Parameters.

The Universe Parameters window is displayed.

[image: This image is described in the surrounding text.]

	
On the Links tab, select the universe and click Change Source.

The Universe To Link window is displayed.


	
Navigate to the folder named after the repository and select the appropriate universe and click Open.


	
Click OK.


	
From the File menu, click Save.


	
Close the universe.


	
Reopen the universe to verify the changes.


	
Repeat steps 2 through 11 for each universe.


	
From the File menu, select Export.

The Export Universe window is displayed. Verify that all the universes are displayed in the Export Universe window.


	
Do one of the following:

	
If all the universes appear in the Export Universe window, click OK.


	
If a universe is missing, click the Add button, and navigate to the location where you saved the universes. Select the missing universe and click OK.





	
Close the universes.









Upgrading Reports

To take advantage of the changes applied to the reports, you must install the new or upgraded reports.

To install new or upgraded reports:

	
Open the Web Intelligence Client.


	
Under the Open Document section, click browse.


	
Navigate to the document/report you want to move and click Open.


	
Click the Data button on the top right corner.


	
Under Data, right-click the universe and select Change Source.

The Change Source Wizard is displayed.


	
To change the universe that the report is associated to, select the Specify a new data source option.


	
From the Select a data source list, select Universe.

The Universe window is displayed.


	
Select a universe to which you want to associate the report and click Select.

The selected universe is displayed under the Specify a new data source option.


	
Click Next.

The Change Source Wizard - Object Mapping window is displayed.


	
Click Finish.


	
From the File menu, click Save to Enterprise.

The Save Document window is displayed.


	
On the Folders tab or Categories tab, select a folder or a category in which you want to save the report.


	
Click Save.


	
Repeat this procedure for all the reports that you want to upgrade.









Optimizing Report Performance

If you observe performance issues with your reports, there are Oracle options that can be hard-coded into the SQL Editor window of the reports. By default, Oracle uses the Cost Based method versus the Rule Based method. To maintain optimal performance using either method, you must analyze and estimate all the MetaSolv Solution schemas. Performance is improved when the indexes are updated and are current. Contact your database administrator to run this procedure.







CONVERT_GMT_TO_LOCALDB Stored Function

The dates and times that are stored in the MetaSolv Solution database are stored at Greenwich Meantime. Using these dates or times in reports can be misleading, because the date-time reported may not be the time in your area. To make these date columns more accurate in reporting, the date objects have been duplicated in the universes that use them. One version of the date object remains as the GMT date and the object name has been appended with GMT. A duplicate date object was created but without the GMT extension.

This version of the object has been defined using a new stored function, CONVERT_GMT_TO_LOCALDB, that must be compiled to the target database before using these objects in reports. This function applied to the GMT date objects in the database converts the GMT date to the date of the time zone that the database is located in.

Table 2-2 lists the date-time objects impacted by this new stored function:


Table 2-2 Date-time Objects Impacted by CONVERT _GMT_TO_LOCALDB Stored Function

	Universe Name	Class/Subclass Name	Object Name
	
Engineering

	
Trouble/Trouble Tickets/Trouble Ticket

	
Ckt In Service Dt


	
Engineering

	
Trouble/Trouble Tickets/Trouble Ticket

	
Close Dt (MM-DD-YYYY)


	
Engineering

	
Trouble/Trouble Tickets/Trouble Ticket

	
Close Dt (YYYY)


	
Engineering

	
Trouble/Trouble Tickets/Trouble Ticket

	
Status Last Modified Dt


	
Engineering

	
Trouble/Trouble Tickets/Trouble Ticket

	
State Last Modified Dt


	
Engineering

	
Trouble/Trouble Tickets/Trouble Ticket

	
Restore Dt


	
Engineering

	
Trouble/Trouble Tickets/Trouble Ticket

	
Open Dt (MM-DD-YYYY)


	
Engineering

	
Trouble/Trouble Tickets/Trouble Ticket

	
Open Dt


	
Engineering

	
Trouble/Trouble Tickets/Trouble Ticket

	
Next Cust Status Dt


	
Engineering

	
Trouble/Trouble Tickets/Trouble Ticket

	
Next Activity Dt


	
Engineering

	
Trouble/Trouble Tickets/Trouble Ticket

	
Defer Until Dt


	
Engineering

	
Trouble/Trouble Tickets/Trouble Ticket

	
Close Dt (MM-YYYY)


	
Engineering

	
Trouble/Trouble Tickets/Trouble Ticket

	
Close Dt


	
Engineering

	
Trouble/Trouble Tickets/Trouble Ticket

	
Cleared Dt


	
Engineering

	
Trouble/Trouble Tickets/Trouble Ticket

	
Trbl Detect Dt


	
Engineering

	
Trouble/Trouble Tickets/Trbl Task

	
Create Date


	
Engineering

	
Trouble/Trouble Tickets/Trbl Task

	
Actual Start Date


	
Engineering

	
Trouble/Trouble Tickets/Trbl Task

	
Actual Completion Date


	
Engineering

	
Trouble/Trouble Tickets/Trbl Task

	
Last Modified Date


	
Ordering

	
Work Mgmnt/Task

	
Task Scheduled Completion Dt


	
Ordering

	
Work Mgmnt/Task

	
Task Revised Completion Dt


	
Ordering

	
Work Mgmnt/Task

	
Task Estimated Completion Dt


	
Ordering

	
Work Mgmnt/Task

	
Task Actual Release Date


	
Ordering

	
Work Mgmnt/Task

	
Task Actual Completion Date


	
Ordering

	
Work Mgmnt/Jeopardy

	
Jeopardy Esc Date Entered


	
Ordering

	
Work Mgmnt/Jeopardy

	
Jeopardy Date Closed


	
Ordering

	
Work Mgmnt/Jeopardy

	
Jeopardy Follow up Date








In addition to the new date objects, all of the conditions (filters) in the reporting universes that refer to any of the GMT dates have been altered to refer to the converted dates. Table 2-3 lists the condition objects that have been modified.


Table 2-3 Condition Objects Modified by CONVERT_GMT_TO_LOCALDB Stored Function

	Universe Name	Class Name	Condition Name
	
Engineering

	
Trouble/Trouble Tickets/Trouble Ticket

	
Prompt for Open Date Range


	
Engineering

	
Trouble/Trouble Tickets/Trouble Ticket

	
Prompt for Close Date Range


	
Ordering

	
Work Mgmnt/Task

	
Prompt Task Actual Comp Date Range


	
Ordering

	
Work Mgmnt/Task

	
Prompt Task Sched Comp Date Range


	
Ordering

	
Work Mgmnt/Task

	
Task Completion Date < Today's Date


	
Ordering

	
Work Mgmnt/Task

	
Prompt Task Revised Comp Date Range


	
Ordering

	
Work Mgmnt/Jeopardy

	
Prompt Jeopardy Closed Date Range











	
Note:

The dates above only occur in the Ordering and the Engineering universes. If you are only using the Customer universe, you do not have to make any modifications.







The stored function is SQL code that must be loaded into SQL*Plus (or any storedprocedure editor that can compile procedures to the Oracle database), and compiled to the target database. For existing customers, the installation is done by a DBA. The stored function is delivered with both the Engineering and the Ordering universe, so the compilation procedure only has to be executed one time.


Downloading and Compiling the CONVERT_GMT_TO_LOCALDB Function

You must run this procedure to ensure that the date objects or filters in the Ordering or Engineering Reporting Universes that use this function parse successfully so that you can use them in a report.

To download and compile the CONVERT_GMT_TO_LOCALDB function:

	
Copy the CONVERT_GMT_TO_LOCALDB.sql to a local directory.

The CONVERT_GMT_TO_LOCALDB.sql file is included in each Universe zip file.


	
Open SQL*Plus.


	
Log in to the database with ASAP authorization and do the following:

	
At the SQL*Plus prompt, enter the following:


"@drive:\path\CONVERT_GMT_TO_LOCALDB.sql"


	
Press Enter.







SQL*Plus displays a message informing you that the function is created.

To verify that the function was successfully compiled, open any of the GMT-related objects in the Business Objects 4.0 Universe Design Tool and parse the object. If the function was successfully compiled, the object parses without any errors.








Integrity Results of Objects and Conditions

Business Objects 4.0 has an option in the Universe Design Tool that runs an integrity check on a universe. The integrity check parses every object and verifies the object in the universe. The integrity check returns errors in all the three MetaSolv Solution universes because Business Objects 4.0 does not support certain SQL statements. However, the objects function correctly in the Web Intelligence Client.

These are recognized parsing violations in Business Objects 4.0. Even though these objects and conditions do not parse, Business Objects 4.0 is still able to generate the reports and run them against an Oracle database successfully.

To run an integrity check:

	
Open the Universe Design Tool.


	
Open the universe.


	
From the Tools menu, select Check Integrity.

The Integrity Check window is displayed.

[image: Surrounding text describes opr_using_int_chck.gif.]

	
Click OK.

The integrity check results are displayed.




The following sections contains screen shots of known integrity check results from each of the universes contained in MSS Operational Reports.


Customer Universe

All the objects in the Date Objects class do not parse but run in Business Objects 4.0 because the SQL is correct.

The Telephone Number Latest object does not parse because of the included MAX SQL function. This object is used to find the telephone number with the greatest suffix associated to it.

The first four conditions (Neither an agent or salesperson, Salesperson & Agent, More than one agent to customer, and More than one Salesperson to cust) do not parse because the SQL for these conditions has been hard-coded into the objects for a specific Sales/Telephone Kit report.

The last condition (No Active Service Items) does not parse because it uses the Not Exists SQL clause, which Business Objects 4.0 does not recognize.

The Price/Offer Price does not parse but runs in Business Objects 4.0. The SQL is correct.

The count for telephone number reservations is currently used as a counting object for the Reservation Report.

Figure 2-7 shows an example of integrity results for the Customer universe.


Figure 2-7 An Example of Integrity Results for the Customer Universe

[image: Description of Figure 2-7 follows]









Engineering Universe

All the objects in the Current Date Objects class do not parse but run in Business Objects 4.0 because the SQL is correct.

Figure 2-8 shows an example of integrity results for the Engineering universe.


Figure 2-8 An Example of Integrity Results for the Engineering Universe

[image: Description of Figure 2-8 follows]









Ordering Universe

All the objects in the Date Objects class do not parse but run in Business Objects 4.0 because the SQL is correct.

The Missing Due Date Task condition does not parse because it uses the Not Exists SQL clause, which Business Objects 4.0 does not recognize.

Figure 2-9 shows an example of integrity results for the Ordering universe.


Figure 2-9 An Example of Integrity Results for the Ordering Universe

[image: Description of Figure 2-9 follows]














3 Universes, Kits, and Reports

This chapter provides a description of the individual universes and their associated reporting kits in Oracle Communications MetaSolv Solution (MSS) Operational Reports.


About Universes, Kits, and Reports

A universe is an organized collection of metadata objects that enables you to analyze and report on information in a format that is non-technical. The universe includes connections to the data sources. You can connect to the universe and run queries and create reports using the objects in the universe without any knowledge of the underlying data structures in the database.

MSS Operational Reports offers three separate universes, which are as follows:

	
Customer


	
Ordering


	
Engineering




Each universe represents a key functional area of MetaSolv Solution. Each universe is supported by individual reporting kits, which in turn contain a set of reports for a specific subject area.


Customer Universe

The Customer universe contains customer information, such as address, service items, and deposit information, along with customer service sales information. This universe lets you keep track of sales performance per individual or product type. The security features allow you to keep track of user names and privileges.

The following reporting kits use the Customer universe:

	
Customer/Security Reporting Kit


	
Sales/Telephone Number Inventory Reporting Kit






Customer/Security Reporting Kit

This kit contains reports that provide information about customers, customer service requests, products on customer service requests, and windows related to MetaSolv Solution security.

Table 3-1 lists the reports contained within this kit.


Table 3-1 Customer/ Security Reporting Kit: Report Definitions and Potential Uses

	Report Name	Description	Potential Uses
	
Priority Status Customer Accounts

	
Prompts for the status of the customer and their priority. Retrieves account number, name, status, and the priority description.

	
Find accounts with a particular status and defined priority.


	
Deposit Report

	
Lists all the deposits made by business or residential customers grouped by state.

	
Estimate the total amount of deposits for business or residential customers grouped by state.


	
Active Accounts with No Active Service Items

	
Lists customer accounts that are in service but have no active service items.

	
Help identify accounts without any active service items.


	
User Window List

	
Prompts for a user and retrieves the windows they have access to, along with the user's status.

	
Audit MetaSolv Solution security.


	
Window Security List

	
Prompts for windows and retrieves the list of users who have access to these windows. In addition, it also lists the status of each user.

	
Audit MetaSolv Solution security.


	
Items without Prices

	
Lists the items that do not have a price listed.

	
Determine the active items defined without prices in the Product Catalog.


	
Disconnected Reason

	
Based on a specified date, retrieves information about account number, customer, type, item, and the reason for disconnection.

	
Determine the customers that have been disconnected and the reason for disconnection.


	
Customer Activity

	
Lists the customer history information, such as product, service request, status, and installation location.

	
Show what products are assigned to what customers, including the product's status.


	
Customer by Order Status

	
Lists all the service requests under a specified status, including their estimated revenue.

	
Determine the status of a service request.


	
Impact of Discontinued Product

	
Lists the customers who have products with price terms. Provides an explanation for the price terms.

	
Determine what is the economic impact of a discontinued product.


	
Product by Customer by Offer Price

	
Lists all the products that have an offer price based on a specified customer.

	
Determine the offer price and the price type of each product for a customer.


	
Customer Pricing Information by Product

	
Lists the customer information, service items ordered by a customer, and pricing information for those service items.

	
Track product pricing changes and cancellations to notify customers.












Sales/Telephone Number Inventory Reporting Kit

This kit contains reports that provide the following:

	
Sales information related to PSR orders stored in MetaSolv Solution


	
Telephone number reports related to the Federal Communications Commission (FCC)




Table 3-2 lists the reports contained within this kit.


Table 3-2 Sales/Telephone Number Inventory Reporting Kit: Report Definitions and Potential Uses

	Report Name	Description	Potential Uses
	
Reservation

	
Lists reserved telephone numbers based on a specified date.

	
Determine numbers that are reserved.


	
PIC Change

	
Shows PIC type and the PIC number for the account # and customer based on specified dates.

	
Provide correct PIC information.


	
E911 Address List

	
Shows customer address based on telephone number.

	
Ensure that the E911 information is correct.


	
Sales Module Audit

	
Audits accounts with:

	
More than one agent/salesperson


	
Both an agent and a salesperson


	
Neither an agent nor a salesperson.




Lists the customer.

	
Audit accounts.


	
Toll Free Telephone #'s

	
Shows the customer toll free numbers based on customer account number.

	
Determine the customer toll free numbers.


	
Cancelled Orders

	
Lists the cancelled service requests.

	
Find all the cancelled service requests within a date range.


	
Salesperson Order Summary

	
Shows customer, service request, product, revenue, and offer price for a given date based on the salesperson.

	
Retrieve data about orders based on the salesperson.


	
Commercial Sales Production Flash

	
Shows the sales module description and allows you to drill down to the salesperson based on product. Also shows the number of service requests and the revenue for the specified product.

	
Determine which products are being sold by which salesperson.


	
Ported Telephone #'s

	
Lists all ported numbers and associated customers.

	
Determine which numbers are portable and the associated customers.


	
Sales Role Summary

	
Counts service requests and revenue by role type. You can drill down by role type for a more specific report.

	
Count all the service requests per salesperson.


	
TN Thousands Group

	
Reports the percentage of utilization or fill rate for each NXX.

	
FCC Numbering Optimization Reporting.


	
TN Aging of Disconnected Numbers

	
Provides a list of numbers with disconnected status, with a transfer of calls, to remove the bit within our switches, which sends calls to AIS.

	
FCC Numbering Optimization Reporting.


	
TN Capacity

	
Provides an overall picture for all telephone numbers within a service provider's inventory.

	
FCC Numbering Optimization Reporting.


	
TN Capacity with Rate Center

	
Provides an overall picture for all telephone numbers within a service provider's inventory. This includes the rate center that is associated with the telephone numbers.

	
FCC Numbering Optimization Reporting.


	
LIDB/CNAM Database Service Provider Ported NXX Notification

	
Provides notification of the first instance of a ported NXX to the LIDB/CNAM database service provider to accept portable LIDB/CNAM records.

	
FCC Numbering Optimization Reporting.


	
LIDB/CNAM Database Service Provider Ported NXX Notification with Rate Center

	
Provides notification of the first instance of a ported NXX to the LIDB/CNAM database service provider to accept portable LIDB/CNAM records. This includes the rate center that is associated with the NXX.

	
FCC Numbering Optimization Reporting.


	
TN Reservation Aging

	
Identifies which customers reservations have exceeded the allowed time frame (currently 45 days).

	
FCC Numbering Optimization Reporting.













Ordering Universe

The Ordering universe contains the objects necessary to generate information on all types of service requests, such as ASR, LSR, PSR, ISR, and so on. This universe contains objects related to work management and provisioning that let you uncover problems in your service fulfillment.

The Ordering universe contains the following reporting kits:

	
Service Request Reporting Kit


	
Work Management Reporting Kit


	
Provisioning Reporting Kit






Service Request Reporting Kit

This kit contains reports that are specific to service requests. The report is generated at the order level, not at the detail level.

Table 3-3 lists the reports contained within this kit.


Table 3-3 Service Request Reporting Kit: Report Definitions and Potential Uses

	Report Name	Description	Potential Uses
	
Service Order Tracking

	
Provides a tool for tracking the progress of service requests. This report includes information about ISR, LSR, and PSR. It includes columns for organization, service type group, order number, and the type of service request.

	
Identify problem areas with service requests.


	
Order Log

	
Provides a summary list of service requests, including ISR, LSR, and PSR data, and columns for organization, service type group, order number, and type of service request. The report also gives service request date information, including the received date, the due date, and the completion date. There is also a column that indicates if the due date was met.

	
View a summary of service requests and identify potential problem areas.


	
Detail Circuit Completion

	
Provides a summary of statistics, dates, and other details about service requests for a particular organization. This report includes all service request types.

	
Track service requests by circuit IDs.


	
Order Status

	
Lists all the service requests that have a late DLRD or RID task. This report includes high-level order information and a list of circuits accompanying the service requests.

	
Resolve potential customer complaints due to delays in circuit design.


	
Open Orders By Date

	
Lists the open service requests for a given date range. This report is first sorted by work group, and then by task scheduled completion date. The report also generates counts for total service requests, service requests in a work group, and service requests in a work queue.

	
Generate a work log or view past due or upcoming service requests.


	
PON & RPON Mismatch

	
Compares the purchase order number (PON) and the related purchase order number (RPON) and reports any differences found between the two values.

	
Identify service requests that have differences between the PON and the RPON.


	
MetaSolv Solution Billing Report

	
Lists the service requests that have been modified.

	
Identify items that may require a change in billing. This report is efficiently utilized in the batch mode by querying for service requests that have changed in the last 24 hours. However, you can run this report in the on-line mode.


	
Open Orders without a Due Date Task

	
Lists all the incomplete service requests that do not have a due date task. This report includes information about the service request and its associated tasks.

	
Audit service requests that do not contain due date tasks.


	
Open Order Inventory with Circuit Count

	
Lists all the open service requests that are not due date complete. This report is grouped by receipt date and sectioned by month. A list of open service requests is displayed with all other open service requests received in the same month. The number of circuits on the service request is also included in this report.

	
Track order inventory.

Use this report as a starting point for tracking potential customer relations problems.


	
Completed Orders Not Billed

	
Lists all the service requests that are complete but have not been sent to the billing system.

	
Prevent revenue leakage by identifying unbilled service requests.


	
Service Request Tracking Summary Report

	
Calculates the completion time for a service request that has been due date completed.

	
Calculates the average process time for a service request.












Work Management Reporting Kit

This kit contains reports that concentrate on the Work Management module in MetaSolv Solution.

Table 3-4 lists the reports contained within this kit.


Table 3-4 Work Management Reporting Kit: Report Definitions and Potential Uses

	Report Name	Description	Potential Uses
	
Non-Work Day List

	
Generates a list of non-work days for a specific organization or group of organizations. Non-work days include both weekends and holidays.

	
Review your work calendar and view the days that are not available for task scheduling.


	
Work Queue Assignment

	
Lists task assignments for a selected work queue.

	
Identify the workload for each work queue.


	
Work Queue Unavailability

	
Indicates the period of time during which an employee is unavailable.

	
Schedule or identify production downtime by analyzing the time period when employees are out of the office.


	
Work Queue Ownership

	
Provides details on which employees own each work queue.

	
Level resources.


	
Provisioning Plan Assignment List

	
Lists provisioning plans, the tasks associated with the provisioning plans, and the default work queue for each task.

	
Evaluate your provisioning plans and the tasks associated with those plans. It may be useful when associating new products with provisioning plans.


	
On Time Task Analysis by Work Group

	
Calculates the number of tasks completed on time by considering the task actual completion date. This report also displays an on-time percentage of tasks completed by work group, provides a graphical view, and drill-down capabilities.

	
Evaluate the efficiency of each work group in an organization.


	
Open Jeopardy With Escalation Information

	
Lists all the open service requests with a jeopardy code.

	
Identify open late tasks. This report enables you to view late tasks and the associated escalation information.


	
Closed Jeopardy Report

	
Lists all the jeopardy items closed within a specified date range.

	
Analyze the use of jeopardy. It allows you to determine if the codes are being used accurately by identifying the jeopardy code as it relates to late and potentially late service requests.


	
Work Queue Interval

	
Analyzes task completion using interval days. Expected intervals are compared against actual completion intervals and an average interval in days is calculated.

	
Determines if the expected completion intervals on provisioning plans need to be adjusted to meet actual results.


	
Jeopardy Report By Code and Task

	
Lists all service requests based on solicited task information. You can specify the task type, task status, and jeopardy code type. Based on the information you specify, this report returns a list of service requests and any associated child service requests.

	
Determines how jeopardy and why missed codes are used across different task types.












Provisioning Reporting Kit

This kit contains reports that pinpoint specifics about work management throughout the provisioning process.

Table 3-5 lists the reports contained within this kit.


Table 3-5 Provisioning Report Kit: Report Definitions and Potential Uses

	Report Name	Description	Potential Uses
	
Provisioning Plan Detail List

	
For the selected organizations, indicates the relationship between tasks, such as predecessors and followers.

	
Show the relationships between tasks in a provisioning plan.


	
Provisioning Plan Summary

	
Lists all provisioning plans and their associated organizations, jurisdictions, and service type groups.

	
Show the provisioning plans. View the products and organizations that can use these provisioning plans.


	
Provisioning Plan Usage

	
Provides information on how frequently a provisioning plan is used.

	
Audit provisioning plan usage.


	
Task Completion Performance

	
Provides information on how often a selected task type meets its due date.

	
Determine the groups that complete their work on time.


	
Task Due List

	
Lists the tasks that are due for a specific time period for service request types ISR, LSR, and PSR. Also contains columns for service request #, organization, and service type group.

	
Identify late open tasks and their associated service requests.


	
Task Due But Not Complete

	
Shows work queues with tasks that are due but not complete and the information about the related service request. This report includes data related to ISR, PSR, ASR, and LSR.

	
Distribute workloads by displaying the current late tasks by workgroup.


	
Why Missed Code Occurrence

	
Lists tasks that have been assigned why missed codes and the number of times a why missed code is assigned to each task type.

	
Determine the reasons for the service requests being delayed.


	
Circuit Status

	
Contains circuit information. This report returns information for all the circuits in the selected status.

	
Monitor circuits of all statuses.


	
Late and Potentially Late Incomplete Tasks

	
Lists scheduled completion intervals, actual completion intervals, and the number of days late for tasks and work queues.

	
Identify tasks or work queues that are late or potentially late.













Engineering Universe

The Engineering universe contains the objects necessary to report on equipment capacity, inventory, circuits, and trouble management. This universe contains objects that allow you to create concise or detailed reports.

The Engineering universe contains the following reporting kits:

	
Equipment Reporting Kit


	
Trouble Management Reporting Kit






Equipment Reporting Kit

This kit contains equipment audit reports and circuit/facility capacity management reports.

Table 3-6 lists the reports contained within this kit.


Table 3-6 Equipment Reporting Kit: Report Definitions and Potential Uses

	Report Name	Description	Potential Uses
	
Relay Racks with Invalid Equipment Names

	
Lists all the relay racks with names that are not 8 characters long. This report is easily customized for all types of equipment and name lengths.

	
Ensure that the naming conventions are being followed.


	
Card Inventory

	
Prompts for CLLI codes and provides a list of cards with their associated shelf location.

	
Inventory cards installed for specific locations.


	
SONET Ring Host Relay Rack

	
Shows the relay rack that is the host for a specific FNI. Additional information includes switching code, network type, CLLI code, and mounting position.

	
Identify critical equipment in SONET applications.


	
Relay Racks Without 11 Character CLLI Codes

	
Shows all the equipment (grouped by CLLI code) that does not have an 11-byte CLLI code. This report also includes the vendor name, part number, comm code, and location information.

	
Inventory relay racks. Ensure that the naming conventions are being followed.


	
Port Usage on DTC/DTCI

	
Provides the status of DTC/DTCI (Digital Trunk Controller/Digital Cross-connect System) equipment. Also includes the notes and the associated CLLI code.

	
Assists in capacity management.


	
DACS Equipment Utilization

	
Determines the hardware used and spare capacity of DACS equipment.

	
Provide capacity management for DACS equipment. Use this report as a projection tool for purchasing equipment.


	
NPA/NXX Threshold Utilization

	
Provides a summary of telephone numbers grouped by their statuses. The status groups are Unassigned, In Service, Pending, Disconnect, Pending Disconnect, Reserved, Suspended, Transitional, and Unavailable.

	
Determine the telephone number statuses in the inventory.


	
Location Facility

	
Shows vacant positions on facility circuits and provides a summary of all the circuit types on the facility based on user-prompted CLLI codes and rate codes.

	
Determine the facilities and facility groups in the inventory.


	
Equipment Specifications

	
Shows what equipment is used in MetaSolv Solution, including detailed information on the description, vendor name, part number, acronym, transmit level, mounting positions, type, issue number, communications code, and mounting position sequence.

	
Determine what equipment specifications are currently available to assist in the requisition or configuration process.


	
Shelf Fill

	
Lists shelf equipment by location name. You can choose the CLLI code that you want to query. Includes a sum of the cards per shelf. Additional information includes the relay rack, shelf name, shelf acronym, rate code of the card, number of cards assigned, and CLLI code.

	
Determine all the shelf equipment for a specific location in the inventory.


	
Capacity Utilization

	
Lists the vendor, CLLI, and capacity information based on a selected vendor.

	
View equipment capacity.


	
Circuit Capacity

	
Graphically displays the following:

	
Originating and terminating locations


	
Facilities that are inventoried or vacant




	
Track capacity between locations.


	
Facility Circuit Position Status

	
Shows vacant circuit positions on facility circuits and provides a summary of all CP statuses based on user prompted CLLI codes.

	
Determine the facilities and facility groups in the inventory.


	
SONET Capacity Report

	
Shows the following:

	
Total positions and vacant positions


	
The percentage assigned on SONET facility circuits by CLLI code




	
Determine the facilities and facility groups in the inventory.


	
Equipment Assignments on Selected Circuit Report

	
Based on a circuit ID, the report displays all the equipment associated to the circuit by location.

	
Shows any equipment that is involved in case of circuit outage. You can use this report to display all locations and equipment involved in a SONET ring.


	
Equipment with Circuit Assignments by Location Report

	
Lists all the equipment in your network that have circuit assignments and their associations in all locations.

	
Displays equipment capacity. Displays information about the equipment occupied in each location down to the circuit assignment level.












Trouble Management Reporting Kit

This kit contains reports that cover the many aspects of trouble tickets in MetaSolv Solution.

Table 3-7 lists the reports contained within this kit.


Table 3-7 Trouble Management Reporting Kit: Report Definitions and Potential Uses

	Report Name	Description	Potential Uses
	
Ticket Type Summary

	
Provides a summary of the count of the priority 1 through 4 tickets for a user-specified time frame grouped by the trouble type code.

	
Analyze trouble traffic and network dependability during a given time frame.


	
Ticket Detail

	
Lists trouble tickets from a user-specified date range. The information includes the Ticket ID, creation date, circuit, type code, and description.

	
Identify the tickets opened for common causes, in addition to analyzing trouble traffic and network dependability during a given time frame.


	
Open Tickets

	
Lists the trouble tickets that are:

	
Open


	
Externally referred




Lists the Ticket ID, creation date, responsible organization, current state, escalation level, and when the trouble ticket was externally referred.

	
Identify the trouble tickets that are open and externally referred.


	
Monthly Priority Level Summary

	
Shows a count of tickets based on their priority and the month they were created.

	
Trend analysis of network dependability.


	
Mean Time to Repair Detail

	
Provides detailed information on the time to repair for tickets that were externally referred. The end user selects what external organizations are to be included and what time frame from the close date of the ticket should be used. Fields included in this report include the type code, found code, cause code, time to repair, circuit ID, person who created the ticket, and ticket ID. The report is grouped by the external organization to which the ticket was referred.

	
Analysis of the response time of external organization to specific tickets in order to identify possible communication problems with organizations or poor service.


	
Infant Circuits with Trouble Summary

	
Lists the trouble tickets that were created on circuits that have been in service for less than 30 days.

	
Trend analysis of installation problems and network dependability.


	
Infant Circuits Trouble Detail

	
Provides detailed information on tickets where the circuit has been in service less than one calendar month. Details include the ticket ID, time to repair, creation date, circuit ID, trouble type, trouble found trouble cause, and circuit cross reference. The details are grouped by the responsible organization.

	
Identify specific installation problems and recurring problems with the network.


	
Externally Referred Ticket Detail

	
Provides detailed information on the tickets that are externally referred. The end user selects what external organizations to include and the time frame for the tickets from the creation date. The information includes the ticket ID, time to repair, amount of time the ticket was externally referred, creation date, external ticket ID, circuit ID, circuit cross reference, ticket description, trouble found, and trouble caused. All the information is grouped by the organization the trouble ticket was externally referred to.

	
Analyze the tickets that required external resolution and the time required to address the problems in specific situations.


	
Business Unit Ticket

	
Provides detailed information on tickets for specific administrative organizations. The information includes the ticket ID, circuit ID, ticket creation user ID, trouble description, closed comments, and total duration. The information is grouped by the administrative organization. You are prompted to select the administrative organization to which the tickets are assigned to, and the time frame from close date.

	
Analyze tickets to specific Administrative organizations and the efficiency of the organizations in resolution of the tickets in a timely manner.


	
All Trouble

	
Provides detailed information on trouble tickets. The information includes the ticket ID, time to repair, date created, circuit ID, trouble type, trouble found, trouble description, cause code, and circuit cross reference. You can select the time frame from the ticket creation date.

	
Analyze all tickets created in a specific time frame and the time to resolve each ticket.


	
Trouble Tickets by Hour and Day

	
Summary of tickets created by the hour and day to determine staffing needs for customer support.

	
Assist the staffing needs of the customer service organization and identify peak and off-peak hours and days.


	
Affected Customer

	
Provides a summary of customers that are affected by an equipment outage. The end user is prompted to enter an equipment name, serial number or spec to identify the equipment that has failed. The information provided in the report includes the customer contact information.

	
Identify the effects of equipment failure and identify critical equipment to assist in required spare parts.


	
Trouble Ticket Organizations Summary

	
Lists administrative organization information.

	
Determine the administrative organization that owns a specific trouble ticket.













Navigating the Engineering Universe

Navigating the Engineering Universe requires familiarity with the equipment hierarchy, circuits, and trouble management.


Equipment Hierarchy

Figure 3-1 shows the relationship structure in the MetaSolv Solution data model.


Figure 3-1 Relationship Structure for Equipment, Port Address, and Mounting Position

[image: Description of Figure 3-1 follows]






In the Equipment Hierarchy structure, a piece of equipment can have other equipment installed on it and a piece of equipment can be installed on another parent piece of equipment. For example, a relay rack provides mounting positions to accommodate other equipment, such as shelves. A shelf occupies mounting positions on the relay rack. A shelf contains a certain number of slots (mounting positions) to accommodate installation of cards. Cards occupy slot positions on the shelf.

The Engineering universe in MSS Operational Reports is a graphical representation of the static SQL that is generated when the reporting objects are built and joined together. Because the reporting objects reflect static SQL statements, you must define a finite number of equipment levels that reflect the flexibility of the equipment hierarchy in the underlying data model. Typically, the equipment hierarchy does not span more than three levels (for example, relay rack, shelf, card). However, you can have as many as six levels of equipment (for example, room, section, row, relay rack, shelf, card). Therefore, the Engineering Universe is designed with seven possible equipment levels.

Figure 3-2 illustrates the equipment hierarchy.


Figure 3-2 Equipment Hierarchy Flowchart

[image: Description of Figure 3-2 follows]






The extent of the equipment levels used in building reports for a given organization depends on how the equipment hierarchy has been established within MetaSolv Solution. In many cases, reports can be based on the objects at any equipment level, because the numbered versions of the tables are aliases of the base table. The iterative structure of the universe design enables you to traverse the hierarchy of related equipment.





Circuits

Similar to the equipment hierarchy, two levels of circuit-related objects form a hierarchy for the same purpose with respect to the parent/child relationship. Circuits can have other circuits associated to them through their circuit positions.

Figure 3-3 shows an example of how the port address at the bottom of the equipment hierarchy is associated with a circuit.


Figure 3-3 Circuit Hierarchy Flowchart

[image: Description of Figure 3-3 follows]









Trouble Management

Two additional aliases exist in the Engineering universe to support the Trouble Management classes and objects. These aliases are not used for supporting hierarchical structures as in the case of equipment and circuits. The Circuit table and the Network Location table are aliased to relate them specifically to other objects that are relevant to Trouble Management reporting. These objects and their relationships are self-explanatory. There is no complex hierarchical organization of objects to comprehend in order to build relevant reports from these objects.












4 Frequently Asked Questions

This chapter provides answers to frequently asked questions regarding the use and functionality of Oracle Communications MetaSolv Solution (MSS) Operational Reports and SAP Business Objects 4.0.

The questions are divided into the following categories:

	
General


	
Universes


	
Reports


	
Security






General


Does Oracle support running MSS Operational Reports against the production database?

Oracle recommends that you not run reports on the production database, because this may cause network problems and performance issues.


What third-party software do I need to use the MSS Operational Reports?

To use MSS Operational Reports, you must install the following software:

	
SAP BusinessObjects BI platform 4.0 SP4:

	
SAP BusinessObjects Enterprise Server 4.0 SP4 (64-bit)—Includes the Central Management Console.


	
SAP BusinessObjects BI platform 4.0 Client Tools SP4 (32-bit or 64-bit)—Includes the Universe Design Tool and the Web Intelligence Client.







Ensure that the service pack versions of both the server and client software are the same.






Universe


Why are the existing universes not consolidated into a single universe?

The primary reason is maintenance. Business Objects 4.0 is a SQL generator. Therefore, a universe designer must convert the relationships in the MetaSolv Solution data model into unique logical pathways. For Business Objects 4.0 to accommodate all the possible pathways, the MetaSolv Solution data model would increase in size to over 2500 tables, causing maintenance issues. Oracle recommends that you direct a universe at a single user group.


Can I create a new universe by combining existing universes?

Oracle does not recommend combining universes. If universes are combined, you are required to define how to navigate through the data model instead of automatic navigation. Instead of combining universes, you can add tables or objects to supplement an existing universe.


Do universe updates from Oracle impact the customized changes?

You do not lose your customized changes if you follow the maintenance recommendations provided by Oracle. When the universes are installed at a client site, a ”sandbox” is set up that inherits from the MetaSolv Solution universes. The changes made in the sandbox are available for reporting, but are not affected by universe updates.






Reports


Does running the reports impact MetaSolv Solution performance?

Oracle recommends that you not run reports on the production database. The performance impact of running reports varies with each network environment. The usual factors, such as network traffic and hits against the server processes, affect performance over the network. Other factors include the complexity of the query being submitted to the database engine and the amount of data being retrieved. Business Objects 4.0 has some built-in checkpoints that allow the Business Objects 4.0 Central Management Console to limit the query processing time or the number of rows returned by individual logon ID.


Can I reuse the MetaSolv Solution security settings with Business Objects 4.0?

Because the Operational Reporting package is a separate product and not integrated with MetaSolv Solution, you are required to separately configure the security settings for both the applications. However, you can set up groups within the Business Objects 4.0 Central Management Console module, configured once, and applied to new users, which makes it very easy to add new users.


How can I use the reports on the Internet?

Using SAP Business Objects 4.0 Web Intelligence, you can create, modify, and view reports on the Web using the universes supplied by MetaSolv Solution.

You can use Business Objects 4.0 Web Intelligence to generate reports in HTML format and publish refreshed reports to a Web server. This enables you to view the reports through a Web browser.


How can I merge data from multiple data sources?

See the SAP Web site for information about merging data from multiple data sources.


Can I save the reports in different formats and export them to other sources?

See the SAP Web site for information about saving reports in different formats.


Can I schedule a report refresh?

See the SAP Web site for information about scheduling a report refresh.


Can I share reports with multiple users?

See the SAP Web site for information about sharing reports with multiple users.


Can I run reports in a mirrored environment?


See the SAP Web site for information about running reports in a mirrored environment.
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