6 Support Hub/Repeater Issues

This chapter describes the issues and problems encountered with running OCM's Support Hub (Repeater) feature. The following issues are addressed:

6.1 Debug Tracing For The Oracle Support Hub

The OCMREPEATER.PROPERTIES file within the ${ORACLE_HOME}/sysman/config directory will allow you to debug certain connection related issues. This section illustrates the contents of this file and how to change certain parameters for debugging the Oracle Support Hub (also known as the OCM Repeater).

Note:

This property file is not the same as the COLLECTOR.PROPERTIES file found for OCM. One sets properties for the Support Hub, the other for the OCM collector.

To enable debug tracing for the Oracle Support Hub:

  1. Edit the ${ORACLE_HOME}/sysman/config/OCMREPEATER.PROPERTIES file. From the listing of available parameter below, adjust:

    log4j.rootCategory=WARN, Rolling
    

    to be:

    log4j.rootCategory=DEBUG, Rolling
    

    For example:

    log4j.appender.Rolling=org.apache.log4j.RollingFileAppender
    log4j.appender.Rolling.File=${oracle.home}/sysman/log/ocmrepeater.log
    log4j.appender.Rolling.Append=true
    log4j.appender.Rolling.MaxFileSize=1000000
    log4j.appender.Rolling.MaxBackupIndex=3
    log4j.appender.Rolling.layout=org.apache.log4j.PatternLayout
    log4j.appender.Rolling.layout.ConversionPattern=%d [%t] %-5p - %m%n
     
    log4j.rootCategory=DEBUG, Rolling
     
    ccr.endpoint=https://ccr.oracle.com
    
  2. Stop and restart the Oracle Support Hub to activate the debug mode. The easiest way to stop and restart the Oracle Support Hub is to execute the following command:

    <OCM_REPEATER_HOME>/ocm/repeater/bin/ocmrepeaterctl configure
    

The ${ORACLE_HOME}/sysman/log/ocmrepeater.log file will now contain additional DEBUG messages.

6.2 Configuring the OCM Repeater Associated with Enterprise Manager 12c with a Proxy

Problem

Configuring an OCM Collector to run via the Oracle Support Hub (also known as the OCM Repeater) associated with Enterprise Manager Cloud Control 12c results in the following message:

OCM Installation Response Generator 10.3.7.0.0 - Production
Copyright (c) 2005, 2012, Oracle and/or its affiliates. All rights reserved.
 
Unable to establish connection to Oracle Configuration Manager server.
Hostname (https://ccr.oracle.com) is unknown.
 
Unable to establish a network connection to Oracle. Specify the URL for an
Oracle Support Hub in this format:
http[s]://<OracleSupportHubHost>:<OracleSupportHubPort>
If you do not wish to configure OCM through an Oracle Support Hub, enter NONE
Oracle Support Hub URL: http://OMShost:port
HTTP Failure 901
Received Error:
Oracle Support Hub cannot connect to the OCM Server.

Cause

Enterprise Manager Cloud Control 12c is configured with a proxy server to connect to Oracle, while the repeater is not yet set up to use the proxy server. For example:

export ORACLE_HOME=/u01/em12c/middleware12.1.0.2.0/oms
export OCM_REPEATER_HOME=/u01/em12c/middleware12.1.0.2.0/oms
export OCM_DOMAIN_PATH=/u01/em12c/middleware12.1.0.2.0/gc_inst/user_projects/domains/GCDomain
$ORACLE_HOME/ocm/repeater/bin/ocmrepeaterctl status
Oracle Support Hub - Release: 10.3.6.1.0 - Production
Copyright (c) 2005, 2012, Oracle and/or its affiliates.  All rights reserved.
Built 07/15/2012 07:00:51 PM
 
Install Root          :/u01/em12c/middleware12.1.0.2.0/oms
Proxy Host            :NONE
Proxy Port            :NONE
Proxy User            :NONE
Logging Level         :WARN, Rolling
Log File Location     :/u01/em12c/middleware12.1.0.2.0/oms/ocm/repeater/log/ocmrepeater.log

Solution

Run the $OCM_REPEATER_HOME/ocm/repeater/bin/ocmrepeaterctl command to configure the Oracle Support Hub for use through a proxy by entering the proxy server details in this format:

[<proxy-user>@]<proxy-host>[:<proxy-port>]