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Preface

Agile PLM is a comprehensive enterprise PLM solution for managing your product 
value chain. 

Audience
This document is intended for administrators and users of the Agile PLM products.

Documentation Accessibility
For information about Oracle's commitment to accessibility, visit the Oracle 
Accessibility Program website at 
http://www.oracle.com/pls/topic/lookup?ctx=acc&id=docacc.

Access to Oracle Support
Oracle customers have access to electronic support through My Oracle Support. For 
information, visit http://www.oracle.com/pls/topic/lookup?ctx=acc&id=info or 
visit http://www.oracle.com/pls/topic/lookup?ctx=acc&id=trs if you are hearing 
impaired.

Related Documents
Oracle's Agile PLM documentation set includes Adobe® Acrobat PDF files. The Oracle 
Technology Network (OTN) Web site 
http://www.oracle.com/technetwork/documentation/agile-085940.html contains the 
latest versions of the Agile PLM PDF files. You can view or download these manuals 
from the Web site, or you can ask your Agile administrator if there is an Agile PLM 
Documentation folder available on your network from which you can access the Agile 
PLM documentation (PDF) files. 

Conventions
The following text conventions are used in this document:

Convention Meaning

boldface Boldface type indicates graphical user interface elements associated 
with an action, or terms defined in text or the glossary.

italic Italic type indicates book titles, emphasis, or placeholder variables for 
which you supply particular values.
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monospace Monospace type indicates commands within a paragraph, URLs, code 
in examples, text that appears on the screen, or text that you enter.

Convention Meaning
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1Installing and Upgrading AutoVue for Agile

AutoVue for Agile PLM Installer updates the Agile PLM Application Server and File 
Manager components for Agile PLM version 9.3.2.x, 9.3.1.x and 9.3.0.x on all 
platforms. It also installs the AutoVue Server component on Windows or Linux.

You must run the AutoVue for Agile PLM Installer on the Application Server and all 
File Managers as well as the machine where you wish to install the AutoVue Server. 
Select the AutoVue for Agile PLM option in the installer if you wish to install the 
AutoVue Server, and select the Upgrade AutoVue 20.2.2 Client Libraries option if you 
are running the installer on an Application Server or File Manager. If your Application 
Server or File Manager is installed on the same machine as AutoVue, then both the 
AutoVue for Agile PLM and the Upgrade AutoVue 20.2.2 Client Libraries options 
must be selected in the installer.

Note: Before updating the AutoVue client libraries, ensure that you 
stop the file server and any additional Agile processes.

To install on Unix platforms:

1. Uninstall any previous versions of AutoVue.

2. Run the Red Hat Update Agent, up2date, to download the latest Xvfb and Mesa 
files.

Note: AutoVue Server installer does not detect whether Mesa or 
Xvfb are installed.

3. Install Xvfb version 6.8.2 or later.

Ensure you install Xvfb with XRender and GLX extensions.

4. Install the latest Mesa package (recommended version is 6.5.1 or later).

5. Install the libsane package, if not already installed.

6. Install the libXp package, if not already installed.

7. Install the Wine RPM package "wine-av-20040914-21.i386.rpm" from Oracle 
AutoVue Open Source Components http://oss.oracle.com/AutoVue.

■  If you have an older version of Wine, you need to uninstall it and then install 
the package that is certified with AutoVue 20.2.2.

■ Install Wine as a root user by running the following command:

– #rpm -i wine-av-20040914-21.i386.rpm



Note: Wine is installed in directory /usr/av.
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8. Download Oracle AutoVue 20.2.2 from Oracle Software Delivery Cloud 
(http://edelivery.oracle.com).

9. Launch the AutoVue 20.2.2 Installer (Linux: setup_av_lin.bin).

Note: For other supported platforms, run the respective .bin 
installers. (Solaris: setup_av_sol.bin /AIX: setup_av_aix.bin /Solx86: 
setup_av_solx86.bin/HP-UX: setup_av_hpux.binetc)

10. While running the above .bin file, provide the following installation details - 
location/appserver/filemanager info etc. The Install window appears.

11. Follow the instructions to proceed with the installation.

12. For information about any screen in the installer, click Help.

13. Click Next to proceed through the installer.

Note: If you are installing on an Application Server or File Manager, 
check the Upgrade AutoVue 20.2.2 Client Libraries option on the 
Choose Install Components panel.

14. Click Done to finish the installation.

To install AutoVue on Windows Platform:

1. Download Oracle AutoVue 20.2.2 from Oracle Software Delivery Cloud 
(http://edelivery.oracle.com) to a temporary directory.

2. For Windows run the setup_av_win.exe from the temporary directory.

3. While running the above .exe file you have to provide installation details - 
location/appserver/filemanager info etc.

4. Follow the installer steps to install.

5. Click Finish to complete the AutoVue installation.

Note: Before updating the AutoVue client libraries, ensure to stop 
the file server and any additional Agile processes.

After installing on the Application Server: After updating the client libraries, 
redeploy the application.ear file and restart the application server.

For instructions on restarting the application server, see either the Installing Agile 
PLM on Oracle Application Server or the Installing Agile PLM on Oracle WebLogic 
Server manual.

After installing on the File Manager: After updating the client libraries, redeploy 
the webfs.war file (Filemgr web application) on the File Manager.

To redeploy the File Manager:

1. Change to the TOMCAT_HOME\webapps directory.
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■ For Agile PLM 9.3.2 and later, TOMCAT_HOME is AGILE_
HOME\FileManager

■ For Agile PLM 9.3.1.x and 9.3.0.x, TOMCAT_HOME is AGILE_
HOME\apache-tomcat-6.0.18

2. Verify there is a directory named Filemgr under the webapps directory.

Note: The TOMCAT version bundled with Agile PLM 9.3.2 and later 
may not create a 'Filemgr' folder in the webapps directory.

3. If the Filemgr directory exists, then perform the following:

cd ..

mkdir webapps.old

Windows: move webapps\Filemgr webapps.old 

UNIX: mv webapps/Filemgr webapps.old

4. Change to the TOMCAT_HOME\work\Catalina\localhost directory

■ For Agile PLM 9.3.2 and later, TOMCAT_HOME is AGILE_
HOME\FileManager

■ For Agile PLM 9.3.1.x and 9.3.0.x, TOMCAT_HOME is AGILE_
HOME\apache-tomcat-6.0.18

5. Remove the directory named Filemgr under the work directory.

6. Start TOMCAT.

Backup the application.ear and webfs.war files before upgrading the client 
libraries to version 20.2.2. If you are upgrading to version 20.2.2, the Profiles folder 
is also backed up and a new Profiles folder is created with the latest GUI files.

If you are upgrading from an earlier version:

1. Remove the CMF files of the previous version on the file vault.

2. To remove the CMF files, unzip the MetaFilesRemover.zip file and run the 
MetaFilesRemover utility located at agile_home\agileDomain\tools.

Usage: java -jar MetaFilesRemover.jar [-delete <value>] [-age <value>] [-size 
<value>] -basedir <value> -prefix <value> -serverURL <value> -username <value> 
-password <value> -dburl <value> -dbuserid <value> -dbpassword <value>

where

■ delete deletes the metafiles.

■ age specifies the last access time (day).

■ size specifies file size (KB).

■ basedir is the file vault location where the metafiles are removed.

■ prefix is the file name prefix.

■ serverURL is the location of the DMS service, for example, 
http://server.company.com:80/Agile/services/DmsService.

■ username is the DMS service username.

■ password is the DMS service password.
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■ dburl is the database location (ex: hostname.us.oracle.com:1521:agile9).

■ dbuserid is the database user id.

■ dbpassword is the database password for this user.
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2Configuring AutoVue for Agile

AutoVue for Agile allows users to view and mark up documents, drawings, and CAD 
files using a Web browser.

AutoVue for Agile consists of two installable components:

■ AutoVue for Agile server ( the AutoVue Server)

■ AutoVue for Agile applet ( the client libraries)

AutoVue for Agile requires no maintenance on the client computer. A Web browser 
downloads the applet from the File Manager and stores it in the browser cache. The 
next time the AutoVue for Agile is launched, the applet is loaded from the cache, 
unless a new version is found on the File Manager.

The AutoVue for Agile servlet (VueServlet) is packaged and deployed as part of the 
File Manager installation. The VueLink Servlet is also deployed on the File Manager 
and tunnels the requests to the Agile Application Server using HTTP protocol. Because 
of this communication, each File Manager should have an associated Viewer on the 
same machine or separate machines. No additional configuration is required except 
that specified for the Agile Web client and the caching Viewer. The VueServlet is used 
to access AutoVue for Agile across firewalls from external clients, such as the Agile 
Web client, on standard HTTP/HTTPS ports.

Client Requirements

Note: Please refer to the AutoVue System Requirements section of 
the AutoVue Installation and Configuration Guide.

Architecture
AutoVue for Agile was designed to provide server scalability to support increasing 
demand for file viewing and markup on intranets and the Internet. Doubling the 
capacity is as simple as adding one more computer. The servers automatically divide 
up the load in a "peer-to-peer" fashion to avoid any bottlenecks. For more details, 
please refer the AutoVue Deployment Guide.

AutoVue for Agile embeds several different rendering schemes to accommodate 
multiple environments. These schemes allow the server to take into account issues 
such as network bandwidth, load balancing between server and client, server 
configuration and performance, intranet/extranet/Internet use, and file size and 
format to be viewed. However, in all rendering options, AutoVue for Agile keeps all 
necessary information for querying purposes; the "intelligence" of drawings is 
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preserved. For example, users can perform text searches on text and CAD files, or 
perform queries based on drawing attributes in a CAD file.

Depending on your network configuration (for example, existing firewalls, DMZ, 
secure connections and proxy servers), a client is able to connect to the AutoVue for 
Agile server using direct sockets or the HTTP/HTTPS protocol (through a Java servlet) 
and avoid any security breach in your system.

Security
During the viewing process, documents available for viewing are rendered on 
AutoVue for Agile, and an intelligent and displayable data stream is delivered to the 
client. In this way, the AutoVue for Agile implementation eliminates any concerns 
about security since the original document is not transferred to the client computer. 
While the viewable data is being transmitted, AutoVue for Agile uses compression and 
streaming algorithms to achieve a quick and responsive feedback to the client side for 
large and multi-page documents.

The server has complete control over the functions available to clients. For example, 
users may be granted or denied rights to perform printing, redlining, or any other 
functions depending on their access permissions.

AutoVue for Agile uses cookies to track the number of users. The cookie is a unique 
number assigned to each browser that defines a user as a single session, regardless of 
the number of files a user consecutively or simultaneously opens.

Note: If you disable or refuse cookies in your browser, AutoVue for 
Agile will continue to work. However, each new instance of the 
browser creates a new session in AutoVue for Agile.

HTTPS can be used for secure communications if you tunnel all communications 
between the viewer client and the server through HTTPS, which uses SSL. The applet 
must communicate with the AutoVue for Agile server through the AutoVue for Agile 
servlet. Any Agile communications that are tunneled are encrypted using SSL.

Configuring Thumbnail Datum Planes
To configure Datum Planes Visibility in AutoVue, add the following: 

[AgileHome]\AVS\bin\profiles

This configuration modification prevents the visibility of the datum planes for the 
Administration user when generating thumbnails.

[PMI]

COORDINATE_SYSTEM_TREE_VIS=0

COORDINATE_SYSTEM_VIEW_VIS=0

DATUM_FEATURE_SYMBOL_TREE_VIS=0

DATUM_FEATURE_SYMBOL_VIEW_VIS=0

DATUM_TARGET_TREE_VIS=0

DATUM_TARGET_VIEW_VIS=0

DIMENSION_TREE_VIS=0
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DIMENSION_VIEW_VIS=0

FEATURE_CONTROL_FRAME_TREE_VIS=0

FEATURE_CONTROL_FRAME_VIEW_VIS=0

LINE_WELD_TREE_VIS=0

LINE_WELD_VIEW_VIS=0

LOCATOR_TREE_VIS=0

LOCATOR_VIEW_VIS=0

MEASUREMENT_POINT_TREE_VIS=0

MEASUREMENT_POINT_VIEW_VIS=0

NOTE_TREE_VIS=0

NOTE_VIEW_VIS=0

REFERENCE_GEOMETRY_TREE_VIS=0

REFERENCE_GEOMETRY_VIEW_VIS=0

SPOT_WELD_TREE_VIS=0

SPOT_WELD_VIEW_VIS=0

SURFACE_FINISH_TREE_VIS=0

SURFACE_FINISH_VIEW_VIS=0

WIRE_TREE_VIS=0

WIRE_VIEW_VIS=0

Verifying the Firewall Configuration
The firewall on the Agile PLM side must be configured to allow:

■ Incoming HTTP/HTTPS connections from the Internet to the Web server.

■ Outgoing TCP/IP connections from the Web server in the DMZ to the Application 
Server inside the firewall on port 7001 or 7002 (SSL) for BEA WebLogic, port 7777 
or 8888 (SSL) for Oracle Application Server, and port 8009 for the File Manager.

Starting AutoVue for Agile
Note After installation, the AutoVue Server service is set to 'Manual'. To start AutoVue 
for Agile when the machine boots, set the service to 'Automatic'.

To start the AutoVue for Agile on Windows:

Start the AutoVue Server service or Choose Start > All Programs > AutoVue for Agile 
PLM > Start AutoVue Server.

To start AutoVue for Agile on Linux:

1. In a console window, go to the AGILE_HOME/AVS/bin directory.

2. Type the following command to initialize the server:

jvueserver &
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Running the AutoVue Server as a Service

Note: For more information about AutoVue configuration, see 
Installation and Configuration Guide, Oracle AutoVue, Client/Server 
Deployment, which can be found on the Oracle Technology Network 
(OTN) Web site http://www.oracle.com/technology/index.html.

When running the AutoVue server as a service, you must run it as a named user and 
not as Local System Account, as the local system account has more privileges than a 
named account.

On Windows Operating Systems
For more information about AutoVue configuration, see Installation and Configuration 
Guide, Oracle AutoVue, Client/Server Deployment, which can be found on the Oracle 
Technology Network (OTN) Web site 
http://www.oracle.com/technology/index.html.

AutoVue server can be run as a Windows Service. The advantage is that it continues to 
run even after you log off of Windows. Before running the AutoVue service, verify that 
it runs properly in "non-service" mode (for example, run by clicking the Start AutoVue 
Server button in the Start menu).

To install the service, go to the \bin folder of the directory where the AutoVue server is 
installed and enter the following:

jvueserverX.exe -install <user information>

where <user information> is in the form "domain\username password". This ensures 
that the AutoVue Server service runs as a named user instead of the local system 
account.

Note: The user account information you enter must be registered in 
the Log on as a service local security policy. If the user information is 
not there, the Oracle AutoVue service does not start.

To check or edit the security policy:

1. Open the Windows Control Panel.

2. Double-click Administrative Tools.

3. Double-click Local Security Policy.

The Local Security Settings window appears.

4. Expand Local Policies and then select User Rights Assignment.

5. Double-click on Log on as service.

The Log on as a service Properties window opens.

6. Verify that the user account is listed under the Local Security Setting tab. If not, 
click Add User or Group to add the user account information.

To remove the service:

1. Go to the <AutoVue Install Root>\bin directory and enter the following:

jvueserverX.exe -remove
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Starting and Stopping the Service

Note: For more information about AutoVue configuration, see 
Installation and Configuration Guide, Oracle AutoVue, Client/Server 
Deployment, which can be found on the Oracle Technology Network 
(OTN) Web site http://www.oracle.com/technology/index.html.

To start the service on Windows Operating Systems:

1. In the Control Panel start Services.

2. Select the Oracle AutoVue Server service.

3. Click Startup.

4. Select whether you want the service started automatically on re-boot or manually. 
The default is Manual.

5. If you select Manual, you can start the service by doing one of the following:

■ Click Start in the Services dialog

or

■ Use the sc.exe utility.

For example: SC start "Oracle AutoVue Server"

or

■ Use the NET program.

For example: NET start "Oracle AutoVue Server"

Once the Service starts it behaves exactly as if running in "non-service" mode. The 
AutoVue server icon appears in the System Tray.

To stop the service:

Click Shutdown.

On Linux Operating Systems

Note: For more information about AutoVue configuration, see 
Installation and Configuration Guide, Oracle AutoVue, Client/Server 
Deployment, which can be found on the Oracle Technology Network 
(OTN) Web site http://www.oracle.com/technology/index.html.

Oracle provides an RC-Script to manage the AutoVue server on Linux.

The AutoVue server can be configured to startup automatically when you restart the 
machine.

To configure the AutoVue Server to startup automatically:

1. Edit file <AutoVue Install Root>/etc/jvueserver_rc and locate the following lines:

AUTAUTOVUEUSEROVUEDIR=$USER_INSTALL_DIR$

=__JVUEUSER__
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2. Replace $USER_INSTALL_DIR$ with the path to AutoVue installation and __
JVUEUSER__ with the name of the user that will be running the AutoVue server.

3. Rename jvueserver_rc to autovue.

4. Login as a root and copy autovue to /etc/init.d folder.

5. As root, go to the /etc/init.d folder and add AutoVue as a service:

chkconfig --add autovue

6. Configure autovue to startup automatically:

chkconfig autovue on

AutoVue now starts up automatically when the machine starts up.

To start the AutoVue service manually:

Run

service autovue start

To stop the AutoVue service manually:

Run

service autovue stop

To remove the AutoVue service:

Run

chkconfig -del AutoVue

Launching jvueserver on a Linux Machine Using X-Manager
To launch a Linux OS machine using X-Manager:

1. Start Xstart.

2. In the Xstart dialog, specify the Linux machine details:

Session Choose a session, if necessary.

Host Host IP address

Protocol SSH

User Name Your user name

Password Your password

Save Check to select

Execution Command /user/bin/xterm -ls -display $DISPLAY

Show status dialog box Check to select

3. Click the Run button.

The xterm popup window is displayed.

4. In the xterm window, to launch the X-manager browser, at the Command prompt, 
enter:

gnome-session
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5. When the Terminal window opens, navigate to the bin directory of the AutoVue 
installation (i.e. AUTOVUE_HOME/bin) and start the AutoVue server as: 
./jvueserver

AutoVue starts once the port verification is completed.

Testing the VueServlet

Note: The Agile View servlet (VueServlet) is packaged and deployed 
as part of the File Manager installation. The VueLink Servlet is 
deployed on the File Manager and tunnels the requests to the Agile 
Application Server using HTTP protocol. No additional configuration 
is required.

The VueServlet is used to access AutoVue for Agile across firewalls from external 
clients on standard HTTP/HTTPS ports.

On the Application Server, you must ensure that the VueServlet has been loaded from 
the AutoVue for Agile home directory and that the VueServlet communicates with the 
Viewer. Open a browser and type the following URL in the location bar:

http://FileManager_hostname or LoadBalancer:port/Filemgr/VueServlet

A message appears indicating that JVueServer is up and running. The sample page 
appears displaying information about servlet tunneling and licensing.

■ On Windows, if you receive the message "The page cannot be displayed," ensure 
the World Wide Web server service is running on the computer. If not running, 
start the service from the Services window.

■ If you specify this URL in the browser and receive the message "Page not found," 
check the following:

– Ensure that the Web server is accessible.

– Check the web proxy configuration to ensure the virtual path and port 
number are correct. On Oracle Application Server, check the 9ias.conf file. On 
WebLogic, check the iisproxy.ini file.

Managing Multiple Viewers for Load Balancing
AutoVue for Agile is designed to provide server scalability to support increasing 
demand for file viewing and markup on intranets and the Internet. It can run in a 
process pool on a single computer that improves the responsiveness for simultaneous 
connections and balances the load across a multi-CPU computer.

The default process pools four concurrent services. It is specified in the 
jvueserver.properties file located in the AutoVue for Agile home folder at \\AGILE_
HOME\AVS\bin:

jvueserverx.nt.processPoolSize=8

The system allows you to add servers to support more users while the servers are 
online, without restarting or disconnecting existing servers. Doubling the capacity is as 
simple as adding another computer. When using multiple viewers, the load can be 
efficiently balanced across the servers by manually directing the viewer client requests 
to different viewers.
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Dynamic and static load balancing are supported. For more information, see the 
AutoVue Client-Server Edition Installation and Administration Manual.

Multiple viewer functionality must be configured as follows:

■ Each viewer computer acts independently.

■ Each viewer computer can point to the same Agile Application Server computer or 
to a different Agile Application Server computer in a single or distributed Agile 
PLM system.

■ The viewers are not clustered, so there is no single entry point computer for all 
Java clients to connect into any viewer.

For Agile Web clients outside the corporate firewall, the functionality for multiple 
viewers must be configured as follows:

■ The AutoVue for Agile client applet can communicate across firewalls on a 
standard HTTP/HTTPS port.

■ Each AutoVue for Agile computer acts independently.

■ Each AutoVue for Agile computer can point to the same Agile Application Server 
computer or to a different Agile Application Server computer in a single or 
distributed Agile PLM system.

■ External Agile Web clients are given different URLs that point to different Web 
servers hosting an Agile Web client with an AutoVue for Agile client and an 
AutoVue for Agile servlet. In turn, each AutoVue for Agile client and AutoVue for 
Agile servlet points to the different viewer to distribute the load.

■ The viewers are not clustered, so there is no single entry point computer for all 
Agile Web clients to connect into any viewer.

To configure AutoVue for Agile server and AutoVue for Agile client communication 
across firewalls on specific ports, use standard HTTP ports.

Client-Server Communications
For AutoVue for Agile, the issue of using IP addresses for client-server communication 
at runtime (rather than hostnames or DNS names) is resolved because the application 
server also hosts the VueServlet. The VueServlet acts as a proxy for AutoVue for Agile, 
and it is placed on the intranet with other Agile server components. In addition, since 
the VueServlet is running on the application server with an Agile Web client, the Web 
server proxies also forward external requests to the intranet. The VueServlet comes as 
part of the File Manager installation.

Removing AutoVue for Agile
Follow these instructions to remove AutoVue.

To remove AutoVue for Agile on Windows:

1. Stop the AutoVue service.

a. Open the Services dialog box.

b. Select AutoVue Server and stop the service.

c. Close the Services dialog box.

2. Choose to Start > Settings > Control Panel.

3. Double-click Add/Remove Programs.
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The Add/Remove Programs Properties dialog appears.

4. Scroll down the window and select AutoVue Web Edition.

5. Click Change/Remove.

6. Click Uninstall, and click ok to confirm the deletion.

7. Click Exit.

To remove AutoVue for Agile from the Start menu:

1. Choose Start > All Programs > AutoVue for Agile PLM > Setup > Uninstall 
AutoVue.

2. Select and delete the installation folders from the location of Agile home directory.

To remove AutoVue for Agile on Linux:

1. Stop the AutoVue server by clicking Shutdown on the View Server applet or 
killing the jvueserver process.

2. Go to the VIEWER_HOME/AVS/_uninst directory.

3. Run the uninstall_linux2.bin file to uninstall AutoVue for Agile.

Troubleshooting AutoVue for Agile
This section provides information for troubleshooting your AutoVue for Agile 
installation.

Errors Which May Occur While Using AutoVue for Agile
Common errors that occur while using AutoVue for Agile are listed in the table below 
along with solutions.

While the Web or Java client tries to start Autovue for Agile PLM:

Errors Reasons Solutions

jVue not found Viewer Content URL in Admin 
> Server Settings > Locations > 
File Manager is incorrect.

Incorrect client applet alias 
specified instead of mandatory 
"jVue."

Confirm that the Viewer 
Content URL is accessible and 
the jVue.jar file is listed.

An error occurred while 
connecting to the server. 
Restart the applet?

AutoVue for Agile or File 
Manager is down.

Incorrect View Server URL in 
Admin > Server Settings > 
Locations > File Manager.

AutoVue for Agile is configured 
incorrectly, or is unavailable

Confirm that the Viewer Server 
URL is accessible and returns a 
successful connection status.

When the Web Client or the Java Client tries to connect to a file manager:

File not found The file manager is down.

The VueServer.ini file points to 
incorrect file manager.

Confirm that the file manager is 
up and running.
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If an attachment uses special fonts:

Fonts may not appear 
correctly or a file error 
may occur or an incorrect 
font substitution may 
occur with viewing or 
printing the attachment.

The computer where the 
Viewer is installed does not 
have the fonts installed.

The computer where Viewer is 
installed must have those special 
fonts installed locally.

For fonts other than the ones used 
by the operating system, the user's 
profile should include a reference 
to the location of the fonts in the 
XFONTPATHS parameter.

Changing Port Numbers
Some AutoVue for Agile PLM port numbers can be changed in the event of a port 
conflict. It is important to change the port number in all referenced locations. For more 
details on ’Port Numbers’, please refer to the AutoVue Installation and Administration 
Manual.

Additional AutoVue for Agile PLM Documentation
The AutoVue Installation and Administration Manual (install.pdf) is installed in the 
following location on the computer where you have installed AutoVue for Agile PLM:

\AVS\docs

Please refer to the AutoVue Installation and Administration Manual for the following 
information:

■ How to use the AutoVue Server Console.

■ How to enable debugging information (logging) for AutoVue for Agile PLM.

■ How to further configure AutoVue for Agile PLM.
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3Using AutoVue for Agile

The AutoVue viewer has been integrated into the Agile system to make use of the 
ability to manage attached files by using Agile system features. The integration also 
streamlines the viewer menus, toolbars, and shortcuts. 

How to Use this Manual
This manual is a supplement to AutoVue online Help. It is intended to be used in 
conjunction with the AutoVue for Agile Online Help and other Oracle Agile manuals.

The following table shows where you can find information about Agile features and 
concepts, which you may find useful.

Feature or concept Contained in this document

Java Client Navigation Getting Started with Agile PLM User Guide

Web Client Navigation Getting Started with Agile PLM User Guide

Relationships and rules between objects Getting Started with Agile PLM User Guide

Attachment files

Working with file folder objects

File folder mass update

Routing and reviewing file folders

File validation (Handle Check Sum)

Viewing and redlining file folder contents

Getting Started with Agile PLM User Guide

Redlining through ECOs, MCOs and SCOs Product Collaboration User Guide

Note: To find an Agile PLM document, choose Help > Manuals in 
the Web Client or the Java Client to display the Agile PLM 
documentation web page.

Getting Help
To get help at any time, choose Help > Contents in the AutoVue for Agile menu bar. 
The AutoVue for Agile Online Help is displayed; it includes detailed information 
about using viewer features.
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complete list of features and user interface details described in the 
AutoVue for Agile Online Help that have been modified in order to 
integrate the viewer with the Agile system.
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About AutoVue for Agile
AutoVue for Agile can display many different file formats without their authoring 
applications. You can view files from many database, graphic, spreadsheet, 
word-processing, and CAD applications. Even archived files can be listed and viewed 
without the need to decompress them. It isn't necessary for you to identify the file 
type; AutoVue for Agile automatically identifies the type of file you are requesting it to 
read. The Agile administrator determines which types of files can be viewed in the 
Viewer & Files node of the Agile Administrator module in Java Client.

Important: To view files through AutoVue for Agile, you need Agile 
Discovery, Read, and ViewFile privileges for the business object. To 
redline files through AutoVue applications, you need the appropriate 
privileges that allow you to redline attachment files (for example, the 
Agile default role Markup for Self and for ECO attachment redlining, 
a role that includes an appropriate Attachment Redlines for Others or 
Attachment Redlines for Self privilege). For information about roles 
and privileges, see Agile Administrator.

The action of attaching your comments, notes, and drawings to a document is known 
as marking up, also commonly known as annotating or redlining. A markup refers to the 
change being made to a document by attaching a markup object. You can use AutoVue 
for Agile to mark up files as well as view them.

Note: Agile Web Client and Agile Java Client support attachment 
redlining. Markups for ECOs can be made on the Redline 
Attachments tab in Web Client and Java Client. You access the 
appropriate redline tab on the Affected Items tabs of ECOs. Markups 
for a file folder object can be made on the Files tab of the file folder 
object in Web Client and Java Client and do not require an ECO.

Some of the AutoVue for Agile features are:

■ Flexible user-defined objects - AutoVue for Agile offers a vast selection of markup 
objects, including circles, clouds, polygons, and arrows. Text can be attached to 
objects, and lengthier comments can be contained in embedded notes.

See AutoVue for Agile Online Help for a detailed discussion of markup objects. 
Choose Help > Contents in the AutoVue for Agile menu bar.

■ Storage of unedited original documents - Original documents are never changed. 
All your notes and drawings are saved in a separate file called a markup file, 
although when viewed they appear to be part of the main document. You do not 
have to manage the storage and retrieval of markup files; Agile does that for you.

■ Support for non-English languages and operating systems - AutoVue for Agile 
works with many non-English languages, and has been tested on Japanese, 
Chinese, French, German, Hebrew, and Swedish operating systems.
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Starting AutoVue for Agile Client
You can start AutoVue for Agile from either the item Attachments tab or the file folder 
Files tab.

To start AutoVue for Agile in Web Client:

Click the file name link in the table.

Or

Select one or more rows.

Note: 9.2.2.x or 9.2.1.x: Click the View File(s) button's drop-down 
arrow and select View from the menu.

Or

9.3.x: Click the View button's drop-down arrow and select View from the menu.

Note: If the View icon is visible on the button, you can simply click 
the button.

When you start AutoVue for Agile, the main AutoVue for Agile window appears.

Note: For more information about starting AutoVue for Agile, see 
"Opening Agile Attachment Files in AutoVue for Agile" on page 4-1.

To start AutoVue for Agile in Java Client:

Double-click the attachment row.

Or

Select one or more rows.

Note:  Click the View File(s) button's drop-down arrow and select 
View from the menu.

Note: If the View icon is visible on the button, you can simply click 
the button.

Viewing an Attachment Tab Row with Multiple Files
Web Client:

Attachment tab rows that refer to a multiple-file file folder display a link for each 
individual file in the File Name column. You can:

■ Click the file name link of a specific file you want to view.

■ Select the row and choose View > View in the Attachments tab menu.

For more information about starting AutoVue for Agile, see "Opening Agile 
Attachment Files in AutoVue for Agile" on page 4-1.
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Java Client:

When viewing files from the Attachments tab of an Agile business object in version 
9.2.2.x or 9.2.1.x, if you view a single row that refers to a multiple-file file folder, the 
Select Files window appears. The Select Files window lists the files in that file folder 
and allows you to select one or more files that you want to view. In version 9.3.x, you 
can select the link of each individual file you want to view.

Understanding AutoVue for Agile
The following sections describe the main AutoVue for Agile window and performance 
modes, in addition to other information you need, to use AutoVue for Agile.

AutoVue for Agile Modes
AutoVue for Agile has two modes of operation: View and Markup.

View Mode
When a document is first opened from business object's Attachments tab or file folder 
Files tab, the menu bar and toolbars are those of View mode. View mode is the 
AutoVue for Agile default mode. Documents can be edited or marked up only from 
Markup mode, described in the next section.

Markup Mode
When AutoVue for Agile is in Markup mode, the currently displayed document can be 
marked up. That is, you can redline or annotate it. Available markup objects include 
various shapes, notes, symbols, and text. When you open AutoVue for Agile from the 
Redline Attachments tab or Files tab in a file folder object, AutoVue for Agile opens 
either in View or Markup mode, depending on whether the attachment has a saved 
markup and the privileges assigned to the user. If the attachment is checked out, then 
the redlining will not be allowed, however, you can change to AutoVue for Agile 
Markup mode to display saved markups. For instructions on how to enter Markup 
mode from View mode, see "Guidelines for Marking Up or Redlining Attachments" on 
page 4-10. When you open a markup file, Markup mode starts automatically.

Note: Markup mode is only available in AutoVue for Agile when the 
viewer is opened from tabs where markups are allowed: from a 
change order's Redline Attachments tab and from the Files tab of a file 
folder. In addition, you must have the appropriate privileges that 
allow you to redline attachment files (for example the Agile default 
role, Markup for Self privilege). Contact your Agile administrator if 
you have questions about your assigned roles and privileges.

AutoVue for Agile Window Components
There are a few basic components to the AutoVue for Agile work environment, shown 
in the following figure. These differ depending on whether AutoVue for Agile is in 
View mode or Markup mode.
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Basic Components of the AutoVue for Agile Work Environment

***********************************************************************************************

PinMe Icon  In the upper right corner of the AutoVue for Agile window is the PinMe 
icon. Click to pin (or lock) the AutoVue for Agile window open. A pinned AutoVue for 
Agile window (displays a pinned icon to indicate the AutoVue for Agile window is 
pinned). When you view an additional attachment, a new AutoVue for Agile window 
opens. This feature allows you to have multiple AutoVue for Agile windows open at 
one time, thus allowing you to switch between open windows to compare or refer to 
multiple viewed files.

Menu Bar  The menu bar at the top of the window is the main access to all of the menu 
commands. The selection of available commands changes according to the mode 
AutoVue for Agile is in and the task that you are performing.

Toolbars  The tool buttons under the menu bar offer easy access to the basic commands 
present in the menu bar. As with menu commands, the selection of available toolbar 
buttons changes according to the mode AutoVue for Agile is in and the task that you 
are performing.

Status Bar  In both View mode and Markup mode, there is a status bar located at the 
bottom of the main window. The fields from left to right for each mode's status bar are 
as follows: markers (see the following list), current active file name, file type, zoom 
factor, current page and total number of pages, current active file size, date of the file's 
creation, and the pointer's coordinate position.

The following types of markers can appear on the status bar:

■ The File has saved markup marker indicates that the current active file has 
associated markup files. While in View mode, click the markup from the File menu 
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to view the Markup Files dialog box. Then select a markup file or group of 
markup files to open. When you open a markup file, Markup mode starts 
automatically.

■ A red exclamation mark indicates that some main resources required to properly 
read the current active document are not available (for example, missing fonts or 
missing CAD files). To quickly identify the missing resources, click the red 
exclamation mark, and the File Properties dialog box appears.

Moving Objects
You can use the left mouse button to click and drag.

■ In View mode - By default, drag to perform an autozoom of all supported file 
formats (including raster and vector files). Select the area you want to enlarge.

■ In Markup mode - If objects are selected, drag to modify and move objects. If no 
objects are selected, drag to perform an autozoom (same as in View mode).

To select an object, click it. Selected objects are framed by a text box. Modify the size of 
the object by dragging the frame handles. To move an object, move the cursor to the 
borders (the edges) of the markup entity until the cursor turns into a hand pointer. 
Drag the hand pointer to a new location.

Accessing Commands with Shortcut Menus
The easiest and quickest way to access most of the AutoVue for Agile functions is by 
using the shortcut menus. Right-click with the pointer over the View window to access 
appropriate commands.

In View mode, use these commands:

■ Zoom Fit - to automatically fit the document to the width of the view window.

■ Zoom Previous - to automatically return to your previous zoom level.

■ Zoom Page Width - to automatically fit the document to the width of the view 
window.

■ Markup/Exit Markup - to enter and exit Markup mode and open an existing 
markup or create a new one. The Markup command is available in View mode 
only when markups are allowed.

In Markup mode, use these additional commands:

■ Line Style - to select a style of line to use in your markup.

■ Line Thickness - to select a line thickness for use in your markup.

■ Fill Type - to select the type of fill to apply to your markup object: Solid Fill, No 
Fill, or Transparent Fill.

■ Entity Color - to select a color for your markup object.

■ Order - to select the overlay order when several markups are being displayed 
simultaneously.

■ Markup Layer - to select which layers are visible or active, change layer color, add 
new layers, and rename existing layers.

■ Copy, Paste, Delete

■ Format (sub-menu), Group, Ungroup, Rotate, Order

■ Attachment
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■ Close All Markups

For more information about using these AutoVue for Agile commands, refer to the 
AutoVue Help. Choose Help > Contents in the AutoVue for Agile menu bar.

Canceling an Operation in Progress
To cancel an operation in progress, click the right mouse button. The current operation 
is canceled immediately.

For example, if while drawing a box you realize that you would prefer to draw a 
cloud, right-click while drawing the box and the box is canceled.

If you have already drawn a box, you can either choose Edit > Undo from the menu 
bar or select the box and press the Delete key on your keyboard, to remove it.
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4Agile-specific Features and Functions

This chapter describes how to view attachments in Agile PLM using AutoVue for 
Agile, and how to work with the Agile-specific AutoVue features and functions.

Opening Agile Attachment Files in AutoVue for Agile
You can view files from either the Attachments tab of a business object or from the 
Files tab of a file folder object.

Viewing Files from Web Client

Note: When multiple files are displayed in AutoVue for Agile, use 
the document navigation buttons in the viewer toolbar to select the 
document that appears in the viewer window. 

To view a file from Web Client, Attachments tab:

1. Go to the Attachments tab of a business object that references the file.

2. Click the file name link in the attachments table.

■ If the attachment row refers to a file folder with only one file, AutoVue for 
Agile opens and displays that file.

■  If the attachment row refers to a multiple-file file folder, each file is listed in 
the File Name column. Click the file link you want. AutoVue for Agile opens 
and displays that file.

Or, you can use the Attachment tab View button:

3. Go to the Attachments tab of a business object that references the file.

4. Select one or more attachment rows.

5. Click the View button's drop-down arrow and select View from the menu.

■ If you selected one attachment row that refers to a file folder with only one 
file, AutoVue for Agile opens and displays that file.

■ If you selected one attachment row that refers to a multiple-file file folder, 
AutoVue for Agile opens and displays all the files in the multiple-file file 
folder.

■ If you selected more than one attachment row, AutoVue for Agile opens and 
all the files in all the selected rows are displayed in the viewer.
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To view a file from Web Client, Files tab:

1. Go to the Files tab of a file folder object containing the files you want to view.

2. Click the filename link in the file table.

AutoVue for Agile opens and displays the file.

Or, select one or more file rows.

3. Click the tab menu View button's drop-down arrow and select View from the 
menu.

AutoVue for Agile opens and displays the selected files.

Viewing Files from Java Client

Note: When multiple files are displayed in AutoVue for Agile, use 
the document navigation buttons in the viewer toolbar to select the 
document that appears in the viewer window.

To view a file from Java Client, Attachments tab:

1. Go to the Attachments tab of a business object that references the file.

2. Double-click the attachment row.

■ If the attachment row refers to a file folder with only one file, AutoVue for 
Agile opens and displays that file.

■  If the attachment row refers to a multiple-file file folder, the Select Files 
window appears. Select one or more files to view and click OK. AutoVue for 
Agile opens and displays the files you selected.

Or, you can use the Attachment tab View File(s) button:

3. Go to the Attachments tab of a business object that references the file.

4. Select one or more attachment rows.

5. Click the View File(s) button's drop-down arrow and select View from the menu.

Note: If the View icon is visible on the button, you can simply click 
the button.

■ If you selected one attachment row that refers to a file folder with only one 
file, AutoVue for Agile opens and displays that file.

■ If you selected one attachment row that refers to a multiple-file file folder, the 
Select Files window appears. Select a file to view and click OK. The file 
displays in the Viewer. The Navigation buttons in the Viewer allows you to 
navigate to other files. 

■ If you selected more than one attachment row, AutoVue for Agile opens and 
all the files in all the selected rows are displayed in the viewer. The Select Files 
window does not appear.

To view a file from Java Client, Files tab:

1. Go to the Files tab of a file folder object containing the files you want to view.
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2. Double-click the filename in the file table. AutoVue for Agile opens and displays 
the file.

3. Or, select one or more file rows.

4. Click the tab menu View File(s) button's drop down arrow and select View from 
the menu.

Note: If the View icon is visible on the button, you can simply click 
the button.

The Viewer opens and displays the selected files.

Opening Agile Attachment Files from the Viewer Window
When the AutoVue for Agile window is open, you can use the viewer menus to select 
additional Agile files. For many viewer functions this is a preferred method compared 
to pre-selecting the files in the Agile client.

The specific AutoVue for Agile menu choices that are available to allow you to select 
an Agile attachment file depend upon the function you originally chose in Agile PLM 
when you opened AutoVue for Agile (View, Compare, or Overlay) and the file type of 
the currently viewed file.

Note: Because the list of available AutoVue for Agile menu selections 
for attachment file selection can vary, some of the following menu 
selections may not be available for you to choose in a specific viewer 
session.

The possible available AutoVue for Agile menu selections that allow you to select 
another attachment file include:

■ File > Open URL

■ Analysis > Compare

■ File > Import File as Overlay - (available if a 2D file is active)

■ File > Import File for Mockup - (available if a 3D model is active)

■ Analysis > Cross Probe

When you choose one of these menu selections, in order to select the file you want to 
view or to add to the current analysis view, a File Open dialog appears. The Agile 
Browse button in the File Open dialog allows you to use your Agile Bookmarks to 
select a file. The Agile Search button in the File Open dialog allows you to perform a 
quick search and select a file.

To use your Agile Bookmarks to select an attachment file:

1. Choose an available Viewer menu option:

■ File > Open URL

■ Analysis > Compare

■ File > Import File as Overlay

■ File > Import File for Mockup - (available if a 3D model is active)

■ Analysis > Cross Probe
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2. Follow any dialog prompts until the File Open dialog appears.

3. Click the Agile Browse button in the File Open dialog to display the DMS: File 
Open dialog.

The DMS: File Open dialog displays your Agile Bookmarks in a tree structure.

Note: If you have not defined any Bookmarks in Agile PLM, the 
Agile Browse button does not appear in the File Open dialog.

4. Click + to expand a bookmark and display its item revisions or its file folder 
versions.

5. Click a revision or version row to highlight the file you want to view.

6. Click OK in the DMS: File Open dialog.

The selected file name appears in the File Name field of the File Open dialog.

7. Click OK in the File Open dialog.

AutoVue for Agile opens the selected file, or, if appropriate, adds the selected file 
to the current analysis function.

To perform a quick search to select an attachment file:

1. Choose an available Viewer menu option:

■ File > Open URL

■ Analysis > Compare

■ File > Import File as Overlay

■ File > Import File for Mockup - (available if a 3D model is active)

■ Analysis > Cross Probe

2. Follow any dialog prompts until the File Open dialog appears.

3. Click the Agile Search button in the File Open dialog to display a Search dialog 
which allows you to run a quick search.

4. Define your search and click the Search button:

■ Class - Select an object class, for example, Items.

■ Search Parameter - Enter a text string or a number.

Agile PLM searches the object ID number attribute and the object Name or 
Description attribute. A Quick search behaves like a Contains search for text 
strings. The search criteria is treated as a single string and Agile PLM searches for 
names or descriptions that contain the search parameter string. In the case of ID 
numbers, Agile PLM searches for an exact match, however, you may use wildcard 
characters to specify part of an ID number as a search criteria.

■ Search Attachment Content - Set this parameter to Yes to search the contents of 
the attachment files as well.

5. In the Search Results table, click the + next to the object number to expand the list 
of attachment files for that object.

6. Click a revision row or a version row to select the file you want to view.

7. Click the Load File button. The selected file name appears in the File Name field of 
the File Open dialog.
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8. Click OK in the File Open dialog.

AutoVue for Agile opens the selected file, or, if appropriate, adds the selected file 
to the current analysis function.

Comparing Revisions or Versions of a File
You can view a file from an item Attachments tab or a file folder Files tab and then 
select, from the AutoVue for Agile window, other item revisions or file folder versions 
of the file to compare against. After comparing one revision or version, you may select 
another, comparing multiple revisions or versions of the file from within the AutoVue 
for Agile window.

To compare multiple item revisions of an attached file:

1. On the item Attachments tab, select the file you want to compare.

2. Choose View from the tab menu. AutoVue for Agile opens, displaying the selected 
file.

3. In the viewer menu, choose Analysis > Compare. The File Open dialog appears.

4. Check the Document Versions checkbox, if it is not already checked.

5. Use the drop-down menu to select another revision of the file for comparison.

Note: Only released item revisions appear in the drop-down list. To 
compare the attachment of a pending revision, view the pending 
revision file, and then use Analysis > Compare to select released 
revisions for comparison.

6. Click OK. AutoVue for Agile opens the selected version in a second window and 
displays the differences between the two files in a third window.

7. To compare another revision, choose File > Exit Compare in the viewer menu.

8. Repeat steps 3 through 6 to select another item revision.

To compare multiple file folder versions of a file:

1. On the file folder Files tab, select the file you want to compare.

2. Choose View from the tab menu. AutoVue for Agile opens, displaying the selected 
file.

3. In the viewer menu, choose Analysis > Compare. The File Open dialog appears.

4. Check the Document Versions checkbox, if it is not already checked.

5. Use the drop down menu to select another file folder version of the file for 
comparison.

6. Click OK. AutoVue for Agile opens the selected version in a second window and 
displays the differences between the two files in a third window.

7. To compare another file version, choose File > Exit Compare in the viewer menu.

8. Repeat steps 3 through 6 to select another file folder version.
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Viewing Design Object Structures

Note: Viewing structured data in a Design data model class object 
relies on the Structure tab to resolve related objects in the structure.

When you open a CAD assembly file in a Design object, Agile PLM also automatically 
opens the subordinate CAD part files in AutoVue for Agile, allowing you to view the 
entire CAD design. Agile PLM uses the assembly structure, as defined on the Structure 
tab of the Design object and the Structure tabs of its child Design objects.

This process is seamless and requires no action by the user other than initiating the 
view function for the assembly file.

The following list provides details about how Agile PLM extracts CAD Structure files 
from the Design object and its Structure table for CAD design viewing:

■ The file type of the Design object selected file must be designated as a CAD 
Structure file type on the File Association tab of the Viewer & Files node in Agile 
Administrator.

■ The structure used to extract files is explicitly set on the Design object Structure 
tab.

■ Agile PLM identifies which Design objects files to extract by the following 
methods:

– If the value of the File Category attribute from any file row of a child Design 
matches the File Category value of the starting file, the file is extracted.

– If the selected starting Design object file has no value for Category, then all 
files in all child Designs are extracted, including the starting Design object.

■ If multiple file rows on a Design object structure have the same Category value as 
the starting file, they are all extracted, at any level in the tree.

■ If the user selects multiple Design object files and chooses View, each selected file 
is interpreted separately, based on Design structure viewing logic.

■ When a Design object is from a business object's Attachment tab, Agile PLM uses 
the rules for viewing Designs, not the rules for viewing DocuBOMs. That is, 
Design object viewing rules are always applied to Design objects whether the 
viewing action is initiated from a Design object or from the business object 
Attachments tab.

Viewing Document Structured File Types

Note: Viewing structured data in a File folders class object relies on 
the DocuBOM or the Relationships tab to resolve related objects in the 
structure.

While this technique for viewing structured CAD files in DocuBOMs is still supported, 
it has been superseded by Design structures as the preferred way for storing and 
viewing CAD data.

CAD data can be stored in Agile PLM using document object BOM structures. This is 
usually accomplished automatically when Agile PLM and EC are integrated using EC 
CAD connectors. A CAD assembly file is attached to an Agile document object, and the 
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subordinate CAD part files are also attached to Agile document objects. The part file 
document objects appear on the BOM tab of the CAD assembly document object, thus 
creating a hierarchical file structure for the attached files.

Note: Files types that are used in structured file hierarchy are 
specified in Agile Administrator Viewer & Files node with the CAD 
Structure file association.

When you open a CAD Structure assembly attachment, Agile PLM automatically 
opens the subordinate part files in AutoVue for Agile also, allowing you to view the 
entire CAD design. This process is seamless and requires no action by the user other 
than initiating the view function for the assembly file.

The following list provides details about how Agile PLM extracts CAD Structure files 
from the document BOM structure for CAD design viewing:

■ Agile PLM extracts only file types specified as CAD Structure file types. If an 
attached file type is not specified as a CAD Structure file type, Agile PLM does not 
traverse the document structure to find other files.

■ If the file type is specified as a CAD Structure file type, then Agile PLM will 
traverse all levels of the document hierarchy, starting with the selected file, and 
extract other files necessary to build the complete model.

■ In order to avoid pulling out unnecessary files, the viewing logic makes use of the 
Attachment Type attribute on the document's Attachments tab. If there is a value 
in this attribute (such as SOURCE) for the originally selected file attachment, then 
only files whose Attachment Type attribute matches this value will be extracted. If 
there is no value in the Attachment Type attribute, then all files within the 
structure hierarchy will be extracted.

■ If there are multiple file attachments with the matching value of Attachment Type 
on the same document, they will all be extracted and sent to the AutoVue for 
Agile. This includes the document from which the view operation was initiated.

■ If any given document in the hierarchy does not have any file attachments, or any 
with the correct value of Attachment Type, the extraction process does not stop but 
simply continues down the tree.

■ The Agile administrator may have configured Agile PLM to use the CAD Revision 
BOM attribute. This is a technique, principally used by the standard Agile EC 
CAD Connectors, to provide an As Saved fixed BOM resolution for CAD designs. If 
this is enabled, when you view a past revision of a design it will appear exactly as 
it was saved. If not, the view may differ slightly if child components have been 
revisioned in the meantime (that is, standard Agile BOM resolution logic is 
followed).

■ You may select any document revision for viewing, including a pending revision. 
If the CAD Revision attribute is enabled, then viewing a pending Rev will display 
any active pending Revs within the structure that were saved from CAD.

■ All AutoVue for Agile operations support CAD Structure file types, including 
View, Markup, Compare, Cross Probe, Overlay, and Digital Mockup.

Using the Version Browser
When a File Folder object is open in Web Client, you can view information about all 
versions of the by using the Actions menu View All Versions command.
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When a Design object is open, you can view information about all versions/revisions 
of the Design by using the Actions menu View All Versions command.

You can select a version and/or revision from the version pull-down selector on File 
Folder objects. Revisions (if set) are indicated to the right of the version.

To switch between versions of a Design object in Web Client:

From the Version drop-down list at the top of the Design object, select the 
version/revision you want to view.

Note: A version number in brackets, for example [4], indicates a 
version that has not yet been checked in. In this example, when 
version 3 was checked out, a pending version [4] was created. 
Selecting [4] in the version drop-down list allows you to view and 
work with the pending version.

To open the Versions palette:

In the Actions menu, choose View All Versions. The Versions palette opens.

Note: The View All Versions action is available only in Web Client. 
Java Client does not support Design objects.

The Version palette displays the following information about each version:

Versions Column Description

Column 1 Displays the approval status of the file folder version.

The approval status is displayed only if there are approvers on the 
Routing Slip.

Version The version number.

Checkin Date

Checkin User

The date the version was checked in and the user who performed the 
checkin.

When the version is checked out, these fields are blank.

Change Info Indicates how the version was modified before it was checked in.

Files indicate that the object's files were modified; for example, files 
were replaced, added, or deleted.

For Design objects, Structure indicates that the Design's Structure tab 
was modified.

Label, Revision, 
Revision Date

These are version-specific editable fields used primarily with Design 
data model objects.

Actions you can initiate in the Versions palette:

■ View: Click the View drop-down menu to choose one of the options.

– View: Select any version row and click View to view the file or files in 
AutoVue for Agile.

– Compare: For single-file versions, select two version rows, and choose 
Compare in the View button drop-down list. AutoVue for Agile compares the 
selected files.

The Design object Version palette includes the following additional actions:
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■ Comparison Report: (Design objects only) Click the Comparison Report 
drop-down menu to choose one of the options.

– Compare: Select any two version rows and click Compare to compare the 
Designs in the Comparison Report drop-down menu. A Design Comparison 
Chart displays a comparison report.

– Comparison by Search: Select a version row and click Compare by Search in 
the Comparison report drop-down list. A Compare by Search palette opens. In 
the drop-down list select either Latest Version or All Versions. Enter a search 
string (enter * to search for any design object) and execute a quick search. 
Choose from a list of Designs to compare with the original Design object. The 
Design Comparison Chart displays a comparison report.

Design Comparison Chart

The Design Comparison Chart displays reports of the compared Design objects.

The plus sign expands the Design object to display a list of child objects attached to it. 
You can collapse the object using the minus sign. Click the grey dot icon to see more 
details about Attributes and Files. Colors indicate the state of the Design object. For 
example, Blue - Added, Orange - Modified, Red - Deleted.

■ Purge Version: Design objects store large CAD files, which are updated regularly. 
The Purge Version action allows you to remove unwanted Design versions and 
help optimize file storage. To begin the process, the Design object needs to be in 
the checked in state. Purging starts at the original version and continues down the 
Structure tab, and goes through all the versions, including the child objects. The 
process stops if you cannot purge a child object.

Accessing Different File Versions from the Business Object Attachments Tab
You can get, open, view, and print any version of an attachment file from the 
Attachments tab of the business object.

You can easily access history without clicking through to the File Folder object. This is 
useful when a single file is being modified and accessed by multiple people/different 
functions. For instance, user can easily trace and identify in which versions another 
user made their edits - this is identified from version create date and checkout user.

The Versions dialog displays, for each version, the Version Creation Date (date the 
version was created), whether that version has redlines (indicated by the Has Been 
Redlined icon), and the Checkout User (user who created that version). This allows 
you to easily see the history of an attachment from the Attachments tab, including 
who modified the file, and when it was modified.

To switch between versions of file folders from an object's Attachments tab in Web 
Client:

1. On the Attachments tab, select the attachment row you want.

2. In the tab menu, choose More > View Versions. The Versions dialog appears.

3. In the Versions dialog, select the row you want, and choose the appropriate dialog 
menu button (Get, View, or Print).

4. Optionally, select two version rows, and then choose Compare or Overlay in the 
View action button drop-down menu.

To switch between versions of file folders from an object's Attachments tab in Java 
Client:

1. On the Attachments tab, select one attachment row that you want to access.
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2. Click the Show Versions button. The Versions dialog appears.

3. Select the version row or rows that you want to access.

4. Click the appropriate action button (Get, Open, View, or Print).

5. Optionally, click the Has Been Redlined icon to open the AutoVue for Agile and 
display the redlines.

6. Optionally, select two version rows, and then choose Compare or Overlay in the 
View action button drop-down menu.

Ad Hoc Markups
Ad hoc 2D, 3D, and EDA markups can be done from the Files tab in the file folder 
object. Change order-controlled 2D, 3D, and EDA markups can be done from the 
Redline Attachments tab in the ECO. When you view a markup file, the original 
document, also known as the base file, opens too.

Note: Change order-controlled and ad hoc markups are independent 
from each other.

To view change order-controlled markups, open the redlined file from the appropriate 
revision of the item Attachments tab or from the change order Redline Attachments 
tab (see "Viewing ECO Redlines from the Attachments Tab of the Item Pending 
Revision" on page 4-14).

To view ad hoc markups, open the redlined file from the file folder object Files tab.

Marking Up - How It Works
Marking up refers to drawing and writing in an electronic document. With AutoVue 
for Agile, your original document remains unchanged because your markups are 
saved in separate markup files. When you view a markup file, AutoVue for Agile 
loads the markups into memory and lays them over the original document.

There can be as many markup files as you wish for a document because each has its 
own unique filename. This allows several individuals to mark up the same document 
at the same time because a unique markup file is created for each person's work. With 
the markup information attached to each markup file, you can even tell who created 
each markup.

Markup files are divided into uniquely named layers. Create, name, and color the 
layers to organize your work as you like. For example, different colors could indicate 
time priorities, and each layer could contain markups relating to a common purpose. 
Markup files are stored with other attachment files in the file vault, part of Agile File 
Manager (AFM). Markup files are managed by Agile and are automatically retrieved 
and presented when you view the redlined document.

Guidelines for Marking Up or Redlining Attachments
With appropriate privileges, you can redline Microsoft Office documents, 2D, 3D, and 
EDA files on the Files tab of a file folder object and redline 2D, 3D, and EDA files on 
the Redline Attachments tab, accessible from the Affected Items tab of an ECO.



Note: You can create and edit file markups only through the Affected 
Items tab of an ECO or the Files tab of a file folder object. Your Agile 
administrator must give you privileges that allow you to mark up or 
redline attachments. For more information about ECOs and file folder 
objects, see Getting Started with Agile PLM.
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Web Client ECO Markups for Agile PLM 9.2.2.x or 9.2.1.x

Note: If the item or file has already been redlined, then the Has been 
redlined icon will be displayed in the place of the Do Redlining icon.

To mark up or redline an attachment file from an ECO in the Web Client:

1. If you have not already done so, add an item with an attachment to the Affected 
Items tab of an unreleased ECO. The item now has a pending revision associated 
with the unreleased ECO.

Note: When redlining an attachment through an ECO, the pending 
revision attachment Folder Version must be set to a specific version 
number; if the Folder Version is set to LATEST-x, you will not be able 
to create redline markups. However, you can edit the Folder Version 
on the Attachments tab of the pending revision so that it refers to a 
specific Folder Version.

For example, if the pending revision of the item refers to Folder Version LATEST-7 
of the file folder, select that row on the Attachments tab, click the Edit button and 
use the Folder Version drop-down list to select 7. Click Save to complete the edit 
process. You will now be able to create redline markups for that attachment. On 
the Affected Items tab, click the Do Redlining icon for that item to open the 
Redlines page.

2. On the Affected Items tab, click the Do Redlining icon (or Has been redlined icon) 
next to the item to open the Redlines page.

3. On the Redline Attachments tab, click the Do Redlining icon (or Has been redlined 
icon) on the row of the file you want to redline. (This icon is available only when 
markups are allowed.)

4. Use the tools described in the Online Help to redline the attachment. To view the 
Online Help, choose Help > Content in the menu bar.

Note: ECO markups are saved against and associated with the 
pending revision of the item. If the ECO is released without first 
replacing the file, the markups appear against the released revision of 
the item.

To ad hoc mark up or redline an attachment file from a File Folder object in the Web 
Client:

1. On the Files tab of a file folder object, click the Do Redlining icon (or Has been 
redlined icon) on the row of the file you want to redline. (This icon appears 
available only when markups are allowed.)
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2. Use the tools described in the viewer Online Help to redline the attachment. To 
view the Online Help, choose Help > Content in the menu bar.

Note: Ad hoc markups are saved against and associated with the 
version of the file folder object.

Web Client ECO Markups for Agile PLM 9.3.x

Note: If the item has already been redlined, then the Has been 
redlined icon is displayed for that item row in the Affected Items 
table. An icon appears on the Redline Attachments tab to indicate that 
the attachment in that row has been redlined. To initiate redlining, 
select the attachment row you want to redline and click the Redline 
button.

To mark up or redline an attachment file from an ECO in the Web Client:

1. If you have not already done so, add an item with an attachment to the Affected 
Items tab of an unreleased ECO. The item now has a pending revision associated 
with the unreleased ECO.

Note: When redlining an attachment through an ECO, the pending 
revision attachment Folder Version must be set to a specific version 
number; if the Folder Version is set to LATEST-x, you will not be able 
to create redline markups. However, you can edit the Folder Version 
on the Attachments tab of the pending revision so that it refers to a 
specific Folder Version.

For example, if the pending revision of the item refers to Folder Version LATEST-7 of 
the file folder, select that row on the Attachments tab, double-click the Versions field to 
edit it and then select 7. Click Save to complete the edit process. You can now create 
redline markups for that attachment. On the Affected Items tab, in the redline 
Attachment tab, select the row and click the Redline button.

1. On the Affected Items tab, select the row of the Item you want to redline. The 
redline tabs for the selected item appear in the lower section of the Affected Items 
tab.

2. On the Redline Attachments tab, select one or more rows and click the Redline 
button (this button is only active when markups are allowed).

3. Use the tools described in the viewer Online Help to redline the attachment. To 
view the Online Help, choose Help > Content in the menu bar.

Note: ECO markups are saved against and associated with the 
pending revision of the item. If the ECO is released without first 
replacing the file, the markups appear against the released revision of 
the item.

To ad hoc mark up or redline an attachment file from a File Folder object in the 
Web Client:
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4. On the Files tab of a file folder object, select one or more rows and click the 
Redline button (this button is only active when markups are allowed).

5. Use the tools described in the viewer Online Help to redline the attachment. To 
view the Online Help, choose Help > Content in the menu bar.

Note: Ad hoc markups are saved against and associated with the 
version of the file folder object.

Java Client ECO Markups
To mark up or redline an attachment file from an ECO in the Java Client:

1. Add an item with an attachment to the Affected Items tab of an unreleased ECO. 
The item now has a pending revision associated with the unreleased ECO.

Note: When redlining an attachment through an ECO, the pending 
revision attachment Folder Version must be set to a specific version 
number; if the Folder Version is set to LATEST-x, you will not be able 
to create redline markups. However, you can edit the Folder Version 
on the Attachments tab of the pending revision so that it refers to a 
specific Folder Version.

For example, if the pending revision of the item refers to Folder Version LATEST-7 
of the file folder, select that row on the Attachments tab, click the Edit  button and 
use the Folder Version drop-down list in the Edit dialog box to select 7. Click OK 
to complete the edit process. You will now be able to create redline markups for 
that attachment. Select the added item on the Affected Items tab of the ECO.

2. On the Redline Attachments tab, select the row containing the file you want to 
redline and click the Do Redlining icon in that row.

3. When AutoVue for Agile opens, click the Markup button. (This button is available 
only when markups are allowed.)

4. Use the tools described in the viewer Online Help to redline the attachment. To 
view Online Help, choose Help > Contents in the AutoVue for Agile menu bar.

Note: ECO markups are saved against and associated with the 
pending revision of the item. If the ECO is released without first 
replacing the file, the markups appear against the released revision of 
the item.

To ad hoc mark up or redline an attachment file from a file folder object in the Java 
Client:

1. Double-click the row containing the file you want to redline.

2. When AutoVue for agile opens, click the Markup button. (This button is available 
only when markups are allowed.)

3. Use the tools described in the viewer Online Help to redline the attachment. To 
view the Online Help, choose Help > Contents in the AutoVue for Agile menu bar.



Note: Ad hoc markups are saved against and associated with the 
version of the file folder object.
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Redlining Markups for Change Orders
The change order redlines of 2D, 3D, and EDA files are based on the pending revision 
of the item. The markup changes are visible from either the change order's Redline 
Attachments tab or from the pending revision item Attachments tab.

Important: AutoVue for Agile 3D features and access to 3D files are 
available only with AutoVue applications that support 3D files. 
AutoVue for Agile features for schematic and PCB files, also referred 
to as EDA files, are available only with AutoVue applications that 
support those files. For more information about purchasing or 
installing AutoVue, contact Oracle Consulting - Agile Practice.

Viewing ECO Redlines from the Attachments Tab of the Item Pending Revision
You can view the change order markup redlines of the pending revision by displaying 
the Attachments tab of the item pending revision, for example, revision (C) 
ECO000453. The redlined file is indicated by the icon (Web Client) or the Has been 
redlined icon (Java Client).

■ In Web Client, click the Has been redlined (for versions 9.2.2.x and 9.2.1.x, for 
version 9.3.x) icon in the row of the file you want to view.

■ In Java Client, select the redlined file you want to view and click the Has been 
redlined icon.

If you have checked out the redlined file and checked in a new version from the 
Attachments tab, the Has been redlined icon does not appear on the Attachments 
table.

To view the redlines of previous versions in Web Client:

1. 9.2.2.x/9.2.1.x: On the Attachments tab of the pending revision, click the Show 
Versions icon in the row you want to view. The Versions dialog appears.

9.3.x: Select View Versions from the Actions menu.

2. On the version row for which you want to view redlines, click the Has been 
redlined (for versions 9.2.2.x and 9.2.1.x, for version 9.3.x) icon.

Note: If you need to determine which file folder version is associated 
with the change order redlines, refer to the change order History tab.

To view the redlines of previous versions in Java Client:

1. On the Attachments tab of the pending revision, select the row you want to view.

2. Click the Show Versions button. The Versions dialog appears.

3. On the version row for which you want to view redlines, doubleclick the Has been 
redlined button.

However, if you do not replace the attachment file on the pending revision item prior 
to the change order release, you can access the redlines only from the released revision 



Opening Agile Attachment Files in AutoVue for Agile

Agile-specific Features and Functions 4-15

of the item. The following diagram shows an example of the change order attachment 
redlining process.

See also Product Collaboration User Guide and Getting Started with Agile PLM User Guide.

 An example of the change order attachment redlining process.

***********************************************************************************************

Marking Up Documents
For information about working with markups, including markup layers and markup 
objects, refer to the viewer Online Help. Choose Help > Contents in the AutoVue for 
Agile menu bar.
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Tips for Marking Up Documents
If you exit the AutoVue for Agile without saving, you will lose any redlines you have 
added to the attachment.

Attaching Information to Markup Files: In Markup mode, the Markup > Properties 
command displays the Markup Information dialog box with five information fields 
attached to the current active markup file.

Markup Rotate: Markup Rotate allows you to rotate symbol markup objects.

To rotate a symbol markup object:

1. Select the symbol markup object you want.

2. Choose Markup > Object > Rotate.

3. Place the cursor on one of the corner squares that indicate the selected object.

4. When you see the crossed-arrows cursor (pointing in four directions), hold down 
the left mouse button and adjust the rotation angle of the object.

5. Release the mouse button when you are finished with adjusting the rotation angle.

Markup Promotion
Markup promotion is the ability to bring forward, or promote:

■ Change markup promotion between versions within the same pending revision of 
the change order.

■ Ad-Hoc markups from older file folder versions to the newer versions.

This allows you to re-validate older markups against a new design.

Markup Promotion for Change-Based Markups
To promote change-based markups in Web Client:

1. Open the change order and display the Affected Items tab.

2. On the Affected Items tab, select the row of the item you want to redline. The 
redline tabs for the selected item appear in the lower section of the Affected Items 
tab.

3. On the redline Attachments tab, select one or more rows and click the Redline 
button. (This button is active only when markups are allowed).

4. When AutoVue for Agile opens, create a new markup. In the AutoVue for Agile 
Markup menu, choose the New command.

5. In the AutoVue for Agile Markup menu, choose the Open command. The Markup 
Files dialog appears

1. Click the All Revisions checkmark. AutoVue for Agile displays all valid markups. 
The available markups are associated to files that have the same file extension as 
the file you are viewing.

2. Select the markup files you want to promote to the current markup.

3. Click OK. The promoted markups display in the file you are currently viewing.

4. To save the promoted markups with the change order revision, save the markups 
before exiting the viewer. In the AutoVue for Agile Markup menu, choose one of 
the Save commands.

To promote change-based markups in Java Client:
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1. Open the change order and display the Affected Items tab.

2. On the Redline Attachments tab:

■ In the row containing the file you want to redline, click the Do Redlining icon.

3. When AutoVue for Agile opens, create a new markup. In the AutoVue for Agile 
Markup menu, choose the New command.

4. In the AutoVue for Agile Markup menu, choose the Open command. The Markup 
Files dialog appears.

5. Click the All Revisions checkmark. AutoVue for Agile displays all valid markups. 
The available markups are associated to files that have the same file extension as 
the file you are viewing.

6. Select the markup files you want to promote to the current markup.

7. Click OK. The promoted markups display in the file you are currently viewing.

8. To save the promoted markups with the change order revision, save the markups 
before exiting the viewer. In the AutoVue for Agile Markup menu, choose one of 
the Save commands.

Markup Promotion for Ad-Hoc Markups
To promote file folder ad hoc mark ups in Web Client:

1. Open the file folder object and display the Files tab.

2. To initiate redlining, select the Files table row you want to redline and click the 
Redline button.

3. When AutoVue for Agile opens, create a new markup. In the viewer Markup 
menu, choose the New command.

4. In the AutoVue for Agile Markup menu, choose the Open command. The Markup 
Files dialog appears.

5. Click the All Revisions checkmark. AutoVue for Agile displays all valid markups. 
The available markups are associated to files that have the same file extension as 
the file you are viewing.

6. Select the markup files you want to promote to the current markup.

7. Click OK. The promoted markups display in the file you are currently viewing.

8. To save the promoted markups with the current file folder version, save the 
markups before exiting the viewer. In the AutoVue for Agile Markup menu, 
choose one of the Save commands.

To promote file folder ad hoc mark ups in Java Client:

1. Open the file folder object and display the Files tab.

2. Click the Do Redlining button (or Has been redlined button ) on the row of the file 
you want to redline. (This button is available only when markups are allowed.)

3. When AutoVue for Agile opens, create a new markup. In the viewer Markup 
menu, choose the New command.

4. In the AutoVue for Agile Markup menu, choose the Open command. The Markup 
Files dialog appears.

5. Click the All Revisions checkmark. AutoVue for Agile displays all valid markups. 
The available markups are associated to files that have the same file extension as 
the file you are viewing.
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6. Select the markup files you want to promote to the current markup.

7. Click OK. The promoted markups are displayed in the file you are currently 
viewing.

8. To save the promoted markups with the current file folder version, save the 
markups before exiting the viewer. In the AutoVue for Agile Markup menu, 
choose one of the Save commands.

Augmented Business Visualization
Augmented Business Visualization (ABV) is a solution that integrates the visual 
representation of models and drawings in AutoVue with the data and processes from 
Agile 9. AutoVue's ABV techniques enable creation of change objects in Agile from 
AutoVue.

You can create ABV solutions by integrating your application with AutoVue's hotspot 
framework. Hotspots activate a portion of 2D or 3D drawing, either by changing the 
text color, or triggering an action.

Example: When you click on a part in 3D or 2D model in AutoVue, the below 
mentioned options appear to help you create a change (provided you have the 
privileges).Create ECRCreate ECO

When you select and click an option, it directly takes you to the cover page of an ECR. 
The change object is automatically created in Agile and the selected Part added as 
Affected Item on the Change object.

Note: The sample Process Extension provided as a download on 
OTN assumes that CAD connector is used and configured such that 
the CAD system filename is the same as the Agile Part Number and 
Design name.

Hotspot:  AutoVue provides a mechanism to turn all 3D parts that contain a specific 
attribute into a hotspot. Based on the hotspot configuration, when you right click the 
hotspot, additional options automatically appear on the right-mouse button menu.

■ When you start the AutoVue client, the Create ECO/ECR options are visible in 
AutoVue.

■ When you select the Create ECO/ECR option, Change objects associated with the 
relevant attributes appear. If not, an error message appears.

■ You are directed to the cover page of the Change object in Agile. The system 
returns only Change objects for which you have privileges.

Note: If you are using custom GUI files, ensure VueActionHotspots 
is included in all the GUI files.

2D Features and Functions
For information about working with 2D files, including CAD views and measuring 
objects, refer to the AutoVue for Agile Online Help. Choose Help > Contents in the 
AutoVue for Agile menu bar.

EDA Features and Functions
AutoVue applications that include EDA features, include:
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■ Ability to view all relevant EDA formats including artwork formats, PCB/IC 
layouts, schematics and manufacturing formats

■ Cross probe between a PCB layout and related schematics (see "Cross Probing" on 
page 4-22.).

■ Verify design by testing for manufacturability or design violation.

■ Generate and export Bills of Material in a variety of formats.

For detailed information about all the EDA features, refer to the viewer Online Help. 
Choose Help > Contents in the AutoVue for Agile menu bar.

3D Features and Functions
For information about working with 3D files, including light settings and models, refer 
to the viewer Online Help. Choose Help > Contents in the AutoVue for Agile menu 
bar.

Note: The Agile administrator must specify the 3D file extension in 
the Files Types list in Agile Administrator Viewer & Files node in 
order for you to view the 3D files.

AutoVue 3D features include:

■ 3D compare

■ Digital Mockup

■ Measurement

■ Interference checking

■ Cross-sectioning

Important: 3D features and access to 3D files are available only with 
AutoVue applications that support 3D files. Features for schematic 
and PCB files, also referred to as EDA files, are available only with 
AutoVue applications that support EDA files. For more information 
about purchasing or installing AutoVue applications, contact Oracle 
Consulting - Agile Practice.

For details about how Agile PLM views 3D CAD assemblies, see:

■ "Viewing Document Structured File Types" on page 4-6.

■ "Viewing Design Object Structures" on page 4-6.

Understanding 3D Basics
3D CAD assemblies are made up of many files dependent one upon another. For 
example, a SolidWorks or Pro/E CAD design consists of at least one assembly file and 
one or more part files. The 3D files are used primarily in manufacturing departments 
for drawing the blueprint of the new instrument. 3D files may be added to the Files tab 
in one or several file folder objects.

■ One File Folder
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All files in one CAD assembly are added to the Files tab of one file folder. When you 
view the assembly, Agile prompts you to identify the top file in the assembly and the 
complete assembly is displayed in AutoVue for Agile.

■ One Design

Assembly Files are added to the Files tab and parts files can be referenced from the 
Design added to the Structure tab.

■ Multiple File Folders

The assembly file is added to the Files tab in one file folder object, and parts files can 
be referenced by adding other file folder objects containing the files as relationships 
with no rules to the Relationships tab of the assembly's file folder object.

3D files can be redlined both through a change order (Redline Attachments) and on 
the Files tab of the file folder object.

Viewing 3D CAD Assemblies in a Multiple-file File Folder from the 9.2.2.x or 9.2.1.x 
Web Client
To view a CAD assembly from Web Client, Attachments tab:

1. Go to the Attachment tab of the business object that references the assembly.

2. Double-click the multiple-file attachment row that references the CAD assembly. 
The Select Files window appears.

Note: A multiple-file attachment row is indicated by a file folder 
icon in the Filename field, followed by the filenames of all the files in 
the file folder.

Or use the Attachment tab View File(s) button:

■ On the business object Attachments tab, click to select the multiple-file 
attachment row.

■ Click the View File(s) button's drop-down arrow and select View from the 
menu.

3. In the Select Files window, click the radio button to select the option View all files 
as an assembly, starting from the selected file.

4. Click to select the file row of the assembly file that indicates the top or starting file 
of the assembly.

5. Click Finish.

To view a CAD assembly from Web Client, Files tab:

1. Go to the Files tab of a file folder object containing the CAD files for the assembly 
that you want to view.

2. Click to select the row for the top or starting file of the assembly.

3. Click the View File(s) button's drop-down arrow and select View As Assembly 
from the menu.

Viewing 3D CAD Assemblies in a Multiple-file File Folder from the 9.3.x Web Client
To view a CAD assembly from Web Client, Attachments tab:

1. Go to the Attachment tab of the business object that references the assembly.
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2. Click the multiple-file attachment row that references the CAD assembly.

Note: A multiple-file attachment row is indicated by a file folder 
icon in the Filename field, followed by the filenames of all the files in 
the file folder.

Use the Attachment tab View button:

■ On the business object Attachments tab, click to select the multiple-file 
attachment row.

■ Click the View button's drop-down arrow and select View from the menu.

To view a CAD assembly from Web Client, Files tab:

1. Go to the Files tab of a file folder object containing the CAD files for the assembly 
that you want to view.

2. Click to select the row for the top or starting file of the assembly.

3. Click the View button's drop-down arrow and select View menu.

Viewing 3D CAD Assemblies in a Multiple-file File Folder from Java Client
To view a CAD assembly from Java Client, Attachments tab:

1. Go to the Attachment tab of the business object that references the assembly.

2. Double-click the multiple-file attachment row that references the CAD assembly. 
The Select Files window appears.

Note: A multiple-file attachment row is indicated by a file folder 
icon in the Filename field, followed by the filenames of all the files in 
the file folder.

Or use the Attachment tab View File(s) button:

a. On the business object Attachments tab, click to select the multiple-file 
attachment row.

b. Click the View File(s) button's drop-down arrow and select View from the 
menu.

3. In the Select Files window, click the radio button to select the option View all files 
as an assembly, starting from the selected file.

4. Click to select the file row of the assembly file that indicates the top or starting file 
of the assembly.

5. Click OK.

To view a CAD assembly from Java Client, Files tab:

1. Go to the Files tab of a file folder object containing the CAD files for the assembly 
that you want to view.

2. Click to select the row for the top or starting file of the assembly.

3. Click the View File(s) button's drop-down arrow and select View.
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Cross Probing
In Agile, cross probing feature is initiated from either the business object Attachments 
tab or the file folder Files tab rather than from the viewer menus. See the viewer 
Online Help for more information about cross probing. Choose Help > Contents in the 
AutoVue for Agile menu bar.

Important: Cross probing features are available only with AutoVue 
applications that support this feature. For more information about 
purchasing or installing AutoVue applications, contact Oracle 
Consulting - Agile Practice.

Use cross probing to interrogate ECAD schematic and layout files in separate viewer 
windows.

Note: The Agile administrator must specify the ECAD file extension 
in the Files Types list in Agile Administrator Viewer & Files node in 
order for you to view the ECAD files.

You can select both needed files from the same Attachments tab or the same file folder 
Files tab from which you launch the Cross Probe action. Or, you can select one file on 
the current tab and then search for the remaining file from the attachments of any 
other object.

The View > By Search > Cross probe option allows you to find other files in the 
system, which you may want to use to cross probe, without having to select two files 
from the same Attachments tab or Files tab; that is, you can search and select one 
attached file from Part 234 and another attached file from Part 765.

Alternatively, you can view a single ECAD file and then initiate cross probing within 
the viewer by adding another file from your desktop.

Note:  AutoVue supports and enables correct view of ECAD files.

For Example: When an .emp or .emn file is selected for view or 
markup treat the file sent to the viewer applet is the same as MCAD 
files such as .asm and .prt files. 

Initiate Cross Probing in AutoVue for Agile
To initiate cross probing in the AutoVue for Agile, you must first select and view an 
appropriate file type that can be used for cross probing analysis.

To view an appropriate file for cross probing:

1. Display the Attachments tab or the Files tab.

2. Select a file row you want to work with and choose:

■ Web Client: View > View

■ Java Client: View Files(s)

AutoVue for Agile opens and displays the selected file.

3. In the AutoVue for Agile Analysis menu, choose Cross Probe. The AutoVue for 
Agile File Open dialog appears.
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4. Use one of the following File Open dialog methods to select a file for cross 
probing:

■ Browse to browse your local directories to select and open files from the 
AutoVue for Agile window.

■ Agile Browse to use Agile bookmarks to open files from the AutoVue for Agile 
window.

■ Agile Search to perform an Agile Quick Search to select and open files from 
the AutoVue for Agile window.

Browse your local directories to select an attachment file:

1. Click the Browse button in the File Open dialog to display File Open dialog.

2. Use the Look in drop-down list to select the directory you want.

3. Select the file you want and click Open.

4. Click OK in the File Open dialog.

The Viewer opens the selected file, or, if appropriate, adds the selected file to the 
current analysis function.

If a markup is saved when Digital Mockup is active, the contents of the Digital 
Mockup, including all objects and their orientations, are saved.

Agile Browse to use your Agile Bookmarks to select an attachment file:

1. Click the Agile Browse button in the File Open dialog to display the DMS: File 
Open dialog.

The DMS: File Open dialog displays your Agile Bookmarks in a tree structure.

Note: If you have not defined any Bookmarks in Agile PLM, the 
Agile Browse button does not appear in the File Open dialog.

2. Click + to expand a bookmark and display its item revisions or its file folder 
versions.

3. Click a revision or version row to highlight the file you want to view.

4. Click OK in the DMS: File Open dialog. The selected file name appears in the File 
Name field of the File Open dialog.

5. Click OK in the File Open dialog.

The Viewer opens the selected file, or, if appropriate, adds the selected file to the 
current analysis function.

Agile Search to perform a quick search to select an attachment file:

1. Click the Agile Search button in the File Open dialog to display a Search dialog 
which allows you to run a quick search.

2. Define your search and click the Search button:

■ Class - Select an object class, for example, Items.

■ Search Parameter - Enter a text string or a number.

Agile PLM searches the object ID number attribute and the object Name or 
Description attribute. A Quick search behaves like a Contains search for text 
strings. The search criteria is treated as a single string and Agile PLM searches 
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for names or descriptions that contain the search parameter string. In the case 
of ID numbers, Agile PLM searches for an exact match, however, you may use 
wildcard characters to specify part of an ID number as a search criteria.

■ Search Attachment Content - Set this parameter to Yes to search the contents of 
the attachment files as well.

3. In the Search Results table, click the + next to the object number to expand the list 
of attachment files for that object.

4. Click a revision row or a version row to select the file you want to view.

5. Click the Load File button. The selected file name appears in the File Name field of 
the File Open dialog.

6. Click OK in the File Open dialog. 

The Viewer opens the selected file, or, if appropriate, adds the selected file to the 
current analysis function.

Cross Probing in Web Client and Java Client
To run cross probing:

1. Display the Attachments tab or the Files tab.

2. Select both file rows you want to work with and choose:

■ 9.2.2.x or 9.2.1.x Web Client: View > Cross Probe.

■ 9.3.x Web Client: View. The file opens in AutoVue for Agile, then choose 
Analysis > Cross Probe.

■ Java Client: View File(s) > Cross Probe.

Each file is displayed in a separate viewer window.

3. Begin cross probing.

See the viewer Online Help for more information about cross probing.

To run cross probing by search:

4. Display the Attachments tab or the Files tab.

5. Select a file row you want to work with and choose:

■ 9.2.2.x or 9.2.1.x Web Client only: View > By Search > Cross Probe.

The Select Files dialog appears, with three Search tabs.

■ Java Client: View File(s) > By Search > Cross Probe.

6. The search dialog allows you to search for any business object (for example, items 
or manufacturer parts) and select the attachments of those objects to use to Cross 
Probe.

Use any of the following search methods:

■ Search tab lets you create a simple search or an advanced search. You can 
check to search attachment contents, too.

■ Saved Searches tab opens to your navigation pane where you can browse in 
search folders, select a search, and run it. Again, returned results may be 
moved to the Selected Items table, and click OK.
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■ Shortcuts tab opens to your navigation pane where you can select objects from 
My Bookmarks or Recently Visited. The system displays shortcuts to only 
those objects that are appropriate to the operation you are performing.

Only business objects with attached files appear in the search results table. For 
example, a business object that you viewed recently will not appear on the 
Recently Visited list of the Shortcuts tab if it has no attachments.

7. When the results of your search are returned, select a row in the Results table, and 
the related files for that object appear in the Related Files table.

8. In the Related Files table, select and move attachments to the Selected Files table.

9. You can continue to run multiple searches or shortcuts until you are finished 
selecting the attachments you want.

10. When you are finished, click OK. Each file is displayed in a separate viewer 
window.

11. Begin cross probing.

See the Online Help for more information about cross probing. Choose Help > 
Contents in the AutoVue for Agile menu bar.

Comparing Files
Comparing files is also described in the AutoVue for Agile Online Help. In Agile, 
rather than initiating file compare from the viewer menus, you initiate file compare 
from either the Files tab of File Folders or the Attachments tab of business objects .

For detailed information about file comparison features, see the AutoVue for Agile 
Online Help. Choose Help > Contents in the AutoVue for Agile Menu bar.

Markups and Comparing Files
Markups (redlines) are not supported in the AutoVue for Agile compare mode.

Comparing Files in Web Client and Java Client
You can select and compare two files from a single file folder Files tab or a single 
business object Attachments tab.

To initiate comparing files:

1. Display the Attachments tab or the Files tab.

2. Select both files you want to work with and choose:

■ Web Client: View > Compare

■ Java Client: View File(s) > Compare

The files and the comparison results display in a single viewer window.

For more information about compare file features and options, choose Help > Contents 
from the viewer menu bar.

Comparing Files by Search
The Compare Files by Search feature allows you to:

■ Compare files from different released revisions of an item.
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■ Compare files from different file folder versions.

■ Select any file on any business object Attachments tab or on any file folder Files 
tab, and then search for a file to use for comparison.

Depending on your search, you can select a business object, and then select a file from 
the list of related files for that object. Or, if you have the appropriate privileges, you 
can search for file folder objects, and then select a file from the list of related files for 
the selected file folder.

Note: For item objects, introductory revisions and unreleased 
pending revisions do not appear in the related files list.

To initiate comparing files by search:

1. Display the Attachments tab or Files tab.

2. Select a file row you want to work with and choose:

■ 9.2.1.x or 9.2.2.x Web Client: View > By Search > Compare

■ 9.3.x Web Client: View > Compare By Search (A search dialog allows you to 
search for the object.)

■ Java Client: View File(s) > By Search > Compare

The Compare Files By Search dialog appears with three search tabs.

3. The search dialog allows you to search for any business object (for example items 
or manufacturer parts) and select the attachments of those objects to compare.

Use any of the following search methods:

■ Search tab lets you create a simple search or an advanced search. You can 
check to search attachment contents, too.

■ Saved Searches tab opens to your navigation pane where you can browse in 
search folders, select a search, and run it. Again, returned results may be 
moved to the Selected Items table, and click OK.

■ Shortcuts tab opens to your navigation pane where you can select objects from 
My Bookmarks or Recently Visited. The system displays shortcuts to only 
those objects that are appropriate to the operation you are performing.

Only business objects with attached files appear in the search results table. For 
example, a business object that you viewed recently will not appear on the 
Recently Visited list of the Shortcuts tab if it has no attachments.

4. When the results of your search are returned, select a row in the results table, and 
the related files for that object appear in the Related Files table.

5. In the Related Files table, select the file you want.

■  If the selected search object is a file folder, use the Version drop-down list in 
the Related Files table to select the file folder version you want.

■ If the selected search object is an item, in the Related Files table displays item 
attachments for each released revision of the item (the file name followed by 
the revision number or letter, for example, widget.dwg - A and widget.dwg - 
B).
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■ If the selected search object is a business object, check the Show Matching File 
Types Only checkbox to display only the related files that are the same file 
type as the file with which you want to compare.

6. When you are finished, click OK.

You can continue to run multiple searches or shortcuts until you are finished 
selecting the attachments you want.

The files and the comparison results appear in a single viewer window. For more 
information about compare file features and options, choose Help > Contents in 
the AutoVue for Agile menu bar.

Initiate Compare in AutoVue for Agile
To initiate comparing files in AutoVue for Agile, you must first select and view an 
appropriate file, that is, a file type that can be used for compare analysis.

1. View an appropriate file for compare:

2. Display the Attachments tab or the Files tab.

3. Select a file row you want to work with and choose:

■  Web Client: View > View

■ Java Client: View Files(s)

AutoVue for Agile opens and displays the selected file.

4. In the AutoVue for Agile Analysis menu, choose Compare. The AutoVue for Agile 
File Open dialog appears.

5. Use one of the following File Open dialog methods to select a file to compare:

■ Browse to browse your local directories to select and open files from the 
AutoVue for Agile window.

■ Agile Browse to use Agile bookmarks to open files from the AutoVue for Agile 
window.

■ Agile Search to perform an Agile Quick Search to select and open files from 
the AutoVue for Agile window.

Browse your local directories to select an attachment file:

1. Click the Browse button in the File Open dialog to display File Open dialog.

2. Use the Look in drop-down list to select the directory you want.

3. Select the file you want and click Open.

4. Click OK in the File Open dialog.

The Viewer opens the selected file, or, if appropriate, adds the selected file to the 
current analysis function.

If a markup is saved when Digital Mockup is active, the contents of the Digital 
Mockup, including all objects and their orientations are saved.

Agile Browse to use your Agile Bookmarks to select an attachment file:
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1. Click the Agile Browse button in the File Open dialog to display the DMS: File 
Open dialog.

The DMS: File Open dialog displays your Agile Bookmarks in a tree structure.

Note: If you have not defined any Bookmarks in Agile PLM, the 
Agile Browse button does not appear in the File Open dialog.

2. Click + to expand a bookmark and display its item revisions or its file folder 
versions.

3. Click a revision or version row to highlight the file you want to view.

4. Click OK in the DMS: File Open dialog. The selected file name appears in the File 
Name field of the File Open dialog.

5. Click OK in the File Open dialog. 

The Viewer opens the selected file, or, if appropriate, adds the selected file to the 
current analysis function.

Agile Search to perform a quick search to select an attachment file:

1. Click the Agile Search button in the File Open dialog to display a Search dialog 
which allows you to run a quick search.

2. Define your search and click the Search button:

■ Class - Select an object class, for example, Items.

■ Search Parameter - Enter a text string or a number.

Agile PLM searches the object ID number attribute and the object Name or 
Description attribute. A Quick search behaves like a Contains search for text 
strings. The search criteria is treated as a single string and Agile PLM searches 
for names or descriptions that contain the search parameter string. In the case 
of ID numbers, Agile PLM searches for an exact match, however, you may use 
wildcard characters to specify part of an ID number as a search criteria.

■ Search Attachment Content - Set this parameter to Yes to search the contents of 
the attachment files as well.

3. In the Search Results table, click the + next to the object number to expand the list 
of attachment files for that object.

4. Click a revision row or a version row to select the file you want to view.

5. Click the Load File button. The selected file name appears in the File Name field of 
the File Open dialog.

6. Click OK in the File Open dialog.

The Viewer opens the selected file, or, if appropriate, adds the selected file to the 
current analysis function.

Overlaying Files
Overlaying files is also described in the viewer Online Help. In Agile, this feature is 
initiated from the file folder Files tab rather than from the viewer menus. For detailed 
information about file overlay features, see the viewer Online Help. Choose Help > 
Contents in the AutoVue for Agile menu bar.
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applications that support this feature. For more information about 
purchasing or installing AutoVue applications, contact Oracle 
Consulting - Agile Practice.
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Overlaying Files in Web Client and Java Client
To initiate overlaying files:

1. Display the Attachments tab or the Files tab.

2. Select both file rows you want to work with and choose

■ Web Client: View > Overlay.

■ Java Client: View File(s) > Overlay.

The files are displayed in a single viewer window, one on top of the other. For more 
information about overlay file features (for example, File > Import File as Overlay in 
the menu bar) and options, choose Help > Contents in the viewer menu bar.

To initiate overlaying files By Search in Java Client:

1. Display the Attachments tab or the Files tab.

2. Select a file row you want to work with and choose:

■ 9.2.2.x or 9.2.1.x Web Client: View > By Search > Overlay.

The View Files by Search dialog appears, with three Search tabs.

■ 9.3.x Web Client: View. The file opens in AutoVue for Agile, then choose File > 
Import File as Overlay.

■ Java Client: View File(s) > By Search > Overlay.

The Select Files dialog appears, with three Search tabs.

3. The search dialog allows you to search for any business object (for example, items 
or manufacturer parts) and select the attachments of those objects to use to 
overlay.

Use any of the following search methods:

■  Search tab lets you create a simple search or an advanced search. You can 
check to search attachment contents, too.

■ Saved Searches tab opens to your navigation pane where you can browse in 
search folders, select a search, and run it. Again, returned results may be 
moved to the Selected Items table, and click OK.

■ Shortcuts tab opens to your navigation pane where you can select objects from 
My Bookmarks or Recently Visited. The system displays shortcuts to only 
those objects that are appropriate to the operation you are performing.

Only business objects with attached files appear in the search results table. For 
example, a business object that you viewed recently will not appear on the 
Recently Visited list of the Shortcuts tab if it has no attachments.

4. When the results of your search are returned, select a row in the Results table, and 
the related files for that object appear in the Related Files table.

5. In the Related Files table, select and move attachments to the Selected Files table.
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6. You can continue to run multiple searches or shortcuts until you are finished 
selecting the attachments you want.

7. When you are finished, click OK.

The files are displayed in a single viewer window, one on top of the other. For 
more information about overlay file features (for example, File > Import File as 
Overlay in the menu bar) and options, choose Help > Contents in the viewer menu 
bar.

Initiate Overlay in AutoVue for Agile
To initiate overlaying files in the AutoVue for Agile, you must first select and view an 
appropriate file, that is, a file type that can be used for overlay analysis.

1. View an appropriate file for overlay analysis:

2. Display the Attachments tab or the Files tab.

3. Select a file row you want to work with and choose:

■ Web Client: View > View

■ Java Client: View Files(s)

AutoVue for Agile opens and displays the selected file.

4. In the AutoVue for Agile File menu, choose Import File as Overlay. The AutoVue 
for Agile File Open dialog appears.

5. Use one of the following File Open dialog methods to select a file to overlay:

■ Browse to browse your local directories to select and open files from the 
AutoVue for Agile window.

■ Agile Browse to use Agile bookmarks to open files from the AutoVue for Agile 
window.

■ Agile Search to perform an Agile Quick Search to select and open files from 
the AutoVue for Agile window.

Browse your local directories to select an attachment file:

1. Click the Browse button in the File Open dialog to display File Open dialog.

2. Use the Look in drop-down list to select the directory you want.

3. Select the file you want and click Open.

4. Click OK in the File Open dialog.

The Viewer opens the selected file, or, if appropriate, adds the selected file to the 
current analysis function.

If a markup is saved when Digital Mockup is active, the contents of the Digital 
Mockup, including all objects and their orientations, will be saved.

Agile Browse to use your Agile Bookmarks to select an attachment file:

5. Click the Agile Browse button in the File Open dialog to display the DMS: File 
Open dialog.

The DMS: File Open dialog displays your Agile Bookmarks in a tree structure.

Note: If you have not defined any Bookmarks in Agile PLM, the 
Agile Browse button does not appear in the File Open dialog.
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6. Click + to expand a bookmark and display its item revisions or its file folder 
versions.

7. Click a revision or version row to highlight the file you want to view.

8. Click OK in the DMS: File Open dialog. The selected file name appears in the File 
Name field of the File Open dialog.

9. Click OK in the File Open dialog.

The Viewer opens the selected file, or, if appropriate, adds the selected file to the 
current analysis function.

Agile Search to perform a quick search to select an attachment file:

1. Click the Agile Search button in the File Open dialog to display a Search dialog 
which allows you to run a quick search.

2. Define your search and click the Search button:

■ Class - Select an object class, for example, Items.

■ Search Parameter - Enter a text string or a number.

Agile PLM searches the object ID number attribute and the object Name or 
Description attribute. A Quick search behaves like a Contains search for text 
strings. The search criteria is treated as a single string and Agile PLM searches 
for names or descriptions that contain the search parameter string. In the case 
of ID numbers, Agile PLM searches for an exact match, however, you may use 
wildcard characters to specify part of an ID number as a search criteria.

■ Search Attachment Content - Set this parameter to Yes to search the contents of 
the attachment files as well.

3. In the Search Results table, click the + next to the object number to expand the list 
of attachment files for that object.

4. Click a revision row or a version row to select the file you want to view.

5. Click the Load File button. The selected file name appears in the File Name field of 
the File Open dialog.

6. Click OK in the File Open dialog.

The Viewer opens the selected file, or, if appropriate, adds the selected file to the 
current analysis function.

Working with Schematic and PCB Files
Important AutoVue for Agile features for schematic and PCB files, also referred to as 
EDA files, are available only with AutoVue applications that support those files. For 
more information about purchasing or installing AutoVue, contact Oracle Consulting - 
Agile Practice. For information about Agile PLM configuration settings for AutoVue 
for Agile, see the Agile PLM Administrator Guide.

For information about these features, refer to the viewer Online Help. Choose Help > 
Contents in the AutoVue for Agile menu bar.

Real-Time Collaboration
For detailed information about collaboration features, refer to the viewer Online Help. 
Choose Help > Contents in the AutoVue for Agile menu bar. The following sections 
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discuss AutoVue for Agile server information and Agile privileges that affect 
collaboration sessions.

Important: Real-time collaboration features are available only with 
AutoVue applications that support this feature. For more information 
about purchasing or installing AutoVue applications, contact Oracle 
Consulting - Agile Practice.

Overview of Collaboration Sessions
The Collaboration feature lets multiple users team up and review documents 
interactively and simultaneously, thus shortening an otherwise lengthy review process 
where documents are passed back and forth. The Collaboration feature is available to 
all users who have Agile Discovery, Read, and the appropriate privileges that allow 
you to redline attachment files (for example, the Agile default role Markup for 
Self).For ECO attachment redlining, you must also have a role that includes an 
appropriate Attachment Redlines privilege (Attachment Redlines for Others or 
Attachment Redlines for Self).

From the Collaboration menu, anyone with the required Agile privileges can initiate a 
Collaboration session and act as host, or join a Collaboration session if invited by the 
host.

Important: If you plan to host a Collaboration session, ensure that all 
intended participants have Discovery, Read, and the appropriate 
privileges that allow them to redline attachment files (for example, the 
Agile default role Markup for Self and, for ECO attachment redlining, 
a role that includes an appropriate Attachment Redlines for Self or 
Attachment Redlines for Others privilege). If they can view and 
redline a file, they have the necessary privileges. If they cannot, 
contact your Agile administrator, who can grant them the necessary 
privileges, before you attempt to initiate the Collaboration session.

In order to participate in the collaboration session, all the collaborators must be logged 
into Agile and viewing a file in the viewer when you start the collaboration session. 
They do not need to view the file you are going to review in the collaboration session; 
they can view any file. For this reason, they may choose to view a small file that will 
load quickly.

When the host initiates a Collaboration session, a session object is created on the 
server, which is maintained for the duration of the Collaboration session. Session 
information is available from the Collaboration menu during a Collaboration session. 
It displays the session subject (the name assigned to the Collaboration session), the 
session ID (each session subject is assigned a unique session ID), the name of the base 
file viewed, the host, and the list of users participating.

A session markup file is created during the Collaboration session to which all 
participants can add markup entities. Participants are assigned different layer colors 
for the session so that the markup entity from each participant is identifiable. The host 
for the session owns the markup file and is the only one who can save it.



Note: In order to use the collaboration feature, all users must connect 
to the same AutoVue for Agile server. All users must specify, in their 
user profile, Preferences tab, under System Preferences, the same 
Preferred File Manager setting. Remote users may have to change 
their preferred File Manager profile setting in a distributed File 
Manager environment.
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Digital Mockup
In 3D mode, you can use the Mockup feature (DMU) to test alignment and interference 
of multiple assemblies. You can save the mockup as a redline markup entity.

Initiate Mockup (DMU) in AutoVue for Agile
To initiate DMU analysis of files in AutoVue for Agile, you must first select and view 
an appropriate file, that is, a file type that can be used for DMU analysis.

View an appropriate file for DMU analysis:

1. Display the Attachments tab or the Files tab.

2. Select a file row you want to work with and choose:

■ Web Client: View > View

■ Java Client: View Files(s)

AutoVue for Agile opens and displays the selected file.

3. In the AutoVue for Agile File menu, choose Import File for Mockup. The AutoVue 
for Agile File Open dialog appears.

4. Use one of the following File Open dialog methods to select files for DMU 
analysis:

■ Browse to browse your local directories to select and open files from the 
AutoVue for Agile window.

■ Agile Browse to use Agile bookmarks to open files from the AutoVue for Agile 
window.

■ Agile Search to perform an Agile Quick Search to select and open files from 
the AutoVue for Agile search window.

Agile Browse to use your Agile Bookmarks to select an attachment file:

1. Click the Agile Browse button in the File Open dialog to display the DMS: File 
Open dialog.

The DMS: File Open dialog displays your Agile Bookmarks in a tree structure.

Note: If you have not defined any Bookmarks in Agile PLM, the 
Agile Browse button does not appear in the File Open dialog.

2. Click + to expand a bookmark and display its item revisions or its file folder 
versions.

3. Click a revision or version row to highlight the file you want to view.

4. Click OK in the DMS: File Open dialog. The selected file name appears in the File 
Name field of the File Open dialog.
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5. Click OK in the File Open dialog.

The Viewer opens the selected file, or, if appropriate, adds the selected file to the 
current analysis function.

Agile Search to perform a quick search to select an attachment file:

1. Click the Agile Search button in the File Open dialog to display a Search dialog 
which allows you to run a quick search.

2. Define your search and click the Search button:

■ Class - Select an object class, for example, Items.

■ Search Parameter - Enter a text string or a number.

Agile PLM searches the object ID number attribute and the object Name or 
Description attribute. A Quick search behaves like a Contains search for text 
strings. The search criteria is treated as a single string and Agile PLM searches 
for names or descriptions that contain the search parameter string. In the case 
of ID numbers, Agile PLM searches for an exact match, however, you may use 
wildcard characters to specify part of an ID number as a search criteria.

■ Search Attachment Content - Set this parameter to Yes to search the contents of 
the attachment files as well.

3. In the Search Results table, click the + next to the object number to expand the list 
of attachment files for that object.

4. Click a revision row or a version row to select the file you want to view.

5. Click the Load File button. The selected file name appears in the File Name field of 
the File Open dialog.

6. Click OK in the File Open dialog.

The Viewer opens the selected file, or, if appropriate, adds the selected file to the 
current analysis function.

Browse your local directories to select an attachment file:

1. Click the Browse button in the File Open dialog to display File Open dialog.

2. Use the Look in drop-down list to select the directory you want.

3. Select the file you want and click Open.

4. Click OK in the File Open dialog.

The Viewer opens the selected file, or, if appropriate, adds the selected file to the 
current analysis function.

If a markup is saved when Digital Mockup is active, the contents of the Digital 
Mockup, including all objects and their orientations, are saved.

Digital Mockup in Web Client and Java Client
To initiate Digital Mockup of files:

1. Display the Attachments tab or the Files tab.

2. Select all the file rows you want to work with and choose:

■ 9.2.2.x or 9.2.1.x Web Client: View > Digital Mockup.

■ 9.3.x Web Client: View > View. After AutoVue for Agile opens, chose File > 
Import file for Mockup.
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■ Java Client: View File(s) > Digital Mockup.

3. Manipulate the models using the viewer features including the features in the 
Analysis menu, for example User Defined Coordinate Systems, Manipulators, 
Interference Checking, and Part Alignment.

For information about these features, refer to the AutoVue for Agile Online Help. 
Choose Help > Contents in the AutoVue for Agile menu bar.

To initiate Digital Mockup of files By Search:

1. Display the Attachments tab or the Files tab.

2. Select a file row you want to work with and choose:

■ 9.2.2.x or 9.2.1.x Web Client: View > By Search > Digital Mockup.

The View Files by Search dialog appears, with three Search tabs.

■ 9.3.x Web Client: View > View. After AutoVue for Agile opens, choose File > 
Import file for Mockup.

■ Java Client: View File(s) > By Search > Digital Mockup.

The Select Files dialog appears, with three Search tabs.

The following steps apply to 9.2.2.x and 9.2.1.x Web Client and the Java Client 
only:

3. The search dialog allows you to search for any business object (for example, items 
or manufacturer parts) and select the attachments of those objects to use for the 
mockup.

Use any of the following search methods:

■ Search tab lets you create a simple search or an advanced search. You can 
check to search attachment contents, too.

■ Saved Searches tab opens to your navigation pane where you can browse in 
search folders, select a search, and run it. Again, returned results may be 
moved to the Selected Items table, and click OK.

■ Shortcuts tab opens to your navigation pane where you can select objects from 
My Bookmarks or Recently Visited. The system displays shortcuts to only 
those objects that are appropriate to the operation you are performing.

Only business objects with attached files appear in the search results table. For 
example, a business object that you viewed recently will not appear on the 
Recently Visited list of the Shortcuts tab if it has no attachments.

4. When the results of your search are returned, select a row in the Results table, and 
the related files for that object appear in the Related Files table.

5. In the Related Files table, select and move attachments to the Selected Files table.

6. You can continue to run multiple searches or shortcuts until you are finished 
selecting the attachments you want.

7. When you are finished, click OK. The files are loaded into the same AutoVue for 
Agile workspace.

8. Manipulate the models using the viewer features including the features in the 
Analysis menu, for example User Defined Coordinate Systems, Manipulators, 
Interference Checking, and Part Alignment.

For information about these features, refer to the viewer Online Help. Choose 
Help > Contents in the AutoVue for Agile menu bar.
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AutoVue Mobile
AutoVue Mobile is de-supported from Release 20.2.1
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5Modified and Unavailable AutoVue for Agile 
Features

As part of the integration, some features in the Viewer are modified or made 
unavailable, primarily to comply with Agile access control requirements.

User Interface Modifications
The following features described in the viewer Online Help have been modified or 
have been suppressed and are not available.

■ Window menu and its options for viewing multiple files (New, Cascade, Tile 
Horizontally, and Tile Vertically) are not available.

■ Tooltips Quick Menu is not available.

■ The ability to click and drag toolbars to move them is not available.

■ Mnemonic letter shortcuts (ALT+letter) are not available and are not displayed as 
underlined letters in menus.

■ The Customize > Options menu selection does not include toolbar and tooltip 
settings.

File Storage and Management Modifications
Since the Agile system manages and controls access to attached files and markups 
(redline files), the following features described in the viewer Online Help may have 
been modified or are not available to you.

Many of these modifications relate to how files are opened, saved, and where they are 
stored. Instead of using viewer features (for example, File > Open, as described in the 
viewer Online Help) to view files, the files are selected via the Agile object 
Attachments tab and the file folder Files tab, and retrieved from the file vault, part of 
Agile File Manager (AFM). The files are then displayed in the viewer window. When 
you create and save markup files, they are also saved in the file vault. (See "Opening 
Agile Attachment Files from the Viewer Window" and "Guidelines for Marking Up or 
Redlining Attachments" on page 4-10.)

If you need more information about a feature, see the AutoVue for Agile Online Help. 
To view Online Help, choose Help > Content in the menu bar.

Opening Files Features
These features described in the viewer Online Help are not available:
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■ Viewer Startup view (empty viewer window).

■ Drag and drop files from Windows Explorer onto the viewer window to open 
them.

■ The following viewer File menu selections are not available in the Agile Advanced 
Viewer: Open, Browse, Next File, Previous File, Load File, and Close.

For information about available File menu open features, see "Opening Agile 
Attachment Files from the Viewer Window" on page 4-3.

■ Archive file directory displayed in viewer window.

■ Import and Export Markup files feature is not available. Import and Export 3D 
Models is not available.

Access to all files, including markup files, is managed by the Agile system. For more 
information about markup files in Agile, see "Marking Up - How It Works" and 
"Guidelines for Marking Up or Redlining Attachments" on page 4-10.

Working with Hyperlinks
Refer to the AutoVue for Agile Online Help for details about working with and 
creating hyperlinks. To view the Online Help, choose Help > Contents in the AutoVue 
for Agile menu bar.

Although you can create hyperlink markup entities, you cannot create hyperlinks to 
other files in the Agile file vault.

The purpose of this viewer feature is to gather or link related information together. 
This functionality is provided by Agile features such as Attachments tabs (which may 
have multiple attached file folder objects) and Relationships tabs. For more 
information about file folder objects and attachments see the Getting Started with Agile 
PLM Guide.
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6Printing

This chapter describes the printing options available to you from AutoVue for Agile. 

Printing Documents from within AutoVue for Agile
For detailed information about printing attachments from the business object 
Attachments tab, see the Getting Started with Agile PLM manual, “Working with 
Attachments”.

For detailed information about printing attachments from the file folder object Files 
tab, see the Getting Started with Agile PLM manual, “Working with File Folders”.

For detailed information about printing from the viewer, see the viewer Online Help. 
To view Online Help, choose Help > Content in the viewer menu bar.

For information about how the Agile administrator can customize the AutoVue for 
Agile print options, see "AutoVue for Agile Administration Tasks" on page 7-1.

The following sections describe print features that have been modified to integrate 
AutoVue with the Agile system.

Headers/Footers Group in Print Properties
This group defines the headers and footers to be included on every printed page of the 
document.

Note: These settings are maintained and modified by your Agile 
administrator.

To view the header and footer settings:

Select the Headers/Footers tab.

A literal percentage mark is indicated by %%. Other codes are as follows:

■ %f = full path of document (for example, D:\PICS\TIFF\CTROK.TIF)

■ %v = document drive

■ %d = document directory (for example, D:\PICS\TIFF)

■ %b = document base name (for example, CTROK)

■ %e = document file extension (for example, TIF)

■ %n = total number of document pages
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■ %p = current page number

■ %N = total number of tiled pages

■ %P = current tile number

■ %r = newline

■ %F = Excel native print settings

■ %Y = date: year

■ %M = date: month

■ %D = date: day

■ %W = date: day of week

■ %H = time: hour

■ %U = time: minute

■ %S = time: second

Watermarks and Banners in Print Properties
The Print Properties dialog box includes a Watermark tab. This tab cannot be modified 
in the AutoVue for Agile Print Properties dialog box.

Watermark and Banner settings are defined and maintained in Agile Administrator. 
The Agile Administrator watermark and banner settings determine if banners and 
watermarks appear on printouts of files attached to Agile objects and the content of 
those banners and watermarks. These banners and watermarks appear on files printed 
with AutoVue for Agile.

Watermarks on attachments are inserted under the file. Therefore, file types that are in 
"solid" formats (e.g. PDF, BMP) will not show the watermark. It will show only on 
"transparent" file types (for example, CAD).

Watermarks
A faint and transparent watermark appears on the current document's contents.

Note: For high resolution black and white printing, the transparent 
watermark is printed on the current document's contents. For low 
resolution black and white printing, the watermark is printed on the 
current document's contents, but it is not transparent.

The watermark settings are maintained and modified by your Agile administrator; see 
the Agile PLM Administrator Guide. For more information, see Viewer Administration 
Tasks.

Stamps Group in Print Properties
This feature is not available in this implementation of AutoVue for Agile.
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Printing DGN Files
AutoVue for Agile can be configured to print files with a DGN extension in the same 
manner as MicroStation. This option must be configured on the server side; please 
contact your Agile system administrator for assistance.
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7AutoVue for Agile Administration Tasks

This chapter describes the administration tasks you can perform within AutoVue for 
Agile. For more details on file formats and specific settings, see AutoVue’s Viewing 
Configuration Guide. 

Note: For information about Agile PLM Administrator settings 
related to AutoVue for Agile, see Agile PLM Administrator Guide, 
"Viewer and Files" chapter.

Note: For more information about the AutoVue for Agile Server, 
including where to find additional AutoVue documentation, see the 
appropriate Agile installation guide for your Agile PLM system; refer 
to the chapter about configuring the AutoVue for Agile Server.

Setting the Print Options
Some file formats require configuring specific print settings to print properly. In 
general, you can change these settings for all users or for individual users:

■ To change the print settings for all users, you need to modify some of the 
parameters in the AVS\bin\allusers.ini file.

■ To change the print settings for individual users, you need to modify some of the 
parameters in each user's .ini file under AVS\bin\profiles.

Caution: When you modify options in the allusers.ini file, the 
existing user profiles are not automatically modified. Because editing 
every individual user profile is impractical, in the procedures below 
you are instructed to delete the existing user profiles when you 
modify allusers.ini. The next time a user opens AutoVue for Agile , a 
new user profile is created which includes the new allusers.ini options 
settings. You may want to notify your users in advance to let them 
know that their user profiles will be reset.

To change the way that the watermark, border, and header (banner) appear when 
printed, you will need to modify the following .ini file parameters:

■ [OPTIONS] - HPBACKGROUND, KEEPORIGINALCOLORS, and 
SWSHOWVIEWPORTBORDER
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■ [PRINTWATERMARK] - FONTNAME, FONTSIZE, ORIENTATION, and 
FONTSTYLE

■ [PRINTHEADERS] - FONTNAME, FONTSIZE, ORIENTATION, and FONTSTYLE

The following sections describe the procedures for printing watermarks and borders, 
and for modifying the headers and watermarks.

Printing Watermarks in .hpg and .plt Files
To print watermarks correctly in .hpg and .plt files, set the background color correctly.

Note: If the watermark image or the color used in the watermark 
image is not transparent, the watermark will not be visible.

To set the background color:

1. Shut down the AutoVue server.

2. On the drive where the AutoVue for Agile Server is installed, find the 
AVS\bin\Profiles folder.

3. Delete all the user profiles in this folder (Example: John Smith.ini).

4. Edit the allusers.ini file (AVS\bin\allusers.ini).

5. In the [OPTIONS] section, add or update the following two lines:

HPBACKGROUND = 0

KEEPORIGINALCOLORS = 1

Printing Viewport Borders in SolidWorks Files
To print viewport borders correctly in SolidWorks files, enable the viewing/printing of 
viewport borders.

To enable the option:

1. Shut down the AutoVue server.

2. On the drive where the AutoVue for Agile Server is installed, find the 
AVS\bin\Profiles folder.

3. Delete all the user profiles in this folder (Example: John Smith.ini).

4. Edit the allusers.ini file (AVS\bin\allusers.ini).

5. In the [OPTIONS] section, add or update the following line:

SWSHOWVIEWPORTBORDER = 1

Modifying the Header and Watermark Font Settings

Note: The watermark may be truncated if the font size is too large or 
if there are too many characters in the watermark text. Truncation 
ensures that the watermark does not distort the image.

To set the watermark font size:

1. Shut down the AutoVue server.
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2. On the drive where the AutoVue for Agile Server is installed, find the 
AVS\bin\Profiles folder.

3. Delete all the user profiles in this folder (Example: John Smith.ini).

4. Edit the allusers.ini file (AVS\bin\allusers.ini).

5. In the [PRINTHEADERS] section and in the [PRINTWATERMAK] section, update 
the lines for Fontname, Fontsize, Orientation, and Fontstyle. For example:

FONTNAME = Serif

FONTSIZE = 24

ORIENTATION = 1

FONTSTYLE = 2

Note: ORIENTATION can be specified as 1 (portrait) or 2 
(landscape).

Adding Fonts
To ensure that specific fonts are recognized by AutoVue for Agile, you can add the font 
path to the allusers.ini configuration file.

To add fonts:

1. Shut down the AutoVue server.

2. On the drive where the AutoVue for Agile Server is installed, find the 
AVS\bin\Profiles folder.

3. Delete all the user profiles in this folder (Example: John Smith.ini).

4. Edit the allusers.ini file (AVS\bin\allusers.ini).

5. In the [OPTIONS] section, update the following line:

XFONTPATHS = {paths}

6. Add the full paths of the font files to the line. Separate the paths with a semicolon.

7. Save the allusers.ini file.

8. Clear your web browser's cache.

9. Restart the AutoVue server.

Viewing Excel Files
When viewing Excel files in AutoVue for Agile, the number of pages listed in the 
viewer status bar is the number of Excel worksheets. The AutoVue for Agile menu 
command View > Page selects a different Excel worksheet to view.
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