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Overview of this guide 
This guide provides an architectural overview of the Central Coding application; step-by-step 
instructions for installing, upgrading, and uninstalling the Central Coding software; descriptions of 
system functions; and step-by-step instructions for managing the Central Coding application at the 
server level, including loading coding dictionaries, adding studies and adapters using the command 
line, and producing performance metrics. 

If you are integrating with the InForm application, the InForm Adapter software must also be 
installed. The Central Coding software uses the InForm Adapter software to control communication 
between Central Coding servers and InForm studies. For more information, see the InForm Adapter 
Installation Guide. 
 

Audience 
This guide is for IT administrators and others who are responsible for installing and uninstalling the 
Central Coding software and the coding dictionaries, and for users responsible for integrating the 
Central Coding application with the Clintrial or InForm applications.  
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Related information 

Documentation 
The Central Coding 3.0 .3 documentation includes the following items. All documentation is 
available from the Oracle Software Delivery Cloud (https://edelivery.oracle.com) and the Download 
Center (https://extranet.phaseforward.com). 

Title Description 
Release Notes The Release Notes document presents information about new 

features, enhancements, and updates for the current release. 

Known Issues The Known Issues document presents information about known 
issues for the current release. 

Note: The most current list of known issues is available on the 
Phase Forward Extranet. 

To sign in to the Extranet, go to 
https://extranet.phaseforward.com and click Customer Login. 
Enter your email address and password, and navigate to the 
Known Issues section. Select a product, and then enter your 
search criteria. 

Secure Configuration Guide The Secure Configuration Guide provides an overview of the security 
features provided with the Oracle® Health Sciences Central Coding 
application, including details about the general principles of 
application security, and how to install, configure, and use the 
Central Coding application securely. 

Installation Guide The Installation Guide provides the following: 

• Architectural overview of the Central Coding application 

• Step-by-step instructions for installing, upgrading, and 
uninstalling the Central Coding software 

• Descriptions of system functions 

• Step-by-step instructions for managing the Central Coding 
application at the server level, including loading coding 
dictionaries, adding studies and adapters using the command 
line, and producing performance metrics. 

This document is also available from the Documentation CD. 

User Guide The User Guide provides an architectural overview of the Central 
Coding application, descriptions of all system functions, and step-
by-step instructions for using the Central Coding application and 
managing the coding dictionaries. 

This document is also available from the Documentation CD and 
the Central Coding user interface. 
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Title Description 
Quick Start for Coders and 
Approvers 

The Quick Start for Coders and Approvers provides a brief overview of 
the tasks that coders and approvers perform in the Central Coding 
user interface, including step-by-step instructions for coding and 
approving requests, and working with queries. 

This document is also available from the Documentation CD. 

Page-level Help The page-level Help describes the function(s) and fields for each 
page in the user interface. 

This document is also available from the Central Coding user 
interface. 

Note: If you are integrating with the InForm application, in addition to the items in the Central 
Coding documentation set, you must refer to the InForm Adapter Installation Guide for 
information about installing the InForm Adapter software. 

 



 Installation Guide  

Oracle® Health Sciences Central Coding 3.0.3 xi 

If you need assistance 
Oracle customers have access to support through My Oracle Support. For information, visit 
http://www.oracle.com/pls/topic/lookup?ctx=acc&id=info, or if you are hearing impaired, visit 
http://www.oracle.com/pls/topic/lookup?ctx=acc&id=trs. 
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Central Coding overview 
The Central Coding software is a web-based application that integrates with the Oracle Clintrial 
software or the Oracle InForm software to provide centralized coding for all studies within an 
organization. Because the Central Coding software works independently from the Clintrial or 
InForm software, you can have parallel work paths for the clinical study teams and the clinical coding 
teams. As a result, coding can happen earlier in the study cycle, providing valuable data visibility for 
study managers who review and assess study safety concerns. 

Coding is the process of mapping a standardized term and code from a given level of a standard 
coding dictionary to a verbatim. You can code adverse events, drugs, diseases, and other items using 
consistent terminology defined in industry-standard and customer-defined dictionaries. 

The Central Coding software streamlines the coding process with features such as autocoding, 
customizable synonym and stopword lists, code and propagate functionality, and configurable 
workflow for the efficient review, resolution, and approval of coded terms—all of which can occur 
simultaneously and across staff, sites, studies, and locations. 

The Central Coding software is FDA 21 CFR Part 11 compliant and provides: 

• Remote connectivity, enabling simultaneous access for multiple, decentralized users. 

• Global, multi-study/multi-center connectivity. 

• Link-through and single sign-on capabilities to the InForm application. 

• Centralized, multi-version, multi-dictionary support including support for MedDRA, MedDRA-J, 
WHO-DD, and JDrug. 

• Customizable algorithms to increase high auto-hit rates. 

• Configurable synonym lists for use across different studies. 

• Definable stopword lists to increase the speed and accuracy of autocoding. 

• Autocoding and automatic approval to reduce the manual coding effort. 

• Code and propagate to eliminate the need to manually code identical verbatims. 

• Configurable role-based workflow and approval. 

• Query creation for use in the InForm application. 

• Reports for coding consistency, coded items, updated codes, and users. 

• Exports for coding consistency, coded items, and queries. 

• Full audit history. 

• Impact analysis to view MedDRA, MedDRA-J, WHO-DD, or JDrug dictionary changes to 
evaluate their impact on study data, and to reconcile any differences to existing terms, codes, and 
synonyms. 

 



 Installation Guide  

Oracle® Health Sciences Central Coding 3.0.3 3 

Supported coding dictionaries 
The Central Coding application supports: 

• The use of the following industry-standard coding dictionaries. 

• MedDRA and MedDRA-J—Medical Dictionary for Regulatory Activities. 

• WHO-DD (C format)—World Health Organization Drug Dictionary. 

When using WHO-DD you can configure the Central Coding application to autocode to the 
Trade Name (default) or to the Medicinal Product. With either configuration option, you can 
report (return) the Trade Name, Preferred Name, and Ingredients to the source application. 

• JDrug—Data File for Ethical Drugs (Coding Table) from Iyaku-Joho-Kenkyujo, Inc. 

• Any number and combination of standard and custom dictionaries. 

Contact Oracle for information on any dictionary other than MedDRA, MedDRA-J, WHO-DD, 
or JDrug. 

• Any number and combination of dictionary versions, such as multiple versions of MedDRA or 
WHO-DD. 

Contact Oracle for a list of the supported dictionary versions. 
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Multilingual data 
The Central Coding application can accept both English and Japanese verbatims (multilingual data). 

• When you install the Central Coding application on an English operating system, you can choose 
whether to use multilingual data. 

• When you install the Central Coding application on a Japanese operating system, the installation 
program assumes that there will be multilingual data. 

If you choose to use multilingual data, the Central Coding installation program: 

• Loads the Japanese report templates. These reports contain the MS Mincho or MS UI Gothic 
font so that Japanese text appears correctly in the reports. These reports can contain both 
Japanese and English data. 

• Sets the default date format to YYYY/MON/DD HH24:MI:SS. You can modify this setting as 
needed on the System Configuration page.  

Note: You cannot perform an upgrade to support the Japanese language. 
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Architectural overview 
The Central Coding software is built on a Microsoft .NET and Oracle platform. It uses web services 
over a network for the transmission of coding requests and responses, and uses Internet Information 
Services (IIS) to provide its web-based user interface to the coding team, so they can provide coding 
services through the Internet. 

The Central Coding software requires a database server and one or more application servers. This 
architecture provides for flexibility and scalability, allowing you to configure the web server, 
application server, and database server layers independently. You can add web and application 
servers to meet increased demand. In all configurations, you access the Central Coding software on 
the application server through HTTP sessions from Windows clients using Internet Explorer. Each 
Central Coding application server runs on a Windows server, which uses the Oracle client with the 
Oracle Data Provider for .NET interface with an Oracle database server.  

• Central Coding and Clintrial integration—The two applications communicate through a web 
service that is configured using the Clintrial application. This integration does not require an 
adapter. For more information, see the Clintrial Admin & Design guide. 

The Clintrial application initiates all communication to and from the Central Coding application. 

• Central Coding and InForm integration—The Central Coding software uses the InForm 
Adapter software to control communication between Central Coding servers and InForm 
studies. 

The Central Coding application initiates all communication to and from the InForm application. 
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Physical configuration options 
• Central Coding and Clintrial integration—The Clintrial software must be installed on a 

different machine than any of the Central Coding application servers. 

• Central Coding and InForm integration—The InForm software and the InForm Adapter 
software must be installed on different machines than any of the Central Coding application 
servers. The InForm Adapter software can be installed on the same machine as the InForm 
software or on its own machine. 

 

Single application server configurations 
The single application server configurations are: 

• The Central Coding application server and database server running on the same machine. 

• The Central Coding application server running on one machine and the database server running 
on a separate machine. 

In a production environment, Oracle recommends running the Central Coding application server 
and database server on separate machines. This configuration allows more flexibility, scalability, 
and performance; is easier to manage and troubleshoot; and is easier to expand in the future by 
adding additional application servers. 

 

Multiple application server configurations 
The multiple application server configurations are: 

• Multiple Central Coding application servers and the database server on the same machine.  

• Multiple Central Coding application servers on one machine and the database server on a 
different machine.  

• Multiple Central Coding application servers on different machines and the database server on a 
different machine. 

This configuration might be practical, for example, if you want to use the Central Coding 
application across different geographic regions. 

You can configure application servers as logical entities, allowing multiple application servers to 
co-exist on the same machine. Application servers can map to either: 

• Unique database instances, each of which has its own dictionaries. 

• A single database instance that shares dictionaries. 

In multiple application server environments, each application server has its own: 

• URL 

• Job scheduler 
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Deployment scenarios 

About integrating with the Clintrial or InForm application 
The Central Coding application supports integration with the InForm application and the Clintrial 
application at the same time under the following circumstances: 

• One of the following is true: 

• The InForm application, Clintrial application, and Central Coding application are behind the 
same firewall. 

• The InForm application, Clintrial application, and Central Coding application are not behind 
the same firewall, but a VPN is used between the Central Coding application and the 
Clintrial application. 

• The Clintrial software must be installed on a different machine than any of the Central Coding 
application servers. 

• The InForm software and the InForm Adapter software must be installed on different machines 
than any of the Central Coding application servers. The InForm Adapter software can be 
installed on the same machine as the InForm software or on its own machine. 

To determine the hardware and software requirements for using the Central Coding application with 
another application via the Services Interface (API), consult your Oracle Services representative. 
 

Central Coding and Clintrial application components 
The Central Coding and Clintrial applications must be hosted at the customer site behind the 
customer firewall. As a result, additional security features are not needed. 
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Central Coding and InForm application components 
The Central Coding application components can be deployed with or without enabling security. 
 

All InForm and Central Coding components behind a firewall 

When integrating with the InForm application, the application servers for all the software 
components in the Central Coding environment can be behind a firewall. This is the typical scenario 
when Oracle hosts all the applications.  
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Central Coding server(s) outside a firewall 

When integrating with the InForm application, the application servers for the InForm and InForm 
Adapter software components can be behind a firewall, while the Central Coding server(s) are 
outside the firewall. This is the typical scenario when Oracle hosts the InForm servers and a 
customer hosts its own Central Coding application server(s). 
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About the Central Coding 3.0.3 release 
The Central Coding 3.0.3 release includes the following components: 

• Central Coding 3.0.3 product. 

• Central Coding 3.0.3 documentation. 

• InForm Adapter product and documentation. 

Before beginning the installation, check the Oracle Software Delivery Cloud 
(https://edelivery.oracle.com) for the latest patchsets and patches, as well as the accompanying 
Release Notes and Known Issues documents, and the latest versions of the documentation. 
 

InForm Adapter product and documentation 
To use the Central Coding software with the InForm application, the InForm Adapter software must 
also be installed and configured. For more information, see the InForm Adapter Installation Guide. 
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Prerequisites 

Set the regional language option on the client and application servers—English 
operating systems only 

You must set the regional language option on the client server(s) and the application server where 
you install the Central Coding software if you are going to perform a fresh installation on an English 
operating system and you want to support both English and Japanese verbatims. 

1 Select Start > Settings > Control Panel > Regional and Language options. 

The Regional and Language Options dialog box appears. The Regional Options tab appears by 
default. 

2 Click the Languages tab. 

3 In the Supplemental language support group box, select Install files for East Asian languages, and 
click OK. 

 

Rename the dictionary file for the JDrug dictionary 
The Dictionary Loader tool does not recognize Japanese file names. Therefore, you must rename the 
JDrug dictionary file so that the Dictionary Loader can recognize the file name and load the 
dictionary. 

• Rename, or copy and rename, the JDrug dictionary file ( ) to all_cases.txt. 

Note: Make sure that this file is in a local directory with only English names in its path. 

For instructions on loading the coding dictionaries, see Loading and managing the coding 
dictionaries (on page 55). 
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Checklist: Setup tasks for integrating the Central Coding and Clintrial 
applications 

To integrate the Central Coding and Clintrial applications, perform the following tasks using the 
Clintrial application before you install the Central Coding 3.0.3 software. 

 

Checklist: Setup tasks for integrating the Central Coding and Clintrial applications 

 Task For details, see... 

 1 Install the Clintrial software. Clintrial Getting Started guide. 

Note: The Clintrial software must be installed on a 
different machine than any of the Central Coding 
application servers. 

 2 Configure network or Internet 
access to the Central Coding 
application server.  

Clintrial Getting Started guide. 

 3 Configure the CC_HOST 
parameter with the HTTP 
address of the Central Coding 
interface. 

Clintrial Admin & Design guide. 

This may be set in the Clintrial Admin module as a 
System or Protocol parameter. 

 4 Set the 
USE_CENTRAL_CODING 
parameter to Yes for the target 
protocol. 

Clintrial Admin & Design guide. 

This may be set in the Clintrial Admin module as a 
System or Protocol parameter. 

 5 Create a new dictionary 
definition. 

Clintrial Manage, Classify & Lab Loader guide. 

 6 Define labels for the dictionary 
definition.  

Clintrial Manage, Classify & Lab Loader guide. 

 7 Select a dictionary definition for 
an item in a panel. 

Clintrial Admin & Design guide. 

 8 Create a Central Coding 
encoding target.  

Clintrial Manage, Classify & Lab Loader guide. 

 9 Map the target items with the 
defined labels. 

Clintrial Manage, Classify & Lab Loader guide. 

 10 Use the Clintrial Manage module 
to send coding requests (define 
the delivery schedule) to the 
Central Coding application. 

Clintrial Admin & Design guide. 
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Checklist: Setup tasks for integrating the Central Coding and InForm 
applications 

To integrate the Central Coding and InForm applications, perform the following tasks before you 
install the Central Coding 3.0.3 software. 

 

Checklist: Setup tasks for integrating the Central Coding and InForm applications 

 Task For details, see... 

Install the applications 

 1 Install the Central Designer 
software. 

Central Designer Installation Guide. 

 2 Install the InForm software. InForm Installation Guide. 

Note: Set up the InForm Adapter to accept data 
securely. 

 3 Install the InForm Adapter 
software. 

InForm Adapter Installation Guide. 

Note: Set up the InForm Adapter to accept data 
securely. 

Note: The InForm software and the InForm Adapter software must be installed on different 
machines than any of the Central Coding application servers. 

Perform this step on the InForm application server 

 4 Install the InForm Server 
Adapter Interface (ISA). 

InForm Adapter Installation Guide. 

Perform these steps on the InForm Adapter server 

 5 Install the Coding interface. InForm Adapter Installation Guide. 

 6 Manually add studies. InForm Adapter Installation Guide. 

 7 Set up one or more InForm 
studies. 

Specify mappings and add InForm users for use with 
the Central Coding application. 

For integration with the InForm 5.0 release or later, 
see the Study and Reporting Setup Guide. 

For integration with releases prior to the InForm 5.0 
release, see the Installation and Configuration guide. 

For more information, see About setting up 
InForm studies for use with the Central Coding 
application (on page 16) and About mapping data 
for coding with the Central Coding application 
(on page 17). 
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About setting up InForm studies for use with the Central Coding application 
To set up one or more InForm studies for use with the Central Coding application, perform the 
steps listed in the following table. 

 

Checklist: Setting up InForm studies for use with the Central Coding application 

 Task Description 

Perform these tasks using the InForm application 

 1 Specify a valid InForm user whose 
credentials can be used by the 
Central Coding application to access 
the InForm application. 

Enter a valid InForm user name and password on 
the System Configuration > Get/Put Job Options 
page. 

This field is required for communication with the 
InForm application if you are using user 
name/password authentication. In addition, when 
you create a new InForm adapter, you must also 
select the option to Call InForm Adapter Web 
Services with User Name/Password Authentication 
on the [Adapter Name] page. 

 2 Create a rule in the InForm 
application to clear the coding targets 
(optional). 

If the following key items are changed in the InForm 
application after a verbatim is coded, they will not be 
updated in the Central Coding application. 

Note: The key items are updated in the Central 
Coding application if the verbatim is not coded in the 
InForm application. 

• SubjectInitials 

• SubjectNumber 

• Visit 

• Site Name 

• Site 

• Study 

If you want the key items to be updated, you must 
create a rule in the InForm application to clear the 
coding targets. 

Perform this task using the Central Designer application 
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Checklist: Setting up InForm studies for use with the Central Coding application 

 Task Description 

 3 Create the coding maps. Specify mapping definitions for controls that hold 
verbatim text and controls that hold the coded values 
assigned by the InForm application. 

For more information, see the Central Designer 
InForm Design Guide. 

Note: Oracle recommends that you do not modify 
coding maps after coding begins for the study. Doing 
so can slow the coding process. 

 
 

About mapping InForm data for coding with the Central Coding application 
Use the Central Designer application to specify the InForm mapping definitions for controls that 
hold verbatim text and controls that hold the coded values. For more information, see the Central 
Designer InForm Design Guide. 

1 For each form that contains data to be coded, design controls to hold data as entered 
(verbatims), controls to hold coded data (code targets), items to hold query data (query targets), 
and if supported by the dictionary, controls to hold additional context information (context 
items).  

Verbatim, code target, query target, and context items must be: 

• In the same visit if the visit is repeating. 

• On the same form if the form is repeating. 

• In the same itemset if the coded data appears in an itemset. 

• Different from each other. 

2 Create a mapping definition that specifies: 

• Each verbatim to be coded. 

• The dictionary used for coding. 

• Each code target to which the Central Coding application returns a coded value. 

• Each context item used to provide additional context data to the Central Coding application. 

• Each applicable verbatim type. 

• Each query target on which to place a query associated with the verbatim. The query target 
can be the verbatim item, or any other visible, editable item on the form. 

3 In a production study, use the Central Coding application to: 

a Export the verbatim and context data from the InForm application to the Central 
Coding application. 

b Code the data. 

c Import the coded data from the Central Coding application to the InForm application. 
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Overview of the Central Coding installation process 
The following table outlines the process for installing the Central Coding software, indicates the 
order in which you must perform the steps, and provides cross-references to instructions for 
completing the procedures. 

Note: Before performing the tasks in the table, be sure you have met the requirements listed in 
the Prerequisites (on page 13). 

 

Overview of the Central Coding installation process 

Step Task For details, see... 
1 Prepare the database and application 

servers. 
Preparing the database and application 
servers (on page 19). 

2 Install the Central Coding software. Installing the Central Coding software (on 
page 29). 

3 Load the coding dictionaries. Loading and managing the coding 
dictionaries (on page 55). 

4 Configure the Central Coding 
application. 

User Guide. 
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Overview: Preparing the database and application servers 
Preparing the database and application servers is step 1 in the installation process. This step is shaded 
in the table. 

For the database server, you must: 

• Install and configure the Oracle software on the database server. 

• Create the database and tablespaces that are used by the Central Coding application. 

For the application server, you must: 

• Verify the version of ASP.Net. 

Note: The Central Coding application supports only one version of a database on a machine. 

 

Overview of the Central Coding Installation process 

Step Task For details, see... 
1 Prepare the database and application 

servers. 
• Install the Oracle software on the 

database server (on page 21). 

• Create the database and tablespaces (on 
page 22). 

• Verify the version of ASP.Net on the 
application server (on page 23). 

• Set the ISAPI and CGI restriction 
settings—Windows 2008 operating 
systems only (on page 24). 

• Install a certificate to secure internal 
communication with the Job Scheduler 
service (on page 25). 

• Disable SSLv2 on the Central Coding 
application server (on page 27). 

2 Install the Central Coding software. Installing the Central Coding software (on 
page 29). 

3 Load the coding dictionaries. Loading and managing the coding 
dictionaries (on page 55). 

4 Configure the Central Coding 
application. 

User Guide. 
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Install the Oracle software on the database server 
When the database server requirements are met, you can install your Oracle database. Use the Oracle 
installation documentation as needed. 
 

Mandatory database parameters 
Most of the default Oracle configuration parameters can be used for the Central Coding database. 
However, the following parameters must be set to the specified values. 

 

Mandatory database parameters 

Parameter Value 
Database Character Set AL32UTF8 - Unicode UTF-8 Universal character set 

National Character Set AL16UTF16 - Unicode UTF-16 Universal character set 

db_cache_size 80 MB 

sga_max_size 1000 MB 

sga_target 600 MB (dependent on how much memory is available for 
Oracle)  

pga_aggregate_target 300 MB (dependent on how much memory is available for 
Oracle) 

BLOCK_SIZE Database: 16k   

Tablespace: 16k 

Note: Your database administrator should dynamically adjust the sga_target and 
pga_aggregate_target values using Oracle Enterprise Manager Advisors as the system grows. 

Note: Oracle recommends that the Oracle instance registry parameter ORA_*SID*_AUTOSTART 
be set to True. This ensures that Oracle is synchronized with the job scheduler, which is an auto-
started service. 
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Create the database and tablespaces 
After installing the Oracle software, create the database and tablespaces. The Central Coding 
application uses the Coding application and Coding platform tablespaces listed in the following table. 

• Note the names of the tablespaces you create. 

You need the names when you enter values for the database users during the Central Coding 
software installation.  

Each tablespace has one or more associated database users, which the installation wizard creates 
when you install a Central Coding application server. For more information, see Installing a 
Central Coding application server (on page 32). 

Note: For demonstration purposes in this guide, example names are provided for the 
recommended tablespaces, and for their associated database users and passwords. The 
same example name is used for both the user name and password. 

The Central Coding Database User name and the Coding Platform Database User name 
cannot be the same. 

The tablespace and user names are not case-sensitive. The passwords are case-sensitive. 

• The Coding application tablespace contains the coding dictionary database, which is created by 
the Dictionary Loader tool. For more information, see About the Dictionary Loader tool (on 
page 59). 

Note: All entries used as Oracle database objects (such as user names, passwords, and 
tablespaces) should follow Oracle recommendations for naming conventions. In addition, Oracle 
recommends using strong passwords, as described in the Secure Configuration Guide. 

 

Recommended tablespaces  

Tablespace Size Contains Database user(s) 
Coding application 

Example name: 
CODING 

500 MB 

Auto extend 
enabled,  
10 MB 
increments. 

Central Coding 
application 

 

• Central Coding Database 
User 

Example name: cca 

Coding platform 

Example name: CCP 

100 MB 

Auto extend 
enabled,  
10 MB 
increments. 

Coding 
dictionaries 

• Coding Platform Database 
User 

Example name: 
codingplatform 

• Coding Dictionary Database 
User 

Example name: 
codingdictionaries 
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Verify the version of ASP.Net on the application server 
After completing the database installation, verify the version of ASP.Net on the application server. If 
the correct version of ASP.Net is not being used by the IIS Manager, you cannot view the login page 
for the Central Coding application. 

1 Select Start > Programs > Administrative Tools > Internet Information Services (IIS) Manager. 

The Internet Information Services (IIS) Manager dialog box appears. 

2 Expand Web Sites. 

3 Right click Default Web Site and select Properties. 

The Default Web Site Properties dialog box appears. 

4 Click the ASP.NET tab. 

5 In the ASP.NET version field, select 4.0. 

6 Click OK. 
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Set the ISAPI and CGI restriction settings—Windows 2008 
operating systems only 

For environments that use the Windows 2008 operating system, after you complete the database 
installation and verify the version of ASP.Net on the application server, you must set the ISAPI and 
CGI Restrictions option to allow the use of ASP.Net 4.0 on the machine on which you are installing 
the Central Coding application.  

1 Select Start > Programs > Administrative Tools > Internet Information Services (IIS) Manager. 

The Internet Information Services (IIS) Manager dialog box appears. 

2 In the Connections pane, select the local machine on which you are working. 

The [Computer Name] Home pane appears. 

3 In the IIS section, make sure ASP is installed. 

4 In the IIS section, double-click ISAPI and CGI Restrictions. 

The ISAPI and CGI Restrictions pane appears. 

5 Double-click ASP.NET v4.0.30319. 

The Edit ISAPI or CGI Restriction dialog box appears. 

6 Select Allow extension path to execute. 

7 Click OK. 
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Install a certificate to secure internal communication with 
the Job Scheduler service 

On each Central Coding application server, an administrator must install the certificate that is used to 
secure communication with the Job Scheduler service.  

• The certificate must be installed to the LOCAL_MACHINE\MY store directory and made 
usable by the user who runs the ASP.NET worker process (by default, the 
NETWORK_SERVICE user). You must also grant this user Full Control rights to the private 
key for the certificate. 

• The certificate and each certificate in the certification path must be 1024 bytes. For information 
about converting an existing certificate, see the Microsoft support website. 

To install the certificate: 

1 Open the Microsoft Management console: 

a Open a Command Prompt window. 

b Type mmc. 

2 Select File > Add/Remove Snap-in. 

The Add or Remove Snap-ins dialog box appears. 

3 In the list of available snap-ins, select Certificates. 

4 Click Add. 

The Add dialog box appears. 

5 Click Computer account. 

6 Click Next.  

7 Click Local Computer. 

8 Click Finish. 

9 Click OK. 

10 In the Microsoft Management console, in the Console Root tree, select Certificates (Local 
Computer). 

11 In the Logical Store Name field, right-click the Personal folder. 

12 Select All Tasks > Import. 

The Certificate Import Wizard appears. 

13 Click Next. 

14 Click Browse, and select the PFX file provided by the certificate vendor.  

15 You are prompted for a password. Type the password for the PFX file. 

16 Click Next to accept the default options for the remaining dialog boxes. 

17 Click Finish. 

The new certificate appears in the displayed list.  
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18 Give the user full control to the certificate. 

a Do one of the following: 

• For Windows 2008 operating systems, right-click the certificate, and select All Tasks > 
Manage Private Keys. 

• For Windows 2003 operating systems, open the certificate in the WSE 2.0 X.509 
certificate tool. 

For specific instructions, see the documentation for your operating system. 

b For the certificate, assign both Read and Read and execute rights to the user. 

• By default, for Windows 2003, the user is NETWORK_SERVICE. 

• By default, for Windows 2008 and Windows 7, the user is NETWORK_SERVICE or 
IIS AppPool\Central Coding New Pool. Please add both users. 

19 Click OK. 
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Disable SSLv2 on the Central Coding application server 
Oracle recommends that for improved security you disable SSLv2 on the Central Coding application 
server. For more information, see the Microsoft website (http://social.technet.microsoft.com).  
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Overview: Installing the Central Coding software 
Installing the Central Coding software is step 2 in the installation process.  

This chapter includes instructions for installing the software (manually or by performing a silent 
installation), modifying an existing installation, upgrading from a previous version of the software, 
repairing an installation, and uninstalling the software. 

 

Overview of the Central Coding installation process 

Step Task For details, see... 
1 Prepare the database and application 

servers. 
Preparing the database and application 
servers (on page 19). 

2 Install the Central Coding software. • Before you begin (on page 31). 

• Installing a Central Coding application 
server (on page 32). 

• Modifying an existing Central Coding 
application server (on page 42). 

• Performing an interactive upgrade to the 
Central Coding 3.0 .3 software (on page 
43). 

• Performing a silent installation (on page 
46). 

• Performing a silent upgrade (on page 48). 

• Verifying the installation (on page 51). 

3 Load the coding dictionaries. Loading and managing the coding 
dictionaries (on page 55). 

4 Configure the Central Coding 
application. 

User Guide. 
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Before you begin 
You can perform either a manual or a silent installation of the Central Coding software. 

Before you run the installation, make sure that: 

• The database instance is running.  

• All clocks are synchronized on the machines where you are installing the Central Coding 
software and the database server.  

The installation program verifies that the clocks are synchronized. If they are not synchronized, 
an error message appears. Installation cannot continue until the clocks are synchronized. 

• The ASP.NET state service is started. 

• The job scheduler is turned off. 
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Interactive installation or upgrade 

Installing a Central Coding application server 
Use this procedure to install an instance of the Central Coding software. After you install one 
instance of the Central Coding software, you can run the installation program as many times as 
necessary to install additional instances. 

Perform this procedure on each application server. 

Note: This installation procedure requires that you enter the names of the database tablespaces 
and their associated database users and passwords. For demonstration purposes in this guide, 
example names for the tablespaces, users, and passwords are provided in this procedure in the 
appropriate steps. For more information, see Create the database and tablespaces (on page 22). 

Caution: All entries used as Oracle database objects (such as user names, passwords, and 
tablespaces) should follow Oracle recommendations for naming conventions. In addition, Oracle 
recommends using strong passwords, as described in the Secure Configuration Guide. 

1 Locate setup.exe. 

2 Right-click and select Run as administrator. 

• If you are installing the Central Coding application for the first time, the Welcome page 
appears. 

• If you have already installed an instance of the Central Coding application, the Existing 
Installed Instances Detected page appears. 

• Select Install a new instance of this application, and click Next. 

The Welcome page appears. 

3 Click Next. 

The page that appears depends on the operating system.  

• If you are performing a fresh installation on a Japanese operating system, the Required 
System Components page appears. Proceed to step 5. 

• If you are performing a fresh installation on an English operating system, the Determine 
Database Sort page appears. 

Use this page to specify the locale, which determines the correct linguistic sorting in the 
database. The choice affects the language of verbatims that can be supported, the default 
date format, and which report templates are installed. 
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4 Select the locale. 

• English—Sets the default database sort group to English. The English option maps to the 
Binary Oracle sort value. 

Select this option to: 

• Support only English verbatims. 

• Set the default date format to DD/MON/YYYY HH24:MI:SS. 

• Load the English report templates. The reports can contain only English data. 

• European—Sets the default database sort group to WesternEuropean. The European 
option supports more character sets than the English option. It maps to the Generic_M 
Oracle sort value, which generally handles the order of the Latin, Cyrillic, Greek, and other 
European characters. 

Select this option to: 

• Support only English verbatims. 

• Set the default date format to DD/MON/YYYY HH24:MI:SS. 

• Load the English report templates. The reports can contain only English data. 

• Global—Sets the default database sort group to JapaneseWesternEuropean. The Global 
option maps to the Japanese_M Oracle sort value. 

Select this option: 

• If you are using an English operating system and you want to support both English and 
Japanese verbatims, or if you are using a Japanese operating system.  

• To set the default date format to YYYY/MON/DD HH24:MI:SS. 

• To load the Japanese report templates. The reports can contain both Japanese and 
English data. 

Note: For the best performance, Oracle recommends that you select Global only if you 
are working with Japanese studies. 

5 Click Next. 

The Required System Components page appears. The installation wizard verifies that the server 
has all the necessary software components, including the operating system, IIS, and the Oracle 
client.  

If required components are missing or are the wrong version, installation stops. The missing and 
invalid components are listed on the Required System Components page. You must install them 
before continuing the installation. 

6 Click Next. 

The License Agreement page appears. Review the license agreement. 

• If you want to print a copy of the license agreement, click Print. 

• You must accept the terms of the license agreement to continue the installation.  



Chapter 4  Installing the Central Coding software  
 

34 Oracle® Health Sciences Central Coding 3.0.3 

7 Click Yes.  

The Company Information page appears. 

8 Enter the following information: 

• Company name—Name of the company licensed to use the software. 

The company name may include any characters. This is informational only. 

• Company URL—URL that is unique to the company. 

This is used to define the security domain in inter-product communication. The Company 
URL: 

• Must be in English. 

• Must follow the proper URL convention and be in valid URL (ascii) narrow characters. 

The URL does not need to point to an actual running website or service. 

• Should not begin with a protocol designation such as http://. 

Note: The Company URL you enter for the Central Coding software must be the same 
as the Company URL you entered for the InForm Adapter software. 

9 Click Next. 

The Select Features page appears. 

10 Select the features to install. At least one feature must be selected in order to continue with the 
installation. If you select only the Dictionary Loader tool, the installation program skips to the 
end of the wizard. 

• Central Coding Server. 

• Dictionary Loader. 

The Dictionary Loader tool must be installed in order to load standard and custom 
dictionaries. However, the Dictionary Loader tool: 

• Does not need to be installed on every machine or on every application server.  

• Can be on a different machine from the Central Coding application server(s). 

• Can be installed without also installing the Central Coding Server. 

If you want to verify whether the Dictionary Loader tool is installed, from the Start Menu, 
select Programs > Phase Forward > Central Coding. If Dictionary Loader appears, it is already 
installed. 

• Coding Service Interface for Clintrial. 

Select only if you plan to use the Central Coding application with the Clintrial application. By 
default, the Coding Service Interface for Clintrial is not installed. 
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11 Click Next. 

The Application Instance Settings page appears. This page collects the instance name and job 
scheduler port number. From the instance name, the installer derives the virtual directories and 
job scheduler service name. The port must be numeric and should designate a port that is 
currently open and will be reserved for only this service. The installation program attempts to 
select a port that has not been used by a prior run of the installation. 

 

 
 

12 Enter the following information: 

• Instance Name—Unique string identifier for this instance. The Instance Name derives 
names for the various services. 

• Do not use special characters and make sure that there are no spaces in the name. 

• If you plan to have multiple application servers, consider using a naming convention for 
the names that allows you to easily identify each instance. 

• TCP port—Port through which the job scheduler communicates on this Central Coding 
application server.  

The Central Coding software reserves the range 54000 through 54999 by convention, 
although it can be any open port. Each instance must be assigned its own port. The 
installation program defaults to a unique number for each instance being installed, starting in 
the conventional range, but not limited to it. 
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The following information is automatically populated: 

• Service name—NT service name for the application server you are creating. By default, this 
is set to Central Coding Job Scheduler. 

This must be a unique name across multiple instances so that the services can be 
distinguished from one another. The installation appends the instance name to the service 
name. 

• Application URL—URL for the application server. 

• Application Server—Name of the virtual directory under which the application is published 
in IIS. 

The installation appends the instance name to the service name. 

• Coding Service Virtual Directory—Unique name for the application server you are 
creating. 

The installation appends the instance name to the service name. 

• Platform Service Virtual Directory—Unique name for the platform you are creating for 
this application server. 

The installation appends the instance name to the service name. 

• Job Service Host Name—Machine name of the host. The default is localhost. 

13 Click Next. 

The Choose Destination Location page appears. 

14 Specify where on the local file system to install the instance of the application. 

By default, the installation wizard installs the Central Coding software in the C:\Program 
Files\Phase Forward\Central Coding Application folder. However, you can click Change and 
navigate to another location. The folder should not be the same as any other installed instance. 

Note: The instructions, paths, and Start Menu navigation in this guide assume you are 
installing to the default location. Oracle strongly recommends that you install the software 
to the default directory. If you select a different location, the uninstaller might not remove 
all related files during the uninstall process. 

15 Click Next. 

The Central Coding Database User page appears. This page collects the connection string and 
the password for the Oracle SYS user account; the database user and password; and the default 
tablespace for the Central Coding application 

The installation program detects the Oracle home location, finds all currently configured 
connection strings, and presents them in a list. Instead of typing in the connection string, you 
pick it from the list. 

Note: If the connection string that you want to use is not in the list, it means the connection 
has not been set up. 
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16 Select or enter the following database information: 

• Connection string—TNS name to use when connecting to the database. 

Note: You can specify the same connection strings on the Central Coding Database 
User, the Coding Platform Database User, and the Create Coding Dictionary Database 
User pages. To receive the best performance, Oracle recommends that you specify 
different connection strings for each user account. 

• Password for SYS user—Password for the Oracle SYS account. 

The password must contain: 

• One or more alphabetical (A-Z, a-z) and numeric (0-9) characters. 

• At least one non-alphanumeric character. 

• One or more upper case (A-Z) and lower case (a-z) characters. 

• A minimum of 8 characters. 

For more information, see the Secure Configuration Guide. 

• Test Connection—Click to attempt an actual database connection using the selected 
Connection string and Password. You can continue with the installation only after the 
connection test succeeds.  
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Note: If the Oracle system has the authentication mode set to NTS (sqlnet.ora), the 
password supplied will be ignored by Oracle, and the connection test will succeed 
when the NT user has permission to access the SYS user.  

17 If you choose to create a new user, you must also enter data for the default tablespace. If the 
Create/Recreate User option is selected and an existing user is supplied, that user will be 
dropped and re-created.  

Alternatively, the option to reuse an existing user is available. In this case, the database is 
assumed to be present already, and the specified user is not dropped. You can test a connection 
with this user before proceeding. 

Select or enter the following information for the Central Coding Database User: 

Note: All entries used as Oracle database objects (such as user names, passwords, and 
tablespaces) should follow Oracle recommendations for naming conventions. In addition, 
Oracle recommends using strong passwords, as described in the Secure Configuration 
Guide. 

• Create/Recreate User—Select to create a new Central Coding Database User. 

• User Name—Oracle user account name.  

The Central Coding Database User name and the Coding Platform Database User 
name cannot be the same. You enter the Coding Platform Database User name in 
step 19. 

• Password—Password for the Oracle user account. 

The password must contain: 

• One or more alphabetical (A-Z, a-z) and numeric (0-9) characters. 

• At least one non-alphanumeric character. 

• One or more upper case (A-Z) and lower case (a-z) characters. 

• A minimum of 8 characters. 

For more information, see the Secure Configuration Guide. 

• Retype Password—Password for the Oracle user account.  

Note: Do not use Oracle reserved words for the user name or password. 

• Existing User—Select to reuse an existing database user. 

• User Name—Oracle user account name. The list is populated with users from the 
database. 

• Password—Password for the Oracle user account. 

• Test User—Click to test the database connection with this user. 

• Default tablespace—Select the name that was created for the Central Coding application. 

This list is populated from the database. For the example in this guide, that name is 
CODING. For more information, see Create the database and tablespaces (on page 22). 
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Note: This field is not available if you select the Existing User option. 

• Create—Click to create a new tablespace. 

The Create New Default Tablespace dialog box appears. In the Name field, enter a name 
for the tablespace, and click Create. The dialog box closes and the name of the newly 
created tablespace appears in the Default tablespace field on the Central Coding 
Database User page. 

Note: The tablespace that is created is the default size and in the default location. If 
you want the tablespace to be a different size or in a different location, you must 
create the tablespace from the database. 

 

18 Click Next. 

The Coding Platform Database User page appears. This page collects the database user, 
password, and default tablespace for the Central Coding Platform. 

If you choose to create a new user, you must also enter data for the default tablespace. If the 
Create/Recreate User option is selected and an existing user is supplied, that user will be 
dropped and re-created. Alternatively, the option to reuse an existing user is available. In this 
case, the database is assumed to be present already, and the specified user is not dropped. You 
can test a connection with this user before proceeding. 
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19 Select or enter the following information for the Coding Platform Database User: 

Note: All entries used as Oracle database objects (such as user names, passwords, and 
tablespaces) should follow Oracle recommendations for naming conventions. In addition, 
Oracle recommends using strong passwords, as described in the Secure Configuration 
Guide. 

• Connection string—The TNS name to use when connecting to the Platform database. 

Note: You can specify the same connection strings on the Central Coding Database 
User, the Coding Platform Database User, and the Create Coding Dictionary Database 
User pages. To receive the best performance, Oracle recommends that you specify 
different connection strings for each user account. 

• Password for SYS user—The password for the Oracle SYS account. 

• Create/Recreate User—Select to create a new Coding Platform Database User. 

• User Name—The Oracle user account (Example name: codingplatform). 

The Central Coding Database User name and the Coding Platform Database User 
name cannot be the same. You enter the Central Coding Database User name in step 
17. 

• Password—The password for the Oracle user account. 

The password must contain: 

• One or more alphabetical (A-Z, a-z) and numeric (0-9) characters. 

• At least one non-alphanumeric character. 

• One or more upper case (A-Z) and lower case (a-z) characters. 

• A minimum of 8 characters. 

For more information, see the Secure Configuration Guide. 

• Retype Password—The password for the Oracle user account. 

• Existing User—Select to reuse an existing database user. 

• User Name—The Oracle user account name. The list is populated with users from the 
database. 

• Password—The password for the Oracle user account 

• Test User—Click to test the database connection with this user. 

• Default tablespace—Select the name that was created for the Central Coding application. 

This list is populated from the database. For the example in this guide, that name is CCP. 
For more information, see Create the database and tablespaces (on page 22). 

Note: This field is not available if you select the Existing User option. 

• Create—Click to create a new tablespace. 

The Create New Default Tablespace dialog box appears. In the Name field, enter a name 
for the tablespace and click Create. The dialog box closes and the name of the newly 



 Installation Guide  

Oracle® Health Sciences Central Coding 3.0.3 41 

created tablespace appears in the Default tablespace field. 

Note: The tablespace that is created is the default size and in the default location. If 
you want the tablespace to be a different size or in a different location, you must 
create the tablespace from the database. 

20 Click Next. 

The Create Coding Dictionary Database User page appears. This page collects the user and 
password that the Central Coding application will use to connect to the dictionary database. This 
user is not dropped or created, and does not have to exist at the time of the installation. You 
create the dictionary database using the Dictionary Loader tool. For more information, see 
Setting up the dictionary database (on page 61). 

21 Enter the following information: 

Note: All entries used as Oracle database objects (such as user names, passwords, and 
tablespaces) should follow Oracle recommendations for naming conventions. In addition, 
Oracle recommends using strong passwords, as described in the Secure Configuration 
Guide. 

• Connection string—TNS name to use when connecting to the dictionary database. 

Note: You can specify the same connection strings on the Central Coding Database 
User, the Coding Platform Database User, and the Create Coding Dictionary Database 
User pages. To receive the best performance, Oracle recommends that you specify 
different connection strings for each user account. 

• User—Name of the user account for the dictionaries (Example name: codingdictionaries). 

• Password—Password for the user account for the dictionaries. 

The password must contain: 

• One or more alphabetical (A-Z, a-z) and numeric (0-9) characters. 

• At least one non-alphanumeric character. 

• One or more upper case (A-Z) and lower case (a-z) characters. 

• A minimum of 8 characters. 

For more information, see the Secure Configuration Guide. 

• Retype password—Retype the password for the user account for the dictionaries (Example 
name: codingdictionaries). 

Note: Make a note of these values. You must use them when you create the repository for 
the dictionaries and when you connect to the database. For more information, see Creating 
a dictionary repository (on page 61) and Creating a connection to the database (on page 
62). 

22 Click Next. 

The Create Coding Administrator Account page appears. 
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23 Enter the following information, and click Next. 

• User—Name of the initial user account for the Central Coding application. 

• Password—Password for the initial user account. 

The password must contain: 

• One or more alphabetical (A-Z, a-z) and numeric (0-9) characters. 

• At least one non-alphanumeric character. 

• One or more upper case (A-Z) and lower case (a-z) characters. 

• A minimum of 8 characters. 

For more information, see the Secure Configuration Guide. 

• Retype password—Retype the password for the initial user account. 

The Create Job Service Account page appears. 

24 Enter and retype a password for the Job Schedule service, and then click Next. 

The Create Job Schedule Service Account page appears. 

25 Click Choose Certificate. 

A list of X.509 certificates on the machine appears in a new window.  

Note: The certificate is for internal communication only, and must already be installed. For 
more information, see Install a certificate to secure internal communication with the Job 
Scheduler service (on page 25). 

26 Select the certificate to use, and click OK. 

The certificate properties appear on the page. 

27 Click Next. 

The Ready to Install the Program page appears. 

28 Click Install. 

After the installation completes, the Central Coding Installation Wizard Complete page appears. 

29 Click Finish. 
 

Modifying an existing Central Coding application server installation of the same 
version 

Use this procedure to change the feature(s) of the same version of the software that you installed on 
an application server. The combination of features includes: 

• Central Coding Server. 

• Dictionary Loader. 

1 Locate setup.exe. 
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2 Right-click and select Run as administrator. 

The Existing Installed Instances Detected page appears. 

3 Select Maintain or update the instance of this application selected below. 

4 Select the appropriate server, and click Next. 

The Welcome page appears. 

5 Select Modify, and click Next.  

The Select Features page appears. 

6 To modify an application server installation, select the feature(s) to change: 

• Central Coding Server. 

• Dictionary Loader. 

The Dictionary Loader tool must be installed in order to load standard and custom 
dictionaries. However, the Dictionary Loader tool: 

• Does not need to be installed on every machine or on every application server.  

• Can be on a different machine from the Central Coding application server(s). 

• Can be installed without also installing the Central Coding Server. 

If you want to verify whether the Dictionary Loader tool is installed, from the Start Menu, select 
Programs > Phase Forward > Central Coding. If Dictionary Loader appears, it is already installed. 

7 Select the feature(s) that you want to install, deselect the feature(s) that you want to uninstall, and 
click Next. 

The files are updated and the Maintenance Complete page appears. 

8 Click Finish. 
 

Performing an interactive upgrade to the Central Coding 3.0.3 software 
Use this procedure to update the Central Coding software to the current version. The installation 
program verifies the components that are currently installed on your system and prompts you to 
update the existing application instance. 

Note: You can upgrade to the current release from the Central Coding 3.0 SP0, 3.0 SP1, and 
3.0.2 releases. If you are using an earlier version of the Central Coding software you must first 
upgrade to the 3.0 SP0 (or later) release on an English operating system. You cannot perform an 
upgrade to support the Japanese language. To accommodate multilingual studies, you must do a 
complete install of the Central Coding software. 

1 Make sure that the Central Coding release 3.0 SP0, 3.0 SP1, or 3.0.2 software is installed. 

2 Download the Central Coding 3.0.3 ZIP file. 

3 Distribute the Central Coding 3.0.3 ZIP file to every machine where you installed the Central 
Coding software. 

4 If the Central Coding job scheduler service is running, stop the service.  

5 Reset IIS, and restart the World Wide Web Publishing Service. 
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6 Back up the coding database (all schema owners defined for the Central Coding application). 

Oracle recommends that you run a full export of the Central Coding database. 

7 Back up the Central Coding installation directory.  

This creates backup copies of all CONFIG files and can provide information about the Central 
Coding configuration before the upgrade. 

8 Right-click and select Run as administrator. 

The Existing Installed Instances Detected page appears. 

9 Select Maintain or update the instance of this application selected below. 

When an existing instance is selected, the installation program automatically enters the upgrade 
mode. Details about the existing instance are read from the instance itself, so that you do not 
need to supply information again. The installation program: 

• Verifies the updated software prerequisites. 

• Copies over all assemblies and relevant files with the new versions, except for configuration 
files that have been modified since the previous installation. 

• Automatically updates the configuration and database. 

10 Select the application server to upgrade, and click Next. 

The Welcome page appears. 

11 Click Next. 

The Required System Components page appears. 

12 Click Next. 

The Setup Status page appears. When the setup is complete, a command prompt window opens 
that displays the upgrade steps as they occur. When the upgrade is complete, the command 
prompt window closes and the Central Coding Update Wizard Complete page appears. 

The Choose Certificate page appears. 

13 Click Choose Certificate. 

A list of X.509 certificates on the machine appears in a new window.  

Note: The certificate is for internal communication only, and must already be installed. For 
more information, see Install a certificate to secure internal communication with the Job 
Scheduler service (on page 25). 

14 Select the certificate to use, and click OK. 

The certificate properties appear on the page. 

15 Click Finish. 

Note: The upgrade may delete the connections that were defined for the dictionary 
repository. After the upgrade is complete, you can restore the connections using the 
previous user information, and the dictionary repository objects will be available again. For 
more information, see Creating a connection to the database (on page 62). 
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16 Clear the browser's cache on your local machine. 

a Click Tools > Internet Options. 

The Internet Options dialog box appears. 

b In the Browsing history section, click Delete. 

The Delete Browsing History dialog box appears. 

c In the Temporary Internet Files section, click Delete files. 

17 Optionally, before starting the job scheduler, specify the length of time that you want entries in 
the job log to remain in the Central Coding database. 

The PhaseForward.Platform.JobScheduler.exe.config file includes a job entry that manages 
the size of the job log table in the database for scheduled jobs.  

The job runs daily and by default deletes entries that are 45 days old. If you want to keep entries 
in the job log for a different amount of time you must edit the file. The file is in 
...\CentralCodingServer\CodingWebUI\bin. 
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Silent installation or upgrade 

Performing a silent installation 
After you install one instance of the Central Coding software, you can run the silent installation as 
many times as necessary to install additional instances. To perform a silent installation of the Central 
Coding software: 

1 Modify the response file. 

For more information, see Modifying the response file (on page 46). 

2 Run the installation from the command line. 

For more information, see Running the installation (on page 48). 
 

Modifying the response file 
Perform this procedure on each application server. 

Note: All entries used as Oracle database objects (such as user names, passwords, and 
tablespaces) should follow Oracle recommendations for naming conventions. In addition, Oracle 
recommends using strong passwords, as described in the Secure Configuration Guide. 

1 Copy the Central Coding installation folder to your local machine. 

2 Locate the setup.iss response file. 

3 Save the setup.iss response file with a different name.  

Note: Oracle recommends saving the response file with a name that references the Central 
Coding instance with which it is associated. 

4 Modify the response file with the following information: 
 

Parameter Description 
svLanguage Locale: 

• English 

• European 

• Global 

szCompanyName Company name. 

szCompanyURL Company URL. 

szDir 

(First) 

Base installation directory. 

This should match the information you specify in the parameter for 
the Central Coding instance directory. 

instanceName Instance name. 



 Installation Guide  

Oracle® Health Sciences Central Coding 3.0.3 47 

Parameter Description 
svPort TNS port number. 

This must be an empty port that has not been used by any other 
software. 

szDir 

(Second) 

Directory for the Central Coding instance.  

This should match the information you specified in the installation 
directory parameter. 

Central Coding Database 
user parameters 

 

svDBServer Database server connection string for the Central Coding Database 
user. 

svOracleSysPassword Oracle system password. 

svdbUID Central Coding Database user ID. 

svdbPID Central Coding Database user password. 

svDBTablespace Name of the tablespace for the Central Coding database. 

Platform Database user 
parameters 

 

svDBServer Database server connection string for the Platform Database user. 

svOracleSysPassword Oracle system password. 

svdbUID Platform Database user ID. 

svdbPID Platform Database user password. 

svDBTablespace Name of the tablespace for the Platform database. 

Dictionary Database user 
parameters 

 

svDBServer Database server connection string for the Dictionary Database user. 

svdbUID Dictionary Database user ID. 

svdbPID Dictionary Database user password. 

Job Scheduler user 
parameters 

 

svdbPID Job Scheduler user password. 

Certificate parameters  
svCertSubject Certificate subject. 

svCertIssuer Certificate issuer. 

svCertName Certificate name. 

svCertExpiration Certificate expiration date, in the format MM/DD/YYYY H:MM:SS 
AM/PM. 
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Parameter Description 
svCertThumbprint Certificate thumbprint. 

 
 

Running the installation 
1 Open a Command Prompt window and navigate to the installation folder on your local machine. 

2 Run the following command: 

...setup.exe -s -f1"[Location of response file]\[Response file name]" -f2"[Location of log file]\[Log file 
name]" 

where: 

• Location of response file—The directory where the response file you modified exists. 

• Response file name—The name you gave the response file to use during the silent 
installation. 

• Location of log file—The directory where you want the log file to be created.  

• Log file name—The name to give the log file. 

Note: The log file is automatically created during the installation. 

3 After you run the silent installation, Oracle recommends that you check the log file to ensure 
that the installation was successful. For more information, see Checking the log file (on page 
50). 

 

Performing a silent upgrade 
Use this procedure to update the Central Coding software to the current version. The installation 
program verifies the components that are currently installed on your system and prompts you to 
update the existing application instance. 

Note: You can upgrade to the current release from the Central Coding 3.0 SP0, 3.0 SP1, and 
3.0.2 releases. If you are using an earlier version of the Central Coding software you must first 
upgrade to the 3.0 SP0 (or later) release on an English operating system. You cannot perform an 
upgrade to support the Japanese language. To accommodate multilingual studies, you must do a 
complete install of the Central Coding software. 

1 Make sure that the Central Coding release 3.0 SP0, 3.0 SP1, or 3.0.2 software is installed. 

2 Download the Central Coding 3.0.3 ZIP file. 

3 Distribute the Central Coding 3.0.3 ZIP file to every machine where you installed the Central 
Coding software. 

4 If the Central Coding job scheduler service is running, stop the service.  

5 Reset IIS, and restart the World Wide Web Publishing Service. 

6 Back up the coding database (all schema owners defined for the Central Coding application). 

Oracle recommends that you run a full export of the Central Coding database. 

7 Back up the Central Coding installation directory.  
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This creates backup copies of all CONFIG files and can provide information about the Central 
Coding configuration before the upgrade. 

8 Navigate to the installation folder. 

9 Copy the installation folder to your local machine. 

10 Locate the upgrade.iss response file. 

11 In order to successfully run the silent upgrade, you need to know the GUID for the existing 
instance of the Central Coding application that you are upgrading. To find this information: 

a Click Start > Run. 

The Run dialog box appears. 

b Type regedit. 

The Registry Editor dialog box appears. 

c Expand the HKEY_LOCAL_MACHINE_SOFTWARE_PHASEFORWARD node. 

d Locate the instance of the Central Coding application that you are upgrading. 

e Copy the GUID information into a text file so that you can easily copy and paste it into 
the command line during the upgrade. 

12 Open a Command Prompt window and navigate to the installation folder on your local machine. 

13 Run the following command: 

...setup.exe -s -ig[Central Coding instance GUID] -f1"[Location of upgrade response file]\[Response file 
name]" -f2"[Location of the log file]\[Log file name]" 

where: 

• Central Coding instance GUID—GUID for the Central Coding instance to upgrade. 

• Location of response file—The directory where the upgrade response file you modified 
exists. 

• Response file name—The name you gave the upgrade response file to use during the silent 
installation. 

• Location of log file—The directory where you want the upgrade log file to be created. 

Note: The upgrade log file is automatically created during the installation. 

• Log file name—The name to give the upgrade log file. 

14 Clear the browser's cache on your local machine. 

a Click Tools > Internet Options. 

The Internet Options dialog box appears. 

b In the Browsing history section, click Delete. 

The Delete Browsing History dialog box appears. 

c In the Temporary Internet Files section, click Delete files. 

15 After you run the silent upgrade, Oracle recommends that you check the error log to ensure that 
the upgrade was successful. For more information, see Checking the log file (on page 50). 
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Checking the log file 
1 Navigate to the directory in which the response file that you modified exists. 

2 Open the log file with the name you specified during the installation. 

• For successful installations, the log file includes ResultCode=0. 

• For unsuccessful installations, the ResultCode field is populated with a number that specifies 
the type of error that occurred during the installation. 

Note: The error codes in the log file are created by InstallShield. If an error occurs during the 
installation, contact Oracle for details. 
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Verify the installation 
After the application server is created, do the following to verify that the installation was successful: 

• Review the setup log. 

This log contains messages the system generated during the installation. It is available at 
...\Central Coding Application\CentralCodingServer\Setuplog.txt 

If the following message appears in Setuplog.txt it indicates that the block size of the tablespace 
for the Central Coding user is not large enough. For more information, see Mandatory 
database parameters (on page 21). 

      
create index CCA_FLAT_LEVELS_IDX1 on CCA_FLAT_LEVELS (* 
      
ERROR at line 1: 
ORA-01450: maximum key length (6398) exceeded 
 

• In IIS, verify that centralcoding<InstanceName> exists; where <InstanceName> is the Instance 
Name you entered on the Application Instance Settings page during the Central Coding 
installation. 

1 To open IIS, select Start > Settings > Control Panel > Administrative Tools > Internet Information 
Services (IIS).  

2 Double-click the machine name, expand Web Sites > Default Web Sites, and locate 
centralcoding<InstanceName>. 

• Verify that the Dictionary Loader tool is installed.  

If you selected Dictionary Loader on the Select Features page when you installed the Central 
Coding software, the Dictionary Loader tool is available from the Start menu. Select Program 
Files > Phase Forward > Central Coding > Dictionary Loader.  

Note: For instructions on using the Dictionary Loader tool to load and manage the coding 
dictionaries, see Loading and managing the coding dictionaries (on page 55). 
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Repairing an installation 
Use this procedure to re-copy all relevant installation files onto the target machine. This option is 
intended to help if the installation files were corrupted.  

1 Locate setup.exe. 

2 Right-click and select Run as administrator. 

The Existing Installed Instances Detected page appears. 

3 Select Maintain or update the instance of this application selected below. 

4 Select the appropriate server, and click Next. 

The Welcome page appears. 

5 Select Repair, and click Next. 
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Uninstalling a Central Coding application server 
Use this procedure to perform a complete uninstall of the Central Coding software. 

Note: The uninstall procedure does not remove the Central Coding folder from the Start menu. 
You must manually remove this folder. 

1 Locate setup.exe. 

2 Right-click and select Run as administrator. 

The Existing Installed Instances Detected page appears. 

3 Select Maintain or update the instance of this application selected below. 

4 Select the appropriate server, and click Next. 

The Welcome page appears. 

5 Select Remove, and click Next.  

A confirmation dialog box appears. 

6 Click Yes. 

Messages display as the system removes the Central Coding components. When the process is 
complete, the Uninstall Complete page appears. 

7 Select whether to restart the computer now or later, and click Finish. 
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About loading and managing the coding dictionaries 
After you install the Central Coding software, you must load the coding dictionaries on the Central 
Coding application server. 

Note: Coding dictionaries are not included as part of the Central Coding installation; you must 
purchase and install your own coding dictionaries. 
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About dictionary types and dictionary schemas 
A dictionary type is a Central Coding concept that identifies a family of coding dictionaries. 

Dictionary types are defined in XML files that contain the metadata for the dictionary levels and the 
SQL needed to set up the tables in the database. These files also contain the default element 
configuration settings that control which coding features and information are available to users in the 
Central Coding user interface. 

Dictionary schemas are created from dictionary types. Each dictionary version is loaded into a 
separate Oracle database schema. 
 

Standard dictionary type XML files 
The Central Coding software includes XML files for the standard dictionary types in 
...\Central Coding Application\DictionaryLoader\Setup. 

 

Standard dictionary type XML files 

Dictionary type XML file Description 
MedDRA_DictionaryType.xml All versions of MedDRA dictionaries have the dictionary 

type MedDRA. 

MedDRAJ_DictionaryType.xml All versions of MedDRA-J dictionaries have the dictionary 
type MedDRAJ. 

MedDRAJ_ja-JP.xml Used by the Dictionary Loader tool to install the language 
pack for the MedDRA-J dictionary. 

The language pack displays the dictionary level names and 
additional information labels in Japanese in the user 
interface. 

WHO-DD_DictionaryType.xml All versions of WHO-DD dictionaries have the dictionary 
type WHODD. 

JDrug_DictionaryType.xml All versions of JDrug dictionaries have the dictionary type 
JDrug. 

Note: You must rename the dictionary file so that the 
Dictionary Loader tool can recognize the file name. For 
more information, see Renaming the dictionary type file 
for the JDrug dictionary (on page 58). 

JDrug_ja-JP.xml Used by the Dictionary Loader tool to install the language 
pack for the JDrug dictionary. The language pack displays 
the dictionary level names and additional information labels 
in Japanese in the user interface. 
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Custom dictionary type XML files 
For custom dictionaries, you must create the required XML file that defines the dictionary type. For 
more information, see the User Guide.  
 

Renaming the dictionary file for the JDrug dictionary 
The Dictionary Loader tool does not recognize Japanese file names. Therefore, you must rename the 
JDrug dictionary file so that the Dictionary Loader can recognize the file name and load the 
dictionary. 

• Rename, or copy and rename, the JDrug dictionary file ( ) to all_cases.txt. 

Note: Make sure that this file is in a local directory with only English names in its path. 
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About the Dictionary Loader tool 
The Central Coding software includes a stand-alone component, called the Dictionary Loader tool, 
that you use to manage all functions associated with loading and managing the coding dictionaries. 
The Dictionary Loader tool can be installed on a machine as part of the Central Coding software 
installation. 

• The Dictionary Loader tool is installed into the Central Coding application directory and added 
to the Start menu for the Central Coding application. 

The Dictionary Loader tool is accessible only from the Central Coding server. You must have 
server-level access to run the Dictionary Loader tool; you cannot run it from the user interface. 

• Dictionaries can be loaded on the same machine as the Central Coding application or on a 
different machine. 

Coding dictionaries are not included as part of the Central Coding installation; you must 
purchase and install your own coding dictionaries. 

• All dictionaries can be loaded into a single tablespace, or you can create a separate tablespace for 
each dictionary. 

The instructions in this guide assume that all dictionaries are loaded into one tablespace. 

• Dictionaries can be used by multiple application servers. 
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Launching the Dictionary Loader tool 
Use the Dictionary Loader tool for all dictionary installation and maintenance tasks. 

• Select Start > Program Files > Phase Forward > Central Coding > Dictionary Loader. 

The Dictionary Loader dialog box appears. 
 

 
 

• This dialog box remains open when you use the Dictionary Loader tool. 

• The first time you install the Central Coding software, the Data Connections tree in the top 
left pane is empty. 

Information appears in the tree after you create connections to the database. 

Note: When you upgrade the Central Coding software, information about previously 
defined connections appears in the Data Connections tree. The upgrade may delete 
the connections that were defined for the dictionary repository. You can restore the 
connections using the previous user information so that the dictionary repository 
objects become available again. For more information, see Creating a connection to 
the database (on page 62). 

• For each connection, information for the associated Dictionaries and Types appears in the top 
right pane of the dialog box. 

• The Output pane at the bottom of the dialog box displays system messages. 
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Setting up the dictionary database 

Overview of the steps to set up the dictionary database 

Note: Setting up the dictionary database is the same for both standard and custom dictionaries. 

 

Steps to set up the dictionary database 

Step Description 
1 Create a dictionary repository (on 

page 61). 
Use to create a repository in the database to hold the 
dictionaries associated with a connection. 

Although you can create multiple repositories, only 
one repository can be connected at a time. 

2 Create a connection to the 
database (on page 62). 

Use to create a connection to the database. 

Connections are created within repositories. Although 
you can create multiple connections, only one 
connection can be active at a time. 

3 Connect to the database (on page 
63). 

Use to connect to an existing database connection. 

4 View the dictionaries available for 
a database connection (on page 
63). 

Use to view information about the dictionary types 
that are available for a connection. 

5 Import the dictionary type XML 
file (on page 64). 

Use to import the dictionary type XML file for the 
dictionary that you want to load. 

 
 

Creating a dictionary repository 
Use this procedure to create a repository in the database to hold the dictionaries associated with a 
connection. Although you can create multiple repositories, only one repository can be connected at a 
time. 

1 If not already started, launch the Dictionary Loader tool. 

For more information, see Launching the Dictionary Loader tool (on page 60). 

2 Select File > New > Dictionary Repository. 

The New Repository dialog box appears. 

3 Enter the following information:  

The values you enter here must match the values you specified during the Central Coding 
software installation. 

• Oracle Server—Oracle database server connection string. 

• SYS Password—Oracle password.  
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• Schema Owner—Name of the coding dictionary database user. 

• This must be the same name that was entered for the Central Coding Dictionary User 
during the Central Coding installation. 

• This name is also required when creating a connection to the database. 

For more information, see Creating a connection to the database (on page 62). 

• Schema Password and Confirm Schema Password—Password for the coding dictionary 
database user. 

• This must be the same password that was entered for the Central Coding Dictionary 
User during the Central Coding installation. 

• This password is also required when connecting to the database. 

For more information, see Connecting to the database (on page 63). 

• Tablespace—The tablespace for the coding dictionaries. 

The example used in this guide is coding. 

Note: For more information about the Oracle fields, see Create the database and 
tablespaces (on page 22). For instructions on installing the Central Coding software, 
see Installing the Central Coding software (on page 29). 

4 Click OK.  

Messages appear in a window as the repository is created. 

When repository creation is complete: 

• A message appears in the Output pane in the Dictionary Loader tool. 

• The log for the job is available at ...\Central Coding 
Application\DictionaryLoader\Setup\CreateRepository.log. 

 

Creating a connection to the database 
Use this procedure to create a connection to the database. Connections are created within 
repositories. Although you can create multiple connections, only one connection can be active at a 
time. 

Note: If a connection is already active, select File > Disconnect before beginning this procedure. 

1 If not already started, launch the Dictionary Loader tool. 

For more information, see Launching the Dictionary Loader tool (on page 60). 

2 In the Dictionary Loader tool, select File > New > Connection.  

The Connection Information dialog box appears. 

3 Enter the following information: 

• Connection Name—Unique name for the connection. 

• Server—Oracle connection string for the database. 

• User Name—Name of the coding dictionary database user that was created when the 
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repository was set up. 

This is the name you entered in the Schema Owner field in the New Repository dialog 
box. For more information, see Creating a dictionary repository (on page 61). 

Note: For more information about the Oracle fields, see Create the database and 
tablespaces (on page 22). For instructions on installing the Central Coding software, see 
Installing the Central Coding software (on page 29).   

4 Click Save.  

The connection is created. It appears in the Data Connections tree view in the left pane of the 
Dictionary Loader tool dialog box. 

Note: If the connection does not appear in the tree, close the Dictionary Loader tool and 
open it again. 

 

Connecting to the database 
Use this procedure to connect to an existing database connection. 

1 If not already started, launch the Dictionary Loader tool. 

For more information, see Launching the Dictionary Loader tool (on page 60). 

2 In the Dictionary Loader tool, select a connection from the Data Connections tree view in the left 
pane. 

3 Select File > Connect.  

The Connection Information dialog box appears. 

4 Type the password that was created when the repository was set up. 

This is the name you entered in the Schema Password field in the New Repository dialog box. 
For more information, see Creating a dictionary repository (on page 61). 

5 Click Connect.  

When the connection is established: 

• A Dictionaries node is added to the Data Connections tree for this connection. 

Select this node for information about the installed dictionaries. 

• A Types node is added to the Data Connections tree for this connection. 

Select this node for information about the installed dictionary types. 
 

Viewing the dictionary types for a connection 
Use this procedure to view information about the dictionary types that are available for a connection. 
When the dictionary types appear in the Dictionary Loader tool, the Dictionary Types menu options 
are active. 

1 If not already started, launch the Dictionary Loader tool. 
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For more information, see Launching the Dictionary Loader tool (on page 60). 

2 If not already connected, select a connection and connect to the database. 

For more information, see Connecting to the database (on page 63). 

3 In the Data Connections tree in the left pane, select the Types node for the active connection. 

Information about the Dictionary Types for this connection appears in the top pane. 

4 If the dictionary type file for the coding dictionary you want to load does not appear in the 
Dictionary Loader tool, you can import the dictionary type. 

For more information, see Importing the dictionary type file (on page 64). 
 

Importing the dictionary type XML file 
Use this procedure to import the dictionary type XML file for the dictionary that you want to load. 

1 If not already started, launch the Dictionary Loader tool. 

For more information, see Launching the Dictionary Loader tool (on page 60). 

2 If not already connected, select a connection and connect to the database. 

For more information, see Connecting to the database (on page 63). 

3 In the Data Connections tree in the left pane, select the Types node for the active connection. 

Information about the Dictionary Types for this connection appears in the top pane. 

4 Select Dictionary Type > Import.  

The Locate Files dialog box appears. 

5 Browse to the folder that contains the XML file to import.  

The Central Coding software includes XML files for the standard dictionary types in 
...\Central Coding Application\DictionaryLoader\Setup. 

• MedDRA_DictionaryType.xml 

• MedDRAJ_DictionaryType.xml 

• WHODD_DictionaryType.xml 

• JDrug_DictionaryType.xml 

Note: If you created a custom dictionary type, browse to the file you created. For more 
information, see Creating a new dictionary type for a custom dictionary (on page 70). 

6 Select a file and click Open.  

The full path to the XML file appears in the Location field. 

7 Click OK. 

When the import is complete, a message appears in the Output pane and information about the 
dictionary type appears at the top of the Dictionary Types pane. 
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Loading standard dictionaries 

Overview of the steps to load a standard coding dictionary 

Steps to load a standard coding dictionary 

Step Description 
1 If you are using a WHO-DD 

dictionary, determine whether you 
are using a pre-ICH or ICH format 
of the dictionary. 

For more information, see: 

• About pre-ICH and ICH formats of the 
WHO-DD dictionary (on page 65). 

• Loading a pre-ICH version of the WHO-DD 
dictionary (on page 66). 

2 Make sure that the dictionary type 
for the dictionary that you want to 
load has been imported. 

For more information, see Importing the dictionary 
type XML file (on page 64). 

3 Make sure that the dictionary 
connection is established. 

For more information, see Viewing the dictionaries 
available for a database connection (on page 66). 

4 Generate the schema for a 
dictionary (on page 67). 

The Dictionary Loader tool uses dictionary types to 
create dictionary schemas. 

5 Load the dictionary data (on page 
68). 

Use to load dictionary data into the database using the 
schema that was generated when you created a new 
dictionary schema. The dictionary schema must exist 
before you can load data into it. 

6 Activate the dictionary (on page 
68). 

Dictionaries must be activated in order to be used for 
coding. 

 
 

About pre-ICH and ICH formats of the WHO-DD dictionary 
The format of the WHO-DD C dictionary files was changed for compliance with the ICH guidelines 
for drug dictionaries. The Central Coding application ships with the control files for both the pre-
ICH and ICH dictionary formats. You can load either format of the WHO-DD dictionary for use in 
the Central Coding application. 

• ICH format—An ICH version of the WHO-DD dictionary is one released in or after March 
2006. 

The control files for the ICH version of the dictionary are stored in two locations: 

• ...\Central Coding Application\Dictionary Loader\bin\setup\control files\whodd 

• ...\Central Coding Application\Dictionary Loader\bin\setup\control files\whodd\ICH 

The Central Coding application is set up by default to use the ICH version of the WHO-DD 
dictionary. Therefore, if you want to use this dictionary format, no changes to the control files 
are required. 

• Pre-ICH format—A pre-ICH version of the WHO-DD dictionary is one released prior to 
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March 2006. 

The control files for the pre-ICH version of the dictionary are stored in: 

• ...\Central Coding Application\Dictionary Loader\bin\setup\control files\whodd\Pre-ICH 

If you want to use this dictionary format, you must copy the control files to a different directory. 

For more information, see Loading a pre-ICH version of the WHO-DD dictionary (on page 
66). 

 

Loading a pre-ICH version of the WHO-DD dictionary 

Note: Use this procedure only if you plan to load a pre-ICH version of the WHO-DD dictionary. A 
pre-ICH version of the WHO-DD dictionary is one released prior to March 2006. 

1 Navigate to ...\Central Coding Application\DictionaryLoader\bin\setup\control files\whodd. 

2 Delete the control files (CTRL) from the whodd directory. 

The control files for the ICH dictionary format are also stored in ...\Central Coding 
Application\Dictionary Loader\bin\setup\control files\whodd\ICH so that they are available if 
you decide to use the ICH dictionary format at a later time. 

3 Navigate to ...\Central Coding Application\DictionaryLoader\bin\setup\control files\whodd\Pre-ICH 
and copy the CTRL files into the ...\Central Coding Application\DictionaryLoader\bin\setup\control 
files\whodd directory. 

 

Viewing the dictionaries available for a database connection 

Note: When the Dictionaries node is selected, the Dictionary menu options are active. 

1 If not already started, launch the Dictionary Loader tool. 

For more information, see Launching the Dictionary Loader tool (on page 60). 

2 If not already connected, select a connection and connect to the database. 

For more information, see Connecting to the database (on page 63). 

3 In the Data Connections tree in the left pane, select the Dictionaries node for the active 
connection.  

The Dictionaries pane displays one row of information for every dictionary associated with this 
connection. 
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Dictionary statuses 

Dictionary statuses 

Status Description 
DEFINED The type, version, culture, and schema that hold data for the dictionary are 

defined. Data is not loaded into the schema. 

LOADED Data is loaded into the schema for the defined dictionary. 

ACTIVE The dictionary is defined, data is loaded into the schema, and the dictionary is 
available for coding. Only dictionaries with an ACTIVE status are available for 
coding. 

INACTIVE The dictionary is defined and data is loaded into the schema, but the dictionary 
is not available for coding. 

REMOVED The schema and data associated with the dictionary are deleted. 

 
 

Generating the schema for the dictionary data 

Note: The Dictionary Loader tool uses dictionary types to create dictionary schemas. 

1 If not already started, launch the Dictionary Loader tool. 

For more information, see Launching the Dictionary Loader tool (on page 60). 

2 If not already connected, select a connection and connect to the database. 

For more information, see Connecting to the database (on page 63). 

3 Verify that the dictionary type for the dictionary that you want to create has been imported. 

If necessary, import the dictionary type. For more information, see Importing the dictionary 
type file (on page 64). 

4 In the Data Connections tree in the left pane, select the Dictionaries node for the active 
connection. 

Information about the Dictionary Types for this connection appears in the top pane. 

5 Select File > New > Dictionary.  

The New Dictionary dialog box appears. 

6 Enter the following information: 

• Type—Dictionary type that exists for this connection. Standard dictionary types are 
WHO-DD and MedDRA. If you imported custom types, they appear in the drop-down list. 

• Version—The version of the dictionary. For example, 06Q4 identifies the 2006 Q4 version 
for WHO-DD; 9.1 identifies the 9.1 version for MedDRA. 30 characters maximum. 

• Culture—The culture setting for the dictionary data. For example, en-US. 10 characters 
maximum. 

• Punctuation Filter—The characters that are to be considered as punctuation by the coding 
algorithm in the step that removes punctuation. OPTIONAL. 100 characters maximum. 
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• Description—A brief description of the dictionary. OPTIONAL. 200 characters maximum. 

• Owner for Schema—The unique name for the schema.  

• Schema Password—The password for this dictionary schema. 

• Confirm Schema Password—The password for this dictionary schema. 

• SYS Password—The password for the Oracle user account.  

• Tablespace—The name of the tablespace that was created for the dictionaries. 

7 Click OK. 

When the dictionary has been created, a message appears in the Output pane and information 
about the dictionary appears in the Dictionaries list in the top pane in the Dictionary Loader 
tool. 

 

Loading dictionary data 
Use this procedure to load dictionary data into the database using the schema that was generated 
when you created a new dictionary schema. The dictionary schema must exist before you can load 
data into it. For more information, see Generating the schema for a dictionary (on page 67). 

1 If not already started, launch the Dictionary Loader tool. 

For more information, see Launching the Dictionary Loader tool (on page 60). 

2 If not already connected, select a connection and connect to the database. 

For more information, see Connecting to the database (on page 63). 

3 In the Data Connections tree in the left pane, select the Dictionaries node for the active 
connection. 

Information about the Dictionaries for this connection appears in the top pane. 

4 In the Dictionaries pane, select the dictionary into which you want to load data. 

5 Select Dictionary > Load.  

The Locate Files dialog box appears. 

6 Enter the following information: 

• Location—Browse to the folder that contains the file with the dictionary data to load. 

Select a directory and click Open. The full path to the files appears in the Location field. 

• Dictionary schema password—Password for this dictionary schema, which was created 
when the dictionary was created. 

7 Click OK.  

The dictionary data loads. Messages appear in the Output pane in the Dictionary Loader tool. 
When the load is complete, you can check the log file to verify the status of the load operation. 
The log file is in ...\DictionaryLoader\Setup\gather_stats_[schemaowner].log. 
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Activating the dictionary 

Note: Dictionaries must have a status of ACTIVE in order to be available for coding. 

1 If not already started, launch the Dictionary Loader tool. 

For more information, see Launching the Dictionary Loader tool (on page 60). 

2 If not already connected, select a connection and connect to the database. 

For more information, see Connecting to the database (on page 63). 

3 In the Data Connections pane, select a connection. 

4 Select Dictionary > Activate.  

The dictionary status changes to ACTIVE. The dictionary is defined, data is loaded into the 
schema, and the dictionary is available for coding. Only dictionaries with an ACTIVE status are 
available for coding. 
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Loading custom dictionaries 

Overview of the steps to load a custom dictionary 

Steps to load a custom coding dictionary 

Step Description 
1 Create a custom dictionary 

definition XML file (on page 70). 
Use to create an XML file that contains the metadata 
for the dictionary levels and the SQL needed to set up 
the tables in the database. 

2 Create a new dictionary type for a 
custom dictionary. 

For more information, see Creating a new 
dictionary type for a custom dictionary (on page 
70). 

3 Import the dictionary type XML file. For more information, see Importing the dictionary 
type XML file (on page 64). 

4 View the dictionaries available for a 
database connection. 

For more information, see Viewing the dictionaries 
available for a database connection (on page 63). 

5 Generate the schema for a 
dictionary (on page 67). 

The Dictionary Loader tool uses dictionary types to 
create dictionary schemas. 

6 Load dictionary data (on page 68). Use to load dictionary data into the database using the 
schema that was generated when you created a new 
dictionary schema. 

The dictionary schema must exist before you can load 
data into it. 

7 Activate the dictionary (on page 
68). 

Dictionaries must be activated in order to be used for 
coding. 

8 Create custom icons for the 
coding browser (on page 76). 

Use to create custom dictionary icons for use in the 
coding browser Browse mode. 

 
 

Creating a custom dictionary definition XML file 
Use the standard XML files for the MedDRA, MedDRA-J, WHO-DD, and JDrug dictionaries as the 
basis for your custom XML files. These files are in 
...Central Coding Application\DictionaryLoader\Setup. 

For the DictionaryType element: 

• adaptertype sub-element must be Custom. 

• numlevels must be greater than 0 and must equal the number of Level elements. 
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Creating a new dictionary type for a custom dictionary 
1 If not already started, launch the Dictionary Loader tool. 

For more information, see Launching the Dictionary Loader tool (on page 60).  

2 If not already connected, select a connection and connect to the database. 

For more information, see Connecting to the database (on page 63). 

3 Select the Types node for the active connection from the Data Connections tree in the left pane.  

Information about the Dictionary Types for this connection appears in the top pane. 

4 Select File > New > New Dictionary Type.  

The New Type dialog box appears.  

When working in the grid: 

• Each row represents one level in the dictionary. 

• Use the buttons to add and remove levels and to change the order of levels for the 
dictionary type. 

• Create at least one level. 

• Create the same number of terms (one or two) at each level. 

5 Enter the following information: 

• Type—The name for the new dictionary type. 

• Description—A description of the dictionary type. OPTIONAL. 

• Supports Stopwords—Select if you want to run the algorithm step(s) that remove 
stopwords from the text to be coded for dictionaries of this type. 

• Term—A label for the first term of this level. 

• Additional Information—A label for each additional level of the dictionary. Separate each 
additional information item with a pipe ( | ). 

• Abbreviation—An abbreviated name to identify this level. 

The full name of this level is the label for the first term, concatenated with the label for the 
second term. 

• Tablename—The name of the table to create in the schema of a dictionary of this type to 
hold data for this level. 

• Filename—The name of the flat file that contains the data for this level. 

• Encoding—The encoding type of the file specified in the Filename field. OPTIONAL. 

If not specified, the default encoding type is used. 

• Delimiter—The field delimiter used in records in the file specified in the Filename field. 
OPTIONAL. 

If not specified, the default delimiter is used. 

6 Click OK.  

The custom dictionary type is added to the Dictionary Types pane in the Dictionary Loader tool. 
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Importing the dictionary type XML file 
Use this procedure to import the dictionary type XML file for the dictionary that you want to load. 

1 If not already started, launch the Dictionary Loader tool. 

For more information, see Launching the Dictionary Loader tool (on page 60). 

2 If not already connected, select a connection and connect to the database. 

For more information, see Connecting to the database (on page 63). 

3 In the Data Connections tree in the left pane, select the Types node for the active connection. 

Information about the Dictionary Types for this connection appears in the top pane. 

4 Select Dictionary Type > Import.  

The Locate Files dialog box appears. 

5 Browse to the folder that contains the XML file to import.  

The Central Coding software includes XML files for the standard dictionary types in 
...\Central Coding Application\DictionaryLoader\Setup. 

• MedDRA_DictionaryType.xml 

• MedDRAJ_DictionaryType.xml 

• WHODD_DictionaryType.xml 

• JDrug_DictionaryType.xml 

Note: If you created a custom dictionary type, browse to the file you created. For more 
information, see Creating a new dictionary type for a custom dictionary (on page 70). 

6 Select a file and click Open.  

The full path to the XML file appears in the Location field. 

7 Click OK. 

When the import is complete, a message appears in the Output pane and information about the 
dictionary type appears at the top of the Dictionary Types pane. 

 

Viewing the dictionary types for a connection 
Use this procedure to view information about the dictionary types that are available for a connection. 
When the dictionary types appear in the Dictionary Loader tool, the Dictionary Types menu options 
are active. 

1 If not already started, launch the Dictionary Loader tool. 

For more information, see Launching the Dictionary Loader tool (on page 60). 

2 If not already connected, select a connection and connect to the database. 

For more information, see Connecting to the database (on page 63). 

3 In the Data Connections tree in the left pane, select the Types node for the active connection. 
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Information about the Dictionary Types for this connection appears in the top pane. 

4 If the dictionary type file for the coding dictionary you want to load does not appear in the 
Dictionary Loader tool, you can import the dictionary type. 

For more information, see Importing the dictionary type file (on page 64). 
 

Dictionary statuses 

Dictionary statuses 

Status Description 
DEFINED The type, version, culture, and schema that hold data for the dictionary are 

defined. Data is not loaded into the schema. 

LOADED Data is loaded into the schema for the defined dictionary. 

ACTIVE The dictionary is defined, data is loaded into the schema, and the dictionary is 
available for coding. Only dictionaries with an ACTIVE status are available for 
coding. 

INACTIVE The dictionary is defined and data is loaded into the schema, but the dictionary 
is not available for coding. 

REMOVED The schema and data associated with the dictionary are deleted. 

 
 

Generating the schema for the dictionary data 

Note: The Dictionary Loader tool uses dictionary types to create dictionary schemas. 

1 If not already started, launch the Dictionary Loader tool. 

For more information, see Launching the Dictionary Loader tool (on page 60). 

2 If not already connected, select a connection and connect to the database. 

For more information, see Connecting to the database (on page 63). 

3 Verify that the dictionary type for the dictionary that you want to create has been imported. 

If necessary, import the dictionary type. For more information, see Importing the dictionary 
type file (on page 64). 

4 In the Data Connections tree in the left pane, select the Dictionaries node for the active 
connection. 

Information about the Dictionary Types for this connection appears in the top pane. 

5 Select File > New > Dictionary.  

The New Dictionary dialog box appears. 

6 Enter the following information: 

• Type—Dictionary type that exists for this connection. Standard dictionary types are 
WHO-DD and MedDRA. If you imported custom types, they appear in the drop-down list. 

• Version—The version of the dictionary. For example, 06Q4 identifies the 2006 Q4 version 
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for WHO-DD; 9.1 identifies the 9.1 version for MedDRA. 30 characters maximum. 

• Culture—The culture setting for the dictionary data. For example, en-US. 10 characters 
maximum. 

• Punctuation Filter—The characters that are to be considered as punctuation by the coding 
algorithm in the step that removes punctuation. OPTIONAL. 100 characters maximum. 

• Description—A brief description of the dictionary. OPTIONAL. 200 characters maximum. 

• Owner for Schema—The unique name for the schema.  

• Schema Password—The password for this dictionary schema. 

• Confirm Schema Password—The password for this dictionary schema. 

• SYS Password—The password for the Oracle user account.  

• Tablespace—The name of the tablespace that was created for the dictionaries. 

7 Click OK. 

When the dictionary has been created, a message appears in the Output pane and information 
about the dictionary appears in the Dictionaries list in the top pane in the Dictionary Loader 
tool. 

 

Loading dictionary data 
Use this procedure to load dictionary data into the database using the schema that was generated 
when you created a new dictionary schema. The dictionary schema must exist before you can load 
data into it. For more information, see Generating the schema for a dictionary (on page 67). 

1 If not already started, launch the Dictionary Loader tool. 

For more information, see Launching the Dictionary Loader tool (on page 60). 

2 If not already connected, select a connection and connect to the database. 

For more information, see Connecting to the database (on page 63). 

3 In the Data Connections tree in the left pane, select the Dictionaries node for the active 
connection. 

Information about the Dictionaries for this connection appears in the top pane. 

4 In the Dictionaries pane, select the dictionary into which you want to load data. 

5 Select Dictionary > Load.  

The Locate Files dialog box appears. 

6 Enter the following information: 

• Location—Browse to the folder that contains the file with the dictionary data to load. 

Select a directory and click Open. The full path to the files appears in the Location field. 

• Dictionary schema password—Password for this dictionary schema, which was created 
when the dictionary was created. 

7 Click OK.  

The dictionary data loads. Messages appear in the Output pane in the Dictionary Loader tool. 
When the load is complete, you can check the log file to verify the status of the load operation. 
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The log file is in ...\DictionaryLoader\Setup\gather_stats_[schemaowner].log. 
 

Activating the dictionary 

Note: Dictionaries must have a status of ACTIVE in order to be available for coding. 

1 If not already started, launch the Dictionary Loader tool. 

For more information, see Launching the Dictionary Loader tool (on page 60). 

2 If not already connected, select a connection and connect to the database. 

For more information, see Connecting to the database (on page 63). 

3 In the Data Connections pane, select a connection. 

4 Select Dictionary > Activate.  

The dictionary status changes to ACTIVE. The dictionary is defined, data is loaded into the 
schema, and the dictionary is available for coding. Only dictionaries with an ACTIVE status are 
available for coding. 
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Using custom icons in the coding browser 
The coding browser in the Central Coding application displays icons for the levels of the coding 
dictionary. When you create a custom dictionary, you must also provide the icons for the coding 
browser. 

To identify the custom dictionary icons to use in the coding browser: 

1 Copy the graphics for the icons to the Resources folder in the virtual directory where the Central 
Coding application is running.  

2 Use the following naming convention for the custom icons: 
<dictionary type>_<tablename for the level>.gif 

where: 

• <dictionary type> is the name of the XML file that defines the dictionary type. 

For more information, see Creating a custom dictionary definition XML file (on page 
70). 

• <tablename for the level> is the name of the Oracle table, where the data for that level is 
stored. 

For example, if a custom dictionary type XML file is named CustomTest.xml and it has three 
levels named soc, pt, and llt, name the icons for the levels as follows: 

• CustomTest_soc.gif 

• CustomTest_pt.gif 

• CustomTest_llt.gif 
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Installing the language packs for the Japanese dictionaries 
Use this procedure to install the language pack for the MedDRA-J or JDrug dictionary. The language 
pack displays the dictionary level names and additional information labels in Japanese in the user 
interface. 

1 If not already started, launch the Dictionary Loader tool. 

For more information, see Launching the Dictionary Loader tool (on page 60). 

2 Make sure that the dictionary database is set up, that you are connected to the database, and that 
the dictionary or dictionaries are loaded. 

For more information, see Setting up the dictionary database (on page 61) and Loading 
dictionaries (on page 55). 

3 In the Data Connections tree in the left pane, select the Types node for the active connection. 

Information about the Dictionary Types for this connection appears in the top pane. 

4 Select the Dictionary Type for which you want to install the language pack. 

5 Select Dictionary Type > Localized Elements. 

The Localized Elements dialog box appears. 

6 Click Import. 

The Locate Files dialog box appears. 

7 Browse to the <LanguagePack>.xml file that you want to install. 

The Central Coding software includes XML files for the standard dictionary types in 
...\Central Coding Application\DictionaryLoader\Setup. 

• MedDRA_ja-JP.xml 

• JDrug_ja-JP.xml 

8 Click OK. 
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Maintaining the coding dictionaries 

Overview of the coding dictionary maintenance tasks 
You can perform the following dictionary maintenance tasks: 

• Change the punctuation filter for a dictionary type (on page 78). 

• Update a dictionary type (on page 79). 

• Delete a dictionary type (on page 80). 

• Inactivate a dictionary (on page 81). 

• Delete a connection to the database (on page 81). 

• Remove a dictionary schema (on page 81). 

• Revive a dictionary schema (on page 82). 

• Delete a dictionary (on page 83). 
 

Changing the punctuation filter for a dictionary type 
Use this procedure to change the characters in the punctuation filter for a dictionary type. The 
punctuation filter identifies characters that you want the coding algorithm to consider as punctuation 
in the step that removes punctuation. 

1 If not already started, launch the Dictionary Loader tool. 

For more information, see Launching the Dictionary Loader tool (on page 60). 

2 If not already connected, select a connection and connect to the database. 

For more information, see Connecting to the database (on page 63). 

3 Select the Types node for the active connection from the Data Connections tree in the left pane.  

Information about the Dictionary Types for this connection appears in the top pane. 

4 Select a row to select the dictionary type that you want to modify.  

An arrow appears in the column to the left of the Type column. 

5 Select Dictionary > Change Punctuation Filter.  

The Punctuation Filter dialog box appears.  

6 Add or remove characters as necessary. 

7 Click OK. 
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Updating a dictionary type and applying the changes to installed dictionaries 
Use this procedure to apply changes from a <Dictionary_Type>.xml file to installed dictionaries. For 
more information, see About dictionary types (on page 57) and the User Guide. 

Note: The <Dictionary_Type>.xml file contains, among other things, the element configuration 
settings for each dictionary type (MedDRA, MedDRA-J, WHO-DD, JDrug, and custom). These 
settings control which coding features and information are available to users in the Central 
Coding user interface. For more information, see the User Guide. 

1 If not already started, launch the Dictionary Loader tool. 

For more information, see Launching the Dictionary Loader tool (on page 60). 

2 If not already connected, select a connection and connect to the database. 

For more information, see Connecting to the database (on page 63). 

3 Select the Types node for the active connection. 

4 Select a dictionary type. 

5 Select Dictionary Type > Update. 

The Locate Files dialog box appears. 

6 Browse to the <Dictionary_Type>.xml file that you want to use for the update. 

The Central Coding software includes XML files for the standard dictionary types in 
...\Central Coding Application\DictionaryLoader\Setup. 

• MedDRA_DictionaryType.xml 

• MedDRAJ_DictionaryType.xml 

• WHODD_DictionaryType.xml 

• JDrug_DictionaryType.xml 

If you are using a custom dictionary type, browse to the file you created. For more information, 
see Creating a new dictionary type for a custom dictionary (on page 70). 

7 Click OK. 

The Dictionary Selection Form dialog box appears. 

8 Select one or more versions of the dictionary. 

9 Click OK. 
 

Converting the WHO-DD dictionary to C format 

Using the Dictionary Loader to convert the WHO-DD dictionary to C format 
Use this procedure to convert a WHO-DD dictionary in B format to C format. 

1 If not already started, launch the Dictionary Loader tool. 

For more information, see Launching the Dictionary Loader tool (on page 60). 

2 If not already connected, select a connection and connect to the database. 
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For more information, see Connecting to the database (on page 63). 

3 In the Data Connections tree in the left pane, select the Dictionaries node for the active 
connection. 

Information about the dictionaries for this connection appears in the top pane. 

4 Select the WHO-DD B format dictionary. 

5 Select Dictionary > Convert WHODD B to C. 

The Locate File dialog box appears. 

6 Click Browse and locate the folder that contains WHO-DD B format dictionary files. 

7 Select the directory and click Open.  

The full path to the files appears in the Location field. 
 

Using the ConvertToC utility to convert the WHO-DD dictionary to C format 
Use this procedure to convert a WHO-DD dictionary in B format to C format. 

1 Open a Command Prompt window and type the name of the drive in which the executable file is 
installed. 

Note: By default, the executable file is installed in the same location as the Central Coding 
application. 

2 Type the location of the executable file in the drive that you specified. 

3 Type the following syntax for converting the WHO-DD B format dictionary to C format: 

ConvertToC [File Path] 

where 

• File Path—Path for the location of the WHO-DD B format dictionary files. 

The ConvertToC utility creates a folder called C in the folder in which the WHO-DD B format 
dictionary files are installed. 

 

Deleting a dictionary type 
Use this procedure to delete a dictionary type. You can delete dictionary types that do not have 
schemas associated with them. If a dictionary schema that uses this dictionary type exists, you must 
delete the schema before you can delete the dictionary type. For more information, see Removing a 
dictionary schema (on page 81). 

1 If not already started, launch the Dictionary Loader tool. 

For more information, see Launching the Dictionary Loader tool (on page 60). 

2 If not already connected, select a connection and connect to the database. 

For more information, see Connecting to the database (on page 63). 

3 In the Data Connections tree in the left pane, select the Types node for the active connection. 

Information about the Dictionary Types for this connection appears in the top pane. 

4 Select Dictionary Type > Delete.  
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A confirmation dialog box appears. 

5 Click Yes. 
 

Inactivating a dictionary 
Use this procedure to inactivate a dictionary. Inactive dictionaries remain in the list of dictionaries for 
a connection and can be reactivated if necessary. 

Note: You must inactivate a dictionary before you can delete it. 

1 If not already started, launch the Dictionary Loader tool. 

For more information, see Launching the Dictionary Loader tool (on page 60). 

2 If not already connected, select a connection and connect to the database. 

For more information, see Connecting to the database (on page 63). 

3 Select the Dictionaries node for the active connection. 

4 Select a dictionary. 

5 Select Dictionary > Inactivate.  

The dictionary status changes to INACTIVE. The dictionary is defined and data is loaded into 
the schema, but the dictionary is not available for coding. 

 

Deleting a connection to the database 
Use this procedure to delete a connection to the database. Deleted connections remain visible in the 
Data Connections tree view in the left pane of the Dictionary Loader tool until you close the dialog 
box. 

1 If not already started, launch the Dictionary Loader tool. 

For more information, see Launching the Dictionary Loader tool (on page 60). 

2 If not already connected, select a connection and connect to the database. 

For more information, see Connecting to the database (on page 63). 

3 Select Connection > Delete. 
 

Removing a dictionary schema 
Use this procedure to remove a dictionary, which removes the dictionary schema and all data. When 
you remove a dictionary schema, all synonym lists, coding definitions, assignment rules, and requests 
entered against the dictionary are lost and cannot be retrieved. 

Caution: Oracle recommends that you do not remove the dictionary schema or delete a dictionary 
that has been used for coding. Only delete dictionaries that you have set up but not coded 
against. 

1 If not already started, launch the Dictionary Loader tool. 
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For more information, see Launching the Dictionary Loader tool (on page 60). 

2 If not already connected, select a connection and connect to the database. 

For more information, see Connecting to the database (on page 63). 

3 Make sure that you have inactivated the dictionary whose dictionary schema you want to remove. 

For more information, see Inactivating a dictionary (on page 81). 

4 Select the Dictionaries node for the active connection. 

5 Select a dictionary to remove. 

6 Select Dictionary > Remove. 

A confirmation dialog box appears. 

7 Click Yes.  

A dialog box appears and prompts you for the SYS user password. 

8 Enter the password and click OK. 

The dictionary remains in the list of Dictionaries. The dictionary status changes to REMOVED. 

Note: You must revive this dictionary type before you can use it again to load dictionaries. 
For more information, see Reviving a dictionary schema (on page 82). 

 

Reviving a dictionary schema 
Use this procedure to revive a dictionary schema, which recreates the schema of a previously 
removed dictionary. For more information, see Removing a dictionary schema (on page 81). After 
reviving a dictionary schema, you can load data into the dictionary. 

1 If not already started, launch the Dictionary Loader tool. 

For more information, see Launching the Dictionary Loader tool (on page 60). 

2 If not already connected, select a connection and connect to the database. 

For more information, see Connecting to the database (on page 63). 

3 Select the Dictionaries node for the active connection. 

4 Select a dictionary.  

You can only revive dictionaries that have a status of REMOVED. 

5 Select Dictionary > Revive. 

The New Dictionary dialog box appears. The information in most fields is read-only because it 
already exists in the database. 

6 Enter the following information, and click OK. 

• Schema Password—The password for this dictionary schema. 

• Confirm Schema Password—The password for this dictionary schema. 

• SYS Password—The password for the Oracle user account. 

• Tablespace—The name of the tablespace that was created for the dictionaries. 
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Deleting a dictionary 
Use this procedure to permanently remove a dictionary from the Central Coding system. Deleted 
dictionaries cannot be revived or reactivated. When you delete a dictionary, all synonym lists, coding 
definitions, assignment rules, and requests entered against the dictionary become invalid and cannot 
be retrieved. 

Caution: Oracle recommends that you do not remove the dictionary schema or delete a dictionary 
that has been used for coding. Only delete dictionaries that you have set up but not coded 
against. 

1 If not already started, launch the Dictionary Loader tool. 

For more information, see Launching the Dictionary Loader tool (on page 60). 

2 If not already connected, select a connection and connect to the database. 

For more information, see Connecting to the database (on page 63). 

3 Make sure that you have removed the schema for the dictionary that you want to delete. 

For more information, see Removing a dictionary schema (on page 81). 

4 Select the Dictionaries node for the active connection. 

5 Select a dictionary.  

6 Select Dictionary > Delete. 

A confirmation dialog box appears. 

7 Click Yes.  

A dialog box appears and prompts you for the SYS user password. 

8 Enter the password and click OK. 
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Using the Data Installer 

About the Data Installer 
The Central Coding software includes a command line application, called the Data Installer, that you 
can use to import data instead of entering the data through the user interface, and to export the data.  

The Data Installer is installed automatically as part of the Central Coding software installation in 
...\Central Coding Application\CentralCodingServer\CodingWebUI\bin.  

You can use the Data Installer to: 

• Export and import synonym lists, stopword lists, coding algorithms, and coding definitions. 

Note: You cannot update coding definitions. You can replace or update a synonym list. 

• Import assignment rules.  

Note: You cannot update assignment rules. 

• Export and import security data such as users, rights, roles, and workteams from an existing 
installation to another installation. 

Note: Security data cannot be created manually. You must export it and then import it to 
the new instance. 

• Export and import system settings such as the authentication options, application settings and 
lock management options, and impact analysis options from an existing installation to another 
installation. 

Note: Oracle recommends that you use the Data Installer to export data from a configured 
instance of the Central Coding application, and import the data file as is, or edit it and perform an 
update. Oracle does not recommend creating your own configuration file for import. 

 

Data Installer modes 
The Data Installer has three modes:  

• Download—Used to export data from the Central Coding application. 

When you export data using the Download mode, an export configuration XML file is created. 
You can use this file with the Data Installer to import or update data in the Central Coding 
application. 

• Setup—Used to import data into the Central Coding application. 

To import data in the Central Coding application, you can use the export configuration XML file 
that is created when you run the Data Installer in Download mode, a manually created XML 
configuration file, or the sample XML configuration file called MasterConfig.xml, which you 
can edit as needed.  

• Update—Used to update existing data in the Central Coding application. 

To update data in the Central Coding application, you can use the export configuration XML file 
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that is created when you run the Data Installer in Download mode, a manually created XML 
configuration file, or the sample XML configuration file called MasterConfig.xml, which you 
can edit as needed. 

Note: The sample XML file is installed in the same location as the Data Installer. 

 

Data Installer parameters 
 

Parameter Description 
ApplicationName Name of the Central Coding application. The application name is 

located in the PhaseForward.Platform.Config.xml file, which is 
installed in the same directory as the Data Installer. The default 
application name is CentralCodingApplication.  

Mode Type of action to perform. The available options are: 

• Download—Export data from the Central Coding application. 

• Setup—Import data to the Central Coding application. 

• Update—Update existing data in the Central Coding application. 

Note: When using the Data Installer in Update mode, make sure 
that the GUIDs for the data in the update configuration file do not 
already exist in the Central Coding application. If duplicate GUIDs 
exist, the Data Installer displays an error message and the update 
does not complete.  

Type Always SysConfig. 

MasterFile Path to the master configuration file, called MasterConfig.xml. The 
master configuration file is installed in the same directory as the Data 
Installer. 

/DISABLESINGLETRA
NSACTION 

Instructs the Data Installer to execute each transaction separately. By 
default, the Data Installer executes all commands in a single 
transaction. 
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Exporting data with the Data Installer 
To export data from an instance of the Central Coding application, use the Data Installer in 
Download mode. You can export synonym lists, stopword lists, coding algorithms, coding 
definitions, and system settings. 

1 Specify the data to export: 

• Edit an existing configuration file. 

• Create a configuration file. 

Make sure to specify the directory path in which to generate the export files. 

Note: The directory must exist before you run the Data Installer. 

2 Open a Command Prompt window and type the name of the drive in which the Data Installer is 
installed. 

3 Type the location of the Data Installer in the drive you specified: 

...\Central Coding Application\CentralCodingServer\CodingWebUI\bin 

4 Run the utility in Download mode, using the following syntax: 
PhaseForward.Platform.Installation.DataInstaller.exe [ApplicationName] 
[Download] [SysConfig] [MasterFile] 

where:  

• ApplicationName—Name of the Central Coding application. The application name is 
located in the PhaseForward.Platform.Config config file, which is installed in the 
same directory as the Data Installer. The default application name is 
CentralCodingApplication.  

• MasterFile—Path to the master configuration file. The master configuration file is 
called MasterConfig.xml, and is located in the same directory as the Data Installer. 

The Data Installer extracts the data and generates the XML files in the directory that you 
specified in the export configuration file. 
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Importing data with the Data Installer 
To import data into an instance of the Central Coding application, use the Data Installer in Setup 
mode. You can import users, roles, workteams, assignment rules, synonym lists, stopword lists, 
coding algorithms, and coding definitions. 

Note: You cannot import an object if its GUID is already used in the database into which you are 
importing. If duplicate GUIDs exist, an error message appears, and the import stops. 

1 Specify the data to import: 

• Edit an existing configuration file. 

• Create a configuration file. 

• Locate an existing export file. 

For more information about the export procedure, see Exporting data with the Data 
Installer (on page 87). 

Note: Oracle recommends that you use the Data Installer to export data from a configured 
instance of the Central Coding application, and import the data file as is, or edit it and 
perform an update. Oracle does not recommend creating your own configuration file for 
import. 

Make sure to specify the directory path of the file to import. 

Note: Data in XML files is case-sensitive. 

2 Open a Command Prompt window and type the name of the drive in which the Data Installer is 
installed. 

3 Type the location of the Data Installer in the drive you specified: 

...\Central Coding Application\CentralCodingServer\CodingWebUI\bin 

4 Run the utility in Setup mode, using the following syntax: 
PhaseForward.Platform.Installation.DataInstaller.exe [ApplicationName] 
[Setup] [SysConfig] [MasterFile] 
where:  

• ApplicationName—Name of the Central Coding application. The application name is 
located in the PhaseForward.Platform.Config config file, which is installed in the 
same directory as the Data Installer. The default application name is 
CentralCodingApplication.  

• MasterFile—Path to the master configuration file. The master configuration file is 
called MasterConfig.xml, and is located in the same directory as the Data Installer. 

The Data Installer adds the data to the appropriate tables in the target Central Coding database, 
based on the import data type. 

 



Chapter 6  Setting up coding metadata using the command line  
 

90 Oracle® Health Sciences Central Coding 3.0.3 

Updating data with the Data Installer 
To update existing data in the Central Coding application using the Data Installer, run the utility in 
Update mode. You can update users, roles, workteams, synonym lists, stopword lists, coding 
algorithms, and system settings. You cannot update coding definitions or assignment rules. 

Note: You cannot import an object if its GUID is already used in the database into which you are 
importing. If duplicate GUIDs exist, an error message appears, and the import stops. 

1 Specify the data to update: 

• Edit an existing configuration file. 

• Create a configuration file. 

• Locate an existing export file. 

For more information about the export procedure, see Exporting data with the Data 
Installer (on page 87). 

Note: Oracle recommends that you use the Data Installer to export data from a configured 
instance of the Central Coding application, and import the data file as is, or edit it and 
perform an update. Oracle does not recommend creating your own configuration file for 
import. 

Make sure to specify the directory path of the file to use in the update procedure. 

Note: Data in XML files is case-sensitive. 

2 Open a Command Prompt window and type the name of the drive in which the Data Installer is 
installed. 

3 Type the location of the Data Installer in the drive you specified: 

...\Central Coding Application\CentralCodingServer\CodingWebUI\bin 

4 Run the utility in Update mode, using the following syntax: 
PhaseForward.Platform.Installation.DataInstaller.exe [ApplicationName] 
[Update] [SysConfig] [MasterFile] 
where:  

• ApplicationName—Name of the Central Coding application. The application name is 
located in the PhaseForward.Platform.Config config file, which is installed in the 
same directory as the Data Installer. The default application name is 
CentralCodingApplication.  

• MasterFile—Path to the master configuration file. The master configuration file is 
called MasterConfig.xml, and is located in the same directory as the Data Installer. 

The Data Installer adds the data to the appropriate tables in your target Central Coding database, 
based on the update data type. 
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Adding adapters and studies using the command line 

About adding adapters and studies using the command line 
You can add adapters and studies from the user interface, and also through the command line. The 
following executable files are installed as part of the Central Coding software installation. Run the 
executable files to install adapters and studies into the Central Coding application. 

• PhaseForward.CentralCoding.SetAdapter.exe—Installs an adapter to a Central Coding 
instance. 

When you install the adapter using the executable file, you use the available parameters to define 
Get Requests and Return Codes schedules for the adapter. 

• PhaseForward.CentralCoding.SetStudyGroup.exe—Creates a study group in a Central 
Coding instance. 

When you create a study group, you use the available parameters to specify the study to add to 
the group, and the Get Requests and Return Codes schedules for the study. 

• PhaseForward.CentralCoding.SetStudy.exe—Installs a study to a Central Coding instance. 

When you add the study, you use the available parameters to specify which adapter with which to 
associate the study, and you add the study to Get Requests and Return Codes schedules. 

Note: You can only add a study to a Get Requests or Return Codes schedule if the schedule 
is already defined for the adapter to which you are adding the study. 

For a list of available parameters for use with the command line executable files, see Available 
parameters (on page 91). 

The files are available in the following location: 

Phase Forward\[ApplicationName]\CentralCodingServer\CodingWebUI\bin 
where  
ApplicationName—The name of your Central Coding application. 
 

Note: You must run the executable files in the location in which they were installed. 
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Available parameters 
 

Parameter Description 

SetAdapter.exe 
AdapterName Name of the adapter to add. 

AdapterURL URL of the adapter to add. 

GetVerbatimsSchedule Rate at which to run the get verbatims job schedule. This 
parameter corresponds to the Time span configuration setting on 
the Schedule GetRequests Job page in the user interface. 

• 0—Indicates that you will run manual get verbatims jobs for 
the adapter, and the adapter should not be added to a Get 
Verbatims schedule. 

• 1—Set a Get Verbatim job schedule to run every minute for 
the adapter. 

• 5—Set a Get Verbatim job schedule to run every five minutes 
for the adapter. 

• 15—Set a Get Verbatim job schedule to run every fifteen 
minutes for the adapter. 

• 30—Set a Get Verbatim job schedule to run every thirty 
minutes for the adapter. 

Note: This parameter is optional. In the Central Coding 
application, the default value is 15. 

ReturnCodesSchedule Rate at which to run the return codes job schedule. This 
parameter corresponds to the Time span configuration setting on 
the Schedule ReturnCodes Job page in the user interface. 

• 0—Indicates that you will run manual return codes jobs for 
the adapter, and the adapter should not be added to a Return 
Codes schedule. 

• 1—Set a Return Codes job schedule to run every minute for 
the adapter. 

• 5—Set a Return Codes job schedule to run every five minutes 
for the adapter. 

• 15—Set a Return Codes job schedule to run every fifteen 
minutes for the adapter. 

• 30—Set a Return Codes job schedule to run every thirty 
minutes for the adapter. 

Note: This parameter is optional. In the Central Coding 
application, the default value is 15. 
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Parameter Description 

SetStudyGroup.exe 
Source Application The name of the application that is integrated with the Central 

Coding application. 

• InForm 

• Clintrial 

• Other—Any supported third-party application. 

Study Group Name Name of the study group to add.  

Client Audit User User name for the audit records that are created in the InForm 
application to record the codes that are returned by the Central 
Coding application. 

AllowAutoQuery Specify whether to allow the Central Coding application to 
duplicate an existing query and apply it to all matching verbatims 
in the study group that are subsequently entered in the Central 
Coding application.  

• Y—Instructs the Central Coding application to duplicate an 
existing query and apply it to all matching verbatims in the 
study group that are subsequently entered in the Central 
Coding application. 

• N—Instructs the Central Coding application not to apply a 
query to all matching verbatims in the study group. 

AllowAutoClose Specify whether to allow the Central Coding application to 
automatically close a query if the verbatim associated with the 
query is successfully coded and approved. 

• Y—Instructs the Central Coding application to automatically 
close a query if the verbatim associated with the query is 
successfully coded and approved. 

• N—Instructs the Central Coding application not to 
automatically close a query if the verbatim associated with the 
query is successfully coded and approved. 

SetStudy.exe 
AdapterName Name of the adapter to which to add the study. 

StudyName Name of the study to add. 

StudyURL URL for the study to add. 

StudyGroupName Name of the study group to which to add the study. 

Note: The study group must already exist in the Central Coding 
instance. 



Chapter 6  Setting up coding metadata using the command line  
 

94 Oracle® Health Sciences Central Coding 3.0.3 

Parameter Description 
GetVerbatimsSchedule Specify whether to add the study to the Get Verbatims schedule 

for the adapter you specified. 

• Y—Indicates that you want to add the study to the Get 
Verbatims schedule that is defined for the adapter you 
specified. 

Note: You can only specify Y if a Get Verbatims schedule is 
already defined for the adapter to which you are adding the 
study. 

• N—Indicates that you do not want to add the study to the 
Get Verbatims schedule that is defined for the adapter you 
specified. 

ReturnCodesSchedule Specify whether to add the study to the Return Codes schedule 
for the adapter you specified. 

• Y—Indicates that you want to add the study to the Return 
Codes schedule that is defined for the adapter you specified. 

Note: You can only specify Y if a Return Codes schedule is 
already defined for the adapter to which you are adding the 
study. 

• N—Indicates that you do not want to add the study to the 
Return Codes schedule that is defined for the adapter you 
specified. 

 
 

Adding a study group using the command line 
1 Open a Command Prompt window and type the name of the drive in which the executable file is 

installed. 

Note: By default, the executable file is installed in the same location as the Central Coding 
application. 

2 Type the location of the executable file in the drive that you specified: 

...\Central Coding Application\CentralCodingServer\CodingWebUI\bin 

Note: You must run the application from this directory. 

3 Type the following syntax for adding a study group: 

PhaseForward.CentralCoding.SetStudyGroup.exe [StudyGroupName] 
[AllowAutoQuery] [AllowAutoClose] 

where 

• StudyGroupName—Name of the study group to add.  

• AllowAutoQuery—Specify whether to allow the Central Coding application to duplicate an 
existing query and apply it to all matching verbatims in the study group that are subsequently 
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entered in the Central Coding application.  

• Y—Instructs the Central Coding application to duplicate an existing query and apply it 
to all matching verbatims in the study group that are subsequently entered in the Central 
Coding application. 

• N—Instructs the Central Coding application not to apply a query to all matching 
verbatims in the study group. 

• AllowAutoClose—Specify whether to allow the Central Coding application to automatically 
close a query if the verbatim associated with the query is successfully coded and approved. 

• Y—Instructs the Central Coding application to automatically close a query if the 
verbatim associated with the query is successfully coded and approved. 

• N—Instructs the Central Coding application not to automatically close a query if the 
verbatim associated with the query is successfully coded and approved. 

 

Adding a study to an adapter and job schedules using the command line 
1 Open a Command Prompt window and type the name of the drive in which the executable file is 

installed. 

Note: By default, the executable file is installed in the same location as the Central Coding 
application. 

2 Type the location of the executable file in the drive that you specified: 

...\Central Coding Application\CentralCodingServer\CodingWebUI\bin 

Note: You must run the application from this directory. 

3 Type the following syntax for adding a study to an adapter and job schedules: 

PhaseForward.CentralCoding.SetStudy.exe [SourceApplication] [AdapterName] 
[StudyName] [StudyURL] [StudyGroupName] [GetVerbatimsSchedule] 
[ReturnCodesSchedule] 

where 

• SourceApplication—The name of the application that is integrated with the Central Coding 
application. 

• InForm 

• Clintrial 

• Other—Any supported third-party application. 

• AdapterName—Name of the adapter to which to add the study. 

• StudyName—Name of the study to add. 

• StudyURL—URL of the study to add. 

• ClientAuditUser—User name for the audit records that are created in the InForm 
application to record the codes that are returned by the Central Coding application. 

• StudyGroupName—Name of the study group with which to associate the study. 
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• GetVerbatimsSchedule—Specify whether to add the study to the Get Requests schedule 
for the adapter you specified. 

• Y—Indicates that you want to add the study to the Get Requests schedule that is 
defined for the adapter you specified. 

Note: You can only specify Y if a Get Requests schedule is already defined for 
the adapter to which you are adding the study. 

• N—Indicates that you do not want to add the study to the Get Requests schedule that is 
defined for the adapter you specified. 

• ReturnCodesSchedule—Specify whether to add the study to the ReturnCodes schedule for 
the adapter you specified. 

• Y—Indicates that you want to add the study to the Return Codes schedule that is 
defined for the adapter you specified. 

Note: You can only specify Y if a Return Codes schedule is already defined for 
the adapter to which you are adding the study. 

• N—Indicates that you do not want to add the study to the Return Codes schedule that 
is defined for the adapter you specified. 

 

Adding an adapter and defining its job schedules using the command line 
1 Open a Command Prompt window and type the name of the drive in which the executable file is 

installed. 

Note: By default, the executable file is installed in the same location as the Central Coding 
application. 

2 Type the location of the executable file in the drive that you specified: 

...\Central Coding Application\CentralCodingServer\CodingWebUI\bin 

Note: You must run the application from this directory. 

3 Type the following syntax for adding an adapter and defining its job schedules: 

PhaseForward.CentralCoding.SetAdapter.exe [AdapterName] [AdapterURL] 
[GetVerbatimsSchedule] [ReturnCodesSchedule] 

where 

• AdapterName—Name of the adapter to add. 

• AdapterURL—URL of the adapter to add. 

• GetVerbatimsSchedule—Rate at which to run the Get Requests job schedule. This 
parameter corresponds to the Time span configuration setting on the Schedule GetRequests 
Job page in the user interface. 
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• 0—Indicates that you will run manual Get Requests jobs for the adapter, and the 
adapter should not be added to a Get Requests schedule. 

• 1—Set a Get Requests job schedule to run every minute for the adapter. 

• 5—Set a Get Requests job schedule to run every five minutes for the adapter. 

• 15—Set a Get Requests job schedule to run every fifteen minutes for the adapter. 

• 30—Set a Get Requests job schedule to run every thirty minutes for the adapter. 

Note: This parameter is optional. 

• ReturnCodesSchedule—Rate at which to run the Return Codes job schedule. This 
parameter corresponds to the Time span configuration setting on the Schedule ReturnCodes 
Job page in the user interface. 

• 0—Indicates that you will run manual Return Codes jobs for the adapter, and the 
adapter should not be added to a Return Codes schedule. 

• 1—Set a Return Codes job schedule to run every minute for the adapter. 

• 5—Set a Return Codes job schedule to run every five minutes for the adapter. 

• 15—Set a Return Codes job schedule to run every fifteen minutes for the adapter. 

• 30—Set a Return Codes job schedule to run every thirty minutes for the adapter. 

Note: This parameter is optional. 
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About performance reports 
The Central Coding software installation includes an executable file that gathers coding data, and a 
Microsoft Excel spreadsheet template that uses the data to create reports for analysis and 
troubleshooting assistance. You can produce data for a specified set of studies, for the entire system, 
or a combination of both options, according to the parameters you set when running the utility. 

To produce the performance reports, you must have server-level access. If you do not have access to 
the Central Coding server for your studies, please contact Oracle for assistance. 
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Generating performance reports 
To generate performance reports: 

1 Run a script to gather study or system data, which is compiled into a CSV file.  

For more information, see Gathering data for performance reports (on page 101). 

2 Create histograms from the data in a Microsoft Excel spreadsheet. 

For more information, see Generating performance reports in Microsoft Excel (on page 
101). 

 

Gathering data for performance reports 
1 Open a Command Prompt window and type the name of the drive in which the executable file is 

installed. 

2 Type the location of the executable file in the drive you specified: 

...\Central Coding Application\CentralCodingServer\CodingWebUI\Utilities\UsageCharts 

3 Run PhaseForward.CentralCoding.CreateUsageCharts.exe, using the following syntax: 

PhaseForward.CentralCoding.CreateUsageCharts.exe [dbUser] [dbPassword] 
[UsageType] [csvFileDirectory] [TrialList] 

where: 

• dbUser—Central Coding Database user ID. 

• dbPassword—Central Coding Database user password. 

• UsageType—The type of data to compile and display in Microsoft Excel. 

• DAILYUSAGE—Produce reports for data from one or more specified studies. 

• SYSTEMSUMMARY—Produce reports for data from the entire system. 

• BOTH—Produce separate reports for individual studies, and reports for the system as a 
whole. 

• csvFileDirectory—The directory in which you want to store the CSV data file. 

• TrialList—For DAILYUSAGE or BOTH usage type, the list of studies for which to 
produce the reports. 

• For one study, specify the study name. 

• For more than one study, list the study names in quotation marks, separated by commas 
(for example, "PFST50, PFSTCardio"). 

The utility produces a CSV file that you open in Microsoft Excel. 
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Generating performance reports in Microsoft Excel 
1 Navigate to the Central Coding installation folder. 

2 Open the UsageCharts.xlsm file. 

A Microsoft Excel spreadsheet opens. 

3 Click the Data tab. 

4 In the Get External Data section of the ribbon, click From Text. 

The Import Text File dialog box appears. 

5 Navigate to the directory you specified for the csvFileDirectory parameter. 

6 Click Import. 

The Text Import Wizard - Step 1 of 3 dialog box appears. 

7 Click Next. 

The Text Import Wizard - Step 2 of 3 dialog box appears. 

8 Select the Tab and Comma delimiters. 

9 Click Next. 

The Text Import Wizard - Step 3 of 3 dialog box appears. 

10 Click Finish. 

The Import Data dialog box appears. 

 
11 Select Existing worksheet and specify that you want to put the data in cell A1. 

12 Click OK. 

The worksheet is populated with the data from the CSV file. 

13 Click the Process Usage Data button. 

Note: You may need to scroll to the right in order to see the button. 

It may take several minutes to process the data. 
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Performance report descriptions 
 

Tab Name Report Name Description 

Daily usage reports 
<StudyName> Daily Tally of <StudyName>'s 

Verbatim Traffic 
For the specified study, the number of 
verbatims that were received, delivered, 
undelivered, or deleted each day, from the 
beginning of the study. 

<StudyName> Total Number of Verbatims in 
<StudyName> Measured Daily 

For the specified study, the total number of 
verbatims that existed and the total number 
of verbatims that were delivered each day, 
from the beginning of the study. 

System summary reports 
Days of Activity Days of Activity For each study in the system, the number of 

days during which preprocessing occurred, 
verbatims were received, and verbatims 
were returned to the source application. 

Trial Running Days Trial Running Days The duration of each study in the system, in 
days. 

Verbatim and 
Transaction Counts 

Verbatim and Transaction 
Counts 

For each study in the system, the number of 
verbatims that exist, the number of 
deletions that occurred, the number of 
times a verbatim was received by the 
Central Coding application, and the largest 
number of times a single verbatim was 
received by the Central Coding application. 

Percentage of 
Activity 

Percentage of Activity During 
Trial Up-Time 

For each study in the system, the percentage 
of time taken for preprocessing, receiving 
verbatims, and returning verbatims to the 
source application. 

Note: Each percentage is calculated based 
on a 20-hour day, allowing for 4 hours of 
system inactivity. The number of hours per 
day is a configurable setting in Microsoft 
Excel. 

Verbatim 
Throughput 

Number of Verbatims 
Processed per Hour over a 
Day 

The maximum number of verbatims 
processed in one hour, and the average 
number of verbatims processed in one hour. 
This data is calculated based on a 20-hour 
day and normalized to one hour. 

Note: This data is displayed in two graphs. 
The first graph is organized by system, and 
the second graph displays the data for each 
study in the system. 
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Tab Name Report Name Description 
Percentage 
Autocoded 

Percentage of Verbatims 
Autocoded 

For each study in the system, the percentage 
of verbatims that were autocoded. 

Active Trials Active Trials shown with 
Median Verbatims Received 
per Day 

The number of studies in the system on any 
given day, and the corresponding median 
number of verbatims received on that day. 

Verbatim Trial Size Size of Trial by # of 
Verbatims 

The number of verbatims in each study, and 
the percent of total verbatims in the system 
to which it corresponds. 

Histograms Preprocess Median/Active 
Day 

The median number of verbatims that were 
preprocessed in a day, and the number of 
studies that fall into each category. 

Preprocess Average/All Days The average number of verbatims that were 
preprocessed in a day, and the number of 
studies that fall into each category. 

Return Median/Active Day The median number of verbatims that were 
returned to the source application in a day, 
and the number of studies that fall into each 
category. 

Return Average/All Days The average number of verbatims that were 
returned to the source application in a day, 
and the number of studies that fall into each 
category. 

Receive Median/Active Day The median number of verbatims that were 
received in the Central Coding application 
in a day, and the number of studies that fall 
into each category. 

Receive Average/All Days The average number of verbatims that were 
received in the Central Coding application 
in a day, and the number of studies that fall 
into each category 

Verbatim Trial Size The number of verbatims in the system, and 
the number of studies that fall into each 
category. 
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Analyzing tables and indexes for performance 
Oracle recommends analyzing all tables and indexes for better performance. You should perform this 
analysis whenever a significant amount of coding data is entered. To help analyze tables and indexes, 
Oracle recommends that you run the following Oracle database utilities: 

• dbms_utility.analyze_schema—Run this utility using the Central Coding application schema 
owner. 

This utility updates the Oracle system tables that are used to perform analysis on a schema. 

• dbms_utility.analyze_schema—Run this utility to update the Oracle system tables for the 
Central Coding database. 
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Changing the execution timeout value 
The execution timeout value determines the number of seconds the Central Coding application waits 
to receive information from the InForm application. The Central Coding installation program sets 
the default value to 900 seconds.  

If you consistently receive the Request timed out error message, you can change the value for 
executionTimeout in the machine.config file. The following shows a sample machine.config file. 

<globalization requestEncoding="utf-8" responseEncoding="utf-8" /> <!-- 
httpRuntime Attributes: 
 executionTimeout=[seconds] - time in seconds before request is 
automatically timed out 
 maxRequestLength=[KBytes] - KBytes size of maximum request length to 
accept 
 useFullyQualifiedRedirectUrl="[true|false]" - Fully qualify the URL for 
client redirects 
 minFreeThreads="[count]" - minimum number of free thread to allow 
execution of new requests 
 minLocalRequestFreeThreads="[count]" - minimum number of free thread to 
allow execution of new local requests 
 appRequestQueueLimit="[count]" - maximum number of requests queued for 
the application 
 enableKernelOutputCache="[true|false]" - enable the http.sys cache on 
IIS6 and higher - default is true 
 enableVersionHeader="[true|false]" - outputs X-AspNet-Version header with 
each request 
--> 
<httpRuntime executionTimeout="900" maxRequestLength="4096" 
useFullyQualifiedRedirectUrl="false" 
minFreeThreads="8" minLocalRequestFreeThreads="4" appRequestQueueLimit="100" 
enableVersionHeader="true" /> <!-- compilation Attributes: 
tempDirectory="directory" 
 

To change the executionTimeout value: 

1 Open machine.config.  

This file is usually located in the \windows\Microsoft.NET\Framework\version\CONFIG folder. 

2 Locate <httpRuntime executionTimeout="900" maxRequestLength="4096" in the file. 

3 Change the value to meet your requirements. 

4 Save machine.config. 
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Changing the transaction timeout value 
If an error occurs when you are importing a large synonym file or when running the Code and 
Propagate action, increase the transaction timeout value for the Microsoft Distributed Transaction 
Coordinator (MS DTC). 

1 On the application server, open Microsoft Component Services. 

2 Select Start > Programs > Administrative Tools > Component Services.  

3 Expand Component Services. 

4 Expand Computers.  

5 Right-click My Computer and select Properties. 

6 Click the Options tab.  

7 Set the Transaction timeout (seconds) to 300 or more, and click Apply.  

8 Click the MSDTC tab, and under Service Control Status for DTC, click the Stop button to stop the 
DTC.  

9 Click the Start button to apply the new transaction timeout setting. 

10 Click OK. 
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Changing the number of matched terms that display in the 
coding browser 

In the Coding Browser dialog box—Search mode, the Return All Matches checkbox indicates 
whether you want all the matched terms found to display in the browser. By default, the coding 
browser displays 200 matches. This number, and whether this option is available, is set by your 
administrator. 

The CodingPlatform.config file contains the following section (these are the default values the 
Central Coding application ships with): 

<CodingBrowserSettings> 
<QuickRowLimit>200</QuickRowLimit> 
<AllowReturnAllMatches>true</AllowReturnAllMatches> 
<HardRowLimit>500</HardRowLimit> 

</CodingBrowserSettings> 
 
where: 

• QuickRowLimit—The number of matched terms to display in the browser. 

The browser displays only the number of terms specified in this setting. It does not allow you to 
page through the terms in lists. 

• AllowReturnAllMatches—Determines whether the Return All Matches option appears in the 
browser. 

If you change this setting to false, the Return All Matches checkbox does not appear in the 
coding browser, and the number of terms specified in the HardRowLimit display in the browser. 

• HardRowLimit—The number of matched terms to display in the browser when the Return 
All Matches option does not appear in the browser or if the option is not selected. 

If the QuickRowLimit is set to -1, or the Return All Matches checkbox is selected, the 
HardRowLimit determines the maximum number of matches that can be returned. 

If HardRowLimit is set to -1, all matches will be returned if the QuickRowLimit is -1 or the 
Return All Matches checkbox is selected. Oracle does not recommend setting the 
HardRowLimit to -1, as there could be thousands of possible returns. 
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About running statistics on the Central Coding application 
Oracle recommends that a database administrator run statistics on a Central Coding application if: 

• The performance of the Central Coding application is slow. 

• A timeout exception error occurs when running a large get verbatims job. 

If the job was running for a long time and a timeout exception error occurred, the 
ExceptionMap.xml file contains an entry that instructs you to ask a database administrator to 
gather statistics on the Central Coding account. 

Oracle recommends that the database administrator monitor the statistics for the account during 
the day and gather statistics if the statistics start to be out of date and the performance of the 
application slows down. 
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Cross-product issues 

Extra audit records in the Central Coding application 
 

Issue Additional audit records in the Central Coding application.  

Possible 
cause 

If you change a verbatim in the InForm application that has already been coded, 
and then change it back to what it was originally, the next time the InForm Adapter 
Coding interface delivers coding data to the Central Coding application, you will see 
additional audit records in the Audit History Report in the Central Coding 
application. This is because although the verbatim is unchanged, it is newer than its 
targets. 

Solution If you use the InForm Adapter software with the Central Coding application, you 
must: 

• Create a rule in the InForm software that is applied to every verbatim that 
clears the verbatim targets whenever the verbatim is changed. 

• Make sure the rule is case-sensitive. 

The rule ensures that the verbatim is treated as uncoded when it is delivered to the 
Central Coding application. 

 
 

Code map not found—Undeliverable requests 
Issue Codes are not returned to the InForm application and the Code map not found 

error appears in the Central Coding application for undeliverable requests when: 

• The mappings for the Central Coding application have been updated in the 
InForm application. 

• Data that is in the Central Coding application was not delivered prior to the 
mapping change.  

Possible 
cause 

When the Central Coding mappings are updated in the InForm application using 
the same refname, the InForm application does not create a new revision for the 
mappings. Instead, the InForm application creates an entirely new set of mappings 
with new GUIDs. 

As a result, when a verbatim is recoded in the Central Coding application after the 
updated mappings are installed in the InForm application, the request is 
undeliverable from the Central Coding application. 

The Code map not found error appears when you view the hover help for a 
request with a delivery status of Undeliverable ( ) on the Coding Requests, 
Approvals, or All Requests page in the Central Coding application. 

For more information, see the User Guide. 

Solution Contact Oracle CAG. 
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Key items not updated 
If the following key items are changed in the InForm application after a verbatim is coded, they will not 
be updated in the Central Coding application. 

Note: The key items are updated in the Central Coding application if the verbatim is not coded in 
the InForm application. 

• Subject Initials 

• Subject Number 

• Visit 

• Site Name 

• Site 

• Study 

If you want the key items to be updated, you must create a rule in the InForm application to clear the 
coding targets. 
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