
Ce logiciel et la documentation qui l’accompagne sont protégés par les lois sur la propriété intellectuelle. Ils sont concédés sous licence et soumis à des restrictions d’utilisation et de divulgation. Sauf disposition de votre contrat de licence ou de la loi, vous ne pouvez pas copier, reproduire, traduire, diffuser, modifier, breveter, transmettre, distribuer, exposer, exécuter, publier ou afficher le logiciel, même partiellement, sous quelque forme et par quelque procédé que ce soit. Par ailleurs, il est interdit de procéder à toute ingénierie inverse du logiciel, de le désassembler ou de le décompiler, excepté à des fins d’interopérabilité avec des logiciels tiers ou tel que prescrit par la loi.

Les informations fournies dans ce document sont susceptibles de modification sans préavis. Par ailleurs, Oracle Corporation ne garantit pas qu’elles soient exemptes d’erreurs et vous invite, le cas échéant, à lui en faire part par écrit.

Si ce logiciel, ou la documentation qui l’accompagne, est concédé sous licence au Gouvernement des Etats-Unis, ou à toute entité qui délivre la licence de ce logiciel ou l’utilise pour le compte du Gouvernement des Etats-Unis, la notice suivante s’applique :

U.S. GOVERNMENT RIGHTS. Programs, software, databases, and related documentation and technical data delivered to U.S. Government customers are "commercial computer software" or "commercial technical data" pursuant to the applicable Federal Acquisition Regulation and agency-specific supplemental regulations. As such, the use, duplication, disclosure, modification, and adaptation shall be subject to the restrictions and license terms set forth in the applicable Government contract, and, to the extent applicable by the terms of the Government contract, the additional rights set forth in FAR 52.227-19, Commercial Computer Software License (December 2007). Oracle America, Inc., 500 Oracle Parkway, Redwood City, CA 94065.

Ce logiciel ou matériel a été développé pour un usage général dans le cadre d’applications de gestion des informations. Ce logiciel ou matériel n’est pas conçu ni n’est destiné à être utilisé dans des applications à risque, notamment dans des applications pouvant causer des dommages corporels. Si vous utilisez ce logiciel ou matériel dans le cadre d’applications dangereuses, il est de votre responsabilité de prendre toutes les mesures de secours, de sauvegarde, de redondance et autres mesures nécessaires à son utilisation dans des conditions optimales de sécurité. Oracle Corporation et ses affiliés déclinent toute responsabilité quant aux dommages causés par l’utilisation de ce logiciel ou matériel pour ce type d’applications.

Oracle et Java sont des marques déposées d’Oracle Corporation et/ou de ses affiliés. Tout autre nom mentionné peut correspondre à des marques appartenant à d’autres propriétaires qu’Oracle.

Ce logiciel ou matériel et la documentation qui l’accompagne peuvent fournir des informations ou des liens donnant accès à des contenus, des produits et des services émanant de tiers. Oracle Corporation et ses affiliés déclinent toute responsabilité ou garantie expresse quant aux contenus, produits ou services émanant de tiers. En aucun cas, Oracle Corporation et ses affiliés ne sauraient être tenus pour responsables des pertes subies, des coûts occasionnés ou des dommages causés par l’accès à des contenus, produits ou services tiers, ou à leur utilisation.
# Contents

List of Tables ...............................................................................................................................7

List of Figures ..............................................................................................................................8

Preface ........................................................................................................................................9
Oracle Resources ........................................................................................................................9
Typographical Conventions ........................................................................................................10
Command Syntax Conventions .................................................................................................10

Chapter 1: Introduction .............................................................................................................12
Oracle Enterprise Manager for Oracle FS System Overview ..............................................12
  System Requirements ....................................................................................................12
Monitoring Oracle FS Systems Overview ...........................................................................13
Generating Oracle FS System Reports Overview ..........................................................13
Managing Oracle FS System Overview ..........................................................................14

Chapter 2: Installation ...............................................................................................................15
Deploying the Plug-In Overview ...........................................................................................15
  Port Assignments ...........................................................................................................16
Deploy the Plug-in Using Self Update Console ..............................................................16
(Optional) Download the Plug-In Archive .......................................................................17
(Optional) Import the Plug-In Archive Manually into OEM ..............................................18
Verify Deployment of the Plug-In ....................................................................................19
(Optional) Undeploy the Plug-In ....................................................................................19
Log In to Oracle Enterprise Manager ................................................................................20
Administrator Accounts Overview ......................................................................................20
Add Oracle FS System Targets ..........................................................................................21
Create Named Credential ....................................................................................................22
Setup Blackout Period .........................................................................................................23
Change Monitoring Configuration .......................................................................................24

Chapter 3: Monitor Oracle FS Systems.....................................................................................25
Oracle FS System Configuration and Metrics Overview ......................................................25
  View Oracle FS Configuration Data and Metrics ............................................................25
Update Oracle FS System Configuration or Metrics Collection Schedule .......................26
Oracle FS System Target Menu Overview ..........................................................................26
  View Status .....................................................................................................................27
  View SAN Hosts ...............................................................................................................28
  View Host Groups ............................................................................................................29
  View Volume Groups .......................................................................................................29
  View Storage Domains ....................................................................................................29
  View LUNs or Clone LUNs .............................................................................................30
  View LUN Clone Schedules ...........................................................................................31
  View Events .....................................................................................................................32
Chapter 4: Manage Oracle FS System Reports
Generating Oracle FS System Reports Overview .........................................................33
Generate Reports ........................................................................................................33

Chapter 5: Manage Oracle FS System ........................................................................35
Managing Host Groups Overview ................................................................................35
Create a Host Group ..................................................................................................35
Modify a Host Group ..................................................................................................36
Delete a Host Group ..................................................................................................36
Assign a Host to a Host Group ..................................................................................37
Managing Volume Groups Overview .........................................................................37
Create a Volume Group .............................................................................................38
Modify a Volume Group .............................................................................................39
Delete a Volume Group .............................................................................................39
Managing Storage Domains Overview .......................................................................40
Create a Storage Domain ..........................................................................................41
Modify a Storage Domain ..........................................................................................41
Delete a Storage Domain ..........................................................................................42
Change Drive Group to Primary Drive Group ............................................................42
Managing LUNs ..........................................................................................................42
Creating LUNs Overview .........................................................................................43
Create a LUN .............................................................................................................44
Create LUN: Quality of Service ..............................................................................44
Create LUN: Mapping to Selected Hosts ................................................................45
Create LUN: Mapping to All Hosts ..........................................................................46
Create LUN: Data Protection ....................................................................................47
Modifying LUNs Overview .......................................................................................48
Modify a LUN .............................................................................................................48
Modify LUN: Quality of Service ..............................................................................49
Modify LUN: Mapped to Specific Hosts ..................................................................49
Modify LUN: Mapped to All Hosts ..........................................................................50
Modify LUN: Data Protection ..................................................................................51
Enable Data Path for LUN ........................................................................................51
Disable Data Path for LUN .......................................................................................52
Delete a LUN .............................................................................................................52
Copy a LUN ..............................................................................................................53
Clone a LUN .............................................................................................................54
Managing Protection Schedules Overview ...............................................................54
Create a Protection Schedule ..................................................................................55
Modify a Protection Schedule ..................................................................................56
Delete a Protection Schedule ....................................................................................57

Appendix A: Oracle FS System Configuration Data and Metrics .....................................58
Oracle FS System Configuration Data and Metrics ....................................................58

Appendix B: Oracle FS System Reports .....................................................................64
Hardware Reports ......................................................................................................64
Oracle FS System I/O Reports ....................................................................................64
List of Tables

Table 1: Oracle resources...........................................................................................................9
Table 2: Typography to mark certain content............................................................................10
Table 3: Typography to mark command syntax........................................................................10
Table 4: System requirements...................................................................................................13
Table 5: Required port...............................................................................................................16
Table 6: Configuration Data collected for Oracle FS Systems..................................................58
Table 7: Metrics collected for Oracle FS Systems.....................................................................59
List of Figures

Figure 1: Verify installation of the plug-in.................................................................................. 19
## Oracle Resources

### Table 1: Oracle resources

<table>
<thead>
<tr>
<th>For help with...</th>
<th>Contact...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Support</td>
<td><a href="http://www.oracle.com/support">http://www.oracle.com/support</a></td>
</tr>
<tr>
<td>Training</td>
<td><a href="https://education.oracle.com">https://education.oracle.com</a></td>
</tr>
<tr>
<td>Documentation</td>
<td>• <a href="http://docs.oracle.com">Oracle Technology Network Documentation</a></td>
</tr>
<tr>
<td></td>
<td>• From the Oracle FS System Manager (GUI): Help &gt; Documentation</td>
</tr>
<tr>
<td></td>
<td>• From Oracle FS System HTTP access: <a href="http://system-name-ip/documentation.php">http://system-name-ip/documentation.php</a> where system-name-ip is the name or the public IP address of your system</td>
</tr>
<tr>
<td>Documentation feedback</td>
<td><a href="http://www.oracle.com/goto/docfeedback">http://www.oracle.com/goto/docfeedback</a></td>
</tr>
</tbody>
</table>
Typographical Conventions

Table 2: Typography to mark certain content

<table>
<thead>
<tr>
<th>Convention</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td><em>italics</em></td>
<td>Within normal text, words in italics indicate one of the following items:</td>
</tr>
<tr>
<td></td>
<td>• Hypertext, as in a URL</td>
</tr>
<tr>
<td></td>
<td>• A reference to a book title</td>
</tr>
<tr>
<td></td>
<td>• New terms and emphasized words</td>
</tr>
<tr>
<td></td>
<td>• Command variables</td>
</tr>
<tr>
<td><em>monospace</em></td>
<td>Indicates one of the following, depending on the context:</td>
</tr>
<tr>
<td></td>
<td>• The name of a file or the path to the file</td>
</tr>
<tr>
<td></td>
<td>• <em>Output</em> displayed by the system on the command line</td>
</tr>
<tr>
<td><em>monospace</em> (bold)*</td>
<td><em>Input</em> provided by an administrator on the command line.</td>
</tr>
<tr>
<td><em>&gt;</em></td>
<td>Indicates a menu item or a navigation path in the Oracle FS System Manager (GUI). For example, “Click <em>SAN &gt; Storage &gt; LUNS &gt; Action &gt; Clone</em>” means to click the <em>Clone</em> link on the <em>SAN</em> page in the GUI.</td>
</tr>
<tr>
<td><em>...</em></td>
<td>Indicates that one or more steps have been omitted from the path or menu structure. The ellipsis is used within an expression of a navigation path or within a cascading menu structure. For example, in the <em>SAN &gt; Storage &gt; LUNS &gt; ... &gt; Clone</em> menu structure, the <em>...</em> implies that one or more menu items have been omitted.</td>
</tr>
</tbody>
</table>

Command Syntax Conventions

Table 3: Typography to mark command syntax

<table>
<thead>
<tr>
<th>Typographic symbol</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>[ ]</td>
<td>Square brackets. Delimits an optional command parameter or a set of optional command parameters.</td>
</tr>
<tr>
<td>{ }</td>
<td>Braces. Delimits a set of command parameters, one of which must be selected.</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td><em>...</em></td>
<td>Ellipsis. Indicates that the immediately preceding parameter or group of parameters can be repeated.</td>
</tr>
<tr>
<td><em>monospace</em></td>
<td>Indicates the name of a command or the name of a command option (sometimes called a <em>flag</em> or <em>switch</em>).</td>
</tr>
<tr>
<td><em>italic</em></td>
<td>Indicates a variable for which you need to supply a value.</td>
</tr>
</tbody>
</table>
Command parameters that are not enclosed within square brackets ( [ ] ) are required.

**Important:** The above symbols (and font styling) are based on the POSIX.1-2008 specification. These symbols are used in the command syntax only to clarify how to use the command parameters. *Do not enter these symbols on the command line.*
CHAPTER 1

Introduction

Oracle Enterprise Manager for Oracle FS System Overview

Oracle Enterprise Manager for Oracle Flash Storage Systems version 12.1.0.1.0 enables you to monitor and manage an Oracle FS System from the Oracle Enterprise Manager Cloud Control 12c.

When you deploy the Oracle Enterprise Manager for Oracle Flash Storage Systems to Oracle Enterprise Manager Cloud Control 12c, you can monitor the organization and components of your Oracle FS System. You can also view statistical metrics, generate reports, and schedule data protection backups for your Oracle FS System.

The Oracle Enterprise Manager for Oracle Flash Storage Systems also enables you to manage the components of your Oracle FS System.

Note: Within this documentation, the Oracle Enterprise Manager for Oracle Flash Storage Systems is referred to as the plug-in. The information in this document describes how to use the plug-in but does not provide detailed information on the Oracle FS System components. For detailed information on the Oracle FS System, review the Oracle Flash Storage System Administrator’s Guide.

Note: Make sure you use the plug-in designed to support the Oracle Flash Storage System which is the Oracle Enterprise Manager for Oracle Flash Storage Systems. The Oracle Enterprise Manager for Pillar Axiom plug-in cannot be used to manage an Oracle Flash Storage System.

System Requirements

Make sure your system meets the requirements for Oracle Enterprise Manager for Oracle Flash Storage Systems and Oracle Enterprise Manager Cloud Control 12c.

Oracle Enterprise Manager for Oracle Flash Storage Systems and Oracle Enterprise Manager Cloud Control 12c require the following software versions to function correctly:
Table 4: System requirements

<table>
<thead>
<tr>
<th>Requirement</th>
<th>Version</th>
</tr>
</thead>
<tbody>
<tr>
<td>Oracle FS System software</td>
<td>Release 6.0 or higher</td>
</tr>
<tr>
<td>Operating systems</td>
<td>The Oracle Enterprise Manager for Oracle Flash Storage Systems is compatible with Oracle Enterprise Manager Cloud Control 12c, version 12.1.0.3.0 but Oracle recommends you deploy the plug-in on Oracle Enterprise Manager Cloud Control 12c, version 12.1.0.4.0 or higher for best results. For more details, refer to the Oracle Enterprise Manager Downloads page (<a href="http://www.oracle.com/technetwork/oem/grid-control/downloads/index.html">http://www.oracle.com/technetwork/oem/grid-control/downloads/index.html</a>).</td>
</tr>
</tbody>
</table>

Monitoring Oracle FS Systems Overview

The Oracle Enterprise Manager for Oracle Flash Storage Systems enables you to view the organizational features and system components on your Oracle FS System. You can also view pre-defined reports and metrics to monitor system configuration and performance.

The plug-in allows you to monitor the host group, volume group, and Storage Domain organizational features of your Oracle FS System.

The plug-in allows you to view Oracle FS System LUN and Clone LUN details. You can also view regularly collected statistical metrics to monitor Oracle FS System, Pilots, Controllers, Drive Enclosures, and LUNs.

The plug-in also provides pre-defined hardware reports, I/O reports, and storage usage reports that you can generate to monitor Oracle FS System configuration and performance. You can also create custom reports to supplement the available pre-defined reports.

Generating Oracle FS System Reports Overview

The Oracle Enterprise Manager for Oracle Flash Storage Systems provides pre-defined hardware, I/O, and storage usage reports that you can generate for Oracle FS System.

Hardware reports include a Oracle FS System summary report, a report of the disk drives in the Drive Enclosures associated with the Oracle FS System, and a hardware status report.

The I/O Access for LUNs report charts input and output statistics for the 10 most active LUNs on the Oracle FS System.

The Storage Usage reports shows storage use per LUN associated with the Oracle FS System, and how much storage is used for the different priority, data access, and I/O bias Quality of Service categories.
In addition to pre-defined reports, you can create custom reports. For information on creating custom reports, review the Oracle Enterprise Manager online help.

Related Links
- Hardware Reports
- Oracle FS System I/O Reports
- Oracle FS System Storage Usage Reports
- Generate Reports

Managing Oracle FS System Overview
The Oracle Enterprise Manager for Oracle Flash Storage Systems allows you to manage the organizational features and components of your Oracle FS System.

The plug-in allows you to create, modify, and delete host group, volume group, and Storage Domain Oracle FS System organizational features. You can also modify the membership of these organizational features with the plug-in.

The plug-in allows you to create, modify, and delete Oracle FS System LUNs and Clone LUNs, and to make copies and clones of these LUNs and Clone LUNs.

The plug-in also allows you to create, modify, and delete data protection schedules that replicate LUNs and Clone LUNs at regular intervals to protect them from data loss.
Chapter 2

Installation

Deploying the Plug-In Overview

The Oracle Enterprise Manager for Oracle Flash Storage Systems plug-in can be installed using the Oracle Enterprise Manager Self Update Console feature. You can also download the archive package from the Oracle Technical Network (OTN) and import the archive package into Oracle Enterprise Manager.

For information on the plug-in deployment process, review the Workflow of Plug-In Deployment topic in either the Oracle Enterprise Manager online help or the Oracle Enterprise Manager Cloud Control Administrator’s Guide 12c Release 4 (12.1.0.4).

Make sure you download and install the plug-in designed to support the Oracle Flash Storage System which is the Oracle Enterprise Manager for Oracle Flash Storage Systems. The Oracle Enterprise Manager for Pillar Axiom plug-in cannot be used to manage an Oracle Flash Storage System.

There are two methods for installing the plug-in:

- **Recommended**: Install the plug-in using the Oracle Enterprise Manager Self Update Console feature. This method ensures access to the latest version of the Oracle Enterprise Manager for Oracle Flash Storage Systems plug-in.

- **Optional**: Download the plug-in from OTN and manually install the plug-in.

The plug-in packaged in an Oracle Plug-In Archive (OPAR) file included in the Oracle Enterprise Manager for Oracle Flash Storage Systems archive file available on OTN. You need to import the archive package to the OEM repository to make the plug-in visible in the OEM GUI. When the plug-in is available in the GUI, you can deploy the plug-in to the management server and management agent.

**Note**: Make sure the plug-in can communicate with the Oracle Flash Storage System as described in this document.
Port Assignments

The Oracle Enterprise Manager for Oracle Flash Storage Systems plug-in communicates with the Oracle FS System through port 8083.

Ensure that port 8083 is available (not blocked by a firewall or security software) and enabled on the Management Agent before you activate the plug-in:

Table 5: Required port

<table>
<thead>
<tr>
<th>Port type</th>
<th>Port number</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>WebCLI</td>
<td>8083</td>
<td>The port on which the plug-in listens for HTTPS traffic with the Oracle FS System WebCLI service.</td>
</tr>
<tr>
<td>HTTPS</td>
<td>8083</td>
<td>Use the following CLI command to verify that this service is enabled: $ fscli webcli -list</td>
</tr>
</tbody>
</table>

If necessary, use the following CLI command to enable the service:

$ fscli webcli -enable

Note: For information on the firewalls, review information in either the Oracle Enterprise Manager online help or the Oracle Enterprise Manager Cloud Control Administrator’s Guide 12c Release 4 (12.1.0.4).

Deploy the Plug-in Using Self Update Console

You can use the Oracle Enterprise Manager Self Update Console to install the plug-in. Below is a description of the Self Update Console procedure to install the plug-in.

Prerequisites:

- My Oracle Support credentials have been set up. This is required to enable plug-ins to be downloaded from the My Oracle Support site. Refer to the Oracle Enterprise Manager online help for further information.
- The Software Library (also known as the local store) has been configured. Updates are downloaded to this local store before being deployed. Refer to the Oracle Enterprise Manager online help for further information.
• Log-in credentials for the management server.
• Log-in credentials for the management agent running on the management server.
• The Oracle Enterprise Manager must have access to the Oracle Enterprise Manager Store through the Internet.

You can manage updates for the Oracle Enterprise Manager for Oracle Flash Storage System plug-in using the Self Update Console.

The process to deploy a plug-in is:
• Check availability of the plug-in for deployment.
• Download the plug-in.
• Deploy the plug-in.
• Verify the plug-in deployment.

For detailed information on this process, review the Managing Plug-Ins topic in the Oracle Enterprise Manager online help or the Oracle Enterprise Manager Cloud Control Administrator’s Guide 12c Release 4 (12.1.0.4)

1 Log in to the Oracle Enterprise Manager Cloud Control 12c console.
2 Check if the plug-in, which is the Oracle Flash Storage System plug-in, is available for deployment. Follow the instructions provided in Check the Availability of Plug-Ins topic in the Oracle Enterprise Manager online help or the Oracle Enterprise Manager Cloud Control Administrator’s Guide 12c Release 4 (12.1.0.4).
3 Download the plug-in from the Oracle Enterprise Manager Store. Follow the instructions provided in Downloading Plug-Ins topic in the Oracle Enterprise Manager online help or the Oracle Enterprise Manager Cloud Control Administrator’s Guide 12c Release 4 (12.1.0.4).
4 Deploy the plug-in to the management server and management agent. Follow the instructions provided in Deploying Plug-Ins to Oracle Management Service and Deploying Plug-Ins on Oracle Management Agent topics in the Oracle Enterprise Manager online help or the Oracle Enterprise Manager Cloud Control Administrator’s Guide 12c Release 4 (12.1.0.4).

Verify the installation by following procedures provided in this document.

(Optional) Download the Plug-In Archive

The Oracle Enterprise Manager for Oracle Flash Storage Systems software and documentation are distributed as a single zip archive that is available for download from the Oracle Technical Network (OTN). You use this method only if you need to manually install the plug-in. The preferred method is to download the plug-in from the Oracle Enterprise Manager Store.
Prerequisite: Join the Oracle Technology Network to gain access to software and documentation downloads:


2 From Oracle FS System Downloads, select Accept License Agreement.

3 Locate and select the name of the software package to download for your operating system version.

4 Open the software archive and extract the contents to your workstation.
The software archive contains a readme text file listing the contents of the archive, the installation executable file, and documentation.

After you download the software, you can install the software.

(Optional) Import the Plug-In Archive Manually into OEM

To activate the Oracle Enterprise Manager for Oracle Flash Storage Systems plug-in on your Oracle Enterprise Manager Cloud Control 12c client, add the plug-in to the Oracle Enterprise Manager repository and then deploy the plug-in to your management server and management agent. This is an optional method as the preferred method is to use the Oracle Enterprise Manager Store to download the plug-in.

Prerequisites:
- My Oracle Support credentials have been set up. Refer to the Oracle Enterprise Manager online help for further information.
- Log-in credentials for the management server.
- Log-in credentials for the management agent running on the management server.
- The path to the *.opar file you downloaded from OTN.

Import the plug-in to the Oracle Enterprise Manager repository from the Oracle Management Server command line. Then deploy the plug-in to the management server and the management agent from the Plug-Ins page.

1 Access the Enterprise Manger Command Line (EM CLI).

2 Import the plug-in archive to the Oracle Software Library Importing Plug-In Archives topic in the Oracle Enterprise Manager online help or the Oracle Enterprise Manager Cloud Control Administrator’s Guide 12c Release 4 (12.1.0.4).
Verify Deployment of the Plug-In

After you install the Oracle Enterprise Manager for Oracle Flash Storage Systems plug-in, verify that the plug-in was installed correctly.

Verify the installation of the plug-in after deploying the plug-in.

Follow the steps listed in Verify Deployed Plug-Ins topic in the Oracle Enterprise Manager online help or the Oracle Enterprise Manager Cloud Control Administrator’s Guide 12c Release 4 (12.1.0.4).

The plug-in appears in the Name column and the number one (1) or the number of agents appears in the Management Agent with Plug-in column. You can also verify the version under Version column.

Figure 1: Verify installation of the plug-in

(Optional) Undeploy the Plug-In

You can remove the Oracle Enterprise Manager for Oracle Flash Storage Systems from Oracle Enterprise Manager when it is no longer needed.

Prerequisites:

- My Oracle Support credentials have been set up. This is required to enable plug-ins to be downloaded from the My Oracle Support site. Refer to the Oracle Enterprise Manager online help for further information.

- The Software Library (also known as the local store) has been configured. Updates are downloaded to this local store before being deployed. Refer to the Oracle...
Enterprise Manager online help for further information.

- Log-in credentials for the management server.
- Log-in credentials for the management agent running on the management server.

You can remove the plug-in following the steps to undeploy from the Oracle management agent.

**Note:** The Oracle Enterprise Manager must have access to the Oracle Enterprise Manager Update Store through the Internet.

1. Follow the instructions in the *Undeploying Plug-Ins from Oracle Management Agent* topic in the Oracle Enterprise Manager online help or the *Oracle Enterprise Manager Cloud Control Administrator’s Guide 12c Release 4 (12.1.0.4)* to undeploy the Oracle Flash Storage System plug-in.

2. Verify you removed the plug-in by following the instructions in the *Verifying Deployed Plug-Ins* topic in the Oracle Enterprise Manager online help or the *Oracle Enterprise Manager Cloud Control Administrator’s Guide 12c Release 4 (12.1.0.4)*.

---

**Log In to Oracle Enterprise Manager**

Oracle Enterprise Manager Cloud Control 12c is a web application that you launch from your browser. You must log in to Oracle Enterprise Manager to use the Oracle Enterprise Manager for Oracle Flash Storage Systems to access Oracle FS System.

**Prerequisites:**

- Server name and port for your Oracle Enterprise Manager installation.
- Login credentials for Oracle Enterprise Manager.

Both can be obtained from your Oracle Enterprise Manager administrator.

1. Start your web browser.
2. In the URL field, enter the server name and port for your Oracle Enterprise Manager installation.
3. Enter your Oracle Enterprise Manager user name and password, and click Login.

---

**Administrator Accounts Overview**

Oracle recommends creating a unique Administrator account or accounts for the plug-in Monitoring Credential and Named Credential accounts for the Oracle
Enterprise Manager for Oracle Flash Storage Systems. You use these accounts to monitor and manage the Oracle FS System from the plug-in.

You can create multiple administrator accounts in an Oracle FS System. Additional accounts are not necessary but Oracle recommends you create at least one Administrator 1 account on each Oracle FS System for the plug-in.

An administrator with Administrator 1 privileges needs to create the plug-in account on the Oracle FS System. The administrator who creates the account provides the name and password for the account to the plug-in administrator. Oracle does not recommend using the Oracle FS System Primary Administrator account for the plug-in account.

You can create additional accounts for other plug-in administrators. For example, you may want one administrator to monitor and generate reports, another administrator to configure the Oracle FS System. Oracle recommends assigning Administrator 1 or Administrator 2 privileges for these accounts based on the administrator’s role. For example, you must be logged in with an Administrator 1 account to create or modify storage resources or perform tasks other than monitor and generate reports on the Oracle FS System. Refer to the Oracle Flash Storage System Administrator’s Guide for details about administrator accounts and assigned privileges on the Oracle FS System.

The account or accounts you create on the Oracle FS System can be used in three places within the plug-in:

- Named Credential
- Monitoring Credential
- Blackout period for changing passwords

**Note:** When you add a target, you create a monitoring credential account. This account uses an administrator account on the Oracle FS System to monitor and run reports about the Oracle FS System target. You can also use this account when you create a Named Credential. You could create separate accounts if you want to define roles such as an administrator who monitors systems and runs reports but does not configure systems.

Refer to the Oracle Flash Storage System Administrator’s Guide for details about creating administrator accounts on the Oracle FS System.

### Add Oracle FS System Targets

Before you can monitor or manage an Oracle FS System in Oracle Enterprise Manager, you must add the system as a target. When you add an Oracle FS System as a target, you also create a Monitoring Credential account. The Monitoring Credential account is used to monitor the Oracle FS System and generate reports.

**Prerequisites:**

- Host name for the Oracle FS System target.
• Login credentials for the Oracle FS System target. These credentials are for an administrator account on the Oracle FS System.

Your Oracle FS System administrator can provide this information.

You add targets from the Setup menu at the top of the Oracle Enterprise Manager page.

1 Select Setup > Add Target > Add Targets Manually.
2 Under Add Targets Manually, select Add Non-Host Targets by Specifying Target Monitoring Properties.
3 From the Target Types drop-down list, select Oracle Flash Storage System.
4 Click the magnifying glass beside the Monitoring Agent text box, select an agent from the list, and click Select.
5 Click Add Manually.
6 Enter a name for the target in the Target Name field.
7 Provide login credentials for the Oracle FS System administrator account in the User ID and Password and Confirm Password fields. This creates a Monitoring Credential for the target.
8 Enter the name of the Oracle FS System in the Host field.
9 Click OK.

A target is added as well as a Monitoring Credential for that target. You can monitor and run reports for that target.

Create Named Credential

As part of the management process, you must create a named credential to enable management activities for the Oracle FS System target within Oracle Enterprise Manager.

**Prerequisites:**

- Host name for the Oracle FS System target.
- Login credentials for the Oracle FS System target.

Your Oracle FS System system administrator can provide this information.

You create a Named Credential from the Setup menu at the top of the Oracle Enterprise Manager page. When a target is added, the user name and password given during the 'Add a Target' process is used for monitoring and is called the Monitoring Credential. The Named Credential is used for management actions within the plug-in; this management account is not required for metric collection or reporting. You use the Monitoring Credential account for that activity.

You can use the same Oracle FS System account for both the Named Credential and Monitoring Credential. You may want to use one Oracle FS System account
for monitoring and running reports and another Oracle FS System account for configuring the Oracle FS System

2. Enter Credential name.
3. Enter Credential description.
4. Select Oracle Flash Storage System from the Authenticating Target Type.
5. Select Host Credentials for the Credential type.
6. Select Global for the Scope. Global is the default value. The global value make the credential usable beyond a single target.
7. Select Host for the Target type.
8. Select a Target name by clicking the search icon. The Target name is the name of the Oracle FS System you are managing with the plug-in.
9. Enter the Username which is the same user id you use on the Oracle FS System to log in to the system.
10. Enter the Password which is the same password you use to log in to the Oracle FS System.
11. Reenter the password in the Confirm password field.
12. Select None for Run Privilege.
13. Click Test and Save.

The plug-in logs into the Oracle FS System.

Setup Blackout Period

Before changing your password on the Oracle FS System account you use with the Oracle Enterprise Manager, you must create a blackout period to prevent Oracle Enterprise Manager from trying to log in to the Oracle FS System while the password is being updated.

**Prerequisites:**
- Host name for the Oracle FS System target.
- Login credentials for the Oracle FS System target.

Your Oracle FS System system administrator can provide this information.

You create a blackout period from the Enterprise pull-down at the Oracle Enterprise Manager page.

1. Select Enterprise > Monitoring > Blackouts.
2. Select Create.
3. Enter a Name for the blackout period. For example, Oracle FS System password change.
4. From the Reason pull-down, select Apps: Application Password Change.
5 Uncheck the Run jobs during the blackout... box to disable jobs from being run from OEM. You do not want any jobs running during the blackout period as any job running from OEM to the Oracle FS System can cause login issues during a password change.

6 Under Targets select Add. Locate the Oracle Flash Storage System you are creating the blackout period for to change the administrator password.

7 Select the Select box next to the Oracle Flash Storage System you selected.

8 Select Next and enter the schedule information.

9 Select Finish to create the blackout schedule.

A blackout is created and begins based on the schedule you created. For more information on blackout periods, review the Oracle Enterprise Manager online help for additional information.

After the blackout schedule is created, go to the Oracle FS System and change the administrator password during the blackout period.

Change Monitoring Configuration

When you add a target, you create a monitoring configuration. After you add the target, you can change the monitoring configuration including the user ID and password. You can also delete the monitoring configuration.

Prerequisites:

- Host name for the Oracle FS System target.
- Login credentials for the Oracle FS System target.

Your Oracle FS System system administrator can provide this information.

You access Monitoring Credentials the from the Setup menu at the top of the Oracle Enterprise Manager page.

1 Select Setup > Security > Monitoring Credentials.

2 Under Target Type, select Oracle Flash Storage System.

3 Select Manage Monitoring Credentials.

4 From the Target Types drop-down list, select Oracle Flash Storage System.

5 Under Target Name, select the target and then select Set Credentials.

6 Change the login credentials for the Oracle FS System in the User ID and Password and Confirm Password fields

7 Click Save.

The credentials are changed. Make sure the changes you make to this account are made to the account on the Oracle FS System.
CHAPTER 3

Monitor Oracle FS Systems

Oracle FS System Configuration and Metrics Overview

Oracle Enterprise Manager collects configuration and metric data for the Oracle FS System and SAN Hosts added as targets. A pre-defined set of configuration and metrics is collected for each Oracle FS System target.

Oracle Enterprise Manager collects configuration and metric data for these components of an Oracle FS System:

- Controllers
- Disk Drives
- Drive Enclosures
- LUNs
- Oracle FS System (overall system)
- Pilots
- SAN Hosts.

You can view Oracle FS System configuration data and metrics in Oracle Enterprise Manager. You can change the collection schedule and edit thresholds and collection settings for the configuration data and metrics. The majority of the metrics are accessed from Monitoring > All Metrics and configuration data is accessed from Configuration > Latest Configuration.

**Note:** Some metrics displayed under Monitoring > All Metrics may not contain data as the metric is not implemented in this product release.

**Related Links**

Oracle FS System Configuration Data and Metrics
View Oracle FS Configuration Data and Metrics

View Oracle FS Configuration Data and Metrics

**Prerequisite:** One or more Oracle FS Systems added as an Oracle Enterprise Manager target.

The Oracle FS System for which you want to view configuration data or metrics must be selected as the target.
1. Select **Oracle Flash Storage System > Configuration > Latest Configuration** for configuration data or **Oracle Flash Storage System > Monitoring > All Metrics** for metrics.

A list of the categories of all configuration data or metrics collected for the target Oracle Flash Storage System displays in the navigation pane.

2. Select a category of configuration data or metrics.

A table of specific configuration data or metrics available for that category displays in the content pane.

**Update Oracle FS System Configuration or Metrics Collection Schedule**

You can change the collection schedule for metrics. The collection schedule defines how often data, such as LUN statistics is collected.

**Prerequisite:** One or more Oracle FS Systems added as an Oracle Enterprise Manager target.

The Oracle FS System for which you want to view metrics must be selected as the target.

1. Select **Oracle Flash Storage System > Configuration > Latest Configuration** for configuration data or **Oracle Flash Storage System > Monitoring > All Metrics** for metrics.

   A list of the categories of all configuration data or metrics collected for the target Oracle Flash Storage System displays in the navigation pane.

2. Select a category of configuration data or metrics.

   A table of specific configuration data or metrics available for that category displays in the content pane.

3. To change the collection schedule for this category of configuration data, click **Actions > History**.

4. To change the collection schedule for this category of configuration data, click **Schedule and Notify**.

5. To change the collection schedule for this category of metrics, click **Modify**.

   In the **Modify Collection Schedule** dialog, you can change the collection frequency, upload interval, and typical usage of the metric data for this category of metrics.

6. Follow the instructions on the screen and when you finish modifying the collection schedule, select **OK**.

7. Select **OK** to save your changes.

   The updated collection schedule is implemented.

**Oracle FS System Target Menu Overview**

The Oracle Enterprise Manager for Oracle Flash Storage Systems enables you to monitor host groups, volume groups, Storage Domains, LUNs, and data
protection schedules on an Oracle Flash Storage System from within the Oracle Enterprise Manager.

When you select an Oracle Flash Storage System target in Oracle Enterprise Manager, you have access to menus from which you can view the host and volume groups, Storage Domains, LUNs, LUN Clone Schedules, events, and other features defined on the target system. To access the menu, select the pull-down next to **Oracle Flash Storage System**.

**Related Links**
- **View Host Groups**
- **View Volume Groups**
- **View LUNs or Clone LUNs**
- **View Storage Domains**
- **View LUN Clone Schedules**

**View Status**

View status of the Oracle FS System with the Oracle Enterprise Manager for Oracle Flash Storage Systems.

**Prerequisite:** One or more Oracle FS Systems added as an Oracle Enterprise Manager target.

The Oracle FS System for which you want to view status must be selected as the target.

1. **Select Oracle Flash Storage Systems > Status.**

Status is displayed for these items:

<table>
<thead>
<tr>
<th>Category</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>System Summary</strong></td>
<td>Provide information on the system including serial number, model, management IP, and status. The status indicators are normal, warning, and critical.</td>
</tr>
<tr>
<td><strong>Storage Summary</strong></td>
<td>Provides information on total storage space, allocated space, and remaining space.</td>
</tr>
<tr>
<td><strong>Software Summary</strong></td>
<td>Provides the software versions for system components.</td>
</tr>
<tr>
<td><strong>Job Activity</strong></td>
<td>Status of background jobs run by Oracle Enterprise Manager</td>
</tr>
<tr>
<td><strong>Pilot Status</strong></td>
<td>Indicates the Pilot status and if the Pilot is the active or standby. The status indicators are normal, warning, and critical. The active Pilot performs configuration tasks. The standby Pilot is available if the active Pilot failover to the standby Pilot.</td>
</tr>
<tr>
<td><strong>Controller Status</strong></td>
<td>Provides the Controller type and status. The status indicators are normal, warning, and critical. Controller type is SAN Only.</td>
</tr>
</tbody>
</table>
Enclosure Status

Provides the enclosure name, model, and status.

Incidents and Problems

Displays information about issues with the Oracle FS System, the host server where the plug-in is installed, and the Oracle Enterprise Manager application.

2 Select the refresh icon to update the page.

The displayed fields for Oracle FS System are updated.

For detailed information or definitions about the displayed data, review the Oracle Flash Storage System Administrator’s Guide.

View SAN Hosts

You can display a list of all host groups previously defined for an Oracle FS System system with the Oracle Enterprise Manager for Oracle Flash Storage Systems.

Prerequisite: One or more Oracle FS Systems added as an Oracle Enterprise Manager target.

The Oracle FS System for which you want to view SAN Hosts must be selected as the target.

1 Select Oracle Flash Storage Systems > Hosts.

2 Select SAN Hosts from the View drop-down list.

All SAN host groups defined for the current Oracle FS System system are listed.

<table>
<thead>
<tr>
<th>Host Name</th>
<th>Identifies the name of the SAN host</th>
</tr>
</thead>
<tbody>
<tr>
<td>Host Group Name</td>
<td>Name of a collection of SAN hosts.</td>
</tr>
<tr>
<td>Number of LUNs Mapped</td>
<td>Identifies the number of LUNs that are mapped to the SAN host either because of a specific mapping or because the LUN is available to all SAN hosts.</td>
</tr>
<tr>
<td>Status</td>
<td>Identifies whether the Oracle FS Path Manager (FSPM) driver is communicating or registered. If the driver is not registered, install the FSPM software.</td>
</tr>
<tr>
<td>FSPM Version</td>
<td>Identifies the FSPM version.</td>
</tr>
<tr>
<td>Host IP Address</td>
<td>Identifies the IP address of the SAN host. If FSPM is not installed, the field displays N/A.</td>
</tr>
<tr>
<td>Host Operating System</td>
<td>Identifies the host operating system on which the FSPM software is installed.</td>
</tr>
</tbody>
</table>

All SAN host groups defined for the current Oracle FS System are listed.

For detailed information or definitions about the displayed data, review the Oracle Flash Storage System Administrator’s Guide.
View Host Groups

Host groups associate registered SAN hosts into logical organizational units so you can assign attributes to the entire group rather than to individual hosts. You can display a list of all host groups previously defined for an Oracle FS System with the Oracle Enterprise Manager for Oracle Flash Storage Systems.

Prerequisite: One or more Oracle FS Systems added as an Oracle Enterprise Manager target.

The Oracle FS System for which you want to view host groups must be selected as the target.

1. Select Oracle Flash Storage System > Hosts.
2. Select Host Groups from the View drop-down list.

All host groups defined for the current Oracle FS System are listed.

For detailed information or definitions about the displayed data, review the Oracle Flash Storage System Administrator’s Guide.

View Volume Groups

Volume groups allow you to organize logical volumes (LUNs) into organizational units. You can display a list of all volume groups previously defined for a Oracle FS System system with the Oracle Enterprise Manager for Oracle Flash Storage Systems.

Prerequisite: One or more Oracle FS Systems added as an Oracle Enterprise Manager target.

The Oracle FS System system for which you want to view volume groups must be selected as the target.

2. Select Volume Groups from the View drop-down list.
3. You can search or filter to look for a volume group in the Filter/Search... field.

All volume groups and any parent volume groups that are defined for the current Oracle FS System are listed.

For detailed information or definitions about the displayed data, review the Oracle Flash Storage System Administrator’s Guide.

View Storage Domains

Storage Domains assign LUNs to a specific collection of Drive Enclosures in an Oracle FS System. You can display a list of all the Storage Domains previously
defined for an Oracle FS System with the Oracle Enterprise Manager for Oracle
Flash Storage Systems.

**Prerequisite:** One or more Oracle FS Systems added as an Oracle Enterprise
Manager target.

The Oracle FS System for which you want to view Storage Domains must be
selected as the target.

1. Select *Oracle Flash Storage System > Storage Domains.*
2. Select *Storage Domains* from the View drop-down list.

The following information is available:

- **Tier Reallocation**
  Indicates whether tier reallocation is enabled or disabled.

- **Allocated Capacity**
  Amount, in GB, of the capacity of this Storage Domain that has already been allocated for storage.

- **Free Capacity**
  Amount, in GB, of the capacity of this Storage Domain that has not yet been allocated for storage, and is available for use.

- **Unavailable Capacity**
  Amount, in GB, of the capacity of this Storage Domain that cannot be allocated for storage because it is in use.

- **Total Capacity**
  Total capacity of this Storage Domain in GB, including both available and unavailable capacity.

For detailed information or definitions about the displayed data, review the *Oracle Flash Storage System Administrator’s Guide.*

**View LUNs or Clone LUNs**

You can display a list of all the LUNs or Clone LUNs defined for an Oracle FS System with the Oracle Enterprise Manager for Oracle Flash Storage Systems.

**Prerequisite:** One or more Oracle FS Systems added as an Oracle Enterprise Manager target.

The Oracle FS System system for which you want to view LUNs or Clone LUNs
must be selected as the target.

1. Select *Oracle Flash Storage System > LUNs.*
2. Select *LUNs* or *Clone LUNs* from the View drop-down list.
3. Select a LUN to display information about that LUN.

Available information includes:

- **Basic Information**
  LUN name, LUID, status, and Storage Domain and volume group membership.
<table>
<thead>
<tr>
<th><strong>Capacity Information</strong></th>
<th>Used, maximum, and available capacity of the selected LUN, in GB.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>LUN Statistics</strong></td>
<td>A summary graph of the read I/O, write I/O, and total I/O each second for the selected LUN over the last 24 hours.</td>
</tr>
<tr>
<td><strong>Quality of Service</strong></td>
<td>Redundancy, I/O bias, access bias, and priority Quality of Service (QoS) attributes assigned to the selected LUN.</td>
</tr>
<tr>
<td><strong>Clone Capacity Information</strong></td>
<td>Used, maximum, and available capacity for clones of the selected LUN (if any), in GB.</td>
</tr>
<tr>
<td><strong>Access Information</strong></td>
<td>Protocol (FC, iSCSI, or both) and type of mapping (to specific hosts or to all hosts) used to access the selected LUN.</td>
</tr>
<tr>
<td><strong>Clone LUNs</strong></td>
<td>Clone LUNs that are children of the select LUN, if any.</td>
</tr>
</tbody>
</table>

For detailed information or definitions about the displayed data, review the *Oracle Flash Storage System Administrator’s Guide*.

**View LUN Clone Schedules**

You can display a list of all the LUN clone schedules defined for a Oracle FS System with the Oracle Enterprise Manager for Oracle Flash Storage Systems.

**Prerequisite:** One or more Oracle FS Systems added as an Oracle Enterprise Manager target.

The Oracle FS System system for which you want to view protection schedules must be selected as the target and you must select the source LUN or Clone LUN for which the schedule was created to display the schedule.

1. Select **Oracle Flash Storage System > LUN Clone Schedules**.
2. Select **LUNs** or **Clone LUNs** from the **View** drop-down list.
3. Select the name of a LUN or Clone LUN from the list.
4. If a clone schedule is associated with the LUN or Clone LUN, the following information about the schedule displays:

   **Schedule Name**  Name given to the schedule when it was created.
   **Start Time**     Scheduled time and date to start creating clones of the LUN.
   **Frequency**      How often clones are scheduled to be created.
   **Protected Volume**  Name of the source volume (LUN) from which clones are scheduled to be created.
   **Enabled**        Identifies whether the data protection schedule is enabled.
- Yes indicates that the schedule is actively cloning the protected volume.
- No indicates that the schedule is not cloning the protected volume.

For detailed information or definitions about the displayed data, review the *Oracle Flash Storage System Administrator’s Guide*.

**View Events**

View events from the Oracle FS System with the Oracle Enterprise Manager for Oracle Flash Storage Systems.

**Prerequisite:** One or more Oracle FS Systems added as an Oracle Enterprise Manager target.

The Oracle FS System for which you want to view events must be selected as the target.

1. Select **Oracle Flash Storage Systems > Events**.
   Status is displayed for these items:
   - **Event**: Displays the name of the event generated by the Oracle FS System.
   - **Severity**: Displays either informational, warning, or critical. Informational severity requires no action. A warning does not require immediate action and should be resolved. A critical status requires immediate action to prevent system failures or offline conditions.
   - **Category**: Displays either security, audit, or system. A security event could be a security problem such as an unauthorized request. An audit event tracks tasks performed such as a login. A system event can include problems with the system as well as tasks completed.
   - **Time Occurred**: Indicates the date and time the event occurred.
   - **Affected Item**: Identifies the name of the system object that caused the event.
   - **Description**: Provides a brief description of the event.

2. Select the refresh icon to update the page.

The displayed fields for Oracle FS System system are updated.

For detailed information or definitions about the displayed data, review the *Oracle Flash Storage System Administrator’s Guide*.
CHAPTER 4

Manage Oracle FS System Reports

Generating Oracle FS System Reports Overview

The Oracle Enterprise Manager for Oracle Flash Storage Systems provides pre-defined hardware, I/O, and storage usage reports that you can generate for Oracle FS System.

Hardware reports include a Oracle FS System summary report, a report of the disk drives in the Drive Enclosures associated with the Oracle FS System, and a hardware status report.

The I/O Access for LUNs report charts input and output statistics for the 10 most active LUNs on the Oracle FS System.

The Storage Usage reports shows storage use per LUN associated with the Oracle FS System, and how much storage is used for the different priority, data access, and I/O bias Quality of Service categories.

In addition to pre-defined reports, you can create custom reports. For information on creating custom reports, review the Oracle Enterprise Manager online help.

Related Links

Hardware Reports
Oracle FS System I/O Reports
Oracle FS System Storage Usage Reports
Generate Reports

Generate Reports

You can generate pre-defined reports for any Oracle FS System system previously added as a target.

Prerequisite: One or more Oracle FS Systems added as an Oracle Enterprise Manager target.

If the Oracle FS System for which you want to generate the report is not already selected as the target, you can specify the Oracle FS System to serve as the target for the report.
1 Select **Enterprise > Reports > Information Publisher Reports**.

2 If not expanded, expand the reports in the Information Publisher Reports list by selecting **Expand All**.

3 Locate the **Oracle Flash Storage Reports** or enter information in the search fields.

4 Click the name report you want to view. The **Specify Target for Report** dialog displays.

5 Verify the name of the target in the **Target** field. If no target is specified, click the magnifying glass icon to search for a target Oracle Flash Storage System to include in the report.

6 Select the **Select** button to chose the host target.

7 Click the **Select** button to save your choice.

8 Click **Continue**. The selected report displays in a new window.

9 (Optional) To capture the output of the report, do either of the following:
   - Click **Printable Page** and use the web browser print function to print the report.
   - Click the comma icon in the top right corner of a report to open the report or save it as a comma-separated value (CSV) file.

For detailed information or definitions about the displayed data, review the *Oracle Flash Storage System Administrator’s Guide*.
CHAPTER 5

Manage Oracle FS System

Managing Host Groups Overview

You can create, modify, or delete host groups in Oracle Enterprise Manager with the Oracle Enterprise Manager for Oracle Flash Storage Systems. You can also assign a new host to a previously created host group.

You can organize SAN hosts into logical units by creating host groups. Creating host groups enables you to manage related hosts without specifying each individual host. As the system changes, you can modify the names of your host groups, and you can delete host groups that you no longer need.

When you first create a host group, you specify only a host group name. Once you create the host group name, you can assign hosts to the group.

Related Links

View Host Groups
Create a Host Group
Modify a Host Group
Delete a Host Group
Assign a Host to a Host Group

Create a Host Group

Creating a host group allows you to associate registered SAN hosts into logical organizational units.

Prerequisite: One or more Oracle FS Systems added as an Oracle Enterprise Manager target.

The Oracle FS System for which you want to create a host group must be selected as the target.

1 Select Oracle Flash Storage System > Hosts.
2 Select Host Groups from the View drop-down list.
3 Select Actions > Create.
4 In the Create Host Group dialog, enter a name for your host group in the Host Group Name field and click OK.
5 Click OK in the Create Host Group Succeeded dialog. The new host group displays in the host groups page.
Modify a Host Group

You can modify a host group only by changing its name.

**Prerequisite:** One or more Oracle FS Systems added as an Oracle Enterprise Manager target.

The Oracle FS System system for which you want to modify a host group must be selected as the target.

1. Select **Oracle Flash Storage System > Hosts**.
2. Select **Host Groups** from the **View** drop-down list.
3. Select the host group you want to modify.
4. Select **Actions > Modify**.
5. Enter a new name in the **Modify Host Group** dialog and click **OK**.
6. Click **OK** in the confirmation dialog.

The new host group name displays in the host groups page.

For detailed information or definitions about the displayed data, review the *Oracle Flash Storage System Administrator’s Guide*.

Delete a Host Group

You can delete a host group when the group is no longer needed because of changes to the hosts that comprise the group.

**Prerequisite:** One or more Oracle FS Systems added as an Oracle Enterprise Manager target.

The Oracle FS System system from which you want to delete a host group must be selected as the target.

**Important:** When you delete a host group, you must replace any mappings to the host group with mappings to a different host group, or with mappings to individual hosts within the deleted host group.

1. Select **Oracle Flash Storage System > Hosts**.
2. Select **Host Groups** from the **View** drop-down list.
3. Select the host group you want to delete.
4. Select **Actions > Delete**.
5. Click **OK** to confirm that you want to delete the host group.
6. Click **OK** in the confirmation dialog.

The host group no longer displays in the list on the host groups page.

For detailed information or definitions about the displayed data, review the *Oracle Flash Storage System Administrator’s Guide*. 
Assign a Host to a Host Group

Once you have created a host group, you can assign hosts to the host group.

**Prerequisites:**
- One or more Oracle FS Systems added as an Oracle Enterprise Manager target.
- The host group must be created before you assign hosts to it.

The Oracle FS System system for which you want to assign a host to a host group must be selected as the target.

**Note:** In the Oracle FS System Manager (GUI), the Associate Hosts command associates ungrouped initiators with a new host that is created or an existing host. The Assign operation associates (drops into the group) an existing host entity with an existing or newly created host group.

1. Select **Oracle Flash Storage System > Hosts**.
2. Select **SAN Hosts** from the **View** drop-down list.
3. Select the host you want to assign to the host group.
4. Select **Actions > Assign**.
5. In the **Assign SAN Host** dialog, select the host group to which you want to assign this host from the **Assign to Host Group Name** drop-down list.
6. Click OK in the **Assign SAN Host** dialog.
   A confirmation dialog informs you when you have successfully assigned the host to the host group.
7. Click OK in the confirmation dialog.
   The host group name displays in the **Host Group Name** column beside the host name in the SAN Hosts page.

For detailed information or definitions about the displayed data, review the *Oracle Flash Storage System Administrator’s Guide*.

Managing Volume Groups Overview

You can create, modify, or delete Oracle FS System volume groups in Oracle Enterprise Manager with the Oracle Enterprise Manager for Oracle Flash Storage Systems.

Volume groups enable you to organize related logical volumes (LUNs) into groups to manage the volume groups together rather than individually. You can also specify parent-child relationships between volume groups to create group hierarchies.

When you create a volume group, you specify a name and a capacity for the group. Once you create a volume group, you can add LUNs to the group by specifying the volume group name in the Quality of Service (QoS) settings for each LUN.
As your needs change, you can change the name or capacity of an existing volume group, or you can change which LUNs belong to the group by modifying the LUN QoS settings. You can also delete a volume group that is no longer needed, but you need to reassign the LUNs to a different volume group before you delete it.

**Related Links**
- View Volume Groups
- Create a Volume Group
- Modify a Volume Group
- Delete a Volume Group
- Create a Volume Group
- Modify a Volume Group
- Delete a Volume Group
- Create LUN: Quality of Service

**Create a Volume Group**

Volume groups allow you to organize logical volumes (LUNs) into organizational units.

**Prerequisite:** One or more Oracle FS Systems added as an Oracle Enterprise Manager target.

The Oracle FS System system for which you want to create the volume group must be selected as the target.

1. Select **Oracle Flash Storage System > Volume Groups**.
2. Select **Actions > Create**.
3. In the **Create Volume Group** dialog, specify the parameters for the volume group.
   - **Required parameters:**
     - **Volume Group Name**.
     - **Parent Volume Group** or **<none>**. The default value is **<none>**.
4. Click **OK**.
5. Click **OK** in the **Create Volume Group Succeeded** dialog.
   The new volume group displays in the volume groups page.

Add LUNs to the volume group by specifying the volume group name in the Quality of Service (QoS) settings for each LUN.

For detailed information or definitions about the displayed data, review the *Oracle Flash Storage System Administrator’s Guide*. 
Modify a Volume Group

You can modify the name, parent, or capacity of a volume group to meet changing needs for those attributes of the group.

**Prerequisite:** One or more Oracle FS Systems added as an Oracle Enterprise Manager target.

The Oracle FS System system for which you want to modify a volume group must be selected as the target.

1. Select **Oracle Flash Storage System > Volume Groups**.
2. Select the volume group you want to modify.
3. Click **Actions > Modify**.
4. In the **Modify Host Group** dialog, modify parameters for the volume group.
   Parameters you can change:
   - **Volume Group Name**.
   - **Parent Volume Group** or <none>. The default value is <none>, so if you do not choose a parent volume group, the volume group is not assigned a parent volume group.
5. Click **OK**.
6. Click **OK** in the confirmation dialog.
   Changes to the volume group display in the volume groups page.

Modify LUN membership in the volume group by changing the volume group name in the Quality of Service (QoS) settings for each LUN.

For detailed information or definitions about the displayed data, review the *Oracle Flash Storage System Administrator’s Guide*.

Delete a Volume Group

You can delete a volume group after you have reassigned all its logical volumes (LUNs) to different volume groups.

**Prerequisites:**
- One or more Oracle FS Systems added as an Oracle Enterprise Manager target.
- All LUNs in the volume group reassigned to other volume groups before you delete the volume group.

**CAUTION:** Before you delete a volume group, reassign its LUNs to other volume groups by changing the volume group name in the Quality of Service (QoS) settings for the LUNs. Deleting a volume group that still has LUNs assigned to it can disrupt operations on the target Oracle FS System.

The Oracle FS System system from which you want to delete a volume group must be selected as the target.
1. Select **Oracle Flash Storage System > Volume Group**.
2. Select the volume group you want to delete.
3. Click **Actions > Delete**.
4. Click **OK**.
5. Click **OK** in the confirmation dialog.
   The volume group is removed from the list on the volume groups page.

### Managing Storage Domains Overview

You can create, modify, or delete Storage Domain in Oracle Enterprise Manager with the Oracle Enterprise Manager for Oracle Flash Storage Systems. You can also associate Drive Enclosures with an existing Storage Domain on the target Oracle FS System.

Storage Domains are logical units that allow you to assign LUNs to a specific collection of Drive Enclosures on a Oracle FS System. All LUNs belong to a Storage Domain. When you create a LUN, it is automatically assigned to the default Storage Domain, or you can specify a different Storage Domain in the Quality of Service (QoS) settings for the LUN.

When you create a Storage Domain, you specify a name for the Storage Domain. Once you create a Storage Domain, you can associate Drive Enclosures with the Storage Domain, and you can assign LUNs to the Storage Domain by specifying the Storage Domain name in the QoS settings for the LUN. You can also make the new Storage Domain the primary Storage Domain.

You can change the name of a Storage Domain or you can change the Drive Enclosures that are associated with the Storage Domain. You can also change whether the Storage Domain is the primary domain, and you can delete a Storage Domain that is no longer needed. To change which LUNs are assigned to the Storage Domain, you must change the specified Storage Domain name in the QoS settings for the LUNs.

### Related Links

- **View Storage Domains**
- **Create a Storage Domain**
- **Modify a Storage Domain**
- **Delete a Storage Domain**
- **Change Drive Group to Primary Drive Group**
- **Create a Volume Group**
- **Modify a Volume Group**
- **Delete a Volume Group**
- **Create LUN: Quality of Service**
Create a Storage Domain

Creating a Storage Domain allows you to assign LUNs to a specific collection of Drive Enclosures in an Oracle FS System.

**Prerequisite:** One or more Oracle FS Systems added as an Oracle Enterprise Manager target.

The Oracle FS System for which you want to create the Storage Domain must be selected as the target.

1. Select Oracle Flash Storage System > Storage Domains.
2. Select Storage Domains from the View drop-down list.
3. Click Actions > Create.
4. In the Create Storage Domain dialog, enter a name for the Storage Domain.
5. Select the background process priority from the pull-down one of these choices which is either system chooses, minimize impact, or maximize speed. System chooses is the recommended value.
6. Check or uncheck Enable tier allocation. The default value is enable tier allocation.
7. Check or uncheck Enable tier allocation statistics collection. The default value is enable tier allocation statistics.
8. Click OK in the Create Storage Domain Succeeded dialog.

The new Storage Domain displays in the Storage Domains page.

For detailed information or definitions about the displayed data, review the Oracle Flash Storage System Administrator’s Guide.

Modify a Storage Domain

You can change the name or the Primary Storage Domain attribute of a Storage Domain.

**Prerequisite:** One or more Oracle FS Systems added as an Oracle Enterprise Manager target.

The Oracle FS System system for which you want to modify a Storage Domain must be selected as the target.

1. Select Oracle Flash Storage System > Storage Domains.
2. Select Storage Domains from the View drop-down list.
3. Select the Storage Domain you want to modify.
4. Click Actions > Modify.

In the Modify Storage Domain dialog, do either of the following:

- Enter a new name for the Storage Domain.
- Select or clear the Primary check box.
5 Click OK.
6 Click OK in the confirmation dialog.
The new Storage Domain name displays in the Storage Domain page.

**Delete a Storage Domain**
You can delete a Storage Domain when it is no longer needed.

**Prerequisite:** One or more Oracle FS Systems added as an Oracle Enterprise Manager target.

The Oracle FS System system from which you want to delete the Storage Domain must be selected as the target.

1 Select **Oracle Flash Storage System > Storage Domains** from the target drop-down list.
2 Select **Storage Domains** from the **View** drop-down list.
3 Select the Storage Domain you want to delete.
4 Click **Actions > Delete**.
5 Click **OK** to confirm that you want to delete the Storage Domain.
6 Click **OK** in the confirmation dialog.
The Storage Domain no longer displays in the list on the Storage Domain page.

**Change Drive Group to Primary Drive Group**
You can change a drive group to be the primary drive group.

**Prerequisite:** One or more Oracle FS Systems added as an Oracle Enterprise Manager target.

The Oracle FS System system for which you want to associate a Drive Enclosure with a Storage Domain must be selected as the target.

1 Select **Oracle Flash Storage System > Storage Domains**.
2 Select **Drive Groups** from the **View** drop-down list.
3 Select the Drive Group you want to change to the primary drive group.
4 Click **Actions > Modify**.
5 Click **Make this the primary drive group**. The primary drive group contains system configuration information. A confirmation dialog informs you when you have successfully changed this drive group to the primary drive group.
6 Click **OK** in the confirmation dialog.

**Managing LUNs**
You can create, modify, or delete Oracle FS System LUNs or Clone LUNs in Oracle Enterprise Manager with the Oracle Enterprise Manager for Oracle Flash
Storage Systems. You can also copy or clone LUNs on the target Oracle FS System.

The Oracle Enterprise Manager for Oracle Flash Storage Systems provides a wizard to guide you through the process of creating or modifying an Oracle FS System LUN. The plug-in also provides a **Delete** button you can use to remove a LUN you no longer need, a **Copy** button you can use to copy a LUN for use as a template to create a new LUN, and a **Clone** button you can use to create a point-in-time back-up copy of a LUN.

**Related Links**
- View LUNs or Clone LUNs
- Delete a LUN
- Copy a LUN
- Clone a LUN

**Creating LUNs Overview**

The Oracle Enterprise Manager for Oracle Flash Storage Systems provides a wizard to guide you through the process of creating a LUN.

The plug-in Create LUN wizard is similar to the Create SAN LUN wizard in the Oracle FS System Manager (GUI).

The wizard starts when you click **Actions > Create**.

The wizard contains two tabs for Single Tier and Auto-Tier. Whether you choose Single Tier or Auto Tier, there are three tabs for LUN information: quality of service, mapping, and data protection. Each tab contains fields for selecting LUN properties. These fields are automatically filled in with default values.

Clicking **OK** at the bottom of any tab saves the LUN with the default values, or with any new values you have added, in each of the tabs.

For detailed information or definitions about the displayed data, review the *Oracle Flash Storage System Administrator’s Guide*.

**Related Links**
- View LUNs or Clone LUNs
- Delete a LUN
- Copy a LUN
- Clone a LUN
- Create LUN: Data Protection
- Create LUN: Mapping to All Hosts
- Create LUN: Mapping to Selected Hosts
- Create LUN: Quality of Service
Create a LUN

Use the Create LUN wizard to create a LUN with the Oracle Enterprise Manager for Oracle Flash Storage Systems.

Prerequisite: One or more Oracle FS Systems added as an Oracle Enterprise Manager target.

The Oracle FS System on which you want to create the LUN must be selected as the target.

1. Select Oracle Flash Storage System > LUNs.
2. Select LUNs or Clone LUNs from the View/Manage drop-down menu.
3. Click Actions > Create.
   The Create LUN wizard displays.

Choose single tier or auto tier and then add LUN properties in the quality of service, mapping, and data protection tabs in the Create LUN wizard, or use the default properties. Click OK when you are finished.

The plug-in Create LUN wizard is nearly identical to the Create SAN LUN wizard in the Oracle FS System Manager (GUI).

The wizard starts when you click Actions > Create.

The wizard contains two tabs for Single Tier and Auto-Tier. Whether you choose Single Tier or Auto Tier, there are three tabs for LUN information: quality of service, mapping, and data protection. Each tab contains fields for selecting LUN properties. These fields are automatically filled in with default values.

Clicking OK at the bottom of any tab saves the LUN with the default values, or with any new values you have added, in each of the tabs.

For detailed information or definitions about the displayed data, review the Oracle Flash Storage System Administrator’s Guide.

Create LUN: Quality of Service

Specify Quality of Service (QoS) attributes to allocate the storage resources necessary to create the LUN.

You can specify a name, Storage Domain, volume group, Storage Profile, and Storage Class attributes for the LUN, as well as priority level, redundancy, capacity, and other QoS attributes, in the Quality of Service tab.

1. Select Single Tier or Auto Tier.
2. Click the Quality of Service tab.
3. Select a Storage Domain for the LUN from the drop-down list. Click the ellipsis button [...] to review the available storage capacity for each Storage Domain.
4. Enter the LUN Name.
5 (Optional) Select the volume group to which you want the new LUN to belong.

6 From the **Storage Profile** drop-down list, select an existing profile or select **Custom** to create a new Storage Profile.
   - If you select an existing Storage Profile, the system updates the QoS attributes as defined by the selected profile. Some fields are grayed out (unavailable) which indicates you cannot make changes to those fields as the fields were defined by the storage profile.
   - If you select **Custom**, choose a **Storage Class** and then select either **Basic** or **Advanced**:
     - **Basic** Complete these fields: Typical Access, I/O Bias, Redundancy, and Priority Level.
     - **Advanced** Complete these fields: RAID Level, Read Ahead, and Priority Level.

7 Select a value for **Background Copy Priority**

8 Adjust the values in the following fields as necessary: **Capacity** and **Allocated Logical Capacity**.

9 (Optional) Click **OK** to create the LUN now.

Clicking **OK** saves the LUN with the QoS settings and any attributes you set in the **Mapping** and **Data Protection** tabs.

After you have defined the QoS attributes for the LUN, you define mappings to the LUN, to either specific hosts or all hosts, in the **Mapping** tab.

For detailed information or definitions about the displayed data, review the *Oracle Flash Storage System Administrator’s Guide*.

**Create LUN: Mapping to Selected Hosts**

Map the LUN to one or more SAN hosts to allow only those specific hosts to access the LUN.

When you need to restrict access to a LUN, such as when the LUN contains sensitive data, map access to the LUN to a specific host or group of hosts.

1 Click the **Mapping** tab.

2 Select the appropriate **Access Protocol**: Fibre Channel (FC), iSCSI, or both. This selection determines the protocols that will be permitted for accessing the LUN.

   **Important**: When you select both FC and iSCSI protocols, the system uses FC optimized and non-optimized paths as a preference over iSCSI paths. Also, the system does not mix load balancing between protocols.

3 Click the **Only selected hosts** option.

4 Select a Controller in the **LUN Controller Assignment** section.
Two storage Controller fields appear. For new LUNs, the Current Controller field is not available. From the Assigned Controller drop-down list, select a Controller or select auto-assign.

If you select auto-assign, the system determines the Controller. You can modify the value or select a new value after the LUN has been created.

5 To create a new host mapping, click Create and select values for the LUN mapping fields:
   • **Host Name**: Select the host to associate to the LUN.
   • **LUN Number**: Select the number to assign to the LUN for the selected host and click OK. This number must be unique for that particular host. It does not need to be unique across all hosts.

6 (Optional) Click OK and Continue to select additional hosts to map to the LUN.

7 In the Ports Masked for this LUN table, indicate which ports you want masked by selecting Yes or No in the Masked column.

8 (Optional) Click OK to create the LUN now.

Clicking OK saves the LUN with the LUN-to-host mapping and any attributes you set in the Quality of Service and Data Protection tabs.

After you have defined the host mappings for a LUN, you must next define Data Protection settings for the LUN.

For detailed information or definitions about the displayed data, review the Oracle Flash Storage System Administrator’s Guide.

**Create LUN: Mapping to All Hosts**

Map the LUN to a unique LUN number to allow all SAN hosts to access the LUN.

1 Click the Mapping tab.

2 Select the appropriate Access Protocol: Fibre Channel (FC), iSCSI, or both. This selection determines the protocols used to access the LUN.

   **Important**: When you select both FC and iSCSI protocols, the system uses FC optimized and non-optimized paths as a preference over iSCSI paths. Also, the system does not mix load balancing between protocols.

3 Select All hosts may access this LUN using LUN number.

4 Select a number for the LUN from the drop-down list to the right of the previous option.

5 Select a Controller in the LUN Controller Assignment section.

Two storage Controller fields appear. For new LUNs, the Current Controller field is not available. From the Assigned Controller drop-down list, select a Controller or select auto-assign.
If you select **auto-assign**, the system determines the Controller. You can modify the value or select a new value after the LUN has been created.

6  In the **Ports Masked for this LUN** table, indicate which ports you want masked by selecting **Yes** or **No** in the Masked column.

7  (Optional) Click **OK** to create the LUN now.

Clicking **OK** saves the LUN with the LUN number mapping and any attributes you set in the Quality of Service and Data Protection tabs.

After you have defined the LUN number mapping for a LUN, you must next define Data Protection settings for the LUN.

**Create LUN: Data Protection**

Allocate capacity for clones of the LUN to ensure protection of the LUN data.

To make sure that enough storage space exists for clones of a LUN, you must allocate a repository for clones when you create the LUN.

To set sufficient capacity, use a value equal to the source LUN capacity times the number of Clone LUNs times the maximum rate of change.

1  Click the **Data Protection** tab.

2  Choose **Single Tier** or **Auto Tier**.

3  Click the **Enable Clones**.

4  Adjust the value in the **Maximum capacity** field by clicking the **Increment** or **Decrement** arrow or entering a new value in the field.

The default value is the available capacity for Clone LUNs, which corresponds to the LUN capacity you set as the Addressable Logical Capacity for the LUN in the Quality of Service tab.

5  If you want to use the same QoS settings for the clone LUN, click the **Match Repository QoS to Tier Qos**. If not, then complete the following fields:

   a) Select the Storage Domain.

   b) Select the Storage Class.

   c) Select either **Basic** or **Advanced**.

   **Basic** Complete these fields: Typical Access, I/O Bias, Redundancy, and Priority Level.

   **Advanced** Complete these fields: RAID Level and Priority Level.

6  Click **OK** to save the LUN.

Clicking **OK** saves the LUN with the new capacity allocation and the attributes you set in the Quality of Service and Mapping tabs.

For detailed information or definitions about the displayed data, review the *Oracle Flash Storage System Administrator’s Guide*. 
Modifying LUNs Overview

The Oracle Enterprise Manager for Oracle Flash Storage Systems provides a wizard to guide you through the process of modifying a LUN.

The Modify LUN wizard is nearly identical to the wizard you use to create LUNs.

The wizard starts when you select a LUN and click **Modify** at the bottom of the LUNs or Clone LUNs page.

The wizard contains three tabs: quality of service, mapping, and data protection. Each tab contains fields for selecting LUN properties. These fields are automatically filled in with default values. Clicking the **OK** button at the bottom of a tab saves the LUN with any changes you make to the values in any of the tabs.

**Related Links**

- View LUNs or Clone LUNs
- Delete a LUN
- Copy a LUN
- Clone a LUN
- Modify LUN: Data Protection
- Modify LUN: Mapped to All Hosts
- Modify LUN: Mapped to Specific Hosts
- Modify LUN: Quality of Service

**Modify a LUN**

Use the Modify LUN wizard to change the properties of an existing LUN with the Oracle Enterprise Manager for Oracle Flash Storage Systems.

**Prerequisite:** One or more Oracle FS Systems added as an Oracle Enterprise Manager target.

The Oracle FS System in which the LUN you want to modify resides must be selected as the target.

1. Select **Oracle Flash Storage System > LUNs.**
2. Select **LUNs or Clone LUNs** from the **View/Manage** drop-down menu.
3. Click **Actions > Modify.**
   The Modify LUN wizard displays.

Modify LUN properties in the quality of service, mapping, and data protection tabs in the Modify LUN wizard, or keep the existing properties. Click OK when you are finished.

For detailed information or definitions about the displayed data, review the **Oracle Flash Storage System Administrator’s Guide.**
Modify LUN: Quality of Service

Modify the current Quality of Service (QoS) attributes to change the QoS settings for the LUN.

As requirements for a LUN change, you can modify the name, Storage Domain, volume group, Storage Profile, Storage Class, and other attributes of the LUN in the Quality of Service tab.

1. Click the Quality of Service tab.
2. Click either Single Tier or Auto Tier.
3. Modify the necessary volume group, Storage Domain membership settings, and QoS attributes.
   - Click the ellipsis button [...] beside the Storage Domain, Volume Group, or Storage Profile field for more information about choices for those fields.
   - Refer to the Capacity by Storage Class table for more information about storage classes.
4. Select Basic or Advanced.
   - Basic Modify these fields: Typical Access, I/O Bias, Redundancy, and Priority Level.
   - Advanced Modify these fields: RAID Level, Read Ahead, and Priority Level.
5. Click OK to save all of your updates, or continue on to the Mapping and Data Protection tabs to make additional updates to the LUN.

Modify LUN: Mapped to Specific Hosts

Remap the LUN to restrict access to one or more specific SAN hosts, or map additional hosts to the LUN.

To restrict access to a LUN, map it to one or more specific SAN hosts. Map additional hosts to extend access to more SAN hosts.

1. Click the Mapping tab.
2. Select the appropriate Access Protocol: Fibre Channel (FC), iSCSI, or both. This selection determines the protocols that will be permitted for accessing the LUN.
   - Important: When you select both FC and iSCSI protocols, the system uses FC optimized and non-optimized paths as a preference over iSCSI paths. Also, the system does not mix load balancing between protocols.
3. Click the Only selected hosts option.
4. In the Ports Masked for this LUN table, you can select Yes or No in the Masked column to determine whether a port should be masked or not.
In the LUN Controller Assignment section, two Controller settings appear. The Current Controller field is informational only. From the Assigned Controller drop-down list, select a CU or select auto-assign. The system auto-assigns the LUN to an available Controller.

Click Create to create a new host mapping. Select values for the LUN mapping fields:

- **Host Name**: Select the host to associate with the LUN.
- **LUN Number**: Select the number to assign to the LUN for the selected host, and click OK. This number must be unique for that particular host but does need not to be unique across all hosts.

(Optional) Click Create to create more host mappings.

Click OK to save all of your updates, or continue on to the Data Protection tab to make additional updates to the LUN.

**Modify LUN: Mapped to All Hosts**

Remap the LUN to a LUN number to make it available to all SAN hosts, or you can change a previously assigned LUN number.

To provide unrestricted access to a LUN, remap the LUN to a unique LUN number that all SAN hosts can use.

1. Click the Mapping tab.
2. Select the appropriate **Access Protocol**: Fibre Channel (FC), iSCSI, or both. This selection determines the protocols that will be permitted for accessing the LUN.

**Important**: When you select both FC and iSCSI protocols, the system uses FC optimized and non-optimized paths as a preference over iSCSI paths. Also, the system does not mix load balancing between protocols.

3. Click the **All hosts may access this LUN using LUN number** option.
4. Modify the number for the LUN from the drop-down list to the right of the previous option.

In the LUN Controller Assignment section, from the two settings that appear: Current Controller and Assigned Controller, select a Controller or select auto-assign.

6. Click OK to save all of your updates, or continue on to the Data Protection tab to make additional updates to the LUN.

For detailed information or definitions about the displayed data, review the Oracle Flash Storage System Administrator’s Guide.
Modify LUN: Data Protection

Reallocate capacity for clones of the LUN to ensure adequate protection of the LUN data.

1. Click the Data Protection tab.
2. Choose Single Tier or Auto Tier.
3. Click the Enable Clones.
4. Adjust the value in the Maximum capacity field by clicking the Increment or Decrement arrow or entering a new value in the field.
   The default value is the available capacity for Clone LUNs, which corresponds to the LUN capacity you set as the Addressable Logical Capacity for the LUN in the Quality of Service tab.
5. If you want to use the same QoS settings for the clone LUN, click the Match Repository QoS to Tier Qos. If not, then complete the following fields:
   a) Select the Storage Domain.
   b) Select the Storage Class.
   c) Select either Basic or Advanced.
      - Basic: Complete these fields: Typical Access, I/O Bias, Redundancy, and Priority Level.
      - Advanced: Complete these fields: RAID Level and Priority Level.
6. Click OK to save the LUN.

Enable Data Path for LUN

Enabling the data path to a LUN restores the communication between the mapped SAN host entry and the volume. When the data path to a LUN has been disabled, you can provide the ability of a SAN host entry to access that LUN using the host mappings already established.

**Prerequisite:** One or more Oracle FS Systems added as an Oracle Enterprise Manager target.

The Oracle FS System for which you want to delete the LUN must be selected as the target.

1. Select Oracle Flash Storage System > LUNs.
2. Select one of the following from the View/Manage drop-down list:
   - LUNs if you want to enable a data path to a LUN.
   - Clone LUNs if you want to enable a data path to a Clone LUN.
3. Select the LUN or Clone LUN you want to enable the data path to access the LUN.
4. Click Actions > Enable Data Path for LUN.
A confirmation dialog asks if you are sure you want to enable data path to the LUN or Clone LUN.

5 Click OK in the confirmation dialog.
The data path is enabled to the LUN or Clone LUN. You can verify this by reviewing the LUNs information page under Access Information where Data Path is displayed as Enabled.

Disable Data Path for LUN
You can remove the ability of a SAN host entry to access a LUN or Clone LUN but not remove the host mappings to the logical volume. This enables you to restore the SAN host entry access when necessary

Prerequisite: One or more Oracle FS Systems added as an Oracle Enterprise Manager target.

The Oracle FS System for which you want to delete the LUN must be selected as the target.

1 Select Oracle Flash Storage System > LUNs.
2 Select one of the following from the View/Manage drop-down list:
   • LUNs if you want to disenable a data path to a LUN.
   • Clone LUNs if you want to disenable a data path to a Clone LUN.
3 Select the LUN or Clone LUN you want to disenable the data path to access the LUN.
4 Click Actions > Disable Data Path for LUN.
   A confirmation dialog asks if you are sure you want to enable data path to the LUN or Clone LUN.
5 Click OK in the confirmation dialog.
The data path is enabled to the LUN or Clone LUN. You can verify this by reviewing the LUNs information page under Access Information where Data Path is displayed as Disabled.

Delete a LUN
You can delete a LUN or a Clone LUN when the LUN is no longer needed.

Prerequisite: One or more Oracle FS Systems added as an Oracle Enterprise Manager target.

The Oracle FS System for which you want to delete the LUN must be selected as the target.

1 Select Oracle Flash Storage System > LUNs.
2 Select one of the following from the View/Manage drop-down list:
   • LUNs if you want to delete a LUN
   • Clone LUNs if you want to delete a Clone LUN.
3 Select the LUN or Clone LUN you want to delete.

4 Click **Actions > Delete**. A confirmation dialog asks if you are sure you want to delete the LUN, and if you also want to delete any data protection schedules associated with the LUN or Clone LUN.

5 (Optional) Select **Also Delete Protection Schedules** if there are data protection schedules associated with the LUN that you want to delete when you delete the LUN.

6 Click **OK** in the confirmation dialog. The LUN no longer appears in the list on the LUNs or Clone LUNs page. If you selected **Also Delete Protection Schedules**, any data protection schedules associated with the LUN are removed.

---

**Copy a LUN**

You can copy a LUN when you want to create a new LUN with different Quality of Service (QoS), mapping, and data protection properties from those of the source LUN.

**Prerequisite:** One or more Oracle FS Systems added as an Oracle Enterprise Manager target.

The Oracle FS System for which you want to copy the LUN must be selected as the target.

1 Select **Oracle Flash Storage System > LUNs**.
2 Select **LUNs** from the **View/Manage** drop-down list.
3 Select the LUN that you want to copy.
4 Click **Copy** at the bottom of the LUNs page.
5 Make any necessary changes in the Quality of Service, Mapping, and Data Protection tabs of the Copy LUN page.
6 Click **OK** in the Copy LUN page. A confirmation dialog informs you when the copy has been created successfully.
7 Click **OK** in the confirmation dialog. The LUN copy appears in the list of LUNs on the LUNs page with “Copy of” prepended to the source LUN name.

For detailed information or definitions about the displayed data, review the *Oracle Flash Storage System Administrator’s Guide*. 
Clone a LUN

You can clone a LUN when you want to create a point-in-time copy of a LUN with the same Quality of Service (QoS) properties as the original.

Prerequisite: One or more Oracle FS Systems added as an Oracle Enterprise Manager target.

The Oracle FS System system for which you want to clone the LUN must be selected as the target.

1. Select Oracle Flash Storage System > LUNs.
2. Select LUNs from the View/Manage drop-down list.
3. Select the LUN that you want to clone.
4. Click Actions > Clone.
5. Make any available changes in the Quality of Service and Mapping tabs of the Clone LUN page.
6. Click OK in the Clone LUN page.
   A confirmation dialog informs you when the Clone Volume (LUN) has been successfully created.
7. Click OK in the confirmation dialog.
   The Clone LUN appears in the list of clones on the Clone LUNs page with “Clone of” prepended to the source LUN name.

For detailed information or definitions about the displayed data, review the Oracle Flash Storage System Administrator’s Guide.

Managing Protection Schedules Overview

You can create, modify, or delete schedules for protecting the data in a LUN or Clone LUN by making clones of the source LUN at regular intervals in Oracle Enterprise Manager with the Oracle Enterprise Manager for Oracle Flash Storage Systems.

Data protection schedules create clones of a source LUN or Clone LUN at regularly scheduled intervals. When you create a protection schedule, you can enable it to run at the scheduled time as soon as you save the schedule, or you can create a schedule and enable it later. You can modify the schedule to as needed, and delete a schedule when the schedule is no longer needed.

Related Links

Create a Protection Schedule
Modify a Protection Schedule
Delete a Protection Schedule
Create a Protection Schedule

You can create a replication schedule to create a clone of a protected LUN or Clone LUN at regular intervals

**Prerequisite:** One or more Oracle FS Systems added as an Oracle Enterprise Manager target.

The Oracle FS System system for which you want to create a protection schedule must be selected as the target.

1. Select **Oracle Flash Storage System > Protection Schedules**.
2. Select LUNs or Clone LUNs from the **View/Manage** drop-down menu.
   - Choose LUNs if you want to schedule protection for a LUN, or choose Clone LUNs if you want to schedule protection for a Clone LUN.
3. Select the LUN or Clone LUN for which you want to create a protection schedule.
4. Click **Actions > Create**.
5. In the **Create LUN Clone Schedule** dialog, enter a name for the schedule in the **Schedule Name** field.
   - **Tip:** Use a meaningful name that includes the type of protection and frequency to help you identify the schedule if you want to modify the schedule later.
6. (Optional) From the **Volume Group** drop-down list, choose the name of the volume group to which the clone volume is assigned.
7. Select **Enabled** if you would like your schedule to start as soon as it is created.
   - If you do not enable your schedule now, you can do so at a later time by modifying the schedule.
8. Verify that the **Protected Volume** is the LUN or Clone LUN that you selected.
9. Use the controls in the Schedule panel to select the date and time.
10. Choose a frequency for your schedule:
    - Run Once
    - Hourly
    - Daily
    - Weekly
    - Monthly
11. In the Recurrence panel, choose a recurrence value for your schedule.
    - If you chose a frequency of **Weekly**, choose the day of the week as well.
12. To save the schedule, click **OK**.
    - Your schedule is listed in the Selected LUN Protection Schedules panel.
Modify a Protection Schedule

You can modify a protection schedule to suit your needs.

**Prerequisite:** One or more Oracle FS Systems added as an Oracle Enterprise Manager target.

The Oracle FS System for which you want to create a protection schedule must be selected as the target and you must select the source LUN or Clone LUN that is the protected volume for the schedule in the LUNs or Clone LUNs list.

1. Select **Oracle Flash Storage System > LUN Clone Schedules**.
2. Select **LUNs** or **Clone LUNs** from the **View/Manage** drop-down menu. Choose **LUNs** if the schedule you want to modify protects a LUN, or choose **Clone LUNs** if the schedule protects a Clone LUN.
3. Select the LUN or Clone LUN for which you created the protection schedule.
   The schedule you want to modify displays in the Selected LUN Protection Schedules panel.
4. Click **Actions > Modify**.
5. In the **Create Data Protection Schedule** dialog, enter a name for the schedule in the **Schedule Name** field.
   **Tip:** Use a meaningful name that includes the type of protection and frequency to help you identify the schedule to modify the schedule later.
6. Verify that **Clone** is selected as the data protection type.
7. (Optional) From the **Volume Group** drop-down list, choose the name of a different volume group to which the clone volume are assigned.
8. Select **Enabled** if you would like your schedule to start as soon as you save your changes.
9. Verify that the **Protected Volume** is the LUN or Clone LUN that you selected.
10. Use the controls in the Schedule panel to select the date and time.
11. Choose a frequency for your schedule:
   - Run Once
   - Hourly
   - Daily
   - Weekly
12. In the Recurrence panel, choose a recurrence value for your schedule.
   If you chose a frequency of **Weekly**, choose the day of the week you would like your report to be generated.
13. To save changes to the schedule, click **OK**.
Your modified schedule displays in the Selected LUN Protection Schedules panel.

Delete a Protection Schedule
You can delete a protection schedule when you no longer need it.

Prerequisite: One or more Oracle FS Systems added as an Oracle Enterprise Manager target.

The Oracle FS System from which you want to delete a protection schedule must be selected as the target.

1 Select Oracle Flash Storage System > Protection Schedules.
2 Select LUNs or Clone LUNs from the View/Manage drop-down menu. Choose LUNs if the schedule you want to delete protects a LUN, or choose Clone LUNs if the schedule protects a Clone LUN.
3 Select the LUN or Clone LUN for which you created the protection schedule. The schedule you want to delete displays in the Selected LUN Protection Schedules panel.
4 Click Delete at the bottom of the screen.
5 Click OK to confirm that you want to delete the protection schedule.
6 Click OK to dismiss the confirmation dialog. The schedule no longer appears in the Selected LUN Protection Schedules panel.
Oracle FS System Configuration Data and Metrics

Oracle Enterprise Manager collects a pre-defined set of configuration data and metrics for each Oracle FS System added as a target.

The following table identifies the categories of configuration data collected.

**Note:** For detailed information or definitions about the displayed data, review the *Oracle Flash Storage System Administrator’s Guide*.

**Table 6: Configuration Data collected for Oracle FS Systems**

<table>
<thead>
<tr>
<th>Category</th>
<th>Collected configuration data</th>
</tr>
</thead>
<tbody>
<tr>
<td>Controller Software Configuration</td>
<td>• Build Version</td>
</tr>
<tr>
<td></td>
<td>• Control Unit FQN</td>
</tr>
<tr>
<td></td>
<td>• Release Version</td>
</tr>
<tr>
<td></td>
<td>• Controller Name</td>
</tr>
<tr>
<td></td>
<td>• Version String</td>
</tr>
<tr>
<td>Drive Enclosures Software Configuration</td>
<td>• Build Version</td>
</tr>
<tr>
<td></td>
<td>• Name</td>
</tr>
<tr>
<td></td>
<td>• Release Version</td>
</tr>
<tr>
<td></td>
<td>• Version String</td>
</tr>
<tr>
<td>Pilot Software Configuration</td>
<td>• Control Unit Name</td>
</tr>
<tr>
<td></td>
<td>• Build Version</td>
</tr>
<tr>
<td></td>
<td>• Control Unit Serial Number</td>
</tr>
<tr>
<td></td>
<td>• Release Version</td>
</tr>
<tr>
<td></td>
<td>• Version String</td>
</tr>
</tbody>
</table>
Table 6: Configuration Data collected for Oracle FS Systems (continued)

<table>
<thead>
<tr>
<th>Category</th>
<th>Collected configuration data</th>
</tr>
</thead>
<tbody>
<tr>
<td>Connected SAN Host Configuration</td>
<td>Host Name</td>
</tr>
<tr>
<td></td>
<td>Host FQN</td>
</tr>
<tr>
<td></td>
<td>IP Address</td>
</tr>
<tr>
<td></td>
<td>Host ID</td>
</tr>
<tr>
<td></td>
<td>Operating System</td>
</tr>
<tr>
<td></td>
<td>FSPM Version</td>
</tr>
</tbody>
</table>

| Oracle Flash Storage System Configuration     | Serial Number                |
|                                               | Contact Name                 |
|                                               | Contact Phone Number         |
|                                               | IP Address                   |
|                                               | Model Name                   |
|                                               | System Name                  |

The following table identifies the categories of metrics collected. You can modify the values associated with these metrics from either Oracle Flash Storage System > Monitoring > Metric and Collection Settings or Oracle Flash Storage System > Monitoring > All Metrics.

**Note:** For detailed information or definitions about the displayed data, review the Oracle Flash Storage System Administrator’s Guide.

Table 7: Metrics collected for Oracle FS Systems

<table>
<thead>
<tr>
<th>Category</th>
<th>Collected metrics</th>
</tr>
</thead>
<tbody>
<tr>
<td>Controller Details</td>
<td>Name</td>
</tr>
<tr>
<td></td>
<td>Operational Status</td>
</tr>
<tr>
<td></td>
<td>Type</td>
</tr>
<tr>
<td>Disk Drives</td>
<td>Serial Number</td>
</tr>
<tr>
<td></td>
<td>Capacity (GB)</td>
</tr>
<tr>
<td></td>
<td>Drive Enclosure Name</td>
</tr>
<tr>
<td></td>
<td>Drive Number</td>
</tr>
<tr>
<td></td>
<td>Operational Status</td>
</tr>
<tr>
<td>Category</td>
<td>Collected metrics</td>
</tr>
<tr>
<td>--------------------------</td>
<td>----------------------------------------</td>
</tr>
<tr>
<td>Drive Enclosures Details</td>
<td>• Model</td>
</tr>
<tr>
<td></td>
<td>• Name</td>
</tr>
<tr>
<td></td>
<td>• Operational Status</td>
</tr>
<tr>
<td></td>
<td>• Serial Number</td>
</tr>
<tr>
<td></td>
<td>• Temperature Status</td>
</tr>
<tr>
<td></td>
<td>• WWN</td>
</tr>
<tr>
<td>Event Details</td>
<td>• Timestamp</td>
</tr>
<tr>
<td></td>
<td>• Category</td>
</tr>
<tr>
<td></td>
<td>• Component Name</td>
</tr>
<tr>
<td></td>
<td>• Component GUID</td>
</tr>
<tr>
<td></td>
<td>• Contact Name</td>
</tr>
<tr>
<td></td>
<td>• Contact Phone Number</td>
</tr>
<tr>
<td></td>
<td>• Description</td>
</tr>
<tr>
<td></td>
<td>• Name</td>
</tr>
<tr>
<td></td>
<td>• Severity</td>
</tr>
<tr>
<td></td>
<td>• Type</td>
</tr>
<tr>
<td>Category</td>
<td>Collected metrics</td>
</tr>
<tr>
<td>--------------</td>
<td>--------------------------------------------------------</td>
</tr>
<tr>
<td>LUN Details</td>
<td>• LUID (LUN unique identifier)</td>
</tr>
<tr>
<td></td>
<td>• Access Bias</td>
</tr>
<tr>
<td></td>
<td>• Active</td>
</tr>
<tr>
<td></td>
<td>• Addressable Capacity (Bytes)</td>
</tr>
<tr>
<td></td>
<td>• Addressable Capacity (GB)</td>
</tr>
<tr>
<td></td>
<td>• Allocated Capacity (Bytes)</td>
</tr>
<tr>
<td></td>
<td>• Allocated Capacity (GB)</td>
</tr>
<tr>
<td></td>
<td>• Allocated Clone Capacity (Bytes)</td>
</tr>
<tr>
<td></td>
<td>• Allocated Clone Capacity (GB)</td>
</tr>
<tr>
<td></td>
<td>• Assigned Controller FQN</td>
</tr>
<tr>
<td></td>
<td>• Clone</td>
</tr>
<tr>
<td></td>
<td>• Current Controller FQN</td>
</tr>
<tr>
<td></td>
<td>• IO Bias</td>
</tr>
<tr>
<td></td>
<td>• ID</td>
</tr>
<tr>
<td></td>
<td>• Logical Maximum Clone Capacity (Bytes)</td>
</tr>
<tr>
<td></td>
<td>• Logical Maximum Clone Capacity (GB)</td>
</tr>
<tr>
<td></td>
<td>• Management State</td>
</tr>
<tr>
<td></td>
<td>• Name</td>
</tr>
<tr>
<td></td>
<td>• Priority</td>
</tr>
<tr>
<td></td>
<td>• Redundancy</td>
</tr>
<tr>
<td></td>
<td>• Remaining Clone Capacity (%)</td>
</tr>
<tr>
<td></td>
<td>• Remaining Clone Capacity (GB)</td>
</tr>
<tr>
<td></td>
<td>• Source LUN FQN</td>
</tr>
<tr>
<td></td>
<td>• Source LUN Name</td>
</tr>
<tr>
<td></td>
<td>• Status</td>
</tr>
<tr>
<td></td>
<td>• Storage Class</td>
</tr>
<tr>
<td></td>
<td>• Storage Domain FQN</td>
</tr>
<tr>
<td></td>
<td>• Used Clone Capacity (Bytes)</td>
</tr>
<tr>
<td></td>
<td>• Used Clone Capacity (GB)</td>
</tr>
<tr>
<td></td>
<td>• Volume Group</td>
</tr>
</tbody>
</table>
### Table 7: Metrics collected for Oracle FS Systems (continued)

<table>
<thead>
<tr>
<th>Category</th>
<th>Collected metrics</th>
</tr>
</thead>
<tbody>
<tr>
<td>LUN Statistics</td>
<td>• Cache Flushes each Second</td>
</tr>
<tr>
<td></td>
<td>• Cache Hit Ratio</td>
</tr>
<tr>
<td></td>
<td>• LUN FQN</td>
</tr>
<tr>
<td></td>
<td>• LUN ID</td>
</tr>
<tr>
<td></td>
<td>• LUN Name</td>
</tr>
<tr>
<td></td>
<td>• Non-Optimized I/O each Second</td>
</tr>
<tr>
<td></td>
<td>• Read Block Size</td>
</tr>
<tr>
<td></td>
<td>• Read Bytes Per Second</td>
</tr>
<tr>
<td></td>
<td>• Read I/Os Per Second</td>
</tr>
<tr>
<td></td>
<td>• Read Latency</td>
</tr>
<tr>
<td></td>
<td>• Read Queue Depth</td>
</tr>
<tr>
<td></td>
<td>• Total Block Size</td>
</tr>
<tr>
<td></td>
<td>• Total Bytes each Second</td>
</tr>
<tr>
<td></td>
<td>• Total I/Os each Second</td>
</tr>
<tr>
<td></td>
<td>• Total Latency</td>
</tr>
<tr>
<td></td>
<td>• Total Queue Depth</td>
</tr>
<tr>
<td></td>
<td>• Write Block Size</td>
</tr>
<tr>
<td></td>
<td>• Write Bytes each Second</td>
</tr>
<tr>
<td></td>
<td>• Write I/Os each Second</td>
</tr>
<tr>
<td></td>
<td>• Write Latency</td>
</tr>
<tr>
<td></td>
<td>• Write Queue Depth</td>
</tr>
<tr>
<td>Pilot Details</td>
<td>• Name</td>
</tr>
<tr>
<td></td>
<td>• Mode</td>
</tr>
<tr>
<td></td>
<td>• Operational Status</td>
</tr>
<tr>
<td></td>
<td>• Serial Number</td>
</tr>
<tr>
<td>Response</td>
<td>• Status</td>
</tr>
<tr>
<td></td>
<td>• Thresholds</td>
</tr>
<tr>
<td></td>
<td>• Real Time Value</td>
</tr>
<tr>
<td>SAN Hosts</td>
<td>• Name</td>
</tr>
<tr>
<td></td>
<td>• Status</td>
</tr>
<tr>
<td>Category</td>
<td>Collected metrics</td>
</tr>
<tr>
<td>----------------------</td>
<td>----------------------------------------</td>
</tr>
<tr>
<td>System Details</td>
<td>• Serial Number</td>
</tr>
<tr>
<td></td>
<td>• Allocated Space (%)</td>
</tr>
<tr>
<td></td>
<td>• Allocated Space (GB)</td>
</tr>
<tr>
<td></td>
<td>• Contact Name</td>
</tr>
<tr>
<td></td>
<td>• Contact Phone Number</td>
</tr>
<tr>
<td></td>
<td>• IP Address</td>
</tr>
<tr>
<td></td>
<td>• Model Name</td>
</tr>
<tr>
<td></td>
<td>• Operational Status</td>
</tr>
<tr>
<td></td>
<td>• Remaining Space (%)</td>
</tr>
<tr>
<td></td>
<td>• Remaining Space (GB)</td>
</tr>
<tr>
<td></td>
<td>• System Name</td>
</tr>
<tr>
<td></td>
<td>• Total Space (GB)</td>
</tr>
<tr>
<td>Other Collected Items</td>
<td>• System Details_Config</td>
</tr>
<tr>
<td></td>
<td>• Drive Enclosures Software_Config</td>
</tr>
<tr>
<td></td>
<td>• Pilot Software_Config</td>
</tr>
<tr>
<td></td>
<td>• Controller Software_Config</td>
</tr>
</tbody>
</table>
APPENDIX B

Oracle FS System Reports

Hardware Reports
Hardware reports provide an overview of the system, details about the drives, and hardware components.

Oracle FS System Summary
The Oracle FS System Summary report provides an overview of the system properties, storage usage, and software installed on the components of the selected Oracle FS System.

Disk Drives
The Oracle FS System Disk Drives report lists the properties and status of all drives on each Drive Enclosure associated with the selected Oracle FS System.

Hardware Status
The Hardware Status report provides the status of each component of the selected Oracle FS System.

Oracle FS System I/O Reports
The Oracle Enterprise Manager for Oracle Flash Storage Systems provides one I/O report: the I/O Access for LUNs report.

The I/O Access for LUNs report charts input and output statistics for the ten most active LUNs on the Oracle FS System.

The top portion of the report is a pie chart that shows the percentage of I/O that has occurred on each LUN during the collection period.

The bottom portion of the report is a bar graph that shows the amount of I/O that has occurred on each of the ten most active LUNs on the selected Oracle FS System.
Oracle FS System Storage Usage Reports

The Oracle Enterprise Manager for Oracle Flash Storage Systems provides two storage usage reports: a Storage Usage by LUN report, and a Storage Usage for LUN by QoS report.

The top portion of the Storage Usage by LUN report is a pie chart that shows the percentage of storage usage for each LUN. The bottom portion of the report is a table that shows the serial numbers and sizes of the ten largest capacity LUNs on the selected Oracle FS System.

The Storage Usage for LUN by QoS report consists of three pie charts that show the percentage of storage usage by LUNs that have priority, data access, or I/O bias Quality of Service (QoS) attributes.
# Index

| A | administrator accounts  
|   | about 20  
|   | assignment  
|   | ports 16 |
| B | blackout period  
|   | how to  
|   | create blackout period 23 |
| C | clone LUNs  
|   | capacity 47, 51  
|   | how to  
|   | allocate capacity for 51  
|   | collected configuration data 58  
|   | collected metrics 58  
|   | configuration data  
|   | how to  
|   | view 25  
|   | list of available 58  
|   | overview 25  
|   | contact information 9  
|   | contacts, Oracle 9  
|   | conventions  
|   | command syntax 10  
|   | typographical 10  
|   | create  
|   | LUNs  
|   | define data protection 47  
|   | define mapping by host 45  
|   | define mapping to all hosts 46  
|   | define Quality of Service 44  
|   | create LUNs 43  
|   | credential  
|   | how to  
|   | add named credential 22  
|   | customer support 9 |
| D | data protection  
|   | create LUNs 47  
|   | modify LUNs 51  
|   | documentation  
|   | feedback 9  
|   | download  
|   | EM Plug-In software 17  
|   | Drive Enclosure  
|   | how to  

| associate with Storage Domains 42 |
| E | education programs 9  
|   | EM Plug-In software  
|   | availability 17  
|   | how to  
|   | download 17  
|   | install 16, 18  
|   | remove 19  
|   | verify installation 19 |
| F | feedback, documentation 9 |
| H | host groups  
|   | how to  
|   | assign hosts 37  
|   | create 35  
|   | delete 36  
|   | modify 36  
|   | view 29  
|   | overview 35  
|   | hosts  
|   | how to  
|   | assign to host groups 37  
|   | hosts, SAN  
|   | how to  
|   | map to LUN 45, 46  
|   | modify LUN mapping to all 50 |
| I | installation  
|   | download 17  
|   | install 16, 18  
|   | overview 15  
|   | port assignments 16  
|   | uninstall 19  
|   | verify 19 |
| L | list  
|   | available configuration data 58  
|   | available metrics 58  
|   | log in  
|   | Oracle Enterprise Manager 20  
|   | LUN mapping  
|   | for all hosts 46 |
Index

M
managing
overview 14
mapping
LUNs to all hosts 46
LUNs to specific hosts
modify 49
metrics
how to
update collection schedule 26
view 25
list of available 58
overview 25
modify
LUN mapping
all hosts 50
specific hosts 49
LUNs
data protection 51
Quality of Service 49
modify LUN
allocate capacity for clones 51
modify LUNs
how to
allocate capacity for clones 51
monitoring
overview 13

N
named credential
how to
add 22

O
online help 9
Oracle Documentation 9
Oracle Enterprise Manager
how to
log in 20
Oracle Enterprise Manager for Oracle Flash Storage Systems
managing overview 14
monitoring overview 13
overview 12
Oracle Flash Storage System targets
how to
add 21
Oracle FS System
administrator accounts 20
how to
modify host mapping to LUNs 49
Oracle FS System targets
how to
add 24
Oracle Technology Network 9

P
ports
required 16
POSIX.1-2008 specification 10
product support 9
protection schedules
how to
create 55
delete 57
modify 56
view 31
overview 54

R
reports
hardware 64
how to
generate 33
I/O 64
overview 13, 33
storage usage 65
requirements
operating systems 12
Oracle FS System 12

S
sales information 9
SAN hosts
how to
map to LUN 45
map to LUNs 46
modify LUN mapping to all 50
  view 28
view status 27, 32
Self-Update Console 16
Storage Domains
  how to
    associate drive enclosure 42
    create 41
    delete 42
    modify 41
    view 29
  overview 40
Support portal 9
syntax conventions 10

T
targets
  how to
    add Oracle Flash Storage System 21
    add Oracle FS System 24
training programs 9
typographical conventions 10

V
verify installation
  EM Plug-In software 19
view storage
  overview 26
volume groups
  how to
    create 38
    delete 39
    modify 39
    view 29
  overview 37