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About this guide

Overview of this guide

The InForm Design Guide describes how to design a study for deployment to the InForm application.

Audience
This guide is for users of the Central Designer application, including the following,

User Description

Clinical data manager A user who is involved in the study design process.

Library administrator A user with library administration privileges for one or more
clinical areas.

Central Designer administrator ~ An IT representative who supports and maintains the application
from a technology and infrastructure perspective.

Study design team Users who implement a study. This team includes several roles
such as form designer, rule designer, and study workflow
designer.

Medical project manager A user who works with the CRF designer to create an annotated
study protocol, usually based on existing CRFs for the therapeutic
arca. This user is concerned with the overall set of study
questions and logic, not the individual details of form design.

Statistician A user who interacts with study designers with respect to data
collection needs for analysis.

Translator A user who is responsible for translating text in clinical studies,
forms, items, and rule queries to a specified language.

Prerequisites

You should have experience in one or more of the following clinical areas:

e Data management

e Data analysis

e Study design

e  Library management

e  Project management
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Additionally, rule developers must have the following levels of programming expertise, depending on
the types of rules they will be creating.

Type of rule Required programming expertise

Simple edit checks using rule None.
templates.
Compatisons, calculations. e Understanding of C# or similar (for example, Java, C, or

C++) expression syntax.

e  Ability to incorporate functions in expressions.

User-defined functions. e  Ability to program in a NET language (for example, C#)
and create NET assemblies.

Oracle® Health Sciences Central Designer 2.1 xiii



About this guide

Documentation

The product documentation is available from the following locations:

e Oracle Software Delivery Cloud (https://edelivery.oracle.com)—The complete
documentation set.

e My Oracle Support (https://support.oracle.com)—Relase Notes and Known Lssues.

e Oracle Technology Network (http://www.oracle.com/technetwork/documentation)—The
most current documentation set, excluding the Rekase Notes and Known Issues.

All documents may not be updated for every Central Designer release. Therefore, the version
numbers for the documents in a release may differ.

Item Description

Release Notes The Release Notes document provides detailed information about the requirements,
enhancements, and fixed issues in the current release.

Known Issues The Known Issues document provides detailed information about the known issues
in this release, along with workarounds, if available.

Installation Guide 'The Installation Guide provides system requirements and instructions for installing
and upgrading the Oracle® Health Sciences Central Designer software and the
Oracle® Health Sciences Central Designer Administrator software.

Administrator The Administrator Guide describes how to use the Oracle® Health Sciences Central
Guide Designer Administrator software to set up users, permissions, system
configuration parameters, and catalog defaults.

User Guide The User Guide introduces the study design environment in the Oracle® Health
Sciences Central Designer application and describes how to work as a study
design team in that environment, including how to:

e  Work collaboratively.
e Maximize study design efficiency by reusing study objects.

e Manage collections of study objects.

InForm Design ~ The InForm Design Guide describes how to design a study for deployment to the
Guide InForm application.

Rules Reference 'The Rules Reference Guide is a reference to the tools that are available for creating
Guide rule expressions, including:

e Study object properties.
e TFunctions.

e Constants.

e Data mappings.

e Methods, operators, and literals.
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Item Description

Secure The Secure Confignration Guide provides an overview of the security features
Configuration provided with the Oracle® Health Sciences Central Designer application, including
Guide details about the general principles of application security, and how to install,

configure, and use the Central Designer application securely.

Third Party The Third Party Licenses and Notices document includes licenses and notices for
Licenses and third party technology that may be included with the Central Designer software.
Notices

Documentation accessibility

For information about Oracle's commitment to accessibility, visit the Oracle Accessibility Program
website at http:/ /www.oracle.com/pls/topic/lookuprctx=acc&id=docacc.
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If you need assistance

Oracle customers have access to support through My Oracle Support. For information, visit
http:/ /www.oracle.com/pls/topic/lookuprctx=acc&id=info, ot if you are heating impaired, visit
http:/ /www.oracle.com/pls/topic/lookup?ctx=acc&id=trs.

Finding Central Designher information and patches on My Oracle Support

The latest information about the Central Designer application is on the Oracle Support self-service
website, My Oracle Support. Before you install and use the Central Designer application, check My
Oracle Support for the latest information, including Release Notes and Known Issues, alerts, white
papers, bulletins, and patches.

Creating a My Oracle Support account

You must register at My Oracle Support to obtain a user name and password before you can enter
the site.

1 Open a browser to https://support.oracle.com.
2 Click the Register link.

3 Follow the instructions on the registration page.

Finding information and articles

1 Sign in to My Oracle Support at https://support.oracle.com.

2 If you know the ID number of the article you need, enter the number in the text box at the top
right of any page, and then click the magnifying glass icon or press Enter.

3 To search the knowledge base, click the Knowledge tab, and then use the options on the page to
search by:

e Product name or family.

e Keywords or exact terms.

Finding patches
You can search for patches by patch ID or number, product, or family.
1 Sign in to My Oracle Support at https://support.oracle.com.
2 Click the Patches & Updates tab.
3 Enter your search criteria and click Search.
4 Click the patch ID number.

The system displays details about the patch. You can view the Read Me file before downloading
the patch.

5  Click Download, and then follow the instructions on the screen to download, save, and install the
patch files.
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Finding Oracle documentation

The Oracle website contains links to Oracle user and reference documentation. You can view or
download a single document or an entire product library.

Finding Oracle Health Sciences documentation

For Oracle Health Sciences applications, go to the Oracle Health Sciences Documentation page at
http:/ /www.oracle.com/technetwork/documentation/hsgbu-clinical-407519.html.

Note: Always check the Oracle Health Sciences Documentation page to ensure you have the most
up-to-date documentation.

Finding other Oracle documentation
1 Do one of the following:
¢ Go to http://www.oracle.com/technology/documentation/index.html.

¢ Go to http://www.oracle.com, point to the Support tab, and then click Product
Documentation.

2 Scroll to the product you need, and click the link.

Finding prerequisite software for Oracle Health Sciences applications

Prerequisite software for Oracle Health Sciences applications is available from the following
locations:

¢ Download the latest major or minor release from the Oracle Software Delivery Cloud

(https:/ /edelivery.oracle.com/).

For information on the credentials that are required for authorized downloads, click FAQs on the
main page of the Oracle Software Delivery Cloud portal.

e Download subsequent patch sets and patches from My Oracle Support
(https:/ /suppott.oracle.com).

To find patch sets or patches, select the Patches & Updates tab.

If a previous version of prerequisite software is no longer available on the Oracle Softwatre Delivery
Cloud, log a software media request Service Request (SR). Previous versions of prerequisite software
are archived and can usually be downloaded. After you open an SR, you can check its status:

e  US customers: Call 1-800-223-1711.

e Outside the US: Check www.oracle.com/us/support/contact/index.html for your local Oracle
Support phone number.

For more information on logging a media request SR, go to My Oracle Support for Document
1071023.1: Requesting Physical Shipment or Download URL for Software Media
(https:/ /suppott.oracle.com/epmos/faces/DocumentDisplay?id=1071023.1).
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Creating a study

You can create a study from scratch or from a template. When you create a study, the Central
Designer application creates a study project with the same name by default. You can change the
study and project name when creating the study.

1  Select File > New Study Project.
The New Study dialog box appears.
2 Type a name and description.

3 From the Templates list, select a template. The list contains all templates that are saved in the
repository. Because templates do not have versions, the template that you choose is the latest.

Note: To base the study on no template, choose <none>.

4 In the Targets section, select the target applications to which the study can be deployed.

5 To change the name of the associated study project, select the Project tab, and type a name,
description, and template for the study project.

6  Click OK.
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Choosing the phase of a study

1 In the Project Explorer, select Study Information.
2 Select the study.

The Study editor appears in the workspace.
3 Select the General tab.

4 From the Phase drop-down list, select the phase of the study.
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Choosing a sponsor for a study

1 In the Project Explorer, select Study Information.
2 Select the study.

The Study editor appears in the workspace.
3 Select the General tab.

4 From the Sponsor drop-down list, select the sponsor to associate with the study.
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Editing the properties of a study

To edit the properties of a study:

1 In the Project Explorer, select Study Information.

2 Select the study.

3 Open the Properties Browser (located by default at the far right of the application window).
4 Modify the properties as necessary.

To edit the properties of a study project:

1 In the Project Explorer, select Study Information.

2 Select the study project.

3 Open the Properties Browser (located by default at the far right of the application window).

4 Modify the properties as necessary.
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Setting the primary layout for a study

Every layout requires a primary layout, or validation fails. An icon on the tab that contains the name
of the layout (at the bottom of the Layout tab) indicates the primary layout.

You set the primary layout for a study at the study level. The first layout that you create for a form or
item is given the name of the primary layout.

When you convert all layouts or a form with multiple layouts, you are prompted to choose the
primary layout, and depending on the option you choose, it is or can be renamed to the name of the
primary layout.

Note: Changing the name of the primary layout affects all forms. If a form has a layout named
Main, and you choose to use the layout named Spanish as the primary layout, then all layouts
named Spanish become the primary layouts.

1  Select Tools > Layout Names Manager.
The Layout Names Manager appears.
2 In the Primary layout name section, select one of the following options:
¢ Use Main as the primary layout name—The layout named Main is the primary layout.

e Use the following as the primary layout name—The layout that you choose from the
drop-down list is the primary layout.

3 Click OK.
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Selecting locales

Choosing the supported locales for a study

You must choose locales to create a layout, translate information, and create Help.

You choose the default locale for a study in the Central Designer application. For more information,

see Choosing the default locale for a study (on page 9).
1 In the Project Explorer, select Study Information.

2 Select the study.

3 Select the Languages tab.

4 From the Languages/Locales list, select the locale or locales for the study.

Note: Only the locales selected in the Central Designer Administrator application appear in
the list.
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About choosing the default locale for a study

About the default locale

The default locale for a study is used to store study metadata that can be localized. For more
information, see Choosing the default Iocale for a study (on page 9).

After modifying the default locale, you do not need to restart the Central Designer application.

If you do not set the default locale, the regional setting is used. The regional setting is set in the
Control Panel > Regional and Language Options > Regional Options tab > Standards and
formats section. If you modify the regional setting, you must close and reopen the Central
Designer application to use the new locale.

You select from the same list of locales that are available when you specify a regional setting.

Display properties that the default locale affects

The default locale affects the display properties of the following:

e Some fields, such as the Default Question for a form, display the text for the default locale.

e The title bar in the workspace displays the default locale. For example: Form : Demographics -
- en-US

e Float numbers are formatted according to the numeric standards for the default locale.
For more information, see Acceptable formatting for float values (on page 11).

Typing translated data

You can enter translated data in the following ways:

You can enter translated data without specifying the locale, and the data is saved as data for the
default locale. For example, you can enter the Default Question of an item in the Item Editor >
Design tab > Default Question field.

You can enter translated data explicitly for a locale, and the data is saved as data for the specified
locale. For example, you can enter the Default Question of an item in the Item Editor > Design
tab > Languages section > Question field.

For more information, see Where to enter translated text (on page 253).

Making sure that the language in which you develop a study is the default locale for which
study metadata is saved

To design a study for any locale, you must make sure that:

In the Central Designer Administrator application, the locale is selected.
In the Central Designer application, the locale is selected for the study.

The user profiles in the Central Designer Administrator application list the locale as a skill.
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Choosing the default locale for a study

If you do not specify a locale for localizable study data, the data is saved according to the default
locale for the study. Study data that is not localizable, such as a RefName, is not saved according to a
locale. You specify a default locale in the Central Designer application. You do not need to restart
the Central Designer application after selecting a default locale.

1  Select Tools > Options.
The Central Designer Options dialog box appears.

2 From the Default locale drop-down list, select a locale.

Note: If you do not select an option, the regional setting is used as the default locale. The
regional setting is set in the Control Panel > Regional and Language Options > Regional
Options tab > Standards and formats section.

3 Click OK.

How to develop a study across multiple locales

You specify the default locale for a study in the Central Designer application. Localizable study
metadata is saved according to the default locale.

Language in which to type text values

You can enter item questions, labels, and text strings in any language, regardless of the default locale
for the study. However, in some places, such as the Design tab of the Form Editor, you can enter
labels and question text without specifying a locale. In these cases, the default locale determines the
language or locale that is assigned to the entered text. If the default locale is not included in the list of
supported locales for the study, the entered text is saved for the locale but is not deployed. Only the
supported locales for the study are deployed.

Typing text values using an explicit locale

If you work on a study with a locale that is different from the default locale, you can enter a study
object's properties with an explicit locale. See the following table for places where the default locale is
used and where you can specify an explicit locale.

Study object  Property Specify a value in the default locale Specify a value in an
here explicit locale here
Study event Title Study Event Editor > General tab Study Event Editor >
General tab
Short Title Study Event Editor > General tab Study Event Editor >
General tab
Form Short Title Study Forms Editor Form Editor > General
tab
Form Title Not available. Form Editor > Layout
tab
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Study object  Property Specify a value in the default locale Specify a value in an
here explicit locale here
Item Question e Form Editor > Design tab Item Editor > Design
tab
e Study Items Editor
Short e Form Editor > Design tab Item Editor > Design
Question . tab
e Study Items Editor
Caption Not available. Form Editor > Layout
tab
Codelist item TLabel e Item Editor > Design tab Codelist Item Editor >

) ) ) Languages tab
e Codelist Editor > Design tab

e Study Codelist Items Editor

Rule component Specify a value in the default locale Specify a value in an
here explicit locale here
Query text Not available. Query Action dialog
box.
Subject or Message Not available. Email Action dialog
box.
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Acceptable formatting for float values

You can enter float values according to numeric standards for:

e The default locale for the study (on page 9).

Note: Oracle recommends entering float data according to the numeric settings of the
default locale for the study.

e The invariant locale. The invariant locale is a locale used by applications when a consistent and
locale-independent result is required. The settings of the invariant locale are similar to English

(United States).

For example, if French (France) is the default locale for a study and you want to type a number with
a decimal point, you can:

e Type "123,45" according to French numeric standards.
e Type "123.45" according to numeric standards of the invariant locale.

The formatting of a float value depends on the default numeric settings for the default locale. For
example, if the default locale is French (France), and you type a value of "123.45," the number
appears as "123,45" after you navigate to a different part of the application and return.

If you change the numeric settings for the default locale—for example, if you change the decimal
point character for the French locale from a comma to a period—the default settings are still used. In
this example, a comma is still used as the decimal point character.

Note: Characters used to separate groups of digits for large numbers (in the United States, a
comma is used) are never saved with float values.

You can type float values for:

e Codelists.
e Value list numbers for custom properties.

e Sequence numbers of workflow objects.
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Saving a study or library project

When you save a study or library project, any study objects that were modified are saved, along with
any administrative modifications that were made to the project since it was last saved.

e Select File > Save Project, or press Ctrl+S.

Note: If you uninstall a deployment system, you cannot save a project that contains study objects
for that system.

Deleting a study or project

When you delete a study, study project, or library project, the contents are permanently removed
from the database.

Note: You cannot delete or archive the System Library or its project.

1 (Optional but highly recommended) Perform a full database backup.
2 (Optional) Archive the study or project (on page 313).

3 In the Project Explorer, right-click a study, study project, library, or library project, and select
Delete.

A confirmation message appears.

The message indicates if the latest version of the selected study, or any of the studies or libraries
in the selected project, has not been archived.

4 Click Yes.
You receive a message that recommends performing a full database backup before deleting.

5 Click Yes.
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Selecting supported libraries

Choosing the libraries to use for a study

Users who are designing a study can search for study objects only in the supported libraries.

Note: After choosing one or more libraries to use for a study, you can set the order of libraries in
the Libraries List. For more information, see Setting the order of libraries in the Libraries List for a
study (on page 13).

To add a library to the Libraries List:
1 In the Project Explorer, select Study Information.
2 Select the study.
3 Select the Libraries tab.
4 Click Add.
The Add Study Library dialog box appears.
5 Select one or more libraties that you want to add to the study, and click OK.

To remove a library from the Libraries List:

—_

In the Project Explorer, select Study Information.

2 Select the study.

3 Select the Libraries tab.

4 In the Libraries List, select the library that you want to remove.
5

Click Remove.

You cannot remove the System Library.

Setting the order of libraries in the Libraries list for a study

You must choose libratries before you can set their order in the Library List. For more information,
see Choosing the libraries to use for a study (on page 13).

1 In the Project Explorer, select Study Information.
2 Select the study.
3 Select the Libraries tab.
4 In the Libraries list, select a library.
5  Click one of the following buttons:
e Up—Move the library up in the list.

e Down—Move the library down in the list.
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Setting up study teams

Users Browser searches

14

To open the Users Browser:

o  Select the View menu, and make sure Users is selected.

Characteristic Description

Use To find users and add them to:

e A study team (in a study project), which an administrator creates as a role
with a study scope in the Central Designer Administrator application.

e Alibrary team (in a library project), which an administrator creates as a role
with a library scope in the Central Designer Administrator application.

Note: A user must be assigned to the corresponding role to be added to a team.

Location of the By default, the browser is located to the right in the application window.
Users Browser

Features You can:
e  Create and save search criteria for personal or global use.

e Open, close, delete, rename, and switch to different searches.

Required search  No required parameters.
parameters

Optional search  Use one, several, or none of the following:

parameters
o Text

e (Categories
e Keywords

The asterisk (*), percent sign (%), and underscore (_) are wildcard operators,
which are inserted before and after text. For example, dem automatically
becomes *dem*. Use a comma as a delimiter.

How the search is Text, keywords, categories, and libraries are connected with the AND operator.
performed Criteria within each parameter are connected with the OR operator. For
example:

e Text that you type
AND

e Keywordl OR Keyword2
AND

e Categoryl OR Category2
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Characteristic Description

Which User names, display names, titles, first names, and last names of:

information is )

searched e Active users
e Inactive users
Note: You can add inactive but not terminated users to teams. View the status
of users in the Central Designer Administrator application.

Search results Users are listed in alphabetical order according to display name, with user names

in parentheses.

Finding and adding a user to a study team and saving the search

An administrator creates study teams as study roles in the Central Designer Administrator
application. A user must be assigned to the corresponding role to be added to a team.

For example, if a user is assigned to the Rule Creation study role in the Central Designer
Administrator application, the user must also be a member of the Rule Creation study team for a
study to create rules in the study. You assign users to roles in the Central Designer Administrator
application and to study and library teams in the Central Designer application. You assign a user to a
study team for the selected study only.

Note: To view all users, click Find without entering parameters. Depending on the size of the
repository, this search might take several minutes. For more information on saving a Users
Browser search, see the User Guide.

To add a user to a study team:

1 Select the Users Browser.
2 Optionally, to name the search:
a  Select Actions > New Search. The Actions menu is located at the top of the browser.
The New search dialog box appears.
b  Type a name for the search, and click OK.
The name of the search appears on a tab to the right of the browser.

3 In the Enter search text field, type text that appears in the uset's name or display name, title, first
name, or last name.

4 To include categories and keywords as parameters, click the down arrows button ( ¥) next to the
Search Filter, and then:

e Optionally, select the Categories tab, and select one or more categories.
e Optionally, select the Keywords tab, and select one or more keywords.

The parameters you select appear in the field below the Search Filter.
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5  Click Find.

The Central Designer application performs a search based on your search criteria. For more
information about how searches work, see Users Browser searches (on page 14).

6 In the Project Explorer, select Study Information.
7 Select a study.
8  Select the Teams tab.
All study roles created in the Central Designer Administrator application appear.
9 In the [Study name] - Teams section, select the team to which you want to add the user.
The name of the team appears above the right section on the tab.
10 In the Users Browser, sclect the user that you want to add, and drag the user to the right section.

The user is added to the team.

Note: You can also add a user to a team by dragging the user directly to the team name in
the left section.

11 Optionally, add the user to more teams, or add different users to teams.

Note: The user that you added must log out and log on again to have the privileges
associated with the team.

Saving a search in the Users Browser

1 Select Actions > Save Search to Repository. The Actions menu is located at the top of the browser.
The Save Search to Repository dialog box appeats.

2 Optionally, type a description for the search.

3 Select an option:
e Just me—Only you can see and use the search.

e Everyone—Everyone can see and use the search.

4 Click Save.

Opening a search saved in the repository

All saved searches are stored in the repository, which contains all data created and saved in the
application.

1 Select either the Libraries Browser (for a study object search) or Users Browser (for a user search).

2 Select Actions > Open Search from Repository. The Actions menu is located at the top of the
browset.

The Open Search from Repository dialog box appears.
3 Select a search, and click Open.

The search opens. A tab with the name of the search appears to the right of the browser.
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Clearing search parameters

Note: If you clear the parameters of a saved search but do not save after clearing, the search is
saved with parameters.

In the Libraries Browser or Users Browser, click Clear Search, which is located at the top of the
browser.

The following information is cleared:
e Textin the Enter search text field.
e Selected categories and keywords.

e Selected libraries (in the Libraries Browser only).

Closing an active search

All saved searches are stored in the repository, which contains all data created and saved in the
application. If you close a saved seatch, the search is removed from your view but is not deleted.

1
2
3

Select either the Libraries Browser (for a study object search) or Users Browser (for a user search).
Select a tab. Tabs are located along the right side of the browser.
Select Actions > Close Active Search. The Actions menu is located at the top of the browser.

The search is closed. If it is a saved search, it remains in the repository. If it is not saved, it is
removed and cannot be reopened.

Deleting a search from the repository

1
2

Select either the Libraries Browser (for a study object search) or Users Browser (for a user search).

Select Actions > Delete Search from Repository. The Actions menu is located at the top of the
browset.

The Delete Search from Repository dialog box appears.

Select a search, and click Delete.

Removing a user from a study or library team

1

In a study, select the Study Information Explorer bar.
or

In alibrary, select the Library Information Explorer bar.
Select the study or library.

Select the Teams tab.

In the left section, right-click the user, and select Remove from Team.
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References

A reference is a text note, a link to a Web page or file (URL), a document, or a combination of all
three, that is attached to a study project for users to consult during the development of a study.

You can attach a reference to a study or study project and view references already attached to a study
or project.

References include standard operating procedures, protocols, naming or project standard documents,
and other relevant documents. Study designers can use reference information to construct a study.

You can attach the following references:

e A shortcut that references a file.

For example, you can attach a shortcut to a file if the file is checked in to a version-control
application and you want all users to view the most recent version.

e A physical file.

You can attach a physical file if the file is stored in a location that everyone cannot access.
e A shortcut that references a URL address.

You can attach the address of a web site that contains information relevant to a study.

References attached to a study project are available for all studies in the project, but references
attached to a study are available only for the study.

Note: Version control is available only for study objects and is not available for references.

Attaching a reference to a study

1 In the Project Explorer, select Study Information.

2 Select a study.

3 Select the References tab.

4 In the Title field in the top grid, type a name for the reference.
5

In the Attachments section (located in the lower-right corner), click the drop-down arrow next to
the Add File button.

A menu of attachment options appears.

6 Attach one of the following references.

To attach the following Perform these steps

Shortcut to a file 1  Select Attach file.
The Open dialog box appears.

2 Navigate to the file that you want to attach, select the file, and
click Open.

A reference to the file appears in the Attachments section.
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To attach the following Perform these steps

Physical copy of a file 1 Select Copy and Attach File.

The Open dialog box appears.

2 Navigate to the file that you want to attach, select the file, and
click Open.

The file appears in the Attachments section.

Shortcut to a URL address 1 Select Attach URL.
The Attach URL dialog box appears.
2 In the field, type the URL address.

A shortcut to the URL appears in the Attachments section.

Note: The maximum size of the attachment is determined by a variety of factors, including
information defined in the configuration file, available hard disk space, and available memory. To
determine the approximate maximum attachment size, check the maxRequestLength attribute in
the machine.config file.

Removing a reference from a study

1 In the Project Explorer, select Study Information.
2 Select a study.

3 Select the References tab.

4 In the Attachments section, select a reference.

5

Click Remove.
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Study administration data

About study administration data

You can capture study administration data— item, query, rights, and signature groups, sponsor
information, and system settings—that is associated with a study. When you deploy the study to the
InForm application, you can include the administration data along with the study.

For more information, see About deployment packages (on page 276).

Study administration data rights

To create, update, or remove study administration data, your administrator must assign you Modify
Study Administration Data rights. If a user who navigates to an administration data editor does not
have rights to modify study administration data, the information that appears in the editors is read-
only.

Study administration data editors

You capture administration data using the following editors:

e Sponsor editor—Defines the study sponsor and contact details.
e System Settings editor—Specifies system settings that are specific to an InForm release.

e Item Groups editor—Combines previously defined items into a group to set the group’s display
options within a rights group.

¢ Query Groups editor—Defines a query group.

¢ Rights Group editor—Combines previously defined items into groups to set the display
options of the groups within a rights group.

e Signature Groups editor—Combines a set of users who can sign case report books and forms.

Sponsor settings

20

Both you and the administrator can create sponsors and detailed sponsor information. Sponsor
information is for documentation and reporting only; this information does not appear in the
InForm application user interface.

When the administrator creates sponsors and sponsor details using the Central Designer
Administration application, the study is propagated to the Central Designer application and is
available for use in studies.

In the Central Designer application, when you create new sponsors and detail information, the
sponsor names, but not the detail information, are propagated back to the Central Designer
Administration application. You also can override sponsors and details that the administrator creates.
The changes you make ate not propagated back to the Central Designer Administration application.
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Selecting a sponsor to associate with a study

1

In the Project Explorer, select Study Information > Administration.

The Study Administration workspace appears.

Select the Sponsor tab.

The Sponsor editor appears.

From the Sponsor Name drop-down list, select a sponsor to associate with the study.

The sponsor detail information appears in the fields.

Adding a sponsor to a study

1

In the Project Explorer, click Study Information > Administration.
The Study Administration workspace appears.

Select the Sponsor tab.

The Sponsor editor appears.

Choose the information for the organization that is sponsoring the study.

Note: The only required field in the Sponsor editor is the Sponsor Name.

For more information, see Sponsor tab of the Administration editor—Option desctiptions
(on page 22).

Editing sponsor detail information

1

In the Project Explorer, click Study Information> Administration.
The Study Administration workspace appears.

Select the Sponsor tab.

The Sponsor editor appeats.

From the drop-down list, select the sponsor, and edit the detail information.

Removing a sponsor from a study

1

In the Project Explorer, click Study Information> Administration.

The Study Administration workspace appears.

Select the Sponsor tab.

The Sponsor editor appears.

From the drop-down list, select the sponsor you want to remove from the study.

Click Clear Sponsor.
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Sponsor tab of the Administration editor—Option descriptions

Option Description

Sponsor Name Name of the organization that is sponsoring the study.
Program Name of the program.

Therapeutic area Medical area that is being investigated by the study.
Note Additional information you may want to include.
Address 1 Sponsor street address.

Address 2 Additional address information.

City City.

State State (United States).

Zip code Zip code (United States).

Province Province (outside the United States).

Postcode Postcode (outside the United States).

Country Country.

Phone Telephone number.

Alt phone Alternate telephone number.

Fax Fax number.

Email address Email address.

System settings

22

System settings specify information that is specific to the InForm release you are using.

The system settings are installed when the Central Designer application is installed. When you create
a new study, it does not have system settings. You need to add the system settings to the study.

About the System Settings editor

The System Settings editor has three columns. You can change only the fields in the Value column;
the fields in the other columns are read-only.

The rows in the System Settings editor are fixed. You cannot add or delete any rows.

Adding system settings to a study

1 In the Project Explorer, select System Settings.

The Study Administration workspace appears.
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Select the System Settings tab.
The System Settings editor appears.
From the Settings drop-down list, select the settings for an InForm release.

The System Settings editor is populated with settings for the InForm release you selected.

Editing system settings

1

In the Project Explorer, select System Settings > Administration.
The Study Administration workspace appears.
Select the System Settings tab.

The System Settings editor appears. The editor is populated with the system settings for the
InForm release you selected when you added the system settings to the study.

In the Value column, edit the settings either by typing or by selecting from the drop-down lists.

For more information, see System settings tab of the Administration editor—Option
descriptions (on page 24).

Restoring default values

1

In the Project Explorer, select System Settings > Administration.
The Study Administration workspace appears.
Select the System Settings tab.

The System Settings editor appears and is populated with the system settings for the InForm
release you selected when you loaded the system settings.

In the toolbar, click Restore Defaults.

Deleting system settings

You can delete system settings only if they are not currently being used in a study.

1

In the Project Explorer, select System Settings > Administration.
The Study Administration workspace appears.
Select the System Settings tab.

The System Settings editor appears and is populated with the system settings for the InForm
release you selected when you added the system settings.

From the Settings drop-down list, select the settings to delete.
Click Remove Settings.

If the selected settings are not currently being used with a study, the Confirm Delete dialog box
appears.

Click Yes.

Oracle® Health Sciences Central Designer 2.1 23



Chapter 1 Setting up and administering a study

24

System settings tab of the Administration editor—Option descriptions

Field Description

EnrollWithIncompleteForms

Whether an InForm user can override a failed screening and
enrollment.

AutoAnswerManualQueries

Whether the InForm application automatically answers a manual
query when a data item change satisfies the rules on the data item.

EmailForNewSite AndUser

Notification

Email address of an administrator who receives notification when a
new site or new user is added.

RequireCommentsForNA

Whether a comment is required when NA is used.

PatientSequence Format for assigning subject numbers (read-only).
TrialDateFormat Format of the date that appears in the study
ViewCRFSignList Whether a list of required signatures is included on each form.
QueryMaxLength Maximum number of characters of query text.
Maximum characters: 350.
InlineDuration Number of seconds that the "Form submitted successfully”
message remains visible in the header of the form before it fades.
Must be a value from 1 to 9.
QuerySelection State in which queries are created.
EnforceVisitDate Whether to require the use of Date of Visit on the first form of
every visit.
ScreeningSequence Sequence number format for assigning screening numbers (read-
only).
UniquelntDOBSwitch Requitements for a subject initial/date of birth combination
settings.
e Initials and DOB combination must be unique within a site.
e Initials and DOB combination must be unique within a study.
UniquePatIDSwitch Requirements for a subject ID.
e  Subject ID must be unique with a site.
e  Subject ID must be unique within a study.
SponsorEditFrozen Whether a sponsor can edit a form after it is marked frozen.
FormSaveMode Location and format of the message that appears when a form is

submitted successfully.

VisitCalculatorEnabled

Whether to enable the visit calculatot.

UserNameOrder

Order in which subjects appear in the Signature Details view.

NavigationMode

Whether to allow users to change the order in which subjects
appear in the InForm UL
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Iltem groups

Item groups are sets of items you group together so you can assign a display override within a rights
group to them.

Using display overrides, you can specify whether the group of items that make up an item group is
hidden, editable, or read-only to the rights group with which the items are associated.

About the Item Groups editor

The Item Groups editor has two sections. The top section has a list of item groups, and the bottom
section has the items that are associated with an item group you select.

Creating item groups

1

In the Project Explorer, select Study Information > Administration.
The Study Administration workspace appears.

Select the Item Groups tab.

The Item Groups editor appears.

In the toolbar, click Create item groups(s).

Choose the settings for the item group.

Do one of the following:

e To create one item group, click Create.

e To create multiple item groups, click Create/Next. When you finish creating item groups, click
Create.

Editing an item group

1

In the Project Explorer, select Study Information > Administration.

The Study Administration workspace appears.

Select the Item Groups tab.

The Item Groups editor appears.

Select the row for the item group you want to edit, and do one of the following:
e In the toolbar, click Edit.

e Right-click and select Edit.

The Edit Item Group dialog box appears.

Edit the item group.

Click OK.
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Deleting item groups

1

In the Project Explorer, select Study Information > Administration.
The Study Administration workspace appears.

Select the Item Groups tab.

The Item Groups editor appeats.

Select one or more rows and do one of the following:

e In the toolbar, click Delete.

e Right-click and select Delete.

e DPress the Delete key.

The Confirm Delete dialog box appears.

Click Yes.

Adding items to an item group

1

In the Project Explorer, select Study Information > Administration.
The Study Administration workspace appears.

Select the Item Groups tab.

The Item Groups editor appears.

Select the row for the item group to which you want to add an item.
Select the item or items you want to add to the group.

Click Add.

Removing items from an item group

1

In the Project Explorer, select Study Information > Administration.

The Study Administration workspace appears.

Select the Item Groups tab.

The Item Groups editor appeats.

Select the row for the item group from which you want to remove an item.
Select the row for the item you want to remove.

Click Remove.

The Confirm Delete dialog box appeats.

Click Yes.
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Item Groups tab of the Administration editor—Option descriptions

Option Description

Group Name Name of the item group.

Description Description of the item group.

Item Name Name of an item that is associated with the item group.
Question Question associated with the item group.

Owner Form (s) Form or forms in which the item group is defined.

Query groups

A query group specifies a set of users who can work with queries that were created by other
members of the same group.

Creating query groups

1 In the Project Explorer, select Study Information > Administration.
The Study Administration workspace appears.

2 Select the Query Groups tab.
The Query Groups editor appears.

3 In the toolbar, click Create query group.
The New Query Group dialog box appears.

4 Type a group name and description.

5 Click Create.

Editing a query group

1 In the Project Explorer, select Study Information > Administration.
The Study Administration workspace appears.

2 Select the Query Groups tab.
The Query Groups editor appears.

3 Select the row you want to edit, and do one of the following:
e In the toolbar, click Edit.
e Right-click the row and select Edit.
The Edit Query Group dialog box appears.

4 Edit the information, and click OK.
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Deleting one or more query groups

1 In the Project Explorer, select Study Information > Administration.
The Study Administration workspace appears.

2 Select the Query Groups tab.
The Query Groups editor appears.
Select one or more rows to delete, and do one of the following:
e In the toolbar, click Delete.
e DPress the Delete key.
The Confirm Delete dialog box appears.

3 Click Yes.

Query Groups tab of the Administration Editor—Option descriptions

Option Description

Group Name Name of the query group.

Description Description of the query group.

Rights groups

Rights groups allow you to create a set of rights and assign them to a set of item groups. Using
display overrides, you can specify whether the group of items that make up an item group that is
associated with a rights group is hidden, editable, or read-only.

About the Rights Groups editor

The Rights Group editor has two sections. The top section has a list of rights groups, and the
bottom shows the associated item groups for the selected rights group.

Creating rights groups
1 In the Project Explorer, select Study Information > Administration.
The Study Administration workspace appears.
2 Select the Rights Groups tab.
The Rights Groups editor appears.
3 In the toolbar, click Create rights group.
The New Rights Group dialog box appears.

4 Choose the settings for the rights group.
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5

Do one of the following:
e To create one rights group, click Create.

e To create multiple rights groups, click Create/Next. When you finish creating rights groups,
click Create.

Editing a rights group

1

In the Project Explorer, select Study Information > Administration.
The Study Administration workspace appears.

Select the Rights Groups tab.

The Rights Groups editor appears.

Select the row for the rights group you want to edit.

In the toolbar, click Edit.

The Edit Rights Group dialog box appears.

Edit the rights group you selected.

Click OK.

Deleting a rights group

1

In the Project Explorer, select Study Information > Administration.
The Study Administration workspace appears.

Select the Rights Groups tab.

The Rights Groups editor appears.

Select the rights group to delete, and in the toolbar, click Delete.
The Confirm Delete dialog box appears.

Click Yes.

Adding item groups to a rights group

1

In the Project Explorer, select Study Information > Administration.

The Study Administration workspace appears.

Select the Rights Groups tab.

The Rights Groups editor appears.

Select the rights group to which you want to add item groups.

Click Add.

The Rights Group — Add Item Groups dialog box appears.

Select the checkbox for each item group you want to add to the rights group.

Click OK.

Oracle® Health Sciences Central Designer 2.1 29



Chapter 1 Setting up and administering a study

Deleting item groups from a rights group
1 In the Project Explorer, select Study Information > Administration.
The Study Administration workspace appears.
2 Select the Rights Groups tab.
The Rights Groups editor appears.
3 Select the rights group from which you want to remove an item group.
4 Select the item group you want to remove.
5  Click Remove.
The Confirm Delete dialog box appears.
6  Click Yes.

Setting the item group display override
1 In the Project Explorer, select Study Information > Administration.
The Study Administration workspace appears.
2 Select the Rights Groups tab.
The Rights Groups editor appears.
3 Select the rights group that has the item group for which you want to set a display override.
The details appear for all the item groups that are assigned to the rights group you selected.

4 From the Display Override drop-down list, select an override.

Rights Groups tab of the Administration Editor—Option descriptions

Option Description

Group Name Name of the item group.

Description Description of the item group.

Item Group Name Name of an item group that is associated with the rights group.

Description Description of an item group that is associated with the rights
group.

Display Override Whether the group of items that make up an item group is

hidden, editable, or read-only.
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Signature groups

A signature group specifies a set of users who can sign case report books and forms in the InForm
application. You create signature groups and add forms to the group so that users in the signature
group can sign the forms.

Note: Adding uses to groups occurs outside the Central Designer application.

For information about the validation checks for signature groups, see Validation checks for
InForm deployment (on page 270).

About the Signature Groups editor

The Signature Groups editor lists defined signature groups in the top section and details for the
selected signature group in the middle section. The bottom section provides options for specifying
the language to use for the signature meaning and affidavit text and for creating affidavit text.

Creating signature groups

1 In the Project Explorer, select Study Information > Administration.
The Study Administration workspace appears.
2 Select the Signature Groups tab.
The Signature Groups editor appears.
3 In the toolbar, click Create a signature group(s).
The New Signature Group dialog box appears.
4 Choose the settings for the signature group.
5 Do one of the following:
e To create one signature group, click Create.

e To create multiple signature groups, click Create/Next. When you finish creating signature
groups, click Create.

Editing a signature group

1 In the Project Explorer, select Study Information > Administration.
The Study Administration workspace appears.

2 Select the Signature Groups tab.
The Signature Groups editor appears.

3 Select the row for the signature group you want to edit, and do one of the following;:
e In the toolbar, click Edit.
e Right-click and select Edit.
The Edit Signature Group dialog box appears.

4 Edit the information.

5 Click OK.
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Adding a form to a signature group

If a signature group is a case report book type, the following restrictions apply to forms that you add
to the signature group:

®  You cannot add a repeating form to the signature group.
®  You can add only one form to the signature group.
e The form can belong to only one study event.
e The form cannot be used in a repeating study event.
To add a form to a signature group:
1 In the Project Explorer, select Study Information > Administration.
The Study Administration workspace appears.
2 Select the Signature Groups tab.
The Signature Groups editor appears.
3 Select the signature group to which to add a form.
4 Click Add.
The Signature Group — Add Forms dialog box appears.
5 Select the checkbox for the form you want to add.

6 Click OK.

About choosing settings for signature meaning and affidavit text

You can translate affidavit text if the language or languages in your skills profile are the same as those
specified for the study.

For the signature meaning, if the translation language is English-United States, you can either select
an option from the Signature Meaning drop-down list or type meanings of your own. For all other
languages, you must the type meanings.

If the translation language is English-United States, you can use the default text for the signature
affidavit.

Specifying translation text for a signature affidavit

1 In the Project Explorer, select Study Information > Administration.
The Study Administration workspace appears.
2 Select the Signature Groups tab.
The Signature Groups editor appears.
3 Select the signature group for which to specify translation text for the signature affidavit.

4 From the Language drop-down list, select the language to use for the Signature Meaning and
Signature Text.
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Do one of the following to specify the signature meaning:

e If you are using the English-United States language, from the Signature Meaning drop-down
list, select either Approved or Reviewed.

e For any language, type a meaning that is appropriate to your study.

In the row for the language you are using, click View/Edit.

The Signature Text dialog box appears.

Do one of the following to specify the affidavit text:

e If you are using the English-United States language and want to use the default affidavit text:

Select the Use default text (available for English - United States Locale only) checkbox. When the
default text appears in the dialog box, click OK.

e Tor any language, to create your own affidavit text:

Deselect the Use default text (available for English - United States Locale only) checkbox, type the
text in the Signature Text dialog box, and click OK.

Removing a form from a signature group

1

A A~ W

In the Project Explorer, select Study Information > Administration.
The Study Administration workspace appears.

Select the Signature Groups tab.

The Signature Groups editor appears.

Select the signature group from which to remove a form.
Select the form to remove.

Click Remove.

Click OK.

Resetting the state of a form

You can specify whether associating a new signature group with a signed form resets the state of the
form to unsigned in the InForm application.

If you reset the state, the original signatures remain valid. However, the form requires a signature
from a member of the newly associated group in the InForm application.

1

In the Project Explorer, select Study Information > Administration.
The Study Administration workspace appears.

Select the Signature Groups tab.

The Signature Groups editor appears.

Select the signature group with which the form is associated.

In the Reset Form State column, select the checkbox.
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About the invalidation level of a signature
The InForm application invalidates a signature if any data items in the form change after signoff.

In cases in which the data items that changed are marked as hidden from a signer, you can prevent an
invalidation by using one of the following options in the Invalidation Level drop-down list:

e User—The signature is invalidated only if the signer from whom the changes were hidden can
view the data item that changed.

e  Group—The signature is invalidated only if at least one signer in the signature group can view the
data item that changed.

Specifying the invalidation level of a signature
1 In the Project Explorer, select Study Information > Administration.
The Study Administration workspace appears.
2 Select the Signature Groups tab.
The Signature Groups editor appears.
3 Select the signature group.

4 From the Invalidation Level drop-down list, select either User or Group.

Note: If a study is integrated with the Central Coding application, to prevent signature
invalidation when the Central Coding application updates an item, set the invalidation level
to User.

Deleting a signature group

1 In the Project Explorer, select Study Information > Administration.
The Study Administration workspace appears.

2 Select the Signature Groups tab.
The Signature Groups editor appears.

3 Select the signature group to delete.

4 In the toolbar, click Delete.
The Confirm Delete dialog box appears.

5  Click Yes.

Signature Groups tab of the Administration editor—Option descriptions

Option Description

Group Name Name of the signature group.
Description Description of the signature group.
Type Type of document a signature group can sign.
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Option Description

Reset Form State Whether associating a new signature group with a form that is signed
resets the state of the form to unsigned.

Invalidation Level Invalidates a signature if items change after signoff.

Title Name of the form a signature group can sign.

Description Description of the form a signature group can sign.
Language Language to use for meaning and signature text.

Signature Meaning Whether the signature indicates that the form is Reviewed,

Approved, or in a user-specified state.

Signature Text The affidavit text.

About exporting study administration data to a user management tool

You can export study administration data to a user management tool using the Export Wizard. The
exported file contains the definitions of the study administration groups you created in the Central
Designer application. The definitions are in a pipe-delimited format.

For more information, see Export Wizard options.

Page Option Description
Welcome Introduction page.
Export Type Select the output format and export type.
Data Type CSML—Export in Clinical Study Markup Language
format.

ODM-—Export in Operational Data Model-compliant
format. The Central Designer application supports the
ODM 1.3 standard.

Administration data—Export only study administration
data for the User Management Tool application.

Export Type Local—Export to the computer where the Central
Designer application is installed.
Export File Path Export Specify the path name and file in which to save the export
Directory file, or click Browse to browse for the path name and file

in which to save the export file.

Ready to Export View a summary of the parameters that will be used for
Central Designer the export.
Data
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About importing study administration data

36

When you import CMSL that includes study administration objects you can choose to import study
objects and administration data, administration data only, or study objects only:

Import study objects and administration data—The study objects (StudyAdministration,
ItemGroups, SignatureGroups, Sponsor, SystemSettings, and RightsGroups) in the CSML you
are importing overwrite the study objects in the existing study.

If a study object in the CSML data you are importing has the same identifier as an object in the
study, the existing object is not deleted. Instead, a new study object is created and its version is
incremented.

Import study administration data only—The study objects are removed from the CSML
before it is imported.

Because the study design has changed, some items and forms that the existing Study
Administration objects reference cannot be part of the study workflow. These references are
removed from the existing Study Administration objects in the study.

For more information, see Import Wizard options - CSML or ODM file.

Page Option Description
Welcome Introduction page.
Import Type Select the source of the data to import.

Import CSML or Generate study objects from a file in CSML or ODM

ODM file format.
Hatvest InForm Generate study objects from the components of an
Resources InForm study.
File Location Path of file to import Specify the path of the CSML or ODM import file, or
click Browse to locate the import file.
Study This page appears only for the CSML import type, if
Administration the CSML file contains study administration objects.
Import Mode

Import study objects Import both study objects and study administration
and administration  objects.
data.

Import Import only study administration objects.
administration data
only.

Import study objects Import only study objects.
only.
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Page Option Description

Rule Import Mode ~ Rule Import Mode ~ Only the Import as Collaboration Notes option is
supported. With this option, each imported rule is
converted to a collaboration note in the Central
Designer application.

Note: This option applies only if the Import Type is
ODM,; if the Import Type is CSML, the import
process creates a Central Designer rule for each
imported rule.

IPR Import Mode  Import IPR data Select whether to import in-place revision objects.

Note: This page appears only if the file contains in-
place revision objects.

Ready to Import View a summary of the import options selected in the
Data to Central wizard.
Designer

Oracle® Health Sciences Central Designer 2.1 37



Chapter 1 Setting up and administering a study

Coding administration

Administering coding tasks

To create coding maps in the Central Designer application, you must first perform the following
administrative tasks.

Select dictionary types for a study or Iibrary (on page 39).

Associate dictionaty types with verbatim types for a study or library (on page 40).

Creating, modifying, and deleting a coding map

When you create a coding map, you specify:

An item to code.

One or more items that will receive code or term information from the Central Coding
application.

One or more items that contain context information. Context information provides assistance to
the person who codes the item.

A query target. When a Central Coding user creates a query, the query appears on the query
target item in the InForm application.

Note: If you select a query target item for a coding map, you can only deploy the study to a
version of the InForm application that supports coding query targets. For more information,
see the InForm documentation.

Note: Only text items with no codelists are available for selection in the drop-down lists for
Item to code and Target Item.

To create a coding map:

1
2
3
4

5
6

In the Project Explorer, select the Forms and Transactions Explorer bar.
Select a form.

Select the Coding tab.

Click New Coding Map.

The New Coding Map dialog box appears.

Fill in the fields in the dialog box.

Click OK.

To modify a coding map:

Note: When you modify a coding map, you cannot modify the dictionary type or the verbatim (the
item to code).

1
2

38

In the Project Explorer, select the Forms and Transactions Explorer bar.

Select a form.
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3 Select the Coding tab.
4 In the top panel, select a coding map, and click Edit.
The Edit Coding Map dialog box appears.
5 Edit the coding map as necessary.
You can modify information in the following fields:
e Dictionary type.
e Item to code.
e Verbatim type.
e Coding Results tab: Target Item and Target Question.
e Context Information tab: Context Item and Context Question.
e  Assign queries to: Query target item.
6 Click OK.
To delete a coding map:
1 In the Project Explorer, select the Forms and Transactions Explorer bar.
2 Select a form.
3 Select the Coding tab.
4 In the top panel, select a coding map, and click Delete.

A confirmation dialog box does 7ot appear.

Selecting and removing dictionary types for a study or library

Only enabled dictionary types appear in the Dictionary types list. An administrator can import and
enable additional dictionary types in the Central Designer Administrator application. For more
information, see Enabling and disabling a dictionazry type (in the Administrator Guide).

1 In the Project Explorer, select Study Information.
2 Select InForm.
3 Select the Coding tab.

4 In the Dictionary Types list, select or deselect the checkbox to select or remove a dictionary type.

Note: If a dictionary type is used in a coding map, (in use) appends the dictionary type, and
you cannot deselect it.

After selecting a dictionary type, you can associate it with one or more verbatim types. For more
information, see Associating dictionary types with verbatim types for a study (on page 40).
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Associating dictionary types with verbatim types for a study or library

Before you associate a dictionary type with a verbatim type, you must select dictionary types for a
study (on page 39).

Only the selected dictionary types and their associated verbatim types are available for creating
coding maps.

You define verbatim types in the Central Designer Administrator application. For more information,
see Adding, modifying, and deleting a verbatim type (in the Administrator Guide).

1 In the Project Explorer, select Study Information.
2 Select InForm.

3 Select the Coding tab.

4

In the Dictionary Types list, select or deselect the checkbox to select or remove a dictionary type.

Note: If the checkbox for the dictionary type is not selected, you cannot associate verbatim
types with the dictionary type.

The Verbatim Types list is populated with verbatim types.

5 In the Verbatim Types list, select the checkboxes for one or more verbatim types.

Note: If a verbatim type is used in a coding map for the selected dictionary type, (in use)
appends the verbatim type, and you cannot deselect it.

About coding setup activities in the Central Designer application

40

Some data that is collected in a study, such as a description of an adverse event, is free-form text.
This item text is called a verbatim. A verbatim is the original reported text that describes the adverse
event, disease, drug, or other item to be coded in the Central Coding application. The verbatim text
must be converted to consistent terminology that is defined in either industry standard or customer-
defined dictionaries for the purposes of statistical analysis. Coding is the process of selecting terms
and codes from a dictionary for a given verbatim.

When you design a study in the Central Designer application, you can create items for which an
InForm user provides a value—the verbatim text—and you can also create additional related items
that are read-only in the InForm application.

A coding map is a study object that contains the necessary information to code an item. By creating a
coding map in the Central Designer application, you can populate the values of the read-only fields
with codes and terms that are selected in the Central Coding application.

After you deploy a study from the Central Designer application to the InForm application and begin
collecting data, you can begin the coding process. All communication between the InForm
application and the Central Coding application is initiated from the Central Coding application. The
Central Coding application uses the InForm Adapter application to control communication between
Central Coding servers and InForm studies.

For more information about the coding process in the Central Coding application, see the Central
Coding User Guide.
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Coding terms and definitions

Term Definition

Coding The process of selecting terms and codes from a dictionary for a verbatim.

Verbatim The original reported text that describes the adverse event, disease, drug, or
other item to be coded in the Central Coding application. A verbatim is
typed in the InForm application.

Coding map A study object that contains the necessary information to code an item.
Target item An item that holds a term, code, or additional information after a verbatim
is coded.

Also called a coding target.

Context item An item that provides additional coding information, such as the indication
and route of administration for drugs, that can be displayed with an item
coded using the WHO-DD dictionary.

Dictionary type A name or identifier for the metadata for a dictionary.
Verbatim type A classification of a verbatim as defined in a coding dictionary.
Query target item An item in the InForm application that you designate as the item on which

to place queries that are created in the Central Coding application. If you
select a query target for a coding map, you can only deploy the study to a
version of the InForm application that supports query targets.

Coding maps

Characteristic Description

Definition and A coding map is a study object that contains the necessary information to
purpose code an item. You create a coding map for an item that needs to be coded
in the Central Coding application.

Where to view and You can create, modify, and delete coding maps only when a form is selected.

create When a form is selected, the Coding tab displays all coding maps for the
form. When a study event is selected, the Coding tab displays all coding
maps for all of the forms in the study event, and so on.

You can view, but not edit, coding maps in the Coding tab of the editors
for the following study objects:

e Study design
e Study element

e Study event
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Characteristic Description

Creation process To create a coding map, you assign an item to one or more dictionary levels
and level types—the level type is the term, code, or additional information
of the dictionary level.

For more information, see Creating, moditying, and deleting a coding
map (on page 38).

Information in a e Verbatim (the item to be coded).
coding map . .
e TForm on which the verbatim appears.
e  Verbatim type.
e Dictionary type to use for coding.

e Any specified context items and target items.

e Query target item.

Multiple coding maps  You can create multiple coding maps for a verbatim—one for each

for a verbatim dictionary type that is installed and selected for a given study or library.
Therefore, a verbatim, a target item, and a context item can all be part of
multiple coding maps.

Reusing When you copy a form to a library or study, the coding maps that are
defined for items on the form are copied with the form.

Deployment Coding maps are deployed to an InForm study as InForm TDE
CODINGMAP objects.

If you select a query target item for a coding map, you can only deploy the
study to a version of the InForm application that supports coding query
targets. For more information, see the InForm documentation.

Note: If you create or modify a coding map, use a full deployment package
to deploy the changes. Changes to coding maps are not supported in
incremental deployment packages.

Requitrements for For repeating sections, the references in a coding map must all be either in
repeating sections the repeating section or outside the repeating section.

Multi-language studies Coding maps are language neutral. You cannot create a language-specific
coding map.
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Dictionary types
Characteristic Description
Detfinition and A dictionary type is a name or identifier for the metadata for a dictionary.
purpose You create a coding map for a verbatim using a dictionary type.

The dictionary type specifies the metadata for all versions of a dictionaty,
including:

e Verbatim types.
e Dictionary levels.
e Dictionary level types, such as Term or Code.

e  Where applicable, context meanings.

Dictionary types in The following dictionary types are installed with the Central Designer
the installation application:

e MedDRA—Medical Dictionary for Drug Regulatory Activities.
e MedDRAJ—]Japanese version of the MedDRA dictionary.

e  WHO-DD—World Health Organization Drug Dictionary (formerly
WHO-DRL—World Health Organization Drug Reference List).

e JDrug—Japanese drug dictionary.

Importing You can import other standard dictionary types as well as custom dictionary
types in the Central Designer Administrator application.

For more information, see Importing and overwriting a dictionaty type
(in the Administrator Guide).

Multiple versions The Central Designer application supports multiple versions of a dictionary

type.

A version consists of dictionary metadata and dictionary data. In most
cases, versions are different only in data, but new versions can also contain
new metadata.

Using in a study or To use a coding dictionary in a study or library to create coding maps, you
library must use the following process:

1 Import the dictionary type (in the Administrator Guide).
2 Enable the dictionary type (in the Administrator Guide).
3 Select the dictionaty type for a study or library (on page 39).

Association with You can associate multiple verbatim types with a single dictionary type.
verbatim types

Deployment Dictionary types that are used in the coding maps are deployed to the
InForm application as MedML DICTIONARY objects.
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Verbatim types

Characteristic Description
Detfinition and A verbatim type is a classification of a verbatim as defined in a coding
purpose dictionary.

Verbatim types in the e AE—Adverse Event

installation * DISEASE—Disease
e LABDATA—Lab data
¢ MEDPROD—Medical product
Association with You can associate multiple verbatim types with a single dictionary type.

dictionary types

Verbatims, context items, target items, and query target items

Characteristic  Verbatims Context items Target items Query target items

Definition and A verbatim is the A contextitemis A targetitemis A query target item is

purpose original reported  an item that an item that an item in the InForm
text that describes provides holds a term, application that you
the adverse event, additional coding code, or designate as the item
disease, drug, or  information, additional on which to place
other item to be  such as the information after queries that are
coded in the indication and a verbatim is created in the Central
Central Coding route of coded. Coding application.
application. administration When a Central

It is a target for

Coding user creates a
one and only one

for drugs, that
You can create

. ; can be displayed . quetry, the query
multiple coding . . verbatim per
f with an item dicti appears on the query
ma;;s ora coded using the iconary type. target item in the
verbatim. WHO-DD Target items can  1nForm application.
i dictionary. icti
A verbatim can 1y hold _dlctlonary You must assign each
have: level information .
- verbatim a query
or additional target when you create
* Oneormore information that di for th
target items. : a coding map for the
is defined by a :
o verbatim.
e One or more dictionary.
context items. Note: To select the
) verbatim item as the
* A coding map quety target item,
f(?r .each select <use
dictionary verbatim> in the
type. Assign queties to
drop-down list in the
New Coding Map
dialog box.
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Characteristic  Verbatims Context items Target items Query target items

Source or result A verbatim is a A contextitem is A targetitemisa A targetitem isa

item source item that  a source item result item that  result item that
provides that provides receives a term  receives a query from
information to the informationto  or code from the the Central Coding
Central Coding the Central Central Coding  application.
application. Coding application.

application.
Location in Can be one of the Can be one of  Cannot be a Cannot be the child of
Project Explorer following: the following: child of a nested  a top-level compound

compound item. item, but can be the
top-level compound
item itself.

e Top-level e Top-level
item. item. Must be one of

) ) the following:
e Childofa e Child of a

Must be:
top-level top-level e Top-level
compound compound item. e A top-level item.
item. item.
e Child of a e Visible and
e Child ofa e Child ofa top-level available for
nested nested compound editing in the
compound compound item. InForm
item. item. application. Items
designated as
query targets must
not have the
Display Override
propetty set to
ReadOnly or
Hidden in the
Central Designer
application.
Conditional on ~ Can be Can be Cannot be Cannot be conditional
another item conditional on conditional on conditional on on another item.
another item. another item. another item.

Requirements:

e A verbatim (the item to code) and its target and context items must be on the same form.

e If a form has a repeating section, all items referenced in the coding map must all be either in the
repeating section or outside the repeating section.

e All verbatims, context items, and target items must be text items. Query target items do not need
to be text items.

e You can map each verbatim to only one coding dictionary. For example, to code to both
Japanese and English dictionaries for the same item on the form, you must create two verbatims
on the form.

®  You can designate an item as a query target for only one verbatim.
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e If you select a query target item for a coding map, you can only deploy the study to a version of
the InForm application that supports coding query targets. For more information, see the
InForm documentation.
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Setting up InForm review states

About review states

In the InForm application, as many as five form-level customizable states, called review states, are
available in the Data Viewer in addition to the standard InForm states. If defined, custom review
states can provide users with greater flexibility in tracking the review progress.

Each custom review state has three customizable stages. For example, you can create two custom
review states, labeled Medical Review and Data Management Review, each with three stages of
Needs Review, Pending, and Reviewed. A custom review state is in one of its three stages at any
time. The first stage is the default stage for a defined custom review state.

In the Central Designer application, you can create as many as five review states for a study, each

having three review stages. You can perform the same actions on a review state as on other study

objects. For example, you can lock, unlock, publish, unpublish, copy, and paste a review state, and
you can mark it as a template and copy it from a library into a study.

Additionally, you can write rules that read and set the review stage of a form.

Review states appear in the Review States editor, which is active when you select the Study
Information Explorer bar > InForm > Review States folder in the Project Explorer. You define a
review state and its review stages in the Review State editor. The annotated study book for a study
optionally includes a listing of the review states defined for the study, along with the review stages of
each.

Creating, modifying, and deleting a review state

Note: Review states are supported only in release 5.5 and later of the InForm application. If you
attempt to deploy a study containing review states to an earlier release of the InForm application,
deployment fails.

To create a review state:

Note: If you create a review state in the Central Designer application to replace a deleted review
state, the new review state must have the same RefName and state number as the review state
that was deleted.

1 In the Project Explorer, select Study Information.
or
In the Project Explorert, select the Library Information Explorer bar.
2 In the InForm folder, right-click Review States, and select New Review State.
or
a  In the InForm folder, select Review States.
b In the Review States editot, click New.

The Object Name dialog box appears.
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3 Enter a title, RefName, and description, and click OK.
The Review State editor appears.
4 Fill in the fields of the editor, and save the study project.

For more information, see Review State editor—Option descriptions (on page 434).

Note: The Label and Mnemonic fields for the review state and each review stage are
required for each InForm product locale (English and Japanese). If a required value is
missing in a product locale tab, the value from the other locale (if it is defined) appears in
the field in red, and an icon appears in the tab to indicate that translation is required. Study
validation also checks for missing translated values. Because both English and Japanese
locales are always required for review states, the study definition does not need to have the
Japanese locale selected, and you do not need the Japanese language skill to translate the
review state fields.

To modify a review state:

Before a review state is deployed to the InForm application, you can change any of its values and the
values of its review stages.

Note: If you change the RefName property of a stage, you must update any rules that refer to the
stage.

After deploying a review state to the InForm application, you cannot change the state number or any
RefNames. You can only change labels, mnemonics, titles, descriptions, and activation state. If you
change the RefName of a review state or the name of a review stage and redeploy the study,
deployment fails.

1 In the Project Explorer, select Study Information.

or

In the Project Explorer, select the Library Information Explorer bar.
2 In the Review States folder, select a review state.

The Review State editor appears.
3 Update the fields as needed.

To delete a review state:

You can delete a review state before or after the study is deployed to the InForm application. If you
delete a review state in the Central Designer application for a deployed study and then redeploy, the
review state is not removed from the InForm study. If you create a review state in the Central
Designer application to replace a deleted review state, the new review state must have the same
RefName and state number as the review state that was deleted.

1 In the Project Explorer, select Study Information.

ot

In the Project Explorer, select the Library Information Explorer bar.
2 Right-click a review state, and select Delete.

A confirmation dialog box appears.

3 Click Yes.
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Designing the study workflow
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About study objects in the study workflow

The study workflow contains:

e Study design—A study design is a container for the structure of a study. Each study has only
one study design, which is created automatically when you create a study (on page 2). The study
design study object is accessible only in a study, not in a library.

e Study elements—A study element is a CDISC term for a basic building block of a study. A
study element represents a segment of a study and can consist of one or more study events.
Study elements are optional

In the InForm application, a study element is a collection of visits (or, in Central Designer
terminology, study events) that are scheduled as a unit. Although you are not required to use
them, consider whether you might benefit from the following uses of study elements:

e If you want to simplify a complex workflow diagram, create a study element and include
several study events in it. Your workflow diagram will have more layers but will be easier to
navigate. A clinician might be better able to review a simplified workflow to determine if it
accurately represents the study protocol.

e Study elements make it easy to reuse a collection of study events. If you add several study
events to a study element and include the study element in a library, you can reuse all of the
study events by reusing the study element.

¢ Study events—A study event is a subject evaluation checkpoint when data is collected. Study
events usually correspond to visits, but one visit can span multiple study events. A study event
can contain one or more forms.

A study event can be repeating. A repeating study event corresponds to a repeating visit in the
InForm application.
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Creating and editing study objects in the study workflow

A study design is a container for the structure of a study. Each study has only one study design,
which is created automatically when you create a study (on page 2). The study design study object is
accessible only in a study, not in a library.

To edit the properties of a study design in the Properties Browser:
1 In the Project Explorer, select the Visit Schedule Explorer bar.
2 Select the StudyDesign folder.

3 Select the Properties Browser.

Note: If the Properties Browser is not visible, select View > Properties.

4 Edit the properties of the study design. After changing each property, press Enter, or tab to the
next property.

Note: The values of editable properties appear in bold, black text, and the values of non-
editable properties appear in gray text.

For more information, see Study design properties (on page 481).

You create a study object (study design, study element, study event, form, section, item, codelist, and
codelist item) in a study or library. You can create a study object outside the hierarchy of a study or
library, but the study object is not deployed until you add it to a parent study object in a study or
library. To include a study object in the hierarchy of a study or library, add it to an existing parent in
the study or library.

To create a study element:

1 (Available only in a study) To create a study element on a study design:
a  In the Project Explorer, select the Visit Schedule Explorer bar.
b Right-click the study design, and select New Element.
To create a study element outside the hierarchy of a study or library:
¢ In the Project Explorer, select the Elements and Events Explorer bar.
d Right-click the Study Elements folder, and select New Element.
The Object Name dialog box appears.

2 Type a title, RefName, and description, and click OK.

To edit the properties of a study element in the Properties Browser:

1 In the Project Explorer, select a study element.

2 Select the Properties Browser.

Note: If the Properties Browser is not visible, select View > Properties.
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3 Edit the properties of the study element. After changing each property, press Enter, or tab to the
next property.

Note: The values of editable properties appear in bold, black text, and the values of non-
editable properties appear in gray text.

For more information, see Study element properties (on page 482).

You create a study object (study design, study element, study event, form, section, item, codelist, and
codelist item) in a study or library. You can create a study object outside the hierarchy of a study or
library, but the study object is not deployed until you add it to a parent study object in a study or
library. To include a study object in the hierarchy of a study or library, add it to an existing parent in
the study or library.

To create a study event:

1 Navigate to the parent study object, as indicated in the following table.

Parent study object Steps

Study design (only in 1 In the Project Explorer, select the Visit Schedule Explorer bar.

studies) 2 Right-click the study design, and select New Event.

Study element 1 In the Project Explorer, select the Elements and Events Explorer
bar.

2 Right-click the study element, and select New Event.

No parent (for example, 1 In the Project Explorer, select the Elements and Events Explorer
in a library) bar.

2 Right-click the Study Events folder, and select New Event.

The Object Name dialog box appears.
2 Type a title, RefName, and description, and click OK.

To edit the properties of a study event in the Properties Browser:

1 In the Project Explorer, select a study event.

2 Select the Properties Browser.

Note: If the Properties Browser is not visible, select View > Properties.

3 Edit the properties of the study event. After changing each property, press Enter, or tab to the
next property.

Note: The values of editable properties appear in bold, black text, and the values of non-
editable properties appear in gray text.
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To specify the short title of a study event:

1 In the Project Explorer, select a study event.
2 Select the General tab.
3 Type a value in the Short Title field.

To make a study event repeating or not repeating:

1 In the Project Explorer, right-click a study event, and select Repeating Event.

If the study event was nonrepeating, it changes to a repeating study event. If the study event was
repeating, it changes to a nonrepeating study event.

To mark a study event as a special InForm visit:
1 In the Project Explorer, select a study event.

2 Open the Properties Browser.

Note: If the Properties Browser is not visible, open the View menu and make sure Properties
is selected.

3 From the Special Visits drop-down list, select a value.
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Working with workflow diagrams

About study workflows

54

On papet, a study designer often charts the major events of a study by using a flow diagram that
indicates the order in which a subject progresses from one step to another and also shows where any
branches in the study occur. You can use the study workflow tools to map out the flow of a study in
a similar way.

Study workflow tools provide a way to define:

e The major branches and events of a study.
e The forms used to collect clinical observations at each study event.

e Decision points that determine the path a subject follows through the study based on specific
observations.

The process of designing the study workflow creates the actual study objects. A lead study designer
can set up the outline by designing the study workflow and can assign the detail design tasks to other
members of the team.

Use the Workflow Diagram tab to create a study workflow.
About the Workflow Diagram tab

The Workflow Diagram tab enables you to create graphical study workflow diagrams that specify the
sequence of steps in a study and the points where the study workflow can branch depending on the
outcome of specific observations. The Central Designer application keeps the study objects in the
Workflow Diagram and Workflow Grid tabs synchronized.

The Workflow Diagram tab appears in the Study Design, Study Element, and Study Event Editors in
studies, and in the Study Element and Study Event Editors in libraries. Within each editor, the
Workflow Diagram tab enables you to design a different level of a study workflow.

Scope of the Workflow Diagram tab for each study object

Editor Scope of workflow

Study Design e Study elements
e Study element workflow rules
e Study events
e Study event workflow rules

o  Global conditions

Study Element e Study events
e  Study event workflow rules

e  Global conditions
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Editor Scope of workflow

Study Event e Forms
o Form workflow rules

e  Global conditions

Where to create study workflows

You can develop study workflows in either a study or a library, and you can use study objects found
in a Libraries Browser search to define a workflow in a study.

Schedule of Events tab

Another component of study workflow design is the Schedule of Events (on page 77) tab, which
displays a schedule of events for the study. In the Schedule of Events tab, you can indicate the forms
that appear in each study event.

Workflow Grid tab

You can also use the Workflow Grid tab (on page 61) to create workflow information. The Central
Designer application keeps the information in the Workflow Diagram and Workflow Grid tabs
synchronized.

Workflow diagram components

Diagram component Purpose

Study element—Can appear in the workflow for a study design.

Mew Elemant

Study event—Can appear in the workflow for a study design or for a
study element.

—
Mew Event

Repeating study event—Can appear in the workflow for a study
design or for a study element.

New Repeating
Ewent

Form—Can appear in the workflow for a study event.

New Form

l“lil

— Repeating form—Can appear in the workflow for a study event.

Repeating
Farm
—

I“H
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Diagram component Purpose
Workflow rule—The color of the component indicates the study
‘) / object that precedes the workflow rule in the workflow diagram:

e  Blue—Study element

e  Green—Study event

e Gray—Form

ge¥itals I Global condition—Above a study object, this component indicates
that a global condition is associated with the study object.

Witals

 — ] Arrow—Connects two workflow diagram components. The arrow
indicates the order of the workflow between the components.
] r Sequence number—Indicates the order of workflow diagram
components that are not at the endpoint of a connecting arrow.
= Data view icons—In the lower-left corner of a workflow object,
icons indicate the target application for which a study object and its
children were designed.
= '@J _ Schedule drop-down list—When you click the clock ('9) icon, a
Sehieduled far: i summary of the scheduling information for a study object appears.
StudpBody
+ 30 days

Viewing a workflow diagram

To view a workflow diagram:

Note: You can view a workflow diagram for a study only in a study, not in a library.

1 In the Project Explorer, select a study design, study element, or study event.
2 Select the Workflow Diagram tab.

To adjust the size of a workflow diagram:

1 In the Project Explorer, select a study design, study element, or study event.

2 Select the Workflow Diagram tab.

[SM)

Select the arrow to the right of the Zoom button.
or
Right-click the workspace.

4 Select a sizing option.
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Creating a study object in a workflow diagram

The editor in which the Workflow Diagram tab appears determines the study objects and
components that you can create. When you create a study object, the study object is added to the
Workflow Diagram tab, the Workflow Grid tab, and the Project Explorer.

Select one of the following Explorer bars and navigate to the Workflow Diagram tab to create the
specified study object:

Study element:

e  Visit Information Explorer bar

e Elements and Events Explorer bar
Study event:

e  Visit Information Explorer bar

e Elements and Events Explorer bar
Form:

e Forms and Transactions Explorer bar

To create the study object on the Workflow Diagram tab:

1

3
4
5

In the Workflow Diagram, click the New <Study Object Type> button.
The Object Name dialog box appears.
In the Title field, type the title of the study object.

As you type, the RefName field is filled in, using the Title text but omitting spaces and
disallowed characters.

Optionally, in the RefName field, type a different RefName from the default.
Optionally, in the Description field, type a description of the study object.
Click OK.

To change the repeating state of a study event:

1
2
3

In the Project Explorer, select the study design or study element on which the study event exists.
Select the Workflow Diagram tab.

Right-click a study event, and change the selection of Repeating Event as needed.

To change the repeating or common state of a form:

1
2
3

In the Project Explorer, select the study event on which the form exists.
Select the Workflow Diagram tab.

Right-click a form in the workflow diagram, and select Repeating Form or Common Form.
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Connecting and ordering study objects in a workflow diagram

58

In a workflow diagram, when you connect:

e Two study objects—You specify the order of the study objects in the workflow.

e A rule and a study object—You specify the study object that comes next in the workflow based
on the outcome of the rule.

When you make a connection to a study event, you can schedule the study event.
To connect a study object to a study element or a study event:
1 In the Project Explorer, select the Visit Schedule Explorer bar.
2 Select a study design, study element, or study event.
3 Select the Workflow Diagram tab.
4

Move the cursor over the first of the two objects you want to connect until it changes to a
pointing finger icon.

w

Drag the cursor to a connection node in the next component in the sequence, and release it.

A connection line points from the first object to the study element or study event, and the Edit
Schedule dialog box appears.

6 Schedule the interval between study objects, and click OK.

Note: You can define multiple schedules leading into a study element or event. However, in
the InForm application, the visit hours are always set to the schedule with the greatest
amount of time.

To connect two forms:

1 In the Project Explorer, select the Visit Schedule Explorer bat.

2 Select a study event.

3 Select the Workflow Diagram tab.

4 Move the cursor over the first of the two forms until it changes to a pointing finger icon.

5 Drag the cursor to a connection node in the next component in the sequence, and release it.
The two forms are linked by an arrow.

To connect a rule to the next study object:

1 In the Project Explorer, select the Visit Schedule Explorer bar.
2 Select a study design, study element, or study event.

3 Select the Workflow Diagram tab.
4

Move the cursor over the rule workflow diagram object until it changes to a pointing finger icon.
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5 Drag the cursor to a connection node in the next component in the sequence, and release it.

A connection line points from the rule to the next object, and one of the following dialog boxes
appears:

e If you are connecting a rule to a study event or study element—Edit Schedule and Rule
Action dialog box.

e If you are connecting a rule to a form—Edit Rule Action dialog box.
6 In the If the value is section, select a value.
7  Click OK.

8 If the workflow branches differently for different outcomes of the rule, repeat the procedure for
the other branch.

For more information, see:
Edit Schedule dialog box—Option descriptions (on page 411).
Edit Rule Action dialog box—Option descriptions (on page 410).

Edit Schedule and Rule Action dialog box—Option descriptions (on page 411).

Changing the sequence number of a study object in a workflow diagram
Sequence numbers specify the order of disconnected study objects in the Workflow Diagram tab.

The first study object in each workflow sequence has a sequence number. If a workflow diagram has
multiple workflow sequences, sequence numbers specify how the workflows are ordered in the
InForm application, unless an unconnected study object is associated with a global condition. For
clarity, and to make sure that dynamic study objects deploy in the correct order, connect all study
objects in a workflow.

You can use whole numbers as well as numbers with decimal points as sequence numbers, and you
are not required to use sequential numbers. For example, if you expect to add additional study
objects to a workflow, you might use only even or odd numbers for existing study objects so you
have additional whole numbers to use for new additions. Alternatively, you can use sequential
numbers for existing study objects and use numbers with decimal points for inserted study objects.

1 In the Project Explorer, select the Visit Schedule Explorer bar.
2 Select a study design, study element, or study event.

3 Select the Workflow Diagram tab.
4

Double-click the sequence number (the numbered gray box that appears to the left of a study
object).

The Modify Step Sequence dialog box appears.

5 In the Step Sequence Number ficld, type the new sequence number.

Note: The new sequence number cannot already exist in the workflow. To insert a new study
object into the sequence, you must renumber other study objects to make the desired
number available.

6 Click OK.
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Creating a reference copy of a study object in a workflow diagram

You can create a reference copy of a study element, study event, or form in a workflow. A reference
copy is a duplicate image of a study object in a diagram; it is not a new link to the study object in the
Central Designer repository. In a workflow diagram with many study objects and connecting lines,

you can use a reference copy of a study object to separate the tangle of connecting lines and make

the workflow diagram less cluttered.

1
2
3

In the Project Explorert, select a study design (in a study only), study element, or study event.
Select the Workflow Diagram tab.

Right-click the study object in the workflow diagram, and select the Create Reference Copy
command for the study element.

Viewing scheduling information

60

1
2
3

In the Project Explorer, select the Visit Schedule Explorer bar.
Select a study design, study element, or study event.

Select the Workflow Diagram tab.

To view scheduling information for a single workflow object, click the clock icon (":/_)) on the
object.

To view scheduling information for the entire workflow, right-click the background of the
wotkflow, and select Show Scheduling.

To hide scheduling information, press Esc.
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Working in the Workflow Grid tab

Working with study objects in a workflow grid

In the Workflow Grid tab, you create the principal study objects in the workflow of a study by using
a grid format.

You create only study objects (no workflow rules or global conditions) in the Workflow Grid tab.
You can connect the study objects in a workflow and use workflow rules and global conditions in the
Workflow Diagram tab. The Central Designer application keeps the study objects in the Workflow
Diagram and Workflow Grid tabs synchronized.

The Workflow Grid tab appears in the Study Design, Study Element, and Study Event Editors in
studies, and in Study Element and Study Event Editors in libraries.

The selected selection in the View Targets drop-down list determines the workflow objects that
appear on the Workflow Grid tab.

Creating a study object in a workflow grid

The editor in which the Workflow Grid tab appears determines the study objects and components
that you can create.

Select one of the following Explorer bars and navigate to the Workflow Grid tab to create the
specified study object:

e  Study element:
e  Visit Information Explorer bar
e Elements and Events Explorer bar
e Study event:
e  Visit Information Explorer bar
e Elements and Events Explorer bar
e Form:
e Forms and Transactions Explorer bar
To create the study object on the Workflow Grid tab:
1 In the Project Explorer, select the study design, study element, or study event.
2 Select the Workflow Grid tab.
3 In the Type column, select the study object type from the drop-down list.
4 In the Title column, type the name of the study object.

5 Press Enter, or click the next row, or press the Tab key.

Note: You cannot reuse the same study event in multiple study elements in the same study.
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To change the repeating state of a study event:

1 In the Project Explorer, select the study design or study element on which the study event exists.
2 Select the Workflow Grid tab.

3 Click within the gray box, located at the beginning of the row for a study event.

4 Right-click the study event, and change the Repeating Event selection as needed.

To change the repeating or common state of a form:

1 In the Project Explorer, select the study event on which the form exists.

2 Select the Workflow Grid tab.

3 Click within the gray box, located at the beginning of the row for a form.

4

Right-click the study form, and change the Repeating Form or Common Form selection as needed.

Opening a child study object from a workflow grid

From the Workflow Grid for a study object, you can open the Design tab of any of its child study
objects. For example, from the Workflow Grid tab for a study design, you can edit its child study
elements and study events.

1 Navigate to the study object, as indicated in the following table.

Child study object Parent Workflow Grid  Steps

Study element Study design (studies 1 In the Project Explorer, select the Visit
only) Schedule Explorer bar.

2 Select the Workflow Grid tab.

Study event Study design (studies 1 In the Project Explorer, select the Visit
only) Schedule Explorer bar.

2 Select the Workflow Grid tab.

Study element 1 In the Project Explorer, select the
Elements and Events Explorer bar.

2 Seclect a study element.

3 Select the Workflow Grid tab.

Form Study event 1 In the Project Explorer, select the Visit
Schedule Explorer bar.

or

2 In the Project Explorer, select the
Elements and Events Explorer bar.

3 Select a study event.

4 Select the Workflow Grid tab.

2 Click within the gray box, located at the beginning of the row for the child study object.
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3 Right-click the row of that study object, and select Edit.
The Design tab for the selected study object appears.
4 Update the study object as needed.
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Study workflows and deployment to the InForm
application

The design of a study workflow affects the following characteristics of the InForm study to which it
is deployed:

e Otrder of visits and forms (on page 64)—The order of visits and forms in the InForm
application depends on the order in which study objects are connected in a workflow and on the
sequence numbers of study objects that are not connected.

e Dynamic status of visits and forms (on page 68)—Whether a visit or form is visible when a
subject is enrolled in an InForm study depends on whether a study event or form is associated
with a workflow rule or global condition in a study workflow. The outcome of the InForm rule
that corresponds to a workflow rule or global condition determines whether a dynamic visit or
form is activated.

e Scheduling of visits (on page 70)—The dates in the Visit Calculator that appears when a
subject is enrolled in an InForm study and the MedML STARTHOUR value of a visit are
generated from the scheduling information specified in a study workflow.

InForm visits and forms

64

Order of InForm visits and forms

The order of visits and forms in the InForm application depends on the order in which study objects
are connected in a workflow and on the sequence numbers of study objects that are not connected.

Note: If the first object in a sequence is de-emphasized, the sequence number is also de-
emphasized.

Simple sequence of forms or study events

Simple sequence of forms or study events

Otder in the InForm application: Form A, Form B, Form C.
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Multiple sequences of forms or study events

A workflow can contain multiple sequences of connected study objects. The first study object in each
sequence is labeled with a sequence number. For more information, see Sequence numbers (on

page 75).

Multiple sequences of forms or study events

'I o o
— Forrn & . Formn B Form C
o | .
2 | s
- Fuarm D — i Farm E
e —— N rrre————

Otder in the InForm application: Form A, Form B, Form C, Form D, Form E.

Workflow with study elements

Workflow with study elements

(Dotted lines indicate that the study elements contain the study events. These study objects do not
appear together in the Workflow Diagram.)

Y
Element 1 Element 2

1 (Visit1 [ Vigit 2 1 (Mieit 3 Wisit 4

Otrder in the InForm application: Visit 1, Visit 2, Visit 3, Visit 4.
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Workflow with study elements and study events

Workflow with study elements and study events

(Dotted lines indicate that the study elements contain the study events. These study objects do not
appear together in the Workflow Diagram.)

1 Vigit 5
Element 1 Element 2

1 [ Wisit 1 Visit 2 1| Wisit 3 Wisit 4

Otrder in the InForm application: Visit 1, Visit 2, Visit 3, Visit 4, Visit 5.

Workflow with workflow rule

Workflow with workflow rule

(Dotted lines indicate that the study elements contain the study events. These study objects do not
appear together in the Workflow Diagram.)

1 rvalue i
Element 1 Fulz Element 2
1 |
I i
T [ Vet 1 Vait 2 1 [ Wik 3 Wisit 4
wihen \rdnTe i% falee
Element 3
|
I
1 [Vist5 Vst B
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Workflow with workflow rule

Otder in the InForm application:

e Initially—Visit 1, Visit 2. Only Visit 1 and Visit 2 are in the Case Book. All other visits are
dynamic and depend on the outcome of the rule.

e If the rule evaluates to True—Visit 1, Visit 2, Visit 3, Visit 4. Visit 5 and Visit 6 are dynamic
and do not appear in the Case Book.

e If the rule evaluates to False—Visit 1, Visit 2, Visit 5, Visit 6. Visit 3 and Visit 4 are dynamic
and do not appear in the Case Book.

Workflow with workflow rule (2)

Workflow with workflow rule 2

(Dotted lines indicate that the study elements contain the study events. These study objects do not

appear together in the Workflow Diagram.)
| Wisit 5 ]

T

Order in the InForm application:
e Initially—Visit 1, Visit 2, Visit 4, and Visit 5. Only Visit 3 is dynamic.
e If the rule evaluates to True—Visit 1, Visit 2, Visit 3, Visit 4, and Visit 5.

e If the rule evaluates to False—Visit 1, Visit 2, Visit 4, and Visit 5. Visit 3 is dynamic and does
not appear in the Case Book.
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Workflow with global condition

Workflow with global condition

Farm B

Order in the InForm application:

e Initially, or if the condition evaluates to False—Form A, Form C. Form B is dynamic and
does not appear in the Case Book.

o If the condition evaluates to True—Form A, Form B, Form C.

Dynamic status of InForm visits and forms

Whether a visit or form is visible when a subject is enrolled in an InForm study depends on whether
a study event or form is associated with a workflow rule or global condition in a study workflow. The
outcome of the InForm rule that corresponds to a workflow rule or global condition determines
whether a dynamic visit or form is activated.

For information about a workflow with a workflow rule, see Order of InForm visits and forms (on
page 64).

Workflow with global condition

EBT Workflow with global condition (dynamic)

Farm B

Dynamic status in the InForm application:

e Initially, or if the condition evaluates to False—Form A and Form C are in the Case Book.
Form B is dynamic and does not appear in the Case Book.

o If the condition evaluates to True—Forms A, B, and C are in the Case Book.
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Complex workflow with global conditions (Example 1)

Study components

e Eventl
e Forml
e Jteml
e Item2

e Event2 (with a global condition)

e Form?2 (with a global condition)

Behavior
e Enter a value for Item1 and submit Form1 without entering a value for Item2: Event2 appears.

e Enter a value for Item2 and submit Form1 without entering a value for Item1: Neither Event2
nor Form?2 appears.

e Subsequently enter a value for Item1 and submit Form1; Both Event2 and Form?2 appeatr.

Complex workflow with global condition (Example 2)

Study components

e FEventl
e Forml
e Iteml
e Jtem2

e Elementl (with a global condition)
e TFvent2

e Event3 (with a global condition)

Behavior

e Enter a value for Item1 and submit Form1 without entering a value for Item2: All the visits in
Element] appear.

e Enter a value for Item2 and submit Form1 without entering a value for Item1: None of the visits
in Element] appear.

e Subsequently enter a value for Item1 and submit Form1: All the visits in Elementl appeat.
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Scheduling of InForm visits

The dates in the Visit Calculator that appears when a subject is enrolled in an InForm study and the
MedML STARTHOUR value of a visit are generated from the scheduling information specified in a
study workflow.

A study element or study event in a workflow can be:

e Scheduled—You can schedule a study element or study event in the Workflow Diagram. The
first study object in a sequence is considered to be scheduled by default.

¢ Unscheduled—If you do not schedule a study element or study event in the Workflow
Diagram, the study element or study event is unscheduled in the InForm application. If a
workflow has more than one sequence, the first study object in any sequence other than the first
is considered to be unscheduled.

If a study object is unscheduled, its STARTHOUR value in the InForm application is set to 1

hour later than the previous study object in the sequence. This is to make sure that no two visits
have the same STARTHOUR.

You can click the drop-down list in the lower-right corner of study elements and study events to
view scheduling information.

Workflows with scheduled and unscheduled study objects

One sequence of study events with scheduling

One sequence of study events with scheduling

1 (Wisit 1 | Wisit 2

S

Scheduled for:
Wit 1
+1 day
Wfindion:
Before delay not zet
After delay not set

Scheduling in the InForm application: Visit 1 and Visit 2 are scheduled. Visit 2 is scheduled one
day after Visit 1.
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Multiple sequences of study events

Multiple sequences of study events

-

1 [ Wizt 1 Wizt 2

©

Schieduled for:
Wigit 1
+1 day
Windom:
Before delay not zet
After delay not set

2 [ Misit 3 Wizt 4 YWizit B
® ©
Scheduled far: Scheduled for:
Wizt 3 Wizt 4
+1 day +1 day
Windomw: Windomws
Before delay nat zet Before delay not zet
After delay not zet After delay not zet

Scheduling in the InForm application:

e All visits except Visit 3 are scheduled. Visits 2, 4, and 5 are scheduled one day after the previous
visit.
e The STARTHOUR attribute of Visit 3 is one hour after Visit 2.

e  Visit 5 is scheduled three days plus one hour after Visit 1.
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Workflow rule with scheduled study events

Workflow rule with scheduled study events

1 [ Visit 1

when value iz true | Wizt 2

©

. Scheduled far;

when vallie iz falze Wit
+1day

WIRdow:
Befare delay not et
After delay not zet

Wizit 3

©)

Schieduled for:
Wizt 1
+ 5 dayz
Wfindion;
Before delay not set
After delay not zet

Scheduling in the InForm application:

e  Visit 1 is scheduled.

e The STARTHOUR attribute of Visit 2 is calculated to be one day after Visit 1, but Visit 2 does
not appear in the Visit Calculator when the value of Rulel is true.

e The STARTHOUR attribute of Visit 3 is calculated to be five days after Visit 1, but Visit 3
does not appear in the Visit Calculator when the value of Rulel is false.

72 Oracle® Health Sciences Central Designer 2.1



InForm Design Guide

Global condition with scheduled and unscheduled study event

Global condition with scheduled and unscheduled study event

1 h h

Wizt 1 Wigik 2 Wizit 3

©

Scheduled far;
Wisit 2
+ 1 day
afind o
Before delay not zet
After delay not get

Scheduling in the InForm application:

e  Visit 1 is scheduled.

o The STARTHOUR attribute of Visit 2 is calculated to be one hour after Visit 1, but Visit 2
does not appear in the Visit Calculator.

e  Visit 3 is scheduled as one day after Visit 2 and one day plus one hour after Visit 1.
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Scheduled study elements

Scheduled study elements

(Dotted lines indicate that the study elements contain the study events. These study objects do not
appear together in the Workflow Diagram.)

1

Elerment 1 Elesnant 2
®

Scheduled o
Elerrent 1
+1 day

Wwindow:
Betore delay not =t
After delay not set

o e

1 [ Wist 1 Visit 2 T | Visit 3

Scheduled for.
Wisit 3
+1 day
Wirndow:

Before delay not set
After delay not zet

Scheduling in the InForm application:
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Visit 1 is scheduled.
Visit 2 is unscheduled. Its STARTHOUR value is one hour after Visit 1.
Visit 3 is scheduled as one day after Visit 2.

Visit 4 is scheduled as one day after Visit 3, or two days plus one hour after Visit 1.

Oracle® Health Sciences Central Designer 2.1



InForm Design Guide

Unscheduled study elements

Unscheduled study elements

(Dotted lines indicate that the study elements contain the study events. These study objects do not
appear together in the Workflow Diagram.)

1 /—
Element 1 Element 2
I I
1 i
1 ((Visit1 [ Wisit 2 1 (Wisit 3 i Visit 4
\ ¥

Scheduling in the InForm application:

e Visit 1 is scheduled.
e Visits 2, 3, and 4 are unscheduled. The STARTHOUR value of each is one hour after the

preceding visit.
Deploying to the InForm application
Sequence numbers
When you create a study object in the Workflow Diagram tab, a sequence number appears in a box

near the upper left corner of the object. Initially, the sequence number indicates the order in which
you created each study object.

As you connect study objects in a workflow, the sequence number disappears for each connected
study object after the first.
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A workflow can contain multiple sequences of study objects. The sequence numbers of the first
study object in each sequence determine the order in which the sequences appear in a deployed

study. In the following example, the order in which the forms appear when deployed is Form A,
Form B, Form C, Form D, Form E.

1

Formn A — Form B

Foarm [ — = Farm E

You can change the sequence number for a study object in a workflow diagram. Changing the
sequence number of a study object affects only the order in which multiple sequences are deployed.
Changing the sequence number does not affect the order in which a study object appears in the
Project Explorer or in the Workflow Diagram tab.

Note: The new sequence number cannot already exist in the workflow. To insert a new study

object into the sequence, you must renumber other study objects to make the desired humber
available.

Invalid workflows

To prevent the creation of an invalid workflow, the Central Designer application enforces the
following rules:

e The sequence of workflow steps cannot be circular. The last step cannot point back to the first
step.

A study object that is associated with a global condition can have only one prerequisite step, and

you cannot associate a global condition with a study object that has more than one prerequisite
step.

A study object can have only one outgoing arrow. Branching to two different study objects
requires a workflow rule.

e The workflow action for each branch of a workflow rule outcome must be unique. For example,
if a step follows a workflow rule when the expression evaluates to True, the other branch of the
workflow cannot also be based on the expression evaluating to True.
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Working in the Schedule of Events tab

Using the Schedule of Events tab to update the study workflow

The Schedule of Events tab is a matrix that lists the study events in a study and indicates the forms
that are included in each study event. The Schedule of Events tab is available in studies and not in
libraries.

The Schedule of Events tab enables you to create or update a study workflow quickly by selecting
(with checkboxes) the forms to include in each study event. When you select or deselect the forms in
a study event and save the study design, the Central Designer application updates the contents of the
study event and also updates the study event workflow.

You can also navigate to the Form editor or delete forms from a study using the Schedule of Events

tab.

Adding or removing a form in the Schedule of Events

1 In the Project Explorer, select the Visit Schedule Explorer bat.
2 Select the study design.

The Study Design Editor appears.
3 Select the Schedule of Events tab.

4 TFor each study event in which the form should be added or be removed, select or deselect the
checkbox where the row of the study object and the column of the study event intersect.

The form is added or removed under each applicable Study Event container in the Project
Explorer and is added to the Workflow Diagram and Workflow Grid tabs of the Study Event
Editor.

Deleting a form from the Schedule of Events

1 In the Project Explorer, select the Visit Schedule Explorer bar.
2 Select the study design.
The Study Design Editor appeats.
3 Select the Schedule of Events tab.
4 Right-click the row of the form, and select Delete InForm form.

A message appears, prompting you to confirm the deletion.
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5

Click one of the following:
e Yes—Delete the study object.

®  Yes, Always Delete—Delete this study object, and do not prompt for confirmation in
subsequent deletions.

e No—Do not delete the study object.

Note: If you click Yes, Always Delete, and later decide that you want to be prompted before
deletions, you can reset the prompt in the Central Designer Options dialog box, which is
available from the Tools menu.

Editing a form in the Schedule of Events

78

1
2

In the Project Explorer, select the Visit Schedule Explorer bar.
Select the study design.

The Study Design Editor appears.

Select the Schedule of Events tab.

Right-click the row of the form, and select Edit InForm form.

The Form Editor appears in the workspace and displays the definition of the study object you
selected.

Edit the form.
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Designing forms

In this chapter
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Forms design activities

About forms

A form is a container for one or more items. A form can contain one or more sections and supports
multiple locales and layouts. (A section is a form embedded within a form.)

Order in which to create forms
The order in which you can create forms and items depends on the current view of a study:

e In the Form editor, a form must first exist before you can create or copy its items or sections.

e In the Study Forms editor, you can create forms and items, or copy them into the study from a
library, in any order.

Working with multiple forms

The topics in this section focus on working with a single form. The Workflow Diagram and the
Workflow Grid tabs of the Study Event Editor enable you to specify how forms relate to each other
in the workflow of a study event. For more information, see About study workflows (on page 54).

Naming conventions

Sometimes lists of forms in the Central Designer application include sections, and in the Study
Forms Container Editor, sections and forms have the same icon. To more easily identify sections and
forms, Oracle recommends that you use a naming convention. For example, you can preface a form
name with frm and a section name with sct.

Repeating, common, and associated forms

Certain types of forms have specialized characteristics when deployed in a study.

Type of form Characteristic Property used to define form
Repeating The form holds multiple Repeating.

;nsttances of the same set of If this property is set to True, the form is

ata. repeating.

Common The same data is visible in all Common.

study events that contain the If this property is set to True, the form is

form.

common.

Associated Data from both forms in the ~ AssociatedForm. (This property is visible only in

association is accessible when the Structured view of a study.)

"Two repeatin . .

( P 5 3 study user works with either . .

forms in the same p Two repeating forms in the same study event
orm.

study event) are associated if the AssociatedForm property of
one form is set to the Title of the other form.
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Creating and editing a form

You create a study object (study design, study element, study event, form, section, item, codelist, and
codelist item) in a study or library. You can create a study object outside the hierarchy of a study or
library, but the study object is not deployed until you add it to a parent study object in a study or
library. To include a study object in the hierarchy of a study or library, add it to an existing parent in
the study or library.

To create a form:

1 To create a form on an existing study event:
e In the Project Explorer, right-click a study event, and select New > Form.
To create a form outside the hierarchy of a study or library:
a  In the Project Explorer, select the Forms and Transactions Explorer bat.
b Right-click the Study Forms container, and select Form.
The Object Name dialog box appears.

2 Type a title, RefName, and description, and click OK.

To edit the properties of a form in the Properties Browser:

1 In the Project Explorer, select the Forms and Transactions Explorer bar.

2 In the Forms folder, select a form.

3 Select the Properties Browser.

Note: If the Properties Browser is not visible, select View > Properties.

4 Edit the properties of the form. After changing each property, press Enter, or tab to the next
property.

Note: The values of editable properties appear in bold, black text, and the values of non-
editable properties appear in gray text.

To add one or more items to a form or section:

—_

In the Project Explorer, select the Forms and Transactions Explorer bar.
2 In the Forms folder, select a form.

3 Select the Design tab.
4

On the toolbar, click Columns, and display the columns that you need in the grid, including
Codelist and Item Properties.

ul

In the grid, create items on the form or section by typing values in each field. Press Tab to
advance to the next field and, when you have reached the end of a row, to the next item.

Oracle® Health Sciences Central Designer 2.1 81



Chapter 3 Designing forms

Your changes are added to the grid after you move the cursor away from the row but are not
saved in the database until you explicitly save them.

Note: To type extended ASCII characters in text fields, press ALT while entering the decimal
code for the character. You can also add HTML formatting characters (on page 244) to a
text field to control its appearance when deployed.

6 To modify the properties of an item:
a  In the Item Properties field, click Edit, or on the toolbar, select Item Properties.
The Item Properties dialog box appears.

b Define the properties of the item (on page 379). The fields that appear in the dialog box
depend upon the type of item that you select. These properties are also available on the
Design tab for an item.

To add a codelist to an item:

—_

In the Project Explorer, select the Forms and Transactions Explorer bar.

2 In the Forms folder, select the form or section that contains the item, and select the Design tab.
3 In the grid, select an integer, text, or float item.

4 Do one of the following:

e  If the codelist already exists, select it from the drop-down list in the Codelist field.

e Create a codelist (on page 124) on the item.

Making a form common or nhot common
1 In the Project Explorer, select the Forms and Transactions Explorer bar.
2 In the Forms folder, right-click a form, and select Common Form.

If Common Form is selected, the form is common. If Common Form is not selected, the form is not
common.

Making a form or section repeating or nonrepeating

1 In the Project Explorer, select the Forms and Transactions Explorer bar.
2 In the Forms folder, right-click a form or section, and select Repeating Form or Repeating Section.

If Repeating Form or Repeating Section is selected, the form or section is repeating.
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Marking a form for source verification

You can indicate that a form requires source verification or that a repeating form is critical for source
verification in the InForm application by setting its SDV Required and SDV Ciritical properties.

Note: All forms that are marked SDV Critical automatically are marked SDV Required.

1 In the Project Exploret, select the Forms and Transactions Explorer bar.
In the Forms folder, select a form.
Select the Design tab.

To indicate that the form requires source verification, select the SDV Required checkbox.

U LN

To indicate that the form is critical for source verification, select both the SDV Required and the
SDV Critical checkboxes.

Marking a form as a special InForm form
1 In the Project Explorer, select the Forms and Transactions Explorer bar.
2 In the Forms folder, select a form.

3 Open the Properties Browser.

Note: If the Properties Browser is not visible, open the View menu and select Properties, if it
is not already selected.

4 From the Special Forms drop-down list, select the type of special form.

Associating two forms

You can associate two repeating forms that are in the same study event. You can associate a form
with only one other form.

1 In the Project Explorer, select the Forms and Transactions Explorer bar.
2 Select a form.

3 In the Properties Browser, select the form you want to associate from the drop-down list in the
Associated property, and press Enter.

The Associated property for both forms is updated.
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Creating and translating instructions and Help for a form

You can create study documents that are specific to a target application or locale for study designs,
study elements, study events, forms, sections, and items.

You can provide instructions and Help information if the study or library supports one or more
locales, and if you have been given skills to work in the locales (in the Central Designer
Administrator application).

To create and delete instructions and Help:

1 In the Project Explorer, select a study object (study design, study element, study event, form,
section, item, codelist, or codelist item).

The editor for the study object appears in the workspace.
2 Select the Instructions & Help tab.

3 To select a locale for the study documents, select the tab for the locale. The tabs are located
along the bottom of the workspace.

4 To create or edit study documents:
a  Type in the text area.

b  Optionally, use the toolbar to format the appearance of the text. Additionally, you can use
HTML formatting characters. For more information, see Supported HTML formatting
tags (on page 244).

5 To delete study documents:
a  On the toolbar, click the Delete button.
or
Select all of the text, and press Delete.
A dialog box appears.
b Choose one of the following options:
e Delete the study documents for only the selected locale.

e Delete the study documents for all locales.
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To translate instructions and Help:

1

In the Project Explorert, select a study object (study design, study element, study event, form,
section, item, codelist, or codelist item).

The editor for the study object appears in the workspace.
Select the Instructions & Help tab.

To select a locale for the study documents, select the tab for the locale. The tabs are located
along the bottom of the workspace.

Optionally, copy and paste study documents from a locale for which the information is already
written.

Select the locale to which you want to translate.
Translate the study documents.

Optionally, use the toolbar to format the appearance of the text.

Viewing the parents of a linked form

You can view the parents of a form, section, item, codelist, or codelist item that:

You copied using the Copy > Link option.

You use on multiple parents.

To view the parents of a linked study object:

1 In the Project Explorer, select a study object, and confirm that a blue icon (%') appears in the
upper-left corner of the study object's icon.
Note: If the icon does not appear, the study object could be used multiple times in the study
but always on the same parent.
2 Right-click the study object, and select Show Parents.
The Show Parents dialog box appears.
3 Review the paths of the parent study objects in the current project.
The paths begin with the project name and work down; the last study object listed is the parent.
4 To copy paths to the Microsoft Windows clipboard:
a  To copy one path, select it and click Copy.
or
Click Copy All.
b Paste the information in a text editor.
Notes:
.

Show Parents is available in both a study and library, but it lists only the parents in the current
project.

Show Parents is not available for a study object on a single parent that appears multiple times,
such as an item on a form that is used multiple times in a study.
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Special InForm forms and items

In the InForm application, certain forms are required, and others have special design requirements to
make sure that their data is handled correctly in an InForm study:

e Screening (on page 80).

e  Enrollment (on page 88).

e Patient Identification (on page 89).
o Study Completion (on page 91).

Special InForm items are required for some forms. You can include the following additional special
InForm items in a regular form:

e Date of Visit (on page 90).
e Randomization (on page 97).

If you do not include special InForm forms and items in your study design, the Central Designer
application includes default versions of some forms and items when you deploy the study to the
InForm application. Default versions are included for the following:

e Screening form (on page 80).
e  Enrollment form (on page 88).

e Date of Visit item (on page 906).

Screening form

86

The Screening form is included in the special InForm Screening visit as the system Screening form.

Design consideration Description

Form title (value of Special ~ Screening.
Forms property)

Purpose in the InForm Captures subject screening data.
application
Required form? Yes. If you include a custom screening form, select Screening in

the Special Forms custom property list in the Properties Browser.

Default version generated?  Yes. If you do not include a screening form, a default form is
generated during deployment to the InForm application. The default
form contains the item listed as a Required item. If you include a
custom screening form, it must contain the required item.

Note: Default forms and items appear in English in the InForm

application. Create custom forms and items if you do not want to
use the default information or if you want to translate an item or

form.
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Design consideration Description

Required items? e Item—Initials.
e Item type—Text.

e Special Fields property—Initials (Screening).

Optional items e Item—Date of birth.
e Item type—Date time.

e Special Fields property—DOB (Screening).

e Item—Screening date.
e Item type—Date time.

e Special Fields property—Screening date (Screening).

Hidden items During deployment, the Central Designer application creates two
hidden items, itmWorkflow and itmVisitHours, which are used
internally by Central Designer dynamics calculations to store data.
These data items are not visible during form design or in the
annotated study book.

Other requirements e The Screening form must have the Special Forms custom
property value of Screening and must be the only form in the
study with this custom property value.

e The study event that contains the Screening form must have the
Special Visits custom property of Screening and must be the
only study event in the study with this custom property value.
The Screening study event must contain only the Screening
form and no other forms.

e The Screening study event must be a standalone study event
that is not connected to the rest of the workflow.

e The Screening study event must be the first study event in the
workflow diagram.

e Items with the following Special Fields custom property values
can occur only once in a study and must be in a form with the
Special Forms custom property value of Screening:

= Initials (Screening)
=  DOB (Screening)
= Screening Date (Screening)

e The Screening form must not contain a repeating section.
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Enroliment form

The Enrollment form is included in the special InForm Enrollment visit as the system Enrollment
form.

Design consideration Description

Form title (value of Special ~ Enrollment.
Forms property)

Purpose in the InForm Captures subject enrollment data.
application
Required form? Yes. If you include a custom enrollment form, select Enrollment in

the Special Forms custom property list in the Properties Browser.

Default version generated?  Yes. If you do not include an enrollment form, a default form is
generated during deployment to the InForm application. The default
form contains an item with a text control called Subject Number.
This item allows InForm users to specify a patient number.

Note: Default forms and items appear in English in the InForm
application. Create custom forms and items if you do not want to
use the default information or if you want to translate an item or

form.
Required items? No.
Optional items If you include an optional Patient Number item, it must conform to

the listed specifications.

Note: If you include the optional Patient Number item and you
create a Patient Identification form, the Patient Identification form
must include the same Patient Number item.

e Item—Patient Number.
e Item type—Text or Integer.

e Special Fields property—Patient No. (Enrollment).
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Design consideration Description

Other requirements

The Enrollment form must have the Special Forms custom
property value of Enrollment and must be the only form in the
study with this custom property value.

The study event that contains the Enrollment form much have
the Special Visits custom property of Enrollment and must be
the only study event in the study with this custom property
value. The Enrollment study event must contain only the
Enrollment form and no other forms.

The Enrollment study event must be a standalone study event
that is not connected to the rest of the workflow.

The Enrollment study event must be the second study event in
the workflow diagram.

The Enrollment form must not contain a repeating section.

Patient Identification form

Design consideration

Description

Form title (value of Special

Forms property)

Patient Identification.

Purpose in the InForm

application

Captures subject identification information that users can edit after a
subject is enrolled.

In the InForm application, the items on the special InForm
Screening or Enrollment forms are not editable after a subject is
screened or enrolled. If you want users to be able to change the
patient initials or patient number, you must include those items on a
form with a Special Forms property value of Patient Identification.

When a subject is enrolled, the Patient Initials or Patient Number
data is transferred from the Screening or Enrollment form to the
Patient Identification form. Subsequently, when a user changes the
patient identification fields on the Patient Identification form, the
new information updates the patient object in the study database.
The updated information is not reflected on the Screening and
Enrollment forms.

To transfer other data (for example, to transfer Date of Birth to a
Demographics form), create a calculation rule to populate the item
on the target form with the value of the item on the screening or
enrollment form. When a subject is enrolled, the calculation runs in
the InForm application.

Note: The ability to transfer screening and enrollment data other
than Patient Initials or Patient Number is not available with some
releases of the InForm application.

Required form?

No.
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Design consideration Description

Default version generated?  No.

Required items? The Patient Number item is required if either of the following is true:

¢ You have created an Enrollment form with the Special Forms
custom property of Enrollment, and that Enrollment form
includes an item with the Special Fields custom property of
Patient No. (Enrollment).

¢ You have not created an Enrollment form with the Special
Forms custom property of Enrollment. In this case a default
Enrollment form is generated.

Otherwise, all items are optional.

Optional items The following items, if included, must conform to the listed
specifications.

Note: The Patient Identification form can also have other items,

including items copied from the Screening or Enrollment special

forms. If you copy Screening or Enrollment items, note the other
requirements that apply.

o Ttem—Initials.
e Item type—Text.

e Special Fields property—Initials (Patient Identification).

e Item—Patient Number.
e Item type—Text or Integer.

e Special Fields property—Patient No. (Enrollment).
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Design consideration Description

Other requirements e The Patient Identification form must have the Special Forms
custom property value of Patient Identification and must be
the only form in the study with this custom property value.

e If the Patient Number and Initials items are included on the
Patient Identification form, the items must be together in
either a section or the top-level form.

®  You can copy the Initials item from the Screening form into the
Patient Identification form. If you copy the Initials item:

* Do not use the Copy > Link command. Use Copy > With
new children or Copy > With links to children.

= Change the Special Fields property value from Initials
(Screening) to Initials (Patient Identification).

e If the Enrollment form contains a Patient Number item with the
Special Fields property of Patient No. (Enrollment), the
Patient Number item on the Patient Identification form must be
the same item. You can copy this item with the Copy > Link
command.

e If you copy the Date of Birth or Screening date items from the
Screening form:

* Do not use the Copy > Link command. Use Copy > With
new children or Copy > With links to children.

= Change the Special Fields property value from DOB
(Screening) or Screening date (Screening) to None.

e If you copy screening or enrollment items other than Initials,
Date of Birth, or Screening date, you can copy them with the
Copy > Link command.

e 'The Patient Number and Randomization items cannot be on the
same section or on the same form, outside a section. If one item
is on a section, the other item is allowed to be outside the section
on the same form.

Study Completion form

Design consideration Description

Form title (value of Special ~Study Completion.
Forms property)

Purpose in the InForm Records the completion of a study by a subject or the reason the
application subject dropped out of the study.
Required form? No.

Default version generated?  No.
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Design consideration Description

If a form is marked as the Study Completion form, the Completion
Status or Drop-out Reason special field must also be present:

Required items?

Item—Study completion status.
Item type—Integer or Text.

Special Fields property—Completion status (Study
Completion).

Item—Drop-out reason.
Item type—Integer or Text.

Special Fields property—Drop out reason (Study Completion).

Other requirements

The Study Completion form cannot be repeating.

The Study Completion form must have the Special Forms custom
property value of Study Completion and must be the only form
in the study with this custom property value.

The item with the Completion status (Study Completion)
Special Fields custom property must have a codelist that has two
codelist items:

® Yes codelist item—The value of the Study Completion
Status Items custom property for this codelist item must be
Complete Study (Study Completion).

®= No codelist item—The value of the Study Completion
Status Items custom property for this codelist item must be
Incomplete Study (Study Completion).

The item with the Drop out reason (Study Completion)
Special Fields custom property must have a codelist that has at
least one codelist item. The code on all codelist items must not
have more than 47 characters. During deployment, the codelist
item values are converted to InForm resources that are available
in the InForm application for Reporting and Analysis. The item
must be able to accept only one value.

Designing for a CDD

e Compound item: Did
the subject complete

the study?

If you are implementing a Custom-Defined Database (CDD), note
that you can map the item with the Drop out reason (Study
Completion) property to only one column. For mapping each drop-
out reason to a separate CDD column, Oracle suggests the following
design:

Create a compound item in which the No response to the study
completion status question has multiple-selection child items for each
drop-out reason. The compound item and its child items do not have
a value for the Special Fields custom property.
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Design consideration Description

e Hidden Yes No item: Create a hidden item with a codelist that has Yes and No codelist
Did the subject items.
complete the study?

Custom properties:

e Item—Special Fields property value is Completion status
(Study Completion).

¢ Yes codelist item—Study Completion Status Items value is
Complete Study (Study Completion).

e No codelist item—Study Completion Status Items value is
Incomplete Study (Study Completion).

e Hidden item: Reason Create a hidden item with a codelist in which each codelist item
for noncompletion corresponds to a child item in No response of the visible compound
item.

Custom property:

e Item—Special Fields property value is Drop out reason (Study
Completion).

e C(Calculation rules Create calculation rules that map:

e The Yes response in the compound item to the Yes codelist item
in the hidden Yes No item.

e The No response in the compound item to the No codelist item
in the hidden Yes No item.

e The selected child item in the No response of the compound
item to the corresponding codelist item in the hidden Reason for
noncompletion item.

Note: Because the compound item allows multiple selections,
and the hidden item requires a single selection, the rule must
contain logic that prioritizes the noncompletion reason to select
in the hidden item if multiple reasons are selected in the
compound item.

e Mapping In a CDD mapping, map each child item in the compound item to a
different data series. Each data seties maps to a separate CDD
column.
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Illustration of Study Completion form design for CDD
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1—sctSCO1 section with study completion data entry items.

2—COMPREAS compound item with multi-select integer items mapped to separate columns in
the CDD.

3—sctSCO2 section with special item and controls required for Reporting and Analysis.
4—COMPLETR hidden item with special custom properties:
e Item—Special Fields property value is Completion status (Study Completion).

¢  Yes codelist item—Study Completion Status Items value is Complete Study (Study
Completion).

¢ No codelist item—Study Completion Status Items value is Incomplete Study (Study
Completion).

This item is populated with a calculation rule.

5—COMPREAR hidden item with dropout reason codelist. Special Fields property value is Drop
out reason (Study Completion). This item is populated with a calculation rule.
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Date of Visit item

Design consideration Description

Item Date of visit.

Purpose in the InForm Captures the visit date for any visit.

application

Required form? A Date of Visit form is not required; however, a special Date of

Visit item must be present on:

e The first form of each visit, if you want to enable the Enforce
visit date entry system configuration option in the InForm
application.

e The first form of each instance of a repeating visit in the
InForm application, regardless of whether the Enforce visit
date entry system configuration option is enabled in the
InForm application.

Default version generated?  Yes. Validation checks for a Date of Visit item on the first form of
each repeating study event. If a Date of Visit item is not present, a
default Date of Visit form containing a Date of Visit item is
generated for each repeating study event when you deploy a study to
the InForm application.

Note: Default forms and items appear in English in the InForm

application. Create custom forms and items if you do not want to
use the default information or if you want to translate an item or

form.

Required items? e Item—Date of visit.
e Item type—Date time.

e Special Fields property—DOYV (Date of Visit).

Other requirements A study can contain only one Date of visit item. To use the same
item in multiple forms, use the Copy > Link command.
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Randomization item

Design consideration Description

Item Randomization.

Purpose in the InForm Holds a sequence and drug kit number generated by InForm
application randomization processing.

Required form? No. The special randomization item can appear on any form.

Default version generated? ~ No.

Required items? e Item—Randomization.

e Item type—Text. The field appears in the InForm application
in the format seguence / drug_kit_number.

e Special Fields property—Randomization field
(Randomization).

Other requirements e Anitem with the Special Fields custom property value of
Randomization field (Randomization) can occur only once
in a study.

e The following configuration is required on the computer
hosting the InForm study:

= Define a randomization sequence for each different list of
drug kits used in the study and install it in the study
database using the MedML Installer tool.

* Configure the randomization data source manager.
*  Configure the format of each randomization sequence.
®  Set up a randomization source database.

= Create an ODBC connection for the randomization source
database.

For more information, see the InForm documentation (S#dy
and Reporting Setup Guide).

e In the Central Designer application, a randomization rule is
required to generate the sequence and drug kit number. The
Randomize function is available to help you create the rule. For
more information, see Randomize (in the Rules Reference Guide).

o The Patient Number and Randomization items cannot be on
the same section or form. If one item is on a section, the other
item is allowed to be outside the section on the same form.

Oracle® Health Sciences Central Designer 2.1 97



Chapter 3 Designing forms

Deciding whether to create custom special InForm forms or use the default

forms

98

Oracle recommends using the default forms if the items they contain meet your needs. You must
create custom screening and enrollment forms if:

¢ You want to collect additional data (other than the default items) in the screening or enrollment
form or to copy that data into another form in the study.

®  You want users to be able to edit the screening or enrollment form after a subject is enrolled.
¢ You do not want to collect the default data on the screening or enrollment form.
¢ You want to translate the screening and enrollment forms.

You must create a form with the special Patient Identification Special Forms property if you want
users to be able to update the patient number or initials and have the updated information stored in
the patient object in the study database. If you create a form with the special Patient Identification
Special Forms property, the form must include the special Patient Number item with a Special Fields
property value of Patient No. (Enrollment) if:

®  You include the special Patient Number item in a custom enrollment form.

®  You use the default enrollment form containing the special Patient Number item.
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Validation for special InForm forms and items

Validation area Error or warning

All special forms Error if:
(Screening, Enrollment,

Patient Identification, and
Study Completion) e The form contains multiple instances of any item.

e The study contains multiple instances of the form.

e Required fields are not on the form.

e The form is marked as repeating or appears in a repeating study
event.

e The Special Forms property is defined on a section that is on the
form.

Screening and Patient Error if:
Identification forms . . . .
e (For a Screening form only) The form is used in multiple study
events.
e (For a Screening form only) The form contains a repeating section.

e (For a Patient Identification form only) The Patient Number and
Initials items are included on the form and are not together in
either a section or the top-level form.

e All items are not on the same section ot form.
e The item types for special items are not correct.

Warning if the special items are on a non-special form.

Enrollment form Error if the:
e Form is used in multiple study events.
e Item types for special items are not correct.
e Form contains a repeating section.

Warning if the special items are on a non-special form.

Study Completion form e  Error if all items are not in the same form.

e Warning if the special items are on a non-special form.
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Validation area Error or warning

Error if the item:

DOV item

Is used multiple times in a study, unless it was copied using Copy >
Link.

Note: You can use the Copy > Link option to reuse the DOV
item in a study. However, an error occurs if you use the DOV item
multiple times in a study event, even if you copied it using Copy >
Link.

Was copied using the Copy > Link option and pasted onto a form
in the same study event.

Has an incorrect item type.

Is not on the first form in a study event.

Is in a repeating section or form.

Is in a common form or a section of a common form.

Is in a section in a repeating study event.

Randomization item

Error if the item appears multiple times in a study.

Error if the Patient Number and Randomization items are on the
same section or form. If one item is on a section, the other item is
allowed to be outside the section on the same form.

Patient Initials item

Warning if the item has 4 characters.

Drop Out Reason item

Error if the code for its codelist item has more than 47 characters.

100

Oracle® Health Sciences Central Designer 2.1



InForm Design Guide

Custom properties for special InForm forms and items

The following custom properties identify special InForm visits (study events), forms, items, and
codelist items:

e Special Visits (for study events).
e Special Forms (for a form).
e Special Fields (for an item).

e Study Completion (for the codelist items used in the Completion Status special item in a Study
Completion form).

After defining a special InForm study event, form, item, or codelist item, you indicate how the study
event, form, item, or codelist item will be used in the InForm study by selecting the appropriate
custom property definition in the Properties Browser.

When a study event, form, item, or codelist item is defined as a specific type of Special Study Event,
Form, Special Field, or Study Completion codelist item, the deployment process generates the
MedML definitions for the required InForm study components, including forms, sections, or items,
along with the required Universally Unique IDs (UUIDs).

Note: You can apply the Special Forms custom property only to a form, not to a section. If you
apply the Special Forms custom property to a section, validation fails.
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Non-clinical forms

Regulatory documents and visit reports, which are monitoring forms, are custom forms used by
monitors when they visit sites. You are not required to create monitoring forms. If you do not create
the forms, default forms are created and deployed with the study.

Visit report form—A form that a CRA uses to report findings from a site visit. A visit report
form cannot be repeating but can contain a repeating section.

Regulatory document form—A form that a CRA uses to record whether required regulatory
documentation, such as the study protocol, IRB approvals, and electronic signature reporting
documentation, is available and up to date. A regulatory document form is not repeating by
default, but you can mark it as repeating.

During deployment, a study event is created for each monitoring form.

You can create one of each type of form in a study, and you can create multiple forms in a library.

Note: You can create monitoring forms only in the NonClinical container in the Project Explorer.

Creating a regulatory document form

You can create only one regulatory document form in a study. You can create multiple forms in a
library. When you create a regulatory document or visit report form in the NonClinical container, the
Special Forms custom property in the Properties Browser is automatically set to the appropriate
value (either Reg Docs or Visit Report).

A regulatory document form is not repeating by default, but you can mark it as repeating.

1
2
3
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In the Project Explorer, select the Forms and Transactions Explorer bar.
Select the Non-Clinical folder.

In the workspace, click New > Reg Docs Form.

The Object Name dialog box appears.

In the Title field, type the title of the study object.

As you type, the RefName field is filled in, using the Title text but omitting spaces and
disallowed characters.

Optionally, in the RefName field, type a different RefName from the default.

Optionally, in the Description field, type a description of the study object.
Click OK.
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Creating a visit report form

You can create only one visit report form in a study. You can create multiple forms in a library. The
form must contain a Date of Visit (DOV) item (on page 96) that is marked as a Date of Visit
special item and is the first item on the form. The item does not have to be in its own section. When
you create a regulatory document or visit report form in the NonClinical container, the Special
Forms custom property in the Properties Browser is automatically set to the appropriate value (either
Reg Docs or Visit Report).

A visit report form cannot be repeating but can contain a repeating section.
1 In the Project Explorer, select the Forms and Transactions Explorer bar.
2 Select the Non-Clinical folder.
3 In the workspace, click New > Visit Report Form.

The Object Name dialog box appears.
4 In the Title field, type the title of the study object.

As you type, the RefName field is filled in, using the Title text but omitting spaces and
disallowed characters.

5 Optionally, in the RefName field, type a different RefName from the default.
6 Optionally, in the Description field, type a description of the study object.
7 Click OK.

Validation for monitoring forms

If you create a custom regulatory document form and a visit report form, the following must be true
for the study to pass validation:

e Only one regulatory document form and one visit report form exist in the study.

e (For visit report forms only) The form contains a Date of Visit item that is marked as a Date of
Visit special item and is the first item on the form.

e  If the study supports multiple locales, the regulatory document form and visit report form are
translated for all locales. A warning occurs if the forms are missing translations for one or more
locales.

e The visit report form is not repeating.
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Designing sections

About sections

If you want to group a set of related items together in a form, you can create a section for those
items. Sections are not required components of a form. If you do include a section in a form, the
section must have at least one item.

In a repeating section, multiple instances of the same set of data appear in the section.

In a fixed repeating section, multiple instances of the same set of data appear in the section,
organized by one or more fixed items. For more information, see Designing fixed repeating
sections (on page 108).

Sections are managed as forms. When you select a form that has one or more sections in the Project
Explorer, the Form Editor for the form includes information about the sections in the form.

Creating and editing a section

You create a study object (study design, study element, study event, form, section, item, codelist, and
codelist item) in a study or library. You can create a study object outside the hierarchy of a study or
library, but the study object is not deployed until you add it to a parent study object in a study or
library. To include a study object in the hierarchy of a study or library, add it to an existing parent in
the study or library.

To create a section:

1 In the Project Exploret, select the Forms and Transactions Explorer bar.

2 In the Study Forms folder, right-click a form, and select New Section.
The Object Name dialog box appears.

3 Fill in the fields as necessary, and click OK.

The section is created and appears in the Project Explorer, and the Design tab of the Section
Editor appears in the workspace.

To add one or more items to a form or section:

1 In the Project Explorer, select a form or section, and select the Design tab.

2 On the toolbar, click Columns, and display the columns that you need in the grid, including
Codelist and ltem Properties.

3 In the grid, create items on the form or section by typing values in each field. Press Tab to
advance to the next field and, when you have reached the end of a row, to the next item.

Your changes are saved after you move the cursor away from the row.

Note: To type extended ASCII characters in text fields, press ALT while entering the decimal
code for the character. You can also add HTML formatting characters (on page 244) to a
text field to control its appearance when deployed.
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4 To modify the properties of an item:
a  In the Item Properties field, click Edit, or, on the toolbar, select Item Properties.
The Item Properties dialog box appears.

b Define the properties of the item (on page 379). The fields that appear in the dialog box
depend upon the type of item that you select. These properties are also available on the
Design tab for an item.

To add a codelist to an item:

—_

In the Project Explorer, select the Forms and Transactions Explorer bar.

2 In the Forms folder, select the form or section that contains the item, and select the Design tab.

3 In the grid, select an integer, text, or float item.

4 Do one of the following:
e If the codelist already exists, select it from the drop-down list in the Codelist field.
e  Create a codelist (on page 124) on the item.

To make a form or section repeating:

1 In the Project Explorer, select the Forms and Transactions Explorer bar.

2 In the Forms folder, right-click a form or section, and select Repeating Form or Repeating Section.
If Repeating Form or Repeating Section is selected, the form or section is repeating.

To mark a repeating section as fixed:

1 Navigate to a repeating section.

2 Do one of the following:
e In the Project Explorer, right-click the repeating section and select Fixed Repeating Section.
o In the <Section name> editor, select the Fixed checkbox.

To edit the properties of a section in the Properties Browser:

1 In the Project Explorer, select the Forms and Transactions Explorer bar.

2 In the Study Forms folder, select a section.

3 Select the Properties Browser.
Note: If the Properties Browser is not visible, select View > Properties.
4 Edit the properties of the section. After changing each property, press Enter, or tab to the next

property.

Note: The values of editable properties appear in bold, black text, and the values of non-
editable properties appear in gray text.
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Reordering the sections on a form

1 In the Project Explorer, select the Forms and Transactions Explorer bar.

2 In the Study Forms folder, select a form with two or more sections, and then select the Design
tab.

3 On the toolbar, click Reorder Sections.
The Reorder Sections dialog box appears.

4 Select a section, and use the Move Up and Move Down buttons to reorder the form.

5 Click OK.

Creating and translating instructions and Help for a section

106

You can create study documents that are specific to a target application or locale for study designs,
study elements, study events, forms, sections, and items.

You can provide instructions and Help information if the study or library supports one or more
locales, and if you have been given skills to work in the locales (in the Central Designer
Administrator application).

To create and delete instructions and Help:

1 In the Project Explorer, select a study object (study design, study element, study event, form,
section, item, codelist, or codelist item).

The editor for the study object appears in the workspace.
2 Select the Instructions & Help tab.

3 To select a locale for the study documents, select the tab for the locale. The tabs are located
along the bottom of the workspace.

4 To create or edit study documents:
a  Type in the text area.

b Optionally, use the toolbar to format the appearance of the text. Additionally, you can use
HTML formatting characters. For more information, see Supported HTML formatting
tags (on page 244).

5 To delete study documents:
a  On the toolbar, click the Delete button.
or
Select all of the text, and press Delete.
A dialog box appears.
b Choose one of the following options:
e Delete the study documents for only the selected locale.

e Delete the study documents for all locales.
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To translate instructions and Help:

1

In the Project Explorert, select a study object (study design, study element, study event, form,
section, item, codelist, or codelist item).

The editor for the study object appears in the workspace.
Select the Instructions & Help tab.

To select a locale for the study documents, select the tab for the locale. The tabs are located
along the bottom of the workspace.

Optionally, copy and paste study documents from a locale for which the information is already
written.

Select the locale to which you want to translate.
Translate the study documents.

Optionally, use the toolbar to format the appearance of the text.

Viewing the parents of a linked section

You can view the parents of a form, section, item, codelist, or codelist item that:

You copied using the Copy > Link option.

You use on multiple parents.

To view the parents of a linked study object:

1 In the Project Explorer, select a study object, and confirm that a blue icon (@) appears in the
upper-left corner of the study object's icon.
Note: If the icon does not appear, the study object could be used multiple times in the study
but always on the same parent.
2 Right-click the study object, and select Show Parents.
The Show Parents dialog box appears.
3 Review the paths of the parent study objects in the current project.
The paths begin with the project name and work down; the last study object listed is the parent.
4 To copy paths to the Microsoft Windows clipboard:
a  To copy one path, select it and click Copy.
or
Click Copy All.
b  Paste the information in a text editor.
Notes:
.

Show Parents is available in both a study and library, but it lists only the parents in the current
project.

Show Parents is not available for a study object on a single parent that appears multiple times,
such as an item on a form that is used multiple times in a study.
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Designing fixed repeating sections

About fixed repeating sections

You might want to design a form that allows a user to enter the same piece of data multiple times for
the same item. For example, a user might need to record a subject's heart rate while the subject is
sitting and then standing, at specified time intervals after the subject receives a drug.

To do this, you can create a fixed repeating section in the Central Designer application. A fixed
repeating section includes items for which predefined values are configured by using codelists at
study design time, and cannot be modified at runtime. For the above example, the fixed repeating
section contains the following study objects:

Study object Type Description
TimePoint item Text, Integer, or The amount of time before or after a drug is
Float administered when data is collected.

Contains predefined values.

Time points codelist Text, Integer, or Codelist items for each required time point.
Float e Codelist item 1—Pre-dose
e Codelist item 2—15 minutes post dose
e Codelist item 3—30 minutes post dose
e Codelist item 4—45 minutes post dose

e Codelist item 5—60 minutes post dose

The codelist items are the predefined values for
the TimePoint item.

Position item Text, Integer, or The subject's position when the data is collected.
Float .
Contains predefined values.
Position codelist Text, Integer, or Codelist items for each required subject position:
Float

e Codelist item 1—Sitting
e Codelist item 2—Standing

The codelist items are the predefined values for
the Position item.

HeartRate item Any type, other than The subject's heart rate at each time point, for
Date each position.

Does not contain predefined values.

In the Edit Fixed Table dialog box for this example, you might create the following rows:

Row itmTime value itmPosition value itmHeartRate

1 Pre-dose Sitting
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Row itmTime value itmPosition value itmHeartRate
2 Pre-dose Standing

3 15 minutes post dose Sitting

4 15 minutes post dose Standing

5 30 minutes post dose Sitting

6 30 minutes post dose Standing BLANK

7 45 minutes post dose Sitting

8 45 minutes post dose Standing

9 60 minutes post dose BLANK

10 60 minutes post dose Standing

The following illustration shows the fixed repeating section in the form layout.

2 1

Form : form1 — g¢n-US

/" Deuggd ?1 Fues | Fude Thrplstes | Dats Series Summary | Gererdl | Coding | Instiuctions L Help |
Eckt Styies... | EdfText dfignCaption = Driectation= Cortrol Typew | Layouts= |ocsle= | Freview =

formi
secl ————
TimePaint Position | Heasl Rate
Fre-dose Sitting |
3 Pre-doge Standing |

15 minutes post dose |Sitting EI

15 minutes post duser Standing El

4 20 minutes post dose)|Sitting EI

5 3 minutes post dose [Standing
45 minutes post dose |Sitting I
45 munutes post dose |Standing EI

6 B0 minutes post dose |Sitling I

B0 munutes post dose | Standing EI

1—HeartRate item that does not contain predefined values.
2—Fixed TimePoint and Position items that contain predefined values.

3—TimePoint codelist item for the Pre-dose predefined value. Each TimePoint codelist item
contains two rows; each row corresponds to a Position codelist item.
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4—Position codelist with predefined Sitting and Standing values. These predefined values appear
five times in the fixed repeating section layout; each instance corresponds to a TimePoint
predefined value

5—Blank cell for an item in a non-fixed column.

6—Blank cell for an item in a fixed column.

As noted in the form layout screenshot, you can also specify a data point that you do not want data
for, but that appears in the fixed repeating section. In addition, in some cases, it might not make
sense for you to collect certain data points. To do this, when you create a fixed repeating section, you
locate the cell that corresponds to the data point, and set is as blank. In the annotated form preview,
a cell that corresponds to data that should not be collected is grayed out. In the target application,
data cannot be entered for that data point.

About writing rules for fixed repeating sections
When you create rules that use the study objects in fixed repeating sections, consider the following:

e For values in fixed columns:
®  You can create a rule that references a value in a fixed column.
e  You can create a rule to check the value in a fixed column.

¢ You cannot create a rule with a query, set value, or email action that affects a value in a fixed
column.

e For values in non-fixed columns:
e  You can create a rule that references a value in a non-fixed column.
e You can create a rule to check a value in a non-fixed column.

®  You can create a rule with a query, set value, or email action that affects a value in a non-
fixed column.

e For blank cells:
®  You can create a rule that references a blank cell in a fixed or non-fixed column.

®  You cannot create a rule with a query, set value, or email action that affects a blank cell in a
fixed or non-fixed column.

e  You can create a rule for a fixed repeating section to compare data between the rows of data in
the fixed repeating section.

For example, you can compare a subject's seated heart rate before receiving a drug to the
subject's seated heart rate 30 minutes after receiving a drug,.
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Creating and editing a fixed repeating section
To create a fixed repeating section:

1 Create a section.

2 In the Project Explorer, select the Forms and Transactions Explorer bar.

3 In the Study Forms folder, right-click a form, and select New Section.
The Object Name dialog box appears.

4 Fill in the fields as necessary, and click OK.

The section is created and appears in the Project Explorer, and the Design tab of the Section
Editor appears in the workspace.

5 In upper-right corner of the section editor, select the following checkboxes:
a  Repeating
b Fixed.

6  Add one or more items to the section.

7 In the Project Explorer, select a form or section, and select the Design tab.

8  On the toolbat, click Columns, and display the columns that you need in the grid, including
Codelist and Item Properties.

9 In the grid, create items on the form or section by typing values in each field. Press Tab to
advance to the next field and, when you have reached the end of a row, to the next item.

Your changes are saved after you move the cursor away from the row.

Note: To type extended ASCII characters in text fields, press ALT while entering the decimal
code for the character. You can also add HTML formatting characters (on page 244) to a
text field to control its appearance when deployed.

10 To modify the properties of an item:
a  In the Item Properties field, click Edit, or, on the toolbar, select Item Properties.
The Item Properties dialog box appears.

b Define the properties of the item (on page 379). The fields that appear in the dialog box
depend upon the type of item that you select. These properties are also available on the
Design tab for an item.

11 For each item that you want to define as a fixed item:
e Create a codelist (on page 124).

e  Create a codelist item (on page 120).
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To mark one or more items as fixed in a fixed repeating section:
1 In the <Fixed repeating section name> editor, do one of the following:
e In the upper-right corner, click the Fixed Table icon ()

e In the toolbar for the editor, click Fixed Table.

Note: If there is more than one fixed repeating section on the form, the Fixed Table
control in the toolbar for the editor is a drop-down list. If there is one fixed repeating
section on the form, the Fixed Table control is a button.

The Edit Fixed Table dialog box appears.
2 In the Define Fixed Columns section, select the items to mark as fixed.
A fixed item must:
e Bea top level item with no nested items.
e Be a text, integer, or float item.
e Have a control type of radio button or pull-down.

e Have a codelist and at least one codelist item defined.

Note: You cannot mark all items in a fixed repeating section as fixed.

3 Optionally, to view only fixed items in the fixed repeating section in the grid, deselect Show non-
fixed columns.

4 Click Add Row, or right-click any arrow in the grid and select Add Row to add a row to the grid.

5 Optionally, to indicate that you do not want a user to enter data for a particular cell, right-click
the cell and select Set as Blank.

The cell is grayed out, and when the study is deployed, the cell is disabled so that a user cannot
enter data for that control. You can set a cell as blank for fixed and non-fixed items.

6 To modify the rows, use the buttons on the right of the dialog box.
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Items and codelists

About items

An item is a study object used as a container for the collection of clinical data collected in a study.
You can design different types of items, depending on the type of information you want to collect.
By default, you can create the following types of items.

Additional item types might be available in your study if a library user has created and published
them in a library that your study project uses.

Item type Description

Blood pressure A specialized type of compound item used to collect blood pressure information

on a form.
Compound An item that has one or more child items that can have different data types.
Date time An item used to collect date and time information on a form.
Float An item used to collect numerical values with decimal points. You can also use a

float item to collect information for a question with a codelist.

Integer An item used to collect a numerical value without a decimal point. You can also
use an integer item to collect information for a question with a codelist. The value
entered in the InForm application must be between -2147483647 and
+2144830647.

Text An item used to collect alphanumeric information. You can also use a text item to
collect information for a question with a codelist.

Yes no A specialized type of integer item used to collect yes or no answers to questions. A
yes no item contains a predefined codelist with Yes and No options.

Note: After you create a yes no item, it is listed as an integer item in the Form
Editor and the Study Items Editor.

Conditional relationships between items

Conditional relationships between items make it possible to design items in which a user both selects
one or more options and provides additional information about the selected option or options. You
can use conditional relationships for collecting:

e Nested levels of multiple-choice data.

e User-entered information along with multiple-choice data, when you want to allow user-entered
information for more than one choice in a list.

You can use up to five levels of nesting for compound and conditional items.

Oracle® Health Sciences Central Designer 2.1 113



Chapter 3 Designing forms

114

You design an item that contains nested information by:

1 Creating an item for each level of nesting. The parent item must include a codelist.

2 Making the nested item conditional on one of the codelist items in the parent item. You specify
conditional relationships between items on the Design tab of the Form Editor.

For example, you can design an item that displays as a set of checkboxes nested within a radio group
and includes text fields in which a user can type other information not covered by the existing
options.

To design this item, you could create three items with codelists:
e Aninteger item for the Unknown/No/Yes options.

e Aninteger item for the family member options. The family member item is conditional on the Yes
option of the Unknown/No/Yes codelist.

e A textitem for the Other field. The text item is conditional on the Other option of the family
member codelist.

lllustration of conditional items

1—First item contains Unknown/No/Yes codelist.
2—Second item contains family members codelist.
3—In the family members codelist, the text field is associated with the Other, specify codelist item.

For more information, see Design tab of the Form Editor or Section Editor - Option
Descriptions (on page sg).

About codelists and codelist items

Codelists enable you to design items in which a user selects from multiple choices. A codelist is a
collection of code-label pairs that gather together the entry choices for an item. A code-label pair
consists of a single code (the value that is used for analysis) and a label (the value that is visible to
users). Hach code-label pair makes up a codelist item.

Certain properties of codelists and codelist items must be unique:
e Code of a codelist item—Must be unique within a codelist.
e Label of a codelist item—Must be unique within a codelist.
¢ RefName of a codelist or codelist item—Must be unique within study object type.

e Title of a codelist or codelist item—Must be unique within a codelist.
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You can include a codelist in the definition of a float, integer, or text item, and the Yes No item type
includes a predefined codelist that contains Yes and No options. When you create a codelist, specify
whether a study user must select only one option or can select multiple options.

Codelist data can appear as a drop-down list, as a set of radio buttons, or as a set of checkboxes. You
specify the formatting information when you generate the layout of the form or item containing the
codelist.

Codelists and conditional item relationships

If you want to design more complex items in which a user both selects one or more options and
provides additional information about the selected option or options, you can make an item
conditional on an option in a codelist. You can use conditional relationships for collecting:

e Nested levels of multiple-choice data.

e User-entered information along with multiple-choice data.

Items and units

When you create integer or float items, you can specify the base unit and one or more conversion
units in which users can enter data. The available units and their conversion calculations are stored in
the database. To specify additional units and conversion calculations ot to provide locale-specific
abbreviations, you must export the units file using the Central Designer Administrator application,
edit it, and import the file using the Central Designer Administrator application.

For more information, see Adding units and conversion calculations in the Administrator Guide.

Creating and editing an item

You create a study object (study design, study element, study event, form, section, item, codelist, and
codelist item) in a study or library. You can create a study object outside the hierarchy of a study or
library, but the study object is not deployed until you add it to a parent study object in a study or
library. To include a study object in the hierarchy of a study or library, add it to an existing parent in
the study or library.

Note: You can use an item only one time in any level of a particular study object hierarchy. For
example, you can use the same item in different sections of a form but not twice in the same
section of the form. In a single section, you can use the same item as a child item in two different
compound items. To use identical item definitions multiple times in a single form, section, or
compound item, copy the item as many times as you need, and use the copies.

To add one or more items to a form or section:

1 In the Project Explorer, select the Forms and Transactions Explorer bar.
In the Forms folder, select a form.

Select the Design tab.

S N A

On the toolbar, click Columns, and display the columns that you need in the grid, including
Codelist and ltem Properties.
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5 In the grid, create items on the form or section by typing values in each field. Press Tab to
advance to the next field and, when you have reached the end of a row, to the next item.

Your changes are added to the grid after you move the cursor away from the row but are not
saved in the database until you explicitly save them.

Note: To type extended ASCII characters in text fields, press ALT while entering the decimal
code for the character. You can also add HTML formatting characters (on page 244) to a
text field to control its appearance when deployed.

6 To modify the properties of an item:
a  In the Item Properties field, click Edit, or on the toolbar, select Item Properties.
The Item Properties dialog box appears.

b Define the properties of the item (on page 379). The fields that appear in the dialog box
depend upon the type of item that you select. These properties are also available on the
Design tab for an item.

To create an item outside the hierarchy of a study or library:

1 In the Project Explorer, select the Items Explorer bar.
2 Select the InForm Items folder.
The InForm Items editor appears.
3 On the toolbar, click New.
A drop-down list appears with a list of available item types.
4 Select the type on which to create the item.
5 Type the title, RefName, and description, and click OK.
The new item is added to the grid and to the container in the Project Explorer.

To add a codelist to an item:
1 In the Project Explorer, select the Forms and Transactions Explorer bar.
In the Forms folder, select the form or section that contains the item, and select the Design tab.

In the grid, select an integer, text, or float item.

E NS V)

Do one of the following:

e If the codelist already exists, select it from the drop-down list in the Codelist field.
e Create a codelist (on page 124) on the item.

T'o make an item conditional on a codelist selection within another item:

1 In the Project Explorer, select the Forms and Transactions Explorer bar.

In the Forms folder, select a form, and select the Design tab.

In the grid, select an item.

B N SN N\

In the Conditional On column, select the title of the item with which to create a conditional
relationship.
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5 In the Conditional Value column, select the Code and Label of the codelist item on which to make
the current item conditional.

For more information, see Conditional relationships between items (on page 113).

To mark an item as a special InForm field:
1 In the Project Explorer, select the Items Explorer bar.
2 In the InForm Items folder, select an item.

3 Open the Properties Browser.

Note: If the Properties Browser is not visible, open the View menu and select Properties.

4 From the Special Fields drop-down list, select the type of special field.

To mark an item as critical for source verification:

You can indicate that an item is critical for source verification in the InForm application by setting its

SDV Ciritical property.

Note: All items that are marked SDV Critical are automatically marked SDV Required.

1 In the Project Explorer, select the Items Explorer bar.
2 In the InForm Items folder, select an item.
The Item Editor appears.

3 Select the Properties Browser.

Note: If the Properties Browser is not visible, select View > Properties.

4 From the SDV Critical drop-down list, select True, and press Enter.

To mark an item as collapsible:

You can indicate that an item is collapsible, meaning that it does not appear in the InForm
application until specified conditions are met, by setting its Collapsible property.

Note: The Collapsible property is only available for child items that are conditional on parent
items.

1 In the Project Explorer, select the Items Explorer bar.
2 In the InForm Items folder, select an item.
The Item Editor appears.

3 Select the Properties Browser.

Note: If the Properties Browser is not visible, select View > Properties.

4 From the Collapsible drop-down list, select True, and press Enter.
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To mark an item as containing Personal/Protected Health Information (PHI):

You can indicate that an item contains Personal/Protected Health Information (PHI) so that, during
rule design and validation, the Central Designer application can verify that no PHI is transmitted
through email in the InForm application because of a rule with an email action. For more
information, see Item properties (on page 477).

1
2

4

In the Project Explorer, select the ltems Explorer bar.
In the InForm Items folder, select an item.
The Item Editor appears.

Select the Properties Browser.

Note: If the Properties Browser is not visible, select View > Properties.

From the PHI drop-down list, select True, and press Enter.

To edit the properties of an item in a form:

1

2
3
4

In the Project Explorer, select the Forms and Transactions Explorer bar.

In the Forms folder, select a form, and select the Design tab.

In the grid, select an item.

In the Item Properties field, click Edit, or, on the toolbar, select Item Properties.
The Item Properties dialog box appears.

Define the properties of the item (on page 379). The fields that appear in the dialog box
depend upon the type of item that you select. These properties are also available on the Design
tab for an item.

To edit the properties of an item in the Properties Browser:

1
2
3

In the Project Explorer, select the Items Explorer bar.
In the InForm Items folder, select an item.

Select the Properties Browser.

Note: If the Properties Browser is not visible, select View > Properties.

Edit the properties of the item (on page 477). After changing each property, press Enter, or tab
to the next property.

Note: The values of editable properties appear in bold, black text, and the values of non-
editable properties appear in gray text.
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Default maximum input field lengths:

When you create an item, you specify the length of the input field. The Central Designer application
supports the following maximum field lengths as a default.

Type of input field Maximum length

Text item 2000
Integer item 10
Float item 18
Float precision 10

Adding a child item to a compound item

Compound items collect data in two or more data fields. The items that make up a compound item
are its child items. The child items of a compound item can be different data types; for example, you
can create a compound item with a date time and a text item.

Note: A blood pressure item is a specialized type of compound item, collecting a blood pressure
measurement in two child items called Systolic Variable and Diastolic Variable.

To create and add a child item to a compound item:

1 In the Project Explorer, select the Items Explorer bar.
2 In the InForm ltems folder, select a compound item.
The Design tab of the Item Editor appears in the workspace.

3 In the Child Iltems section, complete a row in the Compound Item grid for each child item in the
compound item:

a  Type the Question and Title.
b  Select the Type.
4 After you complete each row, and after the final row, press Enter, or tab or click in the next row.
The child item is added to the compound item.
To add an existing child item to a compound item:
1 In the Project Explorer, select the Items Explorer bar.
2 In the InForm Items folder, select a compound item.
The Design tab of the Item Editor appears in the workspace.

3 Drag an item from the Project Explorer, and drop it onto the Child ltems grid.
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Reordering an item in a form or section
1 In the Project Explorer, select the Forms and Transactions Explorer bar.
2 In the Forms folder, select the form or section containing the item to reorder.
The Design tab of the Form Editor opens.

3 In the leftmost column of the grid, drag and drop the button of the item to move onto the
button of the item to appear below it.

The items are reordered so that the item you moved appears above the item you dropped it on.

Specifying column heading text for an item in a repeating form or section

If an item is included in a repeating form or section, you must specify a value to be used as the
column heading for the item in the layout of the form or section. Specify this value in the Short
Question property of the item.

Note: If your InForm installation includes the Reporting and Analysis module, do not use the
words Subject Number or Subject Initials as the value of the Short Question property for an item
in a repeating form or section. Subject Number and Subject Initials are reserved terms in the
Reporting and Analysis module. Using the words Subject Number or Subject Initials as a column
heading in a repeating form or itemset definition causes an error when you generate the clinical
reporting model. If the Question property of an item in a repeating form or section is Subject
Number or Subject Initials, use a different formulation for the Short Question, (for example,
Subject Num or Subject Init).

1 Create the item (on page 115).

2 Select the Properties Browser.

Note: If the Properties Browser is not visible, select View > Properties.
3 In the Properties Browser, type the column heading text in the Short Question property.
4 Press Enter.

Reserved words for an item question or short question

The reserved words below cannot be used for the following item properties:

e Short question.

e Default question or Question if a Short question is not provided, or is populated with a reserved
word.

If you specify a reserved word for the item Default question or Question you must provide a Short
question that is not a reserved word, or the clinical model in the Reporting and Analysis module fails
to generate.
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To design an item for which a reserved word appears as the question on the form in the InForm
application, specify the following:

¢ Question—Reserved word such as Subject Number.

e Default question or Short question—A word that is not on the reserved words list, such as
Subj Number.

In this example, Subject Number appears as the question on the form, and Subj Number appears in
the clinical model in the Reporting and Analysis module and as the itemset column header on the
form in the InForm application. In addition, the clinical model is successfully generated.

e Subject Initials

e Subject Number

e Visit Mnemonic

e Form Mnemonic

e Site Mnemonic

e Visit Index

e Visit Order

e DOV

e Decleted Form

e CREATEDBYUSERID
e CREATEDDATETIME
e MODIFIEDBYUSERID
e MODIFIEDDATETIME
e Site Name

e Site Country

e SUBJECTID

e SITEID

e SUBJECTVISITID

e VISITID

e VISITINDEX

e FORMID

e FORMREV

e FORMINDEX

e CD_COUNT
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About key items in a repeating form or section

In repeating forms and repeating sections, you can identify certain items as key items. In the InForm
application, key items are used to:

e Simplify navigation to a specific instance of a repeating form. The values of key items appear in a
drop-down list in the summary view of the repeating form, and users can navigate to a specific
instance of the form by clicking the key item values for that instance.

e Verify that the values of certain items are unique among instances of a repeating form or an
itemset.

Key items for navigating to an instance of a repeating form

When you identify an item as a key item in a repeating form, regardless of whether it is used to
establish data uniqueness, the value of the item appears in a drop-down list in the summary view of
the repeating form in the InForm application. When an InForm user selects a specific set of key item
values, the instance of the repeating form containing those key item values appears.

Note: Key items in a repeating section must always be defined as having individual or group
uniqueness and are not used as navigation tools for instances of itemsets in the InForm
application.

Unique keys

Key items can have individual or group uniqueness:

e Ifkey items are defined with ndividual uniqueness, an InForm user cannot add an instance of a
repeating form or itemset in which the value of any key item is identical to the value of that item
in another instance. For example, if the DATE and PROCEDURE items are defined as
individually unique keys in a repeating form or section, the following table shows how the
DATE and PROCEDURE items are evaluated when a user attempts to add new instances.

DATE value PROCEDURE value Result when data is
submitted

May 1, 2009 Hematocrit Instance or row added

May 1, 2009 Hemoglobin Instance or row rejected

June 14, 2009 Hematocrit Instance or row rejected

June 15, 2009 Platelet count Instance or row added

Note: A set of key items for a repeating form can include both items that are individually
unique and items that appear in the drop-down list for navigation but are not used to
enforce uniqueness. The key items can come from the repeating form or from a non-
repeating section in the form.

e If key items are defined with group uniqueness, they make up a composite key. An InForm user
cannot add an instance of a repeating form or itemset in which the values of a// of the items in
the composite key are the same as the values of all of the composite key items in another
instance. For example, if the DATE and PROCEDURE items are defined as group unique keys
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in a repeating form or section, the following table shows how the DATE and PROCEDURE
items are evaluated when a user attempts to add new instances.

DATE value PROCEDURE value Result when data is
submitted

May 1, 2009 Hematocrit Instance or row added

May 1, 2009 Hemoglobin Instance or row added

June 14, 2009 Hematocrit Instance or row added

May 1, 2009 Hemoglobin Instance or row rejected

Note: If a group of key items is defined with group uniqueness, no other items in the
repeating form or section can be defined as non-unique key items. Only the items that are
defined with group uniqueness appear in the drop-down list of a repeating form.

Key item requirements

A key item must:

e Bein a repeating section, if the key is for an itemset.

e Bein a repeating form or in a non-repeating section of the repeating form, if the key is for a
repeating form.

A key item must not:

e Be a hidden item.

e Bea compound item.

e Be formatted as a checkbox.

e Have a caption that is aligned at the top or bottom of the control.

e Bein a nested control structure, unless it is at the top of the hierarchy and conforms to other
eligibility requirements.

For example, consider an item called Continuing in an Adverse Events form. The Continuing
item has a YesNo codelist formatted as radio buttons, and the No codelist item has a conditional
date time item called End Date. In this example, the Continuing item can be a key item, but the
End Date item cannot.

Creating keys in a repeating form or section
1 In the Project Explorer, select the Forms and Transactions Explorer bar.
2 Select a repeating form or section, and select the Design tab.
3 Right-click the row of an item, and select Keys.

The Keys dialog box appears.
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In the Data uniqueness for selected keys section, select one of the following:

e None—Key items appear in a drop-down list in the summary view of a repeating form as
navigation aids. The key items are not used to enforce uniqueness of key values across
instances of the repeating form.

e Individual—Each key item must be unique across all instances of the repeating form or
itemset in the InForm application.

e  Group—The combination of all key items evaluated together must be unique across all
instances of the repeating form or itemset in the InForm application.

In the Key selection section, move the key items from the Items available as keys list to the
Selected keys list.

If you are creating keys for a repeating form, and you selected Individual in the previous step,
select the Unique checkbox for each item to designate as a unique key. (In a repeating section, the
Unique checkbox is selected and disabled for all selected key items.)

Note: A set of key items for a repeating form can include both items that are individually
unique and items that appear in the drop-down list for navigation but are not used to
enforce uniqueness. The key items can come from the repeating form or from a non-
repeating section in the form.

To change the order in which the items appear in the InForm application in the drop-down
summary list of a repeating form, select an item and click the Move Up or Move Down button.
Repeat this step for each item you want to move.

Click OK.

Creating and editing a codelist

You create a study object (study design, study element, study event, form, section, item, codelist, and
codelist item) in a study or library. You can create a study object outside the hierarchy of a study or
library, but the study object is not deployed until you add it to a parent study object in a study or
library. To include a study object in the hierarchy of a study or libratry, add it to an existing parent in
the study or library.

To add a codelist to an item:

1

2
3
4

124

In the Project Explorer, select the Forms and Transactions Explorer bar.

In the Forms folder, select the form or section that contains the item, and select the Design tab.
In the grid, select an integer, text, or float item.

Do one of the following:

e If the codelist already exists, select it from the drop-down list in the Codelist field.

e Create a codelist (on page 124) on the item.
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To create a codelist outside the hierarchy of a study or library:

1
2

In the Project Explorer, select the Codelists Explorer bar.

Select the Codelists folder.

The Codelists Editor appears.

In the toolbar, click New.

The Object Name dialog box appears.

Type a title, RefName, and description, and click OK.

The codelist appears in the grid.

Double-click the codelist.

The codelist is selected in the Project Explorer, and the Codelist Editor appears.
To add codelist items:

a In the rows and columns of the grid, type information about each codelist item to include in
the codelist.

b After you complete each row, and after the final row, press Enter, or tab to the next row.

To edit the properties of a codelist in the Properties Browser:

1
2
3

In the Project Explorer, select the Codelists Explorer bar.
In the Codelists folder, select a codelist.

Select the Properties Browser.

Note: If the Properties Browser is not visible, select View > Properties.

Edit the properties of the codelist (on page 472). After changing each property, press Enter, or
tab to the next property.

Note: The values of editable properties appear in bold, black text, and the values of non-
editable properties appear in gray text.
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Creating and editing a codelist item
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You create a study object (study design, study element, study event, form, section, item, codelist, and
codelist item) in a study or library. You can create a study object outside the hierarchy of a study or
library, but the study object is not deployed until you add it to a parent study object in a study or
library. To include a study object in the hierarchy of a study or library, add it to an existing parent in
the study or library.

To add codelist items to a codelist:
1 In the Project Explorer, select the Codelists Explorer bar.
2 In the Codelists folder, select a codelist.

The Codelist Editor appears in the workspace.

3 In the rows and columns of the grid, type information about each codelist item to include in the
codelist.

4 After you complete each row, and after the final row, press Enter, or tab to the next row.
To edit the properties of a codelist item in the Properties Browser:

1 In the Project Explorer, select the Codelists Explorer bar.

2 In the Codelist Items folder, select a codelist item.

3 Select the Properties Browser.

Note: If the Properties Browser is not visible, select View > Properties.

~

Edit the properties of the codelist item (on page 473). After changing each property, press
Enter, or tab to the next property.

Note: The values of editable properties appear in bold, black text, and the values of non-
editable properties appear in gray text.
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About rules

The two classes of rules are:

¢ Data-entry rule—A rule that checks whether data is valid or that sets the value of an item based
on a calculation. You can create a data-entry rule for study designs, study elements, study events,
forms, and items.

e  Workflow rules and global conditions

o Workflow rule—A logical construct that tests data values to determine the study element,
study event, or form to which a subject progresses next.

You can create a workflow rule for a study element, study event, or form only.

¢ Global condition—A logical construct that, when applied to a study object, determines
whether the study object will appear for a particular subject.

About data-entry rules

Characteristic Description

Creating You create the following rules in the Rules tab (on page 137):
e An intrinsic rule (on page 150).
e A rule without a function (on page 154).

e Arule using a function (on page 160).

About A data-entry rule is a rule that checks whether data is valid or that sets the value
of an item based on a calculation. Different actions occur as a result of the
evaluation of the rule expression. For example, an email can be sent or a query
can be created.

A data-entry rule is part of a study object and not a separate component that is
attached to the study object. Rules can be part of study designs, study elements,
study events, forms, and items.

Because rules are part of study objects, when you reuse a study object from the
library, you reuse the rules that are defined on that study object.

e When a rule is part of a study object template or type, the rule is
automatically part of all study objects created from the template or type.

e When a rule is part of a study object and the study object is copied into
another project, the rule is copied with the study object.

e Tor valid data-entry rules, if you modify the RefName of a study object
referenced by the rule, the data-entry rule is automatically updated with the
change.

Note: Modifying the RefName of a study object from within the rule
expression prevents the study object from being updated in rules that
reference the study object.
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Characteristic Description

Types You can create the following types of rules.

e Intrinsic rules (on page 130).
e Calculation rules (on page 134).
e Constraint rules (on page 132).

Depending on the rule, it might be better to use an intrinsic rule, an
expression rule, or a function (on page 130).

Structure All data-entry rules consist of three parts.
e Precondition

The event that causes a rule to execute, such as On Demand (Batch
Mode) or Form Submission.

e Expression
The expression (on page 140) that is evaluated.
e Action

The action or actions to take depending on the result of evaluating the rule
expression, such as create a query, store a value, or send an email message.

Note: The action clause is similar to an If statement in C++, C#, or Java.

Scope (on page A rule that is part of a study object can refer only to:

138)
e The study object and its children.

e Properties and values of the study object and its children.

This concept is called scope.

Running order ~ You cannot set the order in which data-entry rules are run.

Rule deployment Rules created with two or more different actions are deployed to the InForm
application as multiple rules. For example, a rule might call for:

e A query to be sent.
e An email message to be sent.
e A value to be set.

A different rule is created in the InForm application for each type of action. In
the previous example, three rules are created:

e One rule sends a query.
e One rule sends an email message.

o  One rule sets a value.
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Characteristic Description

Deciding among Oracle recommends that you do not use hard-coded values or hard-coded
hard-coded constants in rules, as the rule might be less reusable. Consider using constants or
values, data mappings instead. A data mapping is another name for an item that has
constants, and ~ been added to a data series and has a global scope for the purposes of rule

data mappings ~ creation.

If the value of an item is constant for every subject in a study, such as lab normal
ranges, use constants. For example, if you expect blood pressure ranges to be
uniform for all subjects in a study, you can use a constant for blood pressure.

If you want to capture dynamic values, such as gender, which varies from subject
to subject, use data mappings. For example, acceptable hemoglobin ranges differ
for men and women, so it makes more sense to use data mappings for these
values in a rule.

Testing rules You create test cases in the Rule Test Cases dialog box to test data-entry rules,
workflow rules, and global conditions before deploying a study. Depending on
the rule, you might create several or many test cases.

You can create test cases either after writing each rule or after all rules are
finished.

To make sure that a rule is written correctly, consider writing and running a
single test case for it, so you do not write many test cases for a rule that needs to

be modified.
Naming You are not required to use a naming convention for rules, but conventions can
conventions help you distinguish one type of rule from another and avoid duplicate

RefNames. If you want to adopt a naming convention, consider prefixing rules
with the following:

e wr - workflow rule
e gc - global conditions

e rul - data-entry rules (for example, rulDMConsDtCompare)

Intrinsic rules

Characteristic Description

Definition An intrinsic rule is a constraint rule or calculation rule based on a
predefined rule template. Rule templates can be created for constraint rules
and calculation rules. If no rule templates have been defined for the
selected study object, then you cannot create an intrinsic rule for the study
object.

Study objects that can e  Forms.

have intrinsic rules
e Form templates.
e Jtems.

e Item templates and types.
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Characteristic Description

Programming e To create intrinsic rules—Programming knowledge is not required.
expetrience necessary

e To create rule templates—Programming knowledge is required.

What to define The rule expression is defined by the rule template. You must define:
e When to evaluate the rule.
e Parameters for the rule template.

If the rule template contains parameters, you indicate the source of the
values to be substituted in the parameter with:

®  Numeric values.

®  Values of study objects and their rule model properties.

= Constants.

® Another function.

®  Data mapping study objects and their rule model properties.

e The action to take after the rule executes.

Example An intrinsic rule evaluates whether a weight value falls within a range that
you specify using parameters.

A programmer writes the rule expression in a rule template, and a non-
programmer provides the following information to create the rule:

e When to evaluate the trule—On form submission.

e Parameters for the rule template—Provide the range. In this case, it
is 45 to 125 kilograms.

e The action to take after the rule executes—When the value is false,
a query is issued. You can create additional actions to occur under
different circumstances, such as an action to take when the value is
true.

The following information appears in the Rule Summary section:

evaluate on Form Submission
value = Is the item between {MinValue:45} and {MaxValue:125}
when value is false

issue query: Out of range

Alternatively, you can use a constraint rule (on page 132) to create this
rule.
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Constraint rules

Characteristic Description

Definition A constraint rule checks whether data is valid.

Note: There is no real difference between a calculation rule and a constraint
rule. Each offers different starting points in the Rule Wizard; the options on
the Actions tab change depending on the rule type that you select.

Study objects that e  Study designs

can have constraint
e Study elements

rules
e  Study events
e Forms
e Items
Programming Creating a constraint rule is comparable to writing formulas in the
experience Microsoft Excel spreadsheet software.
necessary
What to define You must define:

e  When to evaluate the rule.
e The rule expression.

For calculation and constraint rules, you can use the following to define
the rule expression:

= Study objects and their rule model properties.

® Functions. If you use a function, you define values for its
parameters using numeric values, values of study objects and their
rule model properties, constants, and data mapping study objects
and their rule model properties.

= Constants.
=  Data mapping study objects and their rule model properties.

e The action to take after the rule executes.
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Characteristic Description

Example A constraint rule determines if a calculated BMI value is below the expected
value of 30. You create the rule on the form that contains the weight and
height items.

(without a function)

You provide the following information to create the rule:
¢  When to evaluate the rule—On form submission.

e The rule expression—To create the rule expression, which calculates
body mass index, either drag the weight and height items from the Data
tab to the Expression workspace, or type the expression.

e The action to take after the rule executes—You specify the
constraint in the action. When the BMI is below 30, an email is sent.

The following information appears in the Rule Summary section:
evaluate on Form Submission

value = this.weight / (this.height)*(this.height)
when value < 30
send email: Subject has reached target BMI.
You could create the rule with a function, as described in the next example,
or with a rule template (on page 130).

Example A constraint rule uses a function (_CalculateBMI) and determines if a
calculated BMI value is below the expected value of 30. You create the rule

with a function . . S
( ) on the form that contains the weight and height items.

A programmer creates the function, and a non-programmer provides the
following information to create the rule:

e When to evaluate the rule—On form submission.

e The rule expression—After you drag the function to the Expression
workspace, the Invoke Function dialog box appears, and you can
provide values for the parameters. In this case, you provide the weight
and height items as parameters.

e The action to take after the rule executes—When the BMI is below
30, an email is sent.

The following information appears in the Rule Summary section:

evaluate on Form Submission
value = _CalculateBMI(this.height.value, this.weight.value)
when value < 30

send email: Subject has reached target BMI.

You could create the rule without a function, as described in the previous
example, or with a rule template. For more information, see Intrinsic rules
(on page 130).
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Calculation rules

Characteristic Description

Definition A calculation rule sets the value of an item based on a calculation.

Note: There is no real difference between a calculation rule and a constraint
rule. Each offers different starting points in the Rule Wizard; the options on
the Actions tab change depending on the rule type that you select.

Study objects that e  Study designs

can have calculation
e Study elements

rules
e  Study events
e Forms
e Items
Programming Creating a calculation rule is comparable to writing formulas in the
experience Microsoft Excel spreadsheet software.
necessary
What to define You must define:

e  When to evaluate the rule.
e The rule expression.

For calculation and constraint rules, you can use the following to define
the rule expression:

= Study objects and their rule model properties.

® Functions. If you use a function, you define values for its
parameters using numeric values, values of study objects and their
rule model properties, constants, and data mapping study objects
and their rule model properties.

= Constants.
=  Data mapping study objects and their rule model properties.

e The action to take after the rule executes.
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Characteristic Description

Example A calculation rule calculates BMI using height and weight values with
. . RefNames of HT and WT. You create the rule on the form that contains
(without a function) the it
e items.

You provide the following information to create the rule:
¢  When to evaluate the rule—On form submission.

e The rule expression—The rule expression divides the weight value by
the height value squared.

e The action to take after the rule executes—The rule calculates BMI
and stores the value in the BMI field.

The following information appears in the Rule Summary section:

evaluate on Form Submission
value = this.WT.Value / (this. HT.Value * this. HT.Value)
always

set this.BMI.Value = value

You could create the rule with a function, as described in the next example.

Example A calculation rule uses a function (_BMI) to calculate BMI from height and
weight values with RefNames of HT and WT. You create the rule on the

with a function . .
( ) form that contains the items.

A programmer creates the function, and a non-programmer provides the
following information to create the rule:

e When to evaluate the rule—On form submission.

e The rule expression—After you drag the function to the Expression
workspace, the Invoke Function dialog box appears, and you can
provide values for the parameters. In this case, you provide the weight
and height items as parameters.

e The action to take after the rule executes—The rule calculates BMI
and stores the value in the BMI field.

The following information appears in the Rule Summary section:

evaluate on Form Submission
value = _BMI(this.HT.Value,this.WT.Value)
always

set this.BMI.Value = value

You could create the rule without a function, as described in the previous
example.
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When to use intrinsic rules, expression rules, and functions

The following table helps you to decide whether to use an intrinsic rule, expression rule, or a rule
with a function. The table also provides guidance about whether rule developer or programming
skills are required to create the rule. In many cases, form developers are able to create rules.

Rule When to use it

Intrinsic rule

rule template.

Who can create it

Intrinsic rules are most helpful for simple Anyone who can write a logical
functionality that is already defined in a

expression. Typically, form
designers are able to create intrinsic
rules.

Expression rule

(constraint or

calculation rule)
an expression rule.

If the functionality of a rule can be
created in a rule expression and is not
already defined in a rule template, create

Expression rules are more complex
than intrinsic rules. However, many
form designers are able to create
expression rules.

Function

If the functionality of a rule is too

A user with NET skills.

complex for a rule expression and cannot
be created using logical operators, the

rule requires a function. If the

functionality is not available in an existing
function, the function must be created.
Functions are built outside of the Central

Designer application in a NET

environment.

Rule collaboration

Some tasks for rule creation require programming knowledge, while others require some or no

programming knowledge.

Skill level Experience Typical tasks
Programmer Ability to program in a e Creates functions.
NET language (for
example, C#) and create e  (reates complex rule templates.
NET assemblies.
Some e Understanding of C# e  Creates calculation and constraint rules and
programming ot similar (for specifies:
kill
SIS example, ] ava, G, or = When the rule fires.
C++) expression
syntax. ® The action to take.

e Ability to incorporate
functions in
expressions.

= A simple rule expression.

Creates less-complex rule templates, with or
without functions.

Creates constants.

Checks rule syntax.

Oracle® Health Sciences Central Designer 2.1



InForm Design Guide

Skill level Experience Typical tasks
No programming None. e  Creates intrinsic rules and specifies:
expetrience

= When the rule fires.
= What action to take.
= The parameters of the rule template.

e Checks rule syntax.

Disabled rules

To deploy a study without validating data-entry rules, workflow rules, or global conditions, you can
disable the rules in the Central Designer application. Disabled rules are not deployed to the InForm
application. This functionality allows you to more easily perform testing for a study during a
development process in which forms and rules are being developed collaboratively by different users,
by viewing the study in the InForm application, without having to validate rules. Disabling a rule
does not prohibit you from performing rule-related tasks, such as editing the rule, and creating and
running test cases for the rule. When you run validation, a message appears, listing the disabled rules
for the study.

Disabled rules are:

e Not validated.

e  Excluded from the deployment package.

Note: You can successfully run a test case for a single disabled rule. However, if you run more
than one rule at a time, the Central Designer application will not run the test cases for any
disabled rules.

Note: Oracle recommends that you disable rules and workflows only while developing a study.
Use the InForm application to disable a rule on a live study.

Rules tab

The Rules tab lists all the rules that are part of the selected study object. The tab can also display the
rules on each child study object of the selected study object.

When a rule is selected in the Rules tab, the Rule Summary at the bottom of the tab shows a
structured specification of the rule.

The Rules tab is part of the editors for study designs, study elements, study events, forms, sections,
and items. In the Rules tab, you can view, search, and manage rules at the study object level. As in
most grids, you can filter and sort the columns.

For more information, see Rules tab - Option descriptions (on page 423).

Oracle® Health Sciences Central Designer 2.1 137



Chapter 4 Designing rules

Rule design considerations

Rule scope

About scope

A rule that is part of a study object can refer only to:

e The study object and its children.

e Properties and values of the study object and its children.

This concept is called scope.

Child items of a compound item

The child items of a compound item are in the scope of the compound item.
Study objects that are outside the scope of a rule

If a study object falls outside the scope of a rule, you have the following options:

e Create the rule on a study object that is higher in the hierarchy and that has the necessary study
object in its scope.

e Move the necessary study object within the scope of the study object on which you create the
rule.

e Add the study object to a data series. Study objects that are part of mappings can be included in
any rule in a study.

For more information, see:
e Mappings for rule creation (on page 195).
®  Rule mappings (on page 208).
Tips
e To allow for reuse, create data-entry rules on the lowest-level study object that is reasonable

based on scope requirements. For example, if an item requires a range check, create the range
check on the item, not on the form that contains the item.

e Do not create all rules on the study design. Although all study objects in the study are in scope,
you cannot reuse the rules because you cannot reuse study designs.

e If one or more study objects are outside the scope of a study object, Oracle recommends
creating the rule on a higher-level study object that has all required study objects in its scope.

If you choose this option, the data-entry rule might be less likely to be reused because it is
created on a study object that might not be reused in many other studies, but you are no longer
limited by the scope of a particular study object.

e As carly as possible, plan the study object on which every rule will be created.

For example, if a study event contains two forms, and you have a rule that requires data from
both forms, the scope of the rule will allow you to create the rule on the study event or a higher
study object.
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Rules and calculated fields

To write a rule that sets a value and sends an email, program the edit check in two separate rules, one
to perform the calculation and another to contain the email action.

For example, consider the scenario where a rule should send an Initial email when a Serious Adverse
Event has occurred and should also send a Follow-up email when subsequent changes are made to
the Adverse Event form after the initial email has been sent.

In this scenatio, you should create two rules:

e Rule 1: Calculate the value of a hidden item that stores the date the Initial email versus Follow-
up email needs to be sent.

e Rule 2: Create an explicit trigger dependency on this hidden item, and specify an action to send
email based on its value (Initial or Follow-Up).
About overriding Screening and Enrollment failures

To design a rule that causes a subject to fail Screening and Enrollment in the InForm application:

e  Create a rule on the Screening and Enrollment form or any of its child study objects (such as an
item on the form).

e Add a query action to the rule.

When a subject fails Screening and Enrollment, an InForm user with the appropriate rights can
override the failure if the study is configured to permit screening and enrollment overrides.
Rules with multiple actions

You can create a rule with multiple actions, with some exceptions.

For a rule, you can create:

e Multiple calculation actions using the Set Value Action dialog box.
e Multiple query actions, as long as the queries are on the same item.
e A combination of the previous two.

You cannot create multiple query actions if the queries are on different items.

Note: Multiple query actions appear as additional lines in the Rules report.

Rules on repeating study objects

When you create a rule on a repeating study object, and data is entered or updated in the InForm
application:

e The rule executes only on the instance of the itemset, repeating form, or repeating visit where

the data changes. It does not execute on all instances of the study object.

e The rule action (such as issuing a query) occurs only on the instance of the itemset, repeating
form, or repeating visit where the data changes, not on all instances.

However, if the rule has a dependency on another study object, and data is entered or changed on
the other study object, the InForm application executes the rule against all instances of the itemset,
repeating form, or repeating visit.
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About copying and moving data-entry rules

You can copy and paste a data-entry rule or move a data-entry rule.

e Copy and paste a data-entry rule.

When you copy and paste a data-entry rule, a new instance of the data-entry rule is created. The

copy of the data-entry rule has:

e A RefName in the following format:

e [Original rule RefName]_[Number to uniquely identify the copied rule]
For example, if you copy a data-entry rule with the RefName chkDOV, the RefName
for the copied rule is chkDOV_1. The appended number is incremented with each
subsequent copy of the rule so that each rule has a unique RefName.
Note: For library rules, a data-entry rule RefName must only be unique among
sibling rules with the same parent object.

e New instances of rule test cases associated with the original rule.

On a copied or moved data-entry rule, the Central Designer app deletes the test cases and does

not modify the rule expression or action parameters. When you copy or move a rule, you must

edit the rule as necessary and create new test cases.
¢ Move a data-entry rule to another study object, using the cut and paste functionality.

When you move a data-entry rule to another study object using the cut and paste functionality, a

new instance of the data-entry rule is 7o created. The following occurs:

e In the Rules tab, the data-entry rule is grayed out.

e When you paste the data-entry rule to a new study object, the data-entry rule is moved from
the original study object to the target study object. The Central Designer application does
not create a new instance of the rule. The RefName and ID for the rule remain unchanged.

Note: The cut and paste functionality for moving a data-entry rule from the Rules tab
is different behavior than using the cut and paste functionality for study objects in the
Project Explorer.

Notes:

You cannot copy or move rule templates, workflow rules, or global conditions. You can only
copy or move intrinsic rules to study objects for which the rule template (on which the intrinsic
rule is based) is defined. However, a rule that is based on a function might not work as expected
if you move or copy and paste the rule onto a study object with a rule that is based on a function
with the same name and parameters but with a different expression.

If you copy or cut a data-entry rule with rule test cases, the test cases are not copied with the
rule.

If you move a data-entry rule, rename any type of rule, or rewrite a rule so that its dependencies
change, and then install a deployment package over an existing study, you must manually remove
old rule attachments from the InForm application. If you do not change the name of the rule
and the study contains old attachments, the Studylnstaller.log file lists warnings about them.
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About locking data-entry rules, workflow rules, and global conditions

You lock study objects and rules, including data-entry rules, workflow rules, and global conditions,
independently of each other. Only the user who holds the lock can modify a data-entry rule,
workflow rule, or global condition. The following types of locks are available:

¢ An automatic lock, also known as an implicit lock, is applied to a rule when you modify it and
is released when you cancel or close without saving or when you save the study object or the
project.

e A requested lock, also known as an explicit lock, is applied to a rule when you explicitly lock it
and is released only when you unlock the rule. You might request a lock if you plan to work on a
rule for an extended period of time.

Note: A lock icon is red if someone else holds the lock and green if you hold the lock. To view
details about the lock, including the person who holds it, point to the lock icon.

About workflow rules and global conditions

Workflow rules
Definition

A workflow rule is a logical construct that tests data values to determine the study element, study
event, or form to which a subject progresses next.

Example

For example, a workflow rule on a group of lab values could determine whether a subject branches
to a set of extended visits or to a termination Vvisit.

when valug iz true

Extended

when valfie iz falze
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When you deploy a study to the InForm application, both study workflow branches that follow the
rule are dynamic; no study objects in the workflow that come after the rule appear in the study until
activated by the rule. When the workflow in the previous example is deployed, the Termination study
event and all of the study events in the Extended study element do not exist until the ExtRule is
executed. If the rule evaluates to true, the visits in the Extended study element appear in the Case
Book, and if the rule evaluates to false, the Termination visit appears in the Case Book.

Workflows and workflow rules

A workflow rule is part of the workflow in which it is created. If you want to use the logic of a
workflow rule in multiple workflows, you must create it in each workflow separately.

For valid workflow rules, if you modify the RefName of a study object referenced by the rule, the
workflow rule is updated with the change.

Note: Modifying a study object RefName from within the workflow rule expression prevents the
study object from being updated in rules that reference the study object.

Where to define
You can define workflow rules in the Workflow Diagram and Workflow Grid tabs.
Naming conventions

You are not required to use a naming convention for rules, but it can help you distinguish one type
of rule from another. If you want to adopt a naming convention, consider prefixing workflow rules
with wr and global conditions with gc to differentiate them from data-entry rules.

Deployment

Workflow rules and global conditions are deployed to the InForm application as trigger
dependencies.

Global conditions

A global condition is a logical construct that, when applied to a study object, determines whether the
study object will appear for a particular subject. You can use a global condition instead of a workflow
rule if, for example, multiple workflows depend upon the value of the same observation.

Using a global condition in a study workflow involves two steps:

1  Creating the global condition and its expression. For more information, see Creating a global
condition (on page 172).

2 Assigning the global condition by associating it with a study object and specifying how its
outcome affects the workflow. For more information, see Assigning and removing a global
condition (on page 173).
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When you create a global condition, you specify the system with which you will use it.
You can assign an InForm global condition to any:

e Study element

e  Study event

e Form

Example

In the following example, a global condition checks whether the subject is female, based on the
Gender item in the Demographics form. If the condition is true, the Pregnancy form is presented.
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Global condition: Is subject female?
(this.Demographics.Gender.Value == this.Demographics.Gender.GenderCodeList.Female)

When you deploy a study to the InForm application, only the study object assigned to the global
condition is dynamic. Study objects that follow the study object with the global condition in the
workflow appear in the study. When the workflow in the example is deployed, the Vital Signs,
Medical History, and Physical Exam forms appear in the visit after the Demogtraphics form. The
Pregnancy Test form appears in the visit only if the global condition outcome is True.

Copying study objects with global conditions using the Libraries Browser

Global conditions appear to be attached to study objects but ate actually part of a workflow. They
are copied with study objects in the following way:

e If a study event contains a form with a global condition, the global condition is actually part of
the study event. When you use the Libraries Browser to copy the study event from a study to a
library, the global condition is copied. The global condition is not copied if you copy only the
form.

e If you use the Libraries Browser to copy the study event from a study to a library, publish only
the form, and copy only the form into a study, the global condition is not copied into the study
because the global condition is part of the workflow at the study event level.

Note: When a global condition is on a study element or study event that is created directly under
the study design in the Project Explorer, the global condition cannot be copied from a study to a
library. The global condition is actually on the study design, and you cannot copy a study design
from a study to a library.

Notes

®  You can apply only one global condition per study object, so you must create an expression that
evaluates all relevant data points in one global condition. Therefore, you cannot apply the global
condition to multiple study objects if the other study objects require other actions. When you
need to apply the same action to multiple study objects, Oracle recommends creating a workflow
rule instead of applying a single global condition to multiple study objects. A workflow rule is
evaluated only once.

e For valid global conditions, if you modify the RefName of a study object referenced by the rule,
the global condition is updated with the change.

If you modify a study object RefName in the global condition expression, the study object is not
automatically updated in other rules that reference it.

®  You are not required to use a naming convention for rules, but it can help you distinguish one
type of rule from another. If you want to adopt a naming convention, consider prefixing
workflow rules with wr and global conditions with gc to differentiate them from data-entry
rules.

e Workflow rules and global conditions are deployed to the InForm application as trigger
dependencies.
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Deciding between a workflow rule and a global condition
When to use workflow rules

Use a workflow rule to determine the branch of a study workflow that a subject should follow. For
example, you can use a workflow rule to determine whether a subject completes a study with the
standard termination visit or continues on to a set of extended visits.

When you need to apply the same action to multiple study objects, Oracle recommends creating a
workflow rule instead of applying a single global condition to multiple study objects. A workflow rule
is evaluated only once.

When a study is deployed, the study objects that follow the workflow rule do not appear in the study
book until the rule outcome determines the branch a study subject should follow.

When to use global conditions

Use a global condition when you want a single study workflow object to be dynamic. For example,
you can use a global condition to generate a pregnancy test form for female subjects.

Because you can apply only one global condition per study object, you must create an expression that
evaluates all relevant data points in one global condition. Therefore, you cannot apply the global
condition to multiple study objects if the other study objects require other actions.

When a study is deployed, the study object to which the global condition is applied does not appear
in the study book until the outcome of the global condition determines whether it is needed.

Oracle® Health Sciences Central Designer 2.1 145



Chapter 4 Designing rules

About the rule expression language
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Use the rule expression language to create the expression component of a data-entry rule, workflow
rule, or global condition.

You create rule expressions in:

e The Expression tab of the Rule Wizard.

e The Expression workspace of the dialog boxes used to create or edit a workflow rule or global
condition.

As you type, a list of the rule model components that you can use in the expression (study objects
and their properties, functions, constants, and data mappings) appears in the Expression workspace.
When you select a rule model component, a tooltip appears to indicate its usage (for example, the
parameters and their data types required for using a function). The list changes dynamically to
support the contents of the expression as you create it.

You can also use the following methods for creating a rule expression:

e Drag rule model components into the Expression workspace from the tabs that appear on the
right side of the workspace.

e Type an expression directly in the Expression workspace.

A rule expression can include any valid C# expression that can appear on the right side of the equals
sign (=), including:

e Operators and literals.
e Study objects and their rule model properties.
e Functions.
e Constants defined for the study.
e  Data mapping study objects and their rule model properties.
e Methods. You can use any method, including:
e Math methods.
e Data set methods.

e Methods for repeating study objects.
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A rule expression cannot include:

e Complex structures, such as if statements (conditionals are allowed) and looping statements.

Use functions to build more complex rule expressions. For more information, see Functions

tab of the Rule Wizard (in the Rules Reference Guide).
e Multi-line expressions.

The rule expression does not allow flow-of-control operators, such as /e, #f, then, for, or while.
You can use parentheses to provide better readability and grouping.

An expression must evaluate to one of the following types:

e Integer
e Float

e Boolean
e Text

e Date time

Note: A rule expression is similar to a switch statement in C++, C#, or Java.
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When you create an expression, you can type directly in the Expression workspace, and you can drag
rule model objects from the tabs at the right side of the windows where you create a data-entry rule,
workflow rule, or global condition.

When you type in the Expression workspace, prompts appear dynamically as you type, listing the rule
model objects that are available for you to use based on the scope of the rule and the content of the
expression. As an alternative to dragging rule model objects from the tabs, you can select the objects
from the prompts.

A dynamic expression prompt appears when you type a period. The prompt contains a list of rule
model objects that you can select.

e To use the value of a study object or rule model property, type this., and select the study object
or property from the dynamic expression prompt.

e To use a function, type Functions., and select the function from the dynamic expression prompt.
e To use a constant, type Constants., and select the constant from the dynamic expression prompt.

e To use a data mapping study object or a rule model property, type DataMappings., and select the
study object or rule model property from the dynamic expression prompt.

When you select a rule model object that requires parameter values (for example, a function or
method), an open parenthesis mark follows the name of the rule model object, and a tooltip indicates
the parameters and their data types. The tooltip also appears when you point to the name of the rule
model object.

The following illustration shows a dynamic expression prompt and tooltip that appear when you
create a rule expression with a function on a study event that includes several forms. The Rule
Wizard tabs containing the same options are visible on the right.

Dynamic expression prompt and tooltip

1—Dynamic expression prompt. Constants, functions, data mappings, and child study objects are
available for selection.

2—Standard Rule Wizard tabs.

3—Tooltip showing format and data types of required parameters for the function.
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Selecting a rule model object from a dynamic 