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About this guide

Overview of this guide

This guide provides a brief overview of the Central Designer software, a description of hardware and
software requirements, and step-by-step instructions for installing, uninstalling, and upgrading the
software.

Audience

This guide is for IT administrators and others who are responsible for installing, upgrading, and
uninstalling the Central Designer software.
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Documentation

The product documentation is available from the following locations:

e Oracle Software Delivery Cloud (https://edelivery.oracle.com)—The complete
documentation set.

e My Oracle Support (https://support.oracle.com)—Relase Notes and Known Lssues.

e Oracle Technology Network (http://www.oracle.com/technetwork/documentation)—The
most current documentation set, excluding the Re/ease Notes and Known Issues.

All documents may not be updated for every Central Designer release. Therefore, the version
numbers for the documents in a release may differ.

ltem Description

Release Notes The Release Notes document provides detailed information about the requirements,
enhancements, and fixed issues in the current release.

Known Issues The Known Issues document provides detailed information about the known issues
in this release, along with workarounds, if available.

Installation Guide 'The Installation Guide provides system requirements and instructions for installing
and upgrading the Oracle® Health Sciences Central Designer software and the
Oracle® Health Sciences Central Designer Administrator software.

Adpministrator The Adpinistrator Guide describes how to use the Oracle® Health Sciences Central
Guide Designer Administrator software to set up users, permissions, system
configuration parameters, and catalog defaults.

User Guide The User Guide introduces the study design environment in the Oracle® Health
Sciences Central Designer application and describes how to work as a study
design team in that environment, including how to:

e Work collaboratively.
e Maximize study design efficiency by reusing study objects.

e Manage collections of study objects.

InForm Design ~ The InForm Design Guide describes how to design a study for deployment to the
Guide InForm application.

Rules Reference  The Rules Reference Guide is a reference to the tools that are available for creating
Guide rule expressions, including:

e Study object properties.
e Functions.

e Constants.

e Data mappings.

e Methods, operators, and literals.

Central Designer 2.1.1.1 vii
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ltem Description

Secure The Secure Confignration Guide provides an overview of the security features
Configuration provided with the Oracle® Health Sciences Central Designer application, including
Guide details about the general principles of application security, and how to install,

configure, and use the Central Designer application securely.

Third Party The Third Party Licenses and Notices document includes licenses and notices for
Licenses and third party technology that may be included with the Central Designer software.
Notices

Documentation accessibility

For information about Oracle's commitment to accessibility, visit the Oracle Accessibility Program
website at http://www.oracle.com/pls/topic/lookuprctx=acc&id=docacc.

viii Central Designer 2.1.1.1
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If you need assistance

Oracle customers have access to support through My Oracle Support. For information, visit
http:/ /www.oracle.com/pls/topic/lookup?ctx=acc&id=info, ot if you are heating impaired, visit
http:/ /www.oracle.com/pls/topic/lookup?ctx=acc&id=trs.

Finding Central Designher information and patches on My Oracle Support

The latest information about the Central Designer application is on the Oracle Support self-service
website, My Oracle Support. Before you install and use the Central Designer application, check My
Oracle Support for the latest information, including Release Notes and Known Issues, alerts, white
papers, bulletins, and patches.

Creating a My Oracle Support account

You must register at My Oracle Support to obtain a user name and password before you can enter
the site.

1 Open a browser to https://support.oracle.com.
2 Click the Register link.

3 Follow the instructions on the registration page.

Finding information and articles

1 Sign in to My Oracle Supportt at https://support.oracle.com.

2 If you know the ID number of the article you need, enter the number in the text box at the top
right of any page, and then click the magnifying glass icon or press Enter.

3 To search the knowledge base, click the Knowledge tab, and then use the options on the page to
search by:

e Product name or family.

e Keywords or exact terms.

Finding patches
You can seatrch for patches by patch ID or number, product, or family.
1 Sign in to My Oracle Supportt at https://support.oracle.com.
2 Click the Patches & Updates tab.
3 Enter your search criteria and click Search.
4 Click the patch ID number.

The system displays details about the patch. You can view the Read Me file before downloading
the patch.

5  Click Download, and then follow the instructions on the screen to download, save, and install the
patch files.

Central Designer 2.1.1.1 iX
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Finding Oracle documentation

The Oracle website contains links to Oracle user and reference documentation. You can view or
download a single document or an entire product library.

Finding Oracle Health Sciences documentation

For Oracle Health Sciences applications, go to the Oracle Health Sciences Documentation page at
http:/ /www.oracle.com/technetwork/documentation/hsgbu-clinical-407519.html.

Note: Always check the Oracle Health Sciences Documentation page to ensure you have the most
up-to-date documentation.

Finding other Oracle documentation
1 Do one of the following:
¢ Go to http://www.oracle.com/technology/documentation/index.html.

e Go to http://www.oracle.com, point to the Support tab, and then click Product
Documentation.

2 Scroll to the product you need, and click the link.

Finding prerequisite software for Oracle Health Sciences applications

Prerequisite software for Oracle Health Sciences applications is available from the following
locations:

e  Download the latest major or minor release from the Oracle Software Delivery Cloud
(https:/ /edelivery.oracle.com/).

For information on the credentials that are required for authorized downloads, click FAQs on the
main page of the Oracle Software Delivery Cloud portal.

e Download subsequent patch sets and patches from My Oracle Support
(https:/ /support.oracle.com).

To find patch sets or patches, select the Patches & Updates tab.

If a previous version of prerequisite software is no longer available on the Oracle Softwatre Delivery
Cloud, log a software media request Service Request (SR). Previous versions of prerequisite software
are archived and can usually be downloaded. After you open an SR, you can check its status:

e US customers: Call 1-800-223-1711.

e Outside the US: Check www.oracle.com/us/support/contact/index.html for your local Oracle
Support phone number.

For more information on logging a media request SR, go to My Oracle Support for Document
1071023.1: Requesting Physical Shipment or Download URL for Software Media
(https:/ /support.oracle.com/epmos/faces/DocumentDisplay?id=1071023.1).
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CHAPTER 1
Architectural overview of the environment

In this chapter

Introduction to the Central Designer SOftWAre. ...
PRySICAl AfCRITECTULE ....vuvaiiiiccicricciererecceteteer et s et sttt senseas

Web farm CAPabILIIES ......c.cviuiiiiiciiciic e
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Chapter 1 Architectural overview of the environment

Introduction to the Central Designer software

The Central Designer software consists of:

Central Designer server application—Communicates with the client applications through web
services.

Central Designer client application—Provides a collaborative environment for designing
clinical studies and deploying them to the InForm application.

Central Designer Administrator client application—Provides an environment for setting up
administrative information, such as users, roles, and system configuration information.

Central Designer 2.1.1.1
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Physical architecture

The physical configuration of the Central Designer software includes:

e A database server machine.

e One or more application server machines. For more information, see Web farm capabilities
(on page 4).
e One or more client machines.

There are three configuration options for the Central Designer software.

Configuration Description

Single-tier The application server, database server, and client applications run on the
same machine.

Two-tier The application server and database server run on the same machine, and
the client applications run on another machine.

Three-tier The database server, application server, and client applications each run
on a separate machine.

Notes:

e Tor optimum performance, Oracle recommends a three-tier configuration.

e If the application server and database server are on the same computer, you must install the
Oracle Server software and Oracle Client software in the same home, or the Central Designer
server installation will not work.

Flrwwall Central Designer Administrator gmart client
] T - ——
Central Designer i .g
application server E —
~ Central Degigner £man elients

PRNUREN IR | _““@
Wrnnnp

Central Designer Administrator smart client

Central Desigrier smart clients

B T oo RO
databake Server
%
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Web farm capabilities

You can expand the performance capabilities of the Central Designer application server by adding
multiple servers in a farm configuration. This configuration is called a web farm. A web farm setup
distributes requests from the client applications among multiple application servers. A web farm is
useful for the following reasons:

e A large number of requests that might impact performance can be spread out among multiple
application servers, thus improving performance.

e Multiple application servers allow for redundancy and failover protection.

In a web farm configuration, all application servers can process any request. However, certain
operations are run asynchronously using the Central Designer Job Scheduler. The Job Scheduler is
installed on every application server, but only one Job Scheduler can process jobs, and only one
service is enabled to process requests. The Job Scheduler service that processes all requests is called
the primary Job Scheduler. You can change the primary Job Scheduler at any time. Oracle
recommends setting the Job Scheduler on the most powerful machine in the web farm as the

primary.

Note: You must use the same port number, which you specify during installation, for all
application servers within a web farm. If one of the application servers uses a different port
number, the Job Scheduler will not work if the machine is set to run the primary Job Scheduler. By
default, the port number is 53000.

4 Central Designer 2.1.1.1
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lllustration of a web farm configuration
The following tasks are performed in a web farm configuration:

e The client applications send requests through a firewall to a load balancer. The load balancer
distributes requests among application servers.

e The job scheduler services on all of the application servers run; however, only the primary job
scheduler processes requests. The other job scheduler services do not accept any requests.
Examples of tasks that require the job scheduler service include importing and validation.

e  All tasks that do not require the job scheduler service are distributed among the application
servers.

Prritmiaty
filul4]

Scheduler
Service

Application server Job

Scheduler
Serdce

L

Cliert applicaion Load balancer

Application ser er

Jaokb
Scheduler
SEervce

Cliert application
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|

Application serer

Information that is stored in the database

Units information and report definitions are stored in the database and are used by all application
servers in a web farm.

¢ You can export the units information to a file and then modify and import the file. You perform
this task in the Central Designer Administrator application.
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e If you have created custom reports, you must back up the Report configuration section of the
DesignerWebServices.config file before upgrading and then import it into the database.

For more information about working with this information, see the Administrator Guide.

About adding application servers

You can add additional application servers to a web farm environment at any time, even if you did
not configure your first application server to support a web farm.

When you install a second application server, the installation recognizes the existing application
server installation. The Job Scheduler service on the existing application server is set as the primary
by default, but you can set the Job Scheduler for the second (or higher) application server as the
primary during the installation of its application server.

You install additional application servers the same way that you install the first application server.
The installation process configures the application server computers as a web farm. For more
information, see Installing the Central Designer application server (on page 38).

Managing web farm capabilities

After a web farm is installed, you can manage it using the Central Designer Administrator software.
You perform the following tasks in the Central Designer Administrator software:

e Viewing the servers that are in the web farm.

e Determining and changing the primary job scheduler.

e Working with Event Log messages for the web farm, including:
e Viewing the messages.
e Changing the default limit for the number of entries in the log.
e Deleting all entries in the log.

e Modifying the file for report definitions.

e  Moditying units information.

For more information, see the Administrator Guide.

6 Central Designer 2.1.1.1
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Chapter 2 Checklists for software installation

Checklist—Planning the server installation

Use the following checklist to help plan the Central Designer application server and database server
installations.

If you are upgrading, see Upgrading the software to this release (on page 49).

M Task Information

O 1  Determine if the setup is Physical architecture (on page 3).
single-tier or multi-tier.

O 2 Make sure all system o System requirements: Application servers in the Release Notes.
requirements, including NET
Framework requirements,
have been met for the
application server.

Verifying that the correct version of Microsoft
.NET Framework 1s installed (on page 20).

O 3  Make sure all system o System requirements: Database server in the Release Notes.
requirements, including
required Oracle database
parameters, have been met
for the database server.

o Install the Oracle database software on the
database server (on page 28).

0 4  On the database server, create The database and tablespaces must be created prior to
the database and tablespaces. installing the Central Designer software.

Create the database and tablespaces (on page 29).

O 5  On the database server, Configuring the Open Cursors setting for a database
configure the Open Cursors  instance (on page 30).
setting,.

U 6  On the database server, Configuring the Cursor Sharing setting for a database
configure the Cursor Sharing  instance (on page 30).
setting.

O 7  On the database server, grant Required tights for database administrators (on page
the appropriate rights to 31).
database administrators.

O 8  Configure the application Configuring the application server for optimal

server for optimal performance (on page 24).
performance.

O 9  On the database server, Configuring the listener to accept connections for the
configure the listener to new database (on page 29).

accept connections for the
new database.

O 10 Determine the security level — Securing communication with Secure Sockets Layer
to be used for (SSL) (on page 69).
communication between the
client applications and the
application server.

8 Central Designer 2.1.1.1
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M Task Information

O 11 Determine if you will Web farm capabilities (on page 4).
implement a web farm.

O 12 Increase the default value of  Increasing the Microsoft Distributed Transaction
the MS DTC timeout on the  Coordinator timeout (on page 25).
application server.

O 13 Monitor the tablespace in the If the tablespace becomes full, expand the tablespace by
database. adding another data file.

U 14 Make sure that the following  If the services are not running, the installation fails.

services are running: ) )
& The IIS Admin Service does not have to run for the

e IIS Admin Service duration of the installation. However, you must start it
e World Wide Web before you click the Next button on the Copying Files

Publishing Service sereet.

Note: Do not use the iisreset command from the MMC
or a command prompt after the installation or upgrade
completes, or the IS settings that were set by the installer
are lost. Instead, use the net start command to start the
services.

QO 15 Install a certificate for signing Installing certificates for signing web service
web service authorizations,  authorizations and deployment packages (on page 14).
and a certificate for signing
deployment packages and
InForm web service
authorizations.

Q 16 If necessary, install the root e  Installing root and intermediate cettificates (on
certificate and intermediate page 17).
certificate or certificates, and

install the main certificate as Installing the main certificate as the root

the root certificate. certificate (on page 19).

Q 17 Install the application server. o  Installing the Central Designer application setver
(on page 38).

e  Performing a silent installation (on page 44).

O 18 Setup an SMTP setver for Set up an SMTP server for automated deployment
automated deployment notifications (on page 74).
notifications.

O 19 Verify the installation of the ~ Verifying the installation of the application server (on
application server. page 45).

Central Designer 2.1.1.1 9



Chapter 2 Checklists for software installation

Checklist—Planning the client installations

Use the following checklist to help plan the installations of the client applications.

The Central Designer and Central Designer Administrator applications are ClickOnce applications.
You start a ClickOnce application by clicking a link from an Internet Explorer window.

When you click a link for either application, the Central Designer server checks whether the release
that is installed on the server matches the files that are cached on your computer:

e If the server has been newly installed or has been upgraded after your last logon, the files that are
necessary to run the application are cached on your computer, and then are used to open the
application.

e If the server has not been updated since your last logon, the cached files on your computer are
used to open the application.

M Task Information

Q 1 Make sure all system requirements, o  System requirements: Client computers in the Release
including NET Framework Notes.
requirements, have been met for

: . .y ) .
the client computers. Verifying that the correct version of Microsoft

.NET Framework 1s installed (on page 20).

O 2 (Optional; this step is Viewing Internet Explorer proxy settings (on page
informational only.) Check 21).
whether the Microsoft Internet
Explorer browser uses a proxy
server to connect to the Internet.
The Central Designer software
uses the same proxy server.

O 3 Make sure the clocks on the Synchronizing clocks on server and client
application server computer, computers (on page 22).
database server computer, and
client computers are synchronized.

O 4 Start the client applications. e  Starting the Central Designer client (on page
40).

e  Starting the Central Designer Administrator
client (on page 47).

10 Central Designer 2.1.1.1
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Chapter 3 Planning your installation

Installing certificates for signing web service
authorizations and deployment packages

You must install a certification for each of the following purposes:

e Signing the web service authorizations.

e Signing deployment packages and InForm web service authorizations on the Central Designer
server.

Install certificates to the LOCAL_MACHINE\MY store. Each certificate in the cettification path
must be 2048 bytes. For more information about converting existing certificates, see the Microsoft
support website.

The Central Designer installation process grants Full Control to access the certificate private keys to
the IIS AppPool\DefaultAppPool user and the NETWORK SERVICE uset.

If a user other than the IIS AppPool\DefaultAppPool user is running the DefaultAppPool
application pool, you must grant the user Full Control to access the private keys, or the user is unable
to sign using the certificates.

For each certificate:

1 Open the Microsoft Management console:
a  Open a Command Prompt window.
b Type mmc.
2 Select File > Add/Remove Snap-in.
The Add or Remove Snap-ins dialog box appeats.
3 In the list of available snap-ins, select Certificates.
4 Click Add.
The Add dialog box appears.
Click Computer account.
Click Next.
Click Local Computer.
Click Finish.
Click OK.

O 0o 1 &N !

10 In the left pane of the console, select Certificates (Local Computer).
11 Right-click the Personal folder.
12 Select All Tasks > Import.
The Certificate Import Wizard appears.
13 Click Next.

12 Central Designer 2.1.1.1
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14

15
16
17

18
19
20

21

Click Browse, and select the PFX file provided by the certificate vendor.
You are prompted for a password.

Type the password for the PFX file.

Click Next to accept the default options for the remaining wizard pages.
Click Finish.

The new certificate appears in the displayed list.

In the left pane, select Personal > Certificates.

Right-click the certificate and select All Tasks > Manage Private Keys.

If a user other than the IIS AppPool\DefaultAppPool user is running the DefaultAppPool
application pool, select that user and grant them Full Control.

Click OK.

Central Designer 2.1.1.1
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Installing a certificate for sighing web service
authorizations

14

On each Central Designer application server, an administrator must install the certificate that is used
for signing web service authotizations to the LOCAL_MACHINE\MY store directory and make it
usable by the user who runs the ASP.NET worker process (by default, the NETWORK_SERVICE

user).

You must also grant this user Full Control rights to the private key for the certificate.

The certificate and each certificate in the certification path must be 1024 bytes. For information
about converting an existing certificate, see the Microsoft support web site.

To install the certificate:

1

Nl e > e, |

11
12

13
14

15
16

Open the Microsoft Management console:
a  Open a Command Prompt window.
b Type mmc.
Select File > Add/Remove Snap-in.
The Add or Remove Snap-ins dialog box appeats.
In the list of available snap-ins, select Certificates.
Click Add.
The Add dialog box appears.
Click Computer account.
Click Next.
Click Local Computer.
Click Finish.
Click OK.

In the Microsoft Management console, in the Console Root tree, select Certificates (Local
Computer).

In the Logical Store Name field, right-click the Personal folder.

Select All Tasks > Import.

The Certificate Import Wizard appears.

Click Next.

Click Browse, and select the PFX file provided by the certificate vendor.
You are prompted for a password.

Type the password for the PFX file.

Click Next to accept the default options for the remaining dialog boxes.
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17 Click Finish.
The new certificate appears in the displayed list.
18 Right-click the certificate, and select All Tasks > Manage Private Keys.
19 Add the ASP.NET worker process to the list and give the user full control.
e By default, for Windows 2003, the user is NETWORK_SERVICE.
e By default, for Windows 2008 and Windows 7, the user is IIS AppPool\DefaultAppPool.
20 Click OK.
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About installing root and intermediate certificates

You might need to install additional certificates for the following situations:

When the main certificate you installed contains an intermediate certificate, a root certificate, or
both in its certification path.

When the PFX file you imported contains an intermediate certificate, a root certificate, or both
embedded within it. In this case, the certificates might not have been installed in the correct
locations.

Determining whether to install additional certificates

16

To check whether you need to install the additional certificates, double-click the main certificate and
select the Certification Path tab. If you sce:

Three or more certificates—Install the root certificate and one or more intermediate
certificates.

For more information, see Installing root and intermediate certificates (on page 17).
Two certificates—Install the root certificate.

For more information, see Installing root and intermediate certificates (on page 17).
One certificate—Install the main certificate from the PFX as the root certificate.

For more information, see Installing the main certificate as the root certificate (on page 19).
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Installing root and intermediate certificates

Perform this procedure for both the root certificate and one or more intermediate certificates.

1 Open the Microsoft Management console:
a  Open a Command Prompt window.
b Type mmc and press Enter.
2 Select File > Add/Remove Snap-in.
The Add or Remove Snap-ins dialog box appears.
3 From the list of available snap-ins, select Certificates.
4 Click Add.
The Add dialog box appears.
Click Computer account.
Click Next.
Click Local Computer.
Click Finish.
Click OK.

O 0o N &N w»

10 In the left pane of the console, select Certificates (Local Computer).
11 Click the Personal folder.
12 Double-click the main certificate you previously imported and select the Certification Path tab.
13 Do one of the following:
e To install the root certificate, double-click the root certificate.

e To install the intermediate certificate, double-click the intermediate certificate and select the
Details tab.

14 Click Copy to File and do the following:
a  Deselect Do not export the private key.
b Select the default file type.
c Select DER encoded binary.
d  Navigate to the location in which to save the certificate.
e Click OK.
15 In the left pane of the console, select one of the following:
e If you are installing an intermediate certificate, select Intermediate Certification Authorities.
e If you are installing the root certificate, select Trusted root Certification Authorities.
16 Right-click the Certificates folder and select All Tasks > Import.
The Certificate Import Wizard appears.
17 Click Next.
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18 Select the CER file for the certificate you are installing, either the intermediate or root certificate.

19 Click Next to accept the default options for the remaining wizard pages.
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Installing the main certificate as the root certificate

1 Open the Microsoft Management console:
a  Open a Command Prompt window.
b Type mmc.
2 Select File > Add/Remove Snap-in.
The Add or Remove Snap-ins dialog box appeats.
3 In the list of available snap-ins, select Certificates.
4 Click Add.
The Add dialog box appears.
Click Computer account.
Click Next.
Click Local Computer.
Click Finish.
Click OK.

O o N & wu

10 In the left pane of the console, select Certificates (Local Computer).
11 Click the Personal folder.
12 Double-click the main certificate you imported and select the Certification Path tab.
13 To install the main certificate as the root certificate, double-click the main certificate.
14 Click Copy to File and do the following:
a  Deselect Do not export the private key.
b Select the default file type.
¢ Seclect DER encoded binary.
d Navigate to the location in which to save the certificate.
e Click OK.
15 In the left pane of the console, select Trusted root Certification Authorities.
16 Right-click the Certificates folder and select All Tasks > Import.
The Certificate Import Wizard appears.
17 Click Next.
18 Select the CER file for the root certificate.

19 Click Next to accept the default options for the remaining wizard pages.
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Verifying that the correct version of Microsoft .NET
Framework is installed

For information about the required versions of Microsoft NET Framework, see Hardware and software
requirements in the Release Notes.

Note: If you have a version of .NET Framework prior to the required version for this release, you do
not need to uninstall it before installing the required version.

e To find .NET Framework versions by viewing the registry:
1 On the Start menu, click Run.
2 In the Open field, type regedit.exe.
3 Click OK.
4

In the Registry Editor, go to
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\NET Framework
Setup\NDP.

The installed versions are listed under the NDP subkey.

If NET Framework is installed, the folder contains folders whose names begin with v, followed
by the NET Framework version number. For example:

e v3.5—indicates that NET Framework 3.5 SP1 is installed.
o v4.0—indicates that NET Framework 4.0 is installed.
For more information, see the Microsoft documentation.

e To find NET Framework versions by using Windows Explorer, paste the following text into the
Windows Explorer address bar:

e For 64-bit: %systemroot”\Microsoft. NET\ Framework64.
e For 32-bit: %systemroot% \Microsoft. NET\ Framework.
If NET Framework is installed, the folder contains folders listing the installed versions.

e If a required version of NET Framework is not installed, install it.
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Viewing Internet Explorer proxy settings

1 Open Internet Explorer, and select Tools > Internet Options.

2 Select the Connections tab, and click one of the following:
e Ifyou are connecting via a local area network—Click the LAN Settings button.
e Ifyou are connecting via a network connection—Click the Settings button.

The proxy settings appear in the dialog box.
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Synchronizing clocks on server and client computers

The clocks on the client computers, application server computer, and database server computer are
not required to be in the same time zone, but they must be no more than 24 hours apart relative to

the Coordinated Universal Time (UTC). Oracle recommends that the clocks be no more than 10
minutes apart.
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Hardware networking switches

Some hardware networking switches change the incoming URL before passing the request to the
Central Designer server. For example, if the address typed during a client installation is
https://abc.com, a switch might change the URL in the following ways:

e A switch that performs hardware SSL processing might change the URL to http://abc.com.
e A switch that performs load balancing might change the URL to http://PhysicalSetrverl.

When the application server is installed in an environment that includes a hardware networking
switch, the URL that you type for the Web server URL root field must match the URL that the
networking switch uses to address the application server. From the previous examples, the required
URLs must be:

e In the first example, http://abc.com.

e In the second example, http:/ /PhysicalServerl.

Note: The application server must be able to use the address that you type for the Web server URL
root field to address itself.
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Configuring the application server for optimal performance

Oracle recommends performing the following modifications on the Central Designer application
server to optimize performance.

Use the /3GB startup switch feature for a 32-bit Microsoft Windows server

Using this startup switch, you can specify allocation details for memory and memory address space
usage. Additionally, the switch allows the server to access 3 GB of address space instead of 2 GB,
which is the default maximum for a 32-bit operating system.

Do not set the startup switch for a 64-bit Microsoft Windows server.

For more information, see the Microsoft documentation.

Configure the worker process recycling settings for Windows 2008

1 On the application server computer, select Start > Control Panel > Administrative Tools > Internet
Information Services (11IS) Manager.

2 Expand the tree for the local computer and select Application Pools.
3 Right-click DefaultAppPool and select Recycling.
4 Configure the following settings:

e Verify that only Regular time intervals (in minutes) is selected.

e Verify that a value of 1740 is entered for that setting.

Configure the worker process health settings for Windows 2008

1 On the application server computer, select Start > Control Panel > Administrative Tools > Internet
Information Services (1IS) Manager.

2 Expand the tree for the local computer and select Application Pools.
3 Right-click DefaultAppPool and select Advanced Settings.

4 Under Process Model, sct Shutdown time limit (seconds) to match the timeout for the client
application. (The default is 1200 seconds.)
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Increase the default Microsoft Distributed Transaction Coordinator timeout

Oracle recommends that you increase the Microsoft Distributed Transaction Coordinator (MS DTC)
timeout because the default Windows timeout setting of 60 seconds might be insufficient for some
Central Designer processes.

1
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Select Start > Control Panel > Administrative Tools > Component Services.

Open Component Services > Computers.

Right-click My Computer, and select Properties.

Select the Options tab.

Change the value of the Transaction timeout (seconds) ficld to 3600. (The default is 60.)
Click oK.

Open Control Panel > Services.

Stop and restart all 1IS services.
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Use the performance tuning capabilities that are available with the Oracle
database software

26

Open the Automatic Database Diagnostic Monitor (ADDM) from the Database Control home page
or from Advisor Central.

This tool helps you diagnose problems, identify their causes, and make recommendations.
About acting on ADDM recommendations:
e Make configuration changes to the database or operating system as necessary.

e The SQL Tuning Advisor might recommend rewriting some SQL statements. However, the
SQL statements cannot be rewritten.

e Add database indexes as needed.

Caution: Take note of all new indexes. Before upgrading, you must drop them to ensure that
they do not cause conflicts with new indexes that have been added to the product. After the
upgrade is finished, you can add the indexes back.

Note: Contact Oracle Global Support to forward SQL statement recommendations or
request index changes in the product.

The most common configuration recommendations from ADDM are:
e SGA_TARGET
e PGA_AGGREGATE_TARGET
e DB_FILE_MULTIBLOCK_READ_COUNT
e Reset to zero instead of using an explicit value.

e Oracle automatically manages this parameter value if it is set to zero.

For more information, see the Oracle database software documentation.
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Prepare the database server

Before installing the Central Designer software, you must:

e Install and configure the Oracle database software on the database server.

e Create the necessary database instance and tablespaces.

Install the Oracle database software on the database server

After the database server requirements are met, you can install the Oracle database software. Use the
Oracle database software installation documentation as needed. For more information about required
Oracle database software versions, in the Relase Notes, see:

e System requirements: Application servers.
e System requirements: Database server.

e  System requirements: Client computers.

Note: If the application server and database server are on the same computer, you must install
the Oracle Server software and Oracle Client software in the same home, or the Central Designer
server installation will not work.

Mandatory configuration

Most of the default Oracle settings can be used for the Central Designer database. However, the
following Oracle configuration must be used.

Page Option Value

Database Oracle Text, a standard Selected.

Components  database component. . .
p p Note: The Oracle database software installation

requires that you install Oracle Data Mining if you
install Oracle Text. If you do not want to install
Oracle Data Mining, you can install Oracle Text
manually after completing the Oracle database
installation. For more information, see the following
My Oracle Supportt note:

Note: 970473.1 Manual installation, deinstallation and
verification of Oracle Text 11gR2.

Oracle Java Virtual Selected.

Machine (JVM)

Character Sets Database Character Set AL32UTEF8 - Unicode 4.0 UTF universal character
set, UTF-8 compliant.

National Character Set AILL16UTF16 - Unicode UTF-16 universal character
set.

Parameters CURSOR_SHARING For Oracle 11g—FORCE
parameter
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Page Option Value
OPEN_CURSORS For Oracle 11g—500
parameter

Additional configuration information

In production databases at Oracle, the DB_ BLOCK_SIZE Oracle parameter is set to 16k (16384
bytes).

Create the database and tablespaces

After you install the Oracle database software, create the database instance and tablespaces. Make
sure the Oracle server has sufficient space to accommodate the new tablespaces. The Central
Designer software uses the following tablespaces by default.

Tablespace Description Minimum size
DESIGNER Main data tablespace 100 MB

Note: Depending on usage, you might
need to increase the size.

DESIGNER_BIGINDEX Index tablespace 10 MB with 16k (16384 bytes) block size.
SYSTEM Main data tablespace 500 MB

SYSAUX Main data tablespace 250 MB

TEMP Temporary tablespace  Always present in the Oracle database.
UNDOTBS1 Main data tablespace 200 MB

Note: The tablespace names provided are the default names. Any names can be used for the
tablespaces.

If you use non-default names, you must specify them during the installation of the application
server (by clicking Advanced on the Database Parameters page), so be sure you take note of
them.

Configuring the listener to accept connections for the new database

After installing the Oracle database software, you must configure the listener to accept connections
for the new database. For more information, see the Oracle database software documentation.

Central Designer 2.1.1.1 29




Chapter 4 Preparing the database server

Configuring the Open Cursors setting for a database instance

When you create a database instance, you must set the Open Cursors setting correctly for your
database version.

e Tor the Oracle 11g database version, set Open Cursors to 500 using the following SQL
command:

ALTER SYSTEM SET open_cursors=500 SCOPE=BOTH;

Before you upgrade, ensure that the Open Cursors parameter is correctly set.

Configuring the Cursor Sharing setting for a database instance

When you create a database instance, you must set the Cursor Sharing setting properly for your
database version.

e For the Oracle database versions 10.2.0.3, 10.2.0.4, and 10.2.0.5, set Cursor Sharing to
SIMILAR.

Note: Oracle database version 10.2.0.4 no longer receives patch support.

e For the Oracle database version 11.2.0.3 or later, set Cursor Sharing to FORCE.
The following SQL command changes the Cursor Sharing setting:
ALTER SYSTEM SET cursor_sharing=<Setting> SCOPE=BOTH;

where:

e Setting—SIMILAR or FORCE, based on the version of the Oracle database software in
your environment.

Before you upgrade, ensure that the Cursor Sharing parameter is correctly set.
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Required rights for database administrators

During the installation of the Central Designer application setver, you ate prompted to specify user
names and passwords for:

o Database Administrator
e Database User

The installation uses the Database Administrator user name and password to create the Database
User and grant that user rights to perform tasks for the Central Designer application. The default
name for the Database Administrator is system, but it can be any user that you assign the rights to
perform the following tasks.

Task SQL Automatically executed for

Create the Database User. CREATE USER &1 All supported Oracle database
IDENTIFIED BY &2 software versions.
DEFAULT TABLESPACE
&3;
GRANT CONNECT TO
&1;
GRANT RESOURCE TO
&1;

GRANT CREATE VIEW
TO &1,

Allow the Database User to GRANT QUERY REWRITE All supported Oracle database
create function indexes. TO &1; software versions.

GRANT CREATE
SYNONYM TO &1;

EXIT;

Note: The Database Administrator user does not have the right to allow the Database User to
execute jobs. For more information on how to assign the Database Administrator the necessary
rights, see For Oracle 11.2.0.3—Granting the EXECUTE on SYS.DBMS_JOB right to the database
administrator (on page 31).

For Oracle 11.2.0.3—Granting the EXECUTE on SYS.DBMS_JOB right to the
database administrator

The Database Administrator user in the Oracle 11g database software does not have the right to
allow the Database User to execute jobs.

Due to a known issue in the 11.2.0.3 database software version, to grant the appropriate right to the
Database Administrator, you must grant the right to execute jobs, revoke the right, and grant the
right again.

To grant the Database User the right to execute jobs, run the following SQL commands as a
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Database Super User:

1  GRANT EXECUTE on SYS.DBMS_JOB to <Database Administrator user name> WITH
GRANT OPTION;

COMMIT;
EXIT;
whete:

e Database Administrator user name—System, or the user name you assigned to the
Database Administrator user.

2 REVOKE EXECUTE on SYS.DBMS_JOB from <Database Administrator user name>
COMMIT;
EXIT;
where:

¢ Database Administrator user name—System, or the user name you assigned to the
Database Administrator user.

3  GRANT EXECUTE on SYS.DBMS_]JOB to <Database Administrator user name> WITH
GRANT OPTION;

COMMIT;
EXIT;
where:

e Database Administrator user name—System, or the user name you assigned to the
Database Administrator user.

You can then run the following SQL commands as the Database Administrator user you referenced
in the previous step to assign a user the right to execute jobs:

GRANT EXECUTE on SYS.DBMS_JOB to &1;
COMMIT;
EXIT;

Note: The Oracle 10g database software automatically runs these SQL commands during
installation.
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Sample SQL

The following SQL commands are not run by the installation but show an example of what a
database administrator needs to do to create the tablespaces. Database administrators must set up the
tablespaces before installing the Central Designer software. Administrators should note the setting of
the cache size before creating the _ BIGINDEX tablespace.

CREATE TABLESPACE designer

LOGGING

DATAFILE 'D:\Oracle\oradata\devl\DESIGNER.ora' SIZE 400M
AUTOEXTEND ON NEXT 1M;

ALTER SYSTEM SET db_16k_cache_size = 80M;

CREATE TABLESPACE "designer_bigindex"

LOGGING

DATAFILE 'D:\Oracle\oradata\devl\DESIGNER_BIGINDEX.ora' SIZE 10M
REUSE

BLOCKSIZE 16384
EXTENT MANAGEMENT LOCAL SEGMENT SPACE MANAGEMENT AUTO;
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Before you begin

The latest information about the Central Designer application is on the Oracle Support self-service
website, My Oracle Support. Before you install and use the Central Designer application, check My
Oracle Support for the latest information, including Release Notes and Known Issues, alerts, white
papers, bulletins, and patches.

For the latest Central Designer software, check the Oracle Software Delivery Cloud
(https:/ /edelivery.oracle.com).
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Overview of installation and configuration

Before you start your installation, plan your work:

e  Checklist—Planning the server installation (on page 8).

o Checklist—Planning the client installations (on page 10).

Overview of installing the application and database servers

Step For more information, see

1 Install the Central Designer o  Preparing the database setver (on page 27).

licati :
Apprication server e Installing the Central Designer application server (on

page 38).

2 Verify the installations. o Veritying the installation of the application server (on
page 45).

Overview of uninstalling

Step For more information, see

1 Uninstall the application e Uninstalling the application setver (on page 45).
server.

Note: The client applications are ClickOnce applications and are therefore not installed on users'
computers. Therefore, you cannot uninstall the client applications.
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Installing the Central Designer application server

38

1

Locate the setup.exe program.

The setup.exe program is available the Oracle Software Delivery Cloud
(https://edelivery.oracle.com).

Double-click setup.exe.

The InstallShield Wizard prepares to install the application server.
A welcome page appears.

Click Next.

The Customer Information page appeats.

Provide the following information:

e User Name—Your name.

e Company Name—The name of your company.

¢ Company URL—A unique identifier for your company data, typically your company URL
(for example, http://www.mycompany.com).

e Select whether to install the application for anyone who uses the computer, or only for your
user.

Click Next.

The following page appears.

Central Designer Server - Installshield Wizard

Setup Type
Select the setup type that best zuits your needs,

Click the tppe of setup you prefer.

" Update

A exizting database will be updated to the new schema.

_—
11 ! 'Fi The existing database user will be dropped and recreated, resulting in the loss of all
AN G data.
o o \Izﬂ_r/--
\ - =
b et =, \,‘_‘
K"“""*-«.._., ﬁ

D estination Folder
(E:\...\Dracle Health ScienceshCentral Designer Browse...

Central Designer”
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6  Select New Database.

Note: If you are installing the second or higher server in a web farm, do not select New
Database. You must select Update.

7 In the Destination Folder area, specify the destination location for the installation. By default, the
installation wizard installs the software in the <PROGRAMEFILESDIR>\ Oracle Health
Sciences\ Central Designer\ folder, where <PROGRAMFILLESDIR> is a system setting that is
usually C:/Program Files. If you want to install to another location, click Browse, and select the
location.

Note: The instructions, paths, and Start Menu navigation in this guide assume you are
installing to the default location. Oracle strongly recommends that you install the software
to the default location.

8  Click Next.

The following page appears.

Central Designer Server - Installshield Wizard

Database Parameters

Fleaze zupply the database parameters with which pou i

Choozing "Create Mew Database" will drop any existing user of the same name, and
create a new uzer with the name provided.

Databaze Uzer Mame: ||

w-""‘"'ﬂ_'_—l"'ﬂ--u._n Databaze Password: I

1'! .-I: 1 Oracle TMS Mame: I
g =

r/u- ‘-, I\T'-- ’f:' N
\ \‘—""i,,.."f-‘"-.- B Databaze Admirztrator Lser Mame: I
'\--.____:{I -"‘:-..5-’.

&

%'“"/} Database sdministratar Passward: I

¥ Create Mew Databaze Advanced. ..

CentralDesigner™

9 Fillin the fields in the page as follows.

Field Description

Database User Name The Oracle user name for the database uset.
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Field Description

Database Password The password for the database user.

Note: The password must not contain any of the following
characters: @ & () [or].

Oracle TNS Name Alias from the TNSnames.ora file. This TINS name is used to
connect to the database instance.

Database Administrator User The Oracle user account for the database administrator.

Name This account is used to create the database user.
Note: The user name cannot be a SYSDBA user account.
Database Administrator The password for the database administrator.
Password Note: The password must not contain any of the following
characters: @ & () [ ot ].
Create New Database Indicate whether to create a new database schema during

installation.

Caution: If you have an existing database schema and you select
Create New Database, all existing information in your current
database schema will be deleted.

Note: Do not use Oracle reserved words for user names or passwords.

10 If a new database was created and tablespaces were created with non-default names, you must
specify the names of the tablespaces.

a  Click Advanced.
The Advanced Database Settings page appears.
b Fill in the fields with the correct information, according to the following table.

¢ Click OK to return to the Database Parameters page.

Field Description

Default Tablespace for new  The first tablespace for the tables of the schema owner.
user

Large (16K) Tablespace for A second tablespace with a block size of at least 16K.

new user

Temp Tablespace for new The temporary tablespace for the tables of the schema owner.
user

Note: The tablespaces that you specify must already exist. The installation does not create
tablespaces.

11 Click Next.
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The following page appears.

Central Designer Server - InstallShield Wizard

Central Designer Job Service
Please supply the parameters for the Central D

The Job Service peiforms background processing and requies an
unused TCPAP port rumber. In most cases, the default value wil sulfice

TCPAP Port Numbes: 53000

¥ Make this server part of a web faim

!['r'r— L“"“-i A Primaty Job Scheduler has been found on server STEIN-PC
\ e = | ¥ Make this server's Job Scheduler the primary
V= =
(N
\'\_,/l/,.ig, %, Mo Please supply a password for the Job Service user. The password must
e ) be the same on all servers in & web faim, meet the length requirement,
' "‘/;5- and satisfy 8t least two of the following requirements

- Conlains al least one letter and one number
- Containg 8t least one non-alphanumenic characler
« Contains at least one upper-case and one lower-case lelter

Password:

Confum Password

tggte Designer™

Cancel

12 Type the TCP/IP port number that the job service will use. The port must be unused. In most
cases, you can use the default value.

Note: If you are installing the server as part of a web farm, all of the servers can use the
same port number, as long as the port is unused.

13 Optionally, to configure the Central Designer software to support a web farm, select Make this
server part of a web farm. A web farm setup allows you to install the Central Designer server
software on multiple application server computers. The installation is the same for all of the
servers, and you must select this option for all servers in the web farm. For more information,

see Web farm capabilities (on page 4).

After you select the checkbox, the installation checks the database to see if a primary Job
Scheduler has been specified. Additional options appear, depending on whether you are installing
the first or second (or higher) server.

e If this installation is the first server in the web farm, the primary Job Scheduler has not been
set yet. The installation automatically sets the Job Scheduler service on the server computer
as the primary Job Scheduler. If you install additional application servers, you can change the
primary Job Scheduler during the installations.

e If this installation is the second or higher server in the web farm, the primary Job Scheduler
service has already been set, and the name of the computer that runs the primary Job
Scheduler appears. To change the primary Job Scheduler, select Make this server's Job
Scheduler the primary.
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14 Specity a password for the Job Service user.

Note: Make sure that the user password meets the requirements listed on the page.

15 Click Next.
The following page appears.

Central Designer Server - InstallShield Wizard

Dezigner System Uzer Password

Pleaze supply a pazzword for the Dezigner System Uger. }

The pazgword must meet the length requirement and satizfy at least bwo
of the following requirenents:

- Containz at least one letter and one number,
- Containz at least one non-alphanurneric character.
- Containz at least one upper-caze and one lower-caze letter,

_",_,—-—'—"'_'_—F-l--..._“_\_\_“

\ ™ |
1.l . Spstem User Pazsword: I
11. .—-;-_af|

r/;ld___.\_l.-« = i Cornfirrn Passwoard: I
\ L\ aE

Central Designer”™

16 Specify a password for the system user.

Note: Make sure that the user password meets the requirements listed on the page.

The Central Designer application installs the system user by default. You can configure the
lockout time for the system user separately from all other users. By default, this user is assigned
the superuser and DesignerAdministrator roles.

Note: The password that you specify for the system user is also used for the archiveimporter
user. For more information about this user, see the Administrator Guide.

17 Click Next.
The Network Parameters page appears.

18 In the Web server URL root ficld, type the server address to which requests will come (for example,
http:] | ABCServer ot htips:/ | ABCServer). If you enabled the Secure Sockets Layer (SSL), use A#ps.
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Note: When the application server is installed in an environment that includes a hardware
networking switch, the URL that you type for the Web server URL root field must match the
URL that the networking switch uses to address the application server. For more
information, see Hardware networking switches (on page 23).

As you type in the Web server URL root field, the Public server URL root field is automatically
updated with the same value. If you edit the value in the Public server URL root field, the field is
no longer updated automatically when the Web server URL root field is updated.

19 Optionally, you can secure (encrypt and prevent tampering of) communications by using a
Secure Sockets Layer (SSL). For more information, see Securing communication with Secure
Sockets Layer (SSL) (on page 69).

20 Optionally, if the application server computer is behind a proxy that rewrites the request URLs,
in the Public server URL root field, type the address that the client computer uses to access the
application server (the public address of the server computer as seen by the client computer).
This address will be typed as the address of the server computer during installation of the client
applications.

If the value for the Public server URL root field does not need to be different from the Web server
URL root field, make sure that the values in both fields match.

21 Specity the certificate to use to sign web service authorizations:
a  Click Choose Certificate.
The Choose Certificate dialog box appears.
b Select a certificate.
¢ Click oK.

The Issued to, Issuer, Expiration, and Friendly name fields are populated.

Note: On each Central Designer application server, an administrator must install the
certificate that is used for sighing web service authorizations to the LOCAL_MACHINE\MY
store.The Central Designer installation process grants Full Control to access the certificate
private keys to the IIS AppPool\DefaultAppPool user and the NETWORK SERVICE user.

If a user other than the IIS AppPool\DefaultAppPool user is running the DefaultAppPool
application pool, you must grant the user Full Control to access the private keys, or the user
is unable to sign using the certificates. For more information, see /Installing certificates for
signing web service authorizations and deployment packages (on page 14).

22 1If the Central Designer application setrver is outside the network of the InForm application
server. Specify the proxy URL or script used by the Central Designer application server to
communicate with the InForm server during automated deployment:

e In the Proxy URL field, type the web address for the proxy server.

e In the Proxy Script ficld, type the web address for the proxy configuration script.
23 Click Next.

The Client Installation Configuration page appears.
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24 In the Environment Name field, type the name for your Central Designer instance.

The environment name appears on the web page to which you navigate to start the Central
Designer application.

25 Click Next.
The InForm Deployment page appears.

26 Specify the certificate to use to sign deployment packages and InForm web service
authorizations:

a  Click Choose Certificate.

The Choose Certificate dialog box appears.
b Select a certificate.
c Click oK.

The Issued to, Issuer, Expiration, and Friendly name fields are populated.

Note: For studies hosted by Oracle Cloud for Industry, the certificate must be issued by a
trusted commercial Certificate Authority.

27 Click Next.
The Start Copying Files page appears.

28 Review the installation settings. To change any settings, click Back. If you are satisfied with the
settings, click Next.

The installation begins. The Setup Status page appears, showing the status of the installation.
When the installation is complete, the InstallShield Wizard Complete page appears.
29 Click Finish.

Note: If the IIS worker process is running under any user other than NETWORK SERVICE or IIS
AppPool\DefaultAppPool, you must grant the user read permission to the
HKEY_LOCAL_MACHINE\SOFTWARE\OracleHS\CentralDesigner registry key after the installation.

Performing a silent installation

To create a setup.iss response file that contains all the installation parameters:

1 Inacommand prompt window, type the path of the Central Designer setup.exe program
followed by /t to run the installation in record mode.

The InstallShield Wizard appears.
2 Follow the wizard steps.

3 When you reach the Start Copying Files page, the setup.iss file is created in the Windows
directory (by default C:\Windows).

To perform a silent installation:

1 Copy the setup.iss file to the same directory as the Central Designer setup.exe program.

2 Inacommand prompt window, type the path of the setup.exe program followed by /s.
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The silent installation is performed.

Verifying the installation of the application server

1 Verity that the job service is installed and running:
a  Open the Control Panel.
b  Open Administrative Tools > Services.
¢ Verify that the Oracle Central Designer Job Scheduler service exists and is running.

2 Verify that the Web site has been added to the Internet Information Services (IIS) Manager
directory:

a  Open the Control Panel.
b Open Administrative Tools > Computer Management.

C Open Services and Applications > Internet Information Services (1IS) Manager > Web Sites >
Default Web Site. Verify that CentralDesigner is listed in the virtual directories.

3 Review the installer.log file. This log contains messages that were generated during installation. It
is available in the following location:

\Program Files\Oracle Health Sciences\Central Designer

Uninstalling the application server

Note: For Central Designer environments that run on the Windows 7 or Windows 2008 operating
system, stop the job scheduler and IIS services before you perform this procedure.

1 Open Control Panel > Add or Remove Programs.

2 Select Central Designer Server, and click Change/Remove.
A confirmation dialog box appears.

3 Click Yes.
The Setup Status page appears, informing you of the status of the uninstall.
The Uninstall Complete page appears.

4 Click Finish.

5 Delete the Central Designer directory.
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Starting the Central Designer client application

46

The client applications are ClickOnce applications, and you do not need to install them to start them,
as you would for applications using a traditional Windows installer.

1 Navigate to the following address:
http:/ / <server name> / CentralDesignerInstall

where <server name> is the name of the application server computer.

2 Click the Start Central Designer Client link.

The application files are downloaded to a cache and the application is installed. The installation
might take some time.

After the installation is complete, the application opens, and you can log on.
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Starting the Central Desigher Administrator client
application

The client applications are ClickOnce applications, and you do not need to install them to start them,
as you would for applications using a traditional Windows installer.
1 Navigate to the following address:
http:/ / <server name> / CentralDesignerInstall
where <server name> is the name of the application server computer.

2 Click the Start Central Designer Administrator link.

The application files are downloaded to a cache and the application is installed. The installation
might take some time.

After the installation is complete, the application opens, and you can log on.
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About upgrading the application server

50

Use these instructions to upgrade to this release from any previous release.

When you upgrade, you must:

e  Choose whether to update the existing database or create a new database.

Caution: Unless you choose the update option, your existing database will be deleted.

e Provide the database and user parameters that you entered when you created the new database
and database user.
Time considerations

Because the upgrade updates every study in the database, upgrading from an earlier release could take
some time, so plan your upgrade carefully. For example, Oracle expects that upgrading a database
with 150 studies could take 10 - 15 hours or longer.
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Checklist—Planning an upgrade

M Task Information

a1 Export the Central Designer Caution: You must perform this step. If the
database user. upgrade is not successful, you might need to
restore the database in order to attempt to install
again.

Depending on the size of the database, this process
could take several houts.

Note: To export a user with the following
information:

e User name—designer
e Database—db1_devl
Use the following command:

exp designer@db1_devl file=file_to_export.dmp
buffer=99999

Note: When you execute this command, you are
prompted for the user password.

a2 If you are migrating to a new To import a database user into the destination
database, import the database user  database server with the following information:
into the destination database server.

User name—designer
e Database—dbl_devl

Use the following command:

imp designer@db1_dev1 fromuser=designer
touser=designer file=file_to_export.dmp

Note: When you execute this command, you are
prompted for the user password.

O 3  Make sure that the Cursor Sharing ~ Configuring the Cursor Shating setting for a
setting for the database instance is ~ database instance (on page 30).
set propetly.

U 4  Make sure that the following services If the services are not running, the installation fails.

are running: ) )
The IIS Admin Service does not have to run for

e IIS Admin Service the duration of the installation. However, you must
e World Wide Web Publishing start it bef(?re you click the Next button on the
Service Copying Files screen.

Note: Do not use the iisreset command from the
MMC or a command prompt after the installation
or upgrade completes, or the IIS settings that were
set by the installer are lost. Instead, use the net
start command to start the services.
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M Task Information

U 5  Configure the application server for ~Configuring the application server for optimal
optimal performance. performance (on page 24).

ao Unlock statistics for specific tables.  Unlock statistics for the following tables:

IC_OBJECT
IC_OBJECT_REVISIONS
IC_OBJECT_BACK_REFERENCES
IC_OBJECT_FORWARD_REFERENCES
IC_BLUEPRINT_OBJECT_MAP

The upgrade process drops non-primary key
indexes on the tables affected by the upgrade and
recreates the indexes at the end of the process. If
the index was originally defined with the
COMPUTE STATISTICS clause, the recreation
also attempts to COMPUTE STATISTICS. 1f
statistics are locked, this process fails.

a7 Make sure that: These settings are necessaty for a successful

e The database upgrade.

UNDO_MANAGEMENT
initialization parameter is set to

AUTO.

e The UNDO and TEMP
tablespaces ate set to
autoextend.

a 8 If you added any new indexes to the After the upgrade is finished, you can add the
database, you must drop them indexes back.
before upgrading to ensure that they
do not cause conflicts with new
indexes that have been added to the
product.

O 9  Ifyouupgrade from release 2.0 or  Installing certificates for signing web service
2.0.1, install a certificate for signing  authorizations and deployment packages (on
deployment packages and InForm ~ page 14).
web service authotizations.

O 10 Ifyouupgrade from a release prior  Installing certificates for signing web service
to Central Designer 2.0: authotizations and deployment packages (on

14).
e Install a certificate for signing page 14)

web setrvice authorizations.

e Install a certificate for signing
deployment packages and
InForm web service
authorizations.
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M Task Information

O 11  If necessaty, install the root Installing root and intermediate certificates (on
certificate and intermediate page 17).
certificate or certificates, and install
the main certificate as the root
certificate.

Installing the main certificate as the root
certificate (on page 19).

U 12 Export custom reports definitions  Upgrading custom reports definitions (on page
from the Central Designer 59).
Administrator application.

O 13  Update data mappings with the Updating data mappings with
PhysicalMappingType property set  PhysicalMapping Type set to All (on page 506).
to All

O 14 (Recommended) Run the A validation check produces an error if a unit name

DetectStudiesWithUnitsWithSpac contains a space.
es.sql script to determine if any

di cai . b Running the
Studlies contain unit names wit DetectStudies WithUnitsWithSpaces.sql script
spaces.
(on page 54).

O 15 Ifyou upgrade to this release from a Running the
release prior to Central Designer 2.0, DetectMisconnectedGlobalConditions.sql
run the sctipt (on page 55).
DetectMisconnectedGlobalCondi
tions.sql script to identify errors in
the way global conditions are
referenced by study objects in a
study workflow.

U 16 Ifyouupgrade from a release prior  Running the DetectlnvalidCodeListItems.sql
to Central Designer 2.0, run the script (on page 55).
DetectInvalidCodeListItems.sql
script to identify codelist items of
types that are incompatible with the
type of their parent codelist.

Q 17  (Optional) If you upgrade to this Running the TestForOverflow.sql script (on
release from a release prior to page 506).
Central Designer 2.0, run the
TestForOverflow.sql script to
identify values that exceed 1000
characters in certain columns and
need to be truncated.

U 18 Run the application server Upgrading the application server (on page 60).
installation to upgrade the
application server.

U 19 Ifyou dropped indexes from your ~ No additional information.
database before upgrading, add them
back in after you finish upgrading.
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M Task Information

U 20 If the IIS worker process is running  No additional information.
under any user other than
NETWORK SERVICE ot IIS
AppPool\DefaultAppPool, you
must grant the user read permission
to the
HKEY_LOCAL_MACHINE\SOF
TWARE\OracleHS\ CentralDesigne
r registry key after you upgrade the
Central Designer application server.

O 21 After you upgrade the Central Upgrading user-defined functions (on page 57).
Designer application server,
recompile user-defined functions
and sign and secure user-defined
function assemblies as needed.

O 22 Re-import custom reports Upgrading custom reports definitions (on page
definitions. 59).

O 23  If you upgrade to this release from  No additional information.
release 2.0 or 2.0.1, recompile all
user-defined function assemblies to
reference the latest version of
Oracle.Designer.ExternalFunctions.
dll (found in the Central
Designer\bin folder of the
installation directory) and re-import
them into any study or library that
contains function objects that
reference the assemblies.

O 24  Setupan SMTP server for Setting up an SMTP server for automated
automated deployment notifications. deployment notifications (on page 74).

O 25 If the web setvice authorization and  Updating certificates without reinstalling the
deployment authorization certificates Central Designer software (on page 67).
have expired, upgrade them.

Note: If the certificates are current,
you can skip this step.

O 26 Inform users that they can resume  Starting the Central Designer client
using the client applications. application (on page 40).

Starting the Central Designer Administrator
client application (on page 47).

Running the DetectStudiesWithUnitsWithSpaces.sql script

A SQL script called DetectStudiesWithUnitsWithSpaces.sql generates a report that identifies the
unit names with spaces and the study projects that contain unit names with spaces. Oracle
recommends that you run this script because a validation check produces an error if a unit name
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contains a space.

Run the script before upgrading the application server. If the script finds units with spaces and study
projects that use the units, perform the following steps:

1 Inany affected study, run validation to determine the items that refer to the units with spaces in
their names.

2 Modify the units file to remove the spaces from the unit names that appear in the output file.

3 Using Control Panel > Administrative Tools > Services, restart the Job Scheduler service (Oracle
Central Designer Job Scheduler).

4 Restart the client applications.
5 In any affected study, modify the items to use the unit names that do not contain spaces.

The script and a readme file (DetectStudiesWithUnitsWithSpaces.Readme) are available on the
product ZIP file in the InstallSupport directory.

Running the DetectMisconnectedGlobalConditions.sql script

In releases of the Central Designer application prior to release 2.0, in certain scenarios, global
conditions were incorrectly removed from study objects in study workflow. Run the
DetectMisconnectedGlobalConditions.sql script before upgrading the application server from a
release prior to 2.0 to detect global conditions that are not connected correctly to study objects in the
study workflow..

The script and a readme file (DetectMisconnectedGlobalConditions.Readme) are available on the
product ZIP file in the InstallSupport directory.

Running the DetectlnvalidCodeListltems.sql script

To be used in a rule, a codelist item must have the same data type as its parent codelist. If the data
types do not match, when you upgrade from a release prior to 2.0, the data types of the codelist items
are changed to the data types of their parent codelists. Changes in data type could have an impact on
study reporting database extracts when new Central Designer 2.1 deployments are executed.

A SQL script called DetectInvalidCodeListItems.sql generates a report that identifies codelist
items of types that are incompatible with the type of their parent codelist.

Run the script before upgrading the application server to assess the impact of data type changes on
studies that are upgraded. The script and a readme file (DetectlnvalidCodeListltems.Readme) are
available on the product ZIP file in the InstallSupport directory.
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Running the TestForOverflow.sql script

The TestForOverflow.sql script checks whether any value in the following columns is more than
1000 characters:

e IC_APPROVALMEANING.MEANINGNAME

e IC_APPROVALPOLICY.POLICYNAME

e IC_BASELINE.DESCRIPTION

e IC_COLLABORATIONOBJECT.SUMMARY

e IC_DEPLOYMENT.DESCRIPTION

e IC_FILESTORE.DESCRIPTION

e IC_VERBATIM_TYPE.VERBATIM_TYPE_DESCRIPTION
e IC_VERBATIM_TYPE.VERBATIM_TYPE_NAME

Run this script before upgrading the application server from a release prior to 2.0 . Truncate any
values that exceed 1000 characters before upgrading to the current release of the Central Designer
software.

The script is available on the product ZIP file in the InstallSupport directory.

Updating data mappings with PhysicalMappingType set to All

56

If a study contains a data mapping for which PhysicalMappingType is set to All and you use the data
mapping for both CDD and CIS, you must use the existing data mapping for one purpose only and
create a new data mapping for the other purpose.

Because creating a new database for CDD is simpler, Oracle recommends using the existing data
mapping for CIS and creating a new CDD data mapping and, if necessary, a new CDD database.

To modify the existing data mapping and create a new data mapping:

1 To determine whether your database contains any data mappings for which
PhysicalMappingType is set to All, before you upgrade, run the
DetectStudiesWithPhysicalMappingAll.sql script, which is available in the InstallSupport
directory on the product ZIP file.

2 For each data mapping for which PhycialMappingType is set to All, change the
PhysicalMappingType property of the data mapping from All to CIS.

The CIS data mapping continues to work as expected, and you are able to perform resynchs with
the CIS database.

3 Create a new CDD data mapping.

4 Copy the data sets in the CIS data mapping and paste them into the CDD data mapping.
The RefNames of the data sets and their data series are appended with _1.

5 If you deployed the study to the InForm application in an earlier release:

e Remove the _1 appended text from the aliases of the data sets and data series in the CDD
data mapping,.
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Caution: Do not update the RefNames, or you will not be able to perform a CIS resynch
after you deploy again to the InForm application.

6 Deploy the study to the InForm application.
7 Set up the new CDD database.

Note: After you create a new data mapping for either CDD or CIS, you cannot perform a resynch
with either the CDD or CIS database. You must create a new database for the new data mapping

type.

Upgrading user-defined functions

If a study contains a user-defined function that performs a task such as reading from or writing to a
file, accessing the database or the registry, making web service calls, running an external application,
sending an email, or using the event log directly, the assembly for the user-defined function must be
signed with a strong named signature that is valid and trusted in order for the function to work in the
InForm application.

To ensure that the user-defined functions and assemblies in your study projects and library projects
are secure, Oracle recommends that you sign user-defined function assemblies using a strong named,
valid and trusted signature.

Note: For InForm studies hosted by Oracle Cloud for Industry, all user-defined function assemblies
that require signing must be signed by Oracle Services prior to deployment.

In addition, user-defined functions that use the Log4Net application must use the Central Designer
Log4Net wrapper or must be recompiled to use Log4Net version 1.2.10.0. For more information
about the Log4Net wrapper, see the Rules Reference Guide.

Identifying user-defined functions and assemblies to update

To identify study and library projects that contain user-defined functions that need to be recompiled
or assemblies that need to be secured and signed, run the ValidateCustomFunctionAssemblies.exe
file after you upgrade the application server.

Note: User-defined functions that refer to an unsupported Log4Net version must be recompiled or
reconfigured to use the Central Designer Log4Net wrapper. For more information about the
Log4Net wrapper, see the Rules Reference Guide.

1 Locate the ValidateCustomFunctionAssemblies.exe file on the product ZIP file, in the
InstallSupport directory.

2 Copy the file and paste it to the bin folder in the directory in which you installed the Central
Designer application.

3 Inacommand prompt window, type one of the following:

e To view assemblies that reference the wrong Log4Net version, type
ValidateCustomFunctionAssemblies L.

e To view assemblies with missing, invalid or untrusted signatures, type
ValidateCustomFunctionAssemblies S.

e To view assemblies with invalid references to ExternalFunctions.dll, type
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ValidateCustomFunctionAssemblies I.
e To view all of the above, type ValidateCustomFunctionAssemblies.
4 When prompted, specify the following:
e System username—system

e System password—Password that you specified on the Database System User Password
page during the Central Designer application installation.

e Path for the output file, including file name—I.ocation in which to save the output file
that lists the study and library projects with user-defined functions that must be updated. For
example, C:\Output\ValidateAssemblies.txt.

A list of user-defined functions is generated.

Securing and signing user-defined function assemblies

To secure and sign assemblies for user-defined functions, create a key pair, extract the public key,
and place the key file:

e On the Central Designer application server. If you are using the Central Designer application in a
web farm environment, place the key on all the application servers in the web farm.

e On all the InForm application servers where studies using the assembly will be deployed.

Note: For InForm studies hosted by Oracle Cloud for Industry, all user-defined function assemblies

that require signing must be signed by Oracle Services prior to deployment.

For specific instructions and information about creating and signing an assembly with a strong
named signature, see the Rules Reference Guide and the documentation for the tool that you use to
create the strong name.

Recompiling user-defined function assemblies

The names of assemblies for user-defined functions have been changed as follows.

Name in releases prior to 2.0 Name in releases 2.0 and later

PhaseForward.Designer. ExternalFunctions.dll ~ Oracle.Designer.ExternalFFunctions.dll

PhaseForward.Designer.PrebuiltFunctions.dll Oracle.Designer.PrebuiltFunctions.dll

The name change requires that you recompile all user-defined function assemblies after upgrading
from a Central Designer release prior to 2.0.

1 When recompiling, replace references to PhaseForward.Designer. ExternalFFunctions.dll with
Oracle.Designer.ExternalFunctions.dll.

2 Additionally, recompile assemblies that reference PhaseForward.Designer.PrebuiltFunctions.dll,
replacing the reference with Oracle.Designer.PrebuiltFunctions.dll.

3 Import each recompiled function assembly into any study or library that contains function
objects that reference the assembly.

After you import, any other studies or libraries use the new versions of the assemblies when
validating and creating deployment packages.
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Upgrading custom reports definitions

If you have defined custom reports, you must export the XML report definition file before
performing an upgrade. After the upgrade, you must re-import the report definitions.

1

In the Central Designer Administrator application, export the XML report definition file. For
more information, see the _Administrator Guide.

Upgrade the Central Designer software.

Modify the XML file exported in the first step, replacing any instances of
assembly=""PhaseForward.Designer.ServerCore' with
assembly="'Oracle.Designer.ServerCore".

Re-import the report definitions on each Central Designer application server:

a  Copy the updated custom reports definition file to the following location, overwriting the
existing file:

<designer_root>\
DBSchema\_Last\Datainstal ler\DesignerReportsDefinitions.xml

where <designer_root> is the root directory of the Central Designer installation.
b  From the <designer_root>\bin directory, run the UpdateReports.bat file.

The UpdateReports.bat file updates the definitions of the custom reports in the database.
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Upgrading the application server

1 Export the Central Designer database user.

Caution: You must perform this step. If the upgrade is not successful, you might need to
restore the database in order to attempt to install again.

To export a user with the following information:
e User name—designer
e Database—dbl devl

Use the following command:

exp designer@dbl_devl file=file_to_export._dmp buffer=99999

Note: When you execute this command, you are prompted for the user password.

2 Locate the setup.exe program.

The setup.exe program is available the Oracle Software Delivery Cloud
(https://edelivery.oracle.com).

3 Double-click setup.exe.
The InstallShield Wizard prepares to install the application server.
You are prompted to delete the previous installation of the application server.
4 Click Yes.
A welcome page appears.
5  Click Next.
A message about the upgrade appears.
6 Review the message, and click Continue.
The Customer Information page appeats.

7 Fill in the fields. You should provide the same values that were entered during the initial
installation of the application server.

e User Name—Your name.
e Company Name—The name of your company.

e Company URL—A unique identifier for your company data, typically your company URL
(for example, http://www.mycompany.com).

Note: You must enter the company URL that you specified during the original Central
Designer installation.

8  Click Next.
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The following page appears.

Central Designer Server - InstallShield Wizard

Setup Type
Select the zetup twpe that best suits your needs.

Click the type of setup vou prefer,

An existing database will be updated to the new schema.

O
\ - !,|,---,i " Mew Database
\ I = The existing databasze user will be dropped and recreated. resulting in the loss of &l
Vet data.
¢\ |
\ o el
- f’j o 13
h,,‘__u.__%.- .

Destination Folder
(C:\...\Drau:le Health Sciencez\Central D esignert, Browse. ..

CentralDesigner™

9  Select Update.

10 In the Destination Folder arca, specify the destination location for the installation. By default, the
installation wizard installs the software in the <PROGRAMFIILESDIR>\ Oracle\ Central Designer\
folder, where <PROGRAMFILESDIR> is a system setting that is usually C:/Program Files. If
you want to install to another location, click Browse, and select the location. You must choose
the location to which the application server was initially installed.

Note: The instructions, paths, and Start Menu navigation in this guide assume you are installing
to the default location. Oracle strongly recommends that you install the software to the default
location.

11 Click Next.
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The following page appears.
Central Designer Server - Installshield Wizard E2

Database Parameters

Flease supply the database parameters with which you will &

Choozing "'Create Mew Databage' will drop any exigting user of the game name, and
create a new user with the name provided.

Database Uszer Mame: ||

— l’““*mi Database Password: I

\ | ] Oracle THS Mame: I
i J,a-n!"." ol 1

(T i;)""'/': Database Administiatar User N
\ - IR k trak :

- ’ ‘) atabase Adminiztratar User Mame I
\"L\,\ /___.

o Databaze Administrator Password: I

¥ Create Mew Databaze Advanced...

Cancel

Central Designer”

Because you are upgrading, the Create New Database checkbox is grayed out.

12 Fill in the following fields. You must provide the values that you created when you set the

Oracle TNS name (typically set when you create the database) and the database user name and
password (set when you created the Central Designer user in the new database).

Field Database

Database User Name The Oracle user name for the Central Designer database user.

Note: The password must not contain any of the following
characters: @ & () [or].

Database Password The password for the Central Designer database user.

Oracle TNS Name Alias from TNSnames.ora file. This TNS name is used to
connect to the Central Designer database instance.

Database Administrator User  The Oracle user account for the database administrator.
Name . .
This account is used to create the database user.
If you provide a database administrator user name different
from the one in your original database, you must type the new
user name.

Note: The user name cannot be a SYSDBA user account.
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Field Database
Database Administrator The password for the database administrator.
Password

If you provide a database administrator password different
from the one in your original database, you must type the new
password.

Note: The password must not contain any of the following
characters: @ & () [ot].

Note: Do not use Oracle reserved words for user names or passwords.

13 Click Next.

The following page appears.

Central Designer Server - InstallShield Wizard

Central Designer Jobh Service
Please supply the parameters for the Central Des

The Job Service peiforms background processing and requies an
unused TCPAP port rumber. In most cases, the default value wil sulfice

TCPAP Port Numbs: 53000

¥ Make this server part of a web faim

14

15

Central Designer 2.1.1.1

et B
) e A Primaty Job Scheduler has been found on server STEIN-PC
l'\ = '_Z"~ W Make this server's Job Scheduler the primary
Ao ﬁl &
o
r\ \L»'J,{g_', v W Please supply a password for the Job Service user. The password must
S ~;:j:" gl be the same on 8 servers in & web fam, meet the length requinement,
o A and satisfy st least two of the following requilements

- Conlains al least one letter and one number
- Containg at least one non-alphanumenic character.
« Contains at least one upper-case and one lower-case lelter

Password:

Confum Password

Type the TCP/IP port number that the job setvice will use. The port must be unused. In most
cases, you can use the default value.

Central Designer™

Cancel

Note: If you are installing the server as part of a web farm, all of the servers can use the
same port number, as long as the port is unused.

Optionally, to configure the Central Designer software to support a web farm, select Make this
server part of a web farm. A web farm setup allows you to install the Central Designer server
software on multiple application server computers. The installation is the same for all of the
servers, and you must select this option for all servers in the web farm. For more information,

sce Web farm capabilities (on page 4).
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17

18

19

20
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After you select the checkbox, the installation checks the database to see if a primary Job
Scheduler has been specified. Additional options appear, depending on whether you are installing
the first or second (or higher) server.

e If this installation is the first server in the web farm, the primary Job Scheduler has not been
set yet. The installation automatically sets the Job Scheduler service on the server computer
as the primary Job Scheduler. If you install additional application servers, you can change the
primary Job Scheduler during the installations.

e  If this installation is the second or higher server in the web farm, the primary Job Scheduler
service has already been set, and the name of the computer that runs the primary Job
Scheduler appears. To change the primary Job Scheduler, select Make this server's Job
Scheduler the primary.

Specify a password for the Job Service user.

Note: Make sure that the user password meets the requirements listed on the page.

Click Next.
The Network Parameters page appears.

In the Web server URL root ficld, type the address of the server on its local network (the server
address to which requests will come, for example, b#p:/ | ABCServer ot https:/ | ABCServer). 1f you
enabled the Secure SocketsLayer (SSL), use A##ps. Unless you made changes that would cause the
server address to have changed, use the address that you typed for the last installation.

Note: When the application server is installed in an environment that includes a hardware
networking switch, the URL that you type for the Web server URL root field must match the
URL that the networking switch uses to address the application server.

As you type in the Web server URL root field, the Public server URL root field is automatically
updated with the same value. If you edit the value in the Public server URL root field, the field is
no longer updated automatically when the Web server URL root field is updated.

Optionally, you can secure (encrypt and prevent tampering of) communications by using a
Secure Sockets Layer (SSL). For more information, see Securing communication with Secure
Sockets Layer (SSL) (on page 69).

Optionally, if the application server computer is behind a proxy that rewrites the request URLs,
in the Public server URL root field, type the address that the client computer uses to access the
application server (the public address of the server computer as seen by the client computet).
This address will be typed as the address of the server computer during installation of the client
applications.

If the value for the Public server URL root field does not need to be different from the Web server
URL root field, make sure that the values in both fields match.

Specify the certificate to use to sign web service authorizations:
a  Click Choose Certificate.
The Choose Certificate dialog box appears.
b Select a certificate.
¢ Click oK.

The Issued to, Issuer, Expiration, and Friendly name fields are populated.
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Note: On each Central Designer application server, an administrator must install the
certificate that is used for sighing web service authorizations to the LOCAL_MACHINE\MY
store.The Central Designer installation process grants Full Control to access the certificate
private keys to the IIS AppPool\DefaultAppPool user and the NETWORK SERVICE user.

If a user other than the 1IS AppPool\DefaultAppPool user is running the DefaultAppPool
application pool, you must grant the user Full Control to access the private keys, or the user
is unable to sign using the certificates. For more information, see Installing certificates for
signing web service authorizations and deployment packages (on page 14).

If the Central Designer application server is outside the network of the InForm application
server, specify the proxy URL or script used by the Central Designer application server to
communicate with the InForm server during automated deployment:

e In the Proxy URL ficld, type the web address for the proxy server.

e In the Proxy Script ficld, type the web address for the proxy configuration script.
Click Next.

The Client Installation Configuration page appears.

In the Environment Name field, type the name for your Central Designer instance.

The environment name appears on the web page to which you navigate to start the Central
Designer application.

Click Next.
The InForm Deployment page appears.

Specify the certificate to use to sign deployment packages and InForm web service
authorizations:

a  Click Choose Certificate.

The Choose Certificate dialog box appeats.
b Select a certificate.
c Click oK.

The Issued to, Issuer, Expiration, and Friendly name fields are populated.

Note: For studies hosted by Oracle Cloud for Industry, the certificate must be issued by a

trusted commercial Certificate Authority.

Click Next.
The Start Copying Files page appears.

Review the installation settings. To change any settings, click Back. If you are satisfied with the
settings, click Next.

The installation begins. The Setup Status page appears, showing the status of the installation.
When the installation is complete, the InstallShield Wizard Complete page appears.

Click Finish.
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Upgrading the client applications

Because the client applications are ClickOnce applications, you do not need to upgrade them. Simply
start the applications as you always do. For more information, see:

e Starting the Central Designer client application (on page 406).

o  Starting the Central Designer Administrator client application (on page 47).
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Updating certificates without reinstalling the Central
Designer software

When the web service authorization and deployment authorization certificates expire, you can install
renewed certificates without reinstalling the Central Designer software.

The procedure updates the configuration files of both the web server and the job scheduler with the
certificates you select and adds access to the private keys for the certificates to NETWORK
SERVICE and DefaultAppPool users.

1
2
3

Open a command window.

Navigate to the <Designer Install Dir>\Dbin directory.

Type Oracle.Designer.CertificateManager.exe and press Enter.

A prompt to select the web services authorization certificate appears.
Click OK.

The Certificate Browser appears.

Select the web services certificate, and click OK.

A prompt to select the for deployment authorization certificate appeats.
Click OK.

The Certificate Browser appears.

Select the deployment authorization certificate, and click OK.

Messages appear that indicate the progress of the tool.
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Securing communication with Secure

Sockets Layer (SSL)

In this chapter
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About communication security

70

You can secure (encrypt and prevent tampering of) communications by using Secure Sockets Layer
(SSL) and, optionally, by signing authorization information issued by the application server. You have

the following options for securing communication between the application server computer and the
client computers.

e SSL—With Secure Socket Layers, all web traffic between the client applications and the web
server is encrypted and tamper resistant. If you enable SSL, the address of the application server
begins with HTTPS instead of HTTP. You configure SSL through IIS using an X.509 certificate.
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About Secure Sockets Layer (SSL)

To encrypt the transmission of data between the application server and the client computers, you
must enable a Secure Sockets Layer (SSL) and obtain an X.509 certificate using your company

certificate store or a third party application. Oracle recommends that you enable SSL. You configure
SSL using IIS.

For more information about enabling SSL, refer to the Microsoft documentation about configuring
SSL for your version of 1IS.

Note: When you install the client applications, type the address of the application server,
including the correct protocol (either HTTP or HTTPS). If you enable SSL, the address of the
application server must begin with HTTPS.
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Getting started

In this chapter
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Creating a sample deployment package using the sample study .........ccceeevivnivniinicnicninn.
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Getting started

Setting up an SMTP server for automated deployment email notifications

You must install and configure an SMTP server to enable the Central Designer web site to send
email notifications for the following events:

e Deployment request is created, approved, or rejected.
e Deployment is started.

e Deployment is completed successfully or with failures.
e Deployment request is cancelled.

¢ Deployment is cancelled.

1 To install and configure an SMTP server, refer to the Microsoft documentation for your
operating system.

You can perform this step before you install the Central Designer application server.

2 Verify that you can send email from the SMTP server. Refer to the Microsoft documentation for
details.

3 After you install the Central Designer application server, you must configure the Central
Designer web site to send email. From IIS Manager, configure SMTP email for the Central
Designer web site.

e Seta dummy address as the email address from which messages are sent (for example,

do.not.reply_designer@mweberf-nel).

e Configure SMTP email for the Central Designer web site to use the same authentication
method as was configured for the SMTP server.

e For more information, refer to the Microsoft documentation about configuring SMTP for
your version of IIS.

Note: Every time you install the Central Designer application, you must reconfigure the SMTP
email settings for the Central Designer web site.

Logging on to the Central Designer Administrator application

An administrator must log on to the Central Designer Administrator application and create user
accounts before other users can log on and use the Central Designer application.

1 Navigate to the following address:
http:/ / <server name> / CentralDesignerInstall
where <server name> is the name of the application server computer.

2 Click the Start Central Designer Administrator link.
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A dialog box appears, indicating that the application is starting.
The logon window appears.

3 Type the following information:
e User name—system.
e Password—Password you set during the server installation.
The application opens.

Oracle recommends:

e Changing the password of the system account after you log on to the Central Designer
Administrator application.

For more information, see Changing your password in the Central Designer Administrator
application (on page 75).

e Deactivating or terminating the system user after you create and activate users.

For more information, see the Adwministrator Guide.

Changing your password in the Central Designer Administrator application

1 In the Users view, right-click a user name, and
o Select Change Password.
or
Press Ctrl+P.
A dialog box appears.

2 Type the new password twice for confirmation, and click OK.

Logging on to the Central Designer application

You can log on after an administrator creates a user account for you.

1 Navigate to the following address:
http:/ / <server name> / CentralDesignerInstall
where <server name> is the name of the application server computer.
2 Click the Start Central Designer Client link.
A dialog box appears, indicating that the application is starting.
The logon window appears.

3 Type your User name and Password, and click Log On.

Note: When a user account is created in the Central Designer Administrator application, the
administrator can require the user to change the password after logging on the first time.
You might be prompted to change your password.

Central Designer 2.1.1.1 75



Chapter 8 Gettin

g started

Changing your password in the Central Designer application

Logging off

If the administrator who created your user account requires that you change your password, you are
prompted when you start the application to change your password.

To change your password because it is required:

1 Log on to the Central Designer application.
The Change Password dialog box appears.
2 Type your old and new passwords. You must type your new password twice.
3 Click OK.
To change your password at any time after logging on:
1  Select File > Change Password.
The Change Password dialog box appears.
2 Type your old and new passwords. You must type your new password twice for confirmation.

3 Click OK.

e Select File > Exit.
If you have unsaved changes, you are prompted to save them.

You are logged off, and the application closes.

Overview of configuring the Central Designer software

76

In the Central Designer Administrator application, you create and manage administrative
components such as users, roles, locales, and security settings.

Some tasks in the Central Designer application cannot be performed until the administration
information is set up correctly in the Central Designer Administrator application.

Other types of administration, including administering studies and libraties, are performed in the
Central Designer application.
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Creating a sample deployment package using the sample

study

The Central Designer installation package contains a sample study and units file. You can import the
files into the Central Designer application and then deploy the sample study to the InForm
application using a manual deployment. Perform the following steps to create a sample deployment

package.
Step Task More information
1 Import the DesignerUnit.xml file into the Exporting and importing a units file
Central Designer Administrator application. This in the Adwinistrator Guide.
file updates custom units of measurement. The DesignerUnit.xml file is located in
the Central Designer installation
package in the InstallSupport\Sample
Trial folder.
2 Set up locales in the Central Designer Adding and removing a locale in the
Administrator application, and include the Administrator Guide.
following locales for the sample study:
e English (United States)
e Japanese (Japan)
e (Czech (Czech Republic)
e Spanish (Mexico)
3 Import the CSML for the sample study into a Importing study objects in the User
new study project. Guide.
The CSML for the sample study is
located in the Central Designer
installation package in the
InstallSupport\Sample Trial folder.
4 Add the locales from step 2 to the study. Choosing the supported locales for
a study in the InForm Design Guide.
5 Select all the dictionary types and all their Associating dictionary types with
verbatim types on the Coding tab. verbatim types for a study or library
in the InForm Design Guide.
6 Validate the study to create a baseline, and Validating a study and creating a
choose to ignore the warnings. baseline in the InForm Design Guide.
7 Create a deployment package. Creating a deployment package in
the InForm Design Guide.
8 Save the deployment package to the local Saving a deployment package to the

computer.

file system in the InForm Design Guide.
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Step Task More information

9 Copy the deployment package and the public key No additional information.
to a location that is accessible to the InForm
server.

10 Perform additional steps in the InForm InForm Installation Guide.

application to finish setting up the study.
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In this chapter
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Troubleshooting
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What should I do if an error occurs during the server installation?

Errors during server installation can be caused by several issues, including issues with the
database user name and with the installation of the Oracle database software.

To troubleshoot:
e Read the installer.]log file.

The installer.]log file contains information about the installation, including any errors that
occurred. The default location of the file on the application server computer is C:\Program
Files\Oracle Health Sciences\Central Designer.

e If the application server and database server are on the same computer, you must install the
Oracle Server software and Oracle Client software in the same home, or the Central
Designer server installation will not work.

What should I do if I cannot log on?

You might encounter issues when logging on if the URL that the client applications use does not
match one of the URL:s listed in the configuration files for Microsoft Web Services
Enhancements (WSE). You can configure the URL or URLSs in the Certificate Configuration
tool, and the URLSs in the configuration files are updated automatically.
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