2 Hardware and Software Requirements

This chapter describes the hardware and software requirements of Oracle Communications Data Model Add-ons:

Before you install Oracle Communications Data Model Add-ons, you must verify that all hardware and software requirements are met.

Supported Platforms

Oracle Communications Data Model Add-ons are supported on the following platforms. For each platform, the given operating system version or later versions are required:

  • Linux x86-64

    • Asianux Server 3 SP2

    • Oracle Linux 5 Update 2

    • Oracle Linux 5 Update 5 (with the Oracle Unbreakable Enterprise Kernel for Linux)

    • Red Hat Enterprise Linux 5 Update 2

    • Red Hat Enterprise Linux 5 Update 5 (with the Oracle Unbreakable Enterprise Kernel for Linux)

    • Red Hat Enterprise Linux 6

    • SUSE Linux Enterprise Server 10 SP2

    • SUSE Linux Enterprise Server 11

  • Oracle Solaris on SPARC (64-bit)

    • Oracle Solaris 10 U6 (5.10-2008.10)

    • Oracle Solaris 11 11/11 SPARC

  • Oracle Solaris on x86-64 (64-bit)

    • Oracle Solaris 10 U6 (5.10-2008.10)

    • Oracle Solaris 11 11/11 X86

  • IBM AIX on POWER Systems (64-bit)

    • AIX 6.1 TL 02 SP1 ("6100-02-01"), 64-bit kernel

    • AIX 7.1 TL 0 SP1 ("7100-00-01-1037"), 64-bit kernel

  • HP-UX Itanium 11.31

Hardware Requirements

The Oracle Database installation guide for your platform includes procedures for checking that your installation meets the hardware and operating system requirements for Oracle Database.

Additionally, for a complete installation of Oracle Communications Data Model Add-ons, the minimum hardware requirement is disk space of at least 10 GB.

Software Requirements

The minimum software requirements for Oracle Communications Data Model Add-ons are as follows:

Note:

The recommended patches and software versions are accurate as of product release. For the latest recommendations for database supported platforms, see https://support.oracle.com/.

Oracle Database Requirements

Oracle Communications Data Model Add-ons installation requires one of the following Oracle Database releases:

  • Oracle Database 12c Release 1 (12.1) Enterprise Edition (12.1.0.2 or later)

  • Oracle Database 11g Release 2 Enterprise Edition (11.2.0.4 or later)

Tip:

When you install the database ensure that the database character set is Unicode (AL32UTF8) to support multilanguage installations since Oracle Communications Data Model permits the installation of support for English and one other language.

Installation of the Oracle Communications Data Model Add-ons components requires the following options to the Oracle Database:

  • Oracle Partitioning

  • Oracle Online Analytical Processing (OLAP)

  • Oracle Data Mining

After you download and install the database, upgrade to the latest patch. Patches are available from My Oracle Support at the following location:

https://support.oracle.com

Oracle Business Intelligence Suite Enterprise Edition

You must have the Oracle Business Intelligence Suite Enterprise Edition installed before you can view and use the Oracle Communications Data Model Add-ons reports (Oracle Business Intelligence Suite Enterprise Edition is not required for the installation of the Oracle Communications Data Model Add-ons components and the installation of Oracle Communications Data Model Reports is valid without Oracle Business Intelligence Suite Enterprise Edition installed).

Oracle Business Intelligence Suite Enterprise Edition 11.1.1.7 or later can be downloaded from the "Oracle Business Intelligence 11g downloads" link on Oracle Technology Network at:

http://www.oracle.com/technetwork/middleware/bi-enterprise-edition/downloads/index.html

Installation instructions are included in the documentation.

Confirm that Oracle Business Intelligence Developer Client Tools Installer is Installed

Select the version of Oracle Business Intelligence Developer Client Tools Installer according to the version of Oracle Business Intelligence Suite Enterprise Edition. For example, if the version of Oracle Business Intelligence Suite Enterprise Edition is 11.1.1.7.0, then select Oracle Business Intelligence Developer Client Tools Installer version is 11.1.1.7.0.

For more information, see:

http://www.oracle.com/technetwork/middleware/bi-enterprise-edition/downloads/bus-intelligence-11g-165436.html

Oracle Data Integrator Enterprise Edition

If you plan to run either Oracle Communications BRM Adapter or Oracle Communications NCC Adapter, you must first install Oracle Data Integrator Enterprise Edition. Oracle Data Integrator Enterprise Edition is not required to install the Oracle Communications Data Model Add-ons. Oracle Data Integrator Enterprise Edition 11g (11.1.1.5.0) can be downloaded from Oracle Technology Network at:

http://www.oracle.com/technetwork/middleware/data-integrator/downloads/index.html

Installation instructions are included in the documentation.

Note:

When you install Oracle Data Integrator Enterprise Edition 11g, at the Step: Repository Configuration, choose the "Skip Repository Configuration" option.

For more information, see

http://www.oracle.com/technetwork/middleware/data-integrator/documentation/index.html

For more information on Oracle Communications Data Model Adapters, see Oracle Communications Data Model Adapters and Analytics User's Guide.

Oracle GoldenGate

If you install Application Adapters, using, installing, and configuring Oracle GoldenGate is optional depending on whether you want to use real-time feeds.

Oracle GoldenGate 11g (11.1.1.1.0) can be downloaded from Oracle Technology Network at:

http://www.oracle.com/technetwork/middleware/goldengate/downloads/index.html

Installation instructions are included in the documentation. For more information, see

http://www.oracle.com/technetwork/middleware/goldengate/documentation/index.html

For more information on Oracle Communications Data Model Adapters, see Oracle Communications Data Model Implementation and Operations Guide.