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Overview of this guide 
The Installation Guide describes how to install the software and configure the environment for the 
InForm application and Cognos 8 Business Intelligence software.  

After installing the software and configuring the environment, use the Study and Reporting Setup Guide 
for information about how to set up a study and the Reporting and Analysis module. 
 

Audience 
This guide is for database and system administrators who are responsible for installing and 
configuring the InForm software and the Cognos 8 Business Intelligence software. 
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Related information 

Documentation 
All documentation is available from the Oracle Software Delivery Cloud 
(https://edelivery.oracle.com) and the Download Center (https://extranet.phaseforward.com). 

 

 

Document Description 

Release Notes The Release Notes document describes enhancements introduced and 
problems fixed in the current release, upgrade considerations, release 
history, and other late-breaking information. 

Known Issues The Known Issues document provides detailed information about the 
known issues in this release, along with workarounds, if available. 

Note: The most current list of known issues is available on the 
Extranet. To sign in to the Extranet, go to 
https://extranet.phaseforward.com. 

Upgrade and Migration Guide The Upgrade and Migration Guide provides instructions for upgrading and 
migrating the InForm software and InForm Portal software to the 
current InForm release, and for upgrading the Cognos 8 Business 
Intelligence software for use with the Reporting and Analysis module. 
The guide also describes any changes and additions made to the 
database schema, MedML, and resource files. 

Secure Configuration Guide The Secure Configuration Guide provides an overview of the security 
features provided with the Oracle® Health Sciences InForm application, 
including details about the general principles of application security, 
and how to install, configure, and use the InForm application securely. 

Installation Guide The Installation Guide describes how to install the software and 
configure the environment for the InForm application and Cognos 8 
Business Intelligence software.  

Study and Reporting Setup 
Guide 

The Study and Reporting Setup Guide describes how to perform the tasks 
that are required to set up an InForm study and configure the 
Reporting and Analysis module for the study. 

User Guide The User Guide provides an overview of the InForm application 
including details on multilingual studies, how to navigate through the 
user interface, and how to use the application to accomplish typical 
tasks you perform while running a clinical study.  

This document is also available from the Documentation CD and the 
InForm user interface. 
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Document Description 

Reporting and Analysis Guide The Reporting and Analysis Guide provides an overview of the Reporting 
and Analysis module. It includes a brief overview of the Reporting and 
Analysis interface, illustrates how to access the Ad Hoc Reporting 
feature, and describes the study management and clinical data packages 
available for Reporting and Analysis. It also provides detailed 
descriptions of each standard report that is included with your 
installation. 

This document is also available from the Documentation CD. 

Reporting Database Schema 
Guide 

The Reporting Database Schema Guide describes the Reporting and 
Analysis database schema, and provides information on creating 
Reporting Database Extracts (RDEs). 

Portal Administration Guide The Portal Administration Guide provides step-by-step instructions for 
setting up the InForm Portal software, and configuring and managing 
the InForm Portal application. 

This document is also available from the Documentation CD. 

Utilities Guide The Utilities Guide provides information about and step-by-step 
instructions for using the following utilities: 

• PFConsole utility 

• MedML Installer utility 

• InForm Data Import utility 

• InForm Data Export utility 

• InForm Performance Monitor utility 

• InForm Report Folder Maintenance utility 

This guide also provides reference information for the MedML 
elements and scripting objects that are used to import and export data 
to and from the InForm application, as well as sample data import 
XML. 

This document is also available from the Documentation CD. 

MedML Installer utility 
online Help 

The MedML Installer utility online Help provides information about, 
and step-by-step instructions for using, the MedML Installer utility, 
which is used to load XML that defines study components into the 
InForm database. 

This guide also provides reference information for the MedML 
elements and scripting objects that are used to import and export data 
to and from the InForm application, as well as sample data import 
XML. 

This document is also available from the user interface. 
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Document Description 

InForm Data Export 
utility online Help 

The InForm Data Export utility online Help provides information 
about and step-by-step instructions for using the InForm Data Export 
utility, which is used to export data from the InForm application to the 
following output formats: 

• Customer-defined database (CDD). 

• Name value pairs. 

This document is also available from the user interface. 

InForm Data Import 
utility online Help 

The InForm Data Import utility online Help provides information 
about and step-by-step instructions for using the InForm Data Import 
utility, which is used to import data into the InForm application. 

This document is also available from the user interface. 
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If you need assistance 
Oracle customers have access to support through My Oracle Support. For information, visit 
http://www.oracle.com/pls/topic/lookup?ctx=acc&id=info, or if you are hearing impaired, visit 
http://www.oracle.com/pls/topic/lookup?ctx=acc&id=trs. 
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About the InForm software 
The InForm software is a data collection and study management application that uses a secure web 
browser to provide access to clinical study data and management of the clinical study process. Your 
user profile and rights determine which InForm features you can access. 

Use the InForm application to: 

• Screen and enroll subjects. 

• Enter and manage form, comment, and visit data. 

• Issue, answer, and close queries. 

• Source verify forms. 

• Freeze and lock forms. 

• Sign forms and case report books. 

• View study specific documentation. 

• Perform and view subject transfers. 

• Perform administrative tasks. 
 

About the Data Viewer 
The Data Viewer is a standard feature in the InForm application that provides Clinical Data 
Managers (CDMs) and other InForm users with a real-time overview of clinical study data across 
visits and sites. You can use the Data Viewer to facilitate the cleaning of data, to look for patterns in 
data, and to identify items that may be anomalies. 

Use the Data Viewer to: 

• Compare items on the same type of forms. 

• Compare two forms side-by-side. 

• Perform InForm actions on one or more forms, such as freezing, locking, and source verifying. 

• View and issue queries on clinical data. 

• Review form and item comments. 

• Export data and comments. 

• Use review states for custom review workflows. 

The Data Viewer is installed as part of the InForm software installation. To use the features in the 
Data Viewer, you must have access rights to the Data Viewer as well as rights to perform certain 
tasks. For details on the XML associated with the Data Viewer rights, see the Utilities Guide. 
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About the Reporting and Analysis module 
The Reporting and Analysis module is an optional part of the InForm application that provides a 
library of configurable reports, predefined reports, and ad hoc reporting and charting tools. Both 
clinical and operational data are available in real time. For more information, see the Reporting and 
Analysis Guide. 

The Reporting and Analysis module is based on the Cognos 8 Business Intelligence applications, 
which have been customized and integrated into the InForm application by Oracle, and embedded in 
the InForm user interface. 

Note: You can install the InForm software without the Reporting and Analysis module if you want 
to use the data collection features of the InForm application without the reporting features. 
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InForm system configuration 
The InForm system configuration consists of the browser computers, the application server, and the 
database server. 
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InForm 5.5 product image 
The InForm product image includes folders that contain: 

• Native installers 

• Customization wizards 

This native installer folder contains setup files that install the base products necessary for the InForm 
software and the InForm Portal software. The customization wizard folders contain setup files you 
use to apply necessary customizations for an installation of the Reporting and Analysis module. Use 
these folders only if you are installing the Reporting and Analysis module. 

 

Folder Description 
InForm Contains the InForm core and the InForm Portal installation software. 

CRNConfig Contains files used to run the Cognos 8 Business Intelligence 
Customization for InForm wizard.  

CRNGatewayConfig Contains files used to run the Cognos 8 Business Intelligence Gateway 
Customization for InForm wizard.  
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Available online Help 
The InForm application provides extensive online Help from the user interface to give you easy 
access to procedural, conceptual, and detailed task-related information that you need while working 
with the application. 

Note: The popup blocker in your browser may prevent the Help pages from opening. If this occurs, 
either turn off the popup blocker or press the Ctrl key before you click the Help icon. 

 

 

Online Help Description How to access 
InForm User 
Guide 

The User Guide provides an overview of 
the InForm application including details 
on multilingual studies, how to navigate 
through the user interface, and how to 
use the application to accomplish typical 
tasks you perform while running a clinical 
study. 

This guide appears in a separate browser 
window that you can resize and move for 
easy viewing. 

• In the upper-right corner of the 
main InForm application 
window, click the Help icon 
( ) > InForm User Guide. 

Cognos 8 
Business 
Intelligence 
documentation 

The complete Cognos 8 Business 
Intelligence documentation set, created 
by Cognos. This documentation is 
available only if using the Reporting and 
Analysis module. 

These guides appear in separate browser 
windows that you can resize and move 
for easy viewing. 

• In the upper-right corner of the 
main InForm application 
window, click the Help icon 
( ) > Reporting User Guide. 

An HTML page appears with 
links to the complete Cognos 8 
Business Intelligence 
documentation set. 

Descriptions of 
InForm standard 
reports 

Detailed descriptions for the fields in the 
report. This information Is available from 
within the Reporting and Analysis 
module, after you output any InForm 
standard report. 

• After you output any InForm 
standard report in HTML 
format, click the Report Help 
link. 

An HTML page appears with 
detailed page-level Help for the 
report.  

Cognos 
documentation 
for Query Studio 

The Cognos Query Studio User Guide, 
created by Cognos. Query Studio is the 
Cognos tool that provides Ad Hoc 
Reporting capability. This guide is 
available from within the reporting user 
interface only if using the Reporting and 
Analysis module.  

This guide appears in a separate browser 
window that you can resize and move for 
easy viewing. 

• In the Ad Hoc Reporting 
workspace, select Ad Hoc Tools 
Help. 
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Online Help Description How to access 
Hover Help Provides a brief description of the 

selected item, button, or icon. 
• Hold your mouse pointer over 

the item and the hover Help 
text appears in a popup 
window. 

When you move your mouse 
pointer off the item, the hover 
Help disappears. 
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Summary of installation tasks 
The following table summarizes the steps for installing and configuring the software required for the 
InForm application and Cognos Reporting environment. All steps are performed one time to set up 
the environment and are required unless marked optional. 

Note: If your installation includes only the InForm application without Cognos Reporting, only 
steps 1, 2, and 6 apply. 

 

Step Where to get more information 
1 Create and configure Oracle database 

instances. 
Configuring Oracle (on page 37). 

2 Install the InForm core software. Installing the InForm core software (on page 
55). 

3 Install the Cognos 8 Business Intelligence 
core software. 

Installing the Cognos 8 Business Intelligence 
core software (on page 81). 

4 Run a set of customization wizards to 
configure Cognos 8 BI for the Reporting 
and Analysis module. 

Configuring the Cognos 8 BI software for the 
InForm environment (on page 109). 

5 Create and configure the study and 
reporting databases. 

Configuring the InForm software for the 
Cognos Reporting environment (on page 131). 

6 Update browser settings on client 
computers. 

Configuring client computers (on page 145). 

. 
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Checklist—Installing and configuring the Oracle database 
 

 Workflow step Where to get more information 

 1 Obtain Oracle database software and 
patches. 

Release Notes. 

 2 Install the Oracle database software 
on each server that hosts the 
InForm, Cognos 8 BI, and Reporting 
and Analysis database instances. 

Oracle database documentation. 

 3 Create the Oracle database instances 
for the InForm software, the Cognos 
8 BI software, and Reporting and 
Analysis. 

• Create Oracle Database instances (on 
page 42). 

• Creating a database schema for the 
Cognos Authentication Provider (CAP) 
(on page 47). 

• Configuring the database for the Cognos 
Authentication Provider (on page 47) 

 4 Create the InForm database users. Required InForm database accounts (on page 
43). 

 5 Create the InForm tablespaces. • Distributed InForm study tablespaces 
(on page 45). 

• Multiple study tablespaces (on page 44) 

• Creating the INFORM_LOB tablespace 
(on page 46) 

 6 Configure and validate a database 
connection. 

• Configuring a database connection (on 
page 52). 

• Validating the database connection (on 
page 52). 

 7 Create the Cognos 8 BI database and 
accounts. 

• Creating a database instance for the 
Cognos 8 BI content store (on page 49) 

• Configuring the Cognos 8 BI content 
store database (on page 49) 

 8 Set up initialization parameters. • Initialization parameters for database 
instances (on page 39). 

• Study database parameters—Different 
database instances (on page 50) 

• Archive log mode in a multiple database 
environment (on page 51) 
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 Workflow step Where to get more information 

 9 Configure the Oracle database client. • Configuring the Oracle client (on page 
52). 

• Configuring a database connection (on 
page 52) 

• Validating the database connection (on 
page 52) 

 10 Set up Oracle XA transaction 
support. 

Setting up Oracle XA Transaction Support 
(on page 53). 
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Checklist—Installing the InForm software 
 

 Workflow step Where to get more information 

 1 Verify that all hardware and software 
requirements are met. 

Release Notes. 

 2 Install and configure the Oracle 
database software. 

Configuring the Oracle database (on page 37) 

 3 Run the InForm installation wizard. Installing the InForm software (on page 57) 

 4 Optionally, change the pfdbadmin 
password. 

Changing the pfdbadmin password (on page 
63) 

 5 Optionally, enable a secure socket layer. Enabling Secure Sockets Layer (SSL) (on 
page 64) 

 6 Update the DomainSuffix entry for the 
AuthenticationFilter registry key 

Updating the DomainSuffix entry for the 
AuthenticationFilter registry key (on page 70) 

 7 Update the ExternalLoginURL and 
ExternalLoginFailureURL entries on 
the InForm server  

Updating the ExternalLoginURL and 
ExternalLoginFailureURL entries on the 
InForm server (on page 70) 

 8 Qualify the installation. Qualifying the installation (on page 72) 
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Worksheet—Database Configuration page of InForm installation wizard 
The Database Configuration page of the installation wizard for the InForm core software requires 
the following values. You can use this worksheet when preparing to run the wizard. 

 

Field in installation 
wizard 

Description Value to input 

Database Connection 
String 

String that the InForm server uses to connect 
to the Oracle instance for the study. 

 

Admin Database 
Username 

User name that is required to access the Admin 
database. The default is informadmin. 

 

Admin Database Password Password that is required to access the Admin 
database. The password is not case-sensitive. 

Note: If users can access your production 
servers using SQL*Plus, Oracle recommends 
that you change the default Admin Database 
Password during installation for security. If 
users cannot access production servers using 
SQL*Plus, normal firewall security should be 
sufficient. 

Unlike the InForm system user name and 
InForm system password, the Admin database 
user name and Admin database password can 
be changed only during the installation process. 

 

InForm System Username User name for the pfdbadmin. The default is 
pfdbadmin. This account is used to create 
study database users in DBSETUP. If this is a 
new InForm installation or if you change the 
user name from the default during the 
installation, select the Prep Oracle checkbox. 
This instructs the InForm software installation 
to create the InForm account using the user 
name and password you specify. 

 

InForm System Password Password for the pfdbadmin. The default is 
pfdbadmin. The password is not case-
sensitive.  

Note: Oracle recommends that you change the 
InForm system password after installing the 
InForm software. For more information, see 
Changing the pfdbadmin password (on 
page 63). 

 

Oracle SYS Password Password of the Oracle SYS account. This 
value is used only if you select the Prep Oracle 
checkbox to create the pfdbadmin account. 
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Field in installation 
wizard 

Description Value to input 

Install Admin DB If selected, creates the: 

• informadmin user, using the Admin 
Database Username and Admin Database 
Password. 

• InForm Admin database for non-clinical 
data, such as a list of studies, with study 
database usernames and passwords. 

 

Prep Oracle • If selected: 

 Runs the informprepora.vbs script, 
that creates the study database user, 
using the InForm System Username 
and InForm System Password. 

 Runs the mtsora102.vbs script, that 
sets up Oracle XA Transaction 
Support and sets the MTS Timeout to 
a minimum of 300 seconds. 

• If not selected: 

 Verifies the study database user and 
password. 

Note: You need to select the Prep Oracle 
checkbox only the first time you install the 
InForm software on an instance. 
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Checklist—Installing the Cognos 8 BI core software 
 

 Workflow step Where to get more information 

 1 Verify that all hardware and software 
requirements are met. 

Release Notes. 

 2 Install and configure the Oracle 
database software. 

Configuring the Oracle database (on page 37). 

 3 Install Sun ONE Directory Server. Installing Sun ONE Directory Server (on 
page 83). 

 4 Install the Cognos 8 BI core software. Installing the Cognos 8 BI software (on page 
95). 

 5 Upgrade to Cognos 8 BI Fix Pack 5. Upgrading Cognos 8.4.1 software to Fix Pack 
5 (on page 98). 

 6 Install the hotsite updates. Installing the 8.4.1 Fix Pack 5 hotsite updates 
(on page 101). 

 7 Copy the Oracle JDBC driver to the 
server where the Cognos 8 Business 
Intelligence Content Manager is 
installed. 

Setting up the Oracle JDBC driver (on page 
104). 

 8 Optionally, customize Cognos 8 BI 
email settings. 

Customizing Cognos 8 BI email settings (on 
page 106). 

 9 Configure IIS 7.0 for Windows 2008 
or IIS 6.0 for Windows 2003. 

• Creating, setting up and installing a key 
certificate for SSL in IIS 7.0 (on page 64). 

• Creating, setting up and installing a key 
certificate for SSL in IIS 6.0 (on page 67). 

 10 Optionally, configure Cognos 8 BI to 
use SSL. 

Configuring for SSL in the Cognos 
Configuration utility (on page 121). 

 11 Optionally, configure the Cognos 
gateway server to use SSL 

Configuring the Internet Information 
Services (IIS) for Windows on the Cognos 
Gateway server (on page 107). 

 12 Start the Cognos 8 BI servers. Starting the Cognos 8 BI servers (on page 
122). 
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Worksheet—Sun ONE Directory Server installation wizard 
The installation wizard for installing Sun ONE Directory Server requires the following values. You 
can use this worksheet when preparing to run the wizard. 

 

Field in installation 
wizard 

Description Value to input 

Fully Qualified Computer Name 
Fully Qualified 
Computer Name 

Fully Qualified Computer Name of the 
computer you are going to use for LDAP. 

 

Select Installation Directory 
Directory to install 
Directory Server 
components 

Path and directory name for the installation of 
the Directory Server components. 

 

Directory Server Settings page 
Server Identifier Physical name of the LDAP server.  

Server Port Use the default port number 389 that is listed.  

Note: Using a specific port number could result 
in port conflicts with other applications. Using 
the default number eliminates port conflicts.  

 

Suffix Network domain (for example, if the domain is 
north.pf.com, enter  dc=north,dc=pf,dc=com).  

Note: Do not enter a space after the comma 
between the parts of the domain. 

 

Configuration Directory Server Administrator page 
Administrator ID Name for registering the server with the 

Configuration Directory Server. 
 

Password Password for the user name entered in the 
Administrator ID field. 

 

Password (again) Confirmation of the password.  

Directory Manager Settings page 
Directory Manager 
DN 

Distinguished Name for the Directory Manager 
user, in the format cn=<user name>. 

 

Password Password of the admin user specified in the 
Directory Manager DN field. 

 

Password (again) Confirmation of the password.  

Administration Server Port Selection page 
Administration Port Port number for the Administration Server 

(keep the default). 
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Checklist—Customizing Cognos 8 BI for Reporting and 
Analysis 

Run the two Cognos 8 BI for InForm customization wizards to specify communication information 
needed by the Cognos 8 BI software and to load files needed by the Reporting and Analysis module. 

 

 Workflow step Where to get more information 

 1 Run the Cognos 8 BI Customization for 
InForm (CRNConfig\setup.exe) 
wizard. 

Running the CRNConfig\setup.exe wizard 
(on page 111) 

 2 Optionally, change or create a new 
MotioCAP_informcap.properties file. 

Changing or creating a new 
MotioCAP_informcap.properties file (on page 
117) 

 3 Run the Cognos 8 BI Gateway 
Customization for InForm 
(CRNGatewayConfig\setup.exe) 
wizard. 

Running the CRNGatewayConfig\setup.exe 
wizard (on page 118) 

 4 Configuring for SSL in the Cognos 
Configuration utility 

Configuring for SSL in the Cognos 
Configuration utility (on page 121) 

 5 Start the Cognos 8 BI servers. Starting the Cognos 8 BI servers (on page 122) 

 6 Configure the CSV settings for reports. Configuring settings for Comma Separated 
Values (CSV) report output (on page 123) 

 7 Update registry settings for the Cognos 
8 BI software. 

• Updating the ExternalLoginURL and 
ExternalLoginFailureURL registry key 
entries on the Cognos 8 BI servers (on 
page 125) 

• Updating the AuthenticationFilter 
DomainSuffix registry key on the Cognos 
8 BI server (on page 126) 

 8 Configure the Cognos 8 BI Gateway 
server to run the Cognos Application 
Firewall 

Configuring the Cognos 8 BI Gateway server 
to run the Cognos Application Firewall (on 
page 129) 

 9 Enable communication among 
distributed Cognos 8 BI components. 

Enabling communication among distributed 
Cognos 8 BI software components (on page 
128) 

 10 Create the PFWD namespace and 
crnsysadmin user. 

• Creating PFWD and crnsysadmin on the 
LDAP server (on page 91) 

• Creating PFWD and crnsysadmin on the 
Cognos 8 BI server (on page 130) 
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Checklists—Configuring the study and reporting schemas 
The procedures for configuring the study and reporting schemas vary according to the way your 
environment is set up: 

• Study and reporting schemas installed in the same database instance 

For the default configuration, Oracle recommends installing the InForm software and the 
Reporting and Analysis module in the same database instance, and installing in different database 
instances only in certain cases. For more information, see Options for distributing software 
components (on page 28). 

• Study and reporting schemas installed in different database instances. 

Note: Study and reporting schemas are set up by default when they are installed in the same 
database instance. 

 

Reporting schema—Study and reporting in different database instances 
Perform these steps in the database instance for the reporting schema in a production environment 
where the study and reporting schemas are in different database instances. 

 

 Workflow step Where to get more information 

 1 Configure reporting 
database parameters. 

Required reporting database parameters—Different 
database instances (on page 139). 

 2 Create reporting 
tablespaces. 

• Required reporting tablespace—Different database 
instances (on page 141). 

• Optional reporting tablespace—Different database 
instances (on page 141). 

 3 Create the rptinstall user 
for reports. 

rptinstall user for reports—Different database instances 
(on page 142). 

 4 Set up communication 
between the study and 
reporting databases. 

Communication between the study and reporting 
databases—Different database instances (on page 143). 
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Study schema—Study and reporting in different database instances 
Perform these steps in the database instance for the study schema in a production environment 
where the study and reporting schemas are in different database instances. 

 

 Workflow step Where to get more information 

 1 Configure additional 
database parameter 
settings. 

Study database parameters—Different database instances 
(on page 133). 

 2 Add tablespaces to the 
study database. 

• Required study tablespace—Different database 
instances (on page 134). 

• Optional study tablespace—Different database 
instances (on page 135). 

 3 Create the rptinstall user 
for studies. 

rptinstall user for studies—Different database instances 
(on page 136). 

 4 Verify archivelog mode is 
set in the study database. 

Archivelog mode verification in the study database—
Different database instances (on page 137). 

 5 Configure reporting 
variables. 

Reporting variable configuration—Different database 
instances (on page 137). 
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Checklists—Configuring client computers 

Microsoft Internet Explorer 
You can perform the following steps in any order. All steps are recommended but optional except 
for the following steps, which are required: 

• Configuring pop-up blocking. 

• Modifying security settings. 
 

 Workflow step Where to get more information 

 1 Specify the preferred browser 
language. 

Specifying the preferred browser language 
(on page 146). 

 2 Enable prompting for downloads. Enabling prompting for downloads (on page 
146). 

 3 Configure pop-up blocking. 
REQUIRED. 

Configuring pop-up blocking (on page 147). 

 4 Prevent automatic password 
completion. 

Preventing automatic password completion 
(on page 147). 

 5 Specify whether to save encrypted and 
temp files. 

Specifying whether to save encrypted and 
temp files (on page 147). 

 6 Optimize performance. Optimizing performance (on page 148). 

 7 Setting HTTP and SSL option for 
performance. 

Setting HTTP and SSL options for 
performance (on page 148). 

 8 Print background graphics. Printing background graphics (on page 148). 

 9 Modify security settings. REQUIRED. Modifying security settings (on page 148). 

 10 Set up tabbed browsing. Setting up tabbed browsing for Internet 
Explorer 7.0 (on page 149). 
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Apple Safari 
You can perform the following steps in any order. All steps are recommended but optional except 
for the following steps, which are required: 

• Configuring pop-up blocking. 

• Modifying security settings. 
 

 Workflow step Where to get more information 

 1 Specify the preferred browser language. Specifying the preferred browser language 
(on page 151). 

 2 Configure pop-up blocking 
REQUIRED. 

Configuring pop-up blocking (on page 151). 

 3 Prevent automatic password 
completion. 

Preventing automatic password completion 
(on page 151). 

 4 Modify security settings. REQUIRED. Modifying security settings (on page 151). 
 

 

Firefox 3.5 
You can perform the following steps in any order. All steps are recommended but optional except 
for the following steps, which are required: 

• Configuring pop-up blocking. 

• Modifying security settings. 
 

 Workflow step Where to get more information 

 1 Specify the preferred browser 
language. 

Specifying the preferred browser language 
(on page 152) 

 2 Configure pop-up blocking. 
REQUIRED. 

Configuring pop-up blocking (on page 152) 

 3 Prevent stored password use. Preventing stored password use (on page 152) 

 4 Setting the SSL option for 
performance. 

Setting the SSL option for performance (on 
page 153) 

 5 Modify security settings. REQUIRED. Modifying security settings (on page 153) 
 

 



 Installation Guide  

InForm 5.5.2 23 

Checklist—Uninstalling software components 
 

 Workflow step Where to get more information 

 1 Uninstall the Cognos 8 BI software. Uninstalling the Cognos 8 BI software (on 
page 163). 

 2 Uninstall Sun ONE Directory Server. Uninstalling Sun ONE Directory Server (on 
page 165). 

 3 Uninstall the InForm core software. Uninstalling the InForm software (on page 
167). 
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Overview of the InForm system architecture 
The InForm software is a four-tiered software design. The following illustration is a logical 
representation of the system architecture. 

 

 

Tier Software component 
hosted on the tier 

Description 

Client Web browser Displays the pages of a study and receives user input. 

Notes: 

• You cannot use the Apple Safari browser with 
Cognos Reporting.  

• You might be able to use the Cognos Reporting 
features with version 8.0 of Microsoft Internet 
Explorer, but that version is not officially supported 
either by Oracle or by Cognos.  

Web 

 

Web server and gateway 
software (MS-IIS) 

Services requests to and from the web browser. 

Cognos 8 BI Gateway 
services 

Provides secure access to the Cognos 8 Business 
Intelligence (Cognos 8 BI) Server. 
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Tier Software component 
hosted on the tier 

Description 

Application 

 

InForm Service Handles study-related requests for operating system 
services. There is one InForm Service per physical server 
machine. 

InForm study application 
server 

Logical server that acts as a transaction manager for 
InForm studies under the InForm Service. The InForm 
Server handles caching and Microsoft Transaction Server 
(MTS) packages. Each study is associated with an 
InForm study application server. 

Cognos 8 BI Service Handles reporting-related requests for operating system 
services. There is one Cognos 8 BI Service per physical 
server machine. 

Cognos 8 BI Content 
Manager 

Logical server that acts as a transaction manager for the 
Reporting and Analysis module under the Cognos 8 BI 
Service. There is one Cognos 8 BI Server per physical 
server machine. 

Sun ONE Directory 
Server 

Provides secure access to the InForm Reporting 
database. 

Data 

 

Oracle database 
instances for: 

 

InForm study 
database 

Stores the study components and the clinical data. 
Studies typically share an instance of Oracle with the 
InForm Admin database. 

InForm Admin 
database 

Used by the InForm Service to manage all the studies on 
a physical machine. There is one InForm Admin 
database per InForm Service. 

InForm Reporting 
database 

Stores views for Cognos Reporting through the 
Reporting and Analysis module. The InForm Reporting 
database can share an instance of Oracle with the 
InForm Admin and study databases or can reside in a 
separate Oracle instance. In an installation in which 
Cognos Reporting is enabled, each InForm study 
database has a corresponding InForm Reporting 
database. 

Cognos 8 BI 
Content Store 

Stores user-created reporting objects such as folders, 
saved reports, and saved views. The Content Store 
usually occurs in a separate Oracle instance. 
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Options for distributing software components 

Single server 
In a single-server deployment, the InForm Server, the Cognos 8 BI Server, and all the study and 
reporting databases are on a single server machine that conforms to the InForm hardware and 
software requirements. 
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Single database instance for InForm and Cognos reporting software 
For the default configuration, Oracle recommends installing the InForm software and the Reporting 
and Analysis module in the same database instance, and installing in different database instances only 
in certain cases.  

• You can install in the same database instance if your study has up to 70 concurrent users and 8 
concurrent reporting connections. The 8 reporting connections can be any combination of 
running an ad hoc query, a standard or custom report, or a report job. 

• If your study requires more than 70 concurrent users and 8 concurrent reporting connections, 
installing in the same database instance may still be acceptable. However, you may want to 
consider installing the InForm software and the Reporting and Analysis module in different 
database instances. 

• If your study requires 16 or more concurrent reporting connections, Oracle recommends 
installing in different database instances. 

Observe the following architecture rules when setting up a single database instance for the InForm 
software and the Reporting and Analysis module: 

• Only one reporting environment is allowed per study schema. 

• A single database can hold multiple reporting schemas. 

• The InForm study and reporting database is not required to run in archive log mode. 
 

Multiple servers 
In a multi-server deployment, the InForm Server, the Cognos 8 Business Intelligence Server, and the 
study and reporting databases are on at least three separate server machines that conform to InForm 
hardware and software requirements. The following example shows a physical representation of 
several server machines configured as follows: 

• One Cognos Gateway server machine. 

• One Cognos 8 BI server machine. 

• One InForm server machine. 

• One Sun Java System LDAP Directory Server machine. 

• Three dedicated Oracle database server machines: 

• Customer-defined database (CDD), InForm Study, and InForm Admin. 

• InForm Reporting. 

• Cognos 8 BI Content Store. 

Note: The InForm application server(s) and the Cognos 8 BI application server(s) must be in the 
same domain.  
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Separate database instances for InForm and Cognos reporting software 
If your study requires 16 or more concurrent reporting connections, you should install the InForm 
and Cognos reporting software in separate database instances for performance reasons. You could 
use separate database instances for each of the following: 

• Each InForm server, which contains one InForm Admin schema and multiple InForm study 
schemas. 

• InForm Reporting schema. 

• Cognos 8 BI Content Store schema. 

• PFCap Admin Schema 

Observe the following architecture rules: 

• You must install the Reporting and Analysis environment (InForm Reporting database) in a 
different database instance than the instance for the study. 

• The InForm application server(s) and the Cognos 8 BI application server(s) must be in the same 
domain.  

• The Oracle user name for the reporting schema in the reporting database instance must be the 
same as the Oracle user name for the study schema in the study database instance. Because the 
users are in different database instances, the user names may have different passwords. 

• Only one reporting environment is allowed per study schema. 

• A single reporting database can hold multiple reporting schemas. The study schemas that are 
associated with these reporting schemas might exist in one or in multiple study databases. 

• The study schema must be created with archive log mode enabled. 

For more information, see Archive log mode in a multiple database environment (on page 
51). 

 

Externally hosted trials 
Externally hosted studies must conform to the following requirements, or authentication issues will 
result. 

• The InForm application server(s) and the Cognos 8 BI application server(s) must be in the same 
domain. 

• You must use the fully qualified domain name to access the site. 
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Determining resources for multiple studies 
You can install one or more studies on an InForm application server or on a physical server. When 
deciding the load that you will place on a server, consider: 

• The number of InForm application servers on each physical server machine. 

• The number of studies on each InForm application server. 

Note: Oracle recommends installing only one study per InForm application server in a 
production environment. 

• The size of the intended InForm application server (each server requires 40 to 50 megabytes of 
memory). 

• The number of studies you intend to run on the server machine. 

• The system availability requirements. 

• The geographic proximity of sites to the server. 
 

Guidelines for determining resources 
Follow these basic guidelines for determining resources: 

• Use separate server machines for production studies and studies that are used for testing and 
training. 

• Consider using one server machine for multiple smaller studies (especially Phase 1 studies) that 
are on separate InForm application servers. 

• Use a separate server machine for each large study (especially Phase 3 studies). Although multiple 
servers might require additional resources and additional cost, they also provide increased 
dependability and stability.  

Separate server machines can reduce risk. If you have more than one study on a server machine 
and make an error in setup or configuration, all the studies on that server are affected. 
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Sizing the server 
When sizing an InForm application server, be aware of the resources that are already being used. 
Make sure that you monitor the servers during the studies. When sizing your server, consider the 
average number of: 

• Sites 

• Subjects per site 

• CRFs 

• Data items 

• Users 

For each study, consider the following: 

• GCP status of the study (GCP or non-GCP). 

• Study phase. 

• Study duration. 

• Enrollment rate. 

• Geographic proximity of servers to sites. 

• System availability requirements. 

• Number of sites. 

• Number of users. 

• Number of subjects. 

• Number of unique forms. 

• Maximum number of items per form. 

• Average number of items per form. 

• Maximum number of rules per form. 

• Average number of rules per form. 

• Total number of forms per subject. 
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Before configuring the Oracle database 
Before you begin to configure the Oracle database, install the required Oracle software and patches. 
For more information, see the Release Notes. 

For a checklist of Oracle installation and configuration steps, see Checklist—Installing and 
configuring Oracle (on page 11). 
 



 Installation Guide  

InForm 5.5.2 39 

Initialization parameters for database instances 
Depending on your environment, you might need one, two, or three database instances (the study, 
the Reporting and Analysis module, and Cognos 8 BI each need an instance). 

When creating each InForm Oracle Instance, use the following initialization parameters in the 
Init.ora file. 

Note: Additional parameter settings are required if your installation includes Cognos 8 BI and the 
Reporting and Analysis module and your study and reporting databases are in separate database 
instances. For more information, see Study database parameters—Different database instances 
(on page 50). 

 

Parameter Production server values Development server values 

compatible 11.2.0 or 10.2.0 11.2.0 or 10.2.0 

cursor_sharing Study database 
instance without 
reporting 

exact Study database 
instance without 
reporting 

exact 

 Reporting database 
instance 

exact Reporting database 
instance 

exact  

 Study and reporting 
in same database 
instance 

exact Study and 
reporting in same 
database instance 

exact 

db_block_size Study database 
instance without 
reporting 

16384 Study database 
instance without 
reporting 

16384 

 Reporting database 
instance 

16384 Reporting database 
instance 

16384 

 Study and reporting 
in same database 
instance 

16384 Study and 
reporting in same 
database instance 

16384 

db_file_multiblock_read_count 16 16 

db_cache_size 

See Note 2 

0 0 

db_files Database dependent. Database dependent. 

open_cursors 

See Note 2 

150 150 

optimizer_features_enable 11.2.0.1 or 10.2.0.3 11.2.0.1 or 10.2.0.3 

pga_aggregate_target 500M (dependent on how 
much memory is available for 
the Oracle database) 

500M (dependent on how 
much memory is available for 
the  Oracle database) 
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Parameter Production server values Development server values 

processes 

See Note 2 

150 (or maximum number of 
concurrent processes) 

50 

session_cached_cursors 150 150 

sga_target x 

See Note 3 

1000M (dependent on how 
much memory is available for 
the Oracle database) 

1000M  (dependent on how 
much memory is available for 
the Oracle database) 

shared_pool_reserved_size 5M 3.5M 

Reporting database 
instance 

True 

 

Reporting database 
instance 

True 

 

Study and reporting in 
same database instance 

True 

 

 

 

 

 

 

 

 
 

Study and reporting in 
same database 
instance 

True 

 

 

 

 

 

 

 

 
 

streams_pool_size 

See Note  1 

200M 200M 

job_queue_processes 5 minimum: 1 job for each trial 
(the job to update 
PF_HEARTBEAT table every 
minute in each trial schema) 
and 1 job for each propagation, 
plus streams’ minimum 
requirement of 2 and Oracle 
MTS’s requirement of 1)  

5 minimum: 1 job for each 
trial (the job to update 
PF_HEARTBEAT table every 
minute in each trial schema) 
and 1 job for each 
propagation, plus streams’ 
minimum requirement of 2 
and Oracle MTS’s requirement 
of 1)  

statistics_levelx Typical Typical 

workarea_size_policy auto auto 

_optimizer_cost_based_transfor
mation See Note  4 

Off Off 

sec_case_sensitive_logon (11g 
only) 

False False 
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Parameter Production server values Development server values 

_push_join_predicate (11g only) False False 

deferred_segment_creation (11g 
only) 

False False 

skip_unusable_indexes No requirement for the trial 
database. 

No requirement for the trial 
database. 

undo_retention 900 900 

parallel_max_servers 3 3 
 

Note 1: These parameters can be changed if desired. Specifying a value other than zero in for 
these parameters enforces a minimum amount of memory that sga_target uses. The minimum is 
deducted from the total memory that sga_target can dynamically allocate across the five 
memory settings it manages. 

Note 2: These parameters might need to be adjusted depending on the demands on the 
database that are created by the InForm application and Streams. 

Note 3: Java_pool_size and large_pool_size are also managed by sga_target. They are not 
specified in a parameter list because they are not needed for the InForm application. 

Note 4:  Workaround provided by Oracle for database issue 5382842. 
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Create Oracle Database instances 
If you are installing the InForm and Cognos reporting software in separate database instances for 
performance reasons. You could use separate database instances for each of the following: 

• Each InForm server, which contains one InForm Admin schema and multiple InForm study 
schemas. 

• InForm Reporting schema. 

• Cognos 8 BI Content Store schema. 

• PFCap Admin Schema 

If you are installing the InForm and Cognos reporting software in the same database instance, you 
could use separate database instances for each of the following: 

• Each InForm server, which contains one InForm Admin schema and multiple InForm study 
schemas and the Reporting schema. 

• Cognos 8 BI Content Store schema. 

• PFCap Admin Schema 

Use the Oracle tools to create the instances you require for your configuration. If you plan to use the 
InForm application without the Reporting and Analysis module, create only a single instance for each 
InForm server.   

Use the following character set specifications for both the InForm and the Cognos 8 BI Content 
Store instances: 

• Database Character Set—AL32UTF8. 

• National Character Set—AL16UTF16. 

To verify the character set settings: 

1 Log into SQL*Plus. Type: 
sqlplus system/<system_password>@<connection_string> 
 

2 Run the following command: 
select * from nls_database_parameters 
where parameter = any('NLS_CHARACTERSET','NLS_NCHAR_CHARACTERSET'); 
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Required InForm database accounts 
The following database accounts are required for each instance of the InForm Service: 

• A DBA user for the InForm software. The default name of this user is pfdbadmin. 

• A user that can connect to the InForm Admin database. The default name of this user is 
informadmin. 

The recommended way to create these accounts is to select the options to create them in the InForm 
installation wizard. If you need to create either account at another time, you can run a script. 

 

Default account 
name 

Installation wizard checkbox Script and where to get information 

pfdbadmin Prep Oracle 

For more information, see 
Installing the InForm software 
(on page 57). 

informprepora.vbs (on page 180) 

For more information, see the Study and 
Reporting Setup Guide. 

informadmin Install Admin DB 

For more information, see 
Installing the InForm software 
(on page 57). 

admindb (on page 170) 

For more information, see the Study and 
Reporting Setup Guide. 

 

In a multi-tier installation of the InForm software, you create the pfdbadmin and the informadmin 
accounts on each server where you install the InForm software. Oracle recommends that you include 
the server name in the user ID of the pfdbadmin and informadmin accounts. 

Note: You need to create the pfadmin user only one time per database instance. Therefore, if you 
uninstall and reinstall the InForm software in the same database instance, you can leave the 
Prep Oracle checkbox deselected during the second installation. 
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Multiple study tablespaces 
By default, all study objects are created in the INFORM tablespace. In a production environment, 
you should distribute each study across multiple tablespaces for improved performance and for 
maintenance and monitoring. Before you install your study on a production server, set up the study-
specific tablespaces. 

The following table lists the Oracle table and index tablespaces to create, along with the required 
parameters. All tablespaces should be locally managed.  

 

Table tablespace Index tablespace Size (MB) 
%STUDY_NAME%_REF %STUDY_NAME%_REF_IDX 120 

%STUDY_NAME%_HIGH_TXN1 %STUDY_NAME%_HIGH_TXN1_IDX 300 

%STUDY_NAME%_HIGH_TXN2 %STUDY_NAME%_HIGH_TXN2_IDX 500 

%STUDY_NAME%_HIGH_TXN3 %STUDY_NAME%_HIGH_TXN3_DX 600 

%STUDY_NAME%_HIGH_TXN4 %STUDY_NAME%_HIGH_TXN4_IDX 500 

%STUDY_NAME%_TXN %STUDY_NAME%_TXN_IDX 250 
 

The remaining syntax for each of these tablespaces is: 

AUTOEXTEND ON NEXT 50M 
EXTENT MANAGEMENT LOCAL AUTOALLOCATE; 
 

Note: The STUDY_NAME portion of the tablespace name must conform to Oracle database name 
standards. It cannot start with a numeric character and cannot contain special characters. 
Additionally, because the Oracle database has an internal limit of 30 characters for a tablespace 
name, the study name must be 16 characters or fewer. 

Oracle provides sample configurations for distributing your tablespaces using from one disk to five 
disks. 
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Distributed InForm study tablespaces 
In a production environment, Oracle recommends distributing tablespaces across multiple disks. 
This table presents a suggested model. In each configuration, it is recommended that you use the C: 
partition for the operating system and distribute the database and application components across the 
remaining partitions. Monitor your system to determine the optimal configuration. 

Note: For production systems, Oracle does not recommend using a single server for both the 
InForm core software and the study database. 

• C: and D: are partitions on one disk. 

• INFORM, SYSTEM, TEMPBIG are tablespaces. 
 

Physical disks 0 1 2 3 4 

Logical disks C: D: E: F: G: H: 
1 disk Windows 

2008 or 
2003 

Oracle 
INFORM 
SYSTEM 
Study Tables 
Study 
Indexes 
TEMPBIG 
Redo logs 
UNDOTBS 
Archive logs 

    

2 disks Windows 
2008 or 
2003 

Oracle 
INFORM 
SYSTEM 
Study Tables 
Redo logs 

Study 
Indexes 
TEMPBIG 
Redo logs 
UNDOTBS 
Archive logs 

   

3 disks Windows 
2008 or 
2003 

Oracle 
INFORM 
SYSTEM 
Redo logs 

Study 
Indexes 
TEMPBIG 
Redo logs 
UNDOTBS 
Archive logs 

Study 
Tables 

 

  

4 disks Windows 
2008 or 
2003 

Oracle 
INFORM 
SYSTEM 
Redo logs 

TEMPBIG 
Redo logs 
UNDOTBS 
Archive logs 

Study 
Tables 

 

Study 
Indexes 

 

 

5 disks Windows 
2008 or 
2003 

Oracle 
SYSTEM 
Redo logs 

INFORM 
Redo logs 
UNDOTBS 

 

Study 
Tables 

 

Study 
Indexes 

 

TEMPBIG 
Archive logs 
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Creating the INFORM_LOB tablespace 
The INFORM_LOB tablespace is optional for InForm installation. To create the INFORM_LOB 
tablespace, use the following syntax: 

CREATE TABLESPACE INFORM_LOB 
DATAFILE ‘<path_to_reporting_data_file>’ SIZE <initial_size> 
AUTOEXTEND ON NEXT 
EXTENT MANAGEMENT LOCAL AUTOALLOCATE; 

 

Tablespace name Initial size/ 
autoextend size 
needed 

File extent size/file 
maximum size 

Comments 

INFORM_LOB 200M Make the initial size 
200 megabytes, set 
AUTOEXTEND on 
and set MAXSIZE to 
UNLIMITED. 

Use of this tablespace is optional, 
but, if used, the name 
INFORM_LOB is required for 
this tablespace. This tablespace 
can be used to hold large objects. 
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Creating a database schema for the Cognos 
Authentication Provider (CAP) 

If you plan to install Cognos Reporting, you must create a database schema for the Cognos 
Authentication Provider (CAP). The purpose of this database schema is to store trial-to-
authentication URL information. This schema can reside in the content store database instance or a 
separate database instance. 

1 Set up an Oracle database schema. 

2 Create a table to store the URL information for CAP. 

3 Ensure that the database schema will be available from the study server and the Cognos 8 BI 
server. 

4 Update the tnsnames.ora file located on the application server to contain an alias establishing a 
connection to the database server. 

 

Configuring the database for the Cognos Authentication Provider 
1 Create the user PFCapAdmin and grant the user these roles: 

• Roles 

• CONNECT 

• RESOURCE 

• Privileges 

• ALTER SESSION 

• CREATE DATABASE LINK 

• CREATE SEQUENCE 

• CREATE SESSION 

• CREATE SYNONYM 

• CREATE TABLE 

• CREATE VIEW 

• UNLIMITED TABLESPACE 

2 Run the create_cap_table.sql script (located in the 
<Installation_Directory>\InForm\bin\DBOra folder) to create a table called TRIAL_URLS 
within this user/schema. 

For more information, see create_cap_table.sql (on page 173). 

Note: The CAP schema can reside in the content store database instance or a separate 
database instance. 

3 Validate the database connection from the Cognos 8 BI server by typing: 
sqlplus <contentuser_userid>/<contentuser_password>@<tnsnames_alias> 

 
If the test is successful, a SQL prompt appears, showing that you have logged on to the database 
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server as the PFCapAdmin user. An unsuccessful test generates an ORA- error. Consult your 
database administrator for help in troubleshooting errors. 
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Creating a database instance for the Cognos 8 BI content 
store 

If you plan to install Cognos Reporting, you must create a database instance for the Cognos 8 BI 
content store. 

1 Set up an Oracle database instance.  

2 Create a database to store the content for Cognos 8 Business Intelligence. Consult your Cognos 
documentation for details.  

3 Update the tnsnames.ora file located on the content store server to contain an alias establishing a 
connection to the database server. 

4 Specify the Unicode character set recommended by Cognos.  

Note: The Unicode character set cannot be changed after the database is created. 

 

Configuring the Cognos 8 BI content store database 
1 Verify that the character set for the content store database is Unicode. 

2 Create a user and grant the user these privileges: 

• Roles 

• CONNECT 

• RESOURCE 

• Privileges 

• CREATE ANY TABLE 

• CREATE TABLE 

• CREATE ANY VIEW 

• UNLIMITED TABLESPACE 

3 Validate the database connection from the Cognos 8 BI server by typing: 
sqlplus <contentuser_userid>/<contentuser_password>@<tnsnames_alias> 

 
If the test is successful, a SQL prompt appears, showing that you have logged on to the database 
server as the content store database user. An unsuccessful test generates an ORA- error. Consult 
your database administrator for help in troubleshooting errors. 
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Study database parameters—Different database instances 
The Reporting and Analysis module requires you to add or modify several study database parameters. 
The following table shows the adjustments that must be made to these parameters when the 
Reporting and Analysis module is installed. All settings are necessary for both production and 
development servers. 

Additionally, it is recommended that you review the processes and sessions parameters, which are 
not mandatory for the Reporting and Analysis installation. 

For more information, see the Oracle database document, Oracle Streams Recommendations. 
 

Parameter Value Comments 
compatible 11.2.0 or 10.2.0  

global_names TRUE  

job_queue_processes 5 minimum 5 minimum: 1 job for each study (the job to 
update PF_HEARTBEAT table every minute in 
each study schema) and 1 job for each 
propagation, plus streams’ minimum requirement 
of 2 and Oracle MTS’s requirement of 1)  

log_archive_dest Destination where 
the archive logs 
will be written 

You must enter at least one destination. 

log_archive_dest_state_1 ENABLE This enables the archive log destination 
(log_archive_dest_1). You must enter a state for 
every destination. 

open_links Four minimum Four minimum is recommended by Oracle for 
Streams. Add one for each reporting schema. 

parallel_max_servers 10 Minimum: 3 dependent on the number of parallel 
apply and/or capture processes. 

timed_statistics TRUE Recommended by Oracle for collecting elapsed 
time information for Streams. 

undo_retention 900 (minimum 
value) 

 

_job_queue_interval One Recommended by Oracle for Streams. 

deferred_segment_creation 
(11g only) 

False  
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Archive log mode in a multiple database environment 
You must create the study database with archive log mode enabled. You can create the database with 
scripts or with the Oracle Database Configuration Assistant utility. 

• Scripts—Specify archivelog as part of the create database statement. 

• Oracle Database Configuration Assistant—On the Archive tab, select the Archive Log 
Mode checkbox during the Initialization Parameters step. 

Note: For more information about the Oracle Database Configuration Assistance utility, see 
the Oracle database document, Oracle Administrators Guide for your platform. 
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Configuring the Oracle client 
The following registry settings are required for the Oracle client home on the InForm application 
server and the Cognos 8 BI server. The entries are in the following Windows Registry key:  

HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE\<Oracle_client_home_key> 
 

Option Value 
NLS_LANG American_America.AL32UTF8 

NLS_SORT JAPANESE_M 
 

 

Configuring a database connection 
To configure the Oracle Client on the application server to connect with the database server, update 
the tnsnames.ora file located on the application server so that it contains the alias that is used to 
establish a connection to the database server.  

Note: When installing the InForm software, you enter the alias specified in the tnsnames.ora file 
as the database connect string. 

 

Validating the database connection 
To validate the database connection from the application server:  

• Type the following statement at the Windows command prompt: 
sqlplus pfdbadmin_userID/pfdbadmin_password@tnsnames_alias 

 
pfdbadmin is the default user name and password for the pfdbadmin database account.  

If the test is successful, a SQL prompt appears, showing that you have logged on to the database 
server as the pfdbadmin user. An unsuccessful test generates an ORA- error. Consult your database 
administrator for help in troubleshooting errors. 

Note: Problems with connections can sometimes be attributed to the database server that 
contains a single Ethernet card with two nodes. Disabling one of the ports from the card usually 
solves the problem. Consult your system administrator for help in resolving errors. 
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Setting up Oracle XA Transaction Support 
To set up Oracle to support MTS transactional components, enable Oracle XA Transaction Support. 
You must enable Oracle XA Transaction Support for both development and production 
environments.  

1 Select the Prep Oracle checkbox during the InForm installation. For more information, see 
Installing the InForm core software (on page 55). 

or 

Run the mtsora102.vbs script during or after the Oracle installation. 

You must run the mtsora102.vbs script only if you are manually setting up XA Transaction 
Support. For more information, see the Study and Reporting Setup Guide. 

Note: In a multi-tier environment, select the Prep Oracle checkbox during the InForm 
installation on each InForm application server, and run mtsora102.vbs script on each 
InForm database server. Restart the server if the script changes any of the MSDTC\Security 
or MSDTC\XADLL registry keys. 

2 Run the oramtsadmin.sql command from the ...\oramts\admin folder of the Oracle Client 
home (where Oracle Services for Microsoft Transaction Server was installed).  

You must run it as the SYS user with the SYSDBA role. Run the script against all Oracle 
instances connected to the InForm Application Server. 

For more information, see the Study and Reporting Setup Guide. 
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About the InForm core software installation 
The InForm core software installation process installs: 

• The InForm Service. 

• The InForm study and Admin databases. 

Before you begin the InForm core software installation, make sure that the required preparation 
steps have been completed, and review the core installation tasks. 

For a checklist of InForm installation steps, see Checklist—Installing the InForm software (on 
page 13). 
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Installing the InForm software 
 

Installation InForm core software 

Purpose The InForm software installation process installs: 

• The InForm core software. 

• The InForm documentation. 

• The InForm Portal. 

• The InForm sample trials. 

File to extract (Example: InForm_55_SP0.iso) 

Where to install InForm server. 
 

1 Download the InForm software from the Oracle Download Center, and extract the ISO image. 

2 Navigate to the location of the installation files on the downloaded ISO image, and double-click 
setup.exe.  

The Choose Setup Language page appears.  

3 Select either English or Japanese for the language that you want the wizard to use during the 
installation. 

Note: Configuration of the language used for application pages occurs later in the 
installation. 

4 Click Next.  

The Preparing Setup progress page appears. When setup is complete, the Welcome page appears.  

5 Click Next. 

The Customer Information page appears.  

6 Type your User Name and Company Name.  

7 Click Next 

The Choose Destination Location page appears.  

8 Accept the default location, or click Change and browse to the desired location.  

9 Click Next. 
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The Select Features page appears.  
 

 
 

10 Expand the InForm node to see the list of products available for installation. The default core 
InForm software installation includes: 

• InForm and Cognos product documentation. 

• Sample studies. 

• InForm Portal 

The checkbox for the InForm Portal files is selected by default to enable the configuration of the 
InForm Portal application. 

11 If you do not want to include the InForm Portal application in your installation, deselect InForm 
Portal. 

Note: For information about configuring the InForm Portal application, see the Portal 
Administration Guide. 

12 Click Next. 

The Select Product Locale page appears.  

13 Select either English or Japanese for the Product Locale for the installation.  

This determines the language in which the InForm application pages appear after installation. 

14 Click Next. 

The Select the Oracle Home for InForm page appears. The Oracle Homes you configured 



 Installation Guide  

InForm 5.5.2 59 

during your Oracle installation appear on the page with the prefix KEY_ to indicate the 
Windows registry key. 

 

 
 

15 Select the entry for the Client Oracle Home registry key.  

16 Click Next. 

The Database Configuration page appears. 

Note: The defaults on this page were set when you configured the Oracle database. The 
values for your installation might be different. When installing onto a production server, 
Oracle recommends that you change the pfdbadmin password after running this wizard. For 
more information, see Changing the pfdbadmin password (on page 63). 
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Enter values or accept the defaults for the configuration fields. Click Next. 
 

Field Description 
Database Connection 
String 

String that the InForm server uses to connect to the Oracle instance for the 
study. 

Admin Database 
Username 

User name that is required to access the Admin database. The default is 
informadmin. 

Admin Database 
Password 

Password that is required to access the Admin database. The password is 
not case-sensitive. 

Note: If users can access your production servers using SQL*Plus, Oracle 
recommends that you change the default Admin Database Password during 
installation for security. If users cannot access production servers using 
SQL*Plus, normal firewall security should be sufficient. 

Unlike the InForm system user name and InForm system password, the 
Admin database user name and Admin database password can be changed 
only during the installation process. 

InForm System 
Username 

User name for the study database. If this is a new InForm installation or if 
you change the user name from the default during the installation, select the 
Prep Oracle checkbox. This instructs the InForm software installation to 
create the InForm account using the user name and password you specify. 
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Field Description 
InForm System 
Password 

Password for the study database. The default is pfdbadmin. The password 
is not case-sensitive. 

Note: Oracle recommends that you change the InForm system password 
after installing the InForm software. For more information, see the Secure 
Configuration Guide. 

Oracle SYS Password Password of the Oracle SYS account. This value is used only if you select 
the Prep Oracle checkbox to create the pfdbadmin account. 

Install Admin DB If selected, creates the: 

• informadmin user, using the Admin Database Username and Admin 
Database Password. 

• InForm Admin database for non-clinical data, such as users, sites, and 
configuration information.  

• Note: You must select this checkbox for both installation and 
upgrades. 

Prep Oracle If selected: 

• Runs the informprepora.vbs script, which creates the study database 
user, using the InForm System Username and InForm System 
Password. 

• Runs the mtsora102.vbs script, which sets up Oracle XA Transaction 
Support and sets the MTS Timeout to a minimum of 300 seconds. 

If not selected: 

• Verifies the study database user and password. 

Note: You need to select the Prep Oracle checkbox only the first time you 
install the InForm software on an instance. 

If any of the information is incorrect (for example, the Database Connection String or InForm 
Username is wrong), a Database Configuration Error window appears. For more information, 
see Oracle MTS configuration is invalid (on page 156). 

17 Click Back to return to the Database Configuration page to fix the incorrect information, and 
click Next when changes are complete. 

The Ready to Install the Program page appears. 

The installation checks both the .NET framework and ODAC, and if an upgraded version is 
required, a message appears. 

18 If you need to upgrade the .NET framework or ODAC, click Cancel to make the necessary 
corrections, and click Yes when the Exit Setup dialog box appears. 

19 If you exited the installation at the previous step, upgrade the .NET framework or ODAC 
version, and restart the installation wizard. 

20 Click Install. 

The Setup Status page appears. The progress of the installation is indicated on the screen. 

21 If your system does not have the required hardware or software components, the Requirements 
Not Met message appears. Click Cancel to make the necessary corrections, and click Yes when 
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the Exit Setup dialog box appears. 

22 If you exited the installation at the previous step, update the server with the required hardware or 
software components, and restart the installation wizard. 

23 When the setup is finished, the Oracle InForm 5.5 Reboot page appears.  

24 You must reboot the system if any of the following is true: 

• ODAC was upgraded during the installation process. 

• The PATH environment variable was modified. 

• The installation tried to access a locked file. 

25 Select Yes or No to indicate whether you want to reboot at this time, and click Finish. 

After rebooting, the final configuration process continues.  

When the system is finished, the InstallShield Wizard Complete page appears. 

26 Click Finish. 
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Changing the pfdbadmin password 
When you install the InForm software on a production server, Oracle recommends that you change 
the default password for the pfdbadmin user on the InForm application server. You can change this 
password on this window during the installation, or manually either before or after installing.  

To change and register the password of the pfdbadmin user, run the informprepora.vbs script: 

1 Open a Command Prompt window. 

2 Execute the following command from the InForm\Bin\DBOra folder of the InForm 
installation: 
cscript  informprepora.vbs  oracle_connection_string  
password_for_SYS_user [pfdbadmin_userid  new_pfdbadmin_password] 

 
3 Enter the following command to put the new password in the Registry: 

pfadmin  config  service  /sysdba  pfdbadmin_userid  
new_pfdbadmin_password 

 
For more information, informprepora.vbs (on page 180). 
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Enabling Secure Sockets Layer (SSL) 
 

Purpose Enables secure communications between servers. 

Where to perform All servers. 
 

Oracle recommends that you enable Secure Sockets Layer (SSL) for production server installations. 
If you are not using Cognos Reporting, enable SSL on all the servers at this time. If you are using 
Cognos Reporting, you can enable SSL on the InForm servers at this time and the Reporting servers 
after you install them, or wait until after the Cognos installations are complete, and enable SSL on all 
of the servers. 

To enable SSL: 

• Create, set up, and install and import key certificates. 

• Verify that the key certificates are installed correctly. 

Note: The procedures vary depending on whether you are using Windows server 2008 (with 
Internet Information Services 7.0) or Windows server 2003 (with Internet Information 
Services 6.0). 

• If you are installing Cognos Reporting, on the InForm application server update the following 
entries for the AuthenticationFilter key in the Windows Registry: 

• ExternalLoginURL 

• ExternalLoginFailureURL 

Note: If you are installing an InForm-only environment without Cognos Reporting, updating 
the ExternalLoginURL and ExternalLoginFailureURL registry key entries is not necessary. 

• Enable the InForm SSL system configuration option for each study through the InForm user 
interface or the MedML Installer utility. For more information, see the Study and Reporting Setup 
Guide. 

 

Creating, setting up and installing a key certificate for SSL in IIS 7.0 
These procedures are for Windows server 2008, with Internet Information Services (IIS) 7.0. 
 

Creating and setting up a key certificate for SSL in IIS 7.0 
1 Open Internet Information Services (IIS) Manager. 

2 Open the <machine_name> node. 

3 Go to the IIS Group > Feature View and select Server Certificate. 

4 From the Actions view, click Open Features. 

5 From the resulting Actions view, select Create Certificate Request. 

6 Request Certificate Wizard opens. 

7 Complete the Request Certificate page. Specify the name of the study server in the Common 
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name field, including the FQDN (for example: <machine_name>.north.pf.com). 

8 Click Next. 

9 Leave all default values in Cryptographic Service Provider Properties and click Next. 

10 Click the Browse. 

11 Specify the certificate request name and folder details. 

12 Click Save.  

13 Click Open. The file name appears in the text box. 

14 Click Finish. 
 

Installing a key certificate on the server machine in IIS 7.0 
1 Open your browser and go to  the security certificate server URL: 

http://<Windows_2008_security_certificate_server>/<certificate _request_page>.  

2 Click Request a certificate. 

3 Click Advanced certificate request. 

4 Click Submit a certificate request by using a base-64-encoded. 

5 Copy all the text in certreq.txt file in the first text field of the saved request.  

6 Click Submit.  

7 Select Base 64 encoded. 

8 Click Download certificate.  

9 Save to c:\certnew.cer. 

10 Click Download certificate chain. 

11 Save to c:\certnew.p7b. 

12 Go to Internet Information Services Manager to complete the certificate request. 

13 Select the <machine_name> node. 

14 From the Feature View, select Server Certificate under IIS group. 

15 From the Actions view, select Open Feature. 

16 From the Actions view, select Complete Certificate Request. 

17 Browse to c:\certnew.cer and give the Friendly name as machine name, and click Next. 

18 Set the SSL port to the port number for the study server. The default is 443.  

19 Click OK. 

20  Go to C:\ directory. Right click on c:\certnew.p7b. 

21 Select Install Certificate, and click Next.  

22 Click Next again, and click Finish. 

23 Click Yes in the Security Warning dialog box. 

24 Click OK on the confirmation dialog box. 

25 Set the Binding for Default Websites. 
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26 Go to IIS Manager. 

27 Select the <machine_name> node. 

28 Open the Web Sites node.  

29 Click Edit Site > Bindings, and click Add. 

30 Select the certificate type as Https and SSL. 

31 Click View. Verify that there is no red exclamation mark for the Certificate. 
 

Import the new key certificate to the local computer and the current user 
Perform these steps for both IIS 6.0 and IIS 7.0. 

1 Go to Start > Run, and type mmc. 

2 From the Console screen, go to file > Add/Remove Snap-in. 

3 Click Available snap-ins > Certificates > Add. 

4 Select My user account, and select Finish. 

5 Click Available snap-ins > Certificates > Add. 

6 Select Computer account, select Next > Finish, and click OK. 

7 Go to Certificates > Current User. 

8 Expand Trusted Root Certificate Authorities. 

9 Right-click Certificates and select Import. 

10 Browse to the certificate you created, select it, and complete the wizard, using all defaults. 

11 Repeat Step 8 through 10 for Certificates > Local Computer. 

Note: Make sure <Windows_2008_security_certificate_server> or 
<Windows_2003_security_certificate_server> is listed in the trusted roots of the certificate 
store for both the current user and the local computer. If it is not there, export it from the 
current user, save it to the disk, and import it to the local computer. 

 

Verifying that the certificate is installed correctly 
1 Open a browser window. 

2 Type: 
 https://<machine_name>.<domain_name>.com 

 
The Security Alert window appears.  

3 Verify that the date and name for the certificate are valid. 
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Creating, setting up and installing a key certificate for SSL in IIS 6.0 
These procedures are for Windows server 2003, with Internet Information Services (IIS) 6.0. 
 

Creating and setting up a key certificate for SSL in IIS 6.0 
1 Open Internet Information Services (IIS) Manager. 

2 Open the <machine_name> node. 

3 Open the Web Sites node.  

4 Right-click Default Web Site, and select Properties.  

5 Click the Directory Security tab.  

6 Click Server Certificate.  

The IIS Certificate Wizard starts.  

7 Click Next. 

8 Select Create a new certificate, and click Next. 

9 Select Prepare the request now, but send it later, and click Next. 

10 Click Next without changing any values. 

11 Type the certificate information. Specify the name of the study server in the Common name 
field. 

12 Enter the appropriate values and click Next. 

13 Enter the FQDN (for example: app01.north.pf.com) of the server, and click Next. 

14 Enter the appropriate values, and click Next. 

15 Click Next to agree to save the certificate to c:\certreq.txt, and click Next. 

16 Click Finish. 
 

Installing a key certificate on the server machine in IIS 6.0 
1 Open your browser and go to  the security certificate server URL: 

http://<Windows_2003_security_certificate_server>/<certificate _request_page>. 

2 Click Request a certificate. 

3 Click Advanced certificate request. 

4 Click Submit a certificate request by using a base-64-encoded. 

5 Copy all the text in certreq.txt file into the first text field of the saved request. 

6 Click Submit.  

7 Select Base 64 encoded. 

8 Click Download certificate.  

9 Save to c:\certnew.cer. 

10 Click Download certificate chain. 

11 Save to c:\certnew.p7b. 
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12 Go to Internet Information Services Manager to complete the certificate request. 

13 Right Click on Default Web Site and select Properties. 

14 Click the Directory Security tab. 

15 Click the Server Certificate button, and click Next. 

16 Click Process the pending request, and click Next. 

17 Browse to c:\certnew.cer, and click Next. 

18 SSL port should be set to 443, and click Next. 

19 Click Next and click Finish. 

20 Click the View Certificate button. 

21 If you see a red exclamation mark on the certificate icon in the General tab, proceed to the next 
step. If not skip to Step 30. 

22 Go to C:\ directory. 

23 Right-click c:\certnew.p7b. 

24 Select Install Certificate. Click Next. 

25 Click Next again and click Finish. 

26  In the Security Warning dialog box, click Yes. 

27 In the confirmation dialog box, click OK. 

28 Go back to IIS and click View Certificate button. 

29 Verify that the red exclamation mark no longer appears on the certificate icon. 

30 Open Internet Information Services (IIS) Manager. 

31 Open the <machine_name> node. 

32 Open the Web Sites node. 

33 Right click Default Web Site and select Properties. 

34 Click the Directory Security tab. 

35 In the Secure communications box, click Edit. 

36 Select Require secure channel (SSL). 

37 Click OK, and click OK again. 
 

Import the new key certificate to the local computer and the current user 
Perform these steps for both IIS 6.0 and IIS 7.0. 

1 Go to Start > Run, and type mmc. 

2 From the Console screen, go to file > Add/Remove Snap-in. 

3 Click Available snap-ins > Certificates > Add. 

4 Select My user account, and select Finish. 

5 Click Available snap-ins > Certificates > Add. 

6 Select Computer account, select Next > Finish, and click OK. 
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7 Go to Certificates > Current User. 

8 Expand Trusted Root Certificate Authorities. 

9 Right-click Certificates and select Import. 

10 Browse to the certificate you created, select it, and complete the wizard, using all defaults. 

11 Repeat Step 8 through 10 for Certificates > Local Computer. 

Note: Make sure <Windows_2008_security_certificate_server> or 
<Windows_2003_security_certificate_server> is listed in the trusted roots of the certificate 
store for both the current user and the local computer. If it is not there, export it from the 
current user, save it to the disk, and import it to the local computer. 

 

Verifying that the certificate is installed correctly 
1 Open a browser window. 

2 Type: 
 https://<machine_name>.<domain_name>.com 

 
The Security Alert window appears.  

3 Verify that the date and name for the certificate are valid. 
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Updating the DomainSuffix entry for the 
AuthenticationFilter registry key 

If you are installing Cognos Reporting, you must update the DomainSuffix entry for the Oracle 
AuthenticationFilter registry key if any of the following is true on the InForm study machine and the 
Cognos 8 BI Gateway Services machine. 

• You use proxy servers for the Cognos 8 BI Gateway Services machine and the InForm study 
server. 

• The fully qualified domain name (FQDN) for either server does not end with a common domain 
suffix. The FQDN is registered in the Oracle AuthenticationFilter DomainSuffix entry during 
installation of the InForm server and the Cognos 8 BI Gateway Services software. If the FQDN 
for both installations ends in a common domain suffix such as .net, .com, .org, .edu, or .gov (with 
or without country name like .uk or .au), you do not need to update the DomainSuffix entry 
unless you use proxy servers. 

• If the FQDN has just two levels. (For example: <servername>.com.) 

Perform the DomainSuffix configuration on both the Cognos 8 BI Gateway Services machine and 
the InForm study server. Both machines must have identical AuthenticationFilter entries for 
DomainSuffix. 

1 In the Windows Registry Editor, navigate to the following Windows Registry key: 
MyComputer\HKEY_LOCAL_MACHINE\SOFTWARE\ORACLEHS\AuthenticationFilter 
 

2 Update the entry for DomainSuffix. 

a Right-click the entry, and select Modify. 

The Edit String dialog box appears. 

b Enter the new value in the Value Data field. Edit the entry: 

• If you use proxy servers, or if the fully qualified domain name for either server does not 
end with a common domain suffix, remove every part of the domain suffix that is not 
identical on both computers. For example, if the FQDN includes 
<servername>.<companyname>.co.uk, after the edit, the entry would be 
<companyname>.co.uk. 

• If the InForm software and Cognos 8 BI are installed on the same machine, and the 
FQDN has only two nodes such as <servername>.com, you must include the server name 
and the domain suffix in the entry. In the above example, the entry would read 
<servername>.co.uk. 

c Click OK. 

3 Exit the Windows Registry Editor. 

4 Restart IIS.  

5 On the InForm server, restart the InForm Service. 
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Updating the ExternalLoginURL and 
ExternalLoginFailureURL entries on the InForm server 

If you are implementing SSL, perform these steps for both IIS 6.0 and IIS 7.0. 

On each server that hosts an InForm study, update the ExternalLoginURL and 
ExternalLoginFailureURL entries for the Oracle AuthenticationFilter registry key. 

1 In the Windows Registry Editor, navigate to the following Windows Registry key: 
MyComputer\HKEY_LOCAL_MACHINE\SOFTWARE\PHASEFORWARD\AuthenticationFilter 
 

2 Update the entries for ExternalLoginURL, ExternalLoginFailureURL. For each entry: 

a Right-click the entry and select Modify. 

The Edit String dialog box appears. 

b Enter the new value in the Value Data field and click OK. For more information, see the table 
that follows this procedure. 

3 Exit the Windows Registry Editor. 

4 Restart IIS. 
 

Entry What to specify in the Value Data field 
ExternalLoginURL Specify the URL to configure for HTTPS, and make sure that the 

<portnumber> value reflects the port number for HTTPS. 
https://<servername>.<domainname>:<portnumber>/PFExternalLog
in/ 
ExternalLoginFrameset.html 
 
Example:  
https://APPSRV23.north.pf.com:443/PFExternalLogin/ 
ExternalLoginFrameset.html 
 

ExternalLoginFailure
URL 

Specify the URL to configure for HTTPS, and make sure that the 
<portnumber> value reflects the port number for HTTPS. 
https://<servername>.<domainname>:<portnumber>/PFExternalLog
in/ 
ExternalLoginEscape.html 
 
Example:  
https://APPSRV23.north.pf.com:443/PFExternalLogin/ExternalLo
ginEscape.html 
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Qualifying the installation 
Qualifying the installation verifies that the study was installed successfully. The qualification process 
consists of a set of administrative and clinical activities that perform the basic functionality of the 
InForm application. The tests are divided into Admin and CRC/CRA tests. 
 

Qualification prerequisites 
 

 Prerequisite Where to get more information 
 InForm software is installed. Installing the InForm software 

 Sample study PFST55 is installed, and the 
server and study are running. 

Study and Reporting Setup Guide, Setting up an 
InForm study > Installing a sample study 

Study and Reporting Setup Guide, Setting up an 
InForm study > Starting an InForm server and 
study 

 Passwords for dobrien and lhill users have 
been changed to InForm. 

Changing the passwords of the sample study 
users (on page 72) 

 
 

Changing the passwords of the sample study users 
1 Log in to the PFST55 study as system/manager. 

2 Click Admin. 

3 For the dobrien and lhill users: 

a Click the user Account Name. 

b On the Users page, deselect the User Active checkbox. 

c Click Submit, and click OK in the message box. 

d Click Change Password. 

e On the Change Password page, type InForm in the New password and Confirm new password 
fields. 

f Click Submit, and click OK in the message box. 

g Click Return. 

h On the Basic Info for User page, select the User Active checkbox. 

i Click Submit, and click OK in the message box. 

4 Log out. 
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Admin—Users test 
 

Pass/Fail Step Description 
 1 Log in as the system user. 

 2 Click Admin. 

 3 Select each of the following: Users, Rights, Groups, Sites, Configuration, 
Events, Rules, and System. 

 4 Click Users, and verify that the following users are active: 

• lhill 

• dobrien 

• mcarlson 

 5 On the Users page, click Add User. 

 6 Enter X in the User Name field. 

In the User must change password at next login field, select No. 

Select values in the Product Locale and Preferred Study Locale fields. 

Click Submit, and click OK in the message box. 

 7 Click Return. 

Verify that user X is shown in the list. 

 8 Click the Account Name and the Group tab for user X. 

Assign a rights group and two user site associations.  

Click Submit, and click OK in the message box. 

 9 Click Return.  

Click any link for user X. 

 10 Click Change Password. 

Give user X a password with eight characters or more. 

Click Submit, and click OK in the message box. 

 11 Click Return.  

Select User Active. 

Click Submit, and click OK in the message box. 

Log out. 

 12 Log in as user X, using the password assigned in Step 10. 

Click Subjects. 

Verify that the Site drop-down list contains only the sites selected in Step 
8. 

 13 Log out. 
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Admin—Rights test 
 

Pass/Fail Step Description 
 1 Log in as the system user. 

 2 Select Rights. 

Click Add Rights Group. 

 3 Enter new rights group information. 

Click Submit, and click OK in the message box. 

 4 Click Return.  

Verify that the rights group that you just created is in the list. 
 

 

Admin—Sites test 
 

Pass/Fail Step Description 
 1 Select Sites. 

Click Add Site.  

Enter the new site information. Site Name, Site Mnemonic, and Study 
Locale are required. 

Click Submit, and click OK in the message box. 

 2 Click Return. 

Verify that the site that you just created is in the list. 
 

 

Admin—Groups test 
 

Pass/Fail Step Description 
 1 Select Groups. 

Click Add Group.  

Select Signature from the Group Type drop-down list, and type the group 
information.  

Click Submit, and click OK in the message box. 

 2 Click Return. 

Verify that the signature group you just created is in the list. 
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Pass/Fail Step Description 
 3 Click Add Group. 

Select Query from the Group Type drop-down list, and enter group 
information. 

Click Submit, and click OK in the message box. 

 4 Click Return. 

Verify that the query group you just created is in the list. 
 

 

Admin—Users and Groups test 
 

Pass/Fail Step Description 
 1 Select Groups. 

In the Members column for the signature group that was created in 
the Admin—Groups test section, click Change.  

For more information, see Admin—Groups test (on page 74). 

 2 Select user X in the Available users list.  

Click Add. 

 3 Verify that user X is in the Users in (signature group) list. 

Click Submit, and click OK in the message box. 

 4 Click Return. 

Verify that the Member Count column shows 1 (and not 0) for the 
signature group. 

 5 In the Members column for the query group that was created in the 
Admin—Groups test section, click Change. 

For more information, see Admin—Groups test (on page 74). 

 6 Select user X in the Available users list. 

Click Add. 

 7 Verify that user X is in the Users in (query group) list. 

Click Submit, and click OK in the message box. 

 8 Click Return. 

Verify that the Member Count column shows 1 (not 0) for the query 
group. 

 9 Log out. 
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CRC / CRA tests 
1 Open two browser windows, using the following URL: 

http://machine_name/pfst55 
 

2 Log in to one session as dobrien (a CRC) and the other as lhill (a CRA). 

3 Perform the CRC/CRA tests. 
 

As dobrien (CRC) 
 

Pass/Fail Step Description 
 1 Click Enroll. 

Click Add Candidate. A question window appears. 

 2 Enter subject information. 

Click Submit. 

 3 Click the Screening Number for the subject who was just entered. 

Edit one of the fields, and provide a reason for change. 

Click Submit, and verify that the field you edited is changed. 

 4 Click Return. 

 5 In the Enrolled column, click the Enroll link. 

 6 Enter the subject number (site ID followed by a hyphen and a 3-digit 
number).  

Click Submit.  

The System Enrollment page displays the heading Candidate Meets All 
Criteria for Enrollment in Study. 

 7 At the bottom of the page, click Enroll. 

Verify that a Subject Schedule (Visit Calculator) page appears for the 
subject with a default baseline date of the current date. 

 8 Change the Start Date. 

Verify that the associated dates are updated correctly. 

 9 Click Go To First Visit. 

 10 Complete the DOV form. 

Click OK. 

The list of forms for the first visit appears.  

Navigate to each form in the first visit. 

 11 Click the Time and Events arrow at the left end of the visit ruler. 

View the Time and Events Schedule to check all visits for the new 
subject. 
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Pass/Fail Step Description 
 12 Click the status icon for the Base visit. 

Click the status icon for the Demographics form. 

Enter data in the form, and click Submit. 

 13 Click Return. 

Click the status icon for the Vital Signs form. 

Enter a value of 200.5 degrees Fahrenheit in the Temperature item. 

Click Submit, and verify that an autoquery is generated. (The 
background for the question becomes pink and an error message is 
shown in red.) 

 14 Click the comment icon in the right column for an item, and add a 
comment in the Comment field. 

Click Submit, and click OK in the message box. 

 15 Click Return. 

Click the query text. 

On the Queries detail page, click Update Data and Answer. 

Change the Temperature value to 98.6 and add a reason for change. 

Click Submit, and click OK in the message box. 

 16 Verify that the auto-query is answered. The background for the 
question changes from pink to gray. 

 17 Click the status icon for any form that has data.  

Select Mark SV Ready from the Select Action list, and click Apply. 

 18 Click the status icon for the Demographics form.  

Select Print Preview from the Select Action list, and click Apply. Verify 
that the preview of the form appears.  

Click Print. 

 19 Verify that the report prints with the correct information. 

 20 Click the Help icon, and select InForm User Guide. 

Verify that the User Guide is installed and functioning. 
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As dobrien (CRC) and lhill (CRA) 

Note: Keep both browsers open to make the following steps easier to perform. 

 

Pass/Fail Step Description 

 1 As lhill: 

Click Subjects. 

In the Subject column, click the link for the subject that was created by 
dobrien in the CRC test. 

Click the status icon for the Base visit. The list of forms appears. 

Click the status icon for the Demographics form. 

Create an open query on an item entered by dobrien: 

Click the query icon ( ) for the item, click Create Query, select Create 
Query in Opened State in the Action list, and select a reason. 

Click Submit, and verify that the query appears with red text in a pink 
box under the item. 

 2 As dobrien: 

Click Subjects. 

In the Subject column, click the link for the subject who was created by 
dobrien in the CRC test. 

Click the status icon for the Demographics form. 

Answer the query:  

Click the query icon or the red query text. 

In the Current Value section, click Answer. In the Query section, enter a 
response to the query. 

Click Submit, and verify that the query disappears from the form. 

 3 As lhill: 

Refresh the Demographics form: click the CRF history icon ( ), and 
select the Demographics form. 

Re-issue the answered query:  

Click the query icon, and in the Current Value section, click Reissue as 
Open.  

In the Query section, select a reason. 

Click Submit, and verify that the query reappears. 
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Pass/Fail Step Description 

 4 As dobrien: 

Refresh the Demographics form: click the CRF history icon ( ), and 
select the Demographics form. 

Re-answer the query. 

Click Submit, and verify that the query disappears from the form. 

 5 As lhill: 

Refresh the Demographics form: click the CRF history icon ( ), and 
select the Demographics form. 

Close the query:  

Click the query icon, and in the Current Value section, click Close Query. 

In the Query section, select a reason. 

Click Submit, and verify that the query disappears from the form. 

 6 Log out of both browser sessions. 
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About the Cognos 8 BI core software installation 
The Cognos 8 BI software installation process installs: 

• Cognos 8 BI Application Tier Components. 

• Cognos 8 BI Gateway services. 

• Cognos 8 BI Content Manager. 

You can install the components on separate servers or on the same server, or you can distribute each 
component across multiple servers. For more information, see the Cognos Installation and Configuration 
Guide, which is included in the InForm product download. 

For more information, see Checklist—Installing the Cognos 8 BI core software (on page 16). 
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Installing Sun ONE Directory Server 
 

Installation Sun ONE Directory Server 

Purpose Installs the Sun ONE Directory Server software on a Windows 2003 
server. 

File to extract SunONE_52_Patch4_install.zip 

Location of setup.exe Root folder of extracted files. 

Where to install Cognos 8 BI server or a separate, dedicated server. 
 

Note: This release of Sun ONE Directory Server is for a Windows 2003 server only. 

1 Download the SunONE_52_Patch4_install.zip file from the Oracle Download Center. The 
setup.exe file is in the root folder. 

2 Double-click setup.exe. 

The Welcome page of the installation wizard appears. 

3 Click Next. 

The License Agreement page appears. 

4 Click Yes (Accept License) to accept the software license, and click Next. 

The Fully Qualified Computer Name page appears. 
 

 
 

5 Enter the fully qualified domain name of the machine on which you are installing the Sun Java 
System LDAP Directory Server, and click Next. 
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The Select Server or Console Installation page appears. 
 

 
 

6 Select Sun Java System Servers, and click Next. 

The Type of Installation page appears. 

 
 

7 Select Typical, and click Next. 
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The Select Installation directory page appears. 
 

 
 

8 Select a folder in which to install the software, and click Next. 

If the Create a new directory? message appears, click Create Directory to create the folder. 

The Select Components page appears. 
 

 
 

9 Make sure that all components are selected. 
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10 If prompted to turn the SNMP service off, click OK. 

The Configuration Directory Server page appears. 
 

 
 

11 Select The new instance will be the configuration Directory Server, and click Next. 

The Data Storage Location page appears. 
 

 
 

12 Select Store data in the new Directory Server, and click Next. 
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The Directory Server Settings page appears. 
 

 
 

13 Enter the following values, and click Next. 
 

Field Value or Comments 
Server Identifier Physical name of the LDAP server. 

Server Port Use the default port number 389 that is listed.  

Note: Using a specific port number could result in port conflicts with 
other applications. Using the default number eliminates port conflicts.  

Suffix Network domain (for example, if the domain is north.pf.com, enter  
dc=north,dc=pf,dc=com).  



Chapter 7  Installing the Cognos 8 BI core software and Sun ONE Directory Server  
 

88 InForm 5.5.2 

 

The Configuration Directory Server Administrator page appears.  
 

 
 

14 Enter the following values, and click Next. 
 

Field Value or Comments 
Administrator ID Name for registering the server with the Configuration Directory Server. 

Password Password for the user name entered in the Administrator ID field. 

Password (again) Confirmation of the password. 
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The Administration Domain page appears. 
 

 
 

15 Enter the domain name of the organization managing the administration domain (for example, 
north.pf.com), and click Next. 

The Directory Manager Settings page appears. 
 

 
 

16 Enter the following values, and click Next. 
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Field Value or Comments 
Directory Manager 
DN 

Distinguished Name for the Directory Manager user, in the format 
cn=<user name>. 

Password Password of the admin user specified in the Directory Manager DN 
field. 

Password (again) Confirmation of the password. 
 

The Administration Server Port Selection page appears. 
 

 
 

17 In the Administration Port field, keep the default port number, and click Next. 

The Ready to Install page appears. 

18 Click Install Now. 

A status window tracks the process of the installation and configuration. 

19 Review Configuration Details, and when configuration is complete, click Next. 
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The Installation Summary page appears. 
 

 
 

20 Click Details, and review the installation information. 

21 Click Close, and restart the computer. 
 

Creating the PFWD namespace and crnsyadmin user 
You must create namespaces in both Cognos 8 Business Intelligence and the Sun ONE Directory 
Server for the Reporting and Analysis module. 
 

Creating PFWD and crnsysadmin on the LDAP server 
 

Purpose Creates the PFWD namespace and crnsysadmin user in Sun ONE 
Directory Server. 

Where to perform Server where the Sun ONE Directory Server is installed. 
 

1 On the server where the Sun ONE Directory Server is installed, use the Cognos Configuration 
utility to ensure that the Cognos 8 Business Intelligence Service is stopped. 

2 Launch the Sun Java System Server Console: Click Start > All Programs > Sun Java(TM) System 
Server Products > Sun Java(TM) System Server Console 5.2. 

or 

In the \Sun\MPS folder of the Sun ONE Directory Server installation, double-click the 
startconsole.exe file. 

The Sun Java System Server Console starts. 

3 Log on, using the password you assigned to the Administrator ID during the Sun ONE 
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Directory Server installation (on the Configuration Directory Server Administrator page of the 
installation wizard). 

4 Expand the <machine name> and Server Group nodes. 

5 Select Directory Server, and click Open in the right pane. 

6 Select the Directory tab. 

7 Right-click the directory node that represents the target domain (for example, ou=pf,ou=con) in 
the directory tree, and select New > Organizational Unit. 

The Create New Organizational Unit dialog box appears. 

8 In the Name field, type PFWD (all uppercase).  

9 Click OK. 

The PFWD node is added to the list of Directory Administrators in the right pane. 

10 On the Directory tab, right-click PFWD in the directory tree, and select New > User. 

The Create New User dialog box appears. 

11 Create a new user for the PFWD namespace as follows:  

• User ID—crnsysadmin 

• Password—<crnsysadmin password> 

12 Click OK.  

13 Close the Sun Java System Server Console utility. 
 



 Installation Guide  

InForm 5.5.2 93 

Install the Oracle Directory Server 
Note: The Oracle Directory Server Enterprise Edition can be installed on Windows 2008 server or 
Windows 2003 server. 

1 Download and install the Oracle Directory Server. 

2 Configure and deploy the Oracle Directory Server to a supported web server. 

For more information, see the Oracle website, the Oracle Directory Server Enterprise Edition 
documentation, or your Oracle database documentation. 

 

Create the PFWD organizational unit (OU) and crnsysadmin user on the Oracle 
Directory Server 

If you are using Reporting, you must create an PFWD namespace and crnsysadmin user on the 
Cognos Content Manager Server and the Cognos Report Server. For more information, see 
Creating PFWD and LDAP namespaces on the Cognos 8 BI server (on page 130) 

1 On the server where the Sun ONE Directory Server is installed, use the Cognos Configuration 
utility to ensure that the Cognos 8 Business Intelligence Service is stopped. 

2 Launch the URL for the Sun ONE Directory Server and log in to the Oracle Directory Service 
Control Center. 

3 Select the Directory Server tab. In the Directory Servers list, click the server name. 

The Server Operations tab opens. 

4 Select the Entry Management tab. 

5 Select the DN from the Browse Data list, and click New Entry. 

The New Entry wizard page displays the Specify Entry Location page. 

6 Make sure that the Entry Parent DN is correct, and click wizard button next. 

The Choose Object Class page appears. 

7 Select Organizational Unit - (organizationalUnit) from the Entry Type drop-down list, and click 
wizard button next. 

The Configure Attributes page appears. 

8 In the Organizational Unit (ou) field, type PFWD (all uppercase), and click wizard button next. 

The Summary page appears. 

9 Review the information. If it is correct, click wizard button finish. 

The ORACLEHS node is added to the Browse Data list. 

10 On the Entry Management tab, right-click ou=PFWD in the Browse Data list, and click New 
Entry. 

The New Entry wizard displays the Specify Entry Location page. 

11 Make sure that the Entry Parent DN is correct, and click wizard button next. 
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The Choose Object Class page appears. 

12 Select User - (inetOrgPerson) from the Entry Type drop-down list, and click wizard button next. 

The Configure Attributes page appears. 

13 Create a new user for the PFWD namespace as follows:  

• Full Name (cn)—crnsysadmin 

• Last Name (sn)—crnsysadmin 

• User ID (uid)—crnsysadmin 

• Password (userPassword)—<crnsysadmin password> 

• Confirm Password—<crnsysadmin password> 

14 Click wizard button next. 

The Summary page appears. 

15 Review the information. If it is correct, click wizard button finish. 

The uid=crnsysadmin node is displayed in the Browse Data list on the Entry Management tab. 
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Installing the Cognos 8 BI software 
 

Installation Cognos 8 BI core software 

Purpose The Cognos 8 BI software installation process installs: 

• Cognos 8 BI Application Tier Components. 

• Cognos 8 BI Gateway services. 

• Cognos 8 BI Content Manager. 

File to extract CZAG1ML.tar.gz 

Location of issetup.exe \\Win32 folder. 

Where to install Cognos 8 BI server or servers. You can install the components on 
separate servers or on the same server, or you can distribute each 
component across multiple servers. For more information, see the 
Cognos Installation and Configuration Guide, which is included in the 
InForm product download. 

 

1 Download the CZAG1ML.tar.gz file from the Oracle Download Center, extract the archive file, 
and navigate to the issetup.exe file in the \Win32 folder. 

2 Double-click issetup.exe. 

The Welcome page of the installation wizard appears. 
 

 
 

3 Select the language to use for the installation, and click Next. 

The License Agreement page appears. 

4 Read the license agreement, select I accept, and click Next. 
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The Installation Location page appears. 
 

 
 

5 In the Installation Directory field, browse to or type the drive and destination folder for 
Cognos 8 Business Intelligence (for example E:\cognos\c8), and click Next.  

If the Folder does not exist message appears, click Yes to create the folder. 

The Component Selection page appears. 
 

 
 

6 Make sure that all components except Cognos Content Database are selected, and click Next. 
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The Shortcut Folder page appears. 

7 Accept the default Program folder, and click Next. 

The Installation Summary page appears. 

8 Review the installation summary, and click Next. 

The installation program installs the components that you selected. This takes several minutes. 
When the component installation is complete, the Finish page appears. 

 

 
 

9 On the Finish page: 

• To view the transfer log or the summary-error log, click the appropriate View button. 

• To view the readme file, select View Cognos Readme. 

• Verify that Start Cognos Configuration is not selected.  

10 Click Finish. 
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Upgrading Cognos 8.4.1 software to Fix Pack 5 
 

Installation Cognos 8.4.1 core software to Fix Pack 5.upgrade 

Purpose Upgrades the Cognos 8.4.1 core software to Fix Pack 5. 

File to extract C8BI_8.4.1_Win32_FP005.tar.gz 

Location of issetup.exe \\Win32 folder. 

Where to install Server where the Cognos 8 BI core software is installed. 
 

1 Download the C8BI_8.4.1_Win32_FP005.tar.gz file from the Oracle Download Center, extract 
the archive file into a different folder from the folder where you originally downloaded the 
Cognos 8 BI version SP0 software, and navigate to the issetup.exe file in the \Win32 folder. 

2 Double-click issetup.exe. 

The Welcome page of the upgrade wizard appears. 
 

 
 

3 Select the language to use for the installation. English is the default. Click Next. 

The License Agreement page appears. 

4 Read the license agreement, select I accept, and click Next. 
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The Installation Location page appears. 
 

 
 

5 In the Installation Directory field, browse to or type the same drive and destination folder that 
you specified for the initial installation of Cognos 8 Business Intelligence (for example 
C:\cognos\c8), and click Next.  

The following warning appears: 
The installation will replace existing files. 
Select 'Yes' to automatically create a backup of all files that are 
replaced. 

6 Click Yes. 

The Shortcut Folder page appears. 

7 Accept the default Program folder, and click Next. 

The Installation Summary page appears. 

8 Review the installation summary, and click Next. 
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When the installation is complete, the Finish page appears. 
 

 
 

9 To review the transfer log or summary error log, click the appropriate View button. 

10 Click Finish. 
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Installing the 8.4 hotsite updates 
 

Installation Cognos 8.4.1 Fix Pack 5 hotsite updates. 

Purpose Upgrades the Cognos 8.4.1 Fix Pack 5 software to required patch 
levels. 

File to extract up_c8bisrvr_win32_8.4.107.1013_ml.tar.gz 

Location of issetup.exe \\Win32 folder. 

Where to install Server where the Cognos 8 BI core software is installed.  
 

In addition to the upgrade to FP5 of the Cognos 8 BI software, you must install hotsite updates. 

1 Download the up_c8bisrvr_win32_8.4.107.1013_ml.tar.gz file from the Oracle Download 
Center, extract the archive file into a different folder from the folder where you originally 
downloaded the Cognos 8 BI version SP0 software, and navigate to the issetup.exe file in the 
\Win32 folder. 

2 Double-click issetup.exe. 

The Welcome page of the upgrade wizard appears. 
 

 
 

3 Select the language to use for the installation, and click Next. English is the default language. 

The License Agreement page appears. 

4 Read the license agreement, select I accept, and click Next. 
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The Installation Location page appears. 
 

 
 

5 In the Installation Directory field, browse to or type the same drive and destination folder that 
you specified for the initial installation of the Cognos 8 Business Intelligence software (for 
example C:\cognos\c8), and click Next.  

The following message appears: 
The installation will replace existing files. 
Select 'Yes' to automatically create a backup of all files that are replaced. 

6 Click Yes. 

The Shortcut Folder page appears. 

7 Accept the default Program folder, and click Next. 

The Installation Summary page appears. 

8 Review the installation summary, and click Next. 
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When the installation is complete, the Finish page appears. 
 

 
 

9 To review the transfer log or summary error log, click the appropriate View button. 

10 Click Finish. 
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Setting up the Oracle JDBC driver 
 

Purpose Makes the Oracle JDBC driver available on the server or servers 
where the Cognos 8 BI Content Manager is installed. 

Location of file ojdbc5.jar (11g)—Download from the Oracle support website  

ojdbc14.jar (10g)—In the oracle\product\10.2.0\client_1\jdbc\lib 
folder. 

Where to perform Every server where the Cognos 8 BI Content Manager is installed. 
 

Before running the wizards that customize the Cognos 8 BI software for the InForm environment, 
you must set up the Oracle JDBC driver on any computer that has a Cognos 8 Business Intelligence 
Content Manager installed. 

For 11g: 

1 Download the ojdbc5.jar file from the Oracle support website. 

2 Copy the ojdbc5.jar file to the <Cognos_Installation_Directory>\webapps\p2pd\WEB-
INF\lib folder. 

For 10g: 

1 Navigate to the Oracle\product\10.2.0\client_1\jdbc\lib folder. 

2 Copy the ojdbc14.jar file (10g) to the <Cognos_Installation_Directory>\webapps\p2pd\WEB-
INF\lib folder. 
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Enabling Secure Sockets Layer (SSL) 
 

Purpose Enables secure communications between servers. 

Where to perform All servers. 
 

If you have not already done so in Enabling Secure Sockets Layer (SSL) (on page 64), Oracle 
recommends that you enable Secure Sockets Layer (SSL) for all Cognos servers in production server 
installations. 

To enable SSL: 

• Create, set up and install and import key certificates. For more information, see Enabling 
Secure Sockets Layer (SSL) (on page 64). 

• Verify that the key certificates are installed correctly. For more information, see Verifying that 
the certificate is installed correctly (on page 66). 

Note: The procedures vary depending on whether you are using Windows server 2003 (with 
Internet Information Services 6.0) or Windows server 2008 (with Internet Information 
Services 7.0). 

• If you are installing Cognos Reporting, on the InForm application server update the following 
entries for the AuthenticationFilter key in the Windows Registry: 

• ExternalLoginURL  

• ExternalLoginFailureURL 

For more information, see Updating the ExternalLoginURL and 
ExternalLoginFailureURL registry key entries on the Cognos 8 BI servers (on page 
125). 

Note: If you are installing an InForm-only environment without Cognos Reporting, it is not 
necessary to update the ExternalLoginURL and ExternalLoginFailureURL registry key 
entries. 

• Enable the InForm SSL system configuration option for each study through the InForm user 
interface or the MedML Installer utility. 
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Customizing Cognos 8 BI email settings 
 

Purpose Configures the SMTP mail server so that email can send links to 
report output. 

Where to perform Any Cognos 8 BI server. 
 

You can set up a feature that you can use to send links to report output using email. By default, the 
report links point to the server where the Cognos 8 BI Gateway services are installed (the Gateway 
server).  

If your environment is configured with an F5 switch, and you must use the generic URL to the 
switch, and instead of pointing to the Gateway server, you must configure the SMTP mail server, 
using the Cognos Configuration utility. 

1 Using the Cognos Configuration utility, configure the SMTP mail server. 

For more information, see the Cognos 8 BI Reporting Quick Start Installation and Configuration Guide. 

2 Select File > Save. 

The Cognos Configuration utility validates the settings and saves the configuration. 

3 When the checks are complete (all items are marked with a green check mark), click Close. 

4 Select Actions > Start. 

The Cognos Configuration utility registers and starts the Cognos 8 BI Service. 

5 Click Close, and close the Cognos Configuration utility window. 
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Configuring the Internet Information Services (IIS) for 
Windows on the Cognos Gateway server 

 

Purpose Enables Web Service Extensions so that IIS works with Windows 
2003 and 2008. 

Where to perform Server where the Cognos 8 BI Gateway services are installed. 
 

If you install Cognos 8 BI on its own dedicated server, you must configure IIS to work with 
Windows 2003 and 2008. On the server where the Cognos 8 Business Intelligence Gateway services 
are installed: 

1 Navigate to Control Panel > Administrative Tools > Internet Information Services (IIS) Manager, and 
expand the node for the local computer. 

2 Select Web Service Extensions. 

3 Make sure that the following options are set to Allowed: 

• All Unknown CGI Extensions. 

• All Unknown ISAPI Extensions. 

• ASP.NET v1.1.4322. 

• ASP.NET v2.0.50727. 

• WebDAV. 

• Active Server Pages. 

 



Chapter 7  Installing the Cognos 8 BI core software and Sun ONE Directory Server  
 

108 InForm 5.5.2 



 

InForm 5.5.2 109 

 

In this chapter 
About customizing the Cognos 8 BI software for the InForm environment ........................... 110 

Running the CRNConfig\setup.exe wizard ................................................................................... 111 

Running the CRNGatewayConfig\setup.exe wizard .................................................................... 118 

Configuring for SSL in the Cognos Configuration utility ............................................................ 121 

Starting the Cognos 8 BI servers ...................................................................................................... 122 

Configuring settings for Comma Separated Values (CSV) report output ................................. 123 

Updating registry settings .................................................................................................................. 125 

Enabling communication among distributed Cognos 8 BI software components .................. 128 

Configuring the Cognos 8 BI Gateway server to run the Cognos Application Firewall ......... 129 

Creating PFWD and LDAP namespaces on the Cognos 8 BI server ........................................ 130 

 
 

C H A P T E R  8  
Customizing the Cognos 8 BI software for 
the InForm environment 



Chapter 8  Customizing the Cognos 8 BI software for the InForm environment  
 

110 InForm 5.5.2 

About customizing the Cognos 8 BI software for the 
InForm environment 

To customize the Cognos 8 BI software for the InForm environment, you run installation and 
configuration wizards, you create the PFWD namespace, update registry settings, and crnsysadmin 
user. 

For a checklist of configuration steps, see Checklist—Customizing Cognos 8 BI for Reporting 
and Analysis (on page 18). 
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Running the CRNConfig\setup.exe wizard 
 

Wizard Cognos 8 BI Customization for InForm (CRNConfig\setup.exe). 

Purpose Copies customization files and modifies files needed to customize the 
Cognos 8 BI software for the InForm application. 

Location of setup.exe CRNConfig folder of the InForm installation image. 

Where to install Server where the Cognos 8 BI Content Manager is installed and each 
Cognos 8 BI report server. 

 

1 Copy the CRNConfig folder from the InForm installation image to a location that you can 
access from the server where the Cognos 8 BI Content Manager is installed and each Cognos 8 
BI report server. 

2 On the server where the Cognos 8 BI Content Manager is installed and each Cognos 8 BI report 
server, run the CRNConfig\setup.exe program file. 

The Choose Setup Language window appears. 
 

 
 

3 Select the language you want the wizard to use during setup. Select either English or Japanese. 
English is the default. Click Next.  

The Welcome page appears.  

4 Click Next.  
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The Cognos 8 BI Installation Location page appears. 
 

 
 

5 Specify the folder in which the Cognos 8 BI Content Manager is installed, and click Next.  

The Setup Type page appears. 
 

 
 

6 Select the memory model (Small, Medium, or Large) that is most appropriate for your business, 
and click Next. 
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Note: You can change this later if you select the wrong size. 

The Content Store page appears. 
 

 
 

7 Enter the following values. 
 

Field Description 
Database server Fully qualified domain name of the database server where the 

Cognos 8 BI Content Store schema is installed. 

Port Port number for communicating with the database server. 

SID SID for communicating with the database server. 

User Name User name of the Oracle user in the Cognos 8 BI content store 
database. You created this user when you configured the Cognos 8 
BI content store database. 

Password, Confirm 
Password 

Password of the CBI user in the Cognos 8 BI content store database.  

 

8 Click Next.  
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The Custom Authentication Provider Configuration Information page appears. 
 

 
 

9 Enter the following values. 
 

Field Description 
Database server Fully qualified domain name of the user that contains the 

TRIAL_URLS table. 

Port Port number for communicating with the database server. 

SID SID for communicating with the database server. 

User Name The name of the PFCAPAdmin user.. 

Password, Confirm 
Password 

Password of the CBI user in the Cognos 8 BI content store database.  

 

10 Click Next.  
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The LDAP Configuration Information page appears. 
 

 
 

11 Enter the following values. 
 

Field Description 
LDAP Server Fully qualified domain name of the server where Sun ONE 

Directory Server is installed. 

LDAP Port Port number used to communicate with the LDAP server. 

Administrator DN Distinguished Name of the administrator of the server. Use the 
format and values shown beneath the field. 

Note: The Administrator DN value corresponds to an LDAP user 
who has READ and SEARCH access to the Base Distinguished 
Name (BDN). The BDN specifies the top level or root of the 
directory structure, which is the starting place for searches. 

Password, Confirm 
Password 

Password of the administrator. 

Parent Node DN 

(Base Distinguished Name) 

Distinguished name of the Parent Node. Use the format shown 
beneath the field. Do not enter a space between after the comma 
between the parts of the domain. 

Note: The Parent Node DN is also known as the Base 
Distinguished Name (BDN). The BDN specifies the top level or 
root of the directory structure, which is the starting place for 
searches. 

Cognos Admin OU Location of the Cognos Admin organizational unit. 
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12 Click Next.  

The CRN Web Server (gateway or IIS server) page appears. 
 

 
 

13 Type the fully qualified domain name of the Cognos 8 BI Gateway server, or click Browse to 
select it from the dialog box. 

14 Click Next.  

If the server has not yet been installed, the installation script asks if it should continue using the 
server name provided. If so, click OK.  

The Ready to Install the Program page appears. 

15 Click Install.  

The Setup Status page appears.  

The program copies the necessary files and creates the CRNSetup.xml file in an InForm 
subfolder under the Cognos 8 installation (...\InForm\Config). The name and location of the file 
appear in a message window. You need the CRNSetup.xml file to run the Cognos 8 BI Gateway 
Customization for InForm wizard. 

16 The Wizard Complete page appears. 

17 Click Finish. 
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Changing or creating a new MotioCAP_informcap.properties file 
The Cognos 8 BI Customization for InForm wizard also creates the 
MotioCAP_informcap.properties file. The information in the file is used to configure the custom 
authentication provider’s connection to Sun ONE Directory Server (LDAP). 

Note: In most cases you do not need to change the MotioCAP_informcap.properties file. 

 

Circumstances that 
require changes to file 

Required action 

LDAP configuration 
changes after installation. 

LDAP properties used for authenticating the admin OU: 

Enter the URL of the server where LDAP is installed. Change the 
number of the LDAP port if necessary. 

Example:  ldap.url=ldap://appsru02.north.pf.com:389 

Enter the Parent Node Distinguished Name. 

Example: ldap.base.dn=dc=north,dc=pf,dc=com 

Enter the Administrator Distinguished Name. This user name is 
used by the Custom Security Provider (CSP) to log on to LDAP.  

Example: ldap.bind.username=uid=admin,ou=Administrators, 
ou=TopologyManagement,o=NetscapeRoot 

Change encrypted to unencrypted and set the password in plain 
text. The password is encrypted when Cognos Reporting starts up. 

Example: ldap.bind.password=unencrypted:password 

New namespace is added 
after the Cognos 8 Business 
Intelligence configuration. 

Duplicate and edit the file for each namespace: 

Copy the MotioCAP_informcap.properties file and save it to the 
same directory as the original. Name the new copy 
MotioCAP_<new_namespace_name>.properties.  

Edit the following properties as necessary: 

• ldap.url 

• ldap.base.dn 

• ldap.bind.username 

• ldap.bind.password 

The database user and/or 
database user password 
changes after installation. 

Note: These will be encrypted after the first run. 

db.user=encrypted:<db_username> 

db.password=encrypted:<db_user_password> 
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Running the CRNGatewayConfig\setup.exe wizard 
 

Wizard Cognos 8 BI Gateway Customization for InForm 
(CRNGatewayConfig\setup.exe). 

Purpose Configures the Cognos 8 BI Gateway services component to work with 
the InForm application. 

Location of setup.exe CRNGatewayConfig folder of the InForm installation image. 

Where to install Server where the Cognos 8 BI Gateway services component is installed. 
 

1 Copy the CRNGatewayConfig folder from the InForm installation image to a location that you 
can access from the server where the Cognos Gateway software is installed. 

2 On the server where the Cognos Gateway software is installed, run the 
CRNGatewayConfig\setup.exe program file. 

The Choose Setup Language page appears.  
 

 
 

3 Select the language you want the wizard to use during setup. Select either English or Japanese. 
English is the default. Click Next.  

The Cognos 8 BI Welcome Screen appears.  

4 Click Next. 
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The Cognos 8 BI Installation Location page appears. 
 

 
 

5 Specify the path to the location of the Cognos 8 BI software. 

The CRN Setup File page appears. 

 
 

6 Browse to the CRNSetup.xml file that was created by the Cognos 8 BI Customization for 
InForm wizard, and click Next. 
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The Ready to Install the Program page appears. 

7 Click Install.  

The Setup Status page appears. 

The program installs, and the World Wide Web Publishing Service restarts. 

The Wizard Complete page appears. 

8 Click Finish. 
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Configuring for SSL in the Cognos Configuration utility 
 

Purpose Updates Web Content URL and Gateway URI entries to configure for 
SSL. 

Where to perform Server where the Cognos 8 BI Gateway services are installed. 
 

1 On the Cognos Gateway server, click Start > All Programs > Cognos8 > Cognos Configuration.  

2 After the Cognos Configuration utility is completely loaded, select Portal Services and update the 
Web Content UrI entry: 
https://<servername>.<domainname>:<portnumber>/COGNOS8 

 

Note: Be sure to change the port number to the port for HTTPS. 

For example: 
https://appsrv23.north.pf.com:443/cognos8 

 
3 Select Environment and update the Gateway URI entry: 

https://<servername>.<domainname>:<portnumber>/cognos8/cgi-
bin/cognosisapi.dll 

 

Note: Be sure to change the port number to the port for HTTPS. 

For example:  
https://APPSRV23.north.pf.com:443/cognos8/cgi-bin/cognosisapi.dll 

 
4 Select File > Save. 

The Cognos Configuration utility validates the settings and saves the configuration. 

5 When the checks are complete (all items are marked with a green check mark), click Close. 

6 Select Actions > Start. 

The Cognos Configuration utility registers and starts the Cognos 8 BI Service. 

7 Click Close, and close the Cognos Configuration utility window. 
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Starting the Cognos 8 BI servers 
 

Purpose Starts the Cognos 8 BI servers. 

Where to perform Server where the Cognos 8 BI service is installed. 
 

After completing the Cognos 8 BI installation and configuration steps, you can start the Cognos 8 BI 
servers. If you have distributed Cognos 8 BI application tier components across multiple servers, see 
the Cognos Installation & Configuration Guide for the specific order for starting the servers. 

1 On the server where the Cognos 8 BI service is installed, select Start > All Programs > Cognos8 > 
Cognos Configuration.  

The Cognos Configuration utility starts. 

2 Select Actions > Start. 

3 When the server is started, close the Cognos Configuration utility. 
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Configuring settings for Comma Separated Values (CSV) 
report output 

The Reporting and Analysis module provides settings that allow you to easily use CSV report output 
files with applications such as the Excel spreadsheet application. Oracle applies these settings for 
hosted environments, and recommends that you apply them to your environments as well.  

Note: You must have server administration rights to modify these settings. 

• Delimiter—Comma-delimited files are widely accepted for use with several applications. 

• Encoding—Using UTF-8 character encoding allows you to use your CSV output with a wide 
range of applications. 

• Terminator—Using carriage return and line feed (CRLF) terminators ensures that the report 
output is properly organized into columns and rows. 

 

Configuring the CSV settings for reports 
1 Go to the Reporting and Analysis home page. 

2 Click Launch > Reporting Administration. 

The Administration page appears. 

By default, the Status tab is selected. 

3 In the pane on the left, click System. 

4 In the Scorecard section, click the server name. 

The full URL for the server appears below the server name. 

5 Click the full URL for the server. 

The available services for the server appear. 

6 Select Report Service > Set Properties. 

The Set properties - ReportService dialog box appears. 

7 Select the Settings tab. 

8 In the Category drop-down list, select Environment. 

9 In the Environment category, in the Advanced settings row, click Edit. 

The Set advanced settings dialog box appears. 

10 Select Override the settings acquired from the parent entry checkbox. 
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11 Type the following parameters and values: 
 

Parameter Value Description 
RSVP.CSV.DELIMITER , Separates each data item in the report output with 

a comma. 

RSVP.CSV.ENCODING UTF-8 Specifies UTF-8 character encoding for report 
data. 

RSVP.CSV.TERMINATOR CRLF Separates each row of data with a carriage return 
and line feed, so that the rows appear in ordered 
columns. 

 

12 Select the checkbox next to each parameter. 

13 Click OK. 

The Set properties - ReportService page appears. 

14 Click OK. 
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Updating registry settings 

Updating the ExternalLoginURL and ExternalLoginFailureURL registry key 
entries on the Cognos 8 BI servers 

 

Purpose Updates entries for the AuthenticationFilter registry key to enable Cognos 
8 BI to use SSL. 

Where to perform Each server where a Cognos 8 BI component is installed. 
 

On each Cognos 8 BI server, update the ExternalLoginURL and ExternalLoginFailureURL entries 
for the Oracle AuthenticationFilter registry key. 

1 In the Windows Registry Editor, navigate to the following Windows Registry key: 
MyComputer\HKEY_LOCAL_MACHINE\SOFTWARE\PHASEFORWARD\AuthenticationFilter 
 

2 Update the entries for ExternalLoginURL, ExternalLoginFailureURL. For each entry: 

a Right-click the entry and select Modify. 

The Edit String dialog box appears. 

b Enter the new value in the Value Data field and click OK. For more information, see the table 
that follows this procedure. 

3 Exit the Windows Registry Editor. 

4 Restart IIS. 
 

Entry What to specify in the Value Data field 
ExternalLoginURL Specify the URL to configure for HTTPS, and make sure that the 

<portnumber> value reflects the port number for HTTPS. 
https://<servername>.<domainname>:<portnumber>/PFExternalLog
in/ 
ExternalLoginFrameset.html 
 
Example:  
https://APPSRV23.north.pf.com:443/PFExternalLogin/ 
ExternalLoginFrameset.html 
 

ExternalLoginFailure
URL 

Specify the URL to configure for HTTPS, and make sure that the 
<portnumber> value reflects the port number for HTTPS. 
https://<servername>.<domainname>:<portnumber>/PFExternalLog
in/ 
ExternalLoginEscape.html 
 
Example:  
https://APPSRV23.north.pf.com:443/PFExternalLogin/ExternalLo
ginEscape.html 
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Updating the AuthenticationFilter DomainSuffix registry key on the Cognos 8 BI 
server 

 

Purpose Updates the AuthenticationFilter DomainSuffix registry key. 

Where to perform • Server where Cognos 8 BI Gateway services are installed. 

• Server for the InForm study. 
 

If you are installing Cognos Reporting, you must update the DomainSuffix entry for the Oracle 
AuthenticationFilter registry key if any of the following is true on the InForm study machine and the 
Cognos 8 BI Gateway Services machine. 

• You use proxy servers for the Cognos 8 BI Gateway Services machine and the InForm study 
server. 

• The fully qualified domain name (FQDN) for either server does not end with a common domain 
suffix. The FQDN is registered in the Oracle AuthenticationFilter DomainSuffix entry during 
installation of the InForm server and the Cognos 8 BI Gateway Services software. If the FQDN 
for both installations ends in a common domain suffix such as .net, .com, .org, .edu, or .gov (with 
or without country name like .uk or .au), you do not need to update the DomainSuffix entry 
unless you use proxy servers. 

• If the FQDN has just two levels. (For example: <servername>.com.) 

Perform the DomainSuffix configuration on both the Cognos 8 BI Gateway Services machine and 
the InForm study server. Both machines must have identical AuthenticationFilter entries for 
DomainSuffix. 

1 In the Windows Registry Editor, navigate to the following Windows Registry key: 
MyComputer\HKEY_LOCAL_MACHINE\SOFTWARE\ORACLEHS\AuthenticationFilter 
 

2 Update the entry for DomainSuffix. 

a Right-click the entry, and select Modify. 

The Edit String dialog box appears. 

b Enter the new value in the Value Data field. Edit the entry: 

• If you use proxy servers, or if the fully qualified domain name for either server does not 
end with a common domain suffix, remove every part of the domain suffix that is not 
identical on both computers. For example, if the FQDN includes 
<servername>.<companyname>.co.uk, after the edit, the entry would be 
<companyname>.co.uk. 

• If the InForm software and Cognos 8 BI are installed on the same machine, and the 
FQDN has only two nodes such as <servername>.com, you must include the server name 
and the domain suffix in the entry. In the above example, the entry would read 
<servername>.co.uk. 

c Click OK. 

3 Exit the Windows Registry Editor. 

4 Restart IIS.  
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5 On the InForm server, restart the InForm Service. 
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Enabling communication among distributed Cognos 8 BI 
software components 

If you install one or more Application Tier Components on a separate server, to insure that they can 
communicate with other Cognos 8 BI reporting components: 

• Configure cryptographic properties. 

• Specify all Content Manager URIs. 

• Specify the Dispatcher URIs. 

• Specify the Dispatcher URI for external applications. 

• In a multiserver environment, on a server where Application Tier Components are installed but 
the Content Manager component is not installed, configure that server's Notification Store 
property to point to the Content Store database. This is described in the online Help notes in the 
Cognos Configuration utility. 

For more information, see the Cognos 8 BI documentation. 
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Configuring the Cognos 8 BI Gateway server to run the 
Cognos Application Firewall 

If all of your Cognos 8 BI servers are not on the same network or behind a system firewall, you 
should enable the Cognos Application Firewall (CAF) on the Cognos Gateway server. 

To enable the Cognos Gateway server to use the CAF: 

1 Connect to Cognos Gateway server. 

2 Navigate to the Windows Start menu. 

3 Select All Programs > Cognos8 > Cognos Configuration.  

4 After the configuration is completely loaded, select Local Configuration\Security\IBM Cognos 
Application Firewall from the Explorer pane. 

The Component Properties pane appears. 

5 Set the property Enable CAF validation? to True. 

6 For the property Valid domains or hosts, click on the pencil icon to the right of the Value cell. 

The Valid domains or hosts page appears. 

7 Click Add. 

8 Fill in the hostnames or domain names that are valid for your environment. 

The CAF will validate hostnames and domain names used or passed in a request, and not allow 
requests to pass unless the name is listed on this page. You can add as many hostnames or 
domain names as needed for your configuration or system topology. 

9 Click OK when you have finished adding names. 

10 Save the Cognos configuration. 

11 Restart the Cognos service. 
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Creating PFWD and LDAP namespaces on the Cognos 8 BI 
server 

 

Purpose Creates the PFWD namespace and crnsysadmin user. 

Where to perform Server where the Cognos 8 BI core software is installed. 
 

Run this procedure each time you run the InForm CRN wizard. 

1 On the server where Cognos 8 BI is installed, select Start > All Programs > Cognos 8 > Cognos 
Configuration. 

The Cognos Configuration window appears. 

2 In the Security tree, right-click Authentication, and select New resource > Namespace. 

The New Resource - Namespace dialog box appears. 

3 Enter the following values: 

• Name—PFWD (all uppercase) 

• Type—LDAP 

4 Click OK.  

5 Complete the parameters as follows: 

• Namespace ID—PFWD 

• Host and Port—<fullyqualifiedmachinename>: <LDAPServerPort>  

(example port number: 389) 

• Base distinguished name—Domain name for your environment. Example: If the 
network domain is pf.com, ou=PFWD,dc=pf,dc=com 

Note: Do not enter spaces after the commas between the parts of the domain. 

• User lookup—(uid=${userID}) 

6 Select File > Save. 

The Cognos Configuration utility validates the settings and saves the configuration. 

7 When the checks are complete (all items are marked with a green check mark), click Close. 

8 Click Close, and close the Cognos Configuration utility window. 
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Comparison of configuration scenarios 
 

Characteristic Different database instances Single database instance 
Oracle Streams Oracle Streams is required. 

When you install the Reporting and 
Analysis module into a different 
database from the study, data is 
replicated using Oracle Streams. 

For more information about streams, 
streams operations, and monitoring, 
see the Oracle database documentation 
about streams. 

Oracle Streams is not required, because 
there is no need to replicate study data. 

Schema 
ownership 

Different schema owners own study or 
reporting objects (and each schema is 
in a separate instance). 

For more information, see Separate 
database instances for InForm and 
Cognos reporting software (on page 
31). 

The study schema owner owns all study 
and reporting objects.  

Multiple reporting and study 
combinations may be put in the same 
study and reporting database instance. 

Archive log 
mode 

Running in archive log mode is 
required. 

For more information, see Archive 
log mode in a multiple database 
environment (on page 51). 

Running in archive log mode is not 
required. 
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Study and reporting schemas in different database 
instances 

Study schema—Different database instances 

Study database parameters—Different database instances 
The Reporting and Analysis module requires you to add or modify study database parameters. The 
following table shows the adjustments that must be made to these parameters when the Reporting 
and Analysis module is installed. All settings are necessary for both production and development 
servers. 

Additionally, Oracle recommends that you review the processes and sessions parameters, which are 
not mandatory for the Reporting and Analysis installation. 

For more information, see the Oracle database document, Oracle Streams Recommendations. 
 

Parameter Value Comments 
job_queue_processes 5 minimum 5 minimum: 1 job for each study (the job to 

update PF_HEARTBEAT table every minute in 
each study schema) and 1 job for each 
propagation, plus streams’ minimum requirement 
of 2 and Oracle MTS’s requirement of 1)  

log_archive_dest Destination where 
the archive logs 
will be written 

You must enter at least one destination. For more 
information, see the Oracle database document, 
Oracle Reference Manual. 

log_archive_dest_state_1 ENABLE This enables the archive log destination 
(log_archive_dest_1). You must enter a state for 
every destination. For more information, see the 
Oracle database document, Oracle Reference Manual. 
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Required study tablespace—Different database instances 
The STRMADMIN_TS tablespace is required for Reporting and Analysis installation. To create the 
STRMADMIN_TS tablespace, use the following syntax: 

CREATE TABLESPACE STRMADMIN_TS 
DATAFILE ‘<path_to_reporting_data_file>’ SIZE <initial_size> 
AUTOEXTEND ON NEXT 
EXTENT MANAGEMENT LOCAL AUTOALLOCATE; 
 

 

Tablespace name Initial size/ 
autoextend size 
needed 

File extent size/file 
maximum size 

Comments 

STRMADMIN_TS 25M Make the initial size 
25 megabytes, set 
AUTOEXTEND on 
and set MAXSIZE to 
UNLIMITED. 

The name STRMADMIN_TS is 
required for this tablespace. This 
tablespace is used to hold 
spillover from streams queues 
into streams_queue_tables. 
Streams queue tables reside in this 
tablespace.  
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Optional study tablespaces—Different database instances 
The following table also lists optional tablespaces that you can create. The optional tablespaces allow 
for the separation of reporting objects, logs, and indexes. Oracle recommends that you create these 
tablespaces. If you do not create the optional tablespaces, space must be available in existing 
tablespaces. 

Additionally, consider the following optional tablespaces.  

• The SYSAUX tablespace is used to store LOGMNR objects by default in Oracle. Therefore, you 
do not need to create a tablespace for Logminer objects. 

The SYSAUX tablespace size and growth are influenced by a number of Oracle tools. The 
Streams capture process writes checkpoint information, among other things, to this tablespace. 
The checkpoint information can grow quickly depending on the settings that affect checkpoint 
retention and frequency. These settings can be adjusted as necessary. 

The checkpoint retention time is an attribute of the capture process and can be changed with the 
DBMS_CAPTURE_ADM.ALTER_CAPTURE Oracle-supplied procedure. The default value 
provided by Oracle for the capture_ckpnt_ret_time variable is 60 days. The checkpoint 
frequency is a capture process parameter and is called _CHECKPOINT_FREQUENCY. This 
can be changed with the DBMS_CAPTURE_ADM.SET_PARAMETER procedure. See the 
Oracle PLSQL Packages and Types Reference and Oracle Concepts and Administration manuals for more 
information. 

• The UNDO tablespace size and growth are influenced by the UNDO_RETENTION database 
parameter setting and Streams needs in addition to normal InForm reporting operations. Oracle 
requires that UNDO_RETENTION be set to at least 900. 

For information about the UNDO_RETENTION parameter and UNDO tablespace, see the 
Oracle database document, Oracle Administrators Guide. 

Note: The names of tablespaces in the study and reporting databases must be identical. 

 

Tablespace name Initial size/ 
Autoextend size 
needed 

File extent size/ file 
maximum size 

Comments 

Chosen by 
customer 

Example:  
<studyname>_table_
ts 

Calculate initial size 
at: (2 * pf_comment 
table size) + (2 * 
pf_controldata table 
size) + (1 * 
pf_resourcedata 
table  size) + (1 * 
pf_rules table size).  

Chosen by customer. The 
size of these tables grows 
as the study size grows. 

Holds study tables used 
for reporting. 
Corresponds to the 
variable trial_table_ts 
variable in the 
configdiffdb.sql file. 
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Tablespace name Initial size/ 
Autoextend size 
needed 

File extent size/ file 
maximum size 

Comments 

Chosen by 
customer 

Example:  

<studyname> 
_index_ts 

Calculate initial size 
at: (2 * pf_comment 
primary key index 
size) + (2 * 
pf_controldata 
primary key index 
size) + (1 * 
pf_resourcedata 
primary key index 
size) + (1 * pf_rules 
primary key index 
size).  

Chosen by customer. The 
size of these tables grows 
as the study size grows. 

Holds study table indexes 
that are used for reporting. 
Corresponds to the 
variable trial_index_ts 
variable in the 
configdiffdb.sql file. 

 
 

rptinstall user for studies—Different database instances 
 

Purpose Creates the rptinstall user for the study schema. The rptinstall user 
has DBA privileges in the study database and is used for install and 
uninstall operations. This account is not used for study operations 
and can be locked when not in use. 

You can drop the rptinstall user after installation is finished. 
However, you must re-create it before attempting any further 
installation or uninstallation activities. 

Where to perform Folder for the Reporting and Analysis module files, for example, 
e:\PF\InForm Reporting 

 

1 Open a Command Prompt window. 

2 Change to the directory where the Reporting and Analysis files were installed by the Reporting 
DB wizard. 

3 Log on to the study database with a user that has sysdba privileges. Make sure that the 
connection is made with the as sysdba clause. 

4 Run this command: 
create user rptinstall identified by <dbauser_study_password> default 
tablespace <tablespace_name> temporary tablespace <tablespace_name> 
 
<dbauser_study_password>—The password for rptinstall, the dbauser for the study. This password 
is case-sensitive. 

<tablespace_name>—A valid tablespace name in the database. Oracle recommends that you do 
not use the SYSTEM tablespace for the default tablespace. 

Note: The default tablespace does not require additional room for objects, because the 
rptinstall user does not own objects. 

5 Type the following at the SQL*Plus prompt: 
@grant_dba_privs rptinstall   
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Archive log mode verification in the study database—Different database 
instances 

 

Purpose Verifies that the database log mode is Archive for an environment 
where the study and reporting schemas are in different database 
instances. 

Where to perform Database instance for the study schema. 
 

You must run the InForm study database in archivelog mode. This is a requirement for Oracle 
Streams. To determine if the InForm database is being run in archivelog mode: 

1 Log on to a privileged Oracle account, for example, sys, using SQL*Plus. 

2 Run the following command: 
archive log list 
You should see the following values: 

• database log mode—Archive. 

• automatic archival—Enabled. 
 

Reporting variable configuration—Different database instances 
To configure reporting variables, you edit the configdiffdb.sql script. The installation and 
uninstallation scripts use the configdiffdb.sql file for user name, password, tablespace, and 
connection information. This file is located in the folder where the reporting software is located, for 
example, PF\InForm Reporting\DBOra. 

The configdiffdb.sql script includes predefined and user-defined variables. You should: 

• Never change predefined variables. 

• Evaluate each user-defined variable, and change the values as needed to reflect your 
environment. For more information, see the table below. 

Note: When you are first configuring the InForm environment to work with the Cognos 8 BI 
software, you configure all of the reporting variables described in this section. When you set up 
the Reporting and Analysis module for each study, you reconfigure the study-specific variables for 
that study. When you set up the file for a specific study, rename the file ConfigDiffDB-
<studyname>.sql. For information about configuring study-specific reporting variables, see the 
Study and Reporting Setup Guide. 

 

Reporting variables in configdiffdb.sql 
 

I/S Variable Value Comments 

I=Set once for the database instance; S=Set for each study; P= Do not change. 
I trialdb_tnsnames_alias Tnsnames alias for the study 

database. 
Used for connection to the study 
database. Also used as a part of the 
PUBLIC database link. 
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I/S Variable Value Comments 

I=Set once for the database instance; S=Set for each study; P= Do not change. 
P trialdbstring @&&trialdb_tnsnames_alias Preset variable. Do not change. 

Used for connection to the study 
database. 

S trial_schema_owner InForm study schema owner. Oracle user name of the study 
schema owner in the study 
database. 

S rep_proxy_user New user. Prepend RP to the 
InForm study schema owner. 

Oracle user name in the study 
database that serves as a proxy user 
for reporting database 
connections. 

I trial_to_rep_dblink 
_name 

Global name of the reporting 
database. 

Name of all database links in the 
study database. 

Connect to the reporting database 
and run the command: Select 
global_name from 
global_name;  

Use the value returned from this 
command for this variable.  

P trial_dblink_name_select @&&trial_to_rep_dblink 
_name 

Preset variable. Do not change. 
Used for connection to remote 
objects in the reporting database. 

I repdb_tnsnames_alias Tnsnames alias for the 
reporting database. 

Used for connection to the 
reporting database. Also used as a 
part of the PUBLIC database link. 

P repdbstring @&&repdb_tnsnames_alias Preset variable. Do not change. 

Used for connection to the 
reporting database. 

P rep_schema_owner &&trial_schema_ow Preset variable. Do not change. 

I rep_to_trial_dblink 
_name 

Global name of study 
database. 

Name of all database links in the 
reporting database. 

Connect to the study database and 
run the command: Select 
global_name from global_name;  

Use the value returned from this 
command for this variable.  

P rep_dblink_name_select @&&rep_to_trial_dblink 
_name 

Preset variable. Do not change. 
Used for connection to remote 
objects in the study database. 
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Reporting schema—Different database instances 
You can install the reporting schema in a separate database instance from the InForm study schema 
to support a study production (multi-user) environment. 

Note: When the study and reporting schemas are in separate database instances/schemas, it is 
necessary to replicate study data in reporting with Oracle Streams. 

 

Required reporting database parameters—Different database instances 
The database parameters listed below are required for the Reporting and Analysis installation.  

Additionally, Oracle recommends that you review the processes and sessions parameters, which are 
not mandatory for the Reporting and Analysis installation. 

For more information, see the Oracle database document, Oracle Streams Recommendations. 
 

Parameter Value Comments 
compatible 11.2.0 or 10.2.0  

cursor_sharing Exact  

db_block_size 16384 After the instance is created, this cannot be 
changed. 

db_file_multiblock_read_count 16  

db_cache_size 

See Note 1 

0 This is automatically managed by Oracle 
when it is set to zero and sga_target is 
specified. 

db_files Database 
dependent. 

 

global_names TRUE  

job_queue_processes 2 minimum Two minimum recommended by Oracle for 
Streams. 

open_cursors 150  

open_links Four minimum  

optimizer_features_enable 11.2.0.1 or 
10.2.0.1 

 

parallel_max_servers Two for each 
apply. 

Two are required for each apply process. 

pga_aggregate_target 300M (dependent 
on how much 
memory is 
available for 
Oracle) 

 

processes 150  
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Parameter Value Comments 
remote_login_password_file exclusive  

session_cached_cursors 150  

sga_target 

See Note 2 

1000M This parameter manages memory for 
Shared_pool_size, db_cache_size, 
streams_pool_size, large_pool_size, and 
java_pool_size. This parameter enables 
Automatic Shared Memory. 

shared_pool_reserved_size 5M  

shared_pool_size 

See Note 1 

0 This is automatically managed by Oracle 
when it is set to zero and sga_target is 
specified. 

skip_unusable_indexes true Required to run refresh jobs. 

statistics_level typical This is necessary for Automatic Shared 
Memory Management (ASMM) to function. 

streams_pool_size  

See Note 1 

200M This is necessary for Automatic Shared 
Memory Management (ASMM) to function. 

timed_statistics TRUE Recommended by Oracle for collecting 
elapsed time information for Streams. 

undo_retention 900 (minimum 
value) 

For more information, see the Oracle Streams 
Recommended Configuration document on 
Metalink (reference below). 

workarea_size_policy auto  

_job_queue_interval 1 Not required, but recommended by Oracle 
for Streams (Note 418755.1). 

_optimizer_cost_based_transfor
mation 

Off  

sec_case_sensitive_logon False Oracle 11g only. 

_push_join_predicate False Oracle 11g only. 

deferred_segment_creation False Oracle 11g only. 

parallel_max_servers 3  
 

Note 1: These parameters can be changed if desired. Specifying a value other than zero in for 
these parameters enforces a minimum amount of memory that sga_target uses. The minimum is 
deducted from the total memory that sga_target can dynamically allocate across the five 
memory settings it manages. 

Note 2: Java_pool_size and large_pool_size are also managed by sga_target. They are not 
specified in a parameter list because they are not needed for the InForm application. 

 
 



 Installation Guide  

InForm 5.5.2 141 

Required reporting tablespace—Different database instances 
The STRMADMIN_TS tablespace is required for Reporting and Analysis installation. To create the 
STRMADMIN_TS tablespace, use the following syntax: 

CREATE TABLESPACE STRMADMIN_TS 
DATAFILE ‘<path_to_reporting_data_file>’ SIZE <initial_size> 
AUTOEXTEND ON NEXT 
EXTENT MANAGEMENT LOCAL AUTOALLOCATE; 
 

 

Tablespace name Initial size/ 
autoextend size 
needed 

File extent size/file 
maximum size 

Comments 

STRMADMIN_TS 25M Make the initial size 
25 megabytes, set 
AUTOEXTEND on 
and set MAXSIZE to 
UNLIMITED. 

The name STRMADMIN_TS is 
required for this tablespace. This 
tablespace is used to hold 
spillover from streams queues 
into streams_queue_tables. 
Streams queue tables reside in this 
tablespace.  

 

 
 

Optional reporting tablespaces—Different database instances 
The following table lists optional tablespaces that you can create. The optional tablespaces allow for 
the separation of reporting objects, logs, and indexes. Oracle recommends that you create these 
tablespaces. If you do not create the optional tablespaces, space must be available in existing 
tablespaces. 

Additionally, consider the following optional tablespaces.  

• The SYSAUX tablespace is used to store LOGMNR objects by default in Oracle. Therefore, you 
do not need to create a tablespace for Logminer objects. 

• The UNDO tablespace size and growth are influenced by the UNDO_RETENTION database 
parameter setting  and Streams needs in addition to normal InForm reporting operations. Oracle 
requires that UNDO_RETENTION be set to at least 900. For more information, see the Oracle 
database document, Oracle Streams Recommendations. 

For information about the UNDO_RETENTION parameter and UNDO tablespace, see the 
Oracle database document, Oracle Administrators Guide. 

Note: The names of tablespaces in the study and reporting databases must be identical. 

 

Tablespace 
name 

Initial size/ 
autoextend 
size needed 

File extent size/file 
maximum size 

Comments 

User-defined 

Example: 

<studyname>_ind
ex_ts 

One-half the 
size of the 
study 

User-defined. 

The size of the indexes grows 
as the study indexes grow. 

Used to store indexes that are 
created on reporting tables. 

Corresponds to the 
rep_index_ts variable in the 
configdiffdb.sql file. 
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Tablespace 
name 

Initial size/ 
autoextend 
size needed 

File extent size/file 
maximum size 

Comments 

User-defined 

Example: 

<studyname>_tab
le_ts 

Size of the 
study 

User-defined. 

The size of the reporting base 
tables grows as the study tables 
grow. 

Used to store reporting tables 

Corresponds to the 
rep_table_ts variable in the 
configdiffdb.sql file. 

 
 

rptinstall user for reports—Different database instances 
 

Purpose Creates the rptinstall user for the reporting schema. The rptinstall 
user has DBA privileges in the reporting database and is used for 
install and uninstall operations. This account is not used for reporting 
operations and may be locked when not in use. 

You can drop the rptinstall user after installation is finished. 
However, you must re-create it before attempting any further 
installation or uninstallation activities. 

Where to perform Folder for the Reporting and Analysis module files, for example, 
e:\PF\InForm Reporting 

 

1 Open a Command Prompt window. 

2 Change to the directory where the Reporting and Analysis files were installed by the Reporting 
DB wizard. 

3 Log on to the reporting database with a user that has sysdba privileges. Make sure that the 
connection is made with the as sysdba clause. 

4 Run this command: 

create user rptinstall identified by <dbauser_rep_password> default tablespace 
<tablespace_name> temporary tablespace <tablespace_name> 

<dbauser_rep_password>—The password for rptinstall, the dbauser for the reporting schema. This 
password is case-sensitive. 

<tablespace_name>—A valid tablespace name in the database. Oracle recommends that you do 
not use the SYSTEM tablespace for the default tablespace. 

Note: The default tablespace does not require additional room for objects, because the 
rptinstall user does not own objects. 

5 Type the following at the SQL*Plus prompt: 
@grant_dba_privs rptinstall   
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Communication between the study and reporting databases—Different 
database instances 

The InForm study database and reporting database communicate through database links. Entries in 
the tnsnames.ora files on the study database and reporting database servers are required. Create 
tnsnames aliases: 

• On the reporting database server to connect to the study instance on the study server. 

• On the study database server to connect to the reporting instance on the reporting server. 
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Required and recommended browser settings for Internet 
Explorer 

Specifying the preferred browser language 
1 In Internet Explorer, select Tools > Internet Options > Languages. 

The Language Preference dialog box appears. 

2 To add another language, click Add. 

The Add Language dialog box appears. 

3 Select a language, and click OK. 

4 Move the language to the top of the list by clicking Move Up, and click OK. 

5 Click OK. 
 

Enabling viewing reports and data listings in Microsoft Excel format 

Enabling Automatic prompting for downloads 
1 In Internet Explorer, select Tools > Internet Options > Security > Custom Level.  

The Security Settings dialog box appears. 

2 In the Downloads section, under Automatic prompting for file downloads, click Enable.  

3 In the Security Settings dialog box, click OK. 

4 In the Internet Options dialog box, click OK. 
 

Configuring trusted sites 
1 In Internet Explorer, select Tools > Internet Options > Security > Trusted Sites > Sites.  

The Security Settings dialog box appears. 

2 In the Add this web site to the zone field, type https://*.webcrf.net, and click Add. 

3 Click OK. 
 

Setting the ForceShellExecute registry entry 
To ensure that HTTP links are handled correctly from Microsoft Excel, add a DWORD entry called 
ForceShellExecute to the registry in the following key: 
 
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\9.0\Common\Internet 
"ForceShellExecute"=dword:00000001  
 
If the ForceShellExecute entry already exists, change its value from 0 to 1.  
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Configuring pop-up blocking 
You must configure the pop-up blocking functionality to allow pop-ups from the InForm 
application. This configuration applies whether pop-ups are enabled or disabled. 

1 In Internet Explorer, select Tools > Pop-up Blocker. 

2 If the Pop-up Blocker command is disabled, click Turn On pop-up Blocker. 

3 Click Tools > Pop-up Blocker > Pop-up Blocker Settings. 

The Pop-up Blocker Settings dialog box appears. 

4 In the Address of Web site to allow field, type the name of the domain used for accessing the study. 
Use the format *.<domain_name>, for example, *.pf.com. 

5 Click Add. 

6 Click Close. 
 

Preventing automatic password completion 
To comply with federal regulations that govern electronic data capture in a clinical study, your 
browser cannot be set to complete user names and passwords on forms.  

1 In Internet Explorer, select Tools > Internet Options > Content.  

2 In the Personal information section, click AutoComplete.  

The AutoComplete Settings dialog box appears. 

3 In the Use AutoComplete for section, deselect the User names and passwords on forms checkbox. 

4 In the Clear AutoComplete history section, click Clear Passwords. 

5 Click OK in the AutoComplete Settings and Internet Options dialog boxes. 
 

Specifying whether to save encrypted and temp files 
1 In Internet Explorer, select Tools > Internet Options > Advanced. 

2 Scroll to the Security section. 

3 Specify the following options: 

• Do Not Save Encrypted Pages to Disk—Not selected. This option allows the system to save 
encrypted pages to disk. Unless the option is deselected, you cannot open reports in 
Microsoft Excel format. Required by Oracle. 

• Empty Temporary Internet File Folder When Browser is Closed—Selected. This option tells the 
system to delete temporary files when the browser is closed. Recommended by Oracle. 

4 Click OK. 
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Optimizing performance 
1 In Internet Explorer, select Tools > Internet Options. 

2 In the Temporary Internet files group, click Settings. 

3 In the Check for newer versions of stored pages group, click Automatically. 

4 In the Amount of disk space to use field, select 6 MB. 

5 Click OK. 
 

Setting HTTP and SSL options for performance 
If a browser machine is not configured to take advantage of HTTP 1.1 or SSL caching, the InForm 
login window displays messages that alert users to either or both conditions. For example: 

Your browser or infrastructure does not support the following optimal 
settings for InForm: 
Configure your browser to support the HTTP 1.1 protocol. 
 

If you receive a performance setting alert: 

1 In Internet Explorer, select Tools > Internet Options > Advanced. 

2 Scroll to the HTTP 1.1 section, and select Use HTTP 1.1. 

3 Scroll to the Security section, and select Use SSL 2.0 and Use SSL 3.0. 

4 Click OK. 
 

Printing background graphics 
1 In Internet Explorer, select Tools > Internet Options > Advanced. 

2 Scroll to the Printing section. 

3 Select Background Colors and Images. 

4 Click OK. 
 

Modifying security settings 
1 In Internet Explorer, select Tools > Internet Options > Security. 

2 Select the Internet type of connection. 

3 Click Custom Level. 

4 Set the following options to Enable: 

• Miscellaneous section—Allow META REFRESH. 

• Scripting section—Active scripting. 

5 Click OK. 

6 In the Internet Options dialog box, select the Privacy tab. 

7 Move the slider to the bottom to select Accept All Cookies. 
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8 Click OK. 
 

Setting up tabbed browsing for Internet Explorer 7.0 
If you are using Internet Explorer 7.0, to make sure that the emailing of Cognos 8 BI reports works 
as it does with Internet Explorer 6.0 Service Pack 1, you must set up tabbed browsing by selecting or 
deselecting the Enable Tabbed Browsing option. 
 

Selecting the Enable Tabbed Browsing option 
1 In Internet Explorer, select Tools > Internet Explorer Options. 

2 In the Tabs section, select Settings. 

3 Select Enable Tabbed Browsing. 

4 Click OK in both dialog boxes. 
 

Deselecting the Enable Tabbed Browsing option 
1 Select Tools > Internet Explorer Options > Advanced, and deselect Reuse windows for launching 

shortcuts. 

2 Click Apply. 

3 Select the General tab. 

4 In the Tabs section, select Settings. 

5 Deselect Enable Tabbed Browsing. 

6 Click OK in both dialog boxes. 
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Other Internet Explorer behaviors to consider 

Using large fonts 
The InForm application does not provide special support for displaying large fonts. If you run the 
InForm application with the Windows display configured to use large fonts, some of the text and 
buttons might overlap. 
 

Authentication and browser sessions 
According to standard Internet Explorer behavior, multiple windows are considered to be part of the 
same session. Although this may vary slightly according to the versions of Internet Explorer, 
windows may be part of the same session if they are created or launched in the following ways: 

• Pop-ups are launched from another window in the session. 

• The File > New > Window command or Ctrl+N is used to create new windows. 

An InForm session includes all Internet Explorer windows from the same session. To prevent 
someone from logging in to an unauthorized session, users must exit InForm sessions in one of the 
following ways: 

• Explicitly log out of the InForm application. 

• Close all browser windows within the session. 

If a user does not log out of the InForm application or does not close all browser windows in the 
session, the user (or another user at the same computer) is not asked to re-authenticate when 
launching the InForm application again, and security could be compromised. 
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Required and recommended browser settings for Apple 
Safari 

Specifying the preferred browser language 
1 Select the Apple menu > System Preferences. 

2 Click International. 

3 Drag your preferred language to the top of the Languages list. 

4 If Safari is open, quit, and restart it. 
 

Configuring pop-up blocking 
You must configure the pop-up blocking functionality to allow pop-ups from the InForm 
application. 

1 In the Safari browser, select Safari > Preferences. 

2 Click Security. 

3 In the Web content section, deselect the Block pop-up windows checkbox. 
 

Preventing automatic password completion 
1 In the Safari browser, select Safari > Preferences. 

2 Click AutoFill. 

3 Deselect the User names and passwords check box. 
 

Modifying security settings 
1 In the Safari browser, select Safari > Preferences. 

2 Click Security. 

3 In the Accept Cookies section, select Always. 
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Required and recommended browser settings for Firefox 

Specifying the preferred browser language 
1 In Firefox, select Tools > Options. 

The Options dialog box appears. 

2 Select the Content tab. 

3 In the Language section, click Choose. 

4 If the language you want is not in the list, click Add. 

The Add Language dialog box appears. 

5 Select a language, from the drop-down list and click Add. 

6 Move the language to the top of the list by clicking Move Up, and click OK. 

7 Click OK. 
 

Configuring pop-up blocking 
You must configure the pop-up blocking functionality to allow pop-ups from the InForm 
application. This configuration applies whether pop-ups are enabled or disabled. 

1 In Firefox, select Tools > Options. 

The Options dialog box appears. 

2 Select the Content tab. 

3 If the Pop-up Blocker command is disabled, click the checkbox to enable it.. 

4 Click the Exceptions button. 

5 The Allowed sites - Pop-ups dialog box appears.  

6 In the Address of Web site field, type the name of the domain used for accessing the study. Use 
the format *.<domain_name>, for example, *.pf.com. 

7 Click Allow. 

8 Click Close. 
 

Preventing stored password use 
To comply with federal regulations that govern electronic data capture in a clinical study, your 
browser cannot be set to Remember passwords for sites and Use a master password. 

1 In Firefox, select Tools > Options. 

The Options dialog box appears. 

2 Select the Security tab. 

3 In the Passwords section, deselect  

• Remember passwords for sites. 
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• Use a master password. 

4 Click OK. 
 

Setting the SSL option for performance 
If a browser machine is not configured to take advantage of SSL caching, the InForm login window 
displays a message that alert you. For example: 

Your browser or infrastructure does not support the following optimal 
settings for InForm: 
Configure your browser to support the SSL caching. 

If you receive this performance setting alert: 

1 In Firefox, select Tools > Options. 

2 The Options dialog box appears. 

3 Select the Advanced tab. 

4 In the Protocols section, select Use SSL 3.0. 

5 Click OK. 
 

Modifying security settings 
1 In Firefox,  select Tools > Options. 

2 The Options dialog box appears. 

3 Select the Privacy tab. 

4 In the History section, select: 

• Accept cookies from sites. 

• Accept third-party cookies. 

5 Click OK. 
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Troubleshooting software installation 

Insufficient software installed 
If you get a warning about missing software during the InForm software installation, install all the 
software that is listed in the Requirements Not Met window, and restart the installation. 
 

InForm login page not in expected language 
Setting the preferred browser language is an optional client configuration step. However, if you do 
not set the preferred browser language, and the language is not English or Japanese, the InForm 
login page appears in the language of the product locale. 

To change the locale in which the login page appears, set the preferred browser language. For more 
information, see the Installation Guide. 
 

Unable to return to previous page after reauthenticating 
If a user's inactivity or reauthentication period expires, the InForm application returns the user to the 
last-used page in the session after reauthenticating. 

However, if the client computer is not configured to allow pop-ups, the InForm application does not 
return the user to the last-used page in the session, and the user must restart the session from the 
default Home page. 

To correct this, configure the client computer to allow pop-ups. For more information, see the 
Installation Guide. 
 

Oracle MTS configuration is invalid 
If the Oracle registry settings are not correct, you may get the following InForm core installer errors 
during the installation process: 

• Oracle MTS configuration is invalid. 

• Registry Settings: INVALID. 

• XA Views: INVALID. 

Possible solutions: 

• If the installation wizard is still open: 

1 Click Back to display the Database Configuration window. 

2 Select the Prep Oracle checkbox. 

3 Click Next to proceed.  

This runs the informprepora.vbs and mtsora102.vbs scripts. 

• If the installation window has been closed, run mtsora102.vbs from the command line. The 
mtsora102.vbs file is in the InstallSupport folder of the InForm installation image. 
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XA Views: INVALID 
If you have tried the solution that is recommended in Oracle MTS configuration is invalid and still get 
this error, or if you run mtsora102.vbs from the command line and get a warning, the xaview.sql file 
may not be installed. 

Note: This can happen for some Oracle client-only installations (multi-tier setup). 

Possible solution: 

1 Copy the xaview.sql file from another machine (running the same Oracle version) to your Oracle 
rdbms\admin directory. 

2 Log in as SYS on a machine with xaview.sql. 

3 Run xaview.sql against your InForm core instance. 

4 Run mtsora102.vbs from the command line. 
 

Database connectivity 
If you get a warning about database connectivity, make sure that: 

• The connect string value is correct. 

• The pfdbadmin password is valid. 

If you get a message that the pfdbadmin user does not exist, create the user by doing one of the 
following: 

• Select the Prep Oracle checkbox in the InForm installation wizard. 

• Run the informprepora.vbs script located in the InstallSupport folder of the InForm installation 
image. 
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Troubleshooting study and reporting setup 

Final InForm configuration fails 
The InForm installation process must be able to access the installation source drive. If an installation 
CD is removed from the drive during installation, or if the network goes down and the UNC path 
cannot be accessed, a message appears. 

Execute the final configuration step manually: 

1 Place the InForm installation CD in the CD-ROM drive, or verify the network connections. 

2 Open a Command Prompt window, and type: 
Run <path>\setup.exe InFormFinalConfig 

 

Errors when removing a reporting schema 
If you run the deinstall_reporting_diffdb.sql script to remove a reporting schema, and you receive 
the message Reporting deinstallation aborted, the uninstall fails and no reporting objects are 
removed. 

The probable cause is a problem with the settings in the configdiffdb.sql file. 

Check the configdiffdb.sql file to make sure that the settings are correct for the reporting schema 
that you want to remove. In particular, the uninstall scripts check for the existence of a tablespace. If 
the configdiffdb.sql file contains variables that refer to nonexistent tablespaces, update the file and 
rerun the uninstall script. 
 



 Installation Guide  

InForm 5.5.2 159 

Reporting and Analysis database setup fails with duplicate column name error 
If the setup of the reporting database fails with an ORA-00957: duplicate column name error, the 
study design might include an item RefName that is used for key column names in CV views. The 
key column names used for CV views are reserved. To resolve the problem, update the study design 
so that it does not include any reserved words as item RefNames. 

The following names are reserved and cannot be used as RefNames: 

• CD_COUNT 

• AFROWID 

• SUBJECTID 

• SITEID 

• STUDYVERSIONID 

• SUBJECTVISITID 

• SUBJECTVISITREV 

• VISITID 

• VISITINDEX 

• FORMID 

• FORMREV 

• FORMINDEX 

• SUBJECTINITIALS 

• SITEMNEMONIC 

• VISITMNEMONIC 

• FORMMNEMONIC 

• VISITORDER 

• SITENAME 

• SITECOUNTRY 

• SECTIONID 

• ITEMSETID 

• ITEMSETINDEX 

• ITEMSETIDX 

• DELETEDITEM 

• DELETEDFORM 

• FORMIDX 
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Performance Options setting in System Properties 
If the InForm application server is also the database server for the study database instance, you might 
receive errors that are related to cache initialization time when installing a study if the system setting 
for Processor scheduling is not set to Adjust for best performance of Programs. 

1 On the InForm application and database server, open the System Properties dialog box, and 
select Advanced. 

2 In the Performance section, click Settings. 

The Performance Options dialog box appears. 

3 Click Advanced. 

4 In the Processor scheduling section, click Programs. 

5 Click OK in both dialog boxes. 

Note: This issue should occur only in a development environment. In a production environment, 
the InForm application software and database are normally on different servers. When the 
InForm application server and database server are different machines, the system setting for 
Processor scheduling in the System Properties > Performance Options dialog box should be the 
default value, Background services. 
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About uninstalling software components 
Uninstall the InForm and Cognos 8 BI software in the following order: 

1 Cognos 8 BI software. 

2 Sun ONE Directory Server. 

3 InForm software. 

For an uninstalling checklist, see Checklist—Uninstalling software components (on page 23). 

Note: This section describes how to uninstall the core InForm and Cognos 8 BI software and the 
customizations for Cognos Reporting. For information about removing a study and removing the 
Reporting and Analysis module for a study, see the Study and Reporting Setup Guide 
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Uninstalling the Cognos 8 BI software 
The Cognos Uninstall Wizard enables you to uninstall the Cognos 8 BI core. 

1 On the server that hosts the Cognos 8 BI software, select Start > All Programs > Cognos 8 > 
Uninstall Cognos 8 BI Uninstall Cognos 8. 

The Uninstall Wizard starts. 
 

 
 

2 On the Uninstall Language Selection page, select the language you want to use to run the 
uninstall, and click Next. 
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3 On the next page, select the component packages to uninstall, and click Next. 

The uninstall process starts. 

4 When the uninstall is complete, click Finish. 

Note: The uninstall procedure might leave some folders and files on the computer. You can delete 
these with the Windows Explorer application. 
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Uninstalling Sun ONE Directory Server 
1 On the server where Sun ONE Directory Server is installed, select Start > Control Panel > Add or 

Remove Programs. 

The Add or Remove Programs dialog box appears. 

2 In the Directory Server entry, click Change/Remove. 

The Welcome page of the Directory Server Uninstallation Program wizard appears. 

3 Click Next. 

The Select Type of Uninstallation page appears. 
 

 
 

4 Select Full, and click Next. 
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The Configuration Directory Server Administrator page appears. 
 

 
 

5 In the Password field, enter the password of the Directory Administrator ID, and click Next. 

The Ready to Uninstall page appears. 

6 Click Uninstall Now. 

The Removing Configuration status page appears. 

7 Review the messages. A successful uninstallation is indicated with the message "Server 
<servername> was successfully removed." 

8 Click Next. 

The Uninstalling status page appears and indicates the progress of the uninstallation.  

A Recommendation dialog box appears and prompts you to approve the removal of the 
remaining installed files. 

9 Click OK. 

The Uninstallation Summary page appears.  

10 For details about the uninstallation, click Details. 

11 Click Close. 
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Uninstalling the InForm software 
1 Stop all InForm servers and studies.  

2 Stop the InForm Service and the InForm Sync Service. 

3 Select Start > Control Panel > Add or Remove Programs. 

4 Select Oracle InForm 5.5, and click Remove. 

A confirmation dialog box appears. 

5 Click Yes. 

6 If a message appears and asks if you want to remove shared files, click No to All. 

A message reminds you to back up customized files before continuing. 

7 To stop uninstalling the software so that you can back up the customized files, click No.  

or 

To continue, click Yes. 

When the uninstall is complete, the Reboot page appears.  

8 Click Finish. 

The computer reboots. 
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admindb 

Purpose 
Creates the InForm Admin database if you did not set it up during the InForm core software 
installation by selecting the Install Admin DB checkbox. 

Location 
<Installation_Directory>\InForm\bin\DBOra folder. 

Usage 
admindb [flags] [connection string] [pfdbadmin password] [informadmin UID] [informadmin password] 
[pfdbadmin UID] 

 

Flag Description 
 –NOPFMQ When run with this flag, the AdminDB command does not create PFMQ 

tables or configure PFMQ. 

– PFMQCFG  When run with this flag, the AdminDB command configures this AdminDB 
as the PFMQ messagestore /infostore. Note that if you choose not to create 
the AdminDB at the time of installation, you should typically use the -
PFMQCFG flag when you run the admindb command to create the 
AdminDB schema manually. However, when the PFMQ data is to be stored 
in a separate schema (for a CIS installation, for example), you should use the 
-NOPFMQ flag. 

 

Example 
admindb -NOPFMQ trial1 pfdbadmin informadmin informadmin pfdabdmin 
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configandcheckdiffdb.sql 

Purpose 
Checks the variable settings in an environment where the study and reporting databases are in 
different database instances. 

Location 
Folder where the reporting software is located, for example, \\Oracle\InForm Reporting\DBOra. 

Usage 
@configandcheckdiffdb 

Notes 
Run logged on to SQL*Plus with /nolog. 

If the script passes with no errors, the variables are correct. If there is an error, make corrections and 
then rerun the script. Do not proceed with the installation until errors have been resolved. 
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configdiffdb.sql 

Purpose 
Contains reporting variables in an environment where the study and reporting databases are in 
different database instances. The reporting installation and uninstallation scripts use the 
configdiffdb.sql file for user name, password, tablespace, and connection information. 

Location 
Folder where the reporting software is located, for example, 
<Installation_Directory>\InForm\bin\DBOra\Reporting. 

Usage 
@configdiffdb 

Notes 
Before running the configdiffdb.sql file, evaluate each user-defined variable, and change the values as 
needed to reflect your environment. 

For more information, see Reporting variable configuration—Different database instances (on 
page 137). 
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create_cap_table.sql 

Purpose 
Creates the TRIAL_URLS table for the PFCAPAdmin user. 

Location 
Folder where the reporting software is located, for example, 
<Installation_Directory>\InForm\bin\DBOra\Reporting. 

Usage 
@create_cap_table.sql 

Notes 
Run from SQL*Plus with /nolog. 

Errors are recorded in the create_cap_table.log file. 

Note: The InForm database installation and administration scripts are designed to be run using 
the InForm Application Server. The scripts can also be run from the Oracle database home on an 
InForm Reporting Server. Running them from a different Windows Oracle client or from a non-
Windows Oracle client or database home may work, but is not supported. 
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deinstall_reporting_diffdb.sql 

Purpose 
Removes a single reporting schema when the study and reporting schemas are located in different 
database instances. This script: 

• Removes all components associated with the Reporting and Analysis module for a single study 
and reporting schema combination. 

• Uninstalls only one reporting schema at a time. To uninstall multiple reporting schemas, you can 
run the script as many times as necessary. 

• Does not remove the underlying reporting infrastructure, including reporting tablespaces. 

Location 
Folder where the reporting software is located, for example, 
<Installation_Directory>\InForm\bin\DBOra\Reporting. 

Usage 
@deinstall_reporting_diffdb 

Notes 
Run from SQL*Plus with /nolog. 

Before running the deinstall_reporting_diffdb.sql script: 

• Review the parameters in the configdiffdb.sql file to make sure that they contain the same values 
that you used to install the reporting schema. For more information, see configdiffdb.sql (on 
page 172). 

• Stop the study. 
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grant_dba_privs.sql 

Purpose 
Grants DBA privileges to the rptinstall user, which is used for install and uninstall operations. 

Location 
Folder where the reporting software is located, for example, 
<Installation_Directory>\InForm\bin\DBOra\Reporting. 

Usage 
@grant_dba_privs rptsinstall 

Notes 
Log on to the study database as SYSDBA. 

The name of the DBA user must be rptinstall. 
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grant_user_privs.sql 

Purpose 
Grants user privileges to the user that owns the study schema. 

Location 
Folder where the reporting software is located, for example, 
<Installation_Directory>\InForm\bin\DBOra\Reporting. 

Usage 
@grant_user_privs.sql <study schema owner> 

 

<study schema owner>—Database user name that holds the study schema. 

Example 
@grant_user_privs pfst55uid 

Notes 
Run from SQL*Plus with /nolog. 

Connect to the study database as a user with the privilege to grant user database privileges, for 
example SYS. 

The script produces a log called grant_user_privs.log. 
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ImportUtility 

Purpose 
Securely import reporting content you export using Cognos commands to a new instance of the 
InForm Reporting server. 

Location 
The InForm application server folder on the InForm application server. For example, 
<Installation_Directory>\InForm\bin. 

Usage 
ImportUtility [-all | -import | -nopwd | -pfmtr] 

 

Option Parameter 
-all • Creates a secure staging folder on the Reporting server accessible to 

system administrators. 

The name of the staging folder is SecureImport_<timestamp>. 

• Creates the import specification object on the Reporting server 
accessible to system administrators. 

• Imports the content from a password-protected deployment package 
to the SecureImport_<timestamp> folder and makes it accessible only 
to system administrators. 

• Copies the imported content to the Public folders on the Reporting 
server. 

• Deletes the SecureImport_<timestamp> folder, all its content, and the 
import specification object.  

-import • Creates a secure staging folder on the Reporting server accessible to 
system administrators. 

The name of the staging folder is SecureImport_<timestamp>. 

• Creates the import specification object on the Reporting server 
accessible to system administrators. 

• Imports the content from a password-protected deployment package 
to the SecureImport_<timestamp>. 

• Deletes the import specification object. 
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Option Parameter 
-nopwd • Creates a secure staging folder on the Reporting server accessible to 

system administrators. 

The name of the staging folder is SecureImport_<timestamp>. 

• Creates the import specification object on the Reporting server 
accessible to system administrators. 

• Imports the deployment package content to the 
SecureImport_<timestamp> folder and makes it accessible only to 
system administrators. 

• Copies the imported content to the Public folders on the Reporting 
server. 

• Deletes the SecureImport_<timestamp> folder, all its content, and the 
import specification object. 

-pfmtr • Creates a secure staging folder on the Reporting server accessible to 
system administrators. 

The name of the staging folder is SecureImport_<timestamp>. 

• Creates the import specification object on the Reporting server 
accessible to system administrators. 

• Imports the content to the SecureImport_<timestamp> folder. 

• Deletes the import specification object. 
 

Command line prompts 
Depending on the option you specify with the ImportUtility, you are prompted for following 
parameters: 

• sysadmin_namespace—Cognos system administrator user namespace. 

• sysadmin_uid—User name for the Cognos system administrator. 

• sysadmin_pass—Cognos system administrator password. 

• dispatcher_url—Internal URI that the InForm server uses to communicate with the Cognos 8 
BI server.  

This Cognos 8 BI parameter is set in the InForm CRN wizard. The parameter setting is stored in 
the cogstartup.xml file and corresponds to the Reporting internal URI value on the Admin > 
System Configuration page of the InForm application. For example, 
http://example.com:9300/p2pd/servlet/dispatch. 

• archive_name—Name of the deployment package containing the reporting content you want to 
import into the Reporting server. 

• archive_pass—Password for the deployment package. 

Note: The archive_pass parameter is not required for the -nopwd or the -pfmtr option. 
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Notes 
• The -import and -pfmtr command options should be used to stage custom reports before 

distributing them to multiple studies. 

To move the content from the staging folder to the study folders and set study-specific 
permissions, use the pfmtrsetuputil command. 

• The -nopwd and -pfmtr command options are used when you are importing a deployment 
package that is not password protected. 

These options should be used only when there is no clinical data present in the deployment 
package. 

Example 
ImportUtility -all 
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informprepora.vbs 

Purpose 
Creates the pfdbadmin user if you did not set it up during the InForm core software installation by 
selecting the Prep Oracle checkbox. 

Location 
<Installation_Directory>\InForm\bin\DBOra folder. 

Usage 
InFormPrepORA.vbs  <oracle_connection_string>  <password_for_sys_user> 
<pfadbadmin_userid> <pfdbadmin_password>   

Example 
informprepora trialdb oracle pfdbadmin pfdbadmin 

Notes 
Set scripting to cscript to suppress popup messages. Type: 

cscript //H:cscript 
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install_reporting_diffdb.sql 

Purpose 
Installs the Reporting and Analysis module in an environment where the study and reporting 
databases are in different database instances. 

Location 
Folder where the reporting software is located, for example, 
<Installation_Directory>\InForm\bin\DBOra\Reporting. 

Usage 
@install_reporting_diffdb.sql 

Notes 
Run from SQL*Plus as /nolog. 

Before running the installation script, make sure that you have updated the study-specific variable 
settings with the configdiffdb.sql script. For more information, see configdiffdb.sql (on page 172). 
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mtsora102.vbs 

Purpose 
Sets up Oracle XA transaction support. During the InForm core software installation, if you check 
the Prep Oracle checkbox, the installation process sets up Oracle XA transaction support. If you do 
not set up Oracle XA transaction support during the installation, the mtsora102.vbs script enables 
you to set it up manually, during or after the Oracle installation. 

The mtsora102.vbs file does the following: 

1 Runs the XAVIEW.sql script as SYS to create the V$XATRANS$ view:   
%ORACLE_HOME%\RDBMS\ADMIN\XAVIEW.SQL 
 

2 Grants SELECT access to the public on these views: 
Grant Select on V$XATRANS$ to public 
Grant Select on sys.dba_pending_transactions to public 
 

3 Modifies the following Registry keys in 
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSDTC\Security 
"NetworkDtcAccess"=dword:00000001 
"NetworkDtcAccessAdmin"=dword:00000001 
"NetworkDtcAccessTransactions"=dword:00000001 
"XaTransactions"=dword:00000001 
"NetworkDtcAccessOutbound"=dword:00000001 
"NetworkDtcAccessInbound"=dword:00000001 
 

4 Modifies the following Registry key in 
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSDTC\XADLL 
"mtxoci.dll"="C:\\WINDOWS\\system32\\mtxoci.dll" 

Location 
<Installation_Directory>\InForm\bin\DBOra folder. 

Usage 
MTSORA102.vbs <oracle_connection_string> <user_sys_password> <oracle_client_home_key> 

Example 
cscript mtsora102.vbs dev1 syspwd KEY_OraClient10g_CLIENT1 

Notes 
When setting up Oracle XA transaction support manually, run both the mtsora102.vbs script and the 
oramtsadmin.sql script. For more information, see oramtsadmin.sql (on page 184). 

Set scripting to cscript to suppress popup messages. Type: 

cscript //H:cscript 
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For a more complete description, refer to one of the following articles: 

• Microsoft Knowledge Base—Q193893 – Info: Using Oracle with Microsoft Transaction 
Server and COM+. 

• MSDN Online Library—Setting up MTS to Access Oracle. 

• Microsoft KB Article 899191. 

• Microsoft KB Article 817066 and 891801 
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oramtsadmin.sql 

Purpose 
Creates the MTS administrative user and schedules automatic transaction recovery. You need to run 
oramtsadmin.sql only if you do not set up Oracle XA transaction support during installation of the 
InForm core software by selecting the Prep Oracle checkbox. If you set up Oracle XA transaction 
support manually, run oramtsadmin.sql after you run the mtsora102.vbs script. 

Location 
%ORACLE_CLIENT_HOME%\oramts\admin folder 

Usage 
@oramtsadmin 

Notes 
Run as the SYS user as SYSDBA. 

Run the script against all Oracle instances connected to the InForm application server. 
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pfadmin 

Purpose 
Sets up the InForm server environment. The parameters are stored in the registry. Therefore, you 
need local administrator privileges to run the utility. 

Location 
\InForm\Bin folder in the InForm installation. 

Usage 
pfadmin [ CHECKREG | CONFIG | CREATEREPORTINGMODEL | HELP | KILLSERVER 
| PING | RECREATEREVIEWSCHEMA | REMOVE | RECREATEREPORTINGSCHEMA | 
SETSERVER | SETUP | SETLANGUAGE | START | STOP | UNINSTALL | VIEW ]  

 

pfadmin command options 

Option Purpose and Syntax 
CHECKREG [/Del] [/DelAll] Displays the current InForm Server COM and MTS components 

in the NT registry.  

WARNING: Be careful to remove the server(s) or uninstall the 
service before using either of the delete options: 

• [/Del]—Removes obsolete settings. 

• [/DelAll]—Removes the settings of all servers. 
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pfadmin command options 

Option Purpose and Syntax 
CONFIG Service  
 [/AdminDB DBServer UID 
PID] | 
 [/AdminDSN DsnName UID 
PID] | 
[ /AdminDN AdminPwd] 
 [/PfUser Password] | 
 [/SysDBA UID PID] 

Configures an existing service. 

• [/AdminDB DBServer UID PID [SQL]]—Sets the ODBC 
DSN for the InformAdmin database. Make sure that 
DBServer, UID, and PID are the same ones that were used to 
create the InformAdmin database. Use alphabetic or 
alphanumeric characters for the UID and PID, and begin 
them with a letter; do not use all numeric characters. 

• [/AdminDSN DsnName UID PID]—Creates the ODBC 
DSN InForm software with the default database server, 
using the specified user name and password. Use alphabetic 
or alphanumeric characters for the UID and PID, and begin 
them with a letter; do not use all numeric characters. 

• [/PfUser Password]—Creates the PfUser_computername 
account during the InForm software installation. The 
account is for Microsoft MTS packages used by InForm 
servers. In general, you do not need to configure the account. 
If you change the password through NT User Manager, you 
must reconfigure the InForm Service with the new password. 

• [/SysDBA UID PID]—Sets the InForm Service DBA user 
name and password. The default username and password is 
pfdbadmin, which is set during the InForm installation. You 
can use this command to change the pfdbadmin password as 
needed. 

If you want to change the InForm Service DBA name, 
modify the provided SQL script InFormPrepORA.sql with 
the new user name and password, then run the script as SYS. 
After running the script, use this command option to 
configure the InForm Service to use the new InForm Service 
DBA. 

Use alphabetic or alphanumeric characters for the UID and 
PID, and begin them with a letter; do not use all numeric 
characters. 

CONFIG Server ServerName 
 [Automatic|Manual] 

Configures the startup mode for an existing server as either 
Automatic or Manual. 
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pfadmin command options 

Option Purpose and Syntax 
CONFIG Trial TrialName 
 [Automatic | Manual] | 
 [/TriDSN DSN UID PID] | 
 [/RndDSN DSN] | 
 [/RndDSN DSN UID PID] | 
 [/Rnd [MDBFilePath ]] | 
 [/Rnd [MDBFilePath ] UID 
PID] | 
 [/Host ServerName] | 
 

Configures an existing study. 

• [Automatic | Manual]—Configures the study startup mode. 

• [/TriDSN DSN UID PID]—Configures the study ODBC 
DSN. Use alphabetic or alphanumeric characters for the 
UID and PID, and begin them with a letter; do not use all 
numeric characters. 

• [/RndDSN DSN]—Configures the study randomization 
source dataset name. Use when setting up a Microsoft 
randomization source database. 

• [/RndDSN DSN UID PID]—Configures the study 
randomization source dataset name. Use when setting up an 
Oracle randomization source database. Use alphabetic or 
alphanumeric characters for the UID and PID, and begin 
them with a letter; do not use all numeric characters. 

• [/Rnd [MDBFilePath]]—Creates a study randomization 
source dataset name to use the given Microsoft Access 
database file. 

• [/Rnd [MDBFilePath] UID PID]—Creates a study 
randomization source dataset name to use the given Oracle 
database file. Use alphabetic or alphanumeric characters for 
the UID and PID, and begin them with a letter; do not use 
all numeric characters. 

• [/Host ServerName]—Moves the study from current host 
server to another server in the InForm Service. 

CONFIG CDD TrialName 
 [Enable | Disable] | 
 [DSN [Active | Inactive]] | 
 [DSN StudyLocale] | 
 [DSN UID PID] 

Configures an existing CDD: 

• [Enable | Disable]—Enables or disables the CDD for a 
particular study. 

• [DSN [Active | Inactive]]—Makes a CDD DSN active or 
inactive for a particular study. 

• [DSN StudyLocale]—Specifies the study locale used for the 
unit symbol translation that is stored in the CDD column for 
the unit symbol. 

• [DSN UID PID]—Configures an existing CDD DSN with 
the User ID and password specified. Use alphabetic or 
alphanumeric characters for the UID and PID, and begin 
them with a letter; do not use all numeric characters. 

CREATEREPORTINGMODE
L TrialName  

Creates the Reporting model from scratch. 

HELP Lists all the options of the pfdamin command. 
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pfadmin command options 

Option Purpose and Syntax 
KILLSERVER ServerName Stops server MTS packages without stopping studies on the 

server. 

PING MachineName  
 1 | 2 | 3:ServerName | 
4:ServerName | 5:ServerName 
[Port#] 

Pings the InForm Service or a particular server. The ping levels 
are: 

• 1—Ping the InForm Service. 

• 2—Ping the InForm Service and all InForm server(s). 

• 3—Ping the specified server. 

• 4—Ping and get information about the specified server. 

• 5—Ping the specified server and dump the user session to a 
server-side file. 

• [Port#]—Allows you to specify the port number the echo 
server is listening on, if you changed it.  

RECREATEREVIEWSCHEM
A [TrialName 
StudyLocale_ISO_name] 

Changes the Review Schema study locale.  

The Review schema study locale is chosen automatically when a 
trial is first installed, but can be changed using this command. 

REMOVE 
 [Server ServerName] | 
 [Trial TrialName [/DSN]] | 
 [CDD TrialName [/All | DSN] 
 

Removes an existing server, study, or CDD. 

• [Server ServerName]—Removes an InForm server from the 
InForm Service. Studies should be either reconfigured to 
other servers or removed before this command is run. 

• [Trial TrialName [/DSN]]—Deletes the named study from 
the InForm Service. The Web virtual directories and folders 
for the study are physically removed. Use the /DSN option 
to remove the study-related DSNs. 

• [CDD TrialName [/All | DSN]—Removes either all CDD 
DSNs in the specified study or the given CDD by DSN. 

Note: Before using the PFADMIN REMOVE command, verify 
that IIS is running. 
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pfadmin command options 

Option Purpose and Syntax 
SETSERVER 
[Site TrialName MachineName] | 
[MedMLInstaller TrialName 
MachineName] | 
[Reporting TrialName 
ReportingUrl] | 
[ReportingAN TrialName 
AuthenticationNamespace] | 
[ReportingUR TrialName 
UserRoot] | 
[ReportingInt TrialName 
ReportingInternalURI] | 

Changes the MedML and Site servers and sets the Reporting 
configuration settings 

• [Site TrialName MachineName]—Not supported. 

• [MedMLInstaller TrialName MachineName]—Not supported. 

• [Reporting TrialName ReportingUrl]—Set Cognos 8 BI URL 
for study. 

• [ReportingAN TrialName AuthenticationNamespace]—Set 
Cognos 8 BI AuthenticationNamespace for study.  

• [ReportingUR TrialName UserRoot]—Set Cognos 8 BI 
UserRoot for study.  

• [ReportingInt TrialName ReportingInternalURI]—Set the 
internal URI that the InForm server uses to communicate 
with the Cognos 8 BI server. 

 

Note: The SETSERVER command requires that you set the 
Default Authentication Level property of the InForm server to 
Connect: 

To set this property: 

1 Select Administrative Tools > Component Services > My 
Computer - Properties. 

2 Set the Default Properties - Default distributed communication 
properties - Default Authentication Level value to Connect. 

SETUP Server ServerName 
[Automatic] 

Creates a new InForm server in the InForm Service. 

• [Automatic]—The server is automatically started with the 
InForm Service. Manual startup is the default. 
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pfadmin command options 

Option Purpose and Syntax 
SETUP Trial TrialName 
ServerName 
 [/DB OracleConnStr UID PID] |  
 [/DSN TriDSN UID PID 
[Automatic]] 

Creates a study on the given InForm server with the option to 
either create a new ODBC DSN or use an existing one. The 
server has to be created. The study startup mode is Manual by 
default. Use the Automatic option to automatically  start the 
study when the InForm server that hosts the study is started. 

• [/DB OracleConnStr UID PID]—Creates an ODBC DSN 
TrialName with the given ServerName, UID, and PID. Use 
alphabetic or alphanumeric characters for the UID and PID, 
and begin them with a letter; do not use all numeric 
characters. 

• [/DSN TriDSN UID PID [Automatic]]—Configures the 
created study TrialName to use the given study dataset name 
TriDSN, UID, and PID. The study must be present in the 
ODBC DSN. Use alphabetic or alphanumeric characters for 
the UID and PID, and begin them with a letter; do not use 
all numeric characters. 

Note: Before using the /DSN command, verify that IIS is 
running. 

SETUP CDD RefName 
TrialName  
 /DB OracleConnStr DSN UID 
PID  
 [/TBSP OraTBSP] [Active] 
[NoSchema] 

Sets up a new CDD DSN associated with the given CDD 
refname. Use alphabetic or alphanumeric characters for the UID 
and PID, and begin them with a letter; do not use all numeric 
characters. 

• [/TBSP OraTBSP]—Defines the Oracle tablespace for the 
CDD schema. 

• [Active]—Specifies that the DSN is transactional. 

• [NoSchema]—Indicates that no new CDD schema should be 
created during setup. The existing database is not touched. 
By default, the user is dropped and the Oracle database 
destroyed. Then, a new schema is created and populated 
based on the RefName that defines the schema. 

Note: To execute this command successfully, the study must be 
started. 
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pfadmin command options 

Option Purpose and Syntax 
SETUP CDD RefName 
TrialName  
 /DSN DSN UID PID  
 [/TBSP OraTBSP] [Active] 
[NoSchema] 

Sets up an existing DSN associated with the given CDD 
RefName. Use alphabetic or alphanumeric characters for the 
UID and PID, and begin them with a letter; do not use all 
numeric characters.[/TBSP OraTBSP]—Defines the Oracle 
tablespace for the CDD schema. 

• [Active]—Makes the DSN transactional. 

• [NoSchema]—Indicates that no new CDD schema should be 
created during setup. The existing database is not touched. 
By default, the user is dropped and the Oracle database 
destroyed. Then, a new schema is created and populated 
based on the RefName that defines the schema. 

Note: To execute this command successfully, the study must be 
started. 

SETLANGUAGE 

[IsoLanguageName] 

| en-US | ja-JP | 

Sets the InForm product locale language. en-US and ja-JP are 
currently supported. 

SETSERVER 
PFREPORTINGUSERPW 

<studyname> <new_password> 

• pfreportinguser is the preferred studyuser to run pfrinit to 
configure Cognos for each study. 

• After the password for the pfreportinguser is changed via the 
InForm user interface, run this pfadmin command to set a 
property used by Reporting when it needs the credentials of 
the pfreportinguser user for building the model.  

START  
 [Server ServerName] | 
 [Trial TrialName] 

Starts an existing InForm server or study. 

• [Server ServerName]—Starts an existing InForm server by 
server name. 

• [Trial TrialName]—Starts an existing study by study name. 

START 
 [Trial TrialName [/Design]] 

Starts the study in design mode. This means you can install study 
components that are not completely designed (strict checking is 
not in force). By default, the study starts in production mode. 

STOP  
 [Server ServerName [/Trials]] | 
 [Trial TrialName [/Anyway]] 

Stops an existing InForm server or study. 

• [Server ServerName [/Trials]]—Stops an existing InForm 
server by server name. By default, a running server can be 
stopped if there is no study running and no other application 
connected to it. The Trials keyword stops all running studies, 
and then stops the server. 

• [Trial TrialName [/Anyway]]—Stops the named study. The 
Anyway keyword stops a study regardless of any connections 
or HTTP requests. 
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pfadmin command options 

Option Purpose and Syntax 
UNINSTALL Removes all InForm servers and studies, and then removes the 

InForm service settings PfUser_computername and the MTS library 
package.  

Note: The InForm service must be running for the command to 
work. 

VIEW  
 [Languages] | [Service] | 
 [Server ServerName] | 
 [Trial TrialName] | 
 [CDD TrialName] | [Reporting 
TrialName]  

 

Displays a monitoring list of all servers in the InForm service, all 
studies in servers, or all RefNames for CDD DSNs configured 
for a study. 

• [Languages]—Lists installed languages without starting the 
InForm Service. 

• [Service] 

 Lists all the servers and studies in the InForm service. 

 Lists installed product languages as well as the actual 
installed product language. 

• [Server ServerName]—Lists each server by server name and 
studies hosted on that server. 

• [Trial TrialName]—Lists a study by its name. 

• [CDD TrialName]—Lists the RefNames for each CDD DSN 
configured for the specified study. 

• [Reporting TrialName]—Lists the current status of Reporting. 

 States whether the trial is configured for Reporting. 

 Specifies the type of reporting setup: samedb or diffdb. 

 Specifies the reporting username. 

 Gives the date of the last Cognos model update. 

 Reports if the Reporting database is up-to-date. 

 States whether Oracle streams are working properly (if 
applicable). 

Examples 
Check the status of InForm Reporting: 

pfadmin view reporting pfst55 
 

Check the status of InForm servers and studies on an InForm Service: 

pfadmin view service 
Start the demo InForm server: 

pfadmin start server demo 
 

Start the pfst55 study: 

pfadmin start study pfst55 
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Stop all studies running on the demo InForm server, and then stop the demo server: 

pfadmin stop server demo /Trials 
 

Notes 
Any arguments containing commas, equal signs, or spaces must be enclosed within double quotes. 
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pfcognosconfig 

Purpose 
Configures an InForm study to work with Cognos 8 BI. 

PFCognosConfig can be run multiple times to change reporting parameters.  If the reporting study 
user password changes, PFCognosConfig.exe must be run to tell InForm about the new password. 

When PFCognosConfig is run multiple times for a study, each run after the first need not specify all 
the parameters – only the changed parameters need be specified. 

Location 
<Installation_Directory>\InForm\bin\DBOra folder. 

Usage 
PFCognosConfig.exe /TRIALNAME:<studyname> /OUT:<Patch_and_name_of 
Output_log>.log /NAMESPACE:<cap_namespace> 
/GATEWAYURI:http://<gateway_uri>:80/cognos8 
/DISPATCHERURI:<dispatcher_uri>:9300/p2pd/servlet/dispatch 
/RootFolder:/<content>/<folder>[@name=<studyname> 
/REPORTINGDIFFDBSERVER:<studyname> /REPORTINGDIFFDBPW:<studyname_password> 
/REGISTERDBSERVER:<servername> /REGISTERDBUSER:<username> 
/REGISTERDBPW:<userpassword> 
/TRIALWEBSERVICE:<InForm_authentication_web_service_URL>/<studyname>/authservice
/authentication.svc/ 

 

Option Description 
/TRIALNAME: <studyname> Name of the InForm study. 

Note: Use the same case as when the study was created 
by the Central Designer deployment package. 

/OUT: <outputlog> Name of output log. Example: nocreatorgcap.log 

/NAMESPACE: <cap_namespace> Custom Authentication Provider (CAP) namespace. The 
default is informcap. The case of the value you enter here 
must be the same case as the entry in the Cognos 
Configuration utility. For example, if the entry in the 
Cognos Configuration utility is in lower case (informcap), 
the <namespace> option must also be informcap. 

Users can create additional namespaces manually in the 
Cognos Configuration tool. In this case, the name of the 
newly created namespace should be used in this field. 

/GATEWAYURI: <gateway_uri> External public URI that communicates with the Cognos 
8 BI Gateway Services from an end user's browser. This 
Cognos parameter is set in the Cognos 8 BI Gateway 
Customization for InForm wizard. The parameter setting 
is stored in the cogstartup.xml file.  

Example: http:example.north.com/cognos8 
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Option Description 
/DISPATCHERURI: <dispatcher_uri> Internal URI that the InForm server uses to communicate 

with the Cognos 8 BI server. This Cognos parameter is 
set in the InForm CRN wizard. The parameter setting is 
stored in the cogstartup.xml file and corresponds to the 
Reporting internal URI value on the Admin > System 
Configuration page of the InForm application. 

Example: 
http://example.north.com:9300/p2pd/servlet/dispatch. 

/ROOTFOLDER: 
/<content>/<folder>[@name='<studyna
me>'] 

The top-level reporting folder for the company. Default: 

/content/folder[@name='<studyname>'] 

/REPORTINGSAMEDB: Use if the study and the Reporting database are on the 
same server. 

/REPORTINGDIFFDBSERVER: Reporting database connection string (TNS Name). Use if 
Reporting and the InForm study are in different 
databases. 

/ REPORTINGDIFFDBPW: Reporting Trial password (reporting database trial 
username must be the same as the InForm database trial 
username, so the username need not be specified). Use if 
the study and the Reporting database are in different 
databases. 

/TRIALWEBSERVICE: InForm authentication web service URL. This is a 
required parameter. 

/REGISTERDBSERVER:<ServerNa
me> 

Name of the server in which the study is registered with 
Cognos.  

/REGISTERDBUSER:<UserName> Study database user registered with Cognos. 

/REGISTERDBPW:<UserPassword> Password for the database user registered with Cognos. 
 

Example: 

Example command-line with a complete set of parameters to set up reporting DiffDB: 

PFCognosConfig.exe /TRIALNAME:PFST55DEC03 /OUT:d:\PFST55DEC03-PFCognosConfig.log 
/NAMESPACE:informcap /GATEWAYURI:http://Kbacon2k3dell.north.pf.com:80/cognos8 
/DISPATCHERURI:http://kbacon2k3dell.north.pf.com:9300/p2pd/servlet/dispatch 
/RootFolder:/content/folder[@name='PFST55DEC03'] /REPORTINGDIFFDBSERVER:STUDY2 
/REPORTINGDIFFDBPW:PFST55DEC03 /REGISTERDBSERVER:STUDY2 
/REGISTERDBUSER:pfst55feb09 /REGISTERDBPW:pfst55feb09 
/TRIALWEBSERVICE:http://dpf001235.north.pf.com/pfst55/authservice/authentication
.svc/ 
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pfrinit 

Purpose 
Performs the following tasks: 

• Modifies the default Cognos 8 BI capabilities to fit the InForm reporting environment. 

• Creates new Cognos 8 BI groups that match InForm reporting requirements. 

• Sets Public folders permissions so that only Publishers can write to this public area. 

• Imports the InForm Trial Management (ITM) archive and prepare for new study setup. 

• Maps study-specific reporting groups to the Cognos 8 BI groups and roles. 

• Creates study-specific data connection and set permissions so that it is restricted for the use of 
study members only. 

• Copies the ITM package present in the InForm folder and renames it as a study-specific ITM 
package. 

• Creates a study folder that contains all the standard folders and reports that point to the study-
specific package. Relative paths within reports will be modified to reflect the new location. 

• Validates all copied reports so that all successfully validated reports are syntactically correct and 
able to run against the study-specific packages. 

Location 
<Installation_Directory>\InForm\bin on InForm application server. 

Usage 
pfrinit PFWD crnsysadmin <crnsysadmin_password> <namespace> <InForm_study_user> 
<InForm_study_user_password> <internal_dispatcher_uri> <studyname> 

The recommended InForm study user for running pfrinit is pfreportinguser. You can change the 
password for this user using the InForm user interface as with any other user. After you change the 
password, however, you must run the PFADMIN command, using this syntax: 

PFADMIN SETSERVER PFREPORTINGUSERPW <studyname> 

When prompted, enter the pfreportinguser password. 

This command sets a property used by Reporting when it needs the credentials of the 
pfreportinguser. 

For more information, see pfadmin (on page 185). 
 

pfrinit command options 

Option Description 
admin_namespace Sun ONE Directory Server admin namespace. Type 

ORACLEHS (case-sensitive). 
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pfrinit command options 

Option Description 
admin_username User name for the Sun ONE Directory Server admin namespace. 

Type crnsysadmin. 

crnsysadmin_password Password you chose when creating the crnsysadmin user. 

namespace Custom Authentication Provider (CAP) namespace. The default is 
informcap. The case of the value you enter here must be the same 
case as the entry in the Cognos Configuration utility. For example, 
if the entry in the Cognos Configuration utility is in lower case 
(informcap), the <namespace> option must also be informcap.   

InForm_study_user InForm study user who is a member of the following Reporting 
groups: 

• Publishers. 

• Either Sponsor Users or Site Users. 

pfreportinguser is the recommended study user to run pfrinit. 
This is user is created during Reporting and Analysis installation. 

InForm_study_user_password Password of the InForm study user. 

internal_dispatcher_uri Internal URI that the InForm server uses to communicate with 
the Cognos 8 BI server. This Cognos 8 BI parameter is set in the 
InForm CRN wizard. The parameter setting is stored in the 
cogstartup.xml file and corresponds to the Reporting internal URI 
value on the Admin > System Configuration page of the InForm 
application. 

Example: 
http://<machine_FQDN>:9300/p2pd/servlet/dispatch. 

studyname Name of the InForm study. 

Note: Use the same case as when the study was created by the 
Central Designer deployment package. 

 

Example 
pfrinit PFWD crnsysadmin crnsysadminpid informcap <InForm_study_user> 
<InForm_study_user_password> http://rdinform222.pf.com:9300/p2pd/servlet/dispatch pfst50 
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