Go to main content

man pages section 9: DDI and DKI Driver Entry Points

Exit Print View

Updated: July 2017
 
 

audio_engine_channels(9E)

Name

audio_engine_channels - return the number of channels for an audio engine

Synopsis

#include <sys/audio/audio_driver.h>

int prefix_channels(void *state);

Parameters

state

pointer to driver supplied soft state

Interface Level

Solaris DDI specific (Solaris DDI)

Description

The audio_engine_channels() function is called by the framework to determine the number of channels used by the engine.

The audio framework currently supports between one and 16 channels.

There is no standard convention for the layout of more than eight channels.

An audio engine may not change the number of channels it uses while it is open.

Return Values

The audio_engine_channels() function returns the number of channels for the engine (such as 1 for mono, 2 for stereo, 6 for 5.1 surround, or 8 for 7.1 surround.)

Context

This function may be called from user or interrupt context.

Attributes

See attributes(5) for descriptions of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Interface Stability
Committed

See Also

attributes(5), audio(7D), audio_engine_ops(9S)