Go to main content

man pages section 9: DDI and DKI Driver Entry Points

Exit Print View

Updated: July 2017
 
 

audio_engine_playahead(9E)

Name

audio_engine_playahead - return the play-ahead sample count for an audio engine

Synopsis

#include <sys/audio/audio_driver.h>

uint_t prefix_playahead(void *state);

Parameters

state

pointer to driver supplied soft state.

Interface Level

Solaris DDI specific (Solaris DDI)

Description

The audio_engine_playahead() function returns a driver-supplied hint indicating how many frames the framework should queue up to the device to avoid device underruns. This entry point is optional and NULL may be supplied, in which case the framework will assume a default that is reasonable for most devices.

This entry point is most appropriate for devices with inconsistent scheduling, such as emulated devices or devices backed by user programs. For these devices, this entry point allows the driver to supply a larger value than the normal default.

Return Values

The audio_engine_playahead() function returns the number of frames the framework should queue for playback.

Usage

This function is only called after the device is first opened; the dynamically changing values are not supported.

Context

This function may be called from user or interrupt context.

Attributes

See attributes(5) for descriptions of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Interface Stability
Committed

See Also

attributes(5), audio(7D), audio_engine_ops(9S)