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1
Introduction

This chapter contains general information, such as an overview of the manual, how
the manual is organized, and how to get technical assistance.

Overview
This manual provides information about using the Oracle Communications LSMS
graphical user interface (GUI), using the LSMS command line, managing NPAC
relations, managing locally provisioned data, report generation, and logs and
measurements.

Scope and Audience
This manual is intended for LSMS operators and database administrators.

Documentation Admonishments
Admonishments are icons and text throughout this manual that alert the reader to
assure personal safety, to minimize possible service interruptions, and to warn of the
potential for equipment damage.

Table 1-1    Admonishments

Icon Description

Danger:

(This icon and text indicate the possibility of
personal injury.)

Warning:

(This icon and text indicate the possibility of
equipment damage.)

Caution:

(This icon and text indicate the possibility of
service interruption.)

Topple:

(This icon and text indicate the possibility of
personal injury and equipment damage.)
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Manual Organization
The Database Administrator's Guide includes:

• Introduction contains general information, such as an overview of the manual,
how the manual is organized, how to get technical assistance, and a list of related
documentation.

• Database Administration Overview contains LSMS overview information, an
overview of database functions, describes the use of the LSMS command line, and
how to start, use, and exit the LSMS GUI.

• Managing NPAC Relations discusses the data that the LSMS and Number
Portability Administration Center (NPAC) have in common.

• Managing Locally Provisioned Data contains information about Element
Management System (EMS) routing, custom TN filters, GTT groups, default and
override global title translation (GTT), Numbering Plan Area (NPA) Splits, and
input data by file.

• LSMS Reports contains procedures for generating, viewing, and printing LSMS
reports in a predefined format. It also contains information about the Report
Generator, which enables you to create customized LSMS reports.

• LSMS Logs and Measurements describes the logs maintained by LSMS and how
to access, navigate, and print them.

• #unique_18 describes 24-hour clock conversion, explains how to calculate local
time, and shows the breakdown of the world time zones expressed in hours (plus
or minus) from Greenwich Mean Time (GMT).

My Oracle Support (MOS)
MOS (https://support.oracle.com) is your initial point of contact for all product
support and training needs. A representative at Customer Access Support (CAS) can
assist you with MOS registration.

Call the CAS main number at 1-800-223-1711 (toll-free in the US), or call the Oracle
Support hotline for your local country from the list at http://www.oracle.com/us/
support/contact/index.html. When calling, make the selections in the sequence
shown below on the Support telephone menu:

1. Select 2 for New Service Request

2. Select 3 for Hardware, Networking and Solaris Operating System Support

3. Select one of the following options:

• For Technical issues such as creating a new Service Request (SR), Select 1

• For Non-technical issues such as registration or assistance with MOS, Select 2

You will be connected to a live agent who can assist you with MOS registration and
opening a support ticket.

MOS is available 24 hours a day, 7 days a week, 365 days a year.

Manual Organization
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Emergency Response
In the event of a critical service situation, emergency response is offered by the
Customer Access Support (CAS) main number at 1-800-223-1711 (toll-free in the US),
or by calling the Oracle Support hotline for your local country from the list at http://
www.oracle.com/us/support/contact/index.html. The emergency response provides
immediate coverage, automatic escalation, and other features to ensure that the critical
situation is resolved as rapidly as possible.

A critical situation is defined as a problem with the installed equipment that severely
affects service, traffic, or maintenance capabilities, and requires immediate corrective
action. Critical situations affect service and/or system operation resulting in one or
several of these situations:

• A total system failure that results in loss of all transaction processing capability

• Significant reduction in system capacity or traffic handling capability

• Loss of the system’s ability to perform automatic system reconfiguration

• Inability to restart a processor or the system

• Corruption of system databases that requires service affecting corrective actions

• Loss of access for maintenance or recovery operations

• Loss of the system ability to provide any required critical or major trouble
notification

Any other problem severely affecting service, capacity/traffic, billing, and
maintenance capabilities may be defined as critical by prior discussion and agreement
with Oracle.

Related Publications
For information about additional publications related to this document, refer to the
Oracle Help Center site. See Locate Product Documentation on the Oracle Help Center
Site for more information on related product publications.

Customer Training
Oracle University offers training for service providers and enterprises. Visit our web
site to view, and register for, Oracle Communications training:

http://education.oracle.com/communication

To obtain contact phone numbers for countries or regions, visit the Oracle University
Education web site:

www.oracle.com/education/contacts

Locate Product Documentation on the Oracle Help Center Site
Oracle Communications customer documentation is available on the web at the Oracle
Help Center (OHC) site, http://docs.oracle.com. You do not have to register to access
these documents. Viewing these files requires Adobe Acrobat Reader, which can be
downloaded at http://www.adobe.com.

Emergency Response
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1. Access the Oracle Help Center site at http://docs.oracle.com.

2. Click Industries.

3. Under the Oracle Communications subheading, click the Oracle
Communications documentation link.

The Communications Documentation page appears. Most products covered by
these documentation sets will appear under the headings "Network Session
Delivery and Control Infrastructure" or "Platforms."

4. Click on your Product and then the Release Number.

A list of the entire documentation set for the selected product and release appears.

5. To download a file to your location, right-click the PDF link, select Save target
as (or similar command based on your browser), and save to a local folder.

Locate Product Documentation on the Oracle Help Center Site
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2
Database Administration Overview

This chapter contains LSMS overview information, an overview of database functions,
describes the use of the LSMS command line, and how to start, use, and exit the LSMS
GUI.

Introduction
Local Number Portability (LNP) allows a subscriber to change location, service
provider, or service while keeping the same directory number. Number portability
ensures that subscribers receive the same freedom of choice for local service as they
have with long-distance service providers.

These changes in telephone service enable LNP:

• When a subscriber is granted LNP service, the subscriber’s telephone number is
"ported" into various LNP databases that contain routing information. The official
repository for LNP database information is contained in government-controlled
Number Portability Administration Centers (NPACs). Currently, eight regional
NPACs serve the United States and Canada.

• Central office and tandem switches no longer will use only a telephone number’s 
NPA-NXX code (area code and local exchange code) to determine where a call
should be delivered. Routing information is stored in LNP databases, which must
be queried when any call is made to an NPA-NXX that contains one or more
ported numbers.

Figure 2-1 shows an overview of how an LSMS serves as an interface between NPAC
Service Management Systems (SMSs) and network elements (central office or tandem
switches). The LSMS maintains a service provider’s LNP data so that it is not
necessary for each network element (NE) to have a direct connection with each NPAC.
This figure shows the maximum number of NPACs and network elements supported
by Oracle's LSMS.
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Figure 2-1    LNP Configuration

The LSMS application receives LNP data from the NPAC, stores the data, and
transfers the data to the correct NE. LSMS supports the following NPACs:

• Midwest

• MidAtlantic

• Northeast

• Southeast

• Southwest

• Western

• WestCoast

• Canada

When connected to multiple NPACs, LSMS keeps the data for each NPAC separate.
Each NPAC can access data only in its corresponding regional database.

Introduction

2-2  LSMS Database Administrator's Guide



The LSMS is composed of hardware and software components that interact to create a
secure and reliable LNP system. These components and their functions are discussed
in this chapter.

Overview of Database Functions
The main function of the LSMS is to provision LNP data to the EAGLE system. To
perform this task, the LSMS maintains active connections with one or more NPAC
region servers and one or more EAGLE nodes. While it is the goal of the LSMS to
maintain active connections to each NPAC server and EAGLE node as nearly full-time
as possible, the more important goal is to reliably forward the data from the NPAC to
the EAGLE as quickly as possible. To that end, a number of protective problem
detection and recovery mechanisms are built into the LSMS design. Several of these
protections actually allow for the termination of application connectivity in order to
gracefully restore full connectivity and guarantee total recovery of data.

In these situations, the LSMS proactively terminates and automatically re-establishes
application connectivity with the NPAC and EAGLE nodes:

• If the LSMS detects network level connectivity failures with either the NPAC or
EAGLE, the respective LSMS processes terminate the socket level connection and
then reconnect. This disconnect and reconnect occurs in a matter of seconds. Built
in resynchronization mechanisms ensure data recovery. The data transmission is
delayed by the time required to disconnect and reconnect, but the automatic
execution of the recovery procedures prevents data loss.

• If the LSMS detects critical internal errors that would cause system outages, the
LSMS processes are designed to terminate and allow the LSMS sentry process to
restart them. This is done only for significant internal errors that jeopardize
internal LSMS communications. Once the sentry process restarts the LSMS
processes, resynchronization provides full data recovery. The restart time for
processes by sentry consists of the detection time plus the restart time. Processes
typically are restarted within 30 seconds.

The following sections describe the functions provided by Oracle's LSMS.

Receiving LNP Data from an NPAC

LNP data are the physical records with telephone number (TN) information about the
subscriber. (LNP data is also referred to as subscription version information.)

LNP data includes:

• Subscription data – The subscriber’s telephone number information.

• Network data – Routing information for the service provider’s network.

• Service provider data – The service provider’s LSMSID. LSMS identifies itself to the
NPAC using a service provider ID. The service provider ID is that of the LSMS
owner, such as Telephone Company A.

Typically, a third party not affiliated with any of the telecommunication service
providers administers an NPAC. When a customer has a number ported to the new
service provider, the current service provider sends the customer LNP data from a
local service order administration (LSOA) to the NPAC. From there, the NPAC sends
the LNP data to each service provider’s LSMS. Each LSMS stores all subscription
version information received from an NPAC in a database.

Overview of Database Functions
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The LSMS software maintains the internal data on the service provider’s network. The
data includes:

• Intermediate or final Global Title Translation (GTT) information for database
services

• Six-digit default GTT (GTT for nonported numbers in a ported NPA-NXX)

• List of ported NPA-NXX requiring message relay service at each node

• Services (translation types) requiring message relay

Administering LNP Data

After receiving the LNP data from the NPAC, LSMS:

• Stores the data on the LSMS database

• Translates the data for Custom Local Area Signaling Services (CLASS), Line
Information Database (LIDB), Calling Name Delivery Service (CNAM), Inter-
Switch Voice Mail (ISVM), and optionally, Wireless Short Message Service Center
(WSMSC).

• Administers the translation type and its alias for the services

• Determines which NE should receive the LNP data

Transferring LNP Data to Service Providers

Service providers use network elements to manage LNP data. Each network element
has its own element management system (EMS) or operating system. Oracle's EAGLE
LNP solution, for example, relies upon a proprietary high-speed multi-processor EMS.
LSMS distributes subscription records to a network element based on its area of
portable service (AOPS).

Service providers store the LNP data on the LNP-STP database for their subscribers.
When a subscription version has to be created or updated on the LNP-STP, LSMS
compares the NPA-NXX of the telephone number with the LNP-STP AOPS. When a
match is found, the subscription version is downloaded to that LNP-STP.

Supporting Additional Service Providers

LSMS is configured to support as many as 32 supported-service providers (entities
who buy access to the LNP service from the LSMS owner and use this functionality to
support LNP in their own networks). Customers have the option to configure
additional SPIDs in blocks of 16 to a maximum of 512 SPIDs.

NPAC administrators assign a unique ID for each supported-service provider. The
name, address, and location of the service provider in LSMS, along with the network
provider’s address, are manually configured in the LSMS.

For each supported-service provider, LSMS assigns a service provider ID and
translates and interprets its data before sending it.

For each supported-service provider, LSMS administers a default six-digit GTT. The
default GTT is specific to each service provider for the six supported services per
NPA-NXX. The default GTT can be a final GTT or a nonfinal GTT. LSMS downloads
this data to all LNPs defined in the supported-service provider network.

NPA-NXX Support

The LSMS supports a maximum of 300,000 NPA-NXXs across all regions.
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Handling NPA Splits

LSMS administers information regarding NPA-NXX splits. An LSMS user creates a
split in the appropriate region ahead of time by entering the Permissive Dialing Period
(PDP) start and end dates. When the split is automatically activated as the start date is
reached, LSMS checks for the old NPA-NXX to be split in each TN Filter. If the old
NPA-NXX or the NPA containing the old NPA-NXX is present in the TN Filter, the
new NPA-NXX is added to the TN Filter.

The NPAC updates its own records and does not automatically send the updated split
information to LSMS. The automatic activation on the LSMS keeps the LSMS and
NPAC records synchronized and prevents incorrect results during an NPAC audit.

Logs and Reports

LSMS logs all request/response transactions between the NPAC and LSMS,
maintaining a separate transactions log for each NPAC. The NPAC transactions log
contains key data elements. All transactions logs related to the subscription version
store the telephone number, subscription ID, and LRN.

LSMS logs all alarms, such as link failures, association failures, database failures, and
data provisioning failures.

Exception logs help to identify the following situations where data provisioning is
incorrect:

• Transaction commands sent to the EAGLE but rejected

The LSMS maintains logs from the past seven days as well as the current day. These
logs are deleted after seven days. If needed, you can back up any or all transactions
logs using standard backup procedures. These logs can be retrieved for reporting
based on a key or time range.

Synchronizing LSMS and Network Element Data

The LSMS/EAGLE LNP system provides a variety of methods to keep the LNP
databases at the LSMS and at the network elements synchronized. For more
information, refer to the LNP Database Synchronization User's Guide.

Security Issues

LSMS offers security by controlling which users can access various functions through
login management. Security between the NPAC and LSMS is provided by keys, as
described in the Configuration Guide.

Permission Groups

The LSMS system administrator is responsible for creating user accounts by assigning
users to permission groups.

For more information about non-configurable permission groups:

• See GUI Function Access

• Refer to the Alarms and Maintenance Guide

For information about configurable permission groups, refer to the following manuals:

• Alarms and Maintenance Guide

• Configuration Guide

Overview of Database Functions
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Managing LSMS Functions

The LSMS GUI can be used for all functions described in this book. For more
information, see Starting an LSMS GUI Session and Navigating the GUI.

Number Pooling EDR
The Number Pooling Efficient Data Representation (EDR) feature allows ported
telephone numbers (TNs) to be assigned to different service providers in a more
efficient manner. Before the availability of this feature, TNs were assigned to service
providers (also known as block holders) in 10,000 number increments (blocks) on an
NPA-NXX basis.

Not all service providers required 10,000 TNs, resulting in many unused telephone
numbers being held in reserved status. Number pooling, which refers to the
assignment of a block of 1000 TNs (NPA-NXX-X) of an NPA-NXX to another service
provider, eliminates this inefficiency by allocating telephone numbers on a smaller
block basis. These smaller blocks, each of which corresponds to 1000 TNs, are called
number pool blocks (NPBs).

In addition, the number pooling data for a particular block of TNs is stored as a single
object rather than as multiple subscription versions. This method increases interface
and database efficiencies.

The LSMS continues to support the existing required transaction rates over the NPAC-
LSMS interface, where a NPA-NXX-X pool block object is equivalent to one
transaction and one TN.

All functions that the LSMS performs to manage TNs are also performed similarly for
NPBs.

SPID Security for Locally Provisioned Data
This optional feature is activated by Oracle customer service using secure activation
procedures.

In LSMS releases previous to LSMS 5.0, any user was able to log in using any Service
Provider Identifier (SPID) that was defined on the LSMS. The user was able to view
any data for any SPID, and depending on which user privileges were assigned to that
username, might even be able to change data associated with any SPID.

Beginning with LSMS Release 5.0, LSMS offered an optional feature that allowed the
LSMS administrator to assign only certain usernames to be allowed to log on with a
specified SPID. In addition, the LSMS administrator can assign a username to be
given access to all SPIDs; such a user is called a “golden user.”

This feature is especially useful for LSMS customers that act as service bureaus,
offering LSMS services to other service providers. The service bureau may administer
locally provisioned data for a client and may choose to allow the client to administer
or view its own data without allowing that client to view or change data belonging to
other clients.

Types of Data Protected by SPID Security

Association of a username with a SPID allows the LSMS system administrator to
restrict access to the following types of locally provisioned data:

• Default global title translation (GTT)
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• Override GTT

• GTT Groups

• Telephone number (TN) filters

• Assignment of GTT groups and TN filters to an EMS (element management
system). For more information about GTT groups, see Enhanced LSMS Filters.

Accessibility to these types of data are protected by SPID security for any access
method (for example, through the GUI, through input data by file, audit, and
reconcile).

For information about activating the SPID security feature and assigning usernames
to SPIDs, refer to the Alarms and Maintenance Guide.

Wireless Short Message Service Center (WSMSC) Support
This feature is activated by Oracle customer service using secure activation
procedures.

NPAC Support

NPAC supports the ability to send Subscription Versions (SVs) or Number Pool Blocks
(NPBs) to the LSMS in different formats. The original format includes four services
(CLASS, CNAM, ISVM and LIDB). With the wireless option enabled, the SVs and
NPBs format will also include Wireless Short Message Service Center for a total of five
services (CLASS, CNAM, ISVM, LIDB, WSMSC). The format selected will apply to
all records being sent from the NPAC, whether all the services are populated or not.

Activating the WSMSC Feature

The LSMS supports the ability to receive WSMSC data from some NPACs and not
from others; therefore, this feature is activated on a regional basis. Also, full activation
of this feature requires coordination with the activation of the related feature on the
EAGLE.

To activate the feature the LSMS customer should contact Oracle customer service.
After Oracle customer service has activated the feature, using secure activation
procedures, the LSMS customer should contact the NPAC to update their regional
profiles.

Note:   When the WSMSC feature is activated, an import of NPAC
subscription version data is required in order to update the LSMS database.
Additionally, if the feature to send WSMSC data to the ELAP is activated,
then a bulkload to the ELAP is also required.

Processing WSMSC Data

When the WSMSC feature has been activated at the LSMS, the LSMS performs the
following functions:

• When the NPAC region has been notified that it may send WSMSC data, the
LSMS determines whether WSMSC data is present in an SV or NPB update from
the NPAC, and, when WSMSC data is present, decodes the data (DPC and SSN)
and stores it in the LSMS database

• Makes WSMSC data available to be viewed through the GUI and recorded in
reports
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• Allows the user to provision WSMSC data in Global Title Translation (GTT)
data:

– For Default GTT, the user can specify TT, DPC, SSN, XLAT, RI, and NGT
WSMSC data

– For Override GTT, the user can specify TT, DPC, SSN, XLAT, RI, NGT, and
RGTA WSMSC data

Custom TN Filters
The Custom TN Filters feature is included as a standard feature and provides
improved usability and performance. The user can specify one or more Custom TN
filters and then associate the Custom TN filter with one or more EMS.

Enhanced LSMS Filters
This optional feature is activated by Oracle Customer Service using secure activation
procedures.

LSMS provides, as a standard feature, an efficient filtering mechanism as described in 
Custom TN Filters. In addition, beginning with LSMS Release 5.0, LSMS offered this
optional feature, Enhanced LSMS Filters, which provides the following enhancements
to the Custom TN Filters:

• Regional TN filters

• GTT groups

To apply any filter (including a standard Custom TN filter) to an EMS, select LSMS >
EMS Routing > Modify.

Overview of Database Functions
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Figure 2-2    Modify EMS Routing

Regional TN Filters

Once the Enhanced LSMS Filters optional feature has been activated, TNs can be
filtered by either of the following, but not by both:

• Custom TN filter —When a custom TN filter is assigned to an EMS, the LSMS
forwards to the EMS only transactions that contain the NPA or NPA-NXX
specified in the custom TN filter (for more information, see Custom TN Filters)

• Regional TN filters—When regional TN filters are assigned to an EMS, the LSMS
forwards to the EMS only NPAC transactions received from the specified regions

Once the Enhanced LSMS Filters optional feature has been activated, the NPAC
Region(s) field will be selectable in the Modify EMS Routing window. To select
one or more NPAC regions to apply to this EMS:

1. Click the NPAC Region(s) radio button so that it is filled in.

2. Select an NPAC region whose TNs and NPBs you wish to have forwarded to this
EMS by clicking the NPAC name so that it is highlighted.

3. To select multiple NPAC regions, do one of the following:

Overview of Database Functions
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• To select additional NPAC regions listed consecutively, hold down the Shift
key while you click another NPAC region. All NPAC regions listed between
the first region clicked and the last region clicked will be highlighted.

• To select additional NPAC regions not listed consecutively, hold down the Ctrl
key while you click additional NPAC regions.

4. When all the NPAC regions desired are highlighted, click either:

• Apply (which allows you to repeat this procedure for another EMS)

• OK (which closes the window)

GTT Groups

GTT groups allow locally provisioned data to be filtered to EMSs similar to how a
Custom TN filter or Regional TN filters allow NPAC data to be filtered to EMSs. After
the Enhanced LSMS Filters optional feature has been activated, filtering can be
applied to the following locally provisioned data:

• Default GTT (DGTT)

• Override GTT (OGTT)

All Default GTT data or Override GTT data must be defined as belonging to a group,
as indicated in Figure 2-3.

Figure 2-3    Create Default GTT Window

• For customers who do not have the Enhanced LSMS Filters feature activated, only
one group can be defined:
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– For customers who upgrade from a previous release of LSMS, all existing
DGTT and OGTT entries in the database are assigned to a group whose
name is default, that group name appears by default in every GTT Group
field, and every new DGTT or OGTT entry is assigned to that group.

– Customers who install LSMS for the first time must define one group, using
the window shown in Figure 2-4 and a name of their choice; that group name
appears by default in GTT Group fields used for other functions, and every
Default GTT and Override GTT entry created must be assigned to that
group.

Figure 2-4    Create GTT Group Window

• Customers who have the Enhanced LSMS Filters feature activated can define
additional groups:

– For customers who upgrade from a release previous to LSMS 5.0, all existing
DGTT and OGTT entries in the database are assigned to a group whose
name is default, additional groups may be defined, and every new DGTT
or OGTT entry must be assigned to one of the defined groups.

– If Release 6.5 or later is your first installation of LSMS, you must use the
window shown in Figure 2-4 to define at least one group, using name(s) of
your choice. Also, every Default GTT and Override GTT entry created must
be assigned to one of the defined groups.

After GTT groups have been created, the user must assign one (and only one) GTT
group for each EMS, using the EMS Routing window Figure 2-2. The LSMS then
forwards only DGTT and OGTT entries that belong to the specified group to that
EMS.
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LSMS to TekPath Audit
Data contained in the TekPath Route Director (TekPath) should be the same as the data
provisioned from the LSMS. If the LSMS and TekPath LNP databases become
unsynchronized, the LSMS LNP database is used as the master database to
synchronize the TekPath LNP database. The LSMS to TekPath audit can be used as a
general maintenance tool to help customers maintain the integrity of their databases.

The LSMS to TekPath audit supports range audits and complete data audits, and it
functions similarly to the LSMS to ELAP audit. However, the LSMS to TekPath audit
does not support default GTT or override GTT audits, because those audits are not
applicable to TekPath. The LSMS to TekPath audit compares data in the LSMS LNP
database to the TekPath LNP database. When the audit is complete, the LSMS
customer has the option to reconcile database discrepancies.

The LSMS Console window displays the type of network element, either ELAP or
TekPath, that has been configured in the EMS Status pane.

Figure 2-5    EMS Status Pane with Network Element Type Displayed
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Figure 2-6    Create LNP System EMS Window with TekPath Configuration Option

Using Login Sessions
Login sessions are used for the following user functions:

• To use the command line:

– To access the lsmsmgr text interface, which is used for configuring and
maintaining the LSMS system

– To enter LSMS commands (generally used for managing LSMS applications);
for more information, refer to the Alarms and Maintenance Guide.

• To use the graphical user interface (GUI), which is generally used for:

– Configuration (for more information, refer to the Configuration Guide)

– Database administration

– Synchronization of the LSMS LNP database with the LNP databases at
network elements (for more information, refer to the LNP Database
Synchronization User's Guide)

Support of Multiple Users

The LSMS allows, as a standard feature, a maximum of eight simultaneous users. The
Support for Additional Users optional feature enables you to have a maximum of 25
simultaneous users. A user is defined as:

• lsmsmgr user (a user who logs in as the lsmsmgr user to start the lsmsmgr text
interface)

Using Login Sessions
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• GUI user (a user who has logged into the active server GUI over the web)

Establishing Login Sessions

From any network-connected terminal, you can establish a variety of sessions with the
active server or with a specific server by:

• Displaying the lsmsmgr text interface of either the active server or of a specific
server

• Displaying the command line of either the active server or a specific server for
entering commands; see “Logging In to LSMS Server Command Line”.

• Displaying the GUI by using a web browser; see “Starting a Web-Based LSMS
GUI Session”

Logging In to LSMS Server Command Line

You can log into the LSMS active server or into a specific server from any terminal
that has a Secure Shell (ssh) client installed.

Note:   If your terminal does not already have ssh installed, PuTTY (Oracle
does not make any representations or warranties about this product) is an
open source ssh utility for Windows that you can download from the web.

You must have a user ID and password before you can log in to LSMS.

1. From a command line prompt on a Windows-based or Linux-based terminal, enter
the following command to start a secure shell session with the LSMS server:

ssh -X <username>@<server_IP_address>

For <username> and <server_IP_address>, specify values shown in Table 2-1
that are appropriate to the procedure you are performing:

Table 2-1    Parameters Used in Accessing Server Command Line

Parameter Value

<username>

Use one of the following:

• lsmsmgr to access the lsmsmgr text
interface for configuration, diagnostics,
and other maintenance functions

• syscheck to run the syscheck
command with no options, which
returns overall health checks and then
exits the login session (for more
information about the syscheck
command, refer to the Alarms and
Maintenance Guide)

• Other user names, as directed by a
procedure

Using Login Sessions

2-14  LSMS Database Administrator's Guide



Table 2-1    (Cont.) Parameters Used in Accessing Server Command Line

Parameter Value

<server_IP_address>

Use one of the following:

• Virtual IP (VIP) address to access the
LSMS Web GUI

• IP address of the specific server, when
directed by a procedure to access a
particular server

2. When prompted, enter the password associated with the user name.

3. You can now continue with any of the following functions:

• If you entered lsmsmgr as the username, the lsmsmgr text interface displays.

You can use any of the lsmsmgr functions, which are described in the Alarms
and Maintenance Guide.

Figure 2-7    lsmsmgr Text Interface Main Menu

Note:   Selections in the lsmsmgr text interface are made by either using the
Up and Down Arrow keys on your keyboard or typing the first letter of any
menu item to change which menu item is highlighted. When the desired menu
item is highlighted, press the Enter key.

In this manual, menu selections are indicated as a series; for example, select
Maintenance>Start Node indicates that you should highlight the Maintenance
item on the main menu, press Enter, then highlight the Start Node item on the
next menu, and press Enter.

• If you entered syscheck as the username, the command line window displays
the System Health Check output.

For more information about syscheck, refer to the Alarms and Maintenance
Guide.

• If you entered any other username the command line prompt displays a
prompt that shows the username and host name, similar to the following

Using Login Sessions
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example (in this example, the user logged in as the lsmsadm user to the server
whose host name is lsmspri):

[lsmsadm@lsmspri lsmsadm]$

Note:   In this manual, the prompt will be indicated simply by $.

LSMS commands can be entered at this prompt. If you need to start the LSMS
GUI, see “Starting a Web-Based LSMS GUI Session”.

Logging in from One Server to the Mate’s Command Line

Sometimes it may be necessary to have access to the command line interfaces for both
servers. You can log into each server separately using ssh, or you can use ssh to go
back and forth between servers.

To log in from one server’s command line to the mate server’s command line:

1. Log in as any user except lsmsmgr or syscheck, using the procedure described in 
“Logging In to LSMS Server Command Line” to log into a server command line.

2. Enter the following command to access the command line on the mate server:

$ ssh mate

If you have not previously logged into the mate, the following information
displays:

The authenticity of host 'mate (192.168.1.1)' can't be established.
RSA key fingerprint is 1c:14:0e:ea:13:c8:68:07:3d:7c:4d:71:b1:0c:33:04.
Are you sure you want to continue connecting (yes/no)?

Type yes, and press Enter.

3. When prompted, enter the password for the same user name.

4. The prompt on your terminal now displays the host name of the mate server, and
you can enter commands for the mate server.

Following is an example of the sequence of commands and prompts that display
during this procedure:

[lsmsadm@lsmspri lsmsadm]$ ssh mate
lsmsadm@mate's password:
[lsmsadm@lsmssec lsmsadm]$

Starting an LSMS GUI Session

The LSMS offers a web-based graphical user interface (GUI). The GUI can be run:

• On a PC with Microsoft® Windows installed, using Microsoft Internet Explorer
(version 8.0, 9.0, 10.0, or 11.0)

A 32-bit installation of Windows uses 32-bit Internet Explorer and 32-bit Java. A
64-bit installation of Windows includes both the 32-bit and 64-bit Internet
Explorer. If you are using the 32-bit Internet Explorer, 32-bit Java is required, and
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if you are using the 64-bit Internet Explorer, 64-bit Java is required. You can check
the Internet Explorer version by clicking on Tools > About Internet Explorer. If
64-bit Edition is displayed as shown in the following example, you are using
the 64-bit edition. If 64-bit Edition is not displayed, you are using the 32-bit
edition.

Figure 2-8    About Internet Explorer

• On a Linux workstation, using Mozilla Firefox

The GUI is accessible from any machine that can access the network on which the
LSMS resides.

Note:   When you have completed logging into the LSMS GUI, the session has
these operating characteristics:

• Pressing the Back button from the browser from which the GUI was
launched terminates that GUI session. To reopen the GUI, you must click
the Refresh button and begin the login process again.

• Pressing the Refresh button from the browser from which the GUI was
launched terminates that GUI session. To reopen the GUI, you must begin
the login process again.

• You cannot use a browser window that was started by selecting File >
New > Window from the browser window to launch another LSMS GUI
session.

• If the GUI is idle for an extended period, you may receive Server not
responding or Invalid Session ID errors; close the existing GUI
session and start a new GUI session.

The HTTPS support on LSMS feature allows you to configure the protocol(s) used for
the GUI:

Using Login Sessions

Database Administration Overview  2-17



• Secure Hypertext Transfer Protocol (HTTPS)

• Hypertext Transfer Protocol (HTTP)

• Both HTTPS and HTTP

Both HTTPS and HTTP are enabled by default. HTTPS supports encryption of data
exchanged between the web server and the browser, thus facilitating data privacy.
HTTP is not encrypted/secure, allowing data to be captured by any network analyzer
and viewed.

A script (/usr/TKLC/lsms/bin/httpConfig.pl) is provided to toggle between
protocols or to check what is currently enabled. The script can be run by the lsmsadm
user with one of the following parameters:

https
Results in HTTPS being enabled and HTTP being disabled.

http
Results in HTTP being enabled and HTTPS being disabled.

both
Results in both HTTPS and HTTP being enabled. This is the default.

status
Displays whether HTTPS and HTTP are enabled or disabled.

Note:    After changing the protocol, the GUI must be refreshed to reflect the
changes. A GUI notification will be displayed.

To start the GUI:

1. Start your web browser (Mozilla Firefox or Internet Explorer).

2. Specify https or http followed by the LSMS VIP address in the Address: field, or
the application VIP in a segmented network. For http, add :8200.

• https://<VIP_address>

• http://<VIP_address>:8200

The <VIP_address> is the Virtual IP address used by your LSMS system. (The
VIP address is always associated with the active server; when switchover occurs,
the VIP address association is switched over from previously active server to the
newly active server.)

3. Press Return and the Oracle Communications LSMS start page is displayed.
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Note:   If using HTTPS, you must click through some security warnings that
are displayed, which differ depending on the browser in use:

• For Internet Explorer, click on Continue to this website (not
recommended) on the following screen:

Figure 2-9    Problem with Security Certificate

• For Mozilla Firefox, click on I Understand the Risks on the
following screen:

Figure 2-10    Connection is Untrusted

Then click on Add Exception on the following screen:
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Figure 2-11    Connection is Untrusted (continued)

Then enter the site in the Location field and click on Confirm Security
Exception:
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Figure 2-12    Add Exception for Untrusted Connection

The Oracle Communications LSMS Start Page displays:
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Figure 2-13    Oracle Communications LSMS Start Page

4. If you are logging in for the first time from this terminal, click the Java Setup
button and follow the instructions on the displayed page to install a Java plug-in
and set up a security policy.

Otherwise, go to 5.

5. Open the Java Control Panel for your terminal, go to the Security tab as shown in 
Figure 2-14, and click on Edit Site List.

Note:   

• The actual screens displayed might differ from these examples depending
upon the specific Java version in use.

• If using both https and http, both must be added to the exception site list
(https://<VIP_address> and http://<VIP_address>:8200).
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Figure 2-14    Security Tab of Java Control Panel

6. After clicking on Edit Site List, click on Add:
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Figure 2-15    Adding to the Exception Site List

7. Type in the location of your LSMS server (https://IP_address or http://
IP_address:8200):

Figure 2-16    Adding the LSMS Server to the Exception Site List

8. Click OK.

The Security tab will now show the server in the Exception Site List, as shown in
the following example:
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Figure 2-17    Exception Site List Including the LSMS Server
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Note:   If you are adding an http site, a warning similar to the following
warning is displayed:

Figure 2-18    Security Warning for HTTP Location

Click Continue to add the server to the Exception Site List.

9. Click OK to exit the Java Control Panel and return to the GUI.

10. If using HTTPS and Internet Explorer, install the security certificate as follows.
Otherwise, go to step 11.

a. Back at the Oracle Communications LSMS Start Page, click on Certificate
error at the right of the address bar, and then click on View certificates
in the popup window titled Certificate Invalid.

Figure 2-19    Certificate Error

The Certificate screen is displayed:
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Figure 2-20    Certificate Screen

b. Click on Install Certificate.

The Certificate Import Wizard opens:
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Figure 2-21    Certificate Import Wizard

c. Click on Next >, and then select the radio button to Place all certificates in the
following store:
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Figure 2-22    Certificate Import Wizard (continued)

d. Click on Browse to go to the Select Certificate Store window, and select Trusted
Root Certification Authorities:
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Figure 2-23    Select Certificate Store

e. Click OK and NEXT, to verify the settings:
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Figure 2-24    Completing the Certificate Import Wizard

f. Click Finish, and then verify that you want to install the certificate:
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Figure 2-25    Certificate Installation Security Warning

g. Click Yes to import the certificate:

Figure 2-26    Certificate Import Successful

h. Click OK, and then OK again to exit the Certificate window.

i. Restart Internet Explorer.

11. Back at the Oracle Communications LSMS Start Page, click on the Web Interface
button.

Using Login Sessions

2-32  LSMS Database Administrator's Guide



Note:   If using HTTPS, click Yes and then Continue for the following security
warnings:

Figure 2-27    Insecure Content Warning

Figure 2-28    Untrusted Website Warning

12. Check the box to accept the risk to run the application, and click Run:
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Figure 2-29    Application Security Warning

The LSMS Web GUI Start Page displays:

Figure 2-30    LSMS Web GUI Start Page with Login Button
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13. Click the Login button.

The LSMS Login screen appears. Next, perform the procedure described in 
“Logging Into the LSMS Console Window”.

Note:   If you log out of this LSMS GUI session, you must start a new browser
to log back in. If you only want to change user, select User/Session>Change
User from the main LSMS menu.

Inactivity Timeout

The Automatic Inactivity Logout (inactivity timeout) feature, when activated, logs out
LSMS GUI and command line users after a preset period of inactivity occurs. For
more information, refer to the Configuration Guide.

Logging in to the LSMS Console Window

After one or more SPIDs have been defined, use the following procedure to log in to
the LSMS console.

1. After you have completed the procedure described in Starting an LSMS GUI
Session, the LSMS Welcome/Login Window displays.

2. Enter the Service Provider ID (SPID), username, and password, which must be as
follows:

a. The username and password must have been defined as described in the Alarms
and Maintenance Guide (the group definition determines to which GUI menu
items the username will have access).

b. The SPID must be one that has been defined on this LSMS, as described in
“Service Provider Contact Information” in the Configuration Guide.

In addition, if the SPID Security feature has been enabled, you must enter a
username that has been authorized to access the SPID you enter. For
information about authorizing usernames to SPIDs, refer to the Configuration
Guide.

3. Click Login.

• If the Customizable Login Message feature is not enabled (or it is enabled, but
no message text has been created), the LSMS Console Window displays.
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Figure 2-31    LSMS Console Window

• If the Customizable Login Message feature is enabled and there is user-defined
login message text configured, the Login Message dialog displays a login
message before the LSMS Console Window is displayed.

System administrators are responsible for creating the customizable login
message text (for information about how to create this message text, refer to
the Configuration Guide). Oracle Customer Service is responsible for enabling
the feature.

The Login Message dialog displays a 10 line by 80 character viewing area, with
a scrollable text area up to a maximum of 5000 characters. Users must
acknowledge this message by clicking the OK button.

Modifying Title Bar in LSMS Console Window
After you successfully log in to LSMS, the console window displays. If the /usr/
TKLC/lsms/config/LSMSname file exists and contains a (0–30 character) unique
LSMS name, the name is displayed in the title bar along with the SPID and user
name. If the file does not exist or is empty (null), no name will be displayed and the
title bar will look as before—displaying only the SPID and user name.

Navigating the GUI
To navigate through the GUI, select your menu choices by using the mouse pointer.

The main user interface of the GUI is the LSMS Console Window. The principle
components of this window are described in the following paragraphs.

Note:   The release versions of the LSMS software that appear in some of the
GUI window illustrations of this manual are representational only and may
not correspond to this manual’s actual release. The release version identified
at the top of an actual GUI session window indicates the LSMS software
version currently in operation.
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Note:   When you pause or stop the mouse over a data entry field or a status
icon, the LSMS GUI displays a tool tip that explains how to use the field. 
Figure 2-32 shows an example of an LSMS tool tip.

Figure 2-32    Example Tool Tip

• Main Menu Bar – This component contains the main GUI menu items. Refer to 
Figure 2-35 to see which items are accessible from the main menu bar.

• Pull-Down Menus – These menus appear when a main menu item is selected.

• NPAC Status Area (General Description) – This area displays the state of the
association between each of the NPAC regions and the LSMS (see Figure 2-31).

Note:   The active NPAC regions only are shown when you initially display the
LSMSGUI.

Each of the eight NPAC regions that can be supported by the LSMS is represented
by a status icon in the NPAC status area. If support for a given region has not been
purchased, the icon for that region either displays with white color and the text
Inactive or is hidden (see Displaying Icons for Inactive NPACs.

Each icon contains:

– Regional name

– A database symbol displaying one of the following colors to indicate the
status of the association with the NPAC:

‐ Green—The NPAC agent is associated with either the primary or
secondary NPAC

‐ Red—The NPAC agent is not associated with either the primary or
secondary NPAC

‐ White—The NPAC region has not been activated

– One of the following text strings to clarify further the status of the association:

‐ Primary—The LSMS is connected to the primary NPAC (icon is green)

‐ Secondary—The LSMS is connected to the secondary NPAC (icon is
green)

‐ Not Connected—The LSMS is not connected to the NPAC (icon is red)

‐ No Agent—The NPAC agent for this region is not running (icon is red)

‐ Inactive—The region is not activated (icon is white)
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Displaying Icons for Inactive NPACs
When the LSMS GUI is first opened, only icons for active NPAC regions display.
Icons for inactive regions can be displayed or hidden by right-clicking anywhere in the
NPAC status area where there is no NPAC region icon.

The pop-up menu shown in Figure 2-33 displays, listing all the inactive regions. If the
checkbox next to the region name is checked, the corresponding inactive NPAC region
icon is currently displayed in the NPAC status area; if it is not checked, the
corresponding NPAC region icon is hidden.

Figure 2-33    Inactive NPAC Regions Pop-up Menu

NPAC Status Icon Pop-up Menus
NPAC status pop-up menu items can be accessed by clicking on any NPAC region
icon (except inactive ones) to highlight it and then right-clicking on the icon.
Depending on the state of the association with the NPAC, some menu items may be
nonselectable (grayed-out), as described in Table 2-2.

Figure 2-34    NPAC Pop-up Menu

Table 2-2    NPAC Icon Pop-up Menu Selectability

Menu Item Selectable:

Logs Always

Associate Only when the NPAC icon text shows Not
Connected

Abort Only when the NPAC icon text shows
Primary or Secondary

EMS Status Area (General Description)
The EMS status area displays the state of the connection between the LSMS and each
Element Management System (EMS) that is configured on the LSMS. If more than
eight EMSs are configured, the EMS status area contains two rows for icons.
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• Each EMS status icon displays the following:

– Text to indicate the COMMON LANGUAGE® Location Identifier (CLLI™)
code of the EMS

– Signal Transfer Point (STP) element symbol displaying one of the following
colors to indicate the status of the association with the EMS:

‐ Green—The LSMS is connected to both EMSs that have this CLLI code

‐ Yellow—The LSMS is connected to a single EMS that has this CLLI code

‐ Red—The LSMS is not connected to either EMS that has this CLLI code

– Text to indicate the CLLI code of the EMS

EMS Status Icon Pop-up Menus
Menu items can be accessed by clicking on any EMS status icon to highlight it and
then right-clicking on the icon.

Note:   All actions you perform using the popup menu are applied to the EMS
you select.

Notification Area
The notification area is similar to the notification area available in previous releases,
except for the following:

The notification area is now displayed in table form, with headings marking the
following fields of the notification:

• Severity of the event, which can be one of the following (the severity is also
indicated by use of color as indicated):

– CLEARED (Green)

– CRITICAL (Red)

– MAJOR (Yellow)

– EVENT (White)

• Time stamp for the time that the event was generated

• Event number (some notifications do not contain an entry for this field)

• System that generated the error, as follows:

– For EMS notifications, the CLLI code

– For NPAC notifications, the affected region

– For all other types of notifications, “LSMS”

• Message text description of the error
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Note:   Notification Area messages cannot be deleted from a GUI session.

Field Syntax for the LSMS GUI
The LSMSGUI includes several different types of data fields. Table 2-3 lists the
characters allowed in each type of LSMS GUI field.

Table 2-3    Characters Allowed by LSMS GUI Field Types

Type of Field Valid Characters

numeric 0 through 9

lowercase a through z

uppercase A through Z

punctuation ~!@#$%^&*()_+{}|[]\-=‘;’´:”,./<>?

file characters -,.

letter characters lowercase and uppercase

alphanumeric letter and numeric

character letter, numeric, and punctuation

filename alphanumeric and file characters

GUI Structure
The GUI windows are structured as shown in Figure 2-35. To follow the flow, start at
LSMS Login.

Note:   The Admin, Configure, and Keys menu items are not shown in 
Figure 2-35; for information about access to those menus, refer to the
Configuration Guide.
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Figure 2-35    LSMS GUI Structure

GUI Function Access
Access to the various LSMS GUI functions is determined by the permission group
assigned by the system administrator. For more information, refer to Configuration
Guide and Alarms and Maintenance Guide.

The following tables show the functions each permission group can access.
Inaccessible functions are deselected (grayed-out) on the actual menus.
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Note:   For information about the Admin, Configure, and Keys LSMS menu
items, refer to Configuration Guide.

Table 2-4    User/Session GUI Access by Permission Group

User/Session
GUI

Functions

User/Session GUI Access by Permission Group
X = This GUI function is accessible to the indicated permission group.

Default Permission Groups

lsmsadm lsmsuser lsmsview lsmsall lsmsuext

Web GUI
Welcome

X X X X X

LSMS Login X X X X X

LSMS
Console
Main Menu

X X X X X

User/Session X X X X X

Change User X X X X X

Change
Service

Provider ID

X X X X X

View Active
User Sessions

X X

Terminate
User Session

X X

Preferences X X X X X

Show Tool
Tips

X X X X X

Exit/Logout X X X X X

Table 2-5    NPAC GUI Access by Permission Group

NPAC GUI
Functions

NPAC GUI Access by Permission Group
X = This GUI function is accessible to the indicated permission group.

Default Permission Groups

lsmsadm lsmsuser lsmsview lsmsall lsmsuext

NPAC X X X X

Resync
NPAC Data

X X
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Table 2-5    (Cont.) NPAC GUI Access by Permission Group

NPAC GUI
Functions

NPAC GUI Access by Permission Group
X = This GUI function is accessible to the indicated permission group.

Default Permission Groups

lsmsadm lsmsuser lsmsview lsmsall lsmsuext

Service
Provider

Network

X X X X

View X X X X

Service
Provider
LRN

X X X X

Create X X

View X X X X

Delete X X

Service
Provider
NPA-NXX

X X X X

Create X X

View X X X X

Delete X X

Table 2-6    LSMS GUI Access by Permission Group

LSMS GUI
Functions

LSMS GUI Access by Permission Group
X = This GUI function is accessible to the indicated permission group.

Default Permission Groups

lsmsadm lsmsuser lsmsview lsmsall lsmsuext

LSMS X X X X X

EMS Routing X X X X X

Modify X X X

View X X X X X

TN Filter X X X X X

Create X X X

Modify X X X
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Table 2-6    (Cont.) LSMS GUI Access by Permission Group

LSMS GUI
Functions

LSMS GUI Access by Permission Group
X = This GUI function is accessible to the indicated permission group.

Default Permission Groups

lsmsadm lsmsuser lsmsview lsmsall lsmsuext

View X X X X X

Delete X X X

GTT Group 1 X X X X X

Create X X

Modify X X

View X X X X X

Delete X X

Default GTT X X X X

Create X X X

Modify X X X

View X X X X

Delete X X X

Override
GTT

X X X X

Create X X X

Modify X X X

View X X X X

Delete X X X

TN/NPB
Query

X X X X X

NPA Split 2 X X X X X

Input Data
By File

X X X 3

LNP
Database

Synchronizat
ion 4

X X X X X

Audit X X X X X
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Table 2-6    (Cont.) LSMS GUI Access by Permission Group

LSMS GUI
Functions

LSMS GUI Access by Permission Group
X = This GUI function is accessible to the indicated permission group.

Default Permission Groups

lsmsadm lsmsuser lsmsview lsmsall lsmsuext

Resync X X X

Bulkload X X X

1 Users belonging to the “lsmsuext” permission group are only authorized to access Default
TT/SSN values for GTT groups assigned to the login SPID.
2 Users belonging to the “lsmsuser” or “lsmsall” permission groups are authorized to create,
modify, view, and delete NPA Splits. Users belonging to the “lsmsadm”, “lsmsview”, and
“lsmsuext” permission groups are authorized only to view NPA Split information.
3 Users belonging to the “lsmsuext” group are authorized to use the Input by File operation
for downloading all data types except for NPA Splits.
4 LNP database synchronization can be performed only for EMSs in which the login user and
SPID are authorized.

Table 2-7    Reports GUI Access by Permission Group

Reports GUI
Functions

Reports GUI Access by Permission Group
X = This GUI function is accessible to the indicated permission group.

Default Permission Groups

lsmsadm lsmsuser lsmsview lsmsall lsmsuext

Reports 1 X X X X X

Service
Provider
Administrati
ve Data

X X X X X

Service
Provider
Network
Data

X X X X X

EMS

Configuratio
n Data

X X X X X

Default GTT
Data

X X X X X

Override
GTT Data

X X X X X
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Table 2-7    (Cont.) Reports GUI Access by Permission Group

Reports GUI
Functions

Reports GUI Access by Permission Group
X = This GUI function is accessible to the indicated permission group.

Default Permission Groups

lsmsadm lsmsuser lsmsview lsmsall lsmsuext

NPA Split
Data

X X X X X

LSMS

Subscriptions
by LRN Data

X X X X X

LSMS
Subscriptions
by Service
Provider
Data

X X X X X

LSMS
Number Pool
Blocks by
LRN Data

X X X X X

LSMS
Number Pool
Blocks by
Service

Provider
Data

X X X X X

Service
Provider
Data

X X X X X

Permission
Group Data

X X X X X

1 Generated reports and logs only contain data that the login SPID has authorization to
access. The permissions associated with Reports also apply to the Reports command of the
LSMS Report Generation Feature.

Note:   

Only the permission group that created a report has the ability to view that
report from the Reports menu. This is the permission group that has logged
onto the command line, not the permission group logged into the GUI.
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Table 2-8    Logs GUI Access by Permission Group

LOGS GUI
Functions

Logs GUI Access by Permission Group
X = This GUI function is accessible to the indicated permission group.

Default Permission Groups

lsmsadm lsmsuser lsmsview lsmsall lsmsuext

Logs1 X X X X X

Security X X

NPAC
Transactions

X X X X X

Local Data
Transactions

X X X X X

NPA Split X X X X X

Activity X X X X X

Alarm X X X X X

CMIP X X X X X

Event X X X X X

Trace X X X X X

Other X X X X X

1 Generated reports and logs only contain data that the login SPID has authorization to
access. The permissions associated with Reports also apply to the Reports command of the
LSMS Report Generation Feature.

Table 2-9    Popup Menus GUI Access by Permission Group

Popup
Menus GUI
Functions

Popup Menus GUI Access by Permission Group
X = This GUI function is accessible to the indicated permission group.

Default Permission Groups

lsmsadm lsmsuser lsmsview lsmsall lsmsuext

NPAC Status
Popup Menu

X X X X X

Associate X X

Abort X X

Logs1 X X X X X

Activity X X X X X

CMIP X X X X X

GUI Function Access

Database Administration Overview  2-47



Table 2-9    (Cont.) Popup Menus GUI Access by Permission Group

Popup
Menus GUI
Functions

Popup Menus GUI Access by Permission Group
X = This GUI function is accessible to the indicated permission group.

Default Permission Groups

lsmsadm lsmsuser lsmsview lsmsall lsmsuext

Event X X X X X

Transactions X X X X X

Measuremen
t Logs

X X X X X

Show NPAC
Regions
Menu

X X X X X

EMS Status
Popup Menu

X X X X X

EMS Routing X X X X X

Modify X X X

View X X X X X

LNP
Database
Synchronizat
ion 2

X X X X X

Audit3 X X X X X

Resync X X X

Bulkload X X X

Logs X X X X X

Transactions X X X X X

Rejected
Transactions

X X X X X

LNP
Database

Synchronizat
ion

X X X X X

Measuremen
t Logs

X X X X X
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Table 2-9    (Cont.) Popup Menus GUI Access by Permission Group

Popup
Menus GUI
Functions

Popup Menus GUI Access by Permission Group
X = This GUI function is accessible to the indicated permission group.

Default Permission Groups

lsmsadm lsmsuser lsmsview lsmsall lsmsuext

LSMS Query
Language
(LQL)

X X X X X

1 Generated reports and logs only contain data that the login SPID has authorization to
access. The permissions associated with Reports also apply to the Reports command of the
LSMS Report Generation Feature.
2 LNP database synchronization can only be performed for EMSs in which the login user and
SPID is authorized.
3 Users belonging to the "lsmsuser", "lsmsall", and "lsmsuext" permission groups are
authorized to audit and reconcile discrepancies found by the audit. Users belonging to the
"lsmsadm" and "lsmsview" permission groups are authorized only to perform an audit.

GUI Button Functionality

The OK, Apply and Cancel buttons have specific GUI functions that are as follows:

• When there is a change in the data and OK is clicked:

– GUI updates the value in the database

– GUI displays a message that the update is successful

– GUI closes the Menu/Window

• When there is no change in the existing data and OK is clicked:

– GUI returns an error that there is nothing to update

– GUI does not close the Menu/Window

• When there is no data entered and OK is clicked the GUI returns an error.

• When there is a change in the data and Apply is clicked:

– GUI updates the value in the database

– GUI displays a message that the update is successful

– GUI does not close the Menu/Window

• When there is no change in the existing data and Apply is clicked:

– GUI returns an error that there is nothing to update

– GUI does not close the Menu/Window

• If Cancel is clicked the open Menu/Window is closed.
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Data Entry Dialogs
The following action buttons are included at the bottom of most data entry screens:

• OK - Enables you to perform the indicated operation and automatically close the
dialog. If a data entry error is encountered, the dialog remains open.

• Apply - Enables you to perform the indicated operation but the dialog remains
open, allowing you to perform additional operations.

• Cancel - Enables you to cancel this operation. Any changes made to the data fields
since the last "Apply" action (or since the screen was created, if no "Apply" action
was performed) are discarded.

User/Session Menu
The User/Session menu item contains:

Figure 2-36    LSMS User/Session Menu

• Change User - Selecting this option enables you to exit the LSMS GUI, and
displays the login screen again.

A confirmation dialog displays before you exit, enabling you to return to the GUI
without exiting.

• Change Service Provider ID - Selecting this option prompts you for a new service
provider ID.

An authorization check is automatically performed before switching you to the
newly requested service provider ID.

• Preferences - Selecting this option enables you to enable or disable the tool tips,
which provide interactive help, by checking or unchecking the Show ToolTips
checkbox. Preferences are not maintained between login sessions.

Figure 2-37    Preferences Menu Item

• Exit/Logout - Selecting this option enables you to exit the LSMS GUI. A
confirmation dialog displays before you exit, enabling you to return to the GUI
without exiting.

Logging Out of the LSMS GUI

To log out of the LSMS GUI:

Data Entry Dialogs

2-50  LSMS Database Administrator's Guide



1. Select Exit/Logout from the User/Session pull-down menu on the LSMS Console
window.

The Console Logout window displays.

2. Click OK to log out or Cancel to return to the LSMS Console window.

User/Session Menu
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3
Managing NPAC Relations

This chapter discusses the data that the LSMS and Number Portability Administration
Center (NPAC) have in common.

Resynchronizing LSMS and NPAC Data
This chapter discusses data that the LSMS and NPAC have in common.

Figure 3-1    LSMS NPAC Menu

The LSMS database continually receives realtime updates from the regional NPAC
databases. If the network connection between the LSMS and the associated NPAC is
broken for a brief period of time, the LSMS initiates an automatic reconciliation
procedure to make sure that its subscription and network information are current. For
more information, refer to the Alarms and Maintenance Guide.

Perform these tasks by using the procedures described in the following sections to
verify that the LSMS and the NPAC are using the same data:

• Resynchronize an individual TN

• Resynchronize a range of TNs

• Resynchronize for a defined period of time

Note:   Resynchronization for a defined period of time will not resynchronize
data for TNs that were modified after the defined period of time. A
resynchronization for a time period that ends with the present time, or an
import of a full bulk data download, may be necessary to acquire all data.

• Resynchronize an individual NPB

• Resynchronize a range of NPBs

You can complete each task using the LSMS GUI as described in the following
sections.
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Resynchronizing an Individual TN Using the GUI

To download subscription information from the NPAC relating to an individual TN
using the GUI:

1. Log in to LSMS as a member of the permission group that is authorized to perform
this operation.

2. From the LSMS Console window, select NPAC > Resync NPAC Data.

The Manual NPAC Resync – Individual TN window displays.

3. Select the desired NPAC region from the pull-down menu.

Figure 3-2    NPAC Region Pull-Down Menu

4. Enter the TN (ten numeric characters only required; no spaces, hyphens, or
underscores).

5. When the above information is complete, click OK or Apply to start the
resynchronization.

Resynchronizing a Range of TNs Using the GUI

To download subscription information from the NPAC relating to a range of TNs
using the GUI:

1. Log in to LSMS as a member of the permission group that is authorized to perform
this operation.

Resynchronizing LSMS and NPAC Data
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2. From the LSMS Console window, select NPAC > Resync NPAC Data.

The Manual NPAC Resync – Individual TN window displays.

3. Select the TN Range tab at the top of the window.

The Manual NPAC Resync – Range TN window displays.

Figure 3-3    Manual NPAC Resync – Range of TNs Window

4. Select the desired NPAC region from the pull-down menu.

5. Enter the starting TN (lowest numeric value, ten numeric characters only required;
no spaces, hyphens, or underscores).

This includes the NPA (area code), NXX (exchange code), and the remaining four
digits of the TN.

6. Enter the last four digits of the ending TN (highest numeric value).

The NPA and NXX of this TN are the same as those of the starting TN.

7. When the above information is complete, click OK or Apply to start the
resynchronization.

Resynchronizing for a Defined Period of Time Using the GUI

To download subscription information and network data from the NPAC for a defined
period of time using the GUI:

Resynchronizing LSMS and NPAC Data
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Note:   Time Stamp values are entered in local time. LSMS automatically
converts local time to Z (Zulu), which is also called GMT (Greenwich Mean
Time). For more information, see Appendix A, "Local Time Calculation and
World Time Zone Data."

Note:   Resynchronization for a defined period of time will not resynchronize
data for TNs that were modified after the defined period of time. A
resynchronization for a time period that ends with the present time, or an
import of a full bulk data download, may be necessary to acquire all data.

1. Log in to LSMS as a member of the permission group that is authorized to perform
this operation.

2. From the LSMS Console window, select NPAC > Resync NPAC Data.

The Manual NPAC Resync – Individual TN window displays.

3. Select the Time Range tab at the top of the window.

The Manual NPAC Resync – Time Range window displays.

4. Select the desired NPAC region from the pull-down menu.

5. Specify the Beginning Date and Time by placing the cursor on the desired field
and then clicking the up or down scroll buttons until the desired value displays in
the listbox.

Field entries have the following parameters:

• Month – Maximum two numeric characters (1–12 only)

• Day – Maximum two numeric characters (1–31 only)

• Year – Exactly two numeric characters

• Hour – Maximum two numeric characters (1-12 only)

• Minute – Exactly two numeric characters (0–59 only)

• Second – Exactly two numeric characters (0–59 only)

• AM or PM – Exactly two alphabetic characters

6. Specify the Ending Date and Time by placing the cursor on the desired field and
then clicking the up or down scroll buttons until the desired value displays in the
listbox.

The field entries have the same parameters as those listed in 

7. Select one or both of the following fields:

• Download Subscription Data – Select this field to resynchronize the TN records
with the NPAC.

• Download Network Data – Select this field to resynchronize the LRN and NPA-
NXX records with the NPAC.

Resynchronizing LSMS and NPAC Data
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8. When the preceding information is complete, click OK or Apply to start the
resynchronization.

Resynchronizing an Individual NPB Using the GUI

To download subscription information from the NPAC relating to an individual NPB
using the GUI:

1. Log in to LSMS as a member of the permission group that is authorized to perform
this operation.

2. From the LSMS Console window, select NPAC > Resync NPAC Data.

The Manual NPAC Resync window displays.

Figure 3-4    Manual NPAC Resync Window

3. Select the Individual NPB tab from the top of the Manual NPAC Resync window.

4. Select the desired NPAC region from the pull-down menu.

Resynchronizing LSMS and NPAC Data
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Figure 3-5    NPAC Region Pull-Down Menu

5. Enter the NPB (exactly seven numeric characters required; no spaces, hyphens, or
underscores).

6. When the above information is complete, click OK or Apply to start the
resynchronization.

Resynchronizing a Range of NPBs Using the GUI

To download subscription information from the NPAC relating to a range of NPBs
using the GUI:

1. Log in to LSMS as a member of the permission group that is authorized to perform
this operation.

2. From the LSMS Console window, select NPAC > Resync NPAC Data.

The Manual NPAC Resync window displays.

3. Select the NPB Range tab at the top of the window.

The Manual NPAC Resync – NPB Range window displays.

Resynchronizing LSMS and NPAC Data
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Figure 3-6    Manual NPAC Resync – Range of NPBs Window

4. Select the desired NPAC region from the pull-down menu.

5. Enter the starting NPB (lowest numeric value, exactly seven numeric characters
required; no spaces, hyphens, or underscores).

This includes the NPA (area code), NXX (exchange code), and X (the first digit of
the TN).

6. Enter the ending NPB (highest numeric value, exactly four numeric characters
required; no spaces, hyphens, or underscores).

This includes the NXX (exchange code) and X (the first digit of the TN). The NPA
of the ending NPB is the same as the starting NPB.

7. When the above information is complete, click OK or Apply to start the
resynchronization.

Viewing an NPAC Service Provider Network
To view information about the service provider network:

1. Log in to LSMS as a member of the permission group that is authorized to perform
this operation.

2. From the LSMS Console window, select NPAC > Service Provider Network >
View.

The View Service Provider Network window displays.

Viewing an NPAC Service Provider Network

Managing NPAC Relations  3-7



Figure 3-7    View Service Provider Network Window

3. Select the desired NPAC region from the pull-down menu.

4. Enter the Service Provider ID (maximum four alphanumeric characters).

5. Click Apply.

The Network Name information is returned in the Network Name field.

Managing NPAC Service Provider Local Routing Number (LRN)
The following procedures explain how to add, view, and delete an NPAC Service
Provider LRN.

Adding an NPAC Service Provider LRN

To send a request to the NPAC to add an NPAC service provider LRN:

1. Log in to LSMS as a member of the permission group that is authorized to perform
this operation.

2. From the LSMS Console window, select NPAC > Service Provider LRN > Create.

The Create Service Provider LRN window displays.

Managing NPAC Service Provider Local Routing Number (LRN)
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Figure 3-8    Create Service Provider LRN Window

3. Select the desired NPAC region from the pull-down menu.

4. Enter the Service Provider ID (maximum four alphanumeric characters).

5. Enter the LRN value (ten numeric characters required).

6. Click OK or Apply.

This sends a Create request to the NPAC. The NPAC sends the Create later if it
determines it is valid. The Creation of ServiceProvLRN Successful message
displays.

7. Click OK at the bottom of the message window.

Viewing an NPAC Service Provider LRN

To view an NPAC service provider LRN:

1. Log in to LSMS as a member of the permission group that is authorized to perform
this operation.

2. From the LSMS Console window, select NPAC > Service Provider LRN > View.

The View Service Provider LRN window appears.

Managing NPAC Service Provider Local Routing Number (LRN)
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Figure 3-9    View Service Provider LRN Window

3. Select the desired NPAC region from the pull-down menu.

4. Optionally, enter the Service Provider ID (maximum four alphanumeric
characters).

5. Enter the LRN value (ten numeric characters required).

6. Click Apply. The Download Reason and Creation Time Stamp information
appears.

Note:   Time Stamp values are entered in local time. LSMS automatically
converts local time to Z (Zulu), which is also called GMT (Greenwich Mean
Time). For more information, see Appendix A, "Local Time Calculation and
World Time Zone Data."

• The Download Reason describes the reason that the LRN was last modified.
The reason codes are:

0 = new
1 = delete
2 = modify
3 = audit discrepancy

• The Creation Time Stamp is the date and time that the LRN was created.

Deleting an NPAC Service Provider LRN

To send a request to the NPAC to delete an NPAC service provider LRN:

1. Log in to LSMS as a member of the permission group that is authorized to perform
this operation.

2. From the LSMS Console window, select NPAC > Service Provider LRN > Delete.

Managing NPAC Service Provider Local Routing Number (LRN)
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The Delete Service Provider LRN window appears.

3. Select the desired NPAC region from the pull-down menu.

4. Enter the Service Provider ID (maximum four alphanumeric characters).

5. Enter the LRN value (ten numeric characters required).

6. Click OK orApply to delete.

The Deletion of ServiceProvLRN Successful window appears.

7. Click OK at the bottom of the message window.

Managing NPAC Service Provider NPA-NXX
The following procedures explain how to add, view, and delete an NPAC Service
Provider NPA-NXX.

Adding an NPAC Service Provider NPA-NXX

To send a request to the NPAC to add a service provider NPA-NXX:

1. Log in to LSMS as a member of the permission group that is authorized to perform
this operation.

2. From the LSMS Console window, select NPAC > Service Provider NPA-NXX >
Create.

The Create Service Provider NPA-NXX window appears.

Figure 3-10    Create Service Provider NPA-NXX Window

3. Select the desired NPAC region from the pull-down menu.

4. Enter the Service Provider ID (maximum four alphanumeric characters).

5. Enter the NPA-NXX value (six numeric characters required; no spaces, hyphens, or
underscores).

Managing NPAC Service Provider NPA-NXX
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6. Specify the Effective Time Stamp by placing the cursor on the desired field and
then clicking the up or down scroll buttons until the desired value displays in the
listbox.

Field entries have the following parameters:

• Month – Maximum two numeric characters (1–12 only)

• Day – Maximum two numeric characters (1–31 only)\

• Year – Exactly two numeric characters

• Hour – Maximum two numeric characters (1-12 only)

• Minute – Exactly two numeric characters (0–59 only)

• Second – Exactly two numeric characters (0–59 only)

• AM or PM – Exactly two alphabetic characters

Note:   Time Stamp values are entered in local time. LSMS automatically
converts local time to Z (Zulu), which is also called GMT (Greenwich Mean
Time). For more information, see Appendix A, "Local Time Calculation and
World Time Zone Data."

7. Click OK or Apply.

The Creation of ServiceProvNPA-NXX Successful window appears.

8. Click OK at the bottom of the message window.

Viewing an NPAC Service Provider NPA-NXX

To view a service provider NPA-NXX:

1. Log in to LSMS as a member of the permission group that is authorized to perform
this operation.

2. From the LSMS Console window, select NPAC > Service Provider NPA-NXX >
View.

The View Service Provider NPA-NXX window appears.

Managing NPAC Service Provider NPA-NXX
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Figure 3-11    View Service Provider NPA-NXX Window

3. Select the desired NPAC region from the pull-down menu.

4. Optionally, enter the Service Provider ID (maximum four alphanumeric
characters).

5. Enter the NPA-NXX value (six numeric characters required; no spaces, hyphens, or
underscores).

6. Click Apply when the information is complete.

The Download Reason, Creation Time Stamp, and Effective time Stamp
information is returned to the window.

• The Download Reason box describes the reason that the NPA-NXX was last
modified.

The reason codes are:

0 = new
1 = delete
2 = modify
3 = audit discrepancy

• The Creation Time Stamp is the date and time that the NPA-NXX was created.

• The Effective Time Stamp is the date and time that the last modification took
effect.

7. After viewing the information, click Cancel.

Deleting an NPAC Service Provider NPA-NXX

To send a request to the NPAC to delete a service provider NPA-NXX:

Managing NPAC Service Provider NPA-NXX
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1. Log in to LSMS as a member of the permission group that is authorized to perform
this operation.

2. From the LSMS Console window, select NPAC > Service Provider NPA-NXX >
Delete.

The Delete ServiceProvider NPA-NXX window appears.

3. Select the desired NPAC Region from the pull-down menu.

4. Enter the Service Provider ID (maximum four alphanumeric characters).

5. Enter the NPA-NXX value (six numeric characters required; no spaces, hyphens, or
underscores).

6. Click OK or Apply to delete.

The Deletion of ServiceProvNPANXX Successful message window displays.

7. Click OK.

Managing NPAC Service Provider NPA-NXX

3-14  LSMS Database Administrator's Guide



4
Managing Locally Provisioned Data

This chapter contains information about Element Management System (EMS) routing,
custom TN filters, GTT groups, default and override global title translation (GTT),
Numbering Plan Area (NPA) Splits, and input data by file.

Introduction
This chapter provides detailed information about EMS routing, TN filters, GTT
groups, default and override GTTs, NPA splits, input data by file, and error codes.
(For information about LSMS database synchronization, refer to the LNP Database
Synchronization User's Guide.)

Entering Locally Provisioned Data on a Shadow LSMS
When you log in to manually enter any locally provisioned data, always use the same
service provider ID (SPID) at both the main LSMS and shadow LSMS.

Note:   Locally provisioned data is correlated with an SPID. For the data to be
the same at the main LSMS and shadow LSMS, it must be entered with the
same SPID at both.

Figure 4-1    LSMS Menu

EMS Routing
EMS routing information enables the LSMS to send subscription information to the
proper network elements. The EMS routing function allows you to modify or view the
routing info that you defined using the TN Filters and GTT Groups (see Managing
Locally Provisioned Data).
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Modify EMS Routing

To modify the TN filters and GTT group assignments for the selected EMS (you can
change the EMS being modified by selecting a new value from the EMS combo box):

Note:   After you update the TN filter, run an audit for the EMSs utilizing that
TN filter. Use the NE Audit with Reconcile procedure (refer to the LNP
Database Synchronization User's Guide) for each NPA-NXX added or changed
and on each affected EMS to update the databases.

However, depending on the number of NPA-NXXs, the number of EMSs
affected, and the physical distance between the LSMS and the network
element, a bulk download to each affected EMS/network element may be
more efficient. For more information, refer to the LNP Database Synchronization
User's Guide.

1. Log in to LSMS as a member of the permission group that is authorized to perform
this operation (see Database Administration Overview for descriptions of these
user access groups).

2. From the LSMS Console window, select LSMS > EMS Routing > Modify.

The Modify EMS Routing window appears.

Figure 4-2    Modify EMS Routing

EMS Routing
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The NPAC Region(s) list contains the eight predefined NPAC region filters. The
Custom Filter list contains all custom TN filters that have been created and named.

3. Apply TN Filters - Choose one, but not both, of the following:

• Regional Filters - When you select the NPAC Region(s) radio button, the EMS
accepts only the TNs from the selected region(s).

• Custom Filter - When you select the Custom Filter radio button, EMS accepts
only the TNs as defined by the selected custom TN filter.

Note:   To modify, view, or delete a custom filter, select the custom filter and
then right-click it. A popup menu displays. You can create a new custom filter
by clicking the Create button. Newly created TN filters are immediately added
to the Custom Filter list.

4. Apply GTT groups, if desired - Default and override GTT translations are
determined by the set of all override and default GTT records belonging to this
GTT group.

Note:   All named GTT groups are displayed in the GTT Groups panel. You
may assign a single group to the selected EMS by clicking on it to select it. You
can view a GTT group by selecting it, and then right-clicking it. A popup
menu displays. Upon selection of a group, the View GTT Group.

Figure 4-3    View GTT Group

5. Click OK .

View EMS Routing

To view the TN filters and GTT group assignments for the selected EMS (you can
change the EMS being viewed by selecting a new value from the EMS combo box):

EMS Routing
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1. Log in to LSMS as a member of the permission group that is authorized to perform
this operation (see Database Administration Overview for descriptions of these
user access groups).

2. From the LSMS Console window, select LSMS > EMS Routing > View.

The View EMS Routing dialog appears.

3. Click OK.

Custom TN Filters
You can specify one or more Custom TN filters and then associate the Custom TN
filter with one or more EMSs.

Note:   After you update the TN filter, run an audit for the EMSs that utilize
the TN filter. To update the databases, use the NE Audit with Reconcile
procedure for each NPA-NXX added or changed, as well as on each affected
EMS. However, depending on the number of NPA-NXXs, the number of EMSs
affected, and the physical distance between the LSMS and the network
element, a bulk download to each affected EMS/network element may be
more efficient. For more information, refer to the LNP Database Synchronization
User's Guide.

Custom TN Filter Attributes

Each Custom TN filter:

• Has a unique name.

• Contains one or more NPAs and/or one or more ranges of non-overlapping NPA-
NXXs.

• Is one of the following types:

– Inclusion filter—all NPA-NXXs that belong to the NPAs or to the NPA-NXX
ranges specified in the filter are sent to the EMSs with which this filter is
associated.

– Exclusion filter—all NPA-NXXs except those belonging to the NPAs or to the
NPA-NXX ranges specified in the filter are sent to the EMSs with which this
filter is associated.

Custom TN Filters
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Figure 4-4    Create Custom Custom TN Filter

Create Custom TN Filters Dialog Overview
The Creat Custom TN Filter dialog is used to manage custom filters.

To include the NPA(s) and NPA-NXX(s) in the list of TNs processed by the selected
EMS, click the Include radio button. To exclude the NPA(s) and NPA-NXX(s) from the
list of TNs processed by the selected EMS, click the Exclude radio button. A TN filter
can only include or exclude (not both) the NPA(s) and NPA-NXX(s) from the list of
TNs processed by the selected EMS.

You may specify a single NPA or NPA-NXX or a range of NPA-NXXs within a single
NPA to add to the filter. To add an NPA to the filter, click the NPA radio button, enter
an NPA in the text field, and click the Add button. To add an NPA-NXX to the filter,
click the NPA-NXX radio button, enter an NPA and NXX in the text fields, and click
the Add button.

Optionally, you may specify an ending NXX value; all NPA-NXXs between the start
NXX and end NXX are added to the filter. To remove a filter, click on an item in the list
(to select it) and click the Remove button.

Create a Custom TN Filter

This dialog allows you to create a new custom TN filter.

To create a custom TN filter:

1. Log in to LSMS as a member of the permission group that is authorized to perform
this operation.

2. From the LSMS Console window, select LSMS > Custom TN Filter > Create.

The Create Custom TN Filter dialog appears.

Custom TN Filters
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Figure 4-5    Create Custom TN Filter Dialog

3. Type in a unique filter name (maximum of 40 characters) in the TN Filter combo
box.

Optionally, type a description of the TN filter in the Description text area. See 
Table 4-1 for a list of the remaining Custom TN Filter fields and the corresponding
field descriptions.

Table 4-1    Create Custom TN Filter Dialog Field Descriptions

Custom TN Filter Field Description

Include The LSMS should only send TNs from the
indicated NPA-NXXs to an EMS that has
this custom TN filter assigned.

Exclude The EMS should only send TNs not from
the indicated NPA-NXXs to an EMS that
has this custom TN filter assigned.

NPA (radio button) Add an entire NPA to the filter.

NPA-NXX (radio button) Add selected NPA-NXXs to the filter.

NPA Add all NPA-NXXs from this NPA to the
filter.

Start NPA-NXX Add this NPA-NXX to the filter.

End NXX Add all NPA-NXXs from "Start NPA"-"Start
NXX" to "Start NPA"-"End NXX" (inclusive)
to the filter.

Custom TN Filters
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Table 4-1    (Cont.) Create Custom TN Filter Dialog Field Descriptions

Custom TN Filter Field Description

NPA-NXX List Contains the NPA-NXXs that make up this
filter. By default, only the NPAs are shown.
To see the NXXs for an NPA, double-click
on the NPA. To hide the NXXs, double-click
on the NPA again.

4. When you are done, click OK or Apply.

Modify a Custom TN Filter

This dialog allows you to modify an existing custom TN filter.

To modify a custom TN filter:

1. Log in to LSMS as a member of the permission group that is authorized to perform
this operation.

2. From the LSMS Console window, select LSMS > Custom TN Filter > Modify.

The Modify Custom TN Filter dialog appears.

3. Select the filter name from the TN Filter combo box.

See Create a Custom TN Filter for a list of the Custom TN Filter fields and the
corresponding field descriptions.

4. When you are done, click OK or Apply.

Note:   After making any changes to the custom TN filter, you must restart the
EAGLE agent for the changes to take effect.

View a Custom TN Filter

This dialog allows you to view an existing custom TN filter. All data entry fields,
except for the TN Filter combo box, are disabled.

To view a custom TN filter:

1. Log in to LSMS as a member of the permission group that is authorized to perform
this operation.

2. From the LSMS Console window, select LSMS > Custom TN Filter > View.

The View Custom TN Filter dialog appears.

3. Select the filter name from the TN Filter combo box.

4. When you are done, click OK.

Delete a Custom TN Filter

Use this dialog to delete an existing TN filter. All data entry fields, except for the TN
Filter combo box, are disabled. The user may delete another filter by selecting it from
the TN Filter combo box, and clicking OK or Apply. If the filter being deleted is

Custom TN Filters
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currently to an EMS via EMS Routing, an error dialog will be displayed, and the
operation will fail.

To view a custom TN filter:

1. Log in to LSMS as a member of the permission group that is authorized to perform
this operation.

2. From the LSMS Console window, select LSMS > Custom TN Filter > Delete.

The Delete Custom TN Filter dialog appears.

3. Select the filter name you want to delete from the TN Filter combo box.

You may delete a specific filter by selecting it from the TN Filter combo box, and
clicking OK or Apply.

Note:   

If the filter being deleted is currently to an EMS via EMS Routing, an error
dialog will be displayed, and the operation will fail.

4. When you are done, click OK or Apply.

Note:   After making any changes to the custom TN filter, you must restart the
EAGLE agent for the changes to take effect.

GTT Groups
The Create GTT Group dialog is used to manage GTT groups. GTT groups are used to
group multiple default and override GTT (see Default GTT and Override GTT)
records which are then assigned to one or more EMSs.

Create GTT Group

The Create GTT Group dialog allows you to create a new GTT group. To create a new
GTT group:

1. Log in to LSMS as a member of the permission group that is authorized to perform
this operation.

2. From the LSMS Console window, select LSMS > GTT Group > Create.

The Create GTT Group dialog appears.

GTT Groups
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Figure 4-6    Create GTT Group Dialog

3. Enter a unique GTT group name in the GTT Group field, and optionally add a
description of the group in the Description field.

4. In the Authorized Service Provider IDs field, select the service providers that are
allowed to use the specified GTT group.

Authorized service providers may modify or delete this GTT group, and may
assign default or override GTT records to this GTT group. To select multiple
service providers, or deselect a previously selected service provider, hold down the
Ctrl key and click on the service provider. To select a range of service providers,
hold down the Ctrl key and click on the service provider.

5. When you are done, click OK or Apply.

Modify GTT Group

The Modify GTT Group dialog allows you to modify an existing GTT group. To
modify a GTT group:

1. Log in to LSMS as a member of the permission group that is authorized to perform
this operation.

2. From the LSMS Console window, select LSMS > GTT Group > Modify.

The Modify GTT Group dialog appears.

3. Select a GTT group from the GTT Group combo box.

4. Type in desired changes, if any, to the description of the group in the Description
field.

GTT Groups
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5. Make any desired changes to the Authorized Service Provider IDs field.

Authorized service providers may modify or delete this GTT group, and may
assign default or override GTT records to this GTT group. To select multiple
service providers, or deselect a previously selected service provider, hold down the
Ctrl key and click on the service provider. To select a range of service providers,
hold down the Ctrl key and click on the service provider.

6. When you are done, click OK or Apply.

View GTT Group

The View GTT Group dialog allows you to view an existing GTT group. To view a
GTT group:

1. Log in to LSMS as a member of the permission group that is authorized to perform
this operation.

2. From the LSMS Console window, select LSMS > GTT Group>View.

The View GTT Group dialog appears.

3. Select a GTT group from the GTT Group combo box to view the information
associated with that GTT group.

4. When you are done, click OK.

Delete GTT Group

The Delete GTT Group dialog allows you to delete an existing GTT group. To delete a
GTT group:

1. Log in to LSMS as a member of the permission group that is authorized to perform
this operation.

2. From the LSMS Console window, select LSMS > GTT Group > Delete.

3. Select the GTT group that you want to delete from the GTT Group combo box.

4. When you are done, click OK or Apply.

Note:   If the GTT group you selected to delete is currently assigned to an EMS
via EMS routing, an error dialog is displayed, and the request to delete is
denied.

Default GTT
The Create Default GTT dialog is used to manage default GTT records.

The Add Service button adds an empty row to the table. The Remove Service(s)
button removes the selected row(s) from the table.

You may change the GTT group that a default GTT record belongs to by selecting a
new value from the GTT Group combo box. When creating or modifying default
GTTs, select a cell in the Message Relay Services table (by clicking on it or navigating
to it using the keyboard), and modify the entry. The entry is entered into the cell when
you select another cell or press Return. When you change the value in the Service

Default GTT
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Name field, only the TT value of that row is populated with the default value for that
service, overwriting any existing values.

When you click OK or Apply to create a default GTT, the GTT data is checked to
ensure that the NPA-NXX is not yet defined for this group. If the NPA-NXX is already
defined, the operation will fail, and an error dialog will be displayed.

After clicking Apply, you may retrieve default GTT values for another NPA-NXX. If
you try to retrieve GTT values for a new NPA-NXX without first saving the changes to
the GTT values for the current NPA-NXX, a confirmation dialog is displayed asking
you to save the changes.

Create Default GTT

The Create Default GTT dialog is used to create new default GTT records.

To create a new default GTT record:

1. Log in to LSMS as a member of the permission group that is authorized to perform
this operation.

2. From the LSMS Console window, select LSMS > Default GTT > Create.

The Create Default GTT dialog appears.

Figure 4-7    Create Default GTT Dialog

3. Type in the Service Provider ID in the Service Provider ID field.

4. Select a GTT group from the GTT Group combo box from which to choose default
GTT records.

5. In the NPA-NXX box, enter an NPA-NXX and press Return to retrieve the default
GTT settings for this NPA-NXX and GTT group.

Default GTT
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See Table 4-2 for a list of the remaining Default GTT fields and the corresponding
field descriptions.

Table 4-2    Create Default GTT Dialog Field Descriptions

Default GTT Field Description

AIN Check Box Indicates whether AIN query message
format is supported. A checked box
indicates that AIN is enabled.

IN Check Box Indicates whether IN query message format
is supported. A checked box indicates that
IN is enabled.

Service Name Global title translation occurs when an SS7
message contains the translation type
corresponding to this service. Used by MPS
only. (The MPS contains the actual TTs
corresponding to the service names.)

DPC Substitute this DPC for the DPC in the SS7
message being translated.

SSN Substitute this SSN for the SSN in the SS7
message being translated.

XLAT The type of translation being performed.

RI The routing indicator.

NGT Substitute this Global Title value for the
Global Title value in the SS7 message being
translated.

6. When you are done, click OK or Apply.

Modify a Default GTT

The Modify Default GTT dialog allows you to modify existing default GTT records.

To modify a default GTT:

1. Log in to LSMS as a member of the permission group that is authorized to perform
this operation.

2. From the LSMS Console window, select LSMS > Default GTT > Modify.

The Modify Default GTT dialog appears.

3. Select a GTT group from the GTT Group combo box from which to choose default
GTT records.

4. In the NPA-NXX box, enter an NPA-NXX and click the View Data button to retrieve
the default GTT settings for this NPA-NXX and GTT group.

See Create Default GTT for a list of the remaining Default GTT fields and the
corresponding field descriptions.

5. When you are done, click OK or Apply.

Default GTT
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View a Default GTT

The View Default GTT dialog allows you to view existing default GTT records. The
Add Service and Remove Service(s) buttons are disabled, and table cell editing is
disabled.

To view a default GTT:

1. Log in to LSMS as a member of the permission group that is authorized to perform
this operation.

2. From the LSMS Console window, select LSMS > Default GTT > View.

The View Default GTT dialog appears.

3. Select the GTT group from the GTT Group combo box.

4. In the NPA-NXX box, enter an NPA-NXX and click the View Data button to retrieve
the default GTT settings for this NPA-NXX and GTT group.

5. When you are done, click OK.

Delete a Default GTT

Use the Delete Default GTT dialog to delete existing default GTT records. The Add
Service and Remove Service(s) buttons are disabled, and table cell editing is disabled.

To delete a default GTT record:

1. Log in to LSMS as a member of the permission group that is authorized to perform
this operation.

2. From the LSMS Console window, select LSMS > Default GTT > Delete.

The Delete Default GTTdialog appears.

3. Select the GTT group from the GTT Group combo box.

4. In the NPA-NXX box, enter an NPA-NXX and click the View Data button to retrieve
the default GTT settings for this NPA-NXX and GTT group.

5. When you are done, click OK or Apply.

Override GTT
The Create Override GTT dialog is used to manage override GTT records.

You may change the GTT group that an override GTT record belongs to by selecting a
new value from the GTT Group combo box. When creating or modifying override
GTTs, select a cell in the table (by clicking on it or navigating to it using the keyboard),
and modify the entry. The entry is entered into the cell when you select another cell or
press Return. When you change the value in the Service Name field, only the TT
value of that row will be populated with the default value for that service, overwriting
any existing values.

When you click OK or Apply to create or modify an override GTT, the GTT data is
checked to ensure that the LRN is not yet defined for this group. If the LRN is already
defined, the operation will fail, and an error dialog will be displayed.

Override GTT
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After clicking Apply, you may create override GTT values for another LRN. If you
attempt to create GTT values for a new LRN while there are unsaved changes to the
GTT values for the current LRN, a confirmation dialog is displayed asking you to save
the changes.

Create an Override GTT

The Create Override GTT dialog is used to create new Override GTT records.

To create a new override GTT record:

1. Log in to LSMS as a member of the permission group that is authorized to perform
this operation.

2. From the LSMS Console window, select LSMS > Override GTT > Create.

The Create Override GTT dialog appears.

3. Type in the Service Provider ID in the Service Provider ID field.

4. Select an existing GTT group name from the GTT Group combo box from which to
choose override GTT records.

5. In the LRN box, enter the LRN (enter a ten-digit number; no spaces, hyphens, or
underscores are permitted).

See Table 4-3 for a list of the remaining Override GTT fields and the corresponding
field descriptions.

Table 4-3    Create Override GTT Dialog Field Descriptions

Override GTT Field Description

Service Name Service name to which the GTT data is
mapped. Used by MPS only. No duplicates
are allowed. Value entered must be one of
the following: CLASS, CNAM, ISVM,
LIDB, or WSMSC.

DPC Substitute this DPC for the DPC in the SS7
message being translated. Value must
contain 3 3-digit octets (1 octet per text
field). First octet must be between 1 and
255. Last 2 octets must be between 0 and
255. Second octet must not be 001 if first
octet between 001 and 005.

SSN Substitute this SSN for the SSN in the SS7
message being translated. Range is 0–255,
excluding 1.

XLAT The type of translation being performed.
Value must be one of the following: dpc,
dpcssn, or dpcngt.

RI The routing indicator. Value must be one of
the following: gt or ssn.

Override GTT
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Table 4-3    (Cont.) Create Override GTT Dialog Field Descriptions

Override GTT Field Description

NGT Substitute this global title address for the
Global Title address in the SS7 message
being translated. Range 0–255. 0 indicates
no RGT, while 1–255 are valid values.

RGTA Indicates whether to replace the global title
address of the SS7 message with the LRN
of this EMS.

6. When you are done, click OK or Apply.

Modify an Override GTT

The Modify Override GTT dialog allows you to modify existing override GTT records.

To modify an override GTT:

1. Log in to LSMS as a member of the permission group that is authorized to perform
this operation.

2. From the LSMS Console window, select LSMS > Override GTT > Modify.

The Modify Override GTT dialog appears.

3. Select a GTT group from the GTT Group combo box from which to choose default
GTT records.

4. In the LRN box, enter the LRN (enter a ten-digit number; no spaces, hyphens, or
underscores are permitted).

Select the View Data button to retrieve the override GTT settings for this NPA-
NXX and Override GTT group. See Create an Override GTT for a list of the
remaining Override GTT fields and the corresponding field descriptions.

5. When you are done, click OK or Apply.

View an Override GTT

The View Override GTT dialog allows you to view existing override GTT records. The
Add Service and Remove Service(s) buttons are disabled, and table cell editing is
disabled.

To view an override GTT:

1. Log in to LSMS as a member of the permission group that is authorized to perform
this operation.

2. From the LSMS Console window, select LSMS > Override GTT > View.

The View Override GTT dialog appears.

3. Select the GTT group from the GTT Group combo box.

4. In the LRN box, enter the LRN (enter a ten-digit number; no spaces, hyphens, or
underscores are permitted).

Override GTT
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Select the View Data button to retrieve the override GTT settings for this NPA-
NXX and Override GTT group.

5. When you are done, click OK.

Delete an Override GTT

Use the Delete Override GTT dialog to delete existing override GTT records. The Add
Service and Remove Service(s) buttons are disabled, and table cell editing is disabled.

To delete an override GTT record:

1. Log in to LSMS as a member of the permission group that is authorized to perform
this operation.

2. From the LSMS Console window, select LSMS > Override GTT > Delete.

The Delete Override GTT dialog appears.

3. Select the GTT group from the GTT Group combo box.

4. In the LRN box, enter the LRN (enter a ten-digit number; no spaces, hyphens, or
underscores are permitted).

Select the View Data button to retrieve the override GTT settings for this NPA-
NXX and Override GTT group.

5. When you are done, click OK or Apply.

TN/NPB Query
The Subscription Query dialog enables you to query the local database for telephone
number and number pool block subscription version records.

By default, users belonging to any of the five default permission groups have access to
this view function.

TN/NPB Query
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Figure 4-8    Subscription Query Dialog

TN Query

To query the local database for a TN, type in the 10 digits, select the region, and click
Apply.

TN/NPB Query
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Figure 4-9    Query Successful Dialog.

If the TN is not found in the region, it will be checked—automatically—to see if it is
part of an NPB. If it is then found as part of an NPB in the region, then the
subscription version data table for the NPB will be populated and a Query Successful
dialog is displayed with the message than the TN is part of an NPB.

Note:   See Table 4-4 for a description of the TN fields that display in the
Subscription Query window when the query is successful.

If neither object can be found in the database, then an error dialog appears stating that
the TN was not found in the specified regional database.

TN Field Descriptions
Table 4-4 describes the fields that display when a TN query is successful.

TN/NPB Query
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Table 4-4    TN Subscription Query Data - Field Descriptions

Field Description

tn The 10 digit telephone number

versionID The version ID

lrn The associated LRN

newCurrentSP The new current service provider ID

activationTimeStamp The time stamp of activation

endUserLocationType The end user location type

endUserLocationValue The end user location value

billingId The billing ID

lnpType The LNP Type

downLoadReason The down load reason

CLASS-DPC The CLASS destination point code

CLASS-SSN The CLASS sub system number

CNAM-DPC The CNAM destination point code

CNAM-SSN The CNAM sub system number

ISVM-DPC The ISVM destination point code

ISVM-SSN The ISVM sub system number

LIDB-DPC The LIDB destination point code

LIDB-SSN The LIDB sub system number

WSMSC-DPC The WSMSC destination point code

WSMSC-SSN The WSMSC sub system number

NPB Query
To query a number pool block (NPB) , type in the first seven digits followed by ***,
select the region, and click Apply . If the query is successful, the subscription version
data table for the NPB will be populated and a Query Successful dialog is displayed.

Note:   See Table 4-5 for a description of the NPB fields that display in the
Subscription Query window when the query is successful.

TN/NPB Query
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Figure 4-10    Query Successful Dialog

If the NPB object cannot be found in the database, then an Error dialog will appear
stating that the NPB was not found in the specified regional database.

Figure 4-11    Error Dialog

When you are finished querying the local database, click Cancel to close the dialog.

NPB Field Descriptions
This table describes the fields that display when an NPB query is successful.

TN/NPB Query
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Table 4-5    NPB Subscription Query Data - Field Descriptions

Field Description

npaNxxX The 7 digit number pool block

blockID The block ID

lrn The associated LRN

blockHolderSpid The block holder service provider ID

activationTimeStamp The time stamp of activation

downLoadReason The down load reason

CLASS-DPC The CLASS destination point code

CLASS-SSN The CLASS sub system number

CNAM-DPC The CNAM destination point code

CNAM-SSN The CNAM sub system number

ISVM-DPC The ISVM destination point code

ISVM-SSN The ISVM sub system number

LIDB-DPC The LIDB destination point code

LIDB-SSN The LIDB sub system number

WSMSC-DPC The WSMSC destination point code

WSMSC-SSN The WSMSC sub system number

NPA Splits
Users belonging to the lsmsuser or lsmsall permission group are authorized to create
and delete NPA Splits. Users belonging to the lsmsadm, lsmsview, and lsmsuext
permission groups are only authorized to view NPA Split information.

NPA Splits are managed from the NPA Splits dialog. You may view splits based on the
old NPA, new NPA, both, or neither (view the entire list). To retrieve the first 500
records and display them in the table, click the View NPA Splits button. To view more
than 500 splits, create an NPA Split report.

Create NPA Split

To create an NPA split:

1. Log in to LSMS as a member of the permission group that is authorized to perform
this operation.

2. From the LSMS Console window, select LSMS > NPA Split.

The NPA Splits dialog appears.

NPA Splits
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Figure 4-12    NPA Splits Dialog

3. Select Create.

The Create NPA Split dialog appears.

NPA Splits
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Figure 4-13    Create NPA Split Dialog

4. In the Old NPA text field, type in the NPA that is being split.

This is a 3-digit field.

5. In the New NPA text field, type in the NPA that the NXXs are being moved to.

This is a 3-digit field and must be different than the old NPA value.

6. In the NXX text field, type in the first NXX that is being moved, then click the Add
button.

NPA Splits
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The NXX specified displays in the NXX(s) box and the entry in the NXX field
disappears. Continue to add additional NXXs, one at a time, in the same manner.
This is a 3-digit field.

7. In the Start PDP (date the permissive dialing period begins) field, highlight the
month, and select the desired value using the up or down arrows.

Modify the day and year values in the same manner. This date must be greater than
the current date.

8. In the End PDP (date the permissive dialing period ends) field, highlight the
month, and select the desired value using the up or down arrows.

Modify the day and year values in the same manner. This date must be greater than
the Start PDP date.

9. When you are done, click OK or Apply.

You return to the NPA Splits dialog.

10. When you are done, click OK.

Modify NPA Split

This dialog allows the user to modify the start and/or end Permissive Dialing Period
(PDP) dates of an existing NPA split. Both the start and ending PDP dates can be
modified for pending splits. Only the ending PDP date can be modified for active
splits. The Old NPA, New NPA, and NXX fields can only be viewed.

To modify an NPA split:

1. Log in to LSMS as a member of the permission group that is authorized to perform
this operation.

2. From the LSMS Console window, select LSMS > NPA Split.

The NPA Splits dialog appears.

3. Select the row in the table you want to modify, and then click the Modify button.

The Modify NPA Split dialog appears.

NPA Splits
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Figure 4-14    Modify NPA Split Dialog

4. You can modify the Start PDP field only if the NPA split status is Pending.

To modify the date, highlight the month, and select the desired value using the up
or down arrows. Modify the day and year values in the same manner. This date
must be greater than the current PDP date.

5. Modify the End PDP date, if desired.

To modify the date, highlight the month, and select the desired value using the up
or down arrows. Modify the day and year values in the same manner. This date
must be greater than the Start PDP date.

6. In the End PDP (date the permissive dialing period ends) field, highlight the
month, and select the desired value using the up or down arrows.

NPA Splits
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Modify the month and year values in the same manner. This date must be greater
than the start date.

7. When you are done, click OK or Apply.

You return to the NPA Splits dialog.

8. When you are done, click OK.

Delete NPA Split

To delete an NPA split:

1. Log in to LSMS as a member of the permission group that is authorized to perform
this operation.

2. From the LSMS Console window, select LSMS > NPA Split.

The NPA Splits dialog appears.

3. Select the row in the table you want to delete, and then click the Delete button.

4. When you are done, click OK.

Reversing (Correcting) an NPA Split Entry Made in Error

Note:   Before you start this procedure, it is recommended that you contact the 
My Oracle Support (MOS).

To correct an NPA split entry made in error, the steps you perform depend upon
whether the split is in Active status.

Use the following procedure to correct an NPA split. This procedure uses an example
in which an NPA-NXX split moves all SVs and NPBs from 909-860 to 123-860 instead
of 124-860.

1. Note whether the split is in Active status:

a. Select LSMS from the menu bar.

b. Select NPASplit from the drop-down list.

c. Select the View tab on the NPA Split window.

d. Select View Entire Table.

e. Select Apply.

2. Delete the split (see Delete NPA Split), then do one of the following:

• If the split is in Pending or Activation Failed status, no further action is
required.

Proceed to 4

• If the split is in Active or Invalid status, or if the split has already been deleted
after being Active, use the procedure described in “Downloading Files from
the NPAC to the LSMS” in the Alarms and Maintenance Guide, requesting the
following data files be copied to the FTP site: one file for the old NPA-NXX,

NPA Splits
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one file for the correct new NPA-NXX, and one file for the erroneous new
NPA-NXX.

Using the example cited earlier in this section, the file names would have the
following format:

909860-909860.<DD-MM-YYYYHHMMSS>
124860-124860.<DD-MM-YYYYHHMMSS>
123860-123860.<DD-MM-YYYYHHMMSS>

• If the NPAC supports EDR, three more data files for the NPBs are also needed.
Again, using the example cited earlier in this section, the file names would
have the following format (note the use of NPA-NXX-X values instead of NPA-
NXX in the file names):

9098600-9098609.<DD-MM-YYYYHHMMSS>
1248600-1248609.<DD-MM-YYYYHHMMSS>
1238600-1238609.<DD-MM-YYYYHHMMSS>

Be sure to perform an LSMS-to-EAGLE audit and reconcile of all SVs and NPBs in
the old, correct new, and erroneous new NPA-NXX on each EMS that received the
incorrect split. Refer to the LNP Database Synchronization User's Guide for the
procedure to perform audit and reconcile.

3. If the split being reversed was already activated on the EAGLE, delete the split
from the EAGLE and audit and reconcile the default GTT entries from the LSMS
to the EAGLE.

Refer to the LNP Database Synchronization User's Guide for the procedure to perform
audit and reconcile.

4. If the PDP is over, do not create the correct split because new and reused TNs may
already exist in the old NPA-NXX.

However, if the PDP End Date is still in the future, then create the split with the
correct values (see Create NPA Split).

Input Data By File
Introduction

Input data by file provides an alternate method of provisioning default GTT, override
GTT, NPA-NXX split entries, and custom TN filters. The data entries are input from a
properly formatted file to the LSMS. If a particular data entry already exists in the
LSMS, the data in the file is used to modify the entire existing entry.

The new default GTT and override GTT entries are automatically validated and
forwarded to the network elements without user intervention. The NPA-NXX split
and custom TN filter entries are automatically validated and added to the LSMS
NPA-NXX split table or custom TN Filter table without user intervention (they are not
forwarded to the network element).

A GUI is provided that allows users to specify the input file name and receive
feedback on the processing of each of the file entries.

File processing is divided into the following phases:

• File Validation Phase

• Input Processing Phase

Input Data By File
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File Validation Phase

In this phase, the input data file is obtained from the client machine running the GUI.
The input data file is parsed and the file format and data items are validated. As the
file is being processed, the Input Data by File dialog displays the following
information:

• The number of items validated (this is an incremental count starting at zero).

• The number of errors (this is an incremental count starting at zero).

• The first 100 erroneous data items are displayed in the dialog's scrolled list.

The entire input data file is validated and both successful and erroneous data items are
written to a result file. If errors are encountered the next phase is never started, and a
warning dialog is displayed to the user. The warning dialog tells the user that the
input data file has errors and to check the result file for specific error messages. The
result file is stored at the client machine running the GUI.

Input Processing Phase

This phase is only performed when the input data file has no File Validation phase
errors. In this phase a check is made to determine if a previous File Validation phase
result file exists. If so, it is deleted.

During this phase, the input data file entries are merged with the data in the LSMS
database. As the file is being processed, the Input Data by File dialog displays the
following information:

• The number of items processed (this is an incremental count starting at zero).

• The number of errors (this is an incremental count starting at zero).

• The first 100 erroneous data items display in the dialog's scrolled list.

As each entry is processed and merged with the existing data, the operation results
(OK or FAILED) are written to a result file. A failed operation indicates that an error
has occurred on the specific entry.

When both of these phases are completed, a message dialog displays indicating that
the entire processing of the file has completed.

Default GTT Input File
The default GTT input file enables you to create, modify, or delete a default GTT.

Each data entry in the default GTT input file is checked to ensure that the format
corresponds to the input file specification. The data values are validated using the
same rules that are presently used when entering a single default GTT via the LSMS
GUI. The entire input data file is validated, successful entries and errors encountered
are written to the result file, and the processing of the next data entry continues.

Only if no errors are encountered is further processing allowed by this feature, at
which time the data entries are added to the LSMS database default GTT

The user-specified filename must have an extension of .DGT to be a valid input data
filename for default GTT.

The default GTT input file should be located at the client machine that is running the
LSMS GUI. You can use a file selection dialog box to select the input file.

Default GTT Input File
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The NPANXX value of each default GTT data entry in the file is used to check if the
default GTT object instance exists in the supported database. If the default GTT object
instance is not present a new instance is created. However, if the default GTT instance
is present in the supported database, then the entire default GTT object instance data
is overwritten with the input file data for that instance. For deletions, if the default
GTT object exists, it is deleted. If the default GTT object does not exist, however, the
delete request is logged as a success, not a failure, in the default GTT result file.

The default GTT input block contains one record for each database entry. Individual
fields are pipe delimited, with a new line (0x0A) after each GTT recorded. Each entry
should begin at the beginning of the line.

Table 4-6    Default GTT Input Block Contents

Field Number Field Name

1 SPID

2 GTT Group Name

3 NPANXX Value

4 AIN

5 IN

6–12 Service # 1

13–19 Service # 2

20–26 Service # 3

27–33 Service # 4

34–40 Service # 5

Note:   It is necessary to have at least 4 Services (Service # 1–Service # 4) filled
with data. If WSMSC feature is enabled, it is necessary to fill Service # 5. Any
unused Services must be represented by unpopulated fields, because the data
is positional.

Default GTT Input File
Figure 4-15 is an example of a default GTT input file with one entry. See Table 4-7 for
an explanation of the fields.

Figure 4-15    Example Default GTT Input File

TKLC|GTTGroup|919420|AIN|IN|CLASS|016|001001001|003|DPCSSN|SSN|0|CNAM|100|
002002002|005|DPCSSN|SSN|0|ISVM|134|003003003|006|DPCSSN|SSN|0|LIDB|125|
004004004|007|DPCSSN|SSN|0|WSMSC|127|004004004|007|DPCSSN|SSN|0

Default GTT Input File
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Table 4-7    Explanation of the Fields in the Default Input File

Field Number Field Name Value in Example Range of Values

1 SPID TKLC [A-Z, a-z, 0-9] {4
alphanumeric}

2 GTT Group Name GTTGroup [A-Z, a-z, 0-9] {64
alphanumeric}

3 NPANXX Value 919420 [0-9]{6 digits}

4 AIN AIN AIN or empty pipe
to indicate no AIN

5 IN IN IN or empty pipe to
indicate no IN

6 S1-Service Name CLASS Character {up to 8
characters}

7 S1-Translation Type 016 [000…255]

8 S1-DPC 001001001 [001…255][000…255]
[000…255] {9
characters}

9 S1-SSN 003 [000…255]

10 S1-XLAT DPCSSN [DPC, DPCSSN,
DPCNGT]

11 S1-RI SSN [GT, SSN]

12 S1-NGT 0 [0…255]

13 S2-Service Name CNAM Character {up to 8
characters}

14 S2-Translation Type 100 [000…255]

15 S2-DPC 002002002 [001…255][000…255]
[000…255] {9
characters}

16 S2-SSN 005 [000…255]

17 S2-XLAT DPCSSN [DPC, DPCSSN,
DPCNGT]

18 S2-RI SSN [GT, SSN]

19 S2-NGT 0 [0…255]

20 S3-Service Name ISVM Character {up to 8
characters}
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Table 4-7    (Cont.) Explanation of the Fields in the Default Input File

Field Number Field Name Value in Example Range of Values

21 S3-Translation Type 124 [000…255]

22 S3-DPC 003003003 [001…255][000…255]
[000…255] {9
characters}

23 S3-SSN 006 [000…255]

24 S3-XLAT DPCSSN [DPC, DPCSSN,
DPCNGT]

25 S3-RI SSN [GT, SSN]

26 S3-NGT 0 [0…255]

27 S4-Service Name LIDB Character {up to 8
characters}

28 S4-Translation Type 125 [000…255]

29 S4-DPC 004004004 [001…255][000…255]
[000…255] {9
characters}

30 S4-SSN 007 [000…255]

31 S4-XLAT DPCSSN [DPC, DPCSSN,
DPCNGT]

32 S4-RI SSN [GT, SSN]

33 S4-NGT 0 [0…255]

34 S5-Service Name LIDB Character {up to 8
characters}

35 S5-Translation Type 125 [000…255]

36 S5-DPC 004004004 [001…255][000…255]
[000…255] {9
characters}

37 S5-SSN 007 [000…255]

38 S5-XLAT DPCSSN [DPC, DPCSSN,
DPCNGT]

39 S5-RI SSN [GT, SSN]

40 S5-NGT 0 [0…255]

41 Block Termination See 1
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Table 4-7    (Cont.) Explanation of the Fields in the Default Input File

Field Number Field Name Value in Example Range of Values

1The block termination field value is a new line character, which is generated by pressing the
Enter key on the keyboard.

Default GTT Input File - Delete Record
The default GTT delete record contains one record for each database entry. Individual
fields are pipe delimited with a new line (0x0A) after each GTT recorded. Each entry
should begin at the beginning of the line.

Example Default GTT Delete Record File

DELETE|GTTGroup|919469

Table 4-8    Explanation of the Fields in the Default GTT Delete Record

Field Number Field Name Range of Values Values in Example

1 Delete record
recognition string

Characters {6
characters}

DELETE1

2 Group name [A-Z, a-z, 0-9] {64
alphanumeric}

GTTGroup

3 NPANXX [0-9]{6 digits} 919469

1This is the fixed string to be used for all delete records. An entry that does not begin with
DELETE, or one in which DELETE is misspelled, will be treated like a create or modify entry.

Creating or Modifying the File

To create or modify a default GTT input file:

1. Prepare the default GTT input file.

See Figure 4-15 for more information about the format of a default GTT input file.
See Table 4-7 for more information about the fields in a default GTT input file. The
default GTT input file extension must be .DGT.

Note:   It is not necessary to have all 4 Services (S1-S4) filled with data. Any
unused Service must have its unused data fields unpopulated, but with the
pipe delimiters as placeholders, because the data is positional.

2. Transfer the default GTT input file to the LSMS.

Transfer the file to the My Documents folder on the Windows desktop of your
computer.

Importing the File

To import the default GTT input file:

1. Log in to LSMS as a member of the permission group that is authorized to perform
this operation.

Default GTT Input File
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If you are logging into a shadow LSMS, see “Entering Locally Provisioned Data on
a Shadow LSMS”.

2. From the LSMS Console window, select LSMS>Input Data by File.

The Input Data by File window is displayed.

3. If the name of the input file does not appear in the Input File field, you can type it
in (specifying the complete path), or use the Browse button to find it.

4. Click the Start button.

This initiates the file validation phase.

Default GTT Result File
The Default GTT result file (which is located in the same directory as the input data
file) stores useful information about the processing of each of the Default GTT data
items read from the input data file while executing the file validation phase. A result
file with the format shown below is produced during file validation or input
processing phase.

For each correct data item read from the input file, a single line appears in the result
file:

SPID|GROUP|NPA-NXX Operation_Status

For each erroneous data item read from the input file, a single line appears in the
result file:

SPID|GROUP|NPA-NXX Operation_Status [Error_Number] [Error_Message]

where:

SPID = SPID value read from input data file

GROUP = GTT Group

NPA-NXX = The six digits value input from file for each data item.

Operation_Status = OK to indicate a successful operation; FAILED to indicate an error
in processing.

Error_Number = An "E" followed by up to 3 numeric digits (this is an optional field, it
appears only if operation status is FAILED).

Error_Message = Text indicating the first processing error found in the data entry (this
is an optional field, it appears only if operation status is FAILED).

Example Default GTT Result File

Figure 4-16 shows a picture of a Default GTT result file.
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Figure 4-16    Example Default GTT Result File.

Default GTT Error Codes

See Error Codes.

Override GTT Input File
The override GTT input file enables you to create, modify, or delete an override GTT.

Each data entry in the override GTT input file is checked to ensure that the format
corresponds to the input file specification. The data values are validated using the
same rules that are presently used when entering a single override GTT via the LSMS
GUI. The entire input data file is validated, successful entries and errors encountered
are written to the result file, and the processing of the next data entry continues.

Only if no errors are encountered is further processing allowed by this feature, at
which time the data entries are added to the LSMS database override GTT table.

The user-specified filename must have an extension of .OGT to be a valid input data
filename for override GTT.

The override GTT input file should be located at the client machine that is running the
LSMS GUI. You can use a file selection dialog box to select the input file.

The LRN value of each override GTT data entry in the file is used to check if the
override GTT object instance exists in the supported database. If the override GTT
object instance is not present a new instance is created. However, if the override GTT
instance is present in the supported database, then the entire override GTT object
instance data is overwritten with the input file data for that instance. For deletions, if
the override GTT object exists, it is deleted. If the override GTT object does not exist,
however, the delete request is logged as a success, not a failure, in the override GTT
result file.

Override GTT Input File
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The override GTT input block contains one record for each database entry. Individual
fields are pipe delimited, with a new line (0x0A) after each GTT recorded. Each entry
should begin at the beginning of the line.

Table 4-9    Override GTT Input Block Contents

Field Number Field Name

1 SPID

2 GTT Group Name

3 LRN

4–11 Service # 1

12–19 Service # 2

20–27 Service # 3

28–35 Service # 4

36–43 Service # 5

Note:   It is necessary to have at least 4 Services (Service # 1–Service # 4) filled
with data. If WSMSC feature is enabled, it is necessary to fill Service # 5. Any
unused Services must be represented by unpopulated fields, because the data
is positional.

Override GTT Input File

Figure 4-17 is an example of an override GTT input file with one entry. See Table 4-10
for an explanation of the fields.

Figure 4-17    Example Override GTT Input File

TKLC|GTTGroup|9194200000|CLASS|016|001001001|003|DPCSSN|SSN|0|YES|CNAM|100|
002002002|005|DPCSSN|
SSN|0|NO|ISVM|134|003003003|006|DPCSSN|SSN|0|YES|LIDB|125|004004004|007|DPCSSN|
SSN|0|NO|WSMSC|126|
004004004|007|DPCSSN|SSN|0|NO

Table 4-10    Explanation of the Fields in the Override GTT Input File

Field Number Field Name Value in Example Range of Values

1 SPID TKLC [A-Z, a-z, 0-9] {4
alphanumeric}

2 GTT Group Name GTTGroup [A-Z, a-z, 0-9] {64
alphanumeric}

3 LRN 3002000000 [0-9]{10 digits}

4 S1-Service Name CNAM Character {up to 8
characters}

Override GTT Input File
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Table 4-10    (Cont.) Explanation of the Fields in the Override GTT Input File

Field Number Field Name Value in Example Range of Values

5 S1-Translation Type 078 [000…255]

6 S1-DPC 233233233 [001…255][000…255]
[000…255] {9
characters}

7 S1-SSN 000 [000…255]

8 S1-XLAT DPC [DPC, DPCSSN,
DPCNGT]

9 S1-RI GT [GT, SSN]

10 S1-NGT 0 [0…255]

11 S1-RGTA NO [YES, NO]

12 S2-Service Name CLASS Character {up to 8
characters}

13 S2-Translation Type 079 [000…255]

14 S2-DPC 122122122 [001…255][000…255]
[000…255] {9
characters}

15 S2-SSN 000 [000…255]

16 S2-XLAT DPC [DPC, DPCSSN,
DPCNGT]

17 S2-RI GT [GT, SSN]

18 S2-NGT 0 [0…255]

19 S2-RGTA NO [YES, NO]

20 S3-Service Name ISVM Character {up to 8
characters}

21 S3-Translation Type 080 [000…255]

22 S3-DPC 011011011 [001…255][000…255]
[000…255] {9
characters}

23 S3-SSN 000 [000…255]

24 S3-XLAT DPC [DPC, DPCSSN,
DPCNGT]

25 S3-RI GT [GT, SSN]
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Table 4-10    (Cont.) Explanation of the Fields in the Override GTT Input File

Field Number Field Name Value in Example Range of Values

26 S3-NGT 0 [0…255]

27 S3-RGTA NO [YES, NO]

28 S4-ServiceName LIBD Character {up to 8
characters}

29 S4-Translation Type 081 [000…255]

30 S4-DPC 100100100 [001…255][000…255]
[000…255] {9
characters}

31 S4-SSN 000 [000…255]

32 S4-XLAT DPC [DPC, DPCSSN,
DPCNGT]

33 S4-RI GT [GT, SSN]

34 S4-NGT 0 [0…255]

35 S4-RGTA NO [YES, NO]

36 S5-ServiceName LIBD Character {up to 8
characters}

37 S5-Translation Type 081 [000…255]

38 S5-DPC 100100100 [001…255][000…255]
[000…255] {9
characters}

39 S5-SSN 000 [000…255]

40 S5-XLAT DPC [DPC, DPCSSN,
DPCNGT]

41 S5-RI GT [GT, SSN]

42 S5-NGT 0 [0…255]

43 S5-RGTA NO [YES, NO]

44 Block Termination See1

1The block termination field value is a new line character, which is generated by pressing the
Enter key on the keyboard.

Override GTT Input File - Delete Record
The override GTT delete record contains one record for each database entry.
Individual fields are pipe delimited with a new line (0x0A) after each GTT recorded.
Each entry should begin at the beginning of the line.
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Example Override GTT Delete Record File

DELETE|GTTGroup|9194690000

Table 4-11    Explanation of the Fields in the Override GTT Delete Record

Field Number Field Name Range of Values Values in Example

1 Delete record
recognition string

Characters {6
characters}

DELETE1

2 Group name [A-Z, a-z, 0-9] {64
alphanumeric}

GTTGroup

3 LRN [0-9]{10 digits} 9194690000

1This is the fixed string to be used for all delete records. An entry that does not begin with
DELETE, or one in which DELETE is misspelled, will be treated like a create or modify entry.

Creating or Modifying the File

To create or modify an override GTT input file:

1. Prepare the override GTT input file.

See Figure 4-17 for more information about the format of an override GTT input
file. See Table 4-10 for more information about the fields in an override GTT input
file. The override GTT input file extension must be .OGT.

Note:   It is not necessary to have all 4 Services (S1-S4) filled with data. Any
unused Service must have its unused data fields unpopulated, but with the
pipe delimiters as placeholders, because the data is positional.

2. Transfer the override GTT input file to the LSMS.

Transfer the file to the My Documents folder on the Windows desktop of your
computer.

Importing the File

To import the override GTT input file:

1. Log in to LSMS as a member of the permission group that is authorized to perform
this operation.

If you are logging into a shadow LSMS, see “Entering Locally Provisioned Data on
a Shadow LSMS”.

2. From the LSMS Console window, select LSMS > Input Data by File.

The Input Data by File window is displayed.

3. If the name of the input file does not appear in the Input File field, you can type it
in (specifying the complete path), or use the Browse button to find it.

4. Click the Start button.

This initiates the file validation phase.

Override GTT Input File
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Override GTT Result File
The Override GTT result file (which is located in the same directory as the input data
file) stores useful information about the processing of each of the Override GTT data
items read from the input data file while executing the file validation phase. A result
file with the format shown below is produced during file validation or input
processing phase.

For each correct data item read from the input file, a single line appears in the result
file:

SPID|GROUP|LRN Operation_Status

For each erroneous data item read from the input file, a single line appears in the
result file:

SPID|GROUP|LRN Operation_Status [Error_Number] [Error_Message]

where:

SPID = SPID value read from input data file

GROUP = GTT Group

LRN = The ten digits value input from file for each data item.

Operation_Status = OK to indicate a successful operation; FAILED to indicate an error
in processing.

Error_Number = An "E" followed by up to 3 numeric digits (this is an optional field, it
appears only if operation status is FAILED).

Error_Message = Text indicating the first processing error found in the data entry (this
is an optional field, it appears only if operation status is FAILED).

Example Override GTT Result File

Figure 4-18 shows a picture of an override GTT result file.
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Figure 4-18    Example Override GTT Result File.

Override GTT Error Codes

See Error Codes.

NPA-NXX Split Input File
The NPA-NXX split input file enables you to create or delete an NPA-NXX split.

Each data entry in the input file is checked to ensure that its format corresponds to the
input file specification. The data values will be validated using the same rules that are
presently used when entering a single NPA-NXX split via the LSMS GUI. Each entry
in the input data file is validate, successful entries and errors encountered are written
to the result file, and the validation of the next data entry continues. For deletions, if
the NPA-NXX split exists, it is deleted. If the NPA-NXX split object does not exist,
however, the delete request is logged as a success, not a failure, in the NPA-NXX split
result file.

Only if no errors are found in the entire input file will further processing continue. If
no errors are found, the data entries are added to the NpaSplit table of the LSMS
supplemental database.

The user-specified filename must have an extension of .NPA to be a valid input data
filename for NPA-NXX splits.

NPA-NXX Split Input File
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The NPA Split input file should be located at the client machine that is running LSMS
GUI. You can use a file selection dialog box to select the input file.

The file contains the data used to create new NPA-NXX instances.

The NPA-NXX Split input block contains one record for each database entry;
individual fields are pipe delimited, with a new line (0x0A) after each split record.
Each entry should begin at the beginning of the line.

Note:   To create a successful NPA-NXX split, all the data fields must be filled
in.

NPA-NXX Split Input File Example

Figure 4-19 is an example of an NPA-NXX Split input file with one entry. See 
Table 4-12 for an explanation of the fields.

Figure 4-19    Example NPA-NXX Split Input File

312|910|666|1|12|2007|5|17|2007

Table 4-12    NPA-NXX Split Input File Fields and Their Values

Field Number Field Name Range of Values Value in Example

1 Old NPA
[2-9][0-9][0-9] {3
digits}

312

2 New NPA
[2-9][0-9][0-9] {3
digits}

910

3 NXX Value
[0-9][0-9][0-9] {3
digits}

666

4 Start Date Month
[1-12] {2 digits
maximum}

1

5 Start Date Day
[1-31] {2 digits
maximum}

12

6 Start Date Year [0-9] {4 digits} 2007

7 End Date Month
[1-12] {2 digits
maximum}

5

8 End Date Day
[1-31] {2 digits
maximum}

17

9 End Date Year [0-9] {4 digits} 2007

10 Block Termination
New Line (press
Enter key)

0x0A

Note:   The New NPA value cannot begin with a “0” or “1”, and cannot end in
“11”.

NPA-NXX Split Input File
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NPA-NXX Split Input File - Delete Record
The NPA-NXX split delete record contains one record for each database entry.
Individual fields are pipe delimited with a new line (0x0A) after each NPA-NXX split
recorded. Each entry should begin at the beginning of the line.

Example NPA-NXX Split Delete Record File

DELETE|312|919|666

Table 4-13    Explanation of the Fields in the NPA-NXX Split Delete Record

Field Number Field Name Range of Values Values in Example

1 Delete record
recognition string

Characters {6
characters}

DELETE1

2 Old NPA [2-9][0-9][0-9] {3
digits}

312

3 New NPA [2-9][0-9][0-9] {3
digits}

919

4 NXX Value [0-9][0-9][0-9] {3
digits}

666

1This is the fixed string to be used for all delete records. An entry that does not begin with
DELETE, or one in which DELETE is misspelled, will be treated like a create or modify entry.

Creating or Modifying the File

To create an NPA-NXX split input file:

1. Prepare the NPA-NXX split input file.

See Figure 4-19 for more information about the format of an NPA-NXX split input
file. See Table 4-12 for more information about the fields in an NPA-NXX split input
file. The NPA-NXX split input file extension must be .NPA.

2. Transfer the NPA-NXX split input file to the LSMS.

Transfer the file to the My Documents folder on the Windows desktop of your
computer.

Importing the File

To import the NPA-NXX split input file:

1. Log in to LSMS as a member of the permission group that is authorized to perform
this operation.

If you are logging into a shadow LSMS, see “Entering Locally Provisioned Data on
a Shadow LSMS”.

2. From the LSMS Console window, select LSMS > Input Data by File.

The Input Data by File window appears.

3. If the name of the input file does not appear in the Input File field, you can type it
in (specifying the complete path), or use the Browse button to find it.

NPA-NXX Split Input File
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4. Click the Start button.

This initiates the file validation phase.

NPA-NXX Split Result File
The NPA-NXX split result file (which is located in the same directory as the input data
file) stores useful information about the processing of each of the NPA-NXX split data
items read from the input data file while in the file validation or input phase. A result
file with the format shown below is produced during file validation or input
processing phase.

For each correct data item read from the input file, a single line appears in the result
file:

Old_NPA|New_NPA|NXX Start_Date|End_Date Operation_Status

For each erroneous data item read from the input file, a single line appears in the
result file:

Old_NPA|New_NPA|NXX Start_Date|End_Date Operation_Status Error_Number
Error_Message

where:

Old_NPA = The three-digit value input from file for each data item.

New_NPA = The three-digit value input from file for each data item.

NXX = The three-digit value input from file for each data item.

Start_Date = The 10-digit Start Date of the Permissive Dialing Period.

End_Date = The 10-digit End Date of the Permissive Dialing Period.

Operation_Status = OK to indicate a successful operation; FAILED to indicate an error
in processing.

Error_Number = "E" followed by up to 3 numeric digits (this is an optional field, it
appears only if operation status is FAILED).

Error_Message = Text indicating the first processing error found in the data entry (this
is an optional field, it appears only if operation status is FAILED).

Example NPA-NXX Split Result File

Figure 4-20 shows a picture of an NPA-NXX split result file.
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Figure 4-20    Example NPA-NXX Split Result File

NPA-NXX Split Error Codes

See Error Codes.

Custom TN Filter Input File
The Custom TN Filter input file enables you to create, modify, or delete a Custom TN
Filter.

Each data entry in the input file is checked to ensure that the format corresponds to the
input file specification. The data values are validated using the same rules that are
presently used when entering a single Custom TN Filter via the LSMS GUI. The entire
input data file is validated, successful entries and errors encountered are written to the
result file, and the processing of the next data entry continues.

Only if no errors are encountered is further processing allowed by this feature, at
which time the data entries are added to the LSMS database Custom TN Filter table.

The user specified filename must have an extension of .TNF to be a valid Custom TN
Filter.

The NPA and/or the NPANXX value of each Custom TN Filter data entry in the file is
used to check if the Custom TN Filter object instance exists in the supported database.
If the Custom TN Filter object instance is not present, a new instance is created. If the
Custom TN Filter instance is present in the supported database, then the entire
Custom TN Filter object instance data is overwritten with the input file data for that
instance. For deletions, if the Custom TN Filter object exists, it is deleted. If the
Custom TN Filter object does not exist, however, the delete request is logged as a
success, not a failure, in the Custom TN Filter result file.

The Custom TN Filter input block contains one record for each database entry;
individual fields are pipe delimited, with a new line (0x0A) after each custom TN filter
record. Each entry should begin at the beginning of the line.

Custom TN Filter Input File
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Table 4-14    Custom TN Filter Input Block Contents

Field Number Field Name

1 Custom TN Filter name

2 Filter description

3 Filter type

4 onward NPA and/or NPANXX values (optional
values)

Custom TN Filter Input File Example

Figure 4-21 is an example of a Custom TN Filter input file with two entries. See 
Table 4-15 for an explanation of the fields.

Figure 4-21    Sample Custom TN Filter Input File

TNFilterName1|Filter 1 description|include|910|867|999
TNFilterName2|Filter 2 description|exclude|919|000|999

Table 4-15    Explanation of the Fields in the Custom TN Filter Input File

Field Number Field Name Value in Example Range of Values

1 Custom TN Filter
name

TNFilterName1 Max 64
alphanumeric
characters

2 Filter description Filter 1 description Any ASCII text
string

3 Filter type include [ exclude | include ]

4 onward NPA and/or
NPANXX values

910 867 999 [0-9]{3 or 6 digits}
Optional field

last Block Termination The block
termination field
value is a new line
character; it is
generated by
pressing the Enter
key on the keyboard.

Custom TN Filter Input File - Delete Record
The Custom TN Filter delete record contains one record for each database entry.
Individual fields are pipe delimited with a new line (0x0A) after each Custom TN
Filter recorded. Each entry should begin at the beginning of the line.

Example Custom TN Filter Delete Record File

DELETE|TNFilterName1

Custom TN Filter Input File
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Table 4-16    Explanation of the Fields in the Override GTT Delete Record

Field Number Field Name Range of Values Values in Example

1 Delete record
recognition string

Characters {6
characters}

DELETE1

2 Custom TN Filter
name

[A-Z, a-z, 0-9] {64
alphanumeric}

TNFilterName1

1This is the fixed string to be used for all delete records. An entry that does not begin with
DELETE, or one in which DELETE is misspelled, will be treated like a create or modify entry.

Creating or Modifying the Input File

To create a custom TN filter input file:

Note:   After you update the TN filter, run an audit for the EMSs utilizing that
TN filter. Use the NE Audit with Reconcile procedure (refer to the LNP
Database Synchronization User's Guide) for each NPA-NXX added or changed
and on each affected EMS to update the databases. However, depending on
the number of NPA-NXXs, the number of EMSs affected, and the physical
distance between the LSMS and the network element, a bulk download to
each affected EMS/network element may be more efficient. For more
information, refer to the LNP Database Synchronization User's Guide.

Note:   After making any changes to the custom TN filter, you must restart the
EAGLE agent for the changes to take effect.

1. Prepare the custom TN filter input file.

See Figure 4-21 for more information about the format of a custom TN filter input
file. See Table 4-15 for more information about the fields in a custom TN filter input
file. The custom TN filter input file extension must be .TNF.

2. Transfer the custom TN filter input file to the LSMS.

Transfer the file to the My Documents folder on the Windows desktop of your
computer.

Importing the File

To import the custom TN filter input file:

1. Log in to LSMS as a member of the permission group that is authorized to perform
this operation.

If you are logging into a shadow LSMS, see “Entering Locally Provisioned Data on
a Shadow LSMS”.

2. From the LSMS Console window, select LSMS > Input Data by File.

The Input Data by File window appears.

Custom TN Filter Input File
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3. If the name of the input file does not appear in the Input File field, you can type it
in (specifying the complete path), or use the Browse button to find it.

4. Click the Start button.

This initiates the file validation phase.

Custom TN Filter Result File
The Custom TN Filter result file (which is located in the same directory as the input
data file) stores useful information about the processing of each of the Custom TN
Filter data items read from the input data file while executing the file validation or
input phase. A result file with the format shown below is produced during file
validation or input processing phase.

For each correct data item read from the input file, a single line appears in the result
file:

Name|Operation_Status

For each erroneous data item read from the input file, a single line appears in the
result file:

Name|Operation_Status|Error_Number|Error_Message

where:

Name = Custom TN Filter Name.

Operation_Status = OK to indicate a successful operation; FAILED to indicate an error
in processing.

Error_Number = "E" followed by up to 3 numeric digits (this is an optional field, it
appears only if operation status is FAILED).

Error_Message = Text indicating the first processing error found in the data entry (this
is an optional field, it appears only if operation status is FAILED).

Example Custom TN Filter Result File

Figure 4-22 shows a picture of a custom TN filter result file.

Figure 4-22    Example Custom TN Filter Result from File Validation Phase

Custom TN Filter Error Codes

See Error Codes.
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Error Codes
Table 4-17 lists the error codes, messages, and causes that apply to the Input Data by
File processes for Default GTT, Override GTT, NPA-NXX Split, and Custom TN
Filters.

Table 4-17    Input Data by File Error Codes

Error Number Error Text Cause

0

Note:   Errors generated by
the supman process will be
logged with Error Number 0.
Some examples include:
• Cannot determine the

region for this split.
• Database Server

Timeout.

Internal processing error

52 Wrong number of values for
OPERATION|DATA TYPE
where OPERATION =
create/modify or delete and
DATA TYPE = DGT or OGT
or NPA Split or TN Filter

The specific data entry has
either too many or not
enough pipe delimited data
fields for a valid entry.

53 Invalid blank line for an
entry

A blank line was be inserted
into the file. Check the input
file for any blank lines. Check
the last entry in the input file
to make sure was NOT a
blank line.

100 Non-numeric date field value The date field value in the
input data entry is not
numeric. Check for illegal
characters.

101 Year value is required Year field value is empty.

102 Non-numeric year value The year field value in the
input data entry is not
numeric. Check for illegal
characters.

103 Invalid year value Year date field value must be
between 1979 and 9999.

104 Month value is required Month field value is empty.

Error Codes
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Table 4-17    (Cont.) Input Data by File Error Codes

Error Number Error Text Cause

105 Non-numeric month value The month field value in the
input data entry is not
numeric. Check for illegal
characters.

106 Invalid month value Month field value must be
between 1 and 12.

107 Day value is required Day field value is empty.

108 Non-numeric day value The day field value in the
input data entry is not
numeric. Check for illegal
characters.

109 Invalid day value Day field value must be
between 1979 and 9999.

120 Invalid GTT type GTT type field must be
include or exclude.

121 Translation Type Service
name is not unique

Translation type service
names must be unique
among all services.

122 Translation Type value is not
unique

Translation type values must
be unique among all services.

130 Service #: XLAT, RI, SSN and
NGT mismatch

The entry has a parameter
inconsistency in service
number (1-4). Note: The
block termination field value
is a new line character, which
is generated by pressing the
Enter key on the keyboard.

140 GTT Group name is required GTT Group field value is
empty.

141 Invalid GTT Group name
length

The GTT Group name is
greater than 40 characters.

142 Invalid GTT Group name The GTT Group name must
be composed of
alphanumeric characters.

150 LRN value is required The LRN field value is
empty.

Error Codes
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Table 4-17    (Cont.) Input Data by File Error Codes

Error Number Error Text Cause

151 Non-numeric LRN value The LRN field value in the
input data entry is not
numeric. Check for illegal
characters.

152 Invalid LRN value length The LRN value in the input
data file is not the required 10
digits length.

160 Service #: NGT value is
required

The NGT field value is
empty.

161 Service #: Non-numeric NGT
value

The NGT field value in the
input data entry is not
numeric. Check for illegal
characters.

162 Service #: Invalid NGT value The NGT field values are
illegal for service number
(1-4).

170 NPA value is required The NPA field value is
empty.

171 Non-numeric NPA value The NPA field value in the
input data entry is not
numeric. Check for illegal
characters.

172 Invalid NPA value The NPA field value is not
between 200 and 999.

180 NPA-NXX value is required The NPA-NXX field value is
empty.

181 Non-numeric NPA-NXX
value

The NPA-NXX field value in
the input data entry is not
numeric. Check for illegal
characters.

182 Invalid NPA-NXX value The NPA-NXX field value is
not between 200000 and
999999.

190 NPA-NXX-X value is
required

The NPA-NXX-X field value
is empty.

191 Non-numeric NPA-NXX-X
value

The NPA-NXX-X field value
in the input data entry is not
numeric. Check for illegal
characters.

Error Codes
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Table 4-17    (Cont.) Input Data by File Error Codes

Error Number Error Text Cause

192 Invalid NPA-NXX-X value The NPA-NXX-X field value
is not between 200000 and
999999.

200 Old and New NPA values
cannot be identical

The NPA-NXX split input
data entry contains an Old
NPA value that equals the
New NPA Value (this is not
allowed).

201 Start date must be equal to or
after current date

The start date precedes the
current date.

202 End date must be after start
date

The end date precedes or
equals the start date.

203 End date must be after the
current date

The end date precedes or
equals the current date.

210 NXX value is required The NXX field value is
empty.

211 Non-numeric NXX value The NXX field value in the
input data entry is not
numeric. Check for illegal
characters.

212 Invalid NXX value The NXX field value is not
between 0 and 999.

221 Service #: Non-ANSI
conforming point code value

The entry read from the input
file DPC value has one of the
following errors:

1-DPC value of 000-XXX-
XXX which is invalid.

2- DPC value of 001-000-XXX
through 005-000-XXX

3- DPC field must be
composed of only the digits
0-9 with a maximum value of
255-255-255.

For service number (1-4).

222 Service #: Point code:
<component> component is
invalid.

The point code component
field value is not between 0
and 255.

230 Service #: RGTA value is
required

RGTA field value is empty.

Error Codes
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Table 4-17    (Cont.) Input Data by File Error Codes

Error Number Error Text Cause

231 Service #: Invalid RGTA
value

The RGTA field value is not
YES or NO .

240 Service #: RI value is required RI field value is empty.

241 Service #: Invalid RI value The RI field value is not GT
or SSN .

250 Service provider ID is
required

SPID field value is empty.

251 Invalid Service Provider ID
value length

SPID must be 4
alphanumerical characters.

252 Invalid Service Provider ID
value length

SPID field value is not the
required 4 alphanumerical
length.

260 Service #: SSN value is
required

The SSN field value is empty.

261 Service #: Non-numeric SSN
value

The SSN field value in the
input data entry is not
numeric. Check for illegal
characters.

262 Service #: Invalid SSN value The SSN field value is not 0
or between 2 and 255.

270 TN value is required The TN field value is empty.

271 Non-numeric TN value The TN field value in the
input data entry is not
numeric. Check for illegal
characters.

272 Invalid TN value length The TN value in the input
data file is not the required 10
digits length.

280 TN filter name is required TN Filter Name field value is
empty.

281 Invalid TN filter name length TN Filter Name field value
must be 40 or less
alphanumeric characters.

282 Invalid TN filter name TN Filter Name field value
must be 40 or less
alphanumeric characters.

Error Codes
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Table 4-17    (Cont.) Input Data by File Error Codes

Error Number Error Text Cause

283 Invalid TN filter description
length

TN Filter Description field
value must be 255 or less
alphanumeric characters.

284 Invalid TN filter type TN Filter Type field value
must be include or exclude.

286 Overlapping TN filter data TN filter NPA and NPA-NXX
ranges cannot overlap.

287 Duplicate TN filter data TN Filter NPANXX field
values already exist.

300 Service #: TT value is
required

The TT field value is empty.

301 Service #: Non-numeric TT
value

The TT field value in the
input data entry is not
numeric. Check for illegal
characters.

302 Service #: Invalid TT value The TT field value is not
between 1 and 255.

310 Service #: TT Service Name is
required

TT Service Name field value
is empty.

311 Service #: Invalid TT services
name value

The TT Service Name field
value is not CLASS ,
CNAM , LIDB , ISVM , or
WSMSC .

312 Invalid Message Relay TT
service Name - WSMSC,
WSMSC feature is not
activated

WSMSC Message Relay TT
service is only valid when the
WSMSC feature is activated.

313 Either AIN or IN or at least
one service must be
populated

A valid default GTT entry
must have either one of the
services fully populated or
AIN or IN field entry.

314 At least one service must be
populated

A valid override GTT entry
must have at least one of the
services fully populated.

Error Codes
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Table 4-17    (Cont.) Input Data by File Error Codes

Error Number Error Text Cause

320 Service #: Translation Type
name is not unique

The data entry contains two
or more of the translation
types that are not unique.
Note: The block termination
field value is a new line
character, which is generated
by pressing the Enter key on
the keyboard.

321 Service #: Translation Type
value not unique

The data entry contains two
or more of the translation
type values that are not
unique.

330 Service #: XLAT value is
required

XLAT field value is empty.

331 Service #: Invalid XLAT value The XLAT field value is not
DPC , DPCSSN , or
DPCNGT .

Error Codes
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5
LSMS Reports

This chapter contains procedures for generating, viewing, and printing LSMS reports
in a predefined format. It also contains information about the Report Generator, which
enables you to create customized LSMS reports.

Introduction
This chapter provides general information about viewing reports in a browser
window. It also provides specific, step-by-step procedures for creating, viewing, and
deleting the following types of pre-formatted LSMS reports.

Note:   

You can generate up to ten reports at a time using the Reports menu item.

• Service Provider Administrative Data

• Service Provider Network Data

• EMS Configuration Data

• Default GTT Data

• Override GTT Data

• NPA Split Data

• LSMS Subscriptions by LRN Data

• LSMS Subscriptions by Service Provider Data

• LSMS Number Pool Blocks by LRN Data

• LSMS Number Pool Blocks by Service Provider Data

• Service Provider Data

• Permission Group Data

Procedures to help you create, view, and delete each type of report follow this
introductory section, beginning with “Service Provider Administrative Data Reports”.

This chapter also provides information about the Report Generator, which enables
you to customize your own reports.

Viewing Reports

The browser from which you launched the GUI is used to display the reports.
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A new browser window opens for the first report that you view, and is reused for
viewing all subsequent reports.

Use the browser file functions to perform desired tasks, such as printing, searching,
and exiting.

Service Provider Administrative Data Reports
The following procedures explain how to create, view, and delete Service Provider
Administrative Data reports.

Creating a Service Provider Administrative Data Report

To create a Service Provider Administrative Data report:

1. Log in to LSMS as a member of the permission group that is authorized to perform
this operation.

2. From the LSMS Console window, select Reports > Service Provider
Administrative Data .

Figure 5-1    Reports Pull-Down List

The Service Provider Administrative Data Report Create window appears.

3. In the File field, enter a file name for the report to be generated.

Click OK or Apply. The report automatically runs in background mode and does
not interfere with LSMS processing tasks such as NPAC traffic processing.

4. An Update Successful message window appears.

5. Click OK to view the report.

Viewing a Service Provider Administrative Data Report

To view a Service Provider Administrative Data report:

1. Log in to LSMS as a member of the permission group that is authorized to perform
this operation.

2. From the LSMS Console window, select Reports > Service Provider
Administrative Data .

Service Provider Administrative Data Reports
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The Service Provider Administrative Data Report Create window appears.

3. Select the View tab.

The Service Provider Administrative Data Report View window appears.

4. In the File field, enter the name of the report to be viewed or click the Browse
button to select a report.

Click OK or Apply.

5. The report output window displays.

Deleting a Service Provider Administrative Data Report

To delete a Service Provider Administrative Data report:

1. Log in to LSMS as a member of the permission group that is authorized to perform
this operation.

2. From the LSMS Console window, select Reports > Service Provider
Administrative Data).

The Service Provider Administrative Data Report Create window appears.

3. Select the Delete tab.

The Service Provider Administrative Data Report Delete window appears.

4. In the File field, enter the name of the report to be deleted or click the Browse
button to select a report.

Click OK or Apply.

5. A Confirm Delete message window appears.

Figure 5-2    Confirm Delete Message Window

6. Click Yes or No.

If you click Yes, an Update Successful message window appears. Click OK to
return to the Service Provider Administrative Data Report Delete window.

Service Provider Administrative Data Reports

LSMS Reports  5-3



Figure 5-3    Update Successful Message Window

7. If you click No, you return to the Service Provider Administrative Data Report
Delete window.

Service Provider Network Data Reports
The following procedures explain how to create, view, and delete Service Provider
Network Data reports.

Creating a Service Provider Network Data Report

To create a Service Provider Network Data report:

1. Log in to LSMS as a member of the permission group that is authorized to perform
this operation.

2. From the LSMS Console window, select Reports > Service Provider Network
Data .

The Service Provider Network Data Report Create window appears.

Figure 5-4    Service Provider Network Data Report Create Window

Service Provider Network Data Reports
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3. In the Service Provider ID field, enter the Service Provider ID (SPID), if desired
(this field is optional).

Note:   See Creating a Permission Group Data Report for the report contents
that are selected and displayed depending upon whether you specify a value
for the optional SPID parameter.

Table 5-1    Using the Optional SPID Parameter (Service Provider Network Data
Report)

SPID Value Specified? Report Contents Displayed

N All LRN, NPA-NXX, and NPA-NXX-X
records

Y LRN, NPA-NXX, and NPA-NXX-X records
containing specified SPID value only

4. In the File field, enter a file name for the report to be generated.

Click OK or Apply. The report automatically runs in background mode and does
not interfere with LSMS processing tasks such as NPAC traffic processing.

5. An Update Successful message window appears.

6. Click OK to view an example of the report.

Note:   A Service Provider ID value of UNKN indicates that the Service
Provider information for the particular object could not be found because of
an object relationship mismatch. If this occurs, call the My Oracle Support
(MOS).

Figure 5-5    Service Provider Network Data Report Example

Viewing a Service Provider Network Data Report

To view a Service Provider Network Data report:

1. Log in to LSMS as a member of the permission group that is authorized to perform
this operation.

2. From the LSMS Console window, select Reports > Service Provider Network
Data .

The Service Provider Network Data Report Create window appears.

Service Provider Network Data Reports
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3. Select the View tab.

The Service Provider Network Data Report View window appears.

4. In the File field, enter the name of the report to be viewed or click the Browse
button to select a report.

Click OK or Apply.

5. The report output window displays.

Deleting a Service Provider Network Data Report

To delete a Service Provider Network Data report:

1. Log in to LSMS as a member of the permission group that is authorized to perform
this operation.

2. From the LSMS Console window, select Reports > Service Provider Network
Data .

The Service Provider Network Data Report Create window appears.

3. Select the Delete tab.

The Service Provider Network Data Report Delete window appears.

4. In the File field, enter the name of the report to be deleted or click the Browse
button to select a report.

Click OK or Apply.

5. A Confirm Delete message window appears.

6. Click Yes or No.

If you click Yes, an Update Successful message window appears. Click OK to
return to the Service Provider Network Data Report Delete window.

7. If you click No, you return to the Service Provider Network Data Report Delete
window.

EMS Configuration Data Reports
The following procedures explain how to create, view, and delete EMS Configuration
Data reports.

Creating an EMS Configuration Data Report

To create an Element Management System Configuration Data report:

1. Log in to LSMS as a member of the permission group that is authorized to perform
this operation.

2. From the LSMS Console window, select Reports > EMS Configuration Data.

The EMS Configuration Data Report Create window appears.

3. In the File field, enter a file name for the report to be generated.

EMS Configuration Data Reports
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Click OKor Apply. The report automatically runs in background mode and does
not interfere with LSMS processing tasks such as NPAC traffic processing.

4. An Update Successful message window appears.

5. Click OK to view an example of the report.

Figure 5-6    EMS Configuration Data Report Example

Viewing an EMS Configuration Data Report

To view an EMS Configuration Data report:

1. Log in to LSMS as a member of the permission group that is authorized to perform
this operation.

2. From the LSMS Console window, select Reports > EMS Configuration Data .

The EMS Configuration Data Report Create window appears.

EMS Configuration Data Reports
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3. Select the View tab.

The EMS Configuration Data Report View window appears.

4. In the File field, enter the name of the report to be viewed or click the Browse
button to select a report.

Click OKor Apply.

5. The report output window displays.

Deleting an EMS Configuration Data Report

To delete an EMS Configuration Data report:

1. Log in to LSMS as a member of the permission group that is authorized to perform
this operation.

2. From the LSMS Console window, select Reports > EMS Configuration Data.

The EMS Configuration Data Report Create window appears.

3. Select the Delete tab.

The EMS Configuration Data Report Delete window appears.

4. In the File field, enter the name of the report to be deleted or click the Browse
button to select a report.

Click OKor Apply.

5. A Confirm Delete message window appears.

6. Click Yes or No.

If you click Yes, an Update Successful message window appears. Click OK to
return to the EMS Configuration Data Report Delete window.

7. If you click No, you return to the EMS Configuration Data Report Delete window.

Default GTT Data Reports
This section contains information about Query GTT by DPC, which enables you to
retrieve certain global title translation (GTT) information for a specific destination
point code (DPC). This section also includes procedures that explain how to create,
view, and delete Default GTT Data reports.

Query GTT by DPC

Query GTT by DPC enables you to retrieve the following global title translation
(GTT) information for a specific destination point code (DPC).

• Numbering Plan Area-Number Exchange (NPA-NXX) default data

• Location Routing Number (LRN) override data

The report contains all the fields included in reports generated by prior releases of
LSMS, but includes only those entries for NPA-NXX translations associated with the
specified DPC.

Default GTT Data Reports
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You can use this information to verify the accuracy of locally provisioned global title
data and to determine impacted translations for various network changes.

Creating a Default GTT Data Report

To create a Default GTT Data report:

1. Log in to LSMS as a member of the permission group that is authorized to perform
this operation.

2. From the LSMS Console window, select Reports > Default GTT.

The Default GTT Data Report Create window appears.

3. Make a selection from the Service Provider ID listbox.

In the DPC (Destination Point Code) field, enter a specific destination point code, if
desired (this field is optional). See Table 5-2 for the report contents that are selected
and displayed depending upon whether you specify a value for the optional DPC
parameter.

Table 5-2    Using the Optional DPC Parameter (Default GTT Report)

DPC Value Specified? Report Contents Displayed

N Default Translation records containing
specified SPID value only

Y Default Translation records containing
specified SPID and DPC values only

4. In the File field, enter a file name for the report to be generated.

Click OKor Apply. The report automatically runs in background mode and does
not interfere with LSMS processing tasks such as NPAC traffic processing.

5. An Update Successful message window appears.

6. Click OK to view an example of the report.

Note:   A value of UNKN in the SPID column indicates that information for
the particular object could not be found because of an object relationship
mismatch. If this occurs, call the My Oracle Support (MOS).

Default GTT Data Reports
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Figure 5-7    Default GTT Report Example

Viewing a Default GTT Data Report

To view a Default GTT Data report:

1. Log in to LSMS as a member of the permission group that is authorized to perform
this operation.

2. From the LSMS Console window, select Reports > Default GTT.

The Default GTT Data Report Create window appears.

3. Select the View tab.

The Default GTT Data Report View window appears.

4. In the File field, enter the name of the report to be viewed or click the Browse
button to select a report.

Click OK or Apply.

5. The report output window appears.

Deleting a Default GTT Data Report

To delete a Default GTT Data report:

1. Log in to LSMS as a member of the permission group that is authorized to perform
this operation.

2. From the LSMS Console window, select Reports > Default GTT.

The Default GTT Data Report Create window appears.

3. Select the Delete tab.

The Default GTT Data Report Delete window appears.

Default GTT Data Reports
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4. In the File field, enter the name of the report to be deleted or click the Browse
button to select a report.

Click OK or Apply.

5. A Confirm Delete message window appears.

6. Click Yes or No.

If you click Yes, an Update Successful message window appears. Click OK to
return to the Default GTT Data Report Delete window.

7. If you click No, you return to the Default GTT Data Report Delete window.

Override GTT Data Reports
This section contains information about Query GTT by DPC, which enables you to
retrieve certain global title translation (GTT) information for a specific destination
point code (DPC). This section also includes procedures that explain how to create,
view, and delete Override GTT Data reports.

Query GTT by DPC

Query GTT by DPC enables you to retrieve the following global title translation
(GTT) information for a specific destination point code (DPC).

• Numbering Plan Area-Number Exchange (NPA-NXX) default data

• Location Routing Number (LRN) override data

The report contains all the fields included in reports generated by prior releases of
LSMS, but includes only those entries for NPA-NXX translations associated with the
specified DPC.

You can use this information to verify the accuracy of locally provisioned global title
data and to determine impacted translations for various network changes.

Creating an Override GTT Data Report

To create an Override GTT Data report:

1. Log in to LSMS as a member of the permission group that is authorized to perform
this operation.

2. From the LSMS Console window, select Reports > Override GTT.

The Override GTT Data Report Create window appears.

Override GTT Data Reports
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Figure 5-8    Override GTT Data Report Create Window

3. Make a selection from the Service Provider ID listbox.

In the DPC (Destination Point Code) field, enter a specific destination point code, if
desired (this field is optional). See Table 5-3 for the report contents that are selected
and displayed depending upon whether you specify a value for the optional DPC
parameter.

Table 5-3    Using the Optional DPC Parameter (Override GTT Report)

DPC Value Specified? Report Contents Displayed

N Override Translation records containing
specified SPID value only

Y Override Translation records containing
specified SPID and DPC values only

4. In the File field, enter a file name for the report to be generated.

Click OK or Apply. The report automatically runs in background mode and does
not interfere with LSMS processing tasks such as NPAC traffic processing.

5. An Update Successful message window appears.

6. Click OK to view an example of the report.

Override GTT Data Reports
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Figure 5-9    Override GTT Report Example

Viewing an Override GTT Data Report

To view an Override GTT Data report:

1. Log in to LSMS as a member of the permission group that is authorized to perform
this operation.

2. From the LSMS Console window, select Reports > Override GTT

The Override GTT Data Report Create window appears.

3. Select the View tab.

The Override GTT Data Report View window appears.

4. In the File field, enter the name of the report to be viewed or click the Browse
button to select a report.

Click OK or Apply.

5. The report output window displays.

Deleting an Override GTT Data Report

To delete an Override GTT Data report:

1. Log in to LSMS as a member of the permission group that is authorized to perform
this operation.

2. From the LSMS Console window, select Reports > Override GTT

The Override GTT Data Report Create window appears.

Override GTT Data Reports
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3. Select the Delete tab.

The Override GTT Data Report Delete window appears.

4. In the File field, enter the name of the report to be deleted or click the Browse
button to select a report.

Click OK or Apply.

5. A Confirm Delete message window appears.

6. Click Yes or No.

If you click Yes, an Update Successful message window appears. Click OK to
return to the Override GTT Data Report Delete window.

7. If you click No, you return to the Override GTT Data Report Delete window.

NPA Split Data Reports
The following procedures explain how to create, view, and delete NPA Split Data
reports.

Creating NPA Split Data Reports

To create an NPA Split Data report:

1. Log in to LSMS as a member of the permission group that is authorized to perform
this operation.

2. From the LSMS Console window, select Reports > NPA Split Data, and then select
Create.

The NPA Split Data Report Create window appears.

3. In the Status field, select the appropriate status.

The options available are All Statuses, Active, Pending, and Activation Failed.

NPA Split Data Reports
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Figure 5-10    NPA Split Data Report Statuses

4. In the NPAC Region field, select the desired region (or All NPAC Regions) for
which you require information.

Figure 5-11    NPA Split Data NPAC Regions

5. In the File field, enter a file name for the report to be generated.

NPA Split Data Reports
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Click OK or Apply. The report automatically runs in background mode and does
not interfere with LSMS processing tasks such as NPAC traffic processing.

6. An Update Successful message window appears.

7. Click OK to view an example of the report.

Figure 5-12    NPA Split Data Report Example

Viewing NPA Split Data Reports

To view an NPA Split Data report:

1. Log in to LSMS as a member of the permission group that is authorized to perform
this operation.

2. From the LSMS Console window, select Reports > NPA Split Data, and then select
View.

The NPA Split Data Report View window appears.

3. In the File field, enter the name of the report to be viewed or click the Browse
button to select a report.

Click OK or Apply.

4. The report output window displays.

Deleting NPA Split Data Reports

To delete an NPA Split Data report:

NPA Split Data Reports
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1. Log in to LSMS as a member of the permission group that is authorized to perform
this operation.

2. From the LSMS Console window, select Reports > NPA Split Data, and then select
Delete.

The NPA Split Data Report Delete window appears.

3. In the File field, enter the name of the report to be deleted or click the Browse
button to select a report.

Click OK or Apply.

4. A Confirm Delete message window appears.

5. Click Yes or No.

If you click Yes, an Update Successful message window appears. Click OK to
return to the NPA Split Data Report Delete window.

6. If you click No, you return to the NPA Split Data Report Delete window.

NPAC Audit Report
The iconectiv NPAC configuration options/features for each region include:

$ lsmsdb -c features | grep ICONECTIV
              N  CANADA_ICONECTIV
              N  MIDATLANTIC_ICONECTIV
              N  MIDWEST_ICONECTIV
              N  NORTHEAST_ICONECTIV
              N  SOUTHEAST_ICONECTIV
              N  SOUTHWEST_ICONECTIV
              N  WESTCOAST_ICONECTIV
              N  WESTERN_ICONECTIV

The value of these features can be changed using the dbcfginternal utility.

The audit script identifies the enabled NPAC regions and the corresponding NPAC
and logs them:

$ auditnpac
Audit is started
Audit complete. Check /var/TKLC/lsms/logs/trace/npacAudit.log.1001 for results

$ cat /var/TKLC/lsms/logs/trace/npacAudit.log.1001
********** NPAC Audit Started **********

Total number of NPAC regions connected : 7

Npacagent MidAtlantic is running
Npacagent MidAtlantic is connected to Neustar

Npacagent Northeast is running
Npacagent Northeast is connected to iconectiv

Npacagent Southeast is running
Npacagent Southeast is connected to Neustar

Npacagent Southwest is running
Npacagent Southwest is connected to Neustar

NPAC Audit Report
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Npacagent Western is running
Npacagent Western is connected to Neustar

Npacagent WestCoast is running
Npacagent WestCoast is connected to Neustar

Npacagent Midwest is running
Npacagent Midwest is connected to iconectiv

Total 2 regions are connected to iconectiv and 5 are connected to Neustar.

********** NPAC Audit Is Complete **********

LSMS Subscriptions by LRN Reports
The following procedures explain how to create, view, and delete LSMS Subscriptions
by LRN reports.

Creating an LSMS Subscription by LRN Report

To create an LSMS Subscription by LRN report:

1. Log in to LSMS as a member of the permission group that is authorized to perform
this operation.

2. From the LSMS Console window, select Reports > LSMS Subscriptions by LRN
Data.

The LSMS Subscriptions by LRN Report Create window appears.

3. In the Local Routing Number field, if desired, enter the LRN of the subscriptions
to be reported.

This is an optional field.

4. In the TN Range field, if desired, enter the TN range.

This is an optional field.

a. If no TN range is specified, then all Subscription Version records that satisfy the
LRN filter are displayed, regardless of its TN.

b. If only the Start TN is specified, then all Subscription Version records with a TN
equal to the Start TN, and that satisfy the LRN filter (if any), are displayed.

c. If both the Start TN and End TN are specified, then all Subscription Version
records with a TN between the Start TN and the End TN, and that satisfy the
LRN filter (if any), are displayed.

5. In the File field, enter a file name for the report to be generated.

Click OK or Apply. The report automatically runs in background mode and does
not interfere with LSMS processing tasks such as NPAC traffic processing.

6. An Update Successful message window appears.

7. Click OK to view an example of the report.
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Figure 5-13    LSMS Subscriptions by LRN Report Example

Viewing an LSMS Subscription by LRN Report

To view an LSMS Subscription by LRN report:

1. Log in to LSMS as a member of the permission group that is authorized to perform
this operation.

2. From the LSMS Console window, select Reports > LSMS Subscriptions by LRN
Data.

The LSMS Subscriptions by LRN Report Create window appears.

3. Select the View tab.

The LSMS Subscriptions by LRN Report View window appears.

4. In the File field, enter the name of the report to be viewed or click the Browse
button to select a report.

Click OK or Apply.

5. The report output window displays.
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Deleting an LSMS Subscription by LRN Report

To delete an LSMS Subscription by LRN report:

1. Log in to LSMS as a member of the permission group that is authorized to perform
this operation.

2. From the LSMS Console window, select Reports > LSMS Subscriptions by LRN
Data.

The LSMS Subscriptions by LRN Report Create window appears.

3. Select the Delete tab.

The LSMS Subscriptions by LRN Report Delete window appears.

4. In the File field, enter the name of the report to be deleted or click the Browse
button to select a report.

Click OK or Apply.

5. A Confirm Delete message window appears.

6. Click Yes or No.

If you click Yes, an Update Successful message window appears. Click OK to
return to the LSMS Subscriptions by LRN Report Delete window.

7. If you click No, you return to the LSMS Subscriptions by LRN Report Delete
window.

LSMS Subscriptions by Service Provider Data Reports
The following procedures explain how to create, view, and delete LSMS Subscriptions
by Service Provider Data reports.

Creating an LSMS Subscription by Service Provider Data Report

To create an LSMS Subscription by Service Provider Data report:

1. Log in to LSMS as a member of the permission group that is authorized to perform
this operation.

2. From the LSMS Console window, select Reports > LSMS Subscriptions by Service
Provider Data.

The LSMS Subscriptions by Service Provider Report Create window appears.
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Figure 5-14    LSMS Subscriptions by Service Provider Report Create Window

3. In the Service Provider ID field, enter the desired SPID.

4. In the TN Range field, enter the desired TN range.

This is an optional field.

a. If no TN range is specified, then all Subscription Version records that satisfy the
Service Provider filter are displayed, regardless of its TN.

b. If only the Start TN is specified, then all Subscription Version records with a TN
equal to the Start TN, and that satisfy the Service Provider filter (if any), are
displayed.

c. If both the Start TN and End TN are specified, then all Subscription Version
records with a TN between the Start TN and the End TN, and that satisfy the
Service Provider filter (if any), are displayed.

5. In the File field, enter a file name for the report to be generated.

Click OK or Apply. The report automatically runs in background mode and does
not interfere with LSMS processing tasks such as NPAC traffic processing.

6. An Update Successful message window appears.

7. Click OK to view an example of the report.
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Figure 5-15    LSMS Subscriptions by Service Provider Data Report Example

Viewing an LSMS Subscription by Service Provider Data Report

To view an LSMS Subscription by Service Provider Data report:

1. Log in to LSMS as a member of the permission group that is authorized to perform
this operation.

2. From the LSMS Console window, select Reports > LSMS Subscriptions by Service
Provider Data.
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The LSMS Subscriptions by Service Provider Report Create window appears.

3. Select the View tab.

The LSMS Subscriptions by Service Provider Report View window appears.

4. In the File field, enter the name of the report to be viewed or click the Browse
button to select a report.

Click OK or Apply.

5. The report output window displays.

Deleting an LSMS Subscription by Service Provider Data Report

To delete an LSMS Subscription by Service Provider Data report:

1. Log in to LSMS as a member of the permission group that is authorized to perform
this operation.

2. From the LSMS Console window, select Reports > LSMS Subscriptions by Service
Provider Data.

The LSMS Subscriptions by Service Provider Report Create window appears.

3. Select the Delete tab.

The LSMS Subscriptions by Service Provider Report Delete window appears.

4. In the File field, enter the name of the report to be deleted or click the Browse
button to select a report.

Click OK or Apply.

5. A Confirm Delete message window appears.

6. Click Yes or No.

If you click Yes, an Update Successful message window appears. Click OK to
return to the LSMS Subscriptions by Service Provider Report Delete window.

7. If you click No, you return to the LSMS Subscriptions by Service Provider Report
Delete window.

LSMS Number Pool Blocks by LRN Data Reports
The following procedures explain how to create, view, and delete LSMS Number Pool
Blocks by LRN Data reports.

Creating an LSMS Number Pool Block by LRN Data Report

To create an LSMS Number Pool Block by LRN Data report:

1. Log in to LSMS as a member of the permission group that is authorized to perform
this operation.

2. From the LSMS Console window, select Reports > LSMS Number Pool Blocks by
LRN Data.

The LSMS Number Pool Blocks by LRN Report Create window appears.
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Figure 5-16    LSMS Number Pool Blocks by LRN Report Create Window

3. In the Local Routing Number field, if desired, enter the LRN of the subscriptions
to be reported.

This is an optional field.

4. In the NPA-NXX-X Range field, enter the appropriate information.

The NPA-NXX-X Range field is optional.

a. If no NPA-NXX-X range is specified, then all Number Pool Block records that
satisfy the LRN filter are displayed, regardless of its NPA-NXX-X.

b. If only the Start NPA-NXX-X is specified, then all Number Pool Block records
with a NPA-NXX-X equal to the Start NPA-NXX-X, and that satisfy the LRN
filter (if any), are displayed.

c. If both the Start NPA-NXX-X and End NPA-NXX-X are specified, then all
Number Pool Block records with a NPA-NXX-X between the Start NPA-NXX-X
and the End NPA-NXX-X, and that satisfy the LRN filter (if any), are displayed.

5. In the File field, enter a file name for the report to be generated.

Click OK or Apply. The report automatically runs in background mode and does
not interfere with LSMS processing tasks such as NPAC traffic processing.

6. An Update Successful message window appears.

7. Click OK to view an example of the report.
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Figure 5-17    LSMS Number Pool Blocks by LRN Report Window

Viewing an LSMS Number Pool Block by LRN Data Report

To view an LSMS Number Pool Block by LRN Data report:

1. Log in to LSMS as a member of the permission group that is authorized to perform
this operation.

2. From the LSMS Console window, select Reports > LSMS Number Pool Blocks by
LRN Data.

The LSMS Number Pool Blocks by LRN Report Create window appears.

3. Select the View tab.

The LSMS Number Pool Blocks by LRN Report View window appears.

4. In the File field, enter the name of the report to be viewed or click the Browse
button to select a report.

Click OK or Apply.

5. The report output window displays.

Deleting an LSMS Number Pool Block by LRN Data Report

To delete an LSMS Number Pool Block by LRN Data report:

1. Log in to LSMS as a member of the permission group that is authorized to perform
this operation.

2. From the LSMS Console window, select Reports > LSMS Number Pool Blocks by
LRN Data.

The LSMS Number Pool Blocks by LRN Report Create window appears.
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3. Select the Delete tab.

The LSMS Number Pool Blocks by LRN Report Delete window appears.

4. In the File field, enter the name of the report to be deleted or click the Browse
button to select a report.

Click OK or Apply.

5. A Confirm Delete message window appears.

6. Click Yes or No.

If you click Yes, an Update Successful message window appears. Click OK to
return to the LSMS Number Pool Blocks by LRN Report Delete window.

7. If you click No, you return to the LSMS Number Pool Blocks by LRN Report Delete
window.

LSMS Number Pool Blocks by Service Provider Data Reports
The following procedures explain how to create, view, and delete LSMS Number Pool
Blocks by Service Provider Data reports.

Creating an LSMS Number Pool Block by Service Provider Data Report

To create an LSMS Number Pool Block by Service Provider Data report:

1. Log in to LSMS as a member of the permission group that is authorized to perform
this operation.

2. From the LSMS Console window, select Reports > LSMS Number Pool Blocks by
Service Provider Data.

The LSMS Number Pool Blocks by Service Provider Report Create window
appears.
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Figure 5-18    LSMS Number Pool Blocks by Service Provider Report Create
Window

3. In the Service Provider ID field, enter the desired SPID.

4. In the NPA-NXX-X Range field, enter the appropriate information.

The NPA-NXX-X Range field is optional.

a. If no NPA-NXX-X range is specified, then all Number Pool Block records that
satisfy the Service Provider filter are displayed, regardless of its NPA-NXX-X.

b. If only the Start NPA-NXX-X is specified, then all Number Pool Block records
with a NPA-NXX-X equal to the Start NPA-NXX-X, and that satisfy the Service
Provider filter (if any), are displayed.

c. If both the Start NPA-NXX-X and End NPA-NXX-X are specified, then all
Number Pool Block records with a NPA-NXX-X between the Start NPA-NXX-X
and the End NPA-NXX-X, and that satisfy the Service Provider filter (if any), are
displayed.

5. In the File field, enter a file name for the report to be generated.

Click OK or Apply. The report automatically runs in background mode and does
not interfere with LSMS processing tasks such as NPAC traffic processing.

6. An Update Successful message window appears.

7. Click OK to view an example of the report.
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Figure 5-19    LSMS Number Pool Blocks by Service Provider Data Window

Viewing an LSMS Number Pool Block by Service Provider Data Report

To view an LSMS Number Pool Block by Service Provider Data report:

1. Log in to LSMS as a member of the permission group that is authorized to perform
this operation.

2. From the LSMS Console window, select Reports > LSMS Number Pool Blocks by
Service Provider Data.

The LSMS Number Pool Blocks by Service Provider Report Create window
appears.

3. Select the View tab.

The LSMS Number Pool Blocks by Service Provider Report View window appears.

4. In the File field, enter the name of the report to be viewed or click the Browse
button to select a report.

Click OK or Apply.

5. The report output window displays.

Deleting an LSMS Number Pool Block by Service Provider Data Report

To delete an LSMS Number Pool Block by Service Provider Data report:

1. Log in to LSMS as a member of the permission group that is authorized to perform
this operation.

2. From the LSMS Console window, select Reports > LSMS Number Pool Blocks by
Service Provider Data.

The LSMS Number Pool Blocks by Service Provider Report Create window
appears.
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3. Select the Delete tab.

The LSMS Number Pool Blocks by Service Provider Report Delete window
appears.

4. In the File field, enter the name of the report to be deleted or click the Browse
button to select a report.

Click OK or Apply.

5. A Confirm Delete message window appears.

6. Click Yes or No.

If you click Yes, an Update Successful message window appears. Click OK to
return to the LSMS Number Pool Blocks by Service Provider Report Delete
window.

7. If you click No, you return to the LSMS Number Pool Blocks by Service Provider
Report Delete window.

Service Provider Data Reports
The following procedures explain how to create, view, and delete Service Provider
Data reports.

Creating a Service Provider Data Report

To create a Service Provider Data report:

1. Log in to LSMS as a member of the permission group that is authorized to perform
this operation.

2. From the LSMS Console window, select Reports > Service Provider Data.

The Service Provider Data Report Create window appears.
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Figure 5-20    Service Provider Data Report Create Window

3. In the NPAC Region field, select the desired region (or All NPAC Regions) for
which you require information.

Figure 5-21    Service Provider Data Report NPAC Regions

4. In the File field, enter a file name for the report to be generated.

Click OK or Apply. The report automatically runs in background mode and does
not interfere with LSMS processing tasks such as NPAC traffic processing.

5. An Update Successful message window appears.
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6. Click OK to view an example of the report.

Figure 5-22    Service Provider Data Report Window

Viewing a Service Provider Data Report

To view a Service Provider Data report:

1. Log in to LSMS as a member of the permission group that is authorized to perform
this operation.

2. From the LSMS Console window, select Reports > Service Provider Data .

The Service Provider Data Report Create window appears.

3. Select the View tab.

The Service Provider Data Report View window appears.

4. In the File field, enter the name of the report to be viewed or click the Browse
button to select a report.
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Click OK or Apply.

5. The report output window displays.

Deleting Service Provider Data Report

To delete a Service Provider Data report:

1. Log in to LSMS as a member of the permission group that is authorized to perform
this operation.

2. From the LSMS Console window, select Reports > Service Provider Data .

The Service Provider Data Report Create window appears.

3. Select the Delete tab.

The Service Provider Data Report Delete window appears.

4. In the File field, enter the name of the report to be deleted or click the Browse
button to select a report.

Click OK or Apply.

5. A Confirm Delete message window appears.

6. Click Yes or No.

If you click Yes, an Update Successful message window appears. Click OK to
return to the Service Provider Data Report Delete window.

7. If you click No, you return to the Service Provider Data Report Delete window.

Permission Group Data Report
The "Permission Group Data" report provides a listing of all permission groups,
commands authorized for each permission group, and users assigned to each
permission group.

Creating a Permission Group Data Report

To create a Permission Group Data report:

1. Log in to LSMS as a member of the permission group that is authorized to perform
this operation.

2. From the LSMS Console window, select Reports > Permission Group Data.

The Permission Group Data Report window appears.

3. From the Permission Group selection box, select All Permission Groups or a
group from the list provided.

4. See Table 5-4 and Table 5-5 for information about field constraints and field
descriptions.
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Table 5-4    Permission Group Data Report Dialog - Field Constraints

Field Type Modifiable? Constraints

Permission Group Combo Box Yes Value restricted to
be one of the default
permission groups,
configurable
permission groups,
or "All Permission
Groups.”

File Text Yes Must be a valid
filename.

Report Progress Progress Bar No Range 0-100%.

Table 5-5    Permission Group Data Report Dialog - Field Descriptions

Field Description

Permission Group Restrict the report to only include data for
this permission group.

File Save the report results under this file name.
The file will be created on the LSMS.

Report Progress The percentage of the report already
created.

5. In the File field, enter a file name for the report to be generated, or hit the Browse
button to select a file.

Click OK or Apply. The report automatically runs in background mode and does
not interfere with LSMS processing tasks such as NPAC traffic processing.

6. An Update Successful message window appears.

7. Click OK to view an example of the report.
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Figure 5-23    Permission Group Data Report Window

Viewing a Permission Group Data Report

To view a Permission Group Data report:

1. Log in to LSMS as a member of the permission group that is authorized to perform
this operation.

2. From the LSMS Console window, select Reports > Permission Group Data.

The Permission Group Report window appears.

3. Select the View tab.

4. In the File field, enter a file name for the report to be generated, or hit the Browse
button to select a file.

Click OK or Apply.
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Deleting a Permission Group Data Report

To delete a Permission Group Data report:

1. Log in to LSMS as a member of the permission group that is authorized to perform
this operation.

2. From the LSMS Console window, select Reports > Permission Group Data.

The Permission Group Report window appears.

3. Select the Delete tab.

4. In the File field, enter a file name for the report to be generated, or hit the Browse
button to select a file.

Click OK or Apply.

Report Generator
This optional feature is activated by Oracle customer service using secure activation
procedures.

Beginning with LSMS Release 5.0, LSMS offered as an optional feature a report
generator that uses a new LSMS Query Language (LQL) to enable the user to create
reports that are not already available through the Reports menu item on the LSMS
GUI. This feature supports queries against the following data types:

• Subscription versions (SVs)

• Number pool blocks (NPBs)

• Default Global Title Translation (GTT)

• Override GTT

• Numbering Plan Area (NPA) splits

LQL can be run only on the command line on the active server.

Note:   This feature is intended for specific queries on indexed fields that
return small result sets (less than 10,000 records). Queries of non-indexed
fields or overly general queries use extensive memory resources, result in
extremely long response times, and may impact LSMS system performance.
For information about indexed fields, see SV Table, NPB Table, DGTT Table, 
OGTT Table, and SPLIT Table. For more information about avoiding poor
performance, see Avoiding Overly General Queries.

Invoking LQL

After the feature has been activated, the user can invoke LQL in either of the following
ways:

• Interactively by entering the command lql without a filename. The command-
line prompt changes to LQL> and the user can enter any of the supported
commands (see LQL Commands).
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• In batch mode by entering the command lql with a file name. LQL processes
each line in the file as an LQL command (see LQL Commands). Batch processing
is terminated when any invalid command or an EXIT command is encountered in
the file The batch file can contain comment lines, which must begin with the #
character.

Multiple LQL processes can be active, but only one LQL process at a time can perform
a query (issue the SELECT command). For more information, see SELECT <column>
FROM <table> WHERE <expression>;.

LQL Commands

The LQL command set is a restricted subset of the American National Standards
Institute (ANSI) Structured Query Language-92 (SQL-92) and uses the SQL syntax,
except where noted. For more information about SQL, refer to:

http://www.w3schools.com/sql/default.asp

Each LQL command is terminated with a semicolon. Therefore, in interactive mode, a
command can span multiple lines. However, in batch mode, each command must
appear all on one line of the file.

The following commands are included in the LQL command set (although LQL
commands are shown in uppercase in this document, the commands are not case-
sensitive):

• USINGREGION <database>;

• SELECT <column> FROM <table> WHERE <expression>;

• DISPLAY <RECORDS|COUNTS>;

• SAVE <COMMANDS|RESULTS> <IN <filename>|OFF>;

• STATUS;

• HELP;

• EXIT;

USING REGION <database>;
Use this command for SV or NPB queries to specify the regional database that is to be
queried. The following values can be specified for <database>:

• ALL_REGIONS

• CANADA

• MIDATLANTIC

• MIDWEST

• NORTHEAST

• SOUTHEAST

• WOUTHWEST

• WESTCOAST
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• WESTERN

The regional database specified is the one queried for all subsequent queries for SVs
and NPBs until this command is issued again with another value for <database>. For
examples of this command, see LQL Examples.

This command is not used for queries of locally provisioned data (for example, queries
of default GTTs or NPA splits).

Note:   This command is not part of the SQL standard.

SELECT <column> FROM <table> WHERE <expression>;
Use this command to select rows from a table (using the WHERE keyword) and to
display columns from the matched rows, where:

• <table> has one of the values shown in LQL Table Names .

• <column> is a comma-separated list of column names (as shown in NPB Table, SV
Table, DGTT Table, OGTT Table, and SPLIT Table) within the relevant table; in
addition, service names can be used to select multiple column names, as described
above each table

• WHERE <expression> is described in WHERE Expressions.

In order to minimize the performance impact that LQL has on the LSMS system, only
one LQL process at a time can issue a SELECT command. If an LQL process issues a
SELECT command when another SELECT command is already in progress:

• In interactive mode, an error message is displayed and the command fails

• In batch mode, the entire batch file is aborted

For examples of this command, see LQL Examples.

LQL Table Names
Specify one of the values shown in the first column of this table for the <table>
parameter in the SELECT command.

Table 5-6    LQL Table Names

LQL Table Name (<table>) Data Type For Column Names, See:

SV Subscription version SV Table

NPB Number pool block NPB Table

DGTT Default GTT DGTT Table

OGTT Override GTT Override GTT

SPLIT NPA split SPLIT Table

WHERE Expressions
Specify the WHERE expression as <column> <operator> <value>, where:
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• <column> is a column name within the relevant table as shown in SV Table, NPB
Table, DGTT Table, OGTT Table, and SPLIT Table.

• <operator> is one of the following:

WHERE Operator (<operator>) Means

+ Plus

- Minus

> Greater than

< Less than

>= Greater than or equal to

<= Less than or equal to

= Equal to

!= Not equal to

LIKE Pattern match (Note)

NOT LIKE Inverse pattern match (Note)

Note:   For possible performance impact of using this operator, see “Avoiding Overly
General Queries”.

• <value> is a valid value for the field that appears in the type of column specified
by <column name>; for more information about the fields and syntax rules that
apply to them, refer to the Alarms and Maintenance Guide

In addition, you can use the following logical operators to negate an expression or to
combine two or more expressions:

• NOT negates the expression

• AND requires that both of two expressions must be true for the statement to be
true

• OR requires that only one of two expressions must be true for the statement to be
true

SQL Data Types
This table describes the SQL data types that appear in the following LQL tables:

• SV (Subscription Version)

• NPB (Number Pool Block)

• DGTT (Default GTT)

• OGTT (Override GTT)
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• Split (NPA Split)

Table 5-7    SQL Data Types and Descriptions

SQL Data Type Description

CHAR[n] A fixed length character array. A column of
type CHAR will always have a value n
characters long. As part of a WHERE
clause, a CHAR field must be compared
against a character string (e.g. TN =
'9194600000', not TN=9194600000).

VARCHAR[n] A variable length character array. A
column of type VARCHAR will have a
value between 0 and n characters long. As
part of a WHERE clause, a VARCHAR
field must be compared against a character
string (e.g. TN = '9194600000', not
TN=9194600000).

BYTE An 8-bit integer field. As part of a WHERE
clause, a BYTE field must be compared
against a number (e.g. CLASS_SSN > 0,
not CLASS_SSN > '0').

SHORT A 32-bit integer field. As part of a WHERE
clause, a BYTE field must be compared
against a number (e.g. VERSION_ID > 0,
not VERSION_ID > '0').

SV Table
The following values can be used for the first <column> parameter in a SELECT
command to select both the DPC and SSN values for the respective service, or for all
services:

• CLASS

• CNAM

• LIDB

• ISVM

• WSMSC

• ALL_SERVICES

Note:   These values cannot be used in a WHERE expression. For more
information about these values, refer to the Alarms and Maintenance Guide.

This table describes the values that can be specified for any <column> parameter
(including in a WHERE expression) in a SELECT command where the value of
<table> is SV. This table also describes which columns are indexed, as well as the
width of each output column. For descriptions of the data types, see SQL Data Types .
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Table 5-8    SV Table Column Names

Column Name Indexed? Output Width Data Type

VERSION_ID YES 10 SHORT

TN YES 10 CHAR[10]

LRN NO 10 CHAR[10]

NEW_CURRENT_S
P

NO 10 CHAR[4]

ACTIVATION_TIM
E

NO 14 CHAR[24]

EUL_VALUE NO 5 CHAR[4]

EUL_TYPE NO 4 CHAR[4]

BILLING_ID NO 7 CHAR[4]

LNP_TYPE NO 4 CHAR[1]

DOWNLOAD_REA
SON

NO 8 CHAR[1]

CLASS_SSN NO 5 BYTE

CLASS_DPC NO 5 CHAR[11]

CNAM_SSN NO 4 BYTE

CNAM_DPC NO 4 CHAR[11]

LIDB_SSN NO 4 BYTE

LIDB_DPC NO 4 CHAR[11]

ISVM_SSN NO 4 BYTE

ISVM_DPC NO 4 CHAR[11]

WSMSC_SSN NO 5 BYTE

WSMSC_DPC NO 5 CHAR[11]

Maximum possible output width 126

NPB Table
The following values can be used for the first <column> parameter in a SELECT
command to select both the DPC and SSN values for the respective service or for all
services; these values cannot used in a WHERE expression:

• CLASS

• CNAM

• LIDB

Report Generator

5-40  LSMS Database Administrator's Guide



• ISVM

• WSMSC

• ALL_SERVICES

This table displays the values that can be specified for any <column> parameter
(including in a WHERE expression) in a SELECT command where the value of
<table> is NPB. It also displays which columns are indexed and shows the width of
each output column. For descriptions of the data types, see SQL Data Types.

Table 5-9    NPB Table Column Names Used in WHERE Expressions

Column Name Indexed? Output Width Data Type

BLOCK_ID YES 10 SHORT

NPA_NXX_X YES 6 CHAR[7]

LRN NO 10 CHAR[10]

BLOCK_HOLDER_
SPID

NO 11 CHAR[4]

ACTIVATION_TIM
E

NO 14 CHAR[24]

DOWNLOAD_REA
SON

NO 8 CHAR[1]

CLASS_SSN NO 5 BYTE

CLASS_DPC NO 5 CHAR[11]

CNAM_SSN NO 4 BYTE

CNAM_DPC NO 4 CHAR[11]

LIDB_SSN NO 4 BYTE

LIDB_DPC NO 4 CHAR[11]

ISVM_SSN NO 4 BYTE

ISVM_DPC NO 4 CHAR[11]

WSMSC_SSN NO 5 BYTE

WSMSC_DPC NO 5 CHAR[11]

Maximum possible output width 103

DGTT Table
The following values can be used for the first <column> parameter in a SELECT
command to select the TT, DPC, SSN, XLAT, RI, and NGT values for the respective
service or for all services; these values cannot used in a WHERE expression:

• CLASS

• CNAM
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• LIDB

• ISVM

• WSMSC

• ALL_SERVICES

This table displays the values that can be specified for any <column> parameter
(including in a WHERE expression) in a SELECT command where the value of
<table> is DGTT. It also displays which columns are indexed and shows the width of
each output column. For descriptions of the data types, see SQL Data Types.

Table 5-10    DGTT Table Column Names Used in WHERE Expressions

Column Name Indexed? Output Width Data Type

GTT_GROUP NO 40 VARCHAR[40]

NPA_NXX NO 6 CHAR[6]

SPID NO 4 CHAR[4]

AIN_ENABLED NO 7 BYTE

IN_ENABLED NO 7 BYTE

CLASS_TT NO 5 BYTE

CLASS_DPC NO 11 CHAR[11]

CLASS_SSN NO 5 BYTE

CLASS_XLAT NO 5 BYTE

CLASS_RI NO 5 BYTE

CLASS_NGT NO 5 BYTE

CNAM_TT NO 4 BYTE

CNAM_DPC NO 11 CHAR[11]

CNAM_SSN NO 4 BYTE

CNAM_XLAT NO 4 BYTE

CNAM_RI NO 4 BYTE

CNAM_NGT NO 4 BYTE

LIDB_TT NO 4 BYTE

LIDB_DPC NO 11 CHAR[11]

LIDB_SSN NO 4 BYTE

LIDB_XLAT NO 4 BYTE

LIDB_RI NO 4 BYTE

LIDB_NGT NO 4 BYTE
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Table 5-10    (Cont.) DGTT Table Column Names Used in WHERE Expressions

Column Name Indexed? Output Width Data Type

ISVM_TT NO 4 BYTE

ISVM_DPC NO 11 CHAR[11]

ISVM_SSN NO 4 BYTE

ISVM_XLAT NO 4 BYTE

ISVM_RI NO 4 BYTE

ISVM_NGT NO 4 BYTE

WSMSC_TT NO 5 BYTE

WSMSC_DPC NO 11 CHAR[11]

WSMSC_SSN NO 5 BYTE

WSMSC_XLAT NO 5 BYTE

WSMSC_RI NO 5 BYTE

WSMSC_NGT NO 5 BYTE

Maximum possible output width 223

OGTT Table
The following values can be used for the first <column> parameter in a SELECT
command to select the TT, DPC, SSN, XLAT, RI, NGT, and RGTA values for the
respective service or for all services; these values cannot used in a WHERE expression:

• CLASS

• CNAM

• LIDB

• ISVM

• WSMSC

• ALL_SERVICES

This table displays the values that can be specified for any <column> parameter
(including in a WHERE expression) in a SELECT command where the value of
<table> is OGTT. It also displays which columns are indexed and shows the width of
each output column. For descriptions of the data types, see SQL Data Types.

Table 5-11    OGTT Table Column Names Used in WHERE Expressions

Column Name Indexed? Output Width Data Type

GTT_GROUP NO 40 VARCHAR[40]
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Table 5-11    (Cont.) OGTT Table Column Names Used in WHERE Expressions

Column Name Indexed? Output Width Data Type

LRN NO 10 CHAR[10]

SPID NO 4 CHAR[4]

CLASS_TT NO 5 BYTE

CLASS_DPC NO 11 CHAR[11]

CLASS_SSN NO 5 BYTE

CLASS_XLAT NO 5 BYTE

CLASS_RI NO 5 BYTE

CLASS_NGT NO 5 BYTE

CLASS_RGTA NO 5 BYTE

CNAM_TT NO 4 BYTE

CNAM_DPC NO 11 CHAR[11]

CNAM_SSN NO 4 BYTE

CNAM_XLAT NO 4 BYTE

CNAM_RI NO 4 BYTE

CNAM_NGT NO 4 BYTE

CNAM_RGTA NO 4 BYTE

LIDB_TT NO 4 BYTE

LIDB_DPC NO 11 CHAR[11]

LIDB_SSN NO 4 BYTE

LIDB_XLAT NO 4 BYTE

LIDB_RI NO 4 BYTE

LIDB_NGT NO 4 BYTE

LIDB_RGTA NO 4 BYTE

ISVM_TT NO 4 BYTE

ISVM_DPC NO 11 CHAR[11]

ISVM_SSN NO 4 BYTE

ISVM_XLAT NO 4 BYTE

ISVM_RI NO 4 BYTE

ISVM_NGT NO 4 BYTE
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Table 5-11    (Cont.) OGTT Table Column Names Used in WHERE Expressions

Column Name Indexed? Output Width Data Type

ISVM_RGTA NO 4 BYTE

WSMSC_TT NO 5 BYTE

WSMSC_DPC NO 11 CHAR[11]

WSMSC_SSN NO 5 BYTE

WSMSC_XLAT NO 5 BYTE

WSMSC_RI NO 5 BYTE

WSMSC_NGT NO 5 BYTE

WSMSC_RGTA NO 5 BYTE

Maximum possible output width 249

SPLIT Table
This table displays the values that can be specified for any <column> parameter
(including in a WHERE expression) in a SELECT command where the value of
<table> is SPLIT. It also displays which columns are indexed and shows the width of
each output column. For descriptions of the data types, see SQL Data Types.

Table 5-12    SPLIT Table Column Names Used in WHERE Expressions

Column Name Indexed? Output Width Data Type

OLD_NPA YES 3 CHAR[3]

NEW_NPA YES 3 CHAR[3]

NXX YES 3 CHAR[3]

REGION YES 8 BYTE

PDP_START YES 8 SHORT

PDP_END YES 6 SHORT

STATUS YES 6 BYTE

Maximum possible output width 37

Avoiding Overly General Queries
Queries should not be made against columns that are not indexed (as indicated in SV
Table, NPB Table, DGTT Table, OGTT Table, and SPLIT Table ). In addition, avoid
overly general queries which can result from using:

• The * wildcard character with the LIKE operator anywhere except at the end of
the search value For example:
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– SELECT * FROM SV WHERE TN LIKE ‘919*’ uses the TN index and
completes quickly

– SELECT * FROM SV WHERE TN LIKE ‘*919’ does not use the TN index and
exhibits the same poor performance as a query on a non-indexed column

• The NOT_LIKE operator for indexed columns. For example:

– SELECT * FROM SV WHERE TN NOT_LIKE ‘919*’ does not use the TN
index and exhibits the same poor performance as a query on a non-indexed
column

Table 5-13 provides some example performance times, assuming an SV table that
contains 1,000,005 records.

Table 5-13    Query Performance Examples

Query
Search Using

Index?

Number of
Records
Searched

Number of
Records
Matched

Time to
Complete Query

SELECT TN
FROM SV;

YES 1,000,005 1,000,005 75 seconds

SELECT TN
FROM SV
WHERE TN >=
'2191209000'
AND TN <
'2191210000';

YES 1,000,005 1,000 < 1 second

SELECT TN
FROM SV
WHERE TN >=
'2191200000'
AND TN <
'2191210000';

YES 1,000,005 10,000 1 second

SELECT TN
FROM SV
WHERE TN >=
'2191200000'
AND TN <
'2191300000';

YES 1,000,005 100,000 8 seconds

SELECT TN
FROM SV
WHERE TN >=
'2190000000'
AND TN <
'2200000000';

YES 1,000,005 1,000,005 75 seconds

SELECT TN
FROM SV
WHERE TN >=
'9190000000'
AND TN <
'9200000000';

YES 1,000,005 0 < 1 second

Report Generator

5-46  LSMS Database Administrator's Guide



Table 5-13    (Cont.) Query Performance Examples

Query
Search Using

Index?

Number of
Records
Searched

Number of
Records
Matched

Time to
Complete Query

SELECT TN
FROM SV
WHERE TN
LIKE '219*';

YES 1,000,005 1,000,005 90 seconds

SELECT TN
FROM SV
WHERE TN
LIKE '919*';

YES 1,000,005 0 < 1 second

SELECT TN
FROM SV
WHERE TN
NOT_LIKE
'919*';

YES 1,000,005 0 < 1 second

SELECT TN
FROM SV
WHERE TN
NOT_LIKE
'219*';

NO 1,000,005 1,000,005 75 seconds

SELECT TN
FROM SV
WHERE
CLASS_SSN =
30;

NO 1,000,005 0 25 seconds

SELECT TN
FROM SV
WHERE
CLASS_SSN =
1;

NO 1,000,005 1,000,005 75 seconds

SELECT TN
FROM SV
WHERE TN
>= ’2191209000’
AND TN <
‘2191210000’

NO 1,000,005 0 25 seconds

Relationship to SQL
The following keywords, which are part of the SQL standard, are not supported by
LQL:

• BETWEEN operator

• ORDER BY

• DISTINCT

• All SQL Functions
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• GROUP BY

• HAVING

• ALIAS

• All multiple-table SELECTs

• All JOINs

• AGGREGATE

• UNION

• INTERSECTION

DISPLAY <RECORDS|COUNTS>;
Use this command to specify how output is to be displayed:

• To display the full query results, use DISPLAY RECORDS

• To display only the number of records resulting from the query, use DISPLAY
COUNTS

The setting remains in effect until another DISPLAY command is entered. For
examples of this command, see LQL Examples.

Relationship to SQL

This command is not part of the SQL standard.

SAVE <COMMANDS|RESULTS> <IN <filename>|OFF>;
Use this command to specify that either all commands issued or all results of a query
are to be stored in the indicated file, or to stop saving commands or results. If a
filename is provided, the filename is given an extension of .lql and is saved in the
user’s reports directory.

To save both commands and results, enter the command twice. If the same filename is
used for both SAVE commands, the commands and results are interleaved in the
output file. For examples of this command, see Using the SAVE Command.

Relationship to SQL

This command is not part of the SQL standard.

STATUS;
Use this command to display the current settings as set by the following commands:

• USING REGION

• DISPLAY

• SAVE

For examples of this command, see Using the STATUS Command.

Relationship to SQL

This command is part of the SQL standard.
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HELP;
Use this command to display the list of supported commands.

Relationship to SQL

This command is not part of the SQL standard.

EXIT;
Use this command to exit the LQL executable. For examples of this command, see 
“LQL Examples”.

Relationship to SQL

This command is not part of the SQL standard.

LQL Output
LQL displays its results as a set of space-padded values. Before writing the first record,
LQL writes a header line that contains the name of each column; if the column name
contains an underscore, the name LQL writes the column name on two lines.

LQL writes each row returned from the query as one line of output. An empty or
missing column appears as only spaces.

LQL Errors
All LQL errors are written to stderr. LQL generates the following types of errors:

• Errors generated by the LQL software—Most errors will be of this type. These
errors are plain text messages that indicate the user’s error and often indicate a
corrective course of action.

• Errors generated by the underlying database—This type of error generally occurs
for an incorrect SELECT statement, which cannot be detected until the command
is submitted to the database for execution. These errors usually generate a
database error message, such as:

E4343:OM_PSR_SYNTAX_ERROR: VQL PARSE ERR: parse error: on/near token...

LQL Examples
Simple SELECT

Here is an example of a simple SELECT operation:

# lql
LQL> USING REGION SOUTHEAST;
LQL> DISPLAY RECORDS;
LQL> SELECT LRN FROM SV WHERE TN = '9194605500'; 
LRN
9194600000
LQL> EXIT;

Using AND in a WHERE Expression

Here is an example of using AND in a WHERE expression:

Report Generator

LSMS Reports  5-49



# lql
LQL> DISPLAY RECORDS;
LQL> SELECT CLASS,CNAM FROM OGTT WHERE GTT_GROUP = 'Group1' AND AIN_ENABLED != 0;

CLASS CLASS               CLASS CLASS CLASS CLASS CLASS CNAM CNAM        
CNAM CNAM CNAM CNAM CNAM 
TT    DPC                 SSN   XLAT  RI    NGT   RGTA  TT    DPC         
SSN  XLAT RI   NGT  RGTA 
1     100-200-100         0     0     0     0     0

LQL> EXIT;

In this example, only the CLASS service is defined for the GTT in this example;
therefore, no entries display for the CNAM columns.

Using OR in a WHERE Expression

Here is an example of using OR in a WHERE expression:

# lql
LQL> DISPLAY RECORDS;
LQL> SELECT SPID, NPA_NXX FROM DGTT WHERE CLASS_SSN = 121 OR CNAM_SSN = 121; 

SPID NPA
         NXX
1234 717323
1234 717326

LQL> EXIT

Using NOT in a WHERE Expression

Here is an example of using NOT in a WHERE expression:

# lql
LQL> DISPLAY RECORDS;
LQL> SELECT * FROM SPLIT WHERE NOT (REGION = 3);

OLD NEW NXX START    END      REGION STATUS
NPA NPA     PDP      PDP
919 864 227 20010801 20020301 4      2

LQL> EXIT

Using LIKE in a WHERE Expression

Here is an example of using LIKE in a WHERE expression (the first query in this
example does not follow the guidelines recommended in “Avoiding Overly General
Queries”):

# lql
LQL> USING REGION SOUTHEAST;
LQL>DISPLAY COUNTS;
LQL>SELECT TN FROM SV WHERE TN LIKE ‘*0000’; 

Query returned 0 rows.
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LQL> DISPLAY COUNTS;LQL>SELECT TN FROM SV WHERE TN LIKE
‘919460*’;

Query returned 936 rows.

LQL> EXIT

Using NOT_LIKE in a WHERE Expression

Here is an example of using NOT_LIKE in a WHERE expression (this example does
not follow the guidelines recommended in “Avoiding Overly General Queries”):

# lql
LQL> USING REGION CANADA; 
LQL>DISPLAY COUNTS;
LQL>SELECT TN FROM SV WHERE TN NOT_LIKE ‘1*’; 

Query returned 945 rows.

LQL> EXIT

Using the SAVE Command

Here is an example of using the SAVE command to save results to a file:

# lql
LQL> USING REGION CANADA;
LQL> DISPLAY COUNTS;
LQL> SELECT * FROM SV WHERE LRN = '9194600000' OR LRN = '9194610000'; 

Query returned 215 rows.

LQL> DISPLAY RECORDS; LQL>SAVE RESULTS IN NpaNxx919460; LQL>
SELECT * FROM SV WHERE LRN = '9194600000' OR LRN = '9194610000';
LQL> SELECT * FROM SV WHERE TN LIKE '919460*' ;LQL> SAVE RESULTS
OFF; LQL> EXIT

The results will be stored in the file /var/TKLC/lsms/free/data/reports/
lsmsadm/.

Using the STATUS Command

Here is an example of using the STATUS command:

# lql
LQL> USING REGION CANADA;
LQL>DISPLAY COUNTS;
LQL STATUS; 

Queries will use region: SOUTHEAST
Query results will show the number of rows found.
Commands will not be saved.
Query results will not be saved.

LQL> EXIT
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6
LSMS Logs and Measurements

This chapter describes the logs maintained by LSMS and how to access, navigate, and
print them.

Introduction
This chapter provides general information about viewing logs in a browser window
(except for measurement logs, which are viewed in an HTML viewer as described in 
Measurement Logs), as well as removing accumulated logs. It also provides examples
and formats of the different types of logs.

Note:   

For information about the permission groups that are authorized to view the
various logs, see Table 2-8 and Table 2-9.

How Logs are Displayed

The browser from which you launched the GUI is used to display the logs.

A new browser window opens for the first log that you view, and is reused for
viewing all subsequent logs.

Use the browser file functions to perform desired tasks, such as printing, searching,
and exiting.

Note:   

Measurement logs are displayed in the HTML viewer. See Measurement Logs
for more information.

Viewing a Log File

To view a log file:

1. Select the type of log file you want to view from the Logs menu.
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Figure 6-1    Logs Pull-down Menu

2. When the Open window appears, select the file you want to view and then click
Open to view the log file.

Figure 6-2    Open Window

Log File Names and Locations
This section describes how log files are named and where they are located.

Log Naming Conventions

Table 6-1 lists information about log files, whether they can be viewed from the LSMS
GUI, and the page reference where you can find examples. (<MMDD> refers to the
month and day, respectively, on which the log or file was created. Because these logs
and files are deleted after seven days, it is not necessary to include the year.)

Log File Names and Locations
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Table 6-1    Log File Information

Log Type File Name Accessible From the
GUI?

Security Logs LsmsSecurity.log.<MMDD> Yes

NPAC Transactions
Logs

LsmsTrans.log.<MMDD> Yes

Local Data
Transactions Logs

LsmsLocalEntry.log.<MMDD> Yes

NPA Split Logs LsmsSplit.log.<MMDD> Yes

Activity Logs LsmsActivity.log.<MMDD> Yes

Alarm Logs LsmsAlarm.log.<MMDD> Yes

CMIP Logs LsmsCMIP.log.<MMDD> Yes

Event Logs LsmsEvent.log.<MMDD> Yes

Trace Logs LsmsTrace.log.<MMDD> Yes

EAGLE Agent Logs Lsmseagleagent.log.<MMDD>

Rejected Transactions
Logs

LsmsRejected.log.<MMDD> Yes

LNP Database
Synchronization
Logs (Audit, Bulk
Load, Re-sync)

Refer to the LNP Database Synchronization
User's Guide

Yes

Measurement Logs <CLLI>.meas.<MMDD> Yes

Surveillance Logs survlog.log.<MMDD> No

Sentry Logs sentryd.log.<MMDD> No

LSMS Log File Names and Locations
This figure shows the directory structure under /var/TKLC/lsms/logs where LSMS
application log files are located.

Log File Names and Locations
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Figure 6-3    LSMS Application Log File Locations

Removing Accumulated Logs
To remove accumulated activity, trace, and application logs:

Note:   Logs are automatically removed after seven days.

1. Log in as root on the active server.

2. Change to the logs directory by typing the following command:

cd /var/TKLC/lsms/logs

Removing Accumulated Logs
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3. Determine the existing log files by typing the following command:

ls -R

Each subdirectory under the /var/TKLC/lsms/logs directory is represented in the
following output by the name of the directory followed by a colon (for example,
Northeast:). For each directory that contains log files, the complete listing of all log
files is shown below the name of the directory. The naming convention of the log
files is:

LsmsType.log.<MMDD>

where Type is the kind of log (such as Activity, Trace, Application), MM is month;
and DD is day. The following example output lists all the subdirectories for an
LSMS that supports eight regions and shows two log files:

./MidAtlantic:

./Midwest:

./Northeast:
LsmsActivity.log.0918 LsmsTrace.log.0918
./Southeast:
./Southwest:
./WestCoast:
./Western:
./Canada:
ems:
supported:

4. To delete the logs, do the following steps:

a. Change to the subdirectory for the desired region by typing the following
command:

cd <subdirectory>

where <subdirectory> is the subdirectory of the region, such as Western.

b. Determine which days you want deleted and type the following command:

rm *.log.<MMDD>

where MM is the month and DD is the day of the log files you want to delete.
For example, if you wanted to delete all logs in the Western region for
September 18, you would type the following commands:

cd Western

rm *.log.0918

Measurement Logs
Measurement logs are viewed in the HTML viewer. The following sections describe
how to navigate, print (from Linux and Windows computers), and exit measurement
logs.

Navigating Measurement Log Windows

Measurement Logs
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If there is more information in a log than can be viewed in the window, use the vertical
and horizontal scroll bars to scroll in either direction.

Printing Measurement Logs from Linux and Windows Computers

To print an LSMS-generated measurement log from a Linux computer, see Printing
Measurement Logs from a Linux Computer.

To print an LSMS-generated log from a Windows computer, see Printing
Measurement Logs from a Windows Computer.

Note:   

• Measurement logs are automatically scaled to fit the width of the page.

• The orientation of all measurement logs is portrait and cannot be
modified.

Printing Measurement Logs from a Linux Computer

To print an LSMS-generated measurement log from a Linux computer:

1. From a window displaying the log (after selecting Open), select File > Print.

Figure 6-4    Printing Measurement Logs Using the File Pull-down Menu

The Print window appears.

Measurement Logs
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Figure 6-5    Linux Print Window Example

2. In the Print Command Options field, enter the Linux print command to print the
log.

Example: lpr -P printer1

3. Click the Print button.

Printing Measurement Logs from a Windows Computer

To print an LSMS-generated measurement log from a Windows computer:

Note:   When printing from a Windows computer, a list of available printers is
automatically generated and displayed.

1. From a window displaying the measurement log (after selecting Open), File >
Print.

Measurement Logs
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Figure 6-6    Printing Measurement Logs Using the File Pull-down Menu

The Print window displays.

2. Select the printer you want to use and print the measurement log.

Exiting Measurement Log Windows

1. To exit the Measurement Log output window, select File > Exit

Figure 6-7    Exiting Measurement Logs Using the File Pull-down Menu

Measurement Logs
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Security Logs
Security logs contain login, logout, locally provisioned commands, and all GUI
activity information, which you can save, view, and print. These logs are stored in text
format and are created on a daily basis. LSMS allows you to access the current day’s
log and the logs created over the preceding seven days.

Viewing Security Logs

To view an LSMS security log:

1. From the LSMS Console window, select Logs > Security.

Figure 6-8    Logs Pull-down Menu

The security log Open window appears.

Figure 6-9    Security Log Open Window

2. Select the log you want to view and click Open.

The security log appears.

Security Logs
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Figure 6-10    Example Security Log

3. When you are done viewing the log, close the file.

NPAC Transactions Logs
The transactions logs provide information associated with M-Create, M-Delete, and M-
Set CMIP operations initiated from the NPAC. The maximum size of the log file is 60
MB.

Table 6-2 explains each field used in the NPAC transactions log for SVs, and also
provides the possible values for each variable. Table 6-3 explains each field used in the
NPAC transactions log for NPBs, and also provides the possible values for each
variable. Following each table are examples of the M-Create, M-Delete, and M-Set
transactions log formats.

Table 6-2    NPAC Transactions Log Format Symbols (for SVs)

Field Content Description

1 NPAC Region

2 characters:

CA = Canada

NE = Northeast

SW = Southwest

SE = Southeast

MW = Midwest

WC = West Coast

WE = Western

MA = Mid Atlantic

2

Received timestamp

Format:

YYYYMMDDhhmmss

14 characters:

YYYY = Year (1997 - 9999)

MM = Month (01 - 12)

DD = Day (01 - 31)

hh = Hour (00 - 23)

mm = Minute (00 - 59)

ss = Second (00 - 59)

Example: 19990315182028

3 Label subVersn

NPAC Transactions Logs
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Table 6-2    (Cont.) NPAC Transactions Log Format Symbols (for SVs)

Field Content Description

4 CMIP operation

1 character:

C = M-Create

D = M-Delete

S = M-Set

5 NPAC version ID
10 characters:

Example: 2000000001

6 Subscription version TN
10 characters:

Example: 9195551234

7 Subscription version LRN
10 characters:

Example: 2222223333

8 Service Provider ID
4 characters:

Example: TKLC

9 Billing ID
4 characters:

Example: Bill

10

Activation timestamp

Format:

YYYYMMDDhhmmss

14 characters:

YYYY = Year (1997 - 9999)

MM = Month (01 - 12)

DD = Day (01 - 31)

hh = Hour (00 - 23)

mm = Minute (00 - 59)

ss = Second (00 - 59)

Example: 19990315182028

11 Subscription LRN Type

1 character:

0 = lspp (interservice
provider port)

1 = lisp (intraservice provider
port)

2 = POOL (Pooled numbers)

Example: 0

12
Subscription download
reason

1 character:

0 = New

1 = Delete

2 = Modify

3= Audit discrepancy

Example: 2

NPAC Transactions Logs
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Table 6-2    (Cont.) NPAC Transactions Log Format Symbols (for SVs)

Field Content Description

13 SVType 1 character:

0= Wireline

1= Wireless

2= VoIP

3= VoWiFi

4= SVType4

5= SVType5

6= SVType6

Example: 1

14 AlternativeSPID 4 characters:

[0-9, A-Z], or NULL

Example: 1234

Note:   SVType and AlternativeSPID fields are not present in delete transactions.

Following are examples of M-Create, M-Delete, and M-Set transactions log formats for
SVs:

M-Create Transactions Format

         MW|19980123172028|subVersn|C|2000000001|9195555555|2222223333|TKLC|BILL|
19970202020202|0|0

M-Delete Transactions Format

MW|19980123172031|subVersn|D|2000000001|9195555555|

M-Set Transactions Format

MW|19980123172028|subVersn|S|2000000001|9195555555|2222223333|    |
TILL|              |0|2
MW|19980123172029|subVersn|S|2000000001|          |4444444444|TKLC|JILL|
19970202020202| |2

Figure 6-11 shows a portion of an example Transactions Log for SVs.

Figure 6-11    Example NPAC Transactions Log (SVs)

NPAC Transactions Logs
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Table 6-3    NPAC Transactions Log Format Symbols (for NPBs)

Field Content Description

1 NPAC Region

2 characters:

CA = Canada

NE = Northeast

SW = Southwest

SE = Southeast

MW = Midwest

WC = West Coast

WE = Western

MA = Mid Atlantic

2

Received timestamp

Format:

YYYYMMDDhhmmss

14 characters:

YYYY = Year (1997 - 9999)

MM = Month (01 - 12)

DD = Day (01 - 31)

hh = Hour (00 - 23)

mm = Minute (00 - 59)

ss = Second (00 - 59)

Example: 19990315182028

3 Label nmPoolBlk

4 CMIP operation

1 character:

C = M-Create

D = M-Delete

S = M-Set

5 NPAC version ID
10 characters:

Example: 2000000001

6 Subscription version TN
10 characters:

Example: 9195551***

7 Subscription version LRN
10 characters:

Example: 2222223333

8 Block Holder
4 characters:

Example: TKLC

NPAC Transactions Logs
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Table 6-3    (Cont.) NPAC Transactions Log Format Symbols (for NPBs)

Field Content Description

9

Activation timestamp

Format:

YYYYMMDDhhmmss

14 characters:

YYYY = Year (1997 - 9999)

MM = Month (01 - 12)

DD = Day (01 - 31)

hh = Hour (00 - 23)

mm = Minute (00 - 59)

ss = Second (00 - 59)

Example: 19990315182028

10 Placeholder

1 character:

T

Note: This field is present for
historical purposes and the
value is always T.

11
Subscription download
reason

1 character:

0 = New

1 = Delete

2 = Modify

3= Audit discrepancy

Example: 2

12 SVType 1 character:

0 = Wireline

1 = Wireless

2 = VoIP

3 = VoWiFi

4 = SVType4

5 = SVType5

6 = SVType6

Example: 1

13 AlternativeSPID 4 characters:

[0-9, A-Z], or NULL

Example: 1234

Note:   SVType and AlternativeSPID fields are not present in delete transactions.

Following are examples of M-Create, M-Delete, and M-Set transactions log formats for
NPBs:

NPAC Transactions Logs
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M-Create Transactions Format

         MW|19980123172028|nmPoolBlk|C|2000000001|9195551***|2222223333|TKLC|
19970202020202|T|0

M-Delete Transactions Format

MW|19980123172031|nmPoolBlk|D|2000000001|9195551***|

M-Set Transactions Format

MW|19980123172028|nmPoolBlk|S|2000000001|9195551***|2222223333|    | |T|2

Figure 6-12 shows a portion of an example Transactions Log for NPBs.

Figure 6-12    Example NPAC Transactions Log (NPBs)

Local Data Transactions Logs
Local data transactions logs provide information about locally provisioned data. 
Figure 6-13 shows an example of a local data transactions log.

Figure 6-13    Example Local Data Transactions Log

Audit Logs
Audit log files are generated for Range Audits. One log file is created for each day that
a Range audit is performed. The log file is named LsmsAudit.log.<MMDD>, where
<MMDD> is the timestamp that contains month and day. This log file is located in the
directory /var/TKLC/lsms/logs/<CLLI>, where <CLLI> is the Common Language
Location Identifier of the network element being audited. Log files are maintained for
seven days after they are created; then they are automatically removed from the LSMS.

Note:   No log file is generated for a Single SV/NPB Audit.

Viewing Audit Log Files
You can view audit log files in either of the following ways

• From the GUI, any time after a Range audit has begun, you can view the audit log
file by clicking the View Log button. If the browser window used for displaying
reports and logs is not already open, it is opened automatically and displays the
log file.

Local Data Transactions Logs
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• You can also use one of the following methods to open the window used to
browse for audit logs:

Figure 6-14    Browsing for Audit Log Files

– Select Logs > Other... from the main menu of the LSMS Console window.

– Click on the LSMS Console window’s EMS Status Icon that corresponds to the
network element being audited so that the icon is highlighted. Right-click and
select Logs > LNP Database Synchronization > Audit.

Scroll down to find the folder that has the <CLLI> name for the NE that is
being audited. Double-click the folder name, and then double click the file
name LsmsAudit.log.<MMDD> that corresponds to the month and day you
desire.

Audit Log File Contents
Whenever a Range audit is started, the audit log file for that day is appended (if this is
the first audit of the day, the file is created). For each audit performed on that day, the
audit log file contains information similar to the information displayed on the Audit
Range, Audit Results, and Download Results tabs, such as start and end times for
each stage, and numbers of missing, extra, and different objects in various LNP
categories. The log and window also record whether database entries are present at the
LSMS but missing at the NE, present at the NE but missing at the LSMS, or present at
both the LSMS and NE but containing different values.

The audit log file contains the following sections:

• Header Section

• Audit Section

• Reconcile Section

• Summary Section

Note:   Starting with LSMS Release 8.X, summary sections for Object Range
Audits indicate whether object types were completely audited, partially
audited, or not audited, and shows results for both completely and partially
audited object types.

Audit Logs
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Audit Log File Example for a Completed Audit

Figure 6-15 shows an example of an audit log file that contains two separate audits
and reconciles performed on the same day.

Figure 6-15    Example of an Audit Log File for a Completed Audit

Thu Nov 1 13:36:16 EST 2001

Username: lsmsuser
NE CLLI:  LARCH

Thu Nov 1 13:36:15 EST 2001
Connection established with network element (192.168.61.202:1030)

Audit of Override GTTs started on Thu Nov 1 13:36:20 EST 2001

2000000000 MISSING

Audit of Override GTTs completed on Thu Nov 1 13:36:20 EST 2001

   0000000000 LRN Start
   9999999999 LRN End
            5 Total audited on LSMS
            4 Total audited on NE
            4 Same on Both
            0 Different on NE
            1 Missing on NE
            0 Extra on NE
            1 Total Discrepancies

Reconcile started on Thu Nov 1 13:37:40 EST 2001

Reconcile completed on Thu Nov 1 13:37:44 EST 2001

           NPA Splits   0 Downloaded     0 errors
   Number Pool Blocks   0 Downloaded     0 errors
Subscription Versions   0 Downloaded     0 errors
         Default GTTs   0 Downloaded     0 errors
        Override GTTs   1 Downloaded     0 errors
                Total   1 Downloaded     0 errors

Audit Log File Example for a Partially Completed Audit

Figure 6-16 shows an example of an audit log file for an Object Range Audit that was
interrupted.

Figure 6-16    Example of Audit Log File for Partially Completed Audit

Mon Jun 6 14:40:20 EDT 2005

Username: lsmsall
NE CLLI:  PALM

Mon Jun 6 14:40:20 EDT 2005
Connection established with network element (192.168.61.100:1030).

Audit of NPA Splits started on Mon Jun 6 14:40:20 EDT 2005

Audit of NPA Splits completed on Mon Jun 6 14:40:27 EDT 2005

         200 Old NPA Start

Audit Logs
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         999 Old NPA End
           5 Total audited on LSMS
           5 Total audited on NE
           5 Same on Both
           0 Different on NE
           0 Missing on NE
           0 Extra on NE
           0 Total Discrepancies

Audit of Subscription Versions started on Mon Jun 6 14:40:27 EDT 2005

9195551212 EXTRA
9195551213 EXTRA
9195551214 MISSING

Audit of Subscription Versions interrupted on Mon Jun 6 14:40:27 EDT 2005

Partial Subscription Version Summary
 919550 NPA-NXX Start
 919559 NPA-NXX End
 919554 NPA-NXX Last Completed Successfully
   4999 Total audited on LSMS
   5000 Total audited on NE
   4997 Same on Both
      0 Different on NE
      1 Missing on NE
      2 Extra on NE
      3 Total Discrepancies

Objects Completely Audited: NPA Split
Objects Partially Audited:  Subscription Version
Objects Not Audited:        Default GTT, Override GTT
Partial Reconcile File:     /var/TKLC/lsms/free/ebda/<CLLI>.reconcile
                            File.0606144036.tar.gz

Continuing an Interrupted Object Range Audit

Starting with LSMS Release 8.X, if an Object Range Audit is interrupted, you can
interpret the contents of the audit log file to determine how many objects were
completely audited. After the interruption has been resolved, you can complete your
original audit goal by performing the following actions in any order (the file shown in 
Figure 6-16 is used as an example):

• Perform a Post-Audit Reconcile (refer to the LNP Database Synchronization User's
Guide), selecting the Partial Reconcile File listed in the Audit log
(<CLLI>.reconcileFile. 0606144036.tar.gz in the example file). This
Post-Audit Reconcile will reconcile the three discrepancies found in the
Subscription Version range from 919550 to 919554 (there were no discrepancies
found in the NPA Splits).

• Perform another Range audit and reconcile of just SVs in the range 910555 to
910559.

Audit Log File Example for Data Discrepancies

An audit can detect three types of data discrepancies (different, missing, and extra)
that may exist on a network element. Each discrepancy that is detected is counted and
recorded in the audit log file. Duplicate LNP data is not considered to be a
discrepancy. Figure 6-17 shows an example of an audit section of an log file that
contains data discrepancies.

Audit Logs
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Figure 6-17    Audit Log File Example for Data Discrepancies

Audit of Subscription Versions interrupted on Mon Jun 6 14:40:36 EDT 2005

Partial Subscription Version Summary

        919550 NPA-NXX Start
        919559 NPA-NXX End
        919554 NPA-NXX Last Completedly Successfully
          4999 Total audited on LSMS
          5000 Total audited on NE
          4997 Same on Both
             0 Different on NE
             1 Missing on NE
             2 Extra on NE
             3 Total Discrepancies

Objects Completely Audited: NPA Split
Objects Partially Audited:  Subscription Version
Objects Not Audited:        Default GTT, Override GTT
Partial Reconcile File:     /var/TKLC/lsms/free/ebda/<CLLI>.reconcile
                            File.0606144036.tar.gz

NPA Split Logs
The LSMS records all changes to LSMS NPA split objects in split log files. Log
information for all eight regions is included in one log file.

Figure 6-18    Example LSMS Split Log

As with other log files, the split log files use the current date in the filename so they
are automatically deleted after seven days. The split log file name has the following
format, where MM is the creation month and DD is the creation day:

LsmsSplit.log.MMDD

The daily limit for this log file is 75 megabytes. (Each TN uses 5 bytes in the Split log
file entry. If 500 NXX—half of the 1000 maximum— in the old NPA change to the new
NPA and each NXX contains the maximum 9999 SVs, that is 25 megabytes in the log
file on the Start Date of that NPA Split. Because up to three NPA splits have occurred
on the same day, the maximum size limit for a Split log file is set at 75 megabytes.)

The following figures show examples of create, activation, and delete entries,
respectively, in a split log file.

NPA Split Logs
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Figure 6-19    Sample Create Entry in a NPA Split Log File

Figure 6-20    Sample Activation Entry in a NPA Split Log File

Figure 6-21    Sample Delete Entry in a NPA Split Log File

Formats Common to All Entries

The following formats apply to all split log entries:

• Time fields for all time stamps are in the 19-character YYYY-MM-DD HH:MM:SS
format, representing year, month, day, hour, minute, and second, respectively.

• Time fields for PDP start and end times are in the 14-character YYYYMMDDHHMMSS
format, representing year, month, day, hour, minute, and second, respectively. The
values for hour, minute, and second are always zero.

• Each entry specifies OK or FAIL to indicate whether the action was completed
successfully.

Create Entry

A create entry, with the following format, is recorded in the log file each time an NPA
Split is created using the GUI or an input file.

CREATE|<OK or FAIL>|<creation time>|<optional failure reason text>
<old NPA>|<new NPA>|<NXX>|<start PDP time>|<end PDP time>

Activation Entry

An activation entry, with the following format, is recorded in the log file each time an
NPA Split is activated.

NPA Split Logs
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START ACTIVATE|<activation time>
<old NPA>|<new NPA>|<NXX>|<start PDP time>|<end PDP time>
NPB:
<X>***|<X>***|…|<X>***
SV:
<XXXX>|<XXXX>|…|<XXXX>
…
<XXXX>|<XXXX>|…|<XXXX>
END ACTIVATE|<OK or FAIL>|<activation time>|<optional failure reason text>
<old NPA>|<new NPA>|<NXX>|<start PDP time>|<end PDP time>

The list of NPBs modified contains up to ten numeric entries. Each entry contains the
last digit in the NPA-NXX-X string that identifies an NPB followed by three asterisks
(***).

Because each line in the list of SVs modified contains up to ten 4-digit numeric entries
for the last four digits of a ten-digit TN identifying an SV, there may be up to one
thousand lines in each list of SVs modified for a given NPA-NXX split.

Delete Entry

A delete entry, with the following format, is recorded in the log file each time an NPA
Split is manually deleted using the GUI.

DELETE|<OK or FAIL>|<deletion time>|<optional failure reason text>

For more information about Split logs and LSMS NPA Splits, see Managing Locally
Provisioned Data.

Activity Logs
The LSMS activity log contains all CMIP operations initiated from the NPAC agent to
a local database or to the NPAC. It contains the decoded CMIP operations including
M_GET, M_SET, M_DELETE, M_ACTION and EVENTREPORT. The maximum size
of the log file is 2 MB. See Figure 6-22 for an example of a partial activity log.

Activity Logs
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Figure 6-22    Example (Partial) Activity Log

Alarm Logs
Alarm logs contain the following elements:

• Prefix line – Single line with title and timestamp for each alarm.

• Event Report Argument – Variable-length decoded CMIP.

• Origin – Single line that ends with a 1 to indicate that the message came from the
NPAC agent.

• Severity – Single line that ends with one of the following numbers:

– 1 – Indicates that the problem is Critical

– 2 – Indicates that the problem is Major

– 5 – Indicates that the problem is Cleared

• Message – Text message printed on GUI as notification.

Alarm Logs
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Figure 6-23    Example Alarm Log

CMIP Logs
The CMIP log collects for later analysis all CMIP protocol data units (PDUs) received
from the NPAC. If a problem arises during an NPAC transaction, support personnel
can print the relevant CMIP log and attach it to the problem report. The maximum
size of the log file is 2 MB. See Figure 6-24 for an example of a CMIP Log.

Figure 6-24    Example CMIP Log

Event Logs
The event log provides GUI notification information about events not related to
problems. The maximum size of the log file is 2 MB and is kept for seven days.

The event log holds the following types of records, each of which contains varying
numbers of information fields (see Table 6-4 for descriptions of each field).

• New NPA-NXX Event, which contains 10 information fields

• First Use of NPA-NXX Event, which contains eight information fields

Note: Optional fields for which no information is generated appear in the event log as
two consecutive pipes (||).

CMIP Logs
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Figure 6-25    Example Event Log

New NPA-NXX Event Log Record

Following is the format of the event message logged when a new serviceProvNPA-
NXX object is created:

<Timestamp> | <EventTime> | <EventId> | <EventType> | <SPID> | <NPANXX-ID>
| <NPANXX> | <EffectiveTimestamp> | <DownloadReason> |
<CreationTimestamp>

See fields 1 through 10 in Table 6-4 for descriptions of each field included in the New
NPA-NXX Event Log Record.

Following is an example of a New NPA-NXX Event Log Record when a new
serviceProvNPA-NXX object is created:

Example:

1998-08-18 12:00:00| 19980818120000 | 300 | New NPA-NXX| 0001 | 25 |
919361 | 19980801120000.0Z | 0 | 19980701120000.0Z

In this example, 19980801120000.0 in field 8 and 19980701120000.0 in field 10 represent
the time stamp values (YYYYMMDDhhmmss.0Z format, where the.0 that
immediately precedes the Z indicates tenths of a second) and Z indicates Zulu time.

Note:   Time Stamp values are entered in local time. LSMS automatically
converts local time to Z (Zulu), which is also called GMT (Greenwich Mean
Time). For more information, see Appendix A, "Local Time Calculation and
World Time Zone Data.".

First Use of NPA-NXX Event Log Record

Following is the format of the event message logged when a
subscriptionVersionNewNPA-NXX notification is received:

Event Logs
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<Timestamp> | <EventTime> | <EventId> | <EventType> | <SPID> | <NPANXX-ID>
| <NPANXX> | <EffectiveTimestamp>

See fields 1 through 8 in for descriptions of each field included in the First Use of NPA-
NXX Event Log Record.

Following is an example of an NPA-NXX event log record when a
subscriptionVersionNewNPA-NXX notification is received:

Example:

1998-08-18 12:00:00| 19980818115500 | 301 | First use of NPA-NXX | 0001 |
25 | 919361 | 19980801120001.0Z

In this example, 19980801120001.0 in field 8 represents the time stamp value
(YYYYMMDDhhmmss.0Z format, where the.0 that immediately precedes the Z
indicates tenths of a second) and Z indicates Zulu time.

Note:   Time Stamp values are entered in local time. LSMS automatically
converts local time to Z (Zulu), which is also called GMT (Greenwich Mean
Time). For more information, see #unique_18.

NPAC Event Log Fields and Field Descriptions

provides a summary of the NPAC event log fields and field descriptions.

Fields 1 through 10 are included in the New NPA-NXX Event Log Record, and fields 1
through 8 are included in the First Use of NPA-NXX Event Log Record.

Table 6-4    NPAC Event Log Fields and Field Descriptions

Field Field Name Field Description

1 <Timestamp>

The date and time that the notification appeared
on the GUI. It is in the same format as the GUI
notification:

YYYY-MM-DD hh:mm:ss

YYYY -Year (1997–9999)

MM - Month of the year (01–12)

DD - Day of the month (01–31)

hh - Hour (00–23)

mm - Minute (00–59)

ss - Second (00–59)

Example: 1998-08-18 12:00:00

2

<EventTime>

Format:

YYYYMMDDhhmmss

The time that the event actually occurred (it is
also an optional field in a CMIP event). If
present, it is in the Abstract Syntax Notation
(ASN.1) Generalized time format.

Example:

19980818120000

Event Logs
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Table 6-4    (Cont.) NPAC Event Log Fields and Field Descriptions

Field Field Name Field Description

3 <EventId>

The event messages are assigned a unique
integer identifier. One of the following
identifiers appears in the

<EventId>

field, depending upon the type of record:

• 300 (New NPA-NXX)
• 301 (First Use of NPA-NXX)

4 <EventType>

One of the following entries appears in the

<EventType>

field, depending upon the type of record:

• New NPA-NXX is the descriptive text
associated with an

<EventId>

of 300.
• First Use of NPA-NXX is the descriptive

text associated with an

<EventId>

of 301.

5 <SPID> Alphanumeric 4-character Service Provider ID.

6 <NPANXX-ID>
Integer identifier that provides a unique key for
the object.

7 <NPANXX> The NPA-NXX value of the portable NPA-NXX.

8

<EffectiveTimestamp>

Format:

YYYYMMDDhhmmss.0Z

(The.0 that immediately
precedes the Z indicates tenths
of a second. The Z indicates
Zulu time.)

Timestamp that specifies when the NPA-NXX is
available for LNP in the service provider
networks.

Example: 19980801120000.0Z

(The.0 that immediately precedes the Z indicates
tenths of a second. The Z indicates Zulu time.)

9 <DownloadReason>

Integer that specifies the reason that the NPA-
NXX was downloaded to the LSMS. The valid
reasons are:

0 - New

1 - Delete

2 - Modified

3 - Audit discrepancy

Event Logs
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Table 6-4    (Cont.) NPAC Event Log Fields and Field Descriptions

Field Field Name Field Description

10

<CreationTimestamp>

Format:

YYYYMMDDhhmmss.0Z

(The.0 that immediately
precedes the Z indicates tenths
of a second. The Z indicates
Zulu time.)

Timestamp that specifies when the NPA-NXX
object was created at the NPAC by the service
provider that owns the NPA-NXX.

Example:

19980801120000.0Z

(The.0 that immediately precedes the Z indicates
tenths of a second. The Z indicates Zulu time.)

Trace Logs
The trace log is used by Oracle applications developers. Each entry, as shown in 
Figure 6-26, contains a timestamp and debug information.

Figure 6-26    Example Trace Log

eagleagent Logs
The LSMS maintains a set of logs for the LSMS’s interface to the network elements.
These logs are viewable from all running GUI sessions, and have a maximum file size
of 200 MB each. The following eagleagent logs are described in this section:

• “eagleagent Transactions Log”

• “Rejected Transactions Log”

• “Measurement Logs”

In addition to these logs, LNP Database Synchronization logs are also eagleagent logs.
A log file is created to record the results of each audit, bulk load, and user-initiated
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resynchronization. These logs files are described in the LNP Database Synchronization
User's Guide.

eagleagent Transactions Log
The Transactions log records all request/response transactions between the LSMS and
the network element. The eagleagent Transactions log shows every message sent to the
EAGLE and (optionally) responses from the EAGLE. The log includes EBDA reconcile
messages and resynchronization messages. The log format identifies which filter was
used and whether the message came from EBDA, local data, or which Region.

Example Transactions Log Entry

Figure 6-27 shows an example of an entry in the eagleagent Transactions log.

Figure 6-27    Example eagleagent Transactions Log

Transactions Log Fields

Table 6-5 shows describes the fields in entries in the eagleagent Transactions log.

Table 6-5    eagleagent Transactions Log Fields, Field Descriptions, and Sample/
Restriction Data

Field
Number

Field Description Sample/Restriction Data

1 Timestamp
Local
timestamp of
event

27 characters

Tue Oct 30 17:48:35 EST 2001

2 Space #1
Space
character

1 space

3
Parenthesis
#1

Open
Parenthesis

1 character

(

4 Filter Type

Identifies
type of
filtering used
by LSMS

13 characters

G indicates GTT Group Filter

T indicatesTN Filter

Example:

FilterType=G,

5 Space #2
Space
character

1 space

eagleagent Logs

6-28  LSMS Database Administrator's Guide



Table 6-5    (Cont.) eagleagent Transactions Log Fields, Field Descriptions, and
Sample/Restriction Data

Field
Number

Field Description Sample/Restriction Data

6 Filter Data

Based on
Filter Type in
Field #4,
contains
information
specific to
filter

Variable number of characters

See 6a or 6b

6a
TN Filter
Data

Identifies
Region Name
and NPA-
NXX for this
transaction,
when
FilterType=T
for #4

For Region, possible values are Canada,
MidAtlantic, Midwest, Northeast, Southeast,
Southwest, Western, WestCoast

NpaNxx is 6 digits

Example:

Region=Southeast, NpaNxx=706595,

6b
GTT Group
Name

GTT Group
Name when
FilterType=G
in #4.

Example:

GttGroupName=Group1,

7 Space #3
Space
character

1 space

8
CMIP
Operation
Type

Identifies
CMIP
operation

7 characters

C indicates Create

S indicates Set (modify)

D indicates Delete

N indicates Not Set

Example:

CMIP=N,

9 Space #4
Space
character

1 space

10 Source

Integer
identifying
source of
update
within the
LSMS

6 characters

Integer (1-9)

Example:

SRC=4,

11 Space #5 1 space
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Table 6-5    (Cont.) eagleagent Transactions Log Fields, Field Descriptions, and
Sample/Restriction Data

Field
Number

Field Description Sample/Restriction Data

12
Start of
LSMS
Command

Identifies the
start of the
LSMS
Command
information

5 characters

Cmd=(

13 Function ID
Identified
HSOP
Function ID

Variable number of characters

Format is funcId=<id>=<name>,

Possible values for <id>=<name> are:

39=HSOP_UPD_SUB_TS 
40=HSOP_UPD_GTT_OVERRIDE_TS 
41=HSOP_UPD_GTT_DEFAULT_TS 
42=HSOP_UPD_NPA_SPLIT_TS 
43=HSOP_DLT_SUB_TS 
44=HSOP_DEL_GTT_OVERRIDE_TS 
45=HSOP_DEL_GTT_DEFAULT_TS 
46=HSOP_DLT_NPA_SPLIT_TS 
47=HSOP_RTRV_SUB 53=HSOP_MAX_FUNC_ID 
(Invalid)

14 Space #6 1 space

15
Command
Length

Denotes
length of
command
excluding
header

5-7 characters

Format is len=xxx where xxx can be 1 to 3
digits.

Example:

len=49,

16 Space #7 1 space

17 Timestamp

Timestamp at
which
command is
sent by
LSMS to
EAGLE

26 characters.

Format is timestamp=yyyymmddHHMMSS
\0,

Example:

timestamp=20050131120000\0,

18 Record data

One or more
pipe-
delimited
record
forwarded to
EAGLE from
LSMS

Variable length character string

Each record type (SV, NPB, Override GTT,
Default GTT, NPA Split) has its own format.

See Table 6-6 and Table 6-7 for formats of
Pipe Delimited Records.
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Table 6-5    (Cont.) eagleagent Transactions Log Fields, Field Descriptions, and
Sample/Restriction Data

Field
Number

Field Description Sample/Restriction Data

19
End of record
data

\n

20
End of LSMS
Cmd

Ending
parenthesis

1 character

)

21
End of
RMTP Cmd

Ending
parenthesis

1 character

)

Transactions Log Record Data Formats

As described in field 18 in Table 6-5, the format of the pipe-delimited record data in a
Transactions log entry differs according to the record type and the type of command. 
Table 6-6 shows the format for each record type and command type and Table 6-7
describes each of the fields used in these formats.

Table 6-6    Format of Pipe-Delimited Record Data in Transactions Log Entry

Record Type Format for Update
Command

Format for Delete Command

SV

TN|LRN|SPID|PoolType|
Class DPC|Class SSN|LIDB
DPC|LIDB SSN|ISVM
DPC|ISVM SSN|CNAM
DPC|CNAM SSN|WSMSC
DPC|WSMSC SSN\0

TN \0

NPB

NPANXXX***|LRN|SPID|
3|Class DPC|Class SSN|
LIDB DPC|LIDB SSN|
ISVM DPC|ISVM SSN|
CNAM DPC|CNAM SSN|
WSMSC DPC|WSMSC SSN
\0

NPANXXX***\0

Override GTT
LRN|SPID| Service 1|
Service 2|Service 3|Service
4|Service 5\0

LRN\0

Default GTT
NPA-NXX|AIN|IN|Service
1|Service 2|Service 3|
Service 4|Service 5\0

NPA-NXX\0

NPA Split
New NPA-NXX|Old NPA-
NXX\0

Old NPA-NXX\0
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Table 6-6    (Cont.) Format of Pipe-Delimited Record Data in Transactions Log Entry

Record Type Format for Update
Command

Format for Delete Command

Table 6-7 describes each of the fields shown in this table.

Table 6-7    Definitions of Fields for Pipe Delimited Records

Name Description Restrictions/Comments

TN Telephone Number 10 digits

LRN Location Routing Number 10 digits

SPID Service Provider ID 4 alphanumeric characters

PoolType Pool Type

1 digit:

• 1 indicates Local Service
Provider Portability
(LSPP)

• 2 indicates Local Intra-
Service Provider
Portability (LISP)

• 3 indicates Pooled Block
Number (POOL)

Class DPC

LIDB DPC

ISVM DPC

CNAM DPC

WSMSC DPC

Destination Point Code
Absent or 9 digits consisting
of 3 octets each between 0
and 255

Class SSN

LIDB SSN

ISVM SSN

CNAM SSN

WSMSC SSN

Subsystem Number
Absent or Up to 3 digits
(0-255)
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Table 6-7    (Cont.) Definitions of Fields for Pipe Delimited Records

Name Description Restrictions/Comments

Service 1

Service 2

Service 3

Service 4

Service 5

Default GTT and Override
GTT commands can contain
from one to five services
(Class, LIDB, ISVM, CNAM,
or WSMSC) depending on
which of those services have
been defined for the Default
GTT or Override GTT. Each
Service field consists of
additional pipe-delimited
fields:

• Default GTT entry, 5
fields: TT|DPC|SSN|
RI|NGT

• OverrideGTT entry, 6
fields: TT|DPC|SSN|
RI|NGT|RGA

TT is 0 to 255 or absent

DPC is 0 to 255 or absent

SSN is 0 to 255 or absent

RI is G, D, or absent

NGT is 0 to 255 or absent

RGTA is L, T, or absent

NPA-NXX

New NPA-NXX

Old NPA-NXX

Number Porting Area -
Exchange

6 digits

AIN
Advanced Intelligent
Network indicator

2 or 3 characters

Either LA or NLA

IN Intelligent Network indicator
2 or 3 characters

Either LI or NLI

Rejected Transactions Log
Rejected transactions logs record exception conditions for LSMS transactions. You can
use these logs to help identify when, where, and why LSMS data is not correctly
provisioned. The rejected transactions log records rejected revision commands that the
LSMS sends to network elements.

The LSMS checks to make sure that accurate data is successfully forwarded to a
network element. When the LSMS receives a subscription version of any kind (create,
delete, or modify) from the NPAC or when an LSMS user creates or modifies a
Default or Override GTT entry, the LSMS sends appropriate commands to the
network elements.

If, after the configured number of retries, the command used to forward the new
information is rejected by a network element, an entry is logged in the rejected
transactions log file.

Rejected Transactions Log Location

One log file is created for each day (if there are rejected transactions on that day), up to
a maximum of seven daily log files. After a log file is seven days old, LSMS
automatically deletes it.
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The rejected transactions log files are located in

/var/TKLC/lsms/logs/<clli>/LsmsRejected.log.<MMDD>

where <MMDD> represents the month and day the file was created. For example, a
log file created April 7th would have the file name:

LsmsRejected.log.0407

Rejected Transactions Log Description

Each record in the log file is a single line of data. The maximum number of entries in
each daily log file is 30,000; the maximum size of each daily log file is 2,340,000 bytes. 
Figure 6-28 shows an example of one entry in a Rejected Transactions Log.

Figure 6-28    Example eagleagent Rejected Transactions Log Entry

The Rejected Transactions log shows every message rejected by the EAGLE. Since a
message must be sent to be rejected, that means every message in the Rejected
Transactions log is also in the Transactions log. However, the entry in the Rejected
Transactions log has error text attached to explain why it failed.

The format of the Rejected Transactions Log is the same as for the Transactions Log for
a Transmission for fields 1 through 18, as described in Table 6-5, Table 6-6 , and 
Table 6-7. Table 6-8 shows the format of fields 19 through 22 in the Rejected
Transactions Log.

Table 6-8    Rejected Transactions Log

Field Number Field Description Sample/Restriction
Data

19 End of record data
3 characters

\n,

20 Space #8 1 space

21 Error Text
Description of error
leading to Rejection.

Variable length text

Example:

errorTxt=Comma
nd Error! \0

22 End of LSMS Cmd Ending parenthesis
1 character

)

22 End of RMTP Cmd Ending parenthesis
1 character

)
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Measurement Logs
Measurement logs are not created by default. You can view measurements from the
GUI as shown in Figure 6-29.

Figure 6-29    EMS Status Icon Popup Menu

In addition, you can use the measdump command to view measurement logs. This
command is located in the following directory:

$ LSMS _DIR/../tools/

(For backward compatibility, you can use the measdump command to create the
measurement files.) For more information about this command, refer to the Alarms and
Maintenance Guide.

The measurement log file provides the following information:

• Region – The name of the NPAC region.

• Last Updated – When this information was last updated in the following format:

– ddd – Day of the week (Sun, Mon, Tue, Wed, Thu, Fri, Sat)

– MMM – Month (Jan, Feb, Mar, Apr, May, Jun, Jul, Aug, Sep, Oct, Nov, Dec)

– DD – Day of the month (01–31)

– hh – Hour (00–23)

– mm – Minute (00–59)

– ss – Second (00–59)

– YYYY – Year (1997–9999)

• Binds – Cumulative number of NPAC-LSMS association binds during the hour.

• SuccessOps – Cumulative number of M-Create, M-Delete, and M-Set commands
that went into the LSMS database and also successfully passed to the supported
manager.

• FailedOps – Cumulative number of M-Create, M-Delete, and M-Set commands that
failed to go into the LSMS database.

The following operations are not measured or contained in this file:

eagleagent Logs

LSMS Logs and Measurements  6-35



• M-Get operations

• Unsuccessful bind operations

• Unbind operations

• Event responses

• Operations that are rejected because of a duplicate entry or invalid attribute

An example of a measurements log is shown in Figure 6-30.

Figure 6-30    Example Measurements Log File

LSMS Evaluation Log Files
Several LSMS log files keep track of system functionality. These log files cannot be
accessed directly from the GUI, but can be found by using the browse feature to look
into the appropriate directory. These include the following types of log files:

• Surveillance

• Sentry

Surveillance Log Files

The LSMS surveillance application monitors various hardware parameters. This
feature creates two log files that are stored in the /var/TKLC/lsms/logs directory.
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The survlog.log file contains debug information from the surveillance application. It can
be used by the surveillance application to monitor itself for improper functioning.
Each line in this log file begins with a timestamp. A text message following the
timestamp indicates the state of the surveillance application. For example:

12/31/1997 08:45 => Unable to open second serial port configuration file

12/31/1997 08:45 => Second serial port not to be used

12/31/1997 08:45 => Console window successfully opened!

The survlog.log file is a persistent log of all console notifications. The format of this log
file is same as the format of console notifications. For example:

LSMS0009|11:55 Feb 04, 1998|lnp13|Keep Alive

LSMS0500|11:56 Feb 04, 1998|lnp13|Notify:Sys Admin

LSMS0501|11:57 Feb 04, 1998|lnp13|Notify:Sys Admin - SAM1

LSMS0502|11:57 Feb 04, 1998|lnp13|Notify:Sys Admin - SAM1

Sentry Log Files

The LSMS sentry application monitors other software processes and attempts to
restart them automatically in certain failure conditions (refer to the Alarms and
Maintenance Guide for more information about the Sentry application). This feature
creates one log file, sentryd.log file,which is stored in the /var/TKLC/lsms/logs/
sentry directory.

The sentryd.log file contains general information from the LSMS sentry application. It
can be used for tracking what the LSMS sentry process is doing regarding the state of
the LSMS applications it is monitoring. Each line in this log file begins with a
timestamp. A text message following the timestamp indicates the state of the LSMS
sentry application. For example:

12/31/1997 08:45 => fatal: environment variable LSMS-DIR not set

09/10/1998 08:45 => sentryd starting

09/10/1998 08:45 => restarting rmtpagent

09/10/1998 08:45 => sentryd stopped

Bulk Data Downloads for Notifications (Optional)
When the optional NANC 3.3 Feature Set is activated, support of Bulk Data
Downloads (BDD) for notifications is enabled. The bulk download file is supplied by
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the NPAC like other bulk download files, and notifications are processed by the
LSMS.

A notifications file is generated for a particular SPID and time range. All attempted
notifications for the SPID in the time range are included in the file, and they are sorted
in order by ascending notification attempt timestamp. The notification BDD filename
is in the following format:

Notifications.<start download>.<start time range>.<end time range>

Note:   Each timestamp has the format <DD-MM-YYYYHHMMSS>

For example, this file:

Notifications.18-09-2006081122.15-09-2006080000.16-09-2006133022

was created starting at 08:11:22 on September 18, 2006 and covered the time ranged
from 08:00:00 on September 15, 2006 through 13:30:22 on September 16, 2006.

Although there are more than 20 possible notification IDs, the LSMS only receives
notification types 1 and 8. Notification ID 1 is “Operational Information” from NPAC,
and Notification ID 8 is the “Subscription Version New NPA-NXX” notification.

The field values for Notification ID 1 are described in Table 6-9.

Table 6-9    Notification ID 1 Field Values

Field Number Field Range of Values

1 Creation Timestamp YYYYMMDDHHMMSS

2 LSMS Customer SPID
[0-9 A-Z] four alphanumeric
characters

3 System Type 0=SOA, 1=LSMS

4 Notification ID 1

5 Object ID [0-9]

6 Maintenance Start Time YYYYMMDDHHMMSS

7 Maintenance End Time YYYYMMDDHHMMSS

8 NPAC Contact Number Telephone number

9
Additional Download Time
Information

Graphic string of up to 255
characters (not used by
LSMS)

The field values for Notification ID 8 are described in Table 6-10.

Table 6-10    Notification ID 8 Field Values

Field Number Field Range of Values

1 Creation Timestamp YYYYMMDDHHMMSS
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Table 6-10    (Cont.) Notification ID 8 Field Values

Field Number Field Range of Values

2 LSMS Customer SPID
[0-9 A-Z] four alphanumeric
characters

3 System Type 0=SOA, 1=LSMS

4 Notification ID 8

5 Object ID

21, when generated
by SV

12, when generated by NPB

6 NPA-NXX ID [0-9]

7 NPA-NXX [0-9] six digits

8
NPA-NXX Effective
Timestamp

YYMMDDHHMMSS

9
Subscription Version New
NPA-NXX SPID

[0-9 A-Z] four alphanumeric
characters

Bulk Data Downloads for Notifications (Optional)
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Bulk Data Downloads for Notifications (Optional)
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