Cloud Documentation
Advanced Search


Getting Started with Your Oracle Financials Cloud Implementation
Close Window

Table of Contents

Show All | Collapse

6 Configuring Financial Reporting

This chapter contains the following:

Financial Reporting Center: How It Works

Define Financial Reporting Center

Configure Smart View Client for Users

Configure Financial Reporting Studio Client for Users

Define Essbase Database Connections in Workspace

Create Financial Statements: Explained

Financial Reporting Center: How It Works

The Oracle Fusion Financial Reporting Center provides functionality for reporting on Oracle Fusion General Ledger balances. It provides secure, self-service access to reports that use real time account information.

You can design traditional financial report formats such as balance sheets, profit and loss statements, and cash flow reports. You can also design nontraditional formats for financial or analytic data that include text and graphics.

The figure shows the main components in the Financial Reporting Center: Financial Reporting, Account Monitor, Account Inspector, Smart View, Financial Reporting Workspace, and Financial Reporting Studio. These components use the Oracle Fusion General Ledger preaggregated balances as the staring data.

Components

Financial Reporting Center is comprised of numerous components:

  • Financial Reporting: Financial users and analysts access live reports and books or published snapshot reports and books from previously scheduled batches in a variety of formats. Other functionality includes the following capabilities:

    • Refresh report data using runtime points of view or parameters

    • Drill through from parents to other parents

    • Drill down to detail balances, journal lines, and subledger transactions

  • Oracle Hyperion Smart View: Financial analysts view, import, manipulate, distribute, and share data from your Oracle Fusion General Ledger balances in Microsoft Excel.

  • Account Monitor and Account Inspector: Financial analysts monitor and track key account balances in real time at every level of your dimensions and hierarchies. These tools provide multidimensional account analysis and drill down capability.

  • Workspace: Reporting administrators:

    • Create, open, save, and delete folders

    • Store report objects, reports, and snapshot reports

  • Oracle Hyperion Financial Reporting Studio: Report authors use an object-oriented graphical report layout with report objects, such as text boxes, grids, images, and charts, to design reports.

Define Financial Reporting Center

Oracle Fusion Financial Reporting Center is a powerful tool for accessing, designing, and presenting financial reports and analytic data.

Configure Financial Reporting Center

You have access to the reports through the folder structure in the Financial Reporting Center and Workspace installed with Oracle Fusion Financials. Your Oracle Fusion Business Intelligence (BI) administrator defines the folder structure in Workspace taking into consideration your company's security requirements for folders and reports, as well as report distribution requirements for financial reporting batches.

Security can be set on folders and reports from Workspace. BI Catalog stores both the Financial Reports and the BI Publisher Reports. You are granted access to the folders and reports you need to view by your BI administrator.

Create and Secure Folder Structure

To create a folder or sub-folder:

  1. Start at the Navigator by selecting Financial Reporting Center.

  2. From the Financial Reporting Center task panel, select Open Workspace for Financial Reporting.

  3. From within Workspace select the Navigator menu > Applications > BI Catalog.

  4. On the Oracle BI Catalog page, go to the desired location in the Folders panel.

  5. In the Oracle BI Catalog tool bar, click New and select Folder.

    Select the Folder option to create a new folder.

  6. The New Folder dialog is displayed. Enter the folder name.

    Enter the name of your folder.

  7. Click OK.

To assign permissions to a folder:

  1. Start at the Navigator by selecting Financial Reporting Center.

  2. From the Financial Reporting Center task panel, select Launch Workspace.

  3. From within Workspace select the Navigator menu > Applications > BI Catalog.

  4. Search for the folder to which you want to assign permissions.

  5. Go to the Tasks panel and click Permissions. The Permission dialog is displayed.

    The Permissions dialog box list the current permissions and provides icons to add or delete permissions.

  6. Click the Add users/roles button.

  7. In the Add Application Roles, Catalog Groups and Users dialog box, query the roles and select those desired. In this example, select General Ledger Functional Administration Duty and General Ledger and Profitability Managerial Duty.

    Select General Ledger Functional Administration Duly and General Ledger and Profitability Managerial Duty.

  8. Click the Move button.

  9. Set Permission to the level desired. In this example, select Full Control.

  10. Click OK.

Configure Smart View Client for Users

Smart View is a multidimensional pivot analysis tool combined with full Excel functionality. Smart View enables you to interactively analyze your balances and define report using a familiar spreadsheet environment.

Load Smart View, an Excel add-in, to each client computer. To download the installation files from Workspace click the Navigator > Financial Reporting Center > Open Workspace for Financial Reporting. Once the Workspace is launched, click Tools > Install > Smart View. Alternatively, download Smart View from http://www.oracle.com/technetwork/middleware/epm/downloads/smart-view-1112x-1594693.html.

Note

Since Smart View is an add-in to Microsoft Office products, you can install Smart View only on a Windows operating system.

Once Smart View is installed, it must be configured to connect to Oracle Fusion Applications. Use the Smart View Shared Connections URL. You can derive the Shared Connections URL by following the following steps.

  1. Launch Workspace from the Financial Reporting Center.

  2. Edit the Workspace URL, for example, if the Workspace URL is https://fusionsystemtest-p-external-bi.us.oracle.com/workspace/index.jsp. Remove index.jsp and add SmartViewProviders at the end of the URL.

    If the Workspace URL is https://efops-rel5st4-cdrm-external-bi.us.oracle.com:10622/workspace/index.jsp, the Shared Connections URL is https://efops-rel5st4-cdrm-external-bi.us.oracle.com:10622/workspace/SmartViewProviders.

  3. Copy the URL.

  4. Launch Excel.

  5. Navigate to the Smart View menu > Options

    Smart View Ribbon added to Excel.

  6. Select the Advanced option.

    Smart View options window used to configure spreadsheets.

  7. Paste the URL in the Shared Connections URL field.

  8. Click the OK button.

For more information on configuring the Smart View client for users, see Oracle Hyperion Smart View for Office User's Guide for Oracle Hyperion Smart View.

To connect Oracle Fusion General Ledger Balances cubes in Smart View:

  1. Open Smart View from your Start menu > Programs > Microsoft Office > Microsoft Excel 2007.

  2. Go to the Smart View menu > Open, in the Start on the ribbon > click on Smart View Panel that appears in the drop down box under the ribbon. This launches a task pane.

  3. Click the Shared Connections button on the task pane.

  4. Sign in with your user name and password.

    Sign in to establish the connection to the database.

  5. Click the Select Server list icon to proceed.



    Note

    If the Essbase Server is not there, then it has to be added. Use the following steps:

    1. Click the Add Essbase Server link on the bottom of the spreadsheet.

    2. Specify the Essbase Server login and password.

    3. Expand the Essbase server and locate its cube.

  6. Select Oracle Essbase from the list of shared connections.

  7. Click the Expand to expand the list of cubes.

  8. Expand your cube that has the name of your chart of accounts.

    Select your cube, which is named for your chart of accounts.

  9. Click db. A list of functions appears on the bottom of the panel.

  10. Click the Ad hoc analysis.

Note

You must perform the steps above only once for a new server and database.

To set how the name and alias of the Essbase database appears:

  1. Click the Options on the ribbon > select the Member Options > select Member Name Display.

  2. Set one of these three options:

  • Distinct Member Name: Only shows the full Essbase distinct path.

  • Member Name and Alias: Shows both the member name and the alias.

  • Member Name Only: Shows only the member name.

Note

The Smart Slice feature is not supported in Oracle Fusion General Ledger. For all other documentation, refer to the Oracle Hyperion Smart View for Office User's Guide.

Configure Financial Reporting Studio Client for Users

Oracle Hyperion Financial Reporting Studio is client-based software tool used for authoring financial reports. Prerequisites needed for installing the Financial Reporting Studio are:

  1. Financial Reporting Studio Client Certifications found at: http://www.oracle.com/technetwork/middleware/bi-foundation/hyperion-supported-platforms-085957.html.

  2. The end user's computer requires Microsoft Office installations.

You connect to the Financial Reporting Studio by downloading the installation files to your computer from Workspace. Follow this path: Navigator > Financial Reporting Center > Open Workspace for Financial Reporting. Once Workspace is opened, click Tools > Install > Financial Reporting Studio.

After performing the prerequisites and completing the installation, launch the Financial Reporting Studio. You must provide your user ID, password, and the Server URL. Derive the Server URL information by following the steps:

  1. Open Navigator > Financial Reporting Center > Open Workspace for Financial Reporting.

  2. Edit the Workspace URL and remove workspace/index.jsp.

  3. Two examples of Server URLs are:

    • If the Workspace URL is https://fusionsystemtest-p-external-bi.us.oracle.com/workspace/index.jsp, the Financial Reporting Server URL is https://fusionsystemtest-p-external-bi.us.oracle.com.

    • If the Workspace URL is https://fusionsystemtest-p-external-bi.us.oracle.com:10622/workspace/index.jsp, the Financial Reporting Server URL is https://fusionsystemtest-p-external-bi.us.oracle.com:10622.

  4. Copy the modified URL to the Server URL field.

Note

For end users installing the Oracle Fusion Financials Reporting Studio, the installer launches a separate console window that continues to run for a brief time after the installation completes the setup tasks. The process is normal, expected, and applies to Oracle Hyperion Reporting Studio installations in both the Oracle Fusion Applications and Enterprise Performance Manager modes.

Note

You must save a new report before attempting to preview it with Web Preview.

Prerequisites needed for installing the Financial Reporting Studio are:

  1. Financial Reporting Studio Client Certifications that are found at: http://www.oracle.com/technetwork/middleware/bi-foundation/hyperion-supported-platforms-085957.html.

  2. The end user's computer requires Microsoft Office installations.

Note

For more information, see:

  • Oracle Enterprise Performance Management System Installation and Configuration Guide.

  • Oracle Hyperion Enterprise Performance Management System EPM System Standard Deployment Guide.

Define Essbase Database Connections in Workspace

You need to create database connections from Workspace so you can access the cubes from Workspace and Financial Reporting Studio.

Note

Ledger setup has to be completed before the database connection can be created. Oracle Fusion General Ledger balances cubes are created as part of ledger setup. There is a separate cube for each combination of chart of accounts and accounting calendar. A database connection is needed for each cube.

Steps to define a database connection are:

  1. Start at the Navigator by selecting Financial Reporting Center.

  2. From the Financial Reporting Center task panel, select Open Workspace for Financial Reporting.

  3. From within Workspace select the Navigator menu > Applications > BI Catalog.

  4. Select Tools menu > Database Connection Manager.

  5. Select New button.

  6. Enter a user friendly name for the Database Connection Name.

  7. Enter Essbase as the Type, your server, user name, and password.

  8. Select Application (cube) and Database from the list of values.

  9. Expand the Application name to see the related database, for example, db.

    Complete the fields in the Database Connection Properties window.

  10. Click the OK button twice to save your selections.

  11. Click Close button in the Database Connection Manager window to save your connection.

For more information on configuring Essbase database connections in Workspace see: Oracle Essbase Database Administrator's Guide.

Note

The database connection is available in both Workspace and Financial Reporting Studio. Optionally, the database connection can be setup in Financial Reporting Studio while entering the grids on a report.

Create Financial Statements: Explained

In Oracle Hyperion Financial Reporting Studio, you can design traditional financial report formats such as balance sheets, profit and loss statements, and cash flow reports. You can also design nontraditional reports for financial or analytic data that include text and graphics. Use Financial Reporting Studio that is a client-based application and is launched from your desktop to create your reports. Perform the following basic tasks to begin defining this report.

The figure shows a rolling 12 month income statement that is created by using the steps in this topic.

  1. Access the Financial Reporting Studio on your desktop.

    The figure shows signing in with your User ID, Password, and Server URL.

    Tip

    The first time you sign in, you must set the Server URL in this format: https://<servername>-bi-ext.us.oracle.com:port.

  2. (B) New Report (1st icon on the tool bar) or (M) File > New > Report.

  3. Use the Report Pallet page as the container to build your report.

  4. (B) New Grid. (First icon in second set on the tool bar.)

  5. Press the left mouse button and drag the mouse to select a large area of the grid in which to create your report.

  6. Click the Database Connection list.

  7. Select your database. A unique cube exists for each combination of chart of accounts and accounting calendar.

    The figure shows the database connection selection list and your User ID and Password.

  8. (B) OK.

Set the Row, Column, and Page Points of View

Set the point of view dimensions and accounts for the rows, columns, and page levels.

  1. Use the Dimension Layout window that opens to arrange your dimensions.

  2. Drag and drop:

    • Accounting Period to Columns.

    • Account to Rows.

    • Company to Pages.

    Tip

    Click the icon in front of the name to select the dimension to drag to the designed area.

    The figure shows Company dimension in the Pages section, AccountingPeriod in the Columns section, and Account in the Rows section of the Dimension Layout window.

  3. (B) OK.

  4. Double-click on Account to open the Select Members dialog box to select the data to use in your report.

  5. Click the Account list item in the Selected box on the right.

  6. (B) Remove in the center to remove the default Account.

  7. (B) Expand for Account node.

  8. Expand:

    • All Corporate Accounts

    • [Account]@[T]

    • 95001

  9. Select 95011 Revenue.

  10. (B) Add.

    The figure shows expanding all levels to select the 95001 Revenue value.

  11. (B) OK.

  12. (M) File > Save As...

  13. Select My Folders.

  14. Enter the name for the report: XXInFusion Income Statement.

  15. (B) Save.

  16. Select the last row in the grid. Click the row header (row with the account in it).

  17. (M) Insert > Row > Text to add a blank row.

  18. Right-click the row header.

  19. (M) Insert Row > Data to add another blank row.

  20. Add expense accounts by double-clicking on account 95011 in line 3.

  21. Remove the Selected account 95011.

  22. Expand:

    • All Corporate Accounts - V1

    • [Account]@[T]

    • 95001

    • 95021 - Expenses

  23. Select all three accounts: 50000, 60000, and 70000.

  24. (B) Add.

  25. Check the Place selections into separate rows check box on the bottom right.

    The figure shows the expanded tree for the Account dimension.

  26. (B) OK.

  27. (I) Save. Leave the report open for the next activity.

Add a Formula

Add a formula to calculate total expenses.

  1. Right click the row header of the row below row 5.

  2. (M) Insert > Row > Formula.

  3. Click in the blank cell on row 6.

  4. Click the Custom Heading option in the panel on the right hand side of the window.

  5. Add a custom heading: Total Expenses.

  6. Click the formula cell at row 6 and column A.

  7. (B) Sum(). The formula Sum() is entered into the Edit box.

  8. Enter [3], [4], [5].

  9. After entering the formula, validate the syntax by clicking the blue check mark.

    The figure shows the formula Sum [3], [4], [5] and the blue check mark.

    (I) Save. Leave the report open for the next activity.

Define Columns Using a Range Function

Define the columns using a range function to create a rolling 12 period column type report.

  1. In the first column on the grid, double-click the AccountingPeriod cell.

  2. Remove the default selection to assign a custom period selection.

  3. Click the AccountingPeriod in the Selected window.

  4. (B) Remove.

  5. (T) Functions.

  6. Click the Range list item.

  7. (B) Add.

    The figure shows the Range function in the Functions tab selected.

  8. (B) OK.

  9. Use the Edit Range Function window to add the range function start and end members or to select a hierarchy to use to select your report data.

  10. Select the StartMember row.

  11. Click in the Value field.

  12. (B) Lookup.

  13. (T) Functions.

  14. Click the RelativeMember list item.

  15. (B) Add.

  16. Select the Member row.

  17. Click in the Value field.

  18. (B) Lookup.

  19. Click the Current Point of View list item.

  20. (B) Add.

  21. (B) OK.

  22. The Offset value determines periods to include from the current point of view. Since this is a rolling 12 month report, enter -12.

    The figure shows entering -12 as the Offset value.

  23. (B) OK twice.

  24. Click the EndMember list item.

  25. (B) Lookup.

  26. Click the Current Point of View list item.

  27. (B) Add.

  28. (B) OK three times until you return to your report.

  29. (I) Save. Leave the report open for the next activity.

Define User Points of View

Define the user points of view for the dimensions and specify values for those dimensions.

  1. Select the Grid object (The intersection of rows and columns on the left margin.)

  2. Right-click the Grid object.

  3. (M) Grid Point of View. The points of view appear across the top of the window.

  4. (B) Ledger: User Point of View for Ledger.

  5. Expand:

    • Ledger

    • All Ledgers

  6. Highlight the Ledger item to include in the report: InFusion USA PL.

    The figure shows expanding all the Ledger dimension levels to select the InFusion USA PL.

  7. (T) Scenario.

  8. Expand Scenario.

  9. Select Actual as the Scenario member to determine what should be included in the columns.

  10. (T) Balance Amount.

  11. Expand the Balance Amount.

  12. Select Period Activity as the balance amount to include in the report.

  13. Click the Currency tab.

  14. Expand Currency.

  15. Search for and select USD from the list.

  16. Click the USD list item.

  17. Click the OK button.

    The figure shows the Select Members window with the USD currency selected.

  18. Right-click the Grid object.

  19. Click the Grid Point of View Setup.

  20. Scroll down and click the Balance Amount list button.

  21. Select the Nothing, Lock Member Selection option.

  22. (B) OK.

  23. Double-click the Pages object.

  24. (B) Remove.

  25. Select the Prompt for Company list item.

  26. (B) Add.

    This figure shows selecting Prompt for Company option and adding it to the Selected window.

  27. (B) OK.

  28. (B) Lookup.

  29. Click the Default Member list icon.

  30. (B) Remove.

  31. (B) Expand:

    • Company

    • All Company Values

  32. Select the required companies. 101-US 1 LE 1 BU 1 and 102-US 1 LE 2 BU 2.

  33. (B) Add.

  34. (B) OK.

  35. Click the Member Labels in Prompt Selection Dialog list button.

  36. Select the Alias list item.

    The figure shows the prompt parameters set for the Enter Company prompt.

  37. (B) OK.

  38. Open the Page Properties dialog box on the right side of the window. If it does not open, click View menu > Property Sheet.

  39. Double-click the Pages object.

  40. Click the Alias: Default option.

    This figure shows the Page Properties and selecting the Alias: Default.

  41. Click the first cell in Row 1.

  42. Open the Heading Row Properties dialog box on the right hand side of the window.

  43. Click the Alias: Default option.

    The figure shows the Heading Row Properties and selecting Alias: Default.

  44. Click the Grid object.

  45. Open the Grid Properties dialog box.

  46. Click the Suppression list item.

  47. Enter 0 in the Zero Values field.

    This figure shows entering a 0 in the Zero Values in the Grid Properties window.

  48. Open the Heading Row Properties dialog box.

  49. Click an entry in the row.

  50. Click the Allow Expansion option.

  51. Click the Grid object.

  52. Open the Grid Properties dialog box.

  53. Click the Drill Through option. (On the very bottom of the window.)

  54. (I) Save. Leave the report open for the next activity.

Add Company Logo and Title

Insert your company's logo and add a title to the report.

  1. (I) Image. (Third icon in the second set of icons on the tool bar.)

  2. Find your company's logo in your file system.

  3. (B) Open.

  4. Drag and drop the cursor over the report pallet to determine the length and width of the image.

  5. (I) Save.

  6. (I) Text. (Second icon in the second set of icons on the tool bar).

  7. Drag and drop the cursor over the report pallet to determine the length and width of the title.

  8. Enter Rolling 12 Month Income Statement.

  9. (M) Format > Font.

  10. Select Bold and 14 as the Font Size.

  11. (I) Center Text.

  12. (M) File > Page Setup option.

  13. Click Landscape.

  14. Click (T) Workspace Size. If needed, you can adjust the Width and Height with the up and down arrows.

    The figure shows the final image in the gird.

  15. (B) OK.

  16. (I) Save.

Preview Report

Preview the report both in the Financial Reporting Studio and the Financial Reporting Center.

In Financial Reporting Studio

  1. (M) File > Print Preview.

  2. Accept the default selections.

  3. (B) OK.

    This figure shows the preview of the report without the periods expanded.

  4. Use the (B) Next Page to see all the columns.

  5. Edit the report definition as needed.

In Financial Reporting Center

  1. Sign in the Oracle Fusion Applications.

  2. Navigator > General Accounting: Financial Reporting Center > My Folders > XXInFusion Income Statement.

  3. (I) View as HTML.

  4. (B) OK to the Respond to Prompts window to keep the default companies.

  5. Click the (L) AccountingPeriod.

    The figure shows the report without the periods expanded.

  6. Expand:

    1. AccountingPeriod

    2. 2012

    3. Qtr2-12

      The figure shows the point of view selection window for the accounting period.

  7. Select 02-12.

  8. (B) OK.

    The figure shows the final report.