Operating System Requirements for x86-64 Linux Platforms

The Linux distributions and packages listed in this section are supported for this release on x86-64.

Identify the requirements for your Linux distribution, and ensure that you have a supported kernel and required packages installed before starting installation.

Note:

  • Oracle Universal Installer requires an X Window System (for example, libx). The libx packages are part of a default Linux installation. If you perform an install on a system with a reduced set of packages, then you must ensure that libx or a similar X Window System package is installed.

  • The Oracle Unbreakable Enterprise Kernel can be installed on x86-64 servers running either Oracle Linux or Red Hat Enterprise Linux. As of Oracle Linux 5 Update 6, the Oracle Unbreakable Enterprise Kernel is the default system kernel. An x86 (32-bit) release of Oracle Linux including the Oracle Unbreakable Enterprise Kernel is available with Oracle Linux 5 update 7 and later.

  • 32-bit packages in these requirements lists are needed only if you intend to use 32-bit client applications to access 64-bit servers.

  • Oracle Database 12c Release 2 (12.2) and later does not require the compiler packages gcc and gcc-c++ on Oracle Linux and Red Hat Enterprise Linux for Oracle Database or Oracle Grid Infrastructure installations.

The platform-specific hardware and software requirements included in this guide were current when this guide was published. However, because new platforms and operating system software versions may be certified after this guide is published, review the certification matrix on the My Oracle Support website for the most up-to-date list of certified hardware platforms and operating system versions:

https://support.oracle.com/

See Also:

If you currently use, or plan to upgrade to, Oracle Linux 7.2 or Red Hat Enterprise Linux 7.2, then see information about the RemoveIPC settings: