Oracle Reports Building Reports
Release 6i

A73172-01

Contents

Index

Prev Next

5
Building a Report with Sections

The report described in this chapter is designed to help you learn more about Report Builder features for report sections and distribution.

To build this report, you will use the Data Wizard to create a multi-query data model, then use the Report Wizard to create the default layout for the first section. You will make fairly extensive manual refinements in the Data Model and Layout Model views. Then, you will again use the Report Wizard to create a default layout for the second section, based on the same data model, and make minor manual refinements in the Layout Model view and Live Previewer.

In this example, you will create a detailed report in the main section showing investment fund elections, and an account summary for employees vested at a specified percentage (one landscape page per employee). Then you will create one-page summary report in the header section of all employees vested at a specified percentage. Finally, you will set up distribution parameters to output each section of the report to multiple formats and destinations.

About sections

Report sectioning enables you to define multiple layouts in the same report, with each layout having a different target audience, output format, page layout, page size, and orientation. You can define up to three report sections (i.e., the Main, Header, or Trailer section). In the other sections, you can define different layouts rather than creating multiple separate reports. For example, a single report can include an executive summary for senior management in one section and can also include a detailed breakdown for individual managers in another section.

The following figure provides a conceptual overview for building a report with multiple sections, and then distributing the report based on the distribution parameters defined for each section. Table 5-1, "Features demonstrated in this Sections sample report" describes the steps you will take to create this report.

The sect.rdf file contains the report you will create after finishing the tasks in this chapter. You may want to refer to this file while you are working. This file is located in your ORACLE_HOME\TOOLS\DOC60\US\RBBR60 directory.

Table 5-1 Features demonstrated in this Sections sample report
Feature  Location 

Create a data model by building five different queries. Then refine the data model in the Data Model view. 

Section 5.1, "Creating a data model" 

Build a Runtime Parameter Form in which users enter parameter values that determine how the report will run. 

Section 5.2, "Designing a Runtime Parameter Form" 

Use the Report Wizard to create a default layout for a detailed section. 

Section 5.3, "Creating a layout for the first section" 

Make manual refinements to the first section in the Layout Model view. 

Section 5.4, "Refining the layout in the Layout Model view" 

Use the Report Wizard to create a default layout for a summary section. Then make minor manual refinements in the Layout Model view and Live Previewer. 

Section 5.5, "Creating a layout for the second section" 

Specify how the two sections of the report that you have created will be distributed. 

Section 5.7, "Specifying distribution" 

To get started, open Report Builder. If the Welcome dialog box appears, click Build a new report manually and click OK. If not, choose File->New->Report. Click Build a new report manually and click OK.

At some point before you generate the report, you will need to log into the database. Choose File->Connect to connect to the database. Enter the appropriate log on information. See Section 1.3, "Obtaining database access before you start" for details.

5.1 Creating a data model

The steps in this section will help you create a data model by building five different queries. Then, you will refine the data model manually in the Data Model view.

5.1.1 Building queries using the Data Wizard

When building a report with multiple queries, you typically use the Data Wizard to create each query and the Report Wizard to create the layout. The steps in this section will help you to create five different queries using the Data Wizard.

 

  1. For online help on this task, choose Help->Report Builder Help Topics

  2. On the Index page, type...
    query, creating

  3. Then click Display to view help topic...
    Creating a local query: Data Wizard

 

  1. In the Data Model view, click to display the Data Wizard.

  2. If the Welcome page appears, click Next.

  3. Type Q_acct in Query Name and click Next.

  4. If the Type page appears, click SQL statement, and click Next. The Type page will only appear if you have configured Report Builder to run with Oracle Express.

  5. Type the following SELECT statement. This query selects personnel information for each employee, along with investment fund deferral and vested percentages:

    SELECT 	a.lastname,
    	a.firstname,
    	a.mi,
    	a.ssn,
    	a.pct_deferral,
    	a.pct_vested,
    	d.street,
    	d.city,
    	d.state,
    	d.zip
    FROM 	accts a,
    	acct_addrs d
    WHERE a.pct_vested=:p_pct_vested
    AND d.ssn=a.ssn
    
  6. Click Next. If you are connected to the database, you will receive a notification that Report Builder is creating a bind parameter for you. Click OK to dismiss it. Because the WHERE clause of this query refers to a bind parameter (p_pct_vested) that does not yet exist, Report Builder creates the parameter for you and notifies you that it has been created.

  7. On the Groups page, click Next. This query requires no break groups.

  8. On the Summary page, click Next. You will create some totals later on in this chapter.

  9. Click Finish.

  10. Repeating steps 1 through 9, create four more queries with the following characteristics:

    • Query Name: Q_dist

      Q_dist selects the percent distribution of investment fund elections for each employee.

      SELECT 	c.fund_id,
      	c.pct_dist,
      	c.ssn,
      	f.name
      FROM	fund_contrib c,
      	funds f
      WHERE  c.fund_id=f.fund_id
      ORDER BY f.name
      
  1. Choose File->Save As. Save the report in the directory of your choice, and name the report sect_511.rdf.

    Tip: It is good practice when you are designing your report to save it frequently under a different file name. If you generate an error or if you don't like some of the changes you made, you easily can go back to the previously saved file and make revisions from that point.

5.1.2 Refining the Data Model

The steps in this section will give your groups more meaningful names, create a break group, turn your data model into a matrix data model, create data links, and create summaries.

  1. In the Data Model view, double-click G_lastname, the group owned by Q_acct, to display the Property Palette.

  2. Under the General Information node, set the Name property to G_acct.

  3. Press RETURN or ENTER to set the change.

  4. Repeating steps 1 through 3, rename the following groups:
    Table 5-2 Group names
    Old Name  New Name 

    G_fund_id 

    G_dist 

    G_description 

    G_xact 

    G_name1 

    G_funds 

  5. Click and drag the G_xact group down a couple of inches to create some space above it.

  6. Click the column named empcomp in the G_xact group, and drag it outside and above the G_xact group.

     

    1. For online help on this task, choose Help->Report Builder Help Topics

    2. On the Index page, type...
      break group, creating

    3. Then click Display to view help topic...
      Creating a break group

     

  7. Click the column named emconame in the G_xact group, and drag it into the new group, G_empcomp. Place emconame after the empcomp column.

  8. Double-click the G_empcomp group to display the Property Palette.

  9. Change the Name property to G_emco.

  10. Rearrange your data model to look similar to the following figure:

  1. Click in the tool palette.

     

    1. For online help on this task, choose Help->Report Builder Help Topics

    2. On the Index page, type...
      matrix group, creating

    3. Then click Display to view help topic...
      Creating a matrix (crosstab) group

     

  2. Drag a rectangle around groups G_emco, G_xact, and G_funds.

  3. Double-click the newly created group, G_1, to display the Property Palette.

  4. Change the Name property to G_matrix.

  5. Click to create a column-to-column link.

     

    1. For online help on this task, choose Help->Report Builder Help Topics

    2. On the Index page, type...
      data link, creating

    3. Then click Display to view help topic...
      Creating a data link

     

  6. Click column ssn in group G_acct and drag to column ssn1 in group G_dist. (This retrieves the percent distribution of investment fund elections.)

  7. Repeating steps 15 and 16, create data links between:
    Table 5-3 Data links to create in the data model

    column ssn in group G_acct, and 

    column ssn2 in group G_xact (to retrieve the contribution category and description of income for each category) 

    column empcomp in group G_emco, and 

    column empcomp1 in group G_amount 

    column ssn2 in group G_xact, and 

    column ssn3 in group G_amount 

    column fund_id1 in group G_funds, and 

    column fund_id2 in group G_amount (to retrieve for each income description in each contribution category in each fund, the account balance) 

    column type in group G_xact, and 

    column trans_type in group G_amount (to retrieve for each income description, a distinct amount) 

    Your data model should now look similar to the following figure:

  1. Click .

     

    1. For online help on this task, choose Help->Report Builder Help Topics

    2. On the Index page, type...
      totals, creating for column

    3. Then click Display to view help topic...
      Creating a summary column

     

  2. Click on the title bar of group G_matrix.

    In the following steps, you will set this new summary column to calculate totals on each income description in each contribution category (row totals).

  3. Double-click the newly created column, CS_1 to display the Property Palette.

  4. In the Property Palette under the General Information node, set the Name property to CS_xactotal.

  5. Under the Column node, set the Width property to 38, the Product Order property to G_emco G_xact, and the Value if Null property to 0.00.

    Tip: The values for the Product Order property can get quite long. To make these values easier to see, resize the Property Palette horizontally.

    For more information on the meaning of these properties, click while the property is selected.

  6. Under the Summary node, set the Source property to amount and the Reset At property to G_xact.

  7. Repeating steps 18 through 23, create summary columns in group G_matrix with the following characteristics
    Table 5-4 Total properties
    Name  Width  Product Order  Value if Null  Source  Reset At 

    CS_fundsubtotal 

    38 

    G_funds G_emco 

    0.00 

    amount 

    G_emco 

    CS_emcototal 

    38 

    G_emco 

    0.00 

    amount 

    G_emco 

    CS_fundtotal 

    38 

    G_funds 

    0.00 

    amount 

    G_funds 

    :

    • CS_fundsubtotal calculates totals on each income fund in each contribution category (column totals).

    • CS_emcototal calculates grand totals on each contribution category.

    • CS_fundtotal calculates grand totals on each fund in all contribution categories.

  8. Repeating steps 18 through 23, create a summary column in group G_acct with the following characteristics:
    Table 5-5 Total properties
    Name  Width  Value if Null  Source  Reset At 

    CS_grandtotal 

    38 

    0.00 

    CS_fundtotal 

    G_acct 

    • CS_grandtotal calculates grand totals on each fund in all contribution categories.

  9. You may want to rearrange the objects inside of group G_matrix to make the summary columns more easily visible.

  10. Save your report as sect_512.rdf.

Your data model should now look similar to the following figure:

5.2 Designing a Runtime Parameter Form

The steps in this section will help you design a Runtime Parameter Form so that you can run your report regularly as you make refinements.

In Section 5.1.1, "Building queries using the Data Wizard", you created a query with the bind parameter p_pct_vested. Whenever you run a report with a bind parameter, the default Runtime Parameter Form appears. You must assign a value to the bind parameter in order to run your report.

You can use the default Parameter Form to enter a value, or you can build your own Parameter Form using the Parameter Form view.

 

  1. For online help on this task, choose Help->Report Builder Help Topics

  2. On the Index page, type...
    Parameter Form view, overview

  3. Then click Display to view help topic...
    Parameter Form view

 

  1. Choose Tools->Parameter Form Builder.

  2. In the Parameter Form Builder, click the following parameters if they are not already selected:

    • DESTYPE

    • DESNAME

    • DESFORMAT

    • P_PCT_VESTED

  3. Click OK to create a parameter form in the Parameter Form view.

  4. Click once to select the P pct vested label, then click it again to enter edit mode. (Double-clicking will display the Property Palette.)

  5. Select the text, and replace it with % Vested.

  6. Double-click PF_P_PCT_VESTED to display the Property Palette.

  7. Under the Parameter node, set the Initial Value property to 100.

  8. Click in the List of Values property field to display the Parameter List of Values dialog box.

  9. If it is not already selected, click Static Values.

  10. Type 0 in the Value field, then click Add.

  11. Repeat step 10 to add the following values:

      10

      25

      50

      75

      100

  12. Click OK to close this dialog box.

  13. Close the Parameter Form view. You will have an opportunity to use the Run-time Parameter Form in a later step.

  14. Save the report as sect_520.rdf.

5.3 Creating a layout for the first section

The steps in this section will help you to create a layout for a detailed section by using the Report Wizard to create a default layout. The Report Wizard by default builds a report layout in the main section of the report.

 

  1. For online help on this task, choose Help->Report Builder Help Topics

  2. On the Index page, type...
    default layout, creating

  3. Then click Display to view help topic...
    Creating a default layout for a report

 

  1. Choose Tools->Report Wizard.

  2. On the Style page, click Matrix with Group.

  3. Click Next.

  4. On the Groups page, select the following groups from the Available Fields list box:

    • click G_matrix, then click Matrix

    • click G_emco, then click Down

  5. Click G_dist (Down) in the Displayed Group list box.

  1. Click . The Groups page should look like the one in the following figure:

  1. Click Next.

  2. On the Fields page, click lastname, then click . Repeat this step to add the following fields to the Displayed Fields list:

    • firstname

    • mi

    • ssn

    • pct_deferral

    • pct_vested

    • description

    • emconame

    • name1

    • amount

    • CS_xactotal

    • CS_fundsubtotal

    • CS_emcototal

    • CS_fundtotal

    • CS_grandtotal

  3. Click Next.

  4. On the Labels page, delete the labels for all of the columns listed, then rename the following columns:
    Table 5-6 Labels
    Column  Label 

    ssn 

    SSN: 

    pct_deferral 

    Deferral Percentage: 

    pct_vested 

    Vested Percentage: 

    CS_grandtotal 

    Total Balance 

  5. Change the widths of the following columns:
    Table 5-7 Widths
    Column  Width 

    pct_deferral 

    pct_vested 

    description 

    emconame 

    name1 

    amount 

    CS_xactotal 

    CS_fundsubtotal 

    CS_emcototal 

    CS_fundtotal 

    CS_grandtotal 

  6. Click Next.

  7. On the Template page, select the Predefined template Cyan Grid.

  8. Click Finish.

  9. In the Runtime Parameter Form, select 100 from the % Vested list box. Notice the Destination type, Destination name, and Destination format fields. You can choose another output type, such as printer, or change the format. For this exercise, however, you will use the default values.

  10. Click to review your report in the Live Previewer. Your report will look similar to the following figure:

  11. Close the Live Previewer.

  12. Save your report as sect_530.rdf.

5.4 Refining the layout in the Layout Model view

The steps in this section will help you to refine the layout of your report using the Layout Model view. You will make extensive changes to your layout by doing the following:

When you finish this section, the layout will look similar to the following figure. Use this layout to help guide you through this exercise.

Tip: If you re-enter the Report Wizard after making manual refinements in the Live Previewer, you will lose some of your changes when you click Apply or Finish in the wizard, and your layout will default back to the state defined by the wizard.

5.4.1 Changing the properties of objects

  1. In the Object Navigator, double-click the Layout Model node to display the Layout Model view of your report.

  2. In the Layout Model view, double-click F_lastname to display the Property Palette.

  3. Under the General Layout node, change the Horizontal Elasticity property to Variable. Repeat this step for the following objects:

    • F_firstname

    • F_mi

    Tip: You can change several objects at one time: shift-click on all objects, then choose Tools->Property Palette.

  4. Click in an empty area of the canvas to deselect the objects.

  5. Shift-click the following objects:

    • F_lastname

    • F_firstname

    • F_mi

    • SSN:

    • F_ssn

    • Deferral Percentage:

    • F_pct_deferral

    • Vested Percentage:

    • F_pct_vest

  6. In the toolbar, select 12 from the font size list box to change the font size of the selected objects.

  7. Click in an empty area of the canvas.

  8. Shift-click the following objects, then choose Tools->Property Palette:

    • F_pct_deferral

    • F_pct_vest

  9. In the Property Palette under the Field node, type NNNN% (case sensitive) in the Format Mask to display the objects as a percentage.

  10. Click in an empty area of the canvas.

  11. Shift-click the following layout objects:

    • F_amount

    • F_CS_fundsubtotal

    • F_CS_fundtotal

    • F_CS_xactotal

    • F_CS_emcototal

    • F_CS_grandtotal

  1. Click .

  1. Click twice.

  1. Click .

  2. Click F_description, then click .

  3. Save the report as sect_541.rdf.

  1. Click .

  2. At the Runtime Parameter Form, click to view the changes in the Live Previewer.

5.4.2 Re-arranging frames and objects

  1. In the Object Navigator, double-click to display the Layout Model view of your report.

    Tip: Every object in the Layout Model view is also represented in the Object Navigator. Sometimes it is easier to refine the layout of a report by selecting objects from the Object Navigator. Arrange your workspace to display the Object Navigator and Layout Model view side-by-side. When you click an object in the Object Navigator, this object is selected in the Layout Model view.

  2. In the Object Navigator, expand the Layout Model, Main Section, Body, and M_G_ACCT_GRPFR nodes if they are not already expanded.

  3. Ctrl-click M_G_ACCT_GRPFR and R_G_ACCT.

  4. In the Layout Model view, using the vertical ruler as a guide, lengthen the M_G_ACCT_GRPFR and R_G_ACCT groups until the bottom of the frames reach 3 inches.

    Tip: M_G_ACCT_GRPFR is the underlying master group. It is under R_G_ACCT. In the Layout Model view, it may look like only one group is selected when, in fact, both frames are selected.

  5. In the Object Navigator, type M_G_MATRIX_GRPFR in the Find field to locate this object. Note that the search occurs as you type, so you will most likely be taken to the object before you finish typing the entire name.

    The M_G_MATRIX_GRPFR frame in the Layout Model view looks similar to the following figure:

  6. In the Layout Model view using the vertical rule as a guide, lengthen the M_G_MATRIX_GRPFR frame until the bottom of the frame reaches 3 inches.

  7. In the Object Navigator, type R_G_FUNDS in the Find field.

    The R_G_FUNDS frame in the Layout Model view looks similar to the following figure:

  8. In the Layout Model view, lengthen the R_G_FUNDS frame until the bottom of the frame reaches its parent (enclosing) frame.

    Tip: If you are unable resize the frame as expected, you may need to toggle Confine Mode off.

    indicates that Confine Mode is on. indicates that Confine Mode off.

  9. Shift-click F_CS_fundtotal and F_CS_grandtotal. Move these objects down until they reach their parent frame.

  10. In the Object Navigator under the Dimension Repeating Frame node, click R_G_EMCO.

    The R_G_EMCO repeating frame in the Layout Model view looks similar to the following figure:

  11. In the Layout Model view, lengthen the R_G_EMCO repeating frame until it reaches the top of the F_CS_fundtotal and F_CS_grandtotal frames.

    The result will look similar to the following figure:

  12. Arrange the following frames end-to-end to look like the figure that follows:

    • F_lastname

    • F_firstname

    • F_mi

  13. Click and then again at the Runtime Parameter Form.

  14. Save your report as sect_542.rdf.

5.4.3 Adding boilerplate objects

 

  1. For online help on this task, choose Help->Report Builder Help Topics

  2. On the Index page, type...
    boilerplate, about

  3. Then click Display to view help topic...
    About boilerplate objects

 

  1. Display the Layout Model view of your report.

  1. Click to create a boilerplate object. Then click in the area directly below F_description.

  2. Type Subtotal:

  3. Click .

  4. Change the following, if necessary:

    • Font to Arial using the Font list box in the toolbar

    • Point size to 10

    • Font style to bold. Click .

  1. If necessary, arrange the boilerplate object so that it is placed next to F_CS_Fundsubtotal. The result will look similar to the following figure:

  1. Repeat steps 2 through 6 to create the following boilerplate objects with the specified characteristics:
    Table 5-8 Boilerplate objects
    Boilerplate  Location  Text Color 

    Grand Total: 

    right of F_CS_fundtotal 

    Yellow 

    Total Funds 

    Above F_CS_xactotal 

    Yellow 

  2. Click and then again at the Runtime Parameter Form. Your report will look similar to the following figure.

  3. Scroll to the right of the report, then click .

    Notice that report is not wide enough to display all the columns on a single page and wraps to the second page. Later, in Section 5.6, "Specifying landscape orientation and page break", you will change the orientation of this layout to landscape and insert a page break. This will allow the report to display one record per page. Before you change the orientation, however, you will create a layout for the second section using the Report Wizard.

  4. Save the report as sect_543.rdf.

5.5 Creating a layout for the second section

The steps in this section will help you to create a layout for a summary in the header section of your report. You will use the Report Wizard to create a default layout. Then you will make manual refinements in the Layout Model view and Live Previewer.

5.5.1 Creating the default layout

  1. Display the Layout Model view of your report.

  2. Choose View->Layout Section->Header Section.

  3. Ensure that the Body of the report is displayed.

  4. Choose Tools->Report Wizard.

  5. On the Style page, type Vesting Summary in the Title field, and click Tabular.

  6. Click Next.

  7. On the Groups page, click G_acct from the Available Fields list box, then click Down.

  8. Click Next.

  9. On the Fields page, click lastname, then click . Repeat this step for the following fields:

    • firstname

    • mi

    • ssn

    • pct_vested

    • CS_grandtotal

  10. Click Next.

  11. On the Labels page, change labels and widths as follows:
    Table 5-9 Labels and Widths
    Column  Label  Width 

    lastname 

    Last Name 

    firstname 

    First Name 

    mi 

    MI 

    ssn 

    SSN 

    pct_vested 

    Vested Percentage 

    CS_grandtotal 

    Total Balance 

  12. Click Next.

  13. On the Template page, click the Predefined template Confidential Background.

  14. Click Finish.

  15. Click and then again at the Runtime Parameter Form.

  16. If necessary click to display the Vesting Summary report. Your report will look similar to the following figure:

  17. Save your report as sect_551.rdf.

5.5.2 Refining the layout in the Live Previewer

  1. In Live Previewer, shift-click the following objects, then click :

    • Last Name

    • First Name

    • MI

    • SSN

    • Vested Percentage

    • Total Balance

  2. Ensure that Flex Mode is on.

  1. Click the lower-right corner of the selected objects and drag the lower edge of the frame down about 0.25 inches. Notice that the space between the rows increases. See the before and after figures that follow:

    Report before increasing the row spacing:

    Report after increasing the row spacing:

  2. Arrange your workspace so that the Object Navigator and Live Previewer are displayed side-by-side.

  3. In the Object Navigator, type R_G_ACCT1 in the Find field.

  4. Click the title bar in the Live Previewer to make it active.

  5. Choose Format->Border and choose Top to toggle off the top border. A checkmark next to an option indicates that it is toggled on.

  6. Repeat step 7 for Left and Right. The bottom border will remain toggled on.

  1. Click , then choose red. This will place a red line between the rows of data. Your report will similar to the following figure:

  2. Save the report as sect_552.rdf.

5.6 Specifying landscape orientation and page break

The steps in this section will help you change the orientation of the layout you created in the Main section.

Tip: If you create multiple layouts using the Report Wizard and plan on changing the orientation setting, it is good practice to change the orientation after building all of your layouts. If you change the orientation of first layout, then build a second layout using the Report Wizard, the orientation of the first layout will revert back to the orientation settings defined in the template.

  1. In the Object Navigator, if necessary, expand the Layout Model node, then click the Main Section node and choose Tools->Property Palette.

  2. In the Property Palette under the Section node, make the following changes:
    Table 5-10 Property settings for the Section node
    Property  Setting 

    Width 

    11 

    Height 

    8.5 

    Orientation 

    Landscape 

  3. Display the Layout Model view of your report.

  4. Click to display the Main section,

  5. In the Layout Model view, click in the toolbar to expose the Margin of your report.

  1. Scroll down to the bottom of the layout, and click the border between the Body and the lower Margin.

  2. Using the vertical ruler as a guide, resize the area by dragging the border up to the 7.5 inch mark.

    Tip: Be sure that you are re-sizing the Margin, not moving the Margin.

  1. Click to expose the Body of your report.

  2. In the Layout Model view, click the lastname field.

  1. Click to select the parent frame.

  2. Choose Tools->Property Palette.

  3. Under the Repeating Frame node, set the Maximum Records per Page property to 1.

  4. Click and then again in the Runtime Parameter Form.

  5. Click in the toolbar to display the layout that you created in a previous section.

    Scroll to the right of the report. Notice the orientation of the report has changed. The report can display all the columns on a single page. Notice also that only one record per page is displayed.

  6. Save your report as sect_560.rdf.

5.7 Specifying distribution

The steps in this section will help you to specify the distribution for the two sections that you have created:

You will distribute your report as follows:

5.7.1 Specifying distribution for the detailed section

  1. In the Object Navigator, type Main Section in the Find field.

  2. Choose Tools->Property Palette.

  3. Click the Distribution value field to display the Distribution dialog box. Specify two distribution output destinations for the report that summarizes account information for employees.

  4. In the Distribution dialog box, specify the distribution for printing the report:
    Table 5-11 Distribution settings for the printed Main section
    Field  Value 

    Distribution ID 

    printdist 

    DESNAME 

    printer path and name 

    DESFORMAT 

    BITMAP 

    DESTYPE 

    Printer 

    COPIES 

    Tip: If you select Printer as the DESTYPE first, the DESNAME is automatically set to your default printer.Change this value if you want to send this report to another printer.

  5. Click New.

  6. In the Distribution dialog box, define the distribution for HTML output:
    Table 5-12 Distribution settings for the HTML version of the Main section
    Field  Value 

    Distribution ID 

    htmldist 

    DESNAME 

    path and file name for the HTML output (e.g., c:\sect_rep.htm

    DESFORMAT 

    HTML 

    DESTYPE 

    File 

    COPIES 

  7. Click OK.

  8. Save your report as sect_571.rdf.

5.7.2 Specifying distribution for the summary section

  1. In the Object Navigator, click the Header Section node.

  2. Choose Tools->Property Palette.

  3. In the Property Palette, under the Section node, click in the Distribution value field to display the Distribution dialog box.

  4. In the Distribution dialog box, define the distribution for sending the summary section to PDF:
    Table 5-13 Distribution settings for the PDF version of the Header section
    Field  Value 

    Distribution ID 

    pdfdist 

    DESNAME 

    path and pdf file name (e.g., c:\sect_rep.pdf) 

    DESFORMAT 

    PDF 

    DESTYPE 

    File 

    COPIES 

  5. Save your report as sect_572.rdf.

Optional Exercise:

Try setting up distribution to e-mail the executive summary. You will need a MAPI-compliant mail application set up on your system.

5.7.3 Distributing the report

  1. In the Object Navigator, click your report name, then choose File->Distribute.

  2. In the Runtime Parameter Form, click .

  3. In the dialog box that prompts for your confirmation to distribute to multiple destinations, click Continue.

  4. Check the printer, your file system, and (optionally) your e-mail inbox to verify that your report was distributed as expected.

Optional Exercise:

Try setting up distribution by creating a .DSTfile and running the distribution from the command line.

Tip: You can trace report distribution. The trace file, which is similar to a .DST file, is generated when you check the Distribution check box in the Runtime Trace Settings dialog box.

5.8 Summary

Congratulations! You have finished the Sectioning sample report. You now know how to:

For more information about sectioning and distribution, see the online help:

 

  1. For online help on this topic, choose Help->Report Builder Help Topics

  2. On the Index page, type...
    sectioning, about

  3. Then click Display to view help topic...
    About report sectioning

 


Prev Next
Oracle
Copyright © 1999 Oracle Corporation.

All Rights Reserved.

Contents

Index